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Preface

This manual provides an introduction to NetCOBOL. NetCOBOL provides a full-featured development environment for COBOL
programs. It allows you to develop COBOL programs that also easily integrate with other languages.

The sample programs shipped with NetCOBOL are intended to give an overview of the capabilities of NetCOBOL. Refer to the
"NetCOBOL User's Guide™ for further details on using NetCOBOL.

Audience
Prior to using NetCOBOL, it is assumed that you have the following knowledge:
- You have some basic understanding as to how to navigate through and use the Microsoft Windows product on your machine.
- You understand the COBOL language from a development perspective.

- Ifyou plan on using Microsoft's Visual Basic development environment, you have spent some time using Visual Basic to get a feel for
its interface and capabilities.

Abbreviations

The following abbreviations are used in this manual:

Product Name Abbreviation

Microsoft(R) Windows Server(R) 2016 Datacenter Windows Server 2016
Microsoft(R) Windows Server(R) 2016 Standard

Microsoft(R) Windows Server(R) 2016 Essentials
Microsoft(R) Windows Server(R) 2012 R2 Datacenter Windows Server 2012 R2

Microsoft(R) Windows Server(R) 2012 R2 Standard
Microsoft(R) Windows Server(R) 2012 R2 Essentials
Microsoft(R) Windows Server(R) 2012 R2 Foundation

Microsoft(R) Windows Server(R) 2012 Datacenter Windows Server 2012
Microsoft(R) Windows Server(R) 2012 Standard
Microsoft(R) Windows Server(R) 2012 Essentials
Microsoft(R) Windows Server(R) 2012 Foundation
Microsoft(R) Windows Server(R) 2008 R2 Standard Windows Server 2008 R2

Microsoft(R) Windows Server(R) 2008 R2 Enterprise
Microsoft(R) Windows Server(R) 2008 R2 Foundation
Microsoft(R) Windows Server(R) 2008 R2 Datacenter

Windows(R) 10 Education Windows 10(x64)
Windows(R) 10 Home
Windows(R)10 Pro
Windows(R) 10 Enterprise
Windows(R) 8.1 Windows 8.1(x64)

Windows(R) 8.1 Pro
Windows(R) 8.1 Enterprise

Windows(R) 7 Home Premium Windows 7(x64)

Windows(R) 7 Professional

Windows(R) 7 Enterprise



Product Name Abbreviation
Windows(R) 7 Ultimate
Oracle Solaris Solaris
Red Hat(R) Enterprise Linux(R) 5(for Intel Itanium) Linux(Itanium)
Red Hat(R) Enterprise Linux(R) 5(for Intel64) 64bit Linux(64)
Microsoft(R) Visual C++(R) development system Visual C++
Microsoft(R) Visual Basic(R) programming system Visual Basic

In this manual, when all the following products are indicates, it is written as "Windows(x64)" or "Windows".

Windows Server 2016
Windows Server 2012 R2
Windows Server 2012
Windows Server 2008 R2
Windows 10(x64)
Windows 8.1(x64)
Windows 7(x64)

Trademarks

NetCOBOL isatrademark or registered trademark of Fujitsu Limited or its subsidiaries in the United States or other countries or in both.

Microsoft, Windows, Windows Server, Visual Basic, and Visual Studio are either registered trademarks or trademarks of Microsoft
Corporation in the United States and/or other countries.

Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of their respective owners.
Oracle Solaris is also referred as Solaris, Solaris Operating System, or Solaris OS.

Other brand and product names are trademarks or registered trademarks of their respective owners.

Export Regulation

Exportation/release of this document may require necessary procedures in accordance with the regulations of your resident country and/or
US export control laws.

The contents of this manual may be revised without prior notice. No part of this document may be reproduced or transmitted in any form
or by any means, electronic or mechanical, for any purpose, without the express written permission of Fujitsu Limited.
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IChapter 1 Sample Programs

The sample programs shipped with NetCOBOL are intended to give an overview of the capabilities of NetCOBOL. Refer to the
"NetCOBOL User's Guide" for further details on using NetCOBOL. The following table details the sample programs available with
NetCOBOL.

NetCOBOL Sample Programs

- Sample 1
Data Processing Using Standard Input-Output

- Sample 2
Using Line Sequential and Indexed Files

- Sample 4
Screen Input-Output Using the Screen Section

- Sample 5
Calling COBOL Subprograms

- Sample 6
Receiving a Command Line Argument

- Sample 7
Environment Variable Handling

- Sample 8
Using a Print File

- Sample 9
Using a Print File (Advanced usage)

- Sample 11
Remote database access

- Sample 12
Remote database access (multiple row processing)

- Sample 13
Calling COBOL from Visual Basic

- Sample 14
Visual Basic calling COBOL -Simple ATM Example

- Sample 15
Basic Object-Oriented Programming

- Sample 16
Collection Class (Class Library)

- Sample 31
Windows System Function Call

- Sample 32
Starting other programs

Each sample explains the following two methods as a way of operating the exercise program.
- Using NetCOBOL Studio
- Using MAKE file



Qn Note

- When you execute the Sample program by using NetCOBOL Studio, see "1.1 Advance preparation for using NetCOBOL Studio to
execute a sample program”.

- When you use MAKE file, use the NetCOBOL command prompt. On Start, select Fujitsu NetCOBOL V12(x64) > NetCOBOL
Command Prompt.

1.1 Advance preparation for using NetCOBOL Studio to execute a
sample program

1.1.1 The basic concept of NetCOBOL Studio

Read through "NetCOBOL Studio" in the "NetCOBOL Studio User's Guide" to understand the necessary basic concepts (workspace,
perspective, etc.) for using NetCOBOL Studio.

Moreover, NetCOBOL Studio screen is composed of a window for the editor area and two or more information displays. Refer to "COBOL
perspective", "Editor" or "Debugging perspective" in the "NetCOBOL Studio User's Guide" for an explanation of each window.

Automatic build

Automatic build is turned on by default. It can be toggled off or on by selecting™ Project” > "Build Automatically” from the NetCOBOL
Studio menu bar. When it is checked, it is turned on. Refer to "Automatic build" in the "NetCOBOL Studio User's Guide" for details on
automatic build.

Project folder

The project property is stored in a folder. It is saved in the workspace and when the project is imported, the project folder is created under
the workspace folder.

Example: The project folder for SAMPLEO1 with a workspace folder of C:\NetCOBOL Studio\workspace:

C:\NetCOBOL Studio\workspace\SAMPLEO1

1.1.2 Advance preparation for using sample

Itis necessary to make the project for the sample program in the folder that is called workspace, and then to build, execute, and debug it using
NetCOBOL Studio.

The steps in order are:
1. Prepare the workspace.

2. Import the sample program project into the NetCOBOL Studio workspace.

Preparing the workspace
A "Workspace" is a folder that stores the various resources of the NetCOBOL Studio project.
About making a workspace, see "A.2 Setting and switch method of workspace" for details.

The workspace for this manual is C:\NetCOBOL Studio\workspace.

Importing sample program project into NetCOBOL Studio workspace

The provided sample program projects are imported to the NetCOBOL Studio workspace with the following procedure.

Qn Note

The following steps use "C:\COBOL" as the NetCOBOL Installation folder. Change "C:\COBOL" to the NetCOBOL installation folder.



. Click the Start button, and then, on the Start menu, select Fujitsu NetCOBOL V12(x64) > NetCOBOL Studio(x64). NetCOBOL
Studio is started.

. On the File menu, click Import.... The Import Wizard is started.

. Select General > EXxisting Projects into Workspace, and click Next.

ﬁ Import O pd
Select “;.1
Create new projects from an archive file or directory. E 5 I

Select an import wizard:

type filter text

w (7= General
B Archive File
2> Existing Projects into Workspace
[} File System
[C] Preferences
[} Projects from Folder or Archive
= CV5
v = Install
(£ Run/Debug
(= Team

[;3'}. < Back Einish Cancel

. Click Select root directory, and click Browse.... The Browse For Folder dialog box appears.

. Select the folder including the project that is the storage location for the COBOL sample program (Here, C:\COBOL\Samples
\COBOL), and then click OK.

. In the Projects pane, confirm the project for the COBOL sample program is displayed, and the click Select All.

. Select Copy projects into workspace, and click Finish.

The projects for the sample programs are imported to the NetCOBOL Studio workspace.



If the Dependency view below is not displayed, on the Window menu, click Show View > Dependency.

E workspace - COBOL - MetCOBOL Studialxbd) - O b4
Eile Edit Mawgate Search  Project Bun Windew Help
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1.1.3 Notes on using the sample programs

For each sample program, the NetCOBOL Studio project associated files below are provided.

Please do not edit these project associated files. The application does not run correctly when these files are changed.
- .Settings\org.eclipse.core.resources.prefs
- .CobolOptions

- .project

1.2 Sample 1. Data Processing Using Standard Input-Output

Sample 1 demonstrates using the ACCEPT/DISPLAY function to input and output data. Refer to the "NetCOBOL User's Guide" for details
on how to use the ACCEPT/DISPLAY statements.

Function
Inputs an alphabetic character (lowercase character) from the console window, and outputs a word to the console window beginning with
the input alphabetic character.
Files Included in Sample 1
- SAMPLE1.COB (COBOL source program)
- MAKEFILE
- COBOLS85.CBR

COBOL Statements Used
ACCEPT, DISPLAY, EXIT, IF, and PERFORM statements are used.



1.2.1 Using NetCOBOL Studio

Compiling and Linking the Program
1. NetCOBOL Studio is started by specifying the workspace created for the sample program. See "Preparing the workspace".
2. In the Dependency view, select the SAMPLEOL1 project.

If there is no SAMPLEDOQ1 project, import the SAMPLEOQ1 project into the NetCOBOL Studio workspace. See "Importing sample
program project into NetCOBOL Studio workspace".

3. The structure of the project is as follows.

D BT ORL = B

| E
v 2 SAMPLEOT -
v (Bl Source Files
Eii] 5amplel.cob
@2 Linking Files
w (2L Other Files
= .settings
= build.xml
COBOLA5.CER
= Makefile
[5=] SAMPLET.exe
=| Samplel.OB)
SAMPLET pdb
Samplel.5VD W

1

The build is executed immediately after importing the project when an automatic build is set. In this case, the file (. EXE . OBJ etc.)
is generated after the build is displayed in "Other Files". It is set to automatic build by default.

4. On the Project menu, click Build Project when SAMPLEL.EXE is not created in "Other Files" (When an automatic build is not
executed), click Build Project On the Project menu.

The project is built, and then SAMPLEL.EXE is created.

Debugging

Referto "Creatinga COBOL Program" in Chapter 2 of the "NetCOBOL Studio User's Guide™ for the SAMPLE1 debugging procedure using
the debugging facility of NetCOBOL Studio.

Program execution
In the Dependency view, select the SAMPLEO1 project. On the Run menu, click Run As > COBOL Application.

When one alphanumerical character is entered, the first word with that character is displayed.

1.2.2 Using the COBOL command and the LINK command

Compiling and Linking the Program

Open a command prompt. Compile and link the sample program using the following command.

C:\COBOL\Samples\COBOL\Sample01>COBOL.EXE -M SAMPLE1.COB
C:\COBOL\Samples\COBOL\SampleO1>LINK /0UT:SAMPLE1.EXE SAMPLE1.0BJ F4AGCIMP.LIB MSVCRT.LIB




1.2.3 Using the MAKE command

The sample program can also be compiled and linked using the nmake command.

C:\COBOL\Samples\COBOL\SampleO1>nmake

Compilation of the sample program is now complete. Verify that SAMPLEL.EXE was created in the same folder in which the sample
program is stored.

Executing the Program
In the command prompt or from Windows Explorer, execute SAMPLE1.EXE

Enter a lowercase letter and then press the ENTER key. A word that begins with the input lowercase letter is displayed.

1.3 Sample 2: Using Line Sequential and Indexed Files

Sample 2 demonstrates a program that reads a data file (line sequential file) created with the Editor, and then creates a master file (indexed
file). For details on how to use line sequential files and indexed files, refer to the "NetCOBOL User's Guide".

Overview

Reads a data file (line sequential file) that contains product codes, product names, and unit prices, and creates an indexed file with the
product code as a primary record key and the product name as an alternate record key.

Figure 1.1 Creating an indexed file from a line sequential file

Line sequential file Index file
0123 SCARE 0200 <] 0123 SCARE 0200
0456 BALLPEN | 0100 < ‘::> 0456 BALL-PEN | 0100
<]
Ay I A% N ;i—_/\f/ v | ¥ IS W P
4 alphanumeric 4 digit number 4 alphanumeric 4 digit number
characters [External decimal] characters [Binary]
i {Primary record key)

40 alphanumeric 40 alphanumeric
characters characters
| <] : Line feed code ‘ (Alternate record key)

Files Included in Sample 2

SAMPLE2.COB (COBOL source program)

DATAFILE (Data file)

MAKEFILE

COBOLS85.CBR

COBOL Statements Used
The CLOSE, EXIT, GO TO, MOVE, OPEN, READ, and WRITE statements are used.



1.3.1 Using NetCOBOL Studio

Compiling and Linking the Program
1. NetCOBOL Studio is started by specifying the workspace created for the sample program. See "Preparing the workspace".

2. In the Dependency view, select the SAMPLEO2 project.

If there is no SAMPLEOQ2 project, import the SAMPLEO2 project into the NetCOBOL Studio workspace. See "Importing sample
program project into NetCOBOL Studio workspace".

3. The structure of the project is as follows.

%D 2|ESs TN = O

8%

v = SAMPLED2 A
v (Bl Source Files
E@ Sampled.cob
@2 Linking Files
v (L Other Files
[= .settings
= buildxml
COBOL85.CER
Datafile
Makefile
[m=] SAMPLE2.exe
Sample2. OBJ
SAMPLE2. pdb
Sampled.5VD W

The build is executed immediately after importing the project when an automatic build is set. In this case, the file (. EXE . OBJ etc.)
is generated after the build is displayed in "Other Files". It is set to automatic build by default.

4. On the Project menu, click Build Project when SAMPLE2.EXE is not created in "Other Files" (When an automatic build is not
executed).

The project is built, and then SAMPLE2.EXE is created.



Setting Runtime Environment Information

1. Start Run-time Environment Setup Tool. The Run-time Environment Setup Tool dialog appears.

B4 Run-time Environment Setup Tool — >

File Envircnment Help

File Marme
C:\MetCOBOL Studio'work zpacesSAMPLE02ACOBOLES. CER

Thread Mode
(®) Single Thread () Multi Thread

E nvironment Y ariables

Sechion; Comman  Section

IMFILE=DATAFILE
OUTFILE= MASTER

Wariable M ame:
[ v

Wariable W alue:

| | < >

Set Delete Lpply

2. On the File menu, click Open. The Select Runtime Initialization file dialog box appears.

3. Select COBOLS85.CBR in the folder that contains the executable program (SAMPLE2.EXE).

4. On the Common tab, enter data as shown below:
- For the file-identifier INFILE, specify the name of the data file (line sequential file) in DATAFILE.
- For the file-identifier OUTFILE, specify the name of master file (indexed file) in MASTER.

INFILE=_\DATAFILE
OUTFILE=.\MASTER

If MASTER is specified for OUTFILE, input the data and click Set.
5. Click Apply. The data is saved in the object initialization file.

6. On the File menu, click Exit to terminate the run-time environment setup tool.

;ﬂ Information

INFILE and OUTFILE are the file reference identifiers specified for ASSIGN clauses in COBOL programs. The file reference identifier
is used to associate a COBOL program and an actual file.

Program execution

1. Inthe Dependency view, select SAMPLEOQ2 project.



2. On the Run menu, click Run As > COBOL Application.

Execution result
No termination message is displayed.

After execution is complete, an indexed file (MASTER) with a product code as a key is created in the SAMPLEO2 directory. Use Windows
Explorer or File Manager to verify that the indexed file was created.

Use the COBOL File Utility to confirm that the indexed file (MASTER) was created correctly. The indexed file record can be browsed using
the COBOL File Utility Browsing Records function. Refer to "COBOL File Utility" in the "NetCOBOL User's Guide" for details.

1.3.2 Using MAKE file

Compiling and Linking the Program

Open a command prompt. Compile and link the sample program using the following command.

C:\COBOL\Samples\COBOL\Sample02>nmake

Compilation of the sample program is now complete. Verify that SAMPLE2.EXE was created in the same folder in which the sample
program is stored.

Setting Runtime Environment Information
Same as "1.3.1 Using NetCOBOL Studio.

Executing the Program
In the command prompt or from Windows Explorer, execute SAMPLE2.EXE

Execution result
Same as "1.3.1 Using NetCOBOL Studio™.

1.4 Sample 4. Screen Input-Output Using the Screen Section

Sample 4 demonstrates using the Screen Section (the "screen handling function") to display and accept data. Refer to the "NetCOBOL User's
Guide" for details on how to use the screen handling function.

Overview

When an employee's number and name are written to the screen, the program creates an indexed file with the employee's number as a
primary record key, and the name as an alternate record key.

Files Included in Sample 4
- SAMPLE4.COB (COBOL source program)
MAKEFILE

SAMPLE4.KBD (Key definition file)
COBOLS85.CBR

COBOL Statements Used
The ACCEPT, CLOSE, DISPLAY, EXIT, GO TO, IF, MOVE, OPEN, and WRITE statements are used.

1.4.1 Using NetCOBOL Studio




Compiling and Linking the Program
1. NetCOBOL Studio is started by specifying the workspace created for the sample program. See "Preparing the workspace".
2. In the Dependency view, select the SAMPLEO4 project.

If there is no SAMPLEOQ4 project, import the SAMPLEO4 project into the NetCOBOL Studio workspace. See "Importing sample
program project into NetCOBOL Studio workspace".

3. The structure of the project is as follows.

XD EE|EES WM = B
B%
v 22 SAMPLEDY A
v (Bl Source Files
Fii Sampled.cob
@2 Linking Files
~ (L Other Files
[= .settings
2 buildxml
COBOLA5.CBR
= Makefile
[m=] SAMPLES. exe
Sampled.kbd
Sampled. OB)
SAMPLE4.pdb
Sampled.5VD W

The build is executed immediately after importing the project when an automatic build is set. In this case, the file (. EXE . OBJ etc.)
is generated after the build is displayed in "Other Files". It is set to automatic build by default.

4. On the Project menu, click Build Project when SAMPLE4.EXE is not created in "Other Files" (When an automatic build is not
executed).

The project is built, and then SAMPLE4.EXE is created.
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Setting Runtime Environment Information

1. Start Run-time Environment Setup Tool. The Run-time Environment Setup Tool dialog appears.

B¢ Run-time Environment Setup Tool — >

File Envircnment Help

File Mame
C:\MetCOBOL Studic'wark zpacesSAMPLE 044COBOLES. CER

Thread Mode
(®) Single Thread i) Multi Thread

E nvironment Y ariables

Sechion; Common  Section

@CBR_SCAR_KEYDEFFILE=A5ampled.kbd
OUTFILE=*MASTER

Y ariable M ame:

Wariable W alue:

| | < >

Set Delete Apply

2. On the File menu, click Open. The Select Runtime Initialization file dialog box appears
3. Select COBOLS85.CBR in the folder that contains the executable program (SAMPLE4.EXE).
4. Select the Common tab and enter data as shown below:
- For the file-identifier OUTFILE, specify the master file name (indexed file) in MASTER.
- For the environment variable @CBR_SCR_KEYDEFFILE, specify SAMPLE4.KBD, which enables the F2 key for use.
5. Click Apply. The data is saved in the object initialization file.

6. On the File menu, click Exit to terminate the run-time environment setup tool.

Program execution
1. In the Dependency view, select SAMPLEOQ4 project.
2. On the Run menu, click Run As > COBOL Application.

Execution result

The screen for entering an employee’'s number and name is displayed.
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B Screen; SAMPLES = O X

ID-HUMBER: 181818

HAME: Jamesfl

PF2:TERH

Enter an employee's 6 digit number and name (up to 40 alphanumeric characters), and press the ENTER key. The input data is written to
the master file, and the screen is cleared for the input of subsequent data.

To terminate processing, press the F2 key. Use Windows Explorer to confirm that the index file (MASTER) was created in the SAMPLEO4
directory with the employee number as the main record key and the employee name as the record sub-key.

1.4.2 Using MAKE file

Compiling and Linking the Program

Open a command prompt. Compile and link the sample program using the following command.

C:\COBOL\Samples\COBOL\Sample04>nmake

Compilation of the sample program is now complete. Verify that SAMPLE4.EXE was created in the same folder in which the sample
program is stored.

Setting Runtime Environment Information
Same as "1.4.1 Using NetCOBOL Studio".

Executing the Program

Execute SAMPLE4.EXE from a command prompt or from Windows Explorer.

Execution result
Same as "1.4.1 Using NetCOBOL Studio".

1.5 Sample 5: Calling COBOL Subprograms

Sample 5 demonstrates an application that calls a subprogram from the main program. Sample 5 was created using free format source.

Sample 5 also demonstrates how to pass an argument string to a program and how to display a message box.
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Qn Note

- C:\COBOL is used as the installation destination for NetCOBOL in this sample. Please change C:\COBOL to the folder where
NetCOBOL is installed.

Overview

Reads the contents of the master file (indexed file created in Sample 2), stores the records in a work file whose name is provided in the
@MGPRM environment variable (a way of passing information to a main program's linkage section), and then passes the work file to a
subprogram that prints the records.

The master file stores product codes, product names, and unit prices. The work file name must be specified in the @ MGPRM parameter at
program execution.

Files Included in Sample 5

- SAMPLE5.COB (COBOL source program)

S_REC.CBL (COBOL library file)

MAKEFILE
COBOLS85.CBR

- INSATSU.COB
When NetCOBOL Studio is used, the following are used. The COBOL source program is a variable format.
- SAMPLEQO5_EXE\SAMPLES.COB (COBOL source program)

SAMPLEO5_EXE\COBOLS85.CBR

SAMPLEO5_DLL\INSATSU.COB

SAMPLEO5_DLL\COBOLS85.CBR

SAMPLEO5_LIB\S_REC.CBL (COBOL library file)

COBOL Statements Used
The CALL, DISPLAY, EXIT, GO TO, MOVE, OPEN, READ, and WRITE statements are used.

Using Free Format in a COBOL Source Program

The following is an example of using free format in a COBOL source program.
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L:n Note

In the above figure, colons are used to denote sections of source code that have been omitted.

In free format, COBOL statements can be written in any character position on the line. Lines beginning with "*>" are treated as comments.

& Note

You must specify the SRF compiler option in order to use free format. The SRF compiler option has two parameters; the first specifies the
format for the source program and the second specifies the format of copybooks. All copybooks must have the same format type. The
available types are FIX, for fixed format source, VAR, for variable format source, and FREE, for free format source.

File Interdependence

The following figure shows the relationship between the source files used in Sample 5.

— Bource file ~-SAMPLEECOE — Library text -2_REZCEL -]

IDENTIFICATION DIVISTIOMN. -7 | Becord definition of worlkr file
PROGRAM-TD. Z2AMPLEE. . -7

- r

COPY "8 REC". — Source file o
) PRINTPRCZ . COE .
[Read master file] / IDENTIFICATION [IVISESN.
PROGRAM-ID. PRINTFERC.
[Create work file] / F 4
COPY "S REC".

CALL "PRINTPRERC" ..

i

[Print processingl
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Prerequisite to Executing the Program

The master file created in Sample 2 is used; therefore, execute the program in Sample 2 before executing Sample 5.

1.5.1 Using NetCOBOL Studio

Compiling and Linking the Program
1. NetCOBOL Studio is started by specifying the workspace created for the sample program. See "Preparing the workspace".

2. Inthe Dependency view, the presence of the SAMPLEOQ5, SAMPLEO5 EXE, SAMPLEO5 DLL and SAMPLEO5_LIB projects are
confirmed.

If there are no SAMPLEQ5 projects, import projects of sample program to NetCOBOL Studio workspace. See "Importing sample
program project into NetCOBOL Studio workspace".

3. The structure of the project is as follows.

H De.. B3 |[REStn. T Ma. = O

v @ SAMPLEOS P
v = SAMPLEOS_DLL
v (Bl Source Files
Insatsu.cob
@2 Linking Files
v (L Other Files
[= .settings
| buildxml
[#%) COBOLBS.CBR
=| IMSATSLULAII
=| IMSATSU. exp
=| INSATSLLlib
=| Insatsu.OB)
=| INSATSU.pdb
=| Insatsu.5WD
v = SAMPLEOS_EXE
v (Bl Source Files
FiE Samples.cob

............... -

[= .settings
[ buildxml
COBOL25.CER
5_rec.chl
[m=] SAMPLES.exe
=| Sample3.0B)
SAMPLES.pdb
=| Sample3.5VD

~ (B SAMPLEOS_LIB

5_rec.chl W

The build is executed immediately after importing the project when an automatic build is set. In this case, the file (. EXE . OBJ etc.)
is generated after the build is displayed in "Other Files". It is set to automatic build by default.
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4. Build setting of solution project

Set a project common option to the build page of the SAMPLEO5 solution project.

Here, set compile option LIB as a common option.

a. Inthe Dependency view, select the SAMPLEO5 projects, and chosen the property from the context menu. The Property dialog
box is displayed.

b. In the left pane, select Build. The Build page appears. Click the Compiler Options tab, confirm the content of the option.

T4 Properties for SAMPLEDS =] ®
type filter tedt Baulld aw - -
w Resource .
Linked Resaurces Lamgiler Options  |ibrary Mames  Linker Optiens l
Rescurce Filbers
Comnpiler aptions:
Bulld EP;ZKMLT
Took = ] fdd...
ET"’J: ‘T:t LIBL/SAMPLEDS LIB)
11 lanten SRF(FREE, FREE]
Praject References Change...
Remote Development —
Run/Debug Settings =
Targes
B4 The CHECKIALL) campile option is autesnatically added when the build mede is Debug
Other compier options:
v
i >
31
Conc

Here, confirm the storage folder of S_REC.CBL is specified for compiler option LIB, and compiler option SRF(FREE,FREE) is
specified. Click OK.
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5. Build setting of sub program and main program

Display the build page of the SAMPLEO5_DLL project and the SAMPLEO5_EXE project.

Bl Properties for SAMPLEDS_DLL o x
type filter text Build D=1 * w
Resgurce ™=@~ 3z 000 [P =
e [JEnzhle project specific settings ~
Build Toals Cornpiles Optsans Library Mames  Linker Sipticns
File Content
Project References puler
Remote Development . .
Run/Debug Settings SRF(FREE,FREE)
Target AR Change...
Remove
ke CHECELALL) compile option s automatically added when the budd racde is Debug,
»
< >
@

The Enable project specific settings check box dose not check.
6. The library reference in the main program

The main program links library file (INSATSU.lib). This library file is output from the SAMPLEO5_DLL project. Confirm
"INSATSU.lib" is added to the link file of the SAMPLEO5_EXE project on the Dependency view.

¥ Depen.. &2 |EE Struct.. T Navig.. — O

H=R-
v = SAMPLEOS_EXE P
~ (Bl Source Files
FitE Samples.cob
v @2 Linking Files
= INSATSUlib - /SAMPLEDS DLL

=

7. Build of solution project
Select the SAMPLEO5 project, and chosen the "Rebuild Project” from the context menu.
The solution project is built, and then SAMPLES.EXE is created.
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Setting Runtime Environment Information

1. Start Run-time Environment Setup Tool. The Run-time Environment Setup Tool dialog appears.

B4 Run-time Environment Setup Tool — >

File Envircnment Help

File Mame
C:\MetCOBOL Studio'work zpacesSAMPLEDS_EXENCOBOLSS.CER

Thread Mode
(®) Single Thread () Multi Thread

E nvironiment Y ariables

Sechion; Comman  Section

(@M GEPRM=zample5
IMFILE=.\SaMPLEOZ\MASTER

W ariable M ame:
[ v

W ariable W alue:

| | < >

Set Delete Apply

2. On the File menu, click Open. The Select Runtime Initialization file dialog box appears.

3. Select COBOLS85.CBR in the folder that contains the executable program (SAMPLES.EXE).
When the build is done from NetCOBOL Studio, the executable program is made for the SAMPLEOQ5_EXE project folder.
The content of the initialization file for execution is displayed.

4. On the Common tab and enter data as shown below:

- For the file-identifier INFILE, specify the path name of the master file (MASTER) created in Sample 2.

INFILE=. .\SAMPLEO2\MASTER

A relative path is a path relative to the current folder.
When you select the Run menu > Run As > COBOL Application, the current folder is a project folder.

- Specify a work file name in the @ MGPRM parameter. The string in this parameter is passed to the first linkage section item in
the executing program. The work file name can contain up to 8 alphanumeric characters. The extension "TMP" is added to the
work file name before the file is created.

5. Click Apply. The data is saved in the object initialization file.

6. On the File menu, click Exit to terminate the run-time environment setup tool.

Executing the Program

This sample program makes the executable file of the dynamic linking structure. It is necessary to add the storage folder of the dynamic link
library (DLL) to environment variable PATH when the DLL is not in the same folder of executable file (EXE) because the DLL of sub-
program is loaded by dynamic linker of the system.
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It explains the method of setting environment variable information with NetCOBOL Studio.
1. In the Dependency view, select SAMPLEQO5_EXE project.

2. On the Run menu, click Run Configurations.... The Run Configurations dialog boxes appears.

B Run Configurations *
Create, manage, and run configurations @
1
| A= Configure launch settings from this dialog:
bype filter text - Press the 'New’ button to create a configuration of the selected type.

) acaEﬂLﬁ.pph:at "=| - Press the 'Duplicate’ button to copy the selected configuration.
3£ - Press the ‘Dedete’ button bo remove the selected configuration,
f i - Press the 'Filtes’ butten ta canfigure filtering aptions.

- Edit or view an existing configuration by selecting it.
; Filter matched 3 of 3 items

@ Bun Clase

3. In the left pane, select COBOL Application, and then click the “New" (,j) button.

In the right pane, "SAMPLEQ5_EXE" is displayed in the name, and the configuration information at execution time is displayed.

. [34 Fun Configurations =
| Create, manage, and run cenfigurations

| Create a configuration ta launch a COBOL application, @

I

(EEE IR Name: | SAMPLEDS_EXE

||| type filter tet & Main™ B Source | B Environment’ [7] Common

w ¢ COBOL Application
| & SAMPLEDS_EXE

Preject name: | SAMPLEQS_EXE | | Brawse..

| CAMetCOBOL Studic-‘-.wwkspat!‘.SAMPLEDS_EEE‘\Eﬂ-l Browse...

Werking falder: | CAMetCOBOL Studia\warkspace’ SAMPLEDS_EXE | Browse...

Program arguments: [

) . Rewert Apply
Filter matched 2 of 2 items

® e
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4, Select the Environment tab.

E Run Configurations “
| Create, manage, and run configurations
| Create a configuration te launch a COBO0L application, @
OB R B3 | yame [ampieos b |
||| type fiter text |® Main 'l:;; Eu:-ur-:e_-! Envirenment =] _Commm;: ]
b & COBOL Application Environment variables to set "
SAMPLEDS_EXE
@ - Variable Valus Hew...
Sefect
Edit..
Remgve
W
Rewert Apple

Filter rnatched 2 of 2 items

@ [ ][ close
5. Here, the storage folder of INSATSU.DLL is added to environment variable Path. First of all, click Select.... The Select Environment
Variables dialog box is displayed.

& Select Environment V... O >

Select environment vanables to add:

P Path [ C:/Program Files/Fujitsu NetCOB A
Ol EPrngramData [ Ch\ProgramData ]

] EPrngramFiles[ ChProgram Files (xB6) ]

] EPrngramFilesl{xﬂE} [ ©\Program Files (x8
Ol EPrngramWMEE [ CM\Program Files ]

] EREQCGBInstDir[ HEEY_LOCAL_MACHIM
[] P& RegCOBRTSInstDir [ C:\Program Files\C

[] R SESSIONNAME [ RDP-Tep#27 | v
< »

Select All Deselect All

@

-20 -



6. Check the Path check box, and click OK.

"Path" is added to the Environment variables to set list.

=i Run Configurations x
Create, manage, and run configurations
Create a configuration to launch a COBOL application, @
[ 2 %] B 3~ | Name: [sampLeos exe
type filter test ‘@ Main [ ;E/ Source | P Environment Wis| Q:-rnm-::nr_ )
v @ COBOL Applicatior || | Environment variables to set:
SAMPLEOS EXE
@ - Variable Value MNew...
i ) . -
Path C:/Prograrm Files/Fujits... Select
Edt..
Remove
" Append environment to native environment
(") Replace native environment with specified environment
; - R Appl
ert
Fitter matched 2 of 2 tems = PPy
'C?; Run Close

7. Itis confirmed that the Append environment to native environment button is clicked.

L:j Note

When the "Replace native environment with specified environment" is checked and the following procedure is progressed, the application
cannot be correctly executed.

Check the "Append environment to native environment".

1. On the Environment tab, select “Path", and click the Edit.... The Edit Environment Variable dialog box appears.

& Edit Environment Variable ot

Mame: | Path

Value: | OL Studio\workspace\SAMPLEDS DLL| | | Variables..

Add the storage folder of SAMPLEOQ5_DLL project to the Value filed, and then click OK.

2. On the Environment tab, click Apply. The environmental setting of execution time is completed.

3. Click Run. SAMPLES.EXE is executed.
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Execution result

The message "GENERATE WORK-FILE=SAMPLES.TMP" is displayed. Confirm the message contents, and close the message box by
clicking OK button.

When the program execution ends, master file is printed to the printer which is set as "Set as default printer ".

1.5.2 Using MAKE file

Compiling and Linking the Program

Open a command prompt. Compile and link the sample program using the following command.

c:\COBOL\Samples\COBOL\Sample05>nmake

Compilation of the sample program is now complete. Verify that SAMPLES.EXE and INSATSU.DLL were created in the same folder in
which the sample program is stored.

Setting Runtime Environment Information
Same as "1.5.1 Using NetCOBOL Studio™.

Executing the Program
Execute SAMPLES.EXE from a command prompt or from Windows Explorer.

The message "GENERATE WORK-FILE=SAMPLES5.TMP" is displayed. Confirm the contents, and then click the OK button to close the
message box.

The master file contents are written to the default printer at the completion of program execution.

Execution result
Same as "1.5.1 Using NetCOBOL Studio".

1.6 Sample 6: Receiving a Command Line Argument

Sample 6 demonstrates a program that receives an argument specified at program execution, using the command line argument handling
function (ACCEPT FROM argument-name/argument-value). Refer to "Using ACCEPT and DISPLAY Statements" in the "NetCOBOL
User's Guide" for details on how to use the command line argument handling function.

Sample 6 also calls an internal program.

Overview

The sample program calculates the number of days from the start date to the end date. The start and end dates are specified as command
arguments in the following format:

command-name start-date end-date

start-date, end-date:

Specify a year, month, and day between January 1, 1900 and December 31, 2172 in the YYYYMMDD format.

Files Included in Sample 6
- SAMPLE®6.COB (COBOL source program)
- MAKEFILE
- COBOLS85.CBR

COBOL Statements Used
The ACCEPT, CALL, COMPUTE, COPY, DISPLAY, DIVIDE, EXIT, GO TO, IF, MOVE, and PERFORM statements are used.
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1.6.1 Using NetCOBOL Studio

Compiling and Linking the Program
1. NetCOBOL Studio is started by specifying the workspace created for the sample program. See "Preparing the workspace".
2. In the Dependency view, the presence of the presence of the SAMPLEO6 project is confirmed.

If there is no SAMPLEOQG project, import the SAMPLEOQ6 project into the NetCOBOL Studio workspace. See "Importing sample
program project into NetCOBOL Studio workspace".

3. The structure of the project is as follows.

¥ De.. % |EEStr. w.Na. = O

| E
v = SAMPLEOG -
v (Bl Source Files
=i Samplef.cob
@2 Linking Files
w (2L Other Files
= .settings
= build.xml
COBOLA5.CER
= Makefile
[5=] SAMPLEG.exe
=| Samplet.OB)
SAMPLEG.pdb
Sampled.5VD W

1

The build is executed immediately after importing the project when an automatic build is set. In this case, the file (. EXE . OBJ etc.)
is generated after the build is displayed in "Other Files". It is set to automatic build by default.

4. On the Project menu, click Build Project when SAMPLEG.EXE is not created in "Other Files" (When an automatic build is not
executed).

The project is built, and then SAMPLEG.EXE is created.

Executing the Program
1. On the Dependency view, select the SAMPLEO6 project

2. On the Run menu, click Run Configurations.... The Run Configurations dialog boxes appears.
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3. In the left pane, select COBOL Application, and then click the “New" (|j) button.

In the right pane, SAMPLEQ6 is displayed in the name, and the configuration information at execution time is displayed.

Run Configurations *
Create, manage, and run configurations
Create & configuration te launch a COBOL application, @
3 li= b | = :-:‘.‘; we Mame: [ SAMPLEDE ]
| type filter text ‘@® Main % Source| I Environment | ] Common | )
L ﬁ COBOL Applicatior
@" EEENG Project name: | SAMPLEOG | | Browse...
Feecutable File: | C\NetCOBOL Studio\workspace\SAM| | Browse...
Working folder: | C:\NetCOBOL Studio\workspace\ SAM| | Browse...
Program arguments: |
< b
Revert Appl
Filter matched 2 of 2 items o

4. Select the Main tab.

=4 Run Configurations *
Create, manage, and run configurations
Create a configuration to launch a COBOL application. @
CEX| 83~ | Name[sampLeos |
|m /@' Main . s Source| [ Environment | (] Common | )
w & COBOL Application
SAMPLEOG
@ Project name: | SAMPLES | | Browse...
Executable File: | CAMNetCOBOL $tud'||:r"|.vmk5|:|ace\SAM| Browse...
Working folder: | C:\NetCOBOL Studic\workspace\SAM| | Browse...
Program arguments: | 20000101 20170101 |
¢ ’ R Appl
Fitber matched 2 of 2 items e PPy
@ Bun Close

In the Program arguments field, enter the start-date and end-date.

Example of program argument

20000101 20170101

-24 -




5. Click Apply, and then click Run. SAMPLEOS is started.

Execution result
The output destination of the DISPLAY statement is system console for this sample program.

Days from January 1, 2000 to January 1, 2017 are displayed as follows.
l |

& Console 2% ¢ o = B8

X% BEEREE a9
«terminated> SAMPLEDE [COBOL Application] C:\MetCOBOL Studic\workspace\ SAMPLEDE\SAMPLEE. exe

DIFFERENCE OF DAYS IS +06210 ~
28 See
EL]

© © 0000000000000 00000000000000000000000000000000000000000000000000000000000000000000000000COCOCOCOCOCEOCEOCE

Refer to "Definition of the target" in the "NetCOBOL Studio User's Guide" when you want to make the output destination of the DISPLAY
statement COBOL console.

© ©0000000000000000000000000000000000000000000O00COCOCOCOCOCIOCIOCOCOCEOCOCOC0CI0C0C0C0CI0C0COC0C0C0C0C0C0C0C0C0C0C0C0C0C0C0C0C0C0C0C0CCCCCOCOCEOCEECEEETS

1.6.2 Using MAKE file

Compiling and Linking the Program

Open a command prompt. Compile and link the sample program using the following command.

C:\COBOL\Samples\COBOL\Sample06>nmake

Compilation of the sample program is now complete. Verify that SAMPLEG.EXE was created in the same folder in which the sample
program is stored.

Executing the Program

Execute "SAMPLEG.EXE start-date end-date” from a command prompt or from Windows Explorer.

C:\COBOL\Samples\COBOL\Sample06>SAMPLE6.EXE 20000101 20170101

Execution Result

Sample 6 displays the number of days from the specified start date to the specified end date.

C:\COBOL\Samples\COBOL\Sample06>SAMPLE6.EXE 20000101 20170101
DIFFERENCE OF DAYS 1S +06210

C:\COBOL\Samples\COBOL\Sample06>

1.7 Sample 7. Environment Variable Handling

Sample 7 demonstrates a program that changes the value of an environment variable during COBOL program execution, using the
environment variable handling function (ACCEPT FROM/DISPLAY UPON environment-name/environment-value). Refer to "Using
ACCEPT and DISPLAY Statements™ in the "NetCOBOL User's Guide™ for details on how to use the environment variable handling
function.

Overview

The sample program divides a master file (the indexed file created in Sample 2) that contains product codes, product names, and unit prices
into two master files according to product codes. The following table shows the division method and the names of the two new master files:
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Table 1.1 Division of the master files

Product Code File Name
Code beginning with 0 master-file-name.A
Code beginning with a non-zero value master-file-name.B

Files Included in Sample 7
- SAMPLE7.COB (COBOL source program)
- MAKEFILE
- COBOLS85.CBR

COBOL Statements Used
The ACCEPT, CLOSE, DISPLAY, EXIT, GO TO, IF, OPEN, READ, STRING, and WRITE statements are used.

1.7.1 Using NetCOBOL Studio

Compiling and Linking the Program
1. NetCOBOL Studio is started by specifying the workspace created for the sample program. See "Preparing the workspace".
2. In the Dependency view, the presence of the presence of the SAMPLEOQ7 project is confirmed.

If there is no SAMPLEQ7 project, import the project for the sample program into the NetCOBOL Studio workspace. See "Importing
sample program project into NetCOBOL Studio workspace".

3. The structure of the project is as follows.

H De.. 27 BESn. = Na.. = O
| E
v = SAMPLEOT ~
v (Bl SourceFiles
Eif S5ampleT.cob
@2 Linking Files
~v (L Other Files
[= .settings
= build.xml
Cobol85.chr
=| Makefile
[m=] SAMPLET exe
=| Sample7.OE)
SAMPLET.pdb
Sample?.5VD v

ik

The build is executed immediately after importing the project when an automatic build is set. In this case, the file (. EXE . OBJ etc.)
is generated after the build is displayed in "Other Files". It is set to automatic build by default.

4. On the Project menu, click Build Project when SAMPLE7.EXE is not created in "Other Files" (When an automatic build is not
executed).

The project is built, and then SAMPLE7.EXE is created.
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Setting Runtime Environment Information

1. Start Run-time Environment Setup Tool. The Run-time Environment Setup Tool dialog appears.

B¢ Run-time Environment Setup Tool = >

File  Envircnment Help

File Mame
C:AMetCOBOL Studiohwork zpacehSakPLE 07\ Cobalds. chr

Thread Mode
(®) Single Thread () Multi Thread

E nvironment Y ariables

Sechion; Common  Section

IMFILE=.\5aMPLEOAMASTER

W ariable M ame:

Wariable W alue:

| | < >

Set Delete Apply

2. On the File menu, click Open. The Select Runtime Initialization file dialog box appears.
3. Select COBOLS85.CBR in the folder that contains the executable program (SAMPLE7.EXE).
4. On the Common tab and enter data as shown below:

- For the file-identifier INFILE, specify the path name of the master file (MASTER) created in Sample 2.

INFILE=. .\SAMPLEO2\MASTER

5. Click Apply. The data is saved in the object initialization file.

6. On the File menu, click Exit to terminate the run-time environment setup tool.

Executing the Program
1. In the Dependency view, select SAMPLEOQ7 project.
2. On the Run menu, click Run As > COBOL Application.

Qn Note

Execute the program in Sample 2 beforehand.

Execution result

The following two files are created in the directory of the master file created in Sample 2:
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- MASTER.A: Stores the data of products whose codes begin with 0.
- MASTER.B: Stores the data of products whose codes begin with a non-zero value.

The contents of the newly created master files (MASTER.A and MASTER.B) can be checked with the program in Sample 5 in the same
manner as for the master file created in Sample 2.

1.7.2 Using MAKE file

Compiling and Linking the Program

Open a command prompt. Compile and link the sample program using the following command.

C:\COBOL\Samples\COBOL\Sample07>nmake

Compilation of the sample program is now complete. Verify that SAMPLE7.EXE was created in the same folder in which the sample
program is stored.

Setting Runtime Environment Information
Same as "1.7.1 Using NetCOBOL Studio™.

Executing the Program

Execute SAMPLE7.EXE from a command prompt or from Windows Explorer.

& Note

Execute the program in Sample 2 beforehand.

Execution result
Same as "1.7.1 Using NetCOBOL Studio".

1.8 Sample 8: Using a Print File

Sample 8 demonstrates a program that outputs data (input from the console window) to a printer using a print file. Refer to "Printing" in the
"NetCOBOL User's Guide" for details on using a print file.

Overview

The sample program inputs data of up to 40 alphanumeric characters from the console window, and outputs the data to the printer.

Files Included in Sample 8
- SAMPLES8.COB (COBOL source program)
- MAKEFILE
- COBOLS85.CBR

COBOL Statements Used
The ACCEPT, CLOSE, EXIT, GO TO, IF, OPEN, and WRITE statements are used.

1.8.1 Using NetCOBOL Studio

Compiling and Linking the Program
1. NetCOBOL Studio is started by specifying the workspace created for the sample program. See "Preparing the workspace".
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2. In the Dependency view, the presence of the presence of the SAMPLEOS8 project is confirmed.

If there is no SAMPLEOQ8 project, import the project for the sample program into the NetCOBOL Studio workspace. See "Importing
sample program project into NetCOBOL Studio workspace".

3. The structure of the project is as follows.

¥ De. % 8ESrn. W Na. — O

v = SAMPLEDS A
v (Bl Source Files
5 S5ampled.cob
@2 Linking Files
v [ZL Other Files
= .settings
2 buildxml
COBOL25.CER
= Makefile
[m] SAMPLES.exe
Sampled. OB)
SAMPLES. pb
Sampled.5VD W

The build is executed immediately after importing the project when an automatic build is set. In this case, the file (. EXE . OBJ etc.)
is generated after the build is displayed in "Other Files". It is set to automatic build by default.

4. On the Project menu, click Build Project when SAMPLES.EXE is not created in "Other Files" (When an automatic build is not
executed).

The project is built, and then SAMPLES8.EXE is created.

Executing the Program
1. Inthe Dependency view, select SAMPLEOS project.
2. On the Run menu, click Run As > COBOL Application.

Execution result
A console window is displayed. In the console window, enter the data to be printed. Up to 40 characters can be entered at a time.
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B Console: SAMPLES = ot
1234567890123456789012345678901234567890A A
ahcd
13636 36 36 36 36 36 36 36 36 36 36 36 5, FY P L E £ 26 36 36 36 36 36 36 36 36 36 36 36 36 36 36 36 36 36 36 3
FEHD

W

To terminate the program, press the RETURN key, type /END and press the RETURN key again. Click the "OK" button to close the message
window.

The input data is written to the printer at program termination.

1234 567890123456 789012345678 901 234 567890
abod

FTEEEEE AT L S\M{PLE 8*1.' FEEEEET T LT T AL AL

\_///,

1.8.2 Using MAKE file

Compiling and Linking the Program

Open a command prompt. Compile and link the sample program using the following command.

C:\COBOL\Samples\COBOL\Sample08>nmake

Compilation of the sample program is now complete. Verify that SAMPLES8.EXE was created in the same folder in which the sample
program is stored.

Executing the Program

Execute SAMPLES.EXE from a command prompt or from Windows Explorer.
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Execution result
Same as "1.8.1 Using NetCOBOL Studio".

1.9 Sample 9: Using a Print File (Advanced usage)

Sample 9 demonstrates the following:

- Using a print file without a FORMAT clause

Using the | control record to set and change page forms, in combination with Forms Control Buffers (FCBs)

- Using the CHARACTER TYPE clause to control letter size and pitch

Using the PRINTING POSITION clause to control the layout (line / column)

Refer to "Printing" in the "NetCOBOL User's Guide" for details on using "print file 1" and "print file 2".

Overview

The table below describes each of the tasks performed by this sample. The tasks show a number of printing features. There are essentially
four elements that give you control over the various printing features:

1. COBOL syntax

- PRINTING MODE clauses in the SPECIAL-NAMES paragraph.

- ASSIGN TO PRINTER in the SELECT statement.

- CHARACTER TYPE and PRINTING POSITION clauses in data definitions.
2. The I-Control Record

A record that you write to the print file using the syntax:
"CTL IS page-cntl" in SPECIAL-NAMES

and

WRITE I-Control-Record AFTER ADVANCING page-cntl

3. Forms Control Buffers (FCBs)

These are form information buffers stored by the COBOL runtime system, using information defined in environment variables of the
form "FCBxxxx=".

4. Environment variables
Environment variables define fonts, FCBs, document names and other printing details.

The table below indicates which of the above are used to provide a particular feature. You will need to read the table, inspect the COBOL
code, and consult the chapter on "Printing" in the "NetCOBOL User's Guide" to fully understand all of the features being demonstrated.

Table 1.2 Features demonstrated in Sample 9

Task Description Detailed features Controlled by Related Environment
I-Control field / COBOL clause Variable(s)
la. Prints a page at 6 LPI, | 6 LPI-definedinFCB | 1-control: FCBLT6L=...
10 CPI on a PowerFORM
overlay grid FCB-NAME (="'LT6L")
10 CPI PRINTING MODE X ... AT PITCH ...
+

CHARACTER TYPE X

Letter size paper 1-Control :

PAPER-SIZE (="LTR™)
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Task Description

Detailed features

Controlled by
I-Control field / COBOL clause

Related Environment
Variable(s)

Impact font

PRINTING MODE x

- WITH FONT GOTHIC ...

CHARACTER TYPE Xx

@PrinterFontName=
(..., Impact)

Courier New font

PRINTING MODE x

. WITH FONT MINCHOU ...

CHARACTER TYPE x

@PrinterFontName=
(Courier New, ...)

Grid (PowerFORM
overlay -
KOL6LT6L.0OVD)

1-Control:
FOVL-NAME (="LT6L"™)

FOVL-R (= 1 - to use overlay on
a single page)

FOVLTYPE=KOLG6
OVD_SUFFIX=0VD

Data item position
within line

PRINTING POSITION

Different character
type forms

PRINTING MODE x

. FORM ...

CHARACTER TYPE Xx

Document name
displayed by
Windows

1-Control:

DOCUMENT-NAME (=DOC1)

@CBR_DocumentName_
DOC1=<document name
string>

1h. Prints a page at 8 LPI,
10 CPI on a PowerFORM
overlay grid

8 LPI -definedin FCB

1-Control:

FCB-NAME (="LT8L")

FCBLTSL=...

10 CPI

PRINTING MODE x ...

CHARACTER TYPE X

AT PITCH ...

Letter size paper

1-Control:

PAPER-SIZE (="LTR™)

Impact font

PRINTING MODE x

- WITH FONT GOTHIC ...

CHARACTER TYPE x

@PrinterFontName=
(..., Impact)

Courier New font

PRINTING MODE x
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Task Description

Detailed features

Controlled by

|I-Control field / COBOL clause

Related Environment
Variable(s)

. WITH FONT MINCHOU ...

CHARACTER TYPE x

Grid (PowerFORM
overlay -
KOLG6LT8L.OVD)

1-Control:

FOVL-NAME (="LT8L'")

FOVL-R (= 1 - to use overlay on

a single page)

FOVLTYPE=KOLG6
OVD_SUFFIX=0VD

Data item position
within line

PRINTING POSITION

Different character
type forms

PRINTING MODE x

. FORM ...

CHARACTER TYPE x

2a. Prints letters in font
sizes 3,7.2,9, 12, 18, 24,
36, 50, 72, 100, 200, and
300 points. On legal-sized
paper

(After printing a header
page)

The COBOL runtime
system automatically
calculates the best
character pitch fitted to the
character size (character
pitch specification is
omitted).

Document name
displayed by
Windows

1-Control:

DOCUMENT-NAME (=D0OC1)

@CBR_DocumentName_
DOC1=<document name
string>

Different font sizes

PRINTING MODE x

. IN SIZE nn POINT ...

CHARACTER TYPE Xx

Legal size paper

1-Control:
PAPER-SIZE (="XXX")

FCB-NAME (="LP16')

@PRN_FormName_XXX
=Legal 8 1/2x 14 in

FCBLPI6=...

Impact font

Default - Gothic font

@PrinterFontName=
(..., Impact)

Shaded background
(PowerFORM
overlay -
KOL6LGLT.OVD)

1-Control:

FOVL-NAME (="LGLT™)

FOVL-R (= 1 - to use overlay on

a single page)

FOVLTYPE=KOLG6
OVD_SUFFIX=0VD

Document name
displayed by
Windows

1-Control:

DOCUMENT-NAME (=DOC2)

@CBR_DocumentName_
DOC2=<document name
string>

2b. Prints characters at
pitches1,2,3,5,6,7.5, 20,
and 24 CPI.

The COBOL runtime
system automatically

Different pitches

PRINTING MODE x

. AT PITCH n CPI ...
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Task Description

Detailed features

Controlled by

|I-Control field / COBOL clause

Related Environment
Variable(s)

calculates the best
character size fitted to the
character pitch (the
character size
specification is omitted).

CHARACTER TYPE Xx

Legal size paper

1-Control:
PAPER-SIZE (="XXX'™)

FCB-NAME (="LP16')

@PRN_FormName_XXX
=Legal 8 1/2x 14 in

FCBLPI6=...

Impact font

Default - Gothic font

@PrinterFontName=
(..., Impact)

Shaded background
(PowerFORM
overlay -
KOL6LGLT.OVD)

1-Control:

FOVL-NAME (="LGLT'™)

FOVL-R (= 1 - to use overlay on

a single page)

FOVLTYPE=KOLG6
OVD_SUFFIX=0VD

Document name

1-Control:

@CBR_DocumentName_

displayed by DOC2=<document hame
Windows DOCUMENT-NAME (=DOC2) string>
2c. Prints characters in Impact font PRINTING MODE x @PrinterFontName=

Impact,

Impact half-size,
Courier New, Courier
New half size.

. WITH FONT
{GOTHIC

{GOTHIC-HANKAKU} ...
+

CHARACTER TYPE Xx

(..., Impact)

Courier New font

PRINTING MODE x

- WITH FONT
{MINCHOU

{MINCHOU-HANKAKU}

CHARACTER TYPE Xx

@PrinterFontName=
(Courier New, ...)

Full size PRINTING MODE x
. BY FORM F ...
+

CHARACTER TYPE x

Half size PRINTING MODE x

. BY FORM H ...

CHARACTER TYPE x
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Task Description

Detailed features

Controlled by
I-Control field / COBOL clause

Related Environment
Variable(s)

Legal size paper

1-Control:
PAPER-SIZE (="XXX'")

FCB-NAME (="LP16')

@PRN_FormName_XXX
=Legal 8 1/2x 14 in

FCBLPI6=...

Shaded background
(PowerFORM
overlay -
KOL6LGLT.OVD)

1-Control:
FOVL-NAME (="LGLT™)

FOVL-R (= 1 - to use overlay on
a single page)

FOVLTYPE=KOLG6
OVD_SUFFIX=0VD

Document name I-Control - @CBR_DocumentName_
displayed by DOC2=<document name
Windows DOCUMENT-NAME (=DOC2) string>

2d. Prints characters in Em-size PRINTING MODE X

different form sizes:

. . BY FORM F ...

Em-size,

en-size, expanded em- +

size,

CHARACTER TYPE Xx

expanded en-size,

En-size As above with:

tall em-size, tall en-size,
double em-size and

double en-size.

. BY FORM H ...

Expanded em-size

As above with:

. BY FORM F0201 ...

Expanded en-size

As above with:

. BY FORM HO201 ...

Tall em-size As above with:
. BY FORM F0102 ...
Tall en-size As above with:

. BY FORM HO102 ...

Double em-size

As above with:

. BY FORM F0202...

Double en-size

As above with:

. BY FORM HO202...

Legal size paper

1-Control:
PAPER-SIZE (="XXX'")

FCB-NAME (="LPI16™)

@PRN_FormName_XXX
=Legal 8 1/2x 14 in

FCBLPI6=...

Shaded background
(PowerFORM

1-Control:
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Task Description Detailed features Controlled by Related Environment

I-Control field / COBOL clause Variable(s)

overlay - FOVL-NAME (="LGLT')
KOL6LGLT.OVD)

FOVL-R (= 1 - to use overlay on

a single page)
Document name I-Control : @CBR_DocumentName_
displayed by DOC2=<document name
Windows DOCUMENT-NAME (=DOC2) string>

2e. Prints a mixture of the
above features: font size,
pitch, half/full size
characters.

Files Included in Sample 9
- SAMPLEY.COB (COBOL source program)
- KOL6LGLT.OVD (Form overlay pattern)
- KOL6LT6L.OVD (Form overlay pattern)
- KOL6LT8L.OVD (Form overlay pattern)
- COBOLS85.CBR
- MAKEFILE

COBOL Statements Used
The ADD, CLOSE, DISPLAY, IF, MOVE, OPEN, PERFORM, STOP, and WRITE statements are used.

1.9.1 Using NetCOBOL Studio

Compiling and Linking the Program
1. NetCOBOL Studio is started by specifying the workspace created for the sample program. See "Preparing the workspace".
2. In the Dependency view, the presence of the presence of the SAMPLEO9 project is confirmed.

If there is no SAMPLEOQ9 project, import the project for the sample program into the NetCOBOL Studio workspace. See "Importing
sample program project into NetCOBOL Studio workspace".
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3. The structure of the project is as follows.

H De.. 2| &ES. = Na.. = O

v =% SAMPLEO9 ~
~ (Bl Source Files
Ei# Sampled.cob
@2 Linking Files
~ [EL Other Files
[= settings
E buildxml
COBOLE5.CER
B Kol6lglt.ovd
B Kol6ltsl.ovd
Kol6lt8l.ovd
= Makefile
[m=] SAMPLES.exe
= Sample2.0BJ
SAMPLES. pdb
=| Sampled.SVD e

The build is executed immediately after importing the project when an automatic build is set. In this case, the file (. EXE . OBJ etc.)
is generated after the build is displayed in "Other Files". It is set to automatic build by default.

4. On the Project menu, click Build Project when SAMPLE9.EXE is not created in "Other Files" (When an automatic build is not
executed).

The project is built, and then SAMPLE9.EXE is created.
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Setting Runtime Environment Information

1. Start Run-time Environment Setup Tool. The Run-time Environment Setup Tool dialog appears.

B¢ Run-time Environment Setup Tool — >

File Envircnment Help

File Mame
C:\MetCOBOL Studio'work zpaceSAMPLEONCOBOLES.CER

Thread Mode
(®) Single Thread () Multi Thread

E nvironiment Y ariables

Sechion; Comman  Section

@CER_Docurment ame_DOCT=54MPL A

@CER_Docurmentt ame_DOCZ=VARI0

‘Yariable Mame: ECER_OverlayPrint0ffzet="ALI0

- @CER_DverlayPrintS PEC=COBOL
(@CBR_PrinteraMk._Size=TvPE-PC

|| ™ | @CER_Print T extPozition=TvFE2

ACER_Textalign=B0TTOM
W ariable ' alue: @DefaultFCB_Mame=FCBDFLT
(BE S etwdindow=l15E b
| | £ >
Set Delete Apply

2. On the File menu, click Open. The Select Runtime Initialization file dialog box appears.
3. Select COBOL85.CBR in the SAMPLEQ9 folder. The window should look like the above figure.

4. Check the setting of environment variable FOVLDIR in the list of environment variables. If it is not set to your location for the
SAMPLEO9 folder, change it to that value by:

FOVLDIR=.\

a. Selecting FOVLDIR inthe environment variable list. "FOVLDIR" will be displayed in the Variable Name field, and its current
setting in the Variable Value field.

b. Use the browse ("...") button to navigate to the SAMPLEQ9 folder, select any file, and click OK. The path and filename are
returned to the Variable Value field.

C. Delete the last "\" and the file name that follows it from the string in the Variable Value field.
d. Click the Set button to set your change in the Section list of environment variables.
e. Click the Apply button to save your changes to the COBOL85.CBR file.

5. Click Apply. The data is saved in the object initialization file.

6. On the File menu, click Exit to terminate the run-time environment setup tool.

Executing the Program
1. In the Dependency view, select SAMPLEQ9 project.
2. On the Run menu, click Run As > COBOL Application.
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Execution result

The sample pages described in the table "Features demonstrated in Sample 9" above are printed to the default printer.

1.9.2 Using MAKE file

Compiling and Linking the Program

Open a command prompt. Compile and link the sample program using the following command.

C:\COBOL\Samples\COBOL\Sample09>nmake

Compilation of the sample program is now complete. Verify that SAMPLE9.EXE was created in the same folder in which the sample
program is stored.

Setting Runtime Environment Information
Same as "1.9.1 Using NetCOBOL Studio™.

Executing the Program

Execute SAMPLE9.EXE from a command prompt or from Windows Explorer.

Execution result
Same as "1.9.1 Using NetCOBOL Studio".

1.10 Sample 11: Remote Database Access

Sample 11 extracts data from a database and assigns it to a host variable using the SQL database function.

In normal operation, the database is placed on a server and is accessed by the client via an ODBC driver. A database file is included with
this sample to enable you to use a relational database off-line. This database file, called STOCK.MDB, includes the Microsoft Access
runtime support. It can therefore be used as long as Open Database Connectivity (ODBC) is installed and configured properly.

For more information about using ODBC drivers, refer to "Database (SQL)" in the "NetCOBOL User's Guide", and the relevant
documentation from your database vendor.

To run this sample program in a true distributed configuration, the following products are required:
Client

- ODBC driver manager

- ODBC driver

- Products needed for the ODBC driver
On the server

- Database

L:)] Note

This sample does not function correctly with Microsoft® Access.
- Products needed for accessing the database via ODBC

Overview

The sample program accesses the database on the server and outputs all data stored in the database table "STOCK" to the client console.
When all data has been referenced, the link to the database is disconnected.
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Files Included in Sample 11
- SAMPLE11.COB (COBOL source program)
- MAKEFILE
- COBOLS85.CBR

COBOL Statements Used
The DISPLAY, IF and PERFORM statements are used.

Embedded SQL statements (embedded exception declarations and CONNECT, DECLARE CURSOR, OPEN, FETCH, CLOSE,
ROLLBACK, and DISCONNECT statements) are also used.

Prerequisite to Executing the Program

ODBC is a defined interface that attempts to provide a highly generic API into any database system that provides compliant drivers. Just
about every database system available today provides ODBC drivers for a variety of platforms.

In order to execute this sample, the DBMS product which can be connected via ODBC is installed in server side and make the table named
STOCK for the database connected by default.

Make the STOCK table in the format as following.

GNO GOODS QOH WHNO
Binary integer Fixed-length character Binary integer Binary integer
4 digits 10 bytes 9 digits 4 digits

Store the data items shown below in the STOCK table.

GNO GOODS QOH WHNO
110 TELEVISION 85 2
111 TELEVISION 90 2
123 REFRIGERATOR 60 1
124 REFRIGERATOR 75 1
137 RADIO 150 2
138 RADIO 200 2
140 CASSETTE DECK 120 2
141 CASSETTE DECK 80 2
200 AIR CONDITIONER 4 1
201 AIR CONDITIONER 15 1
212 TELEVISION 0 2
215 VIDEO 5 2
226 REFRIGERATOR 8 1
227 REFRIGERATOR 15 1
240 CASSETTE DECK 25 2
243 CASSETTE DECK 14 2
351 CASSETTE TAPE 2500 2
380 SHAVER 870 3
390 DRIER 540 3
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Then create the ODBC information file using SQLODBCS.EXE.

1.10.1 Using NetCOBOL Studio

Compiling and Linking the Program
1. NetCOBOL Studio is started by specifying the workspace created for the sample program. See "Preparing the workspace".
2. In the Dependency view, the presence of the presence of the SAMPLE11 project is confirmed.

3. Ifthere is no SAMPLE11 project, import the project for the sample program into the NetCOBOL Studio workspace. See "Importing
sample program project into NetCOBOL Studio workspace".

4. The structure of the project is as follows.

# De.. #7 | &EStn. @ Na. — O

CE
v = SAMPLETT ”
v (Bl Source Files
E@ Samplell.cob
@2 Linking Files
v (L Other Files
[= .settings
2 buildxml
COBOLE5.CER
= Makefile
[m5] SAMPLET.exe
=| Samplel1.QB)
= SAMPLE1.pdb
=| Samplel1.5VD hd

The build is executed immediately after importing the project when an automatic build is set. In this case, the file (. EXE . OBJ etc.)
is generated after the build is displayed in "Other Files". It is set to automatic build by default.

5. On the Project menu, click Build Project when SAMPLE11.EXE is not created in "Other Files" (When an automatic build is not
executed).

The project is built, and then SAMPLE11.EXE is created.
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Setting Runtime Environment Information

1. Start Run-time Environment Setup Tool. The Run-time Environment Setup Tool dialog appears.

B¢ Run-time Environment Setup Tool = >

Eile Envircnment Help

File Mame
C:AMetCOBOL Studio'workspacetSAMPLET15COBOLSS.CER

Thread Mode
(®) Single Thread () Multi Thread

E nvironment Y ariables

Section: Comman  Section

@ODBC_Inf= \DEMSACS.INF

Yariahle M ame:
[ v|

W ariable W alue

| | < >

Set Delete Lpply

2. On the File menu, click Open. The Select Runtime Initialization file dialog box appears.
3. Select COBOLS85.CBR in the folder that contains the executable program (SAMPLE11.EXE).
4. Select the Common tab and enter data as shown below:
- Specify DBMSACS.INF for the environment variable @ODBC_Inf.
5. Click Apply. The data is saved in the object initialization file.

6. On the File menu, click Exit to terminate the run-time environment setup tool.

Executing the Program
1. Inthe Dependency view, select SAMPLEL1 project.
2. On the Run menu, click Run As > COBOL Application.

Execution result
The data extracted from the table is displayed, as shown in the following figure. (Console: SAMPLE11)

no.12:

Product number = +0227

Product name = REFRIGERATOR
Stock quantiry = +00000015
Warehouse number = +0001

no.13:

Product number = +0240

Product name = CASSETTE DECK
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Stock quantiry = +00000025
Warehouse number = +0002

no.14:

Product number = +0243

Product name = CASSETTE DECK
Stock quantiry = +00000014
Warehouse number = +0002

no.15:

Product number = +0351

Product name = CASSETTE TAPE
Stock quantiry = +00002500
Warehouse number = +0002
There are 15 data in total

END OF SESSION

1.10.2 Using MAKE file

Compiling and Linking the Program

Open a command prompt. Compile and link the sample program using the following command.

C:\COBOL\Samples\COBOL\Samplell>nmake

Compilation of the sample program is now complete. Verify that SAMPLE11.EXE was created in the same folder in which the sample
program is stored.

Setting Runtime Environment Information
Same as "1.10.1 Using NetCOBOL Studio".

Executing the Program

Execute SAMPLE11.EXE from a command prompt or from Windows Explorer.

Execution result
Same as "1.10.1 Using NetCOBOL Studio".

1.11 Sample 12: Remote Database Access (Multiple row
processing)

Sample 12 shows how two or more lines in a database can be operated using one SQL statement, demonstrating an example of advanced
usage of the database (SQL) function.

In this example, a database that exists on a server is accessed from a client, via an ODBC driver. For details of database access using an
ODBC driver, refer to "Database (SQL)" in the "NetCOBOL User's Guide".

To use this program, the following products are necessary:
Client

- ODBC driver manager

- ODBC driver

- Products necessary for the ODBC driver
Server

- Database
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Qn Note

This sample does not function correctly with Microsoft® Access.
- Products necessary for database access using ODBC

Overview

Sample 12 uses the STOCK table of the sample database. Refer to "Sample Database" in the "NetCOBOL User's Guide" for details. Sample
12 accesses and disconnects it after the following operation:

- Display of all data items in the database

Fetch of the GNO value on a row with GOODS value "TELEVISION"

QOH update on a row with the fetched GNO

Deletion of lines with GOODS values "RADIO", "SHAVER", and "DRIER"
- Redisplay of all data items in the database

Part of the output result is output to a file by using compiler option SSOUT.

Programs and files in Sample 12
- SAMPLE12.COB (COBOL source program)
- MAKEFILE
- COBOLS85.CBR

COBOL functions used in Sample 12
- Remote database access

- Project management function

COBOL statements used
The CALL, DISPLAY, IF, and PERFORM statements are used.

Embedded SQL statements (host variable with multiple rows specified, host variable with a table specified, embedded exception
declaration, CONNECT statement, cursor declaration, OPEN statement, FETCH statement, SELECT statement, DELETE statement,
UPDATE statement, CLOSE statement, COMMIT statement, ROLLBACK statement, and DISCONNECT statement) are used.

Prerequisite to Executing the Program

In order to execute this sample, the DBMS product which can be connected via ODBC is installed in server side and make the table named
STOCK for the database connected by default.

Make the STOCK table in the format as following.

GNO GOODS QOH WHNO
Binary integer Fixed-length character Binary integer Binary integer
4 digits 10 bytes 9 digits 4 digits

Store the data items shown below in the STOCK table.

GNO GOODS QOH WHNO
110 TELEVISION 85 2
111 TELEVISION 90 2
123 REFRIGERATOR 60 1
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GNO GOODS QOH WHNO
124 REFRIGERATOR 75 1
137 RADIO 150 2
138 RADIO 200 2
140 CASSETTE DECK 120 2
141 CASSETTE DECK 80 2
200 AIR CONDITIONER 4 1
201 AIR CONDITIONER 15 1
212 TELEVISION 0 2
215 VIDEO 5 2
226 REFRIGERATOR 8 1
227 REFRIGERATOR 15 1
240 CASSETTE DECK 25 2
243 CASSETTE DECK 14 2
351 CASSETTE TAPE 2500 2
380 SHAVER 870 3
390 DRIER 540 3

Then create the ODBC information file using SQLODBCS.EXE.

1.11.1 Using NetCOBOL Studio

Compiling and Linking the Program
1. NetCOBOL Studio is started by specifying the workspace created for the sample program. See "Preparing the workspace".
2. In the Dependency view, select the SAMPLE12 project.

If there is no SAMPLE12 project, import the project of sample program into the NetCOBOL Studio workspace. See "Importing
sample program project into NetCOBOL Studio workspace".

3. The structure of the project is as follows.

¥ De.. % |[ESr. W Na. — O
| E
v = SAMPLE12 *
v (Bl Source Files
5t S5amplel2.cob
@2 Linking Files
v (L Other Files
[= .settings
= buwildzxml
COBOL25.CER
= Makefile
[m] SAMPLE12.exe
=| Samplel2 OEB)
SAMPLE12.pdb
= Samplel2.5VD A

&y
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The build is executed immediately after importing the project when an automatic build is set. In this case, the file (. EXE . OBJ etc.)
is generated after the build is displayed in "Other Files". It is set to automatic build by default.

4. On the Project menu, click Build Project when SAMPLE12.EXE is not created in "Other Files" (When an automatic build is not
executed), click Build Project On the Project menu.

The project is built, and then SAMPLE12.EXE is created.

Setting Runtime Environment Information

1. Start Run-time Environment Setup Tool. The Run-time Environment Setup Tool dialog appears.

B Run-time Environment Setup Tool — X

File Envircnment Help

File Mame
C:AMetCOBOL Studio'wworkzpacetSAMPLET2ACOBOLES.CEBR

Thread Mode
{®) Single Thread () Multi Thread

Environment Y ariables

S ection: Comman  Section

@ODBC_Inf= DEMSACS INF
RESULT=A\RESULT.THT

Y arable Mame:
[ v

W ariable W alue:

| | < >

Set Delete Apply

2. On the File menu, click Open. The Select Runtime Initialization file dialog box appears.
3. Select COBOLS85.CBR in the folder that contains the executable program (SAMPLE12.EXE).
4. On the Common tab, enter data as shown below:
- Specify an ODBC information file name in @ODBC_Inf (ODBC information file specification).
- Specify a file to save the DISPLAY statement output result in environment variable RESULT.
5. Click Apply. The data is saved in the object initialization file.

6. On the File menu, click Exit to terminate the run-time environment setup tool.

Executing the Program
1. Inthe Dependency view, select SAMPLE12 project.
2. On the Run menu, click Run As > COBOL Application.
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Execution result
The following is displayed in the COBOL console window. (Console: SAMPLE12)

SUCCESSFUL CONNECTION WITH DATABASE.

RECEIVE THE PRODUCT NUMBER WHOSE PRODUCT NAME 1S "TELEVISION*
SET STOCKS OF THE FOLLOWING PROCUCTS DECREASING 10
TELEVISION -> +0110
TELEVISION -> +0111
TELEVISION -> +0212
DELETE THE ROW WHICH HAS PRODUCT NAME 1S "RADIO". *"SHAVER®" OR "DRIER".

PROGRAM END

The contents of the STOCK table before and after the operation are output in the format shown below to the file assigned to environment
variable RESULT.

Contents before processing

No.01:
Product number = +0110
Product name = TELEVISION
Stock quantity = +000000085
Warehouse number = +0002

No.19:
Product number = +0390
Product name = DRIVER
Stock quantity = +000000540
Warehouse number = +0003

There are 19 data in total.
Contents after processing

No.01:
Product number = +0110
Product name = TELEVISION
Stock quantity = +000000075
Warehouse number = +0002

No.15:
Product number = +0351
Product name = CASSETTE TAPE
Stock quantity = +000002500
Warehouse number = +0002

There are 15 data items in total.

1.11.2 Using MAKE file

Compiling and Linking the Program

Open a command prompt. Compile and link the sample program using the following command.

C:\COBOL\Samples\COBOL\Samplel2>nmake

Compilation of the sample program is now complete. Verify that SAMPLE12.EXE was created in the same folder in which the sample
program is stored.

Setting Runtime Environment Information
Same as "1.11.1 Using NetCOBOL Studio".

Executing the Program
Execute SAMPLE12.EXE from a command prompt or from Windows Explorer.
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Execution result
Same as "1.11.1 Using NetCOBOL Studio".

1.12 Sample 13: Calling COBOL from Visual Basic

Sample 13 illustrates a COBOL DLL created with NetCOBOL that is called from a Visual Basic® application.

This sample program requires the following:

- Microsoft .NET Framework 4 or later

Overview

At initialization, the Visual Basic application calls a subroutine JMPCINT?2 that initializes the COBOL runtime environment, ready for a
call to a COBOL program.

The Visual Basic form shows a simple equation in which the user enters two numbers on either side of a multiply "*" sign and presses the

="button. The Visual Basic application passes the two values to the COBOL application, which does the multiplication and returns the
result for the Visual Basic code to display.

The Visual Basic application's termination code calls the IMPCINT3 subroutine to close the COBOL runtime environment.

Files Included in Sample 13
- SAMPLE13.COB (COBOL source program)
- VBProj\app.config
- VBProj\AssemblyInfo.vb (Visual Basic Assembly information file)
- VBProj\Samplel13.Designer.vb (Visual Basic Designer code file)
- VBProj\Samplel3.resX (Visual Basic XM resource file)
- VBProj\sample13.sin (Visual Basic solution file)
- VBProj\Samplel13.vb (Visual Basic source code file)
- VBProj\sample13.vbproj (Visual Basic project file)
- MAKEFILE_VB
- MAKEFILE_COBOL
- COBOLS85.CBR

Subroutines used in Sample 13
These subroutines are used by Visual Basic to initialize and terminate the COBOL runtime system.
- JMPCINT2
- JMPCINT3

1.12.1 Using NetCOBOL Studio

Compiling and Linking the Visual Basic Program

Open a command prompt. Compile and link the sample program using the following command.

C:\COBOL\Samples\COBOL\Samplel3>nmake -f MakeFile_VB

Compilation of the sample program is now complete. Verify that SAMPLE13.EXE was created.

In the example above, SAMPLE13.EXE is stored as shown below.
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C:\COBOL\Samples\COBOL\SAMPLE13\VBProj\bin\SAMPLE13_EXE

Compiling and Linking the COBOL Program
1. NetCOBOL Studio is started by specifying the workspace created for the sample program. See "Preparing the workspace".
2. In the Dependency view, select the SAMPLE13 project.

If there is no SAMPLE13 project, import the project for the sample program into the NetCOBOL Studio workspace. See "Importing
sample program project into NetCOBOL Studio workspace".

3. The structure of the project is as follows.

¥ De.. B7|EEStn. w Na.. — O

| E
v = SAMPLE13 ~
v (Bl Source Files
Samplel3.cob
@2 Linking Files
w (2L Other Files
[= .settings
= VBProj
= build.ml
COBOLS5.CBR
= Makefile_COBOL
Malkefile_VE
SAMPLET3.dII
SAMPLET3.exp
SAMPLET3.ib
Samplel3.0B)
SAMPLE13.pdb
Samplel13.5VD W

15

The build is executed immediately after importing the project when an automatic build is set. In this case, the file (. EXE . OBJ etc.)
is generated after the build is displayed in "Other Files". It is set to automatic build by default.

4. On the Project menu, click Build Project when SAMPLE13.DLL is not created in “Other Files" (When an automatic build is not
executed).

The project is built, and then SAMPLE13.DLL is created.

Executing the Program
1. Confirm that SAMPLE13.DLL is in a current folder or in the folder set to environment variable PATH.

2. In the Dependency view, select SAMPLE13 project.
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3. On the Run menu, click Run As > COBOL Application. The Executable File Selection dialog appears.

@ Executable File Selection oo

Specify the executable file name for inveoking the application

Executable file name; | | Browse...

oK Cancel

4. Enter the following file as an "Executable file name", and click OK.

C:\COBOL\Samples\COBOL\SAMPLE13\VBProj\bin\x64\Release\SAMPLE13_EXE

Execution result

1. The simple calculator window used by this application is shown in the following figure.

gt Sample 13

|| * = ||

Clear

Enter 2 numbers of 4 digits or less. Click on the = button to call

the COBOL DLL that calculates the result. The result will be
displayed to the right.

End

2. To use this form:

Enter a number (up to 4 digits) in each text box to the left of the "=" button.

Press the "=" button.

3. Visual Basic calls COBOL to perform the calculation and format the answer. Visual Basic then displays the answer to the right of
the "=" button.

1.12.2 Using MAKE file

Compiling and Linking the Visual Basic Program
Same as "1.12.1 Using NetCOBOL Studio".

Compiling and Linking the COBOL Program

Open a command prompt. Compile and link the sample program using the following command.

C:\COBOL\Samples\COBOL\Samplel3>nmake -f Makefile_COBOL
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Compilation of the sample program is now complete. Verify that SAMPLE13.DLL was created in the same folder in which the sample
program is stored.

Executing the Program
Confirm that the SAMPLE13.DLL file is in a current folder or in the folder set to environment variable PATH.

Execute SAMPLE13.EXE from a command prompt or from Windows Explorer.

Execution result
Same as "1.12.1 Using NetCOBOL Studio".

1.13 Sample 14: Visual Basic calling COBOL -Simple ATM Example

Sample 14 demonstrates Visual Basic calling COBOL by using a simple automatic teller machine (ATM) bank account handling example.

This sample program requires the following:

- Microsoft .NET Framework 4 or later

Overview

This sample program performs the following account functions:
- Opening a new account
- Depositing funds
- Withdrawing funds
The account data, comprising account number, PIN number, name and balance, is saved in an indexed file.

The structure of the indexed file is:

Account number 9(5) *> (This is the primary record key.)

Password 9(4)
Name X(12)
Deposit 9(9)

When functions are requested from the "ATM terminal” (user screens), the record data for the account in the indexed file is updated.

Files Included in Sample 14
- VBProj\app.config
- VBProj\AssemblyInfo.vb (Visual Basic Assembly information file)

- VBProj\Error_h.Designer.vb (Visual Basic Designer code file)
Error message box.

- VBProj\Error_h.resX (Visual Basic XML resource file)
Error message box.

- VBProj\Error_h.vb (Visual Basic source code file)
Error message box.

- VBProj\Nyukin.Designer.vb (Visual Basic Designer code file)
Dialog for performing a deposit.

- VBProj\Nyukin.resX (Visual Basic XML resource file)
Dialog for performing a deposit.

- VBProj\Nyukin.vb (Visual Basic source code file)
Dialog for performing a deposit.

- VBProj\Samplel4.sin (Visual Basic solution file)
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VBProj\Sample14.vbproj (Visual Basic project file)
VBProj\Sample14 bas.vb (Visual Basic standard module)
VBProj\Samplel14_frm.Designer.vb (Visual Basic Designer code file)
VBProj\Samplel4_frm.resX (Visual Basic XML resource file)
VBProj\Samplel4_frm.vb (Visual Basic source code file)

VBProj\Sele.Designer.vb (Visual Basic Designer code file)
Account-handling dialog - shows account number, name and balance, and offers the withdrawal and deposit functions.

VBProj\Sele.resX (Visual Basic XML resource file)
Account-handling dialog - shows account number, name and balance, and offers the withdrawal and deposit functions.

VBProj\Sele.vb (Visual Basic source code file)
Account-handling dialog - shows account number, name and balance, and offers the withdrawal and deposit functions.

VBProj\Sinki.Designer.vb (Visual Basic Designer code file)
Dialog for opening a new account.

VBProj\Sinki.resX (Visual Basic XML resource file)
Dialog for opening a new account.

VBProj\Sinki.vb (Visual Basic source code file)
Dialog for opening a new account.

VBProj\Sinkichk.Designer.vb (Visual Basic Designer code file)
Displays the assigned account number for a new account.

VBProj\Sinkichk.resX (Visual Basic XML resource file)
Displays the assigned account number for a new account.

VBProj\Sinkichk.vb (Visual Basic source code file)
Displays the assigned account number for a new account.

VBProj\Syukin.Designer.vb (Visual Basic Designer code file)
Dialog for performing a withdrawal.

VBProj\Syukin.resX (Visual Basic XML resource file)
Dialog for performing a withdrawal.

VBProj\Syukin.vb (Visual Basic source code file)
Dialog for performing a withdrawal.

K_KEN.COB (COBOL source program)
Retrieves accounts by account number.

K_SIN.COB (COBOL source program)
Opens a new account.

K_NYU.COB (COBOL source program)
Adds money deposited to an account.

K_SYU.COB (COBOL source program)
Subtracts money withdrawn from an account.

MAKEFILE_VB
MakeFile for Visual Basic program

MAKEFILE_COBOL
MakeFile for COBOL Program

COBOLS85.CBR
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Processing Overview

The Visual Basic application starts, and subroutine JIMPCINT2, which initializes the COBOL runtime system, is called when the main form
is loaded.

The Visual Basic forms manage the interface with the user - accepting input data, transaction requests and displaying output data and
messages. COBOL programs are called to manage the account data in the indexed file.

When the Visual Basic application is closed, it calls subroutine JMPCINT3, which terminates the COBOL runtime.

Figure A.55 shows the structure of the application:

“izual Basic copaL
System

sampleld.ene

COBOL initiglization processing JiP CINTZ Initializ ation procedure subroudtine
|
Processing opening of 3 new account FAocount number retrieval processing
FAocount retriewal processing Pocount retiewval processing
iithdrawal proce ssing Processing for debiting money
Dep osit processing Processing for depositing money
|
|
COBOLtermination processing Ml P CINT3 Termination subroutine

COBOL Statements used in Sample 14
The MOVE, IF, PERFORM, COMPUTE, OPEN, READ, WRITE, REWRITE, CLOSE and EXIT statements are used.

COBOL Runtime System Subroutines
The following routines are used to initialize and terminate the COBOL run-time system.
- JMPCINT2
- JMPCINT3

1.13.1 Using NetCOBOL Studio

Compiling and Linking the Visual Basic Program

Open a command prompt. Compile and link the sample program using the following command.

C:\COBOL\Samples\COBOL\Samplel4>nmake -f MakeFile_VB

Compilation of the sample program is now complete. Verify that SAMPLE14.EXE was created.
In the example above, SAMPLE14.EXE is stored as shown below.

C:\COBOL\Samp1es\COBOL\SAMPLE14\VBProj\bin\x64\Release\SAMPLE14_EXE

Compiling and Linking the COBOL Program

1. NetCOBOL Studio is started by specifying the workspace created for the sample program. See "Preparing the workspace".
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2. In the Dependency view, select the SAMPLE14 project.

If there is no SAMPLE14 project, import the project for the sample program into the NetCOBOL Studio workspace. See "Importing
sample program project into NetCOBOL Studio workspace".

3. The structure of the project is as follows.

H De.. 2 8ESt. = Na.. = O

v 2 SAMPLE14 ~
~ (Bl Source Files
K_syu.cob
K_ken.cob
K_nyu.cohb
K_sin.cob
@2 Linking Files
v (L Other Files
[= .settings
[== VBProj
2 buildxml
COBOLAS.CBR
K_KEM.dlI
K_KEM.exp
K_KEM.lib
K_ken.OBJ
K_KEM.pdb
K_ken.5VD
K_nyu.OB)
K_nyu.SVD
K_sin.QBJ
K_sinSVD
K_syu.OBJ
K_syu.5VD
Makefile_COBOL
Makefile_VB ¥

The build is executed immediately after importing the project when an automatic build is set. In this case, the file (. EXE . OBJ etc.)
is generated after the build is displayed in "Other files". It is set to automatic build by default.

4. Onthe Project menu, click Build Project when K_KEN.DLL is not created in “Other Files" (When an automatic build is not executed).
The project is built, and then K_KEN.DLL is created.

Executing the Program
1. Confirm that K_KEN.DLL is in a current folder or in the folder set to environment variable PATH.

2. In the Dependency view, select SAMPLE14 project.
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3. On the Run menu, click Run As > COBOL Application. The Executable File Selection dialog appears.

@ Executable File Selection oo

Specify the executable file name for inveoking the application

Executable file name; | | Browse...

QK Cancel

4. Enter the following file as an "Executable file name", and click OK.

C:\COBOL\Samples\COBOL\SAMPLE14\VBProj\bin\SAMPLE14 .EXE

Execution result

The Samplel4 dialog box

g5l Sample 14 x

Acount number ||

PIM number |

Mew
Account?

oK ‘ End ‘

1. Click New Account?. The New Account Information dialog appears.

2. Open a new account. Type in a name (such as Smith), an amount (such as 10000) and a PIN number (such as 1234). Click OK.
A dialog displays the assigned account number.

3. To terminate the application, click End.

The New Account Information dialog box

g5 Mew Account Information ot

Name ||

Depasit amount |

PIMN number |

OK | Cancel

1. Typeinaname, anamount and a PIN number. Click OK. A new account is made and the account number assignment dialog box
is displayed. If an error occurs, an error dialog box is displayed.

2. To cancel new account creation, click Cancel.
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The Account Number Assignment dialog box

ot Account Mumber Assignment

Mame |Smith
Account number |DDD[}3
OK

1. Confirm the account number and click OK. The Sample14 dialog box is displayed:

The Withdrawal or Deposit dialog box

ol Withdrawal or Deposit ot

Account number

Mame

Amount

Withdrawal

10003

|Smith

110000

Cancel

Deposit |

1. To withdraw, click Withdrawal.
2. To deposit, click Deposit.
3. To interrupt the application, click Cancel.

The Deposit dialog box

ol Deposit 3
Account-number |DD[}3
Mame |Smith
Current Balance | 10000
Deposit amt. |
DK | Cancel

1. Type in a deposit amount and click OK. The Withdrawal or Deposit dialog box appears.
If an error occurs, an ERROR message box is displayed.

1. To interrupt the application, click the Cancel.
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The Withdrawal dialog box

o=l Withdrawal oo

Account number |DD[}3

Mame |Smith

Current Balance | 10000

Withdrawal amt. ||

OK | Cancel

T

1. Type in a withdrawal amount and click OK. The Withdrawal or Deposit dialog box appears. If an error occurs, an ERROR
message box is displayed.

2. To interrupt the application, click Cancel.

The ERROR window

al ERROR %

The account number was not
entered.

oK

1. To confirm the error message, click OK.

1.13.2 Using MAKE file

Compiling and Linking the Program

Open a command prompt. Compile and link the sample program using the following command.

C:\COBOL\Samples\COBOL\Samplel4>nmake -f MakeFile_COBOL

Compilation of the sample program is now complete. Verify that K_KEN.DLL and SAMPLE14.EXE were created in the same folder in
which the sample program is stored.

Executing the Program
Confirm that K_KEN.DLL is in a current folder or in the folder set to environment variable PATH.

Execute SAMPLE14.EXE from a command prompt or from Windows Explorer.

Execution result
Same as "1.13.1 Using NetCOBOL Studio".

1.14 Sample 15: Basic Object-Oriented Programming

This program illustrates basic object-oriented programming functions including encapsulation, object generation and method invocation.
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Overview

In the sample program, three employee objects are generated. After an object has been generated using the "NEW" method, the "Data-Set"
method is invoked to set the data.

Although all of the employee objects have the same form, they have different data (employee numbers, names, departments and sections,
and address information). Address information containing postal codes and addresses also belongs to an object.

Upon input of an employee number on the screen, the appropriate "Data-Display” method in the employee object is invoked, and the
employee information in the object is displayed.

The employee object invokes the "Data-Get" method of the associated address object to acquire the address information.

The employee object consists of three pieces of data and an object reference to an address object. The structure of the object is transparent
to the main program user. However, the user must understand the "Data-Set" and "Data-Display" methods.

The encapsulation of data completely masks the information in the object.

Files Included in Sample 15
- MAIN.COB (COBOL source program)

MEMBER.COB (COBOL source program)

ADDRESS.COB (COBOL source program)
MAKEFILE

COBOLS85.CBR

COBOL Functions used in Sample 15
- Object-oriented programming function
- Class definition (Encapsulation)
- Object generation
- Method invocation

- Project management

Object-Oriented Syntax used in Sample 15
- INVOKE and SET statements
- REPOSITORY paragraph

- Class, object and method definitions

1.14.1 Using NetCOBOL Studio

Compiling and Linking the Program
1. NetCOBOL Studio is started by specifying the workspace created for the sample program. See "Preparing the workspace".
2. In the Dependency view, select the SAMPLEL5 project.

If there is no SAMPLE15 project, import the project for the sample program into the NetCOBOL Studio workspace. See "Importing
sample program project into NetCOBOL Studio workspace".
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3. The structure of the project is as follows.

¥ De. 2 |8ESrn. . MNa. — O

v = SAMPLE15 "
v (Bl Source Files
Address.cob
Eii) Main.cob
Mernber.cob
@2 Linking Files
v [[ZL Other Files
= .settings
ff] ADDR.rep
Address,0B)
Address.5VD
2 buildxml
COBOLS5.CEBR
[f] EMPLOYEE.rep
[mz] MAIN.exe
= MAIMN.exp
MAIM. ik
Main. OBl
MAIM. pdb
Main.5VD
Makefile
Member.OBJ
Member.5VD b

The build is executed immediately after importing the project when an automatic build is set. In this case, the file (. EXE . OBJ etc.)
is generated after the build is displayed in "Other Files". It is set to automatic build by default.

4. Onthe Project menu, click Build Project when MAIN.EXE is not created in "Other Files" (When an automatic build is not executed).

The project is built, and then MAIN.EXE is created.

Executing the Program
1. Inthe Dependency view, select SAMPLEL5 project.
2. On the Run menu, click Run As > COBOL Application. The Executable File Selection dialog appears.

Execution result

Sample 15 requires no special execution environment information to be set.

Please enter the employee number(l or 2 or 3)

The interface is very basic - simply enter an employee number 1, 2 or 3 to display details for that employee. After the details are displayed,
enter N to terminate or Y to continue.

Please enter the employee number(l or 2 or 3)

1

NO.---NAME---——————————— BELONGING--------- POST----ADDR-————— === —m o
0001 James Smith Language group 411-0007 2929 Park Avenue, New York, N
Y
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Do you to end?(Y/N)

1.14.2 Using MAKE file

Compiling and Linking the Program

Open a command prompt. Compile and link the sample program using the following command.

C:\COBOL\Samples\COBOL\Samplel5>nmake

Compilation of the sample program is now complete. Verify that MAIN.EXE was created in the same folder in which the sample program
is stored.

Executing the Program

Execute MAIN.EXE from a command prompt or from Windows Explorer.

Execution result
Same as "1.14.1 Using NetCOBOL Studio".

1.15 Sample 16: Collection Class (Class Library)

Sample 16 demonstrates the use of a collection class for creating a class library.

This sample can be used to create a class library in an actual program.

This sample covers only the basic operation. An easy-to-use class library can be created by modifying and changing this sample.

Overview
A collection class is the generic name of a class that handles a set of objects — it is used to collectively handle and store many objects.
This sample covers the following classes:
- Collect (Collection)
- Dict (Dictionary)
- List (List)

Class Layers

The following diagram shows the relationships between the class layers in Sample 16.
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FIBASE

Inherited

Collect

CollectionSize-Get
FirstElement-Get
MextElement-Get
PreviousElement-Get

Inherited
List Dict
Element-Get Element-Get
Element-Insert Element-PutAt
Element-PutAt Firstkey-Get
Element-PutlLast Lastiey-Get
ElementMo-Get Remove-All
LastElement-Get Remove-At
Remove-All
Remove-At

g._z] Note

In addition to the above classes, Sample 16 also includes the classes BinaryTree-Class, DictionaryNode-Class and ListNode-Class. These
classes, which are used inside the List and Dict classes, are transparent to the collection class user, and are not explained here.

Collect Class
This is the highest collection class. All collection classes inherit this class.
Collect is an abstract class, and does not create any objects.

Since this class inherits the FIBASE class, all the methods defined in the FIBASE class can be used.

Definitions

CLASS-ID. Collect INHERITS FJBASE.
ENVIRONMENT DIVISION.
CONFIGURATION SECTION.
REPOSITORY.
CLASS FJBASE.

OBJECT.
PROCEDURE DIVISION.
METHOD-ID. CollectionSize-Get.
METHOD-ID. FirstElement-Get.
METHOD-ID. NextElement-Get.
METHOD-ID. PreviousElement-Get.
END OBJECT.

END CLASS Collect.
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CollectionSize-Get method
This method ascertains the number of elements in a set.
Parameter
None

Return value

PIC 9(8) BINARY

Returns the number of elements in a set.
FirstElement-Get method
This method returns the first element in a set.
Parameter
None

Return value

USAGE OBJECT REFERENCE

Returns the first element in a set. If no element exists, NULL is returned.
NextElement-Get method
This method returns the element following the one currently pointed to.
Parameter
None

Return value

USAGE OBJECT REFERENCE

Returns the element following the one currently pointed to. If no following element exists, NULL is returned.
PreviousElement-Get method
This method returns the element immediately preceding the one currently pointed to.
Parameter
None

Return value

USAGE OBJECT REFERENCE

Returns the element immediately preceding the one currently pointed to. If no preceding element exists, NULL is returned.

Dict Class

This class has the following features:

- Each element has a key.

The key value is unique.

A key can be used for retrieval.

The key is used for ordering.
Since this class inherits from the Collect class, all the methods defined in Collect can be used as well.

Definitions

CLASS-ID. Dict [INHERITS Collect.
ENVIRONMENT DIVISION.
CONFIGURATION SECTION.
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REPOSITORY .
CLASS Collect.

OBJECT.
PROCEDURE DIVISION.
METHOD-ID. Element-Get.
METHOD-ID. Element-PutAt.
METHOD-ID. FirstKey-Get.
METHOD-ID. LastKey-Get.
METHOD-ID. Remove-All.
METHOD-1ID. Remove-At.
END OBJECT.

END CLASS Dict.

Element-Get method
This method returns elements for a specified key.
Parameter

Key:

PIC X(10)

Specifies a key value for an element to be returned.

Return value

USAGE OBJECT REFERENCE

Returns an element for a specified key if it is found, and returns NULL if it is not found.
Element-PutAt method
This method adds an element for a specified key. If an element with the same key already exists, it is replaced by the new element.
Parameters

Key:

PIC X(10)

Specifies the key value of the element to be added or replaced.

Element:

USAGE OBJECT REFERENCE

Specifies the element to be added or replaced.
Return value
None
FirstKey-Get method
This method determines the key value for the first element.
Parameter
None

Return value

PIC X(10)

Returns the key value for the first element. If the number of elements is 0, or if the key for the first element is a blank, a blank is
returned.

LastKey-Get method

This method determines the key value for the last element.
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Parameter
None

Return value

PIC X(10)

Returns the key value for the last element. If the number of elements is 0, or if the key for the last element is a blank, a blank is
returned.

Remove-All method
This method deletes all elements contained in a set.
Parameter
None
Return value
None
Remove-At method
This method deletes an element for a specified key.
Parameter

Key:

PIC X(10)

Specifies the key value for the element to be deleted.
Return value

None

List Class
This class has the following features:
- Elements are arranged in a certain order.
- Allows duplicate elements.
Since this class inherits from the Collect class, all of the methods defined in the Collect class can be used as well.

Definitions

CLASS-ID. List [INHERITS Collect.
ENVIRONMENT DIVISION.
CONFIGURATION SECTION.
REPOSITORY .
CLASS Collect.

OBJECT.
PROCEDURE DIVISION.
METHOD-ID. Element-Get.
METHOD-ID. Element-Insert.
METHOD-ID. Element-PutAt.
METHOD-ID. Element-PutLast.
METHOD-ID. ElementNo-Get.
METHOD-ID. LastElement-Get.
METHOD-ID. Remove-All.
METHOD-ID. Remove-At.
END OBJECT.

END CLASS List.

Element-Get method

This method returns the element at a specified location (index).
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Parameter

Index:

PIC 9(8) BINARY

Specifies the location of the element to be returned by an integer starting at 1.

Return value

USAGE OBJECT REFERENCE

Returns the specified element. If no element exists at the specified location, NULL is returned.
Element-Insert method
This method adds an element at the specified location (index).
Parameters

Index:

PIC 9(8) BINARY

Specifies the location at which the element is to be added by an integer beginning with 1.
If a value greater than the number of elements plus 1 is specified, no element is added.

Element:

USAGE OBJECT REFERENCE

Specifies the element to be added.

Return value

PIC 9(8) BINARY

Returns the location at which the element was added by an integer beginning with 1. If no element is added, 0 is returned.
Element-PutAt method
This method replaces the element at the specified location (index).
Parameters

Index:

PIC 9(8) BINARY

Specifies the location of the element to be replaced by an integer beginning with 1. If a value greater than the number of elements
is specified, no element is replaced.

Element:

USAGE OBJECT REFERENCE

Specifies the element to be replaced.

Return value
Returns the location of the replaced element using an integer beginning with 1.
If no element has been replaced, 0 is returned.

Element-PutLast method

This method adds an element after the last element.

Parameter
Element:

Specifies the element to be added.
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Return value
None
ElementNo-Get method
This method checks the location (index) of a specified element.
Parameter
Element:
Specifies the element whose location is checked.

Return value

PIC 9(8) BINARY

Returns the location of the element using an integer beginning with 1.
If the specified element is not found, O is returned.
If duplicate elements exist, the first found location is returned.
LastElement-Get method
This method returns the last element.
Parameter
None

Return value

USAGE OBJECT REFERENCE

Returns the last element. If the number of elements is 0, NULL is returned.
Remove-All method
This method deletes all the elements contained in a set.
Parameter
None
Return value
None
Remove-At method
This method deletes the element at the specified location (index).
Parameter

Index:

PIC 9(8) BINARY

Specifies the location of the element to be deleted using an integer starting at 1. If a value greater than the number of elements
is specified, no element is deleted.

Return value

Returns the location of the deleted element using an integer beginning with 1. If no element has been deleted, 0 is returned.

Programs and Files in Sample 16

COLLECT.COB (COBOL source program)

DICT.COB (COBOL source program)

LIST.COB (COBOL source program)

BIN_TREE.COB (COBOL source program)
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D_NODE.COB (COBOL source program)

L_NODE.COB (COBOL source program)

MAKEFILE
COBOLS85.CBR

COBOL Functions Used in Sample 16
- Object-oriented programming functions
- Class definition (Encapsulation)
- Inheritance
- Object creation

- Method calling

Object-Oriented Syntax used in Sample 16
- INVOKE and SET statements
- Object properties

- Method calling

REPOSITORY paragraphs

- Class, object and method definitions

1.15.1 Using NetCOBOL Studio

Compiling and Linking the Program
1. NetCOBOL Studio is started by specifying the workspace made for the sample program. See "Preparing the workspace".
2. In the Dependency view, select the SAMPLE16 project.

If there is no SAMPLE16 project, import the project for the sample program into the NetCOBOL Studio workspace. See "Importing
sample program project into NetCOBOL Studio workspace".
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3. The structure of the project is as follows.

H De.. 22 8EStn. = Na.. = O

v 2 SAMPLE16 ~
v (Bl Source Files
Collect.cob
D_Mode.cob
Dict.cob
L_Mode.cob
List.cob
Bin_Tree.cob
@2 Linking Files
v (L Other Files
[= .settings
|Z| Bin_Tree.QEl
=| Bin_Tree.5VD
@ BINARYTREE-CLASS.rep
E buildxml
COBOL25.CBR
COLLECT.dIl
COLLECT.exp
COLLECT.lib
Collect. OB
COLLECT.pdb
COLLECT.rep
Collect.5VD
D_Mode OBl
D_ModeSWD
Dict.OB)
DICT.rep
Dict.5VD
DICTIOMARYMNODE-CLASS
L_Mode OBJ
=| L_MNode.SVD
List.OBJ
I5T.rep
List.5VD
LISTMNODE-CLASS.rep
Makefile b

El'm' El'm' [E) o) e @:-.n' TR T TR T

—

) £ i (5

The build is executed immediately after importing the project when an automatic build is set. In this case, the file (. EXE . OBJ etc.)
is generated after the build is displayed in "Other Files". It is set to automatic build by default.

4. When compiling terminates, the following files are created.

On the Project menu, click Build Project when the following files are not created in "Other Files" (When an automatic build is not
executed).

- COLLECT.DLL
- COLLECT.LIB
- COLLECT.REP
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- DICT.REP
- LIST.REP

gn Note

Some other files are also created, but they are not required when the class library is used.

Using the Class Library

When the sample class library to be used is installed in a program, the following files are required:

For Compiling or Linking

COLLECT.LIB (Import library)

COLLECT.REP (Repository library)

DICT.REP (Repository file)

LIST.REP (Repository file)

Install the above files to be used into a project that uses the class library.

For Executing
- COLLECT.DLL (DLL file)

1.15.2 Using MAKE file

Compiling and Linking the Program

Open a command prompt. Compile and link the sample program using the following command.

C:\COBOL\Samples\COBOL\Samplel6>nmake

When compiling terminates, the following files are created.

COLLECT.DLL

COLLECT.LIB
COLLECT.REP

DICT.REP

LIST.REP

L:n Note

Some other files are also created, but they are not required when the class library is used.

Using the Class Library

When the sample class library to be used is installed in a program, the following files are required:

For Compiling or Linking
- COLLECT.LIB (Import library)
- COLLECT.REP (Repository library)
- DICT.REP (Repository file)
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- LIST.REP (Repository file)

Install the above files to be used into a project that uses the class library.

For Executing
- COLLECT.DLL (DLL file)

1.16 Sample 31: Windows System Function Call

Sample 31 demonstrates how to invoke a Windows system function - for this example, a call to create a message box.

Overview

Sample 31 calls the Windows system function "MessageBoxA" to display a message in a message box with YES, NO and Cancel buttons.
(Note that an "A" needs to be appended to the function call when the function call contains a character string parameter and you are working
in ASCII, as opposed to Unicode data, where the suffix is "W".)

The message box returns a value indicating which button was pressed. This value is returned in the data item specified in the RETURNING
phrase.

In a batch file, this return value can be accessed by via ERRORLEVEL, as demonstrated in SAMPLE31.BAT.

@echo off
set msg=Return the value depending on return code from the MessageBox.
:START
echo %msg%
set msg=Selected the ''Cancel', Restart again.
start /w MsgBox.exe
@rem If return code is over 9999 then call the COBOL program again.
if errorlevel 9999 goto START
@rem If return code is over 9 then selected the *"No'".
it errorlevel 9 goto NG
echo Selected the "Yes".
goto END
NG
echo Selected the *"No™.
“END
set msg=

Files Included in Sample 31
- MSGBOX.COB (COBOL source program)

MAKEFILE

SAMPLE31.BAT (Batch file for start)
COBOLS85.CBR

COBOL Statements Used
- Method of calling C program from COBOL program
- Parameter transfer BY VALUE

RETURNING phrase of CALL statement
- Special register PROGRAM-STATUS (RETURN-CODE)
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Qn Note

- Most Windows system functions (and C routines in general) require that strings be terminated with a null byte (X"00" or LOW-
VALUE). This sample shows how you can place these bytes using reference modification.

- The Windows system function names are case sensitive, so be sure to get the case correct, as in "MessageBoxA". Specify compiler
option "NOALPHAL" or "ALPHAL(WORD)" to ensure that the COBOL system uses mixed case for the function name.

1.16.1 Using NetCOBOL Studio

Compiling and Linking the Program
1. NetCOBOL Studio is started by specifying the workspace created for the sample program. See "Preparing the workspace".
2. In the Dependency view, select the SAMPLES31 project.

If there is no SAMPLE31 project, import the project for the sample program into the NetCOBOL Studio workspace. See "Importing
sample program project into NetCOBOL Studio workspace".

3. The structure of the project is as follows.

¥ De.. % [§ESir. @ MNa. — O
| E
v [ SAMPLE31 ”
~ [El Source Files
5] Msgbox.cob
@2 Linking Files
v (L Other Files
[= .settings
= buwild.xml
COBOLA5.CEBR
=| Makefile
[E] MsgBox.exe
=| Msgbox.OBJ
=| MsgBox.pdb
=| Msghbox5VD
[2] Sample3l.bat W

i

4. The build is executed immediately after importing the project when an automatic build is set. In this case, the file (. EXE . OBJ etc.)
is generated after the build is displayed in "Other Files". It is set to automatic build by default.

The properties dialog box is displayed.
5. Link USER32.LIB to use "MessageBoxA" of the Window s system function in this exercise.

To confirm linked libraries, select the SAMPLE31 project from the Dependency view, and then select Property... from the context
menu. The "Properties for SAMPLE31" dialog box is displayed.
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6. In the left pane, select Build. The Build page appears. And, select the Link Options tab.

[ Properties for SAMPLES] O ¥
Lype fier test Build T
R
E:s;un:c ] Enahble project specific sestings
» Build Toals Compiler Options  Librasy Mames  Linker Options
File Content
Project References Linker apilsars;
Femete Development ‘C\Program Files (xBE\Windows Eitsh B 1 Libywins G Pium'psdi User 32 Lib Add..,
Run/Debug Settings
Taript Change...
Rermoye
Bemcve All
Up
Dowm
Use C funciions
C Run-time Librang Mame
| | Erowse...

DLL Entry Object

Far COBOL program only Fer linking with non-COB0L program

[#] Output debugging jnfomnation

Cher option=

® I

The storage place of USER32.LIB is set as follows. Please change the setting according to the installation environment of Windows
SDK.

${NetCOBOL}\User32.Lib

7. On the Project menu, click Build Project when MSGBOX.EXE is not created in "Other Files" (When an automatic build is not
executed).

The project is built, and then MSGBOX.EXE is created

Executing the Program

1. Open a command prompt, change directories to the SAMPLE31 folder, and execute SAMPLE31.BAT.

c:\NetCOBOL Studio\workspace\SAMPLE31>sample3l.bat
Return the value depending on return code from the MessageBox

2. The following message boxes are displayed. Click one of the buttons.

From COBOL: TITLE X

It is a message box.

Mo Cancel
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3. The COBOL program detects which button was pressed and indicates such by displaying a message.

c:\NetCOBOL Studio\workspace\SAMPLE31>sample3l.bat
Return the value depending on return code from the MessageBox
Selected the '"Yes".

c:\NetCOBOL Studio\workspace\SAMPLE31>

When the Cancel button is clicked, the program is executed again.

1.16.2 Using MAKE file

Compiling and Linking the Program

Open a command prompt. Compile and link the sample program using the following command.

C:\COBOL\Samples\COBOL\Sample31>nmake

Compilation of the sample program is now complete. Verify that MSGBOX.EXE was created in the same folder in which the sample
program is stored.

Select "Build Project” on "Project” menu bar of NetCOBOL Studio when MSGBOX.EXE is not created in "Other Files" (When an
automatic build is not executed).

The project is built, and then MSGBOX.EXE is created.
Executing the Program

Same as "1.16.1 Using NetCOBOL Studio".

1.17 Sample 32: Starting Another Program

Sample 32 demonstrates a program that starts another program, waits for the started program to terminate, and receives a completion code
from the started program via inter-program communications.

Overview

When SAMPLE32 is executed, you are prompted for a program to run. If you enter nothing, the program MSGBOX.EXE from the
SAMPLE3L1 folder is executed. If you specify a program name, you must enter the fully qualified path to the location of the application (or
batch file) to execute.

The Windows system function "CreateProcessA" is called specifying this for the argument, and specified program or batch file is started.
If the specified program is successfully started, SAMPLE32 then waits until the specified program terminates and then receives the
completion code from the started program.
Files Included in Sample 32
- SAMPLE32.COB(COBOL source program)
- MAKEFILE
- COBOLS85.CBR

COBOL Statements Used
- Method of calling a C program from COBOL program
STDCALL call convention

- Parameter transfer in BY VALUE

RETURNING phrase of CALL statement
STORED-CHAR-LENGTH function
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- Project Manager

Before Executing the Application
- SAMPLE32 uses MSGBOX.EXE from SAMPLE 31; therefore, please build the MSGBOX application prior to executing SAMPLE32.
- In the following screens, SAMPLEOG is also executed; therefore please build SAMPLEOQ6 prior to executing SAMPLE32.

1.17.1 Using NetCOBOL Studio

Compiling and Linking the Program
1. NetCOBOL Studio is started by specifying the workspace created for the sample program. See "Preparing the workspace".
2. In the Dependency view, select the SAMPLE32 project.

If there is no SAMPLE32 project, import project for the sample program into the NetCOBOL Studio workspace. See "Importing
sample program project into NetCOBOL Studio workspace".

3. The structure of the project is as follows.

¥ De. ¥ EEStn. wm MNa. = O
2%
v [ SAMPLE32 ~
v (Bl Source Files
Eii S5ample32.cob
@2 Linking Files
~ (L Other Files
[= .settings
2 buildxml
COBOLS5.CBR
= Makefile
[m=] SAMPLE32.exe
=| Sample32.0B)
=| SAMPLE3Z. pdb
=| Sample32.5VD w

4. The build is executed immediately after importing the project when an automatic build is set. In this case, the file (. EXE . OBJ etc.)
is generated after the build is displayed in "Other Files". It is set to automatic build by default.

5. On the Project menu, click Build Project when SAMPLE32.EXE is not created in "Other Files" (When an automatic build is not
executed).

The project is built, and then SAMPLE32.EXE is created.

Executing the Program

1. Execute SAMPLE32.EXE from a command prompt or from Windows Explorer. The following is displayed, waiting for input.

Input the path name that execution program.
(IF input no character, then execute the MsgBox.EXE of SAMPLE31)
=>

2. Input the path and filename of an executable program or batch file. The environment variable PATH is not referenced here; therefore
it is necessary to specify a relative path from the SAMPLE32 folder or a fully qualified path name.

3. If nothing is entered, and then MSGBOX.EXE of SAMPLE3L1 is executed. Press the ENTER key.
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4. The completion code of MSGBOX.EXE of SAMPLE31 is displayed, indicating the button that was clicked. In the following screen,

the "No" button was clicked.

Input the path name that execution program.

(If input no character, then execute the MsgBox.EXE of SAMPLE31)
=>

Execute the program ..\SAMPLE31\MSGBOX.EXE

Succeeded in executing program ..\SAMPLE31\MSGBOX.EXE

Return code from ..\SAMPLE31\MSGBOX.EXE is "00000009".

5. If SAMPLE32 is re-executed and an executable program or batch file name is specified, you are then prompted to enter command

line arguments (if any) for the EXE or BAT file, as shown below.

Input the path name that execution program.

(1f Input no character, then execute the MsgBox.EXE of SAMPLE31)
=>_ _\SAMPLEO6\SAMPLEG . EXE

Input the command line arguments.

=

6. SAMPLEO6.EXE requires two command line arguments to be specified following the program name.

Input the path name that execution program.

(1T input no character, then execute the MsgBox.EXE of SAMPLE31)
=>_ _\SAMPLEO6\SAMPLEG . EXE

Input the command line arguments.

=>20000101 20140101

7. A message indicating that SAMPLEO6 has been started is displayed. The system console is opened and the execution result of

SAMPLEO6 is output. The completion code of SAMPLEOQG.EXE is displayed and execution ends.

Input the path name that execution program.

(1T Input no character, then execute the MsgBox.EXE of SAMPLE31)
=>_ _\SAMPLEO6\SAMPLEG6 . EXE

Input the command line arguments.

=>20000101 20140101

Execute the program ..\SAMPLEO6\SAMPLEG.EXE

Succeeded in executing program ..\SAMPLEO6\SAMPLEG.EXE

Return code from ..\SAMPLEO6\SAMPLE6.EXE is “00000000".

1.17.2 Using MAKE file

Compiling and Linking the Program

Open a command prompt. Compile and link the sample program using the following command.

C:\COBOL\Samples\COBOL\Sample32>nmake

Compilation of the sample program is now complete. Verify that SAMPLE32.EXE was created in the same folder in which the sample

program is stored.

Executing the Program
Same as "1.17.1 Using NetCOBOL Studio".
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Appendix A Handling of workspace and project

This topic covers the handling of the workspace and the project.

A.1l Default workspace

The default workspace is in the following folder. It is created when NetCOBOL Studio is first started.

My documents folder (*1) \NetCOBOL Studio V12.0.0(x64)\workspace4.6

*1: The "My documents" folder is used to save each user's data. The location of the "My documents" folder varies based on the Windows
Os.

A.2 Setting and switch method of workspace

"Workspace" is a folder that stores various resources of the project made on Eclipse.

The Workspace can be used differently depending on the needs, such as workspace for development, workspace for the investigation, and
workspace for testing.

Workspace for Workspace for Workspace for
Development Testing Investigation
Project Al Project T1 Froject 11
Project A2 Project T2 Project 12
Project A3 Project T3 Project I3

A.2.1 Setting workspace

The Workspace is set using the "setting operating environment" dialog box according to the following procedures.

1. Click Start, select Fujitsu NetCOBOL V12(x64) > NetCOBOL Studio(x64). NetCOBOL Studio is started.
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2. Click Setup.... The Setup Configuration dialog box appears.

Setup Configuration

Wiorkzpace folder name:
C:hUzershCenter\DocumentsiMNetCOBOL Studio ...

Cancel

Help

Delete

ik

Esecution option:
I

v Alwaps show Launch dialog

3. Click Add. The Select Folder dialog box appears.

4. Select the folder used as the workspace.
When you click the Make New Folder button, a "New folder" is made in the selected folder. It can be used by changing the name.

Select Folder >

Select Workspace Folder

w = |ocal Disk (C:) ~

FujitsuF4CR

inetpub

MEFTLOGROOT

MNetCOBOL

W MNetCOBOL Studio
workspace
Perflogs

Program Files “

Folder: workspace

Make Mew Folder Cancel

Select a folder, and click OK. In this example, "C:\NetCOBOL Studio\workspace" is set as the new workspace.
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5. When the following message box is displayed, click OK.

MetCOBOL

........................................

The list of workspaces is displayed in the "Workspace folder name."

6. Select the workspace, and then click OK.

Setup Configuration

Wiorkzpace folder name:

C:AMetCOBOL Studiohwark zpace (]
C:hUzershCenter\DocumentziMNetCOBOL Studio ...

Cancel

aig

Help

Add...

Delete

;

Emecution aphian:

v Always show Launch dialog

The start screen appears.
7. Click Run. The NetCOBOL Studio window appears.
The Workspace becomes "C:\NetCOBOL Studio\workspace."

E) Point

© © 0000000000 00000000000000000000000000000000000000000000000000000000000000000000000000000COCOCOCOCOCEOCEOEE

When NetCOBOL Studio starts next time, this setting becomes effective.

© ©0000000000000000000000000000000000000000000O00COCOCOCOCOCIOCIOCOCOCEOCOCOC0CI0C0C0C0CI0C0COC0C0C0C0C0C0C0C0C0C0C0C0C0C0C0C0C0C0C0C0CCCCCOCOCEOCEECEEETS

A.2.2 Switch of workspace

The Workspace can be switched to another workspace when NetCOBOL Studio is active.

1. On the File menu, click Switch Workspace > Other.
The Eclipse Launcher dialog box appears. The present workspace is displayed in the Workspace box.
2. In the Workspace box, enter the switched new workspace name using the full path.

The folder can be selected by using the Browse button.
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Click the Workspace arrow to see the history of the workspaces used so far. The Workspace can be selected from the list displayed.

E Eclipse Launcher % |

Select a directory as workspace
MetCOBOL Studio(xtd) uses the workspace directory to store its preferences and development artifacts.

Workspace: | ANetCOBOL Studic\worksp w Browse...

r Copy Settings

A

,

@ Gance

3. Click OK.
NetCOBOL Studio is re-started. The Workspace becomes the specified workspace.

A.3 Importing Project

In the following cases, the projects are imported and used.
- When you want to use a project created with a 32bit NetCOBOL Studio, with a 64bit NetCOBOL Studio.
Use the following method to import an existing project in batch mode.
1. Set the workspace of the copy destination, and start NetCOBOL Studio.

2. On the File menu, click Import.... The Import wizard is launched.
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3. Select General > Existing projects into Workspace, and then, click Next.

ﬁ Import ] b4

Select

W
Choose impon wizard. @

Select an import wizard:

= General
[

= Install

= Run/Debug
= Team

WO W W W

@ < Back Next > Finish | Cancdl

4. Click Select root directory, and click the Browse button. The Browse For Folder dialog box appears.

5. Select the workspace folder (In this example, C:\Samples) where the project of the copy source is included, and click the OK button.
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6. Confirm that the project of the copy source is displayed in the Projects pane, and click the Select All button.
Next, check Copy projects into workspace, and click the Finish button.

B Import (] ,
Import Projects -
Select a directory to search for existing Eclipse projects. B‘
i®) Select root directory: | ChSamples w | Browse...
() Select archive file: Browse...
Projects:

[+] SAMPLEX (ChSamplestSamplel) - Select Al
[+] SAMPLEDZ [C\SamplectSampledZ)
[+ SAMPLED (ChSampleshSampledd)

Deselect All

SAMPLEDS (C\Samples\ SampleD3\ SAMPLEDS) S
[+] SAMPLEDS_DLL (C\Gamples Sarmpled3\SAMPLEDS_DLL) W

Options

[[]5earch for nested projects

FLopy projects into workspace

[]Hide projects that already exist in the workspace

Warking sets

[ add preject to working sets Mew...

Warking sets: Select

@ < Back Net> [ Finish Cancel
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The project is copied onto the NetCOBOL Studio workspace .

E workspace - COBOL - NetCOBOL Stwdio(xtd)
Mavegate  Search  Project  Bun  Windew Help

Eile  Edit
1oRIFTRC SN BT R P R R RS e
e

L = 0O

ok |leahE
5 (2N SAMPLEDT |
5 12d SAMPLEDZ
> 128 SAMPLEN
3 g SAMPLEOS
3 = SAMPLEDG
5 12 SAMPLEDT
5 12 SAMPLEDR
5 124 SAMPLEDS
5 1 SAMPLEN
> 1 SAMPLETR
5 1= SAMPLE1Z
5 1= SAMPLE1Y
3 1= SAMPLE1S
5 128 SAMPLE1E
3 1 SAMPLEN
> 1f SAMPLE3Z

[T] Properies

=
— 1, |
17

= B  [& Problems 32 2
o4 = Ditems

Praperty Value Deseription Resaurce

] x

Chsick Access| 1= ‘i'i

S et S |
o
An outling is not
available,

Path
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