This section describes an example configuration procedure of the network shown in the diagram below.
The xx, yy in the figure below are assigned automatically by the automatic address configuration.
If the Standby patrol monitoring function is not used, omit 6) in the procedure for setting up on each host.
Note
An example of configuring /etc/inet/ndpd.conf to use Solaris server as an IPv6 router is described below:
For details on /etc/inet/ndpd.conf, refer to the Solaris manual.
For Solaris 10
ifdefault AdvSendAdvertisements true # Every interface sends a router advertisement. prefix fec0:1::0/64 fjgi2000 # fjgi2000 sends Prefix "fec0:1::0/64". prefix fec0:2::0/64 fjgi3000 # fjgi3000 sends Prefix "fec0:2::0/64". |
For Solaris 11
ifdefault AdvSendAdvertisements true # Every interface sends a router advertisement. prefix fec0:1::0/64 net2000 # net2000 sends Prefix "fec0:1::0/64". prefix fec0:2::0/64 net3000 # net3000 sends Prefix "fec0:2::0/64". |
[HOST-A]
1) Setting up the system
1-1) Define IP addresses and hostnames in /etc/inet/hosts file.
192.168.70.1 hosta # HOST-A Virtual IP 192.168.70.3 host71 # HOST-A Physical IP (Tagged VLAN interface) 192.168.80.1 hostb # HOST-A Virtual IP 192.168.80.3 host81 # HOST-A Physical IP (Tagged VLAN interface) 192.168.70.2 hostc # HOST-B Virtual IP 192.168.70.4 host72 # HOST-B Physical IP (Tagged VLAN interface) 192.168.80.2 hostd # HOST-B Virtual IP 192.168.80.4 host82 # HOST-B Physical IP (Tagged VLAN interface) 192.168.70.100 swhub1 # primary Switch/HUB IP 192.168.70.101 swhub2 # secondary Switch/HUB IP |
1-2) For Solaris 10
Write the hostnames defined above in /etc/hostname.fjgi2000 file and /etc/hostname.fjgi3000 file. If a file does not exist, create a new file.
Contents of /etc/hostname.fjgi2000
host71 |
Contents of /etc/hostname.fjgi3000
host81 |
1-2) For Solaris 11
Set the host by the interface used with the dladm(1M) command and the ipadm(1M) command and also by the host name defined above.
Interface net2000
# /usr/sbin/dladm create-vlan -l net0 -v 2 # /usr/sbin/ipadm create-ip net2000 # /usr/sbin/ipadm create-addr -T static -a host71/24 net2000/v4 |
Interface net2001
# /usr/sbin/dladm create-vlan -l net1 -v 2 |
Interface net3000
# /usr/sbin/dladm create-vlan -l net0 -v 3 # /usr/sbin/ipadm create-ip net3000 # /usr/sbin/ipadm create-addr -T static -a host81/24 net3000/v4 |
Interface net3001
# /usr/sbin/dladm create-vlan -l net1 -v 3 |
1-3) Define the subnet mask in /etc/inet/netmasks file.
192.168.70.0 255.255.255.0 192.168.80.0 255.255.255.0 |
1-4) For Solaris 10
Create /etc/hostname6.fjgi2000 and /etc/hostname6.fjg3000 file as an empty file.
1-4) For Solaris 11
Set the interface to be used by using the ipadm(1M) command.
Interface net2000
# /usr/sbin/ipadm create-addr -T addrconf net2000/v6 |
Interface net3000
# /usr/sbin/ipadm create-addr -T addrconf net3000/v6 |
1-5) Define IP addresses and hostnames in /etc/inet/ipnodes file.
fec0:1::1 v6hosta1 # HOST-A Virtual IP(1) fec0:2::1 v6hosta2 # HOST-A Virtual IP(2) fec0:1::2 v6hostb1 # HOST-B Virtual IP(1) fec0:2::2 v6hostB2 # HOST-B Virtual IP(2) |
2) Creation of IPv4 virtual interface
2-1) For Solaris 10
# /opt/FJSVhanet/usr/sbin/hanetconfig create -n sha0 -m d -i 192.168.70.1 -e 192.168.70.3 -t fjgi2000,fjgi2001 # /opt/FJSVhanet/usr/sbin/hanetconfig create -n sha1 -m d -i 192.168.80.1 -e 192.168.80.3 -t fjgi3000,fjgi3001 |
2-1) For Solaris 11
# /opt/FJSVhanet/usr/sbin/hanetconfig create -n sha0 -m d -i 192.168.70.1 -e 192.168.70.3 -t net2000,net2001 # /opt/FJSVhanet/usr/sbin/hanetconfig create -n sha1 -m d -i 192.168.80.1 -e 192.168.80.3 -t net3000,net3001 |
Note
Ensure that the physical IP address specified using option '-e' is the same IP address configured in /etc/hostname.fjgi2000, in /etc/hostname.fjgi3000, or with the ipadm(1M) command.
3) Creation of IPv6 virtual interface
# /opt/FJSVhanet/usr/sbin/hanetconfig copy inet6 -n sha0,sha0 -i fec0:1::1/64 # /opt/FJSVhanet/usr/sbin/hanetconfig copy inet6 -n sha1,sha1 -i fec0:2::1/64 |
4) Setting up the HUB monitoring function
# /opt/FJSVhanet/usr/sbin/hanetpoll create -n sha0 -p 192.168.70.100,192.168.70.101 -b on |
5) Setting up the HUB monitoring function (Synchronized switching)
# /opt/FJSVhanet/usr/sbin/hanetpoll copy -n sha0,sha1 |
6) Setting up the Standby patrol monitoring function
Please define only one Standby patrol monitoring function.
# /opt/FJSVhanet/usr/sbin/hanetconfig create -n sha2 -m p -t sha0 |
7) Reboot
Run the following command to reboot the system. Using the ifconfig command, make sure that fjgi2000 and fjgi3000 for Solaris 10, net2000 and net 3000 for Solaris 11 are enabled as IPv6 interfaces after rebooting the system.
# /usr/sbin/shutdown -y -i6 -g0 |
[HOST-B]
1) Setting up the system
1-1) Define IP addresses and hostnames in /etc/inet/hosts file. Defined information is the same as for HOST-A.
1-2) For Solaris 10
Write the hostnames defined above in /etc/hostname.fjgi2000 file and /etc/hostname.fjgi3000 file. If a file does not exist, create a new file.
Contents of /etc/hostname.fjgi2000
host72 |
Contents of /etc/hostname.fjgi3000
host82 |
1-2) For Solaris 11
Set the host by the interface used with the dladm(1M) command and the ipadm(1M) command and also by the host name defined above.
Interface net2000
# /usr/sbin/dladm create-vlan -l net0 -v 2 # /usr/sbin/ipadm create-ip net2000 # /usr/sbin/ipadm create-addr -T static -a host72/24 net2000/v4 |
Interface net2001
# /usr/sbin/dladm create-vlan -l net1 -v 2 |
Interface net3000
# /usr/sbin/dladm create-vlan -l net0 -v 3 # /usr/sbin/ipadm create-ip net3000 # /usr/sbin/ipadm create-addr -T static -a host82/24 net3000/v4 |
Interface net3001
# /usr/sbin/dladm create-vlan -l net1 -v 3 |
1-3) Define the subnet mask in /etc/inet/netmasks file. Defined content is same as HOST-A.
1-4) For Solaris 10
Create /etc/hostname6.fjgi2000 and /etc/hostname6.fjgi3000 file as an empty file.
1-4) For Solaris 11
Set the interface to be used by using the ipadm(1M) command.
Interface net2000
# /usr/sbin/ipadm create-addr -T addrconf net2000/v6 |
Interface net3000
# /usr/sbin/ipadm create-addr -T addrconf net3000/v6 |
1-5) Define IP addresses and hostnames in /etc/inet/ipnodes file. Defined content is same as HOST-A.
2) Creation of IPv4 virtual interface
2-1) For Solaris 10
# /opt/FJSVhanet/usr/sbin/hanetconfig create -n sha0 -m d -i 192.168.70.2 -e 192.168.70.4 -t fjgi2000,fjgi2001 # /opt/FJSVhanet/usr/sbin/hanetconfig create -n sha1 -m d -i 192.168.80.2 -e 192.168.80.4 -t fjgi3000,fjgi3001 |
2-1) For Solaris 11
# /opt/FJSVhanet/usr/sbin/hanetconfig create -n sha0 -m d -i 192.168.70.2 -e 192.168.70.4 -t net2000,net2001 # /opt/FJSVhanet/usr/sbin/hanetconfig create -n sha1 -m d -i 192.168.80.2 -e 192.168.80.4 -t net3000,net3001 |
Note
Ensure that the physical IP address specified using option '-e' is the same IP address configured in /etc/hostname.fjgi2000, in /etc/hostname.fjgi3000, or with the ipadm(1M) command.
3) Creation of IPv6 virtual interface
# /opt/FJSVhanet/usr/sbin/hanetconfig copy inet6 -n sha0,sha0 -i fec0:1::2/64 # /opt/FJSVhanet/usr/sbin/hanetconfig copy inet6 -n sha1,sha1 -i fec0:2::2/64 |
4) Setting up the HUB monitoring function
# /opt/FJSVhanet/usr/sbin/hanetpoll create -n sha0 -p 192.168.70.100,192.168.70.101 -b on |
5) Setting up the HUB monitoring function (Synchronized switching)
# /opt/FJSVhanet/usr/sbin/hanetpoll copy -n sha0,sha1 |
6) Setting up the Standby patrol monitoring function
Please define only one Standby patrol monitoring function.
# /opt/FJSVhanet/usr/sbin/hanetconfig create -n sha2 -m p -t sha0 |
7) Reboot
Run the following command to reboot the system. Using the ifconfig command, make sure that fjgi2000 and fjgi3000 for Solaris 10, net2000 and net 3000 for Solaris 11 are enabled as IPv6 interfaces after rebooting the system.
# /usr/sbin/shutdown -y -i6 -g0 |