(1) Verification of the physical interface
Verify if the physical interface is inserted into the system using prtconf (1M) command.
# prtconf -D | grep "name of the physical interface" |
For example, to use qfe, execute the command as below:
# prtconf -D | grep qfe SUNW,qfe, instance #0 (driver name: qfe) SUNW,qfe, instance #1 (driver name: qfe) SUNW,qfe, instance #2 (driver name: qfe) SUNW,qfe, instance #3 (driver name: qfe) |
In the above example, it is possible to use qfe0, qfe1, qfe2, and qfe3. For details regarding prtconf (1M) command, refer to the Solaris manual.
If the system has no NIC installed, install a NIC. After adding a new NIC on the system, run "boot -r" command at the ok prompt, and then verify the physical interface as above.
Information
When using Tagged VLAN, ensure that the NIC supports tagged VLAN functionality (IEEE802.1Q). Refer to the documents of individual ethernet driver for configuring tagged VLAN interface. In addition, in a Redundant Line Control function, the effective range of VLAN-ID which can be specified is from 1 to 4094.
(2) Checking the name service
When using name services such as DNS or NIS, define keywords such as hosts, netmasks, and ipnodes in /etc/nsswitch.conf file to first refer to the local file. This allows to solve the address even if the DNS, NIS or LDAP sever is unreachable. The following is an example of /etc/nsswitch.conf.
# # /etc/nsswitch.files: # # An example file that could be copied over to /etc/nsswitch.conf; it # does not use any naming service. # # "hosts:" and "services:" in this file are used only if the # /etc/netconfig file has a "-" for nametoaddr_libs of "inet" transports. passwd: files group: files hosts: files dns ipnodes: files networks: files protocols: files rpc: files ethers: files netmasks: files bootparams: files |
Note
Even when using only IPv4 address in Redundant Line Control function, please define a host name as both /etc/inet/hosts file and /etc/inet/ipnodes file.
(3) Checking the network configuration files of the OS
When setting IP addresses using the network configuration files of the OS (/etc/hostname.interface file or /etc/hostname6.interface file), it is recommended to set up as follows for hardware failure such as NIC or SB (System Board).
[Solaris 10]
Create either or both of the following files as the network configuration files for both physical interfaces for redundancy:
/etc/hostname.interface
/etc/hostname6.interface
[Solaris 11]
Set both physical interfaces for redundancy by using the ipadm(1M) command.
[Solaris 10]
Create either or both of the following files as the network configuration files for either of the physical interfaces for redundancy:
/etc/hostname.interface
/etc/hostname6.interface
[Solaris 11]
Set either of the physical interfaces for redundancy by using the ipadm(1M) command.
It is not necessary to create any network configuration files of physical interfaces for redundancy.
Note
Services related to the network including Redundant Line Control function will not start if all IP addresses set by hostname.interface or the ipadm command cannot be allocated due to a hardware failure on system startup.
To activate Redundant Line Control function even in the case of a hardware failure, set interfaces as shown in the following figure:
For Solaris 10
Create the hostname.interface file.
For Solaris 11
Set IP addresses by the ipadm command.
For NIC switching mode, it is recommended to create the network configuration files so that at least one physical interface is to be activated on system startup as shown in the following figure:
Figure 3.2 Setup example of the OS setting file in the NIC switching mode (For Solaris 10)
Figure 3.3 Setup example of the OS setting file in the NIC switching mode (For Solaris 11)
When system boards are multiplexed or NICs with multiple ports are used, activation of the network service (svc:/network/physical) may fail because IP addresses cannot be assigned by rebooting the system while a failure occurs in the system board or the NIC. In this case, services related to the network including the service Redundant Line Control function (svc:/network/physical) will not start.
Therefore, if the a system board is multiplexed, it is recommended to set one or more physical interfaces to be activated on each system board so that at least one physical interface is to be activated on system startup as shown in the following figure.
For Solaris 10, set interfaces by creating the network configuration files.
For Solaris 11, set interfaces by using the ipadm command.
If you cannot follow the procedures above due to reasons such as the small number of equipped NICs, check that the physical interface to be activated for the network configuration file has no failure before rebooting the system.
Figure 3.4 Setup example of the OS setting file in the environment with redundant system boards (For Solaris 10)
Figure 3.5 Setup example of the OS setting file in the environment with redundant system boards (For Solaris 11)
In the NIC switching mode (physical IP takeover II), it is necessary to avoid IP duplication between nodes in the cluster. For Solaris 10, create an empty network configuration file to avoid IP addresses being set. When network configuration files are required, create network configuration files so that at least one physical interface other than the physical interface for redundancy is to be activated on system startup.
When using an IPv4 address, define in the /etc/inet/hosts file the host names (host names to be attached to virtual IP, monitored host names to be specified in monitoring destination information, etc.) to be specified in environment definitions of Redundant Line Control function. These host names must be specified in the /etc/inet/hosts file even if no host names but IP addresses are directly specified in environment definitions.
If an IPv6 address is used, define the IPv6 address and a host name in /etc/inet/ipnodes file.
When using an IPv4 address, define a configured physical interface to use in IPv4 before defining a virtual interface.
[Solaris 10]
Check whether or not an /etc/hostname.interface file exists. If not, create it and reboot the system.
[Solaris 11]
Create a physical interface by using the ipadm(1M) command and reboot the system.
When using an IPv6 address, define a configured physical interface to use in IPv6 before defining a virtual interface.
[Solaris 10]
Check whether or not an /etc/hostname6.interface file exists. If not, create it and reboot the system. When creating a /etc/hostname6.interface file, make sure it is an empty file.
[Solaris 11]
Create a physical interface by using the ipadm(1M) command and reboot the system.
If IPv6 address is used, it is recommended to setup at least two Solaris servers running in Fast switching mode as IPv6 routers just in case an IPv6 router fails and communication cannot be achieved using a site local address. Note that if configuring IPv6 router for multiple servers, make sure these servers use the same prefix information for the virtual interface configured in /etc/inet/ndpd.conf.
An example of setting a /etc/inet/ndpd.conf file when using a Solaris server as an IPv6 router is shown below. (See a Solaris manual for the detail of a /etc/inet/ndpd.conf file.)
ifdefault AdvSendAdvertisements true # Every interface sends a router advertisement. prefix fec0:1::0/64 sha0 # sha0 sends "Prefix fec0:1::0/64". |
When using IPv4 address:
When using an IPv4 address, define in the /etc/inet/hosts file the host names (host names to be attached to virtual IP, monitored host names to be specified in monitoring destination information, etc.) to be specified in environment definitions of Redundant Line Control function. These host names must be specified in the /etc/inet/hosts file even if no host names but IP addresses are directly specified in environment definitions.
When using an IPv4 address, define a configured primary physical interface to use in IPv4 before defining a virtual interface.
[Solaris 10]
Check whether or not an /etc/hostname.interface file exists. If not, create it and reboot the system.
[Solaris 11]
Create a physical interface by using the ipadm(1M) command and reboot the system.
For Redundant Line Control function, the path information must be initialized and the routing daemon must be restarted. If path information is statically specified, the static paths must be described in /etc/gateways.
When using IPv6 address:
If an IPv6 address is used, define the IPv6 address and a host name in /etc/inet/ipnodes file.
When using an IPv6 address, define a configured physical interface to use in IPv6 before defining a virtual interface.
[Solaris 10]
Check whether or not an /etc/hostname6.interface file exists. If not, create it and reboot the system. When creating a /etc/hostname6.interface file, make sure it is an empty file.
[Solaris 11]
Create a physical interface by using the ipadm(1M) command and reboot the system.
When using an IPv6 address, set an IPv6 router on a network to be connected without fail. Specify the same prefix and the same length of a prefix for an IPv6 address to be set in a Redundant Line Control function as those set in an IPv6 router.
In addition, when you use a Solaris server as an IPv6 router, please define two or more server as an IPv6 router. When abnormalities occur in an IPv6 router, it becomes impossible to perform communication which used a site local address. Therefore, it recommends defining two or more IPv6 routers. When you define an IPv6 router as two or more servers, the prefix information on the virtual interface defined as /etc/inet/ndpd.conf should define the same value in each server.
An example of setting a /etc/inet/ndpd.conf file when using a Solaris server as an IPv6 router is shown below. (See a Solaris manual for the detail of a /etc/inet/ndpd.conf file.)
ifdefault AdvSendAdvertisements true # Every interface sends a router advertisement. prefix fec0:1::0/64 hme0 # hme0 sends "Prefix fec0:1::0/64". prefix fec0:2::0/64 hme1 # hme1 sends "Prefix fec0:2::0/64". |
When using an IPv4 address, define in the /etc/inet/hosts file the host names (host names to be attached to virtual IP, monitored host names to be specified in monitoring destination information, etc.) to be specified in environment definitions of Redundant Line Control function. These host names must be specified in the /etc/inet/hosts file even if no host names but IP addresses are directly specified in environment definitions.
The physical interface to be specified must not be defined for normal use in TCP/IP.
(Check whether or not an /etc/hostname.interface file exists. If it does, rename the file or delete it, and execute "/usr/sbin/ifconfig <interface> unplumb" command.)
When you do not configure the virtual gateway in GS/SURE linkage mode, dynamic routing is required. When configuring dynamic routing, it is necessary to block leaks of routing information from the local system. Use the routeadm(1M) command to set up a routing daemon. The following show how to set up a routing daemon.
Routing daemon setup: # routeadm -e ipv4-routing # routeadm -s ipv4-routing-daemon="/usr/sbin/in.routed" # routeadm -s ipv4-routing-daemon-args="-q" # routeadm Configuration Current Current Option Configuration System State --------------------------------------------------------------- IPv4 forwarding disabled disabled IPv4 routing enabled disabled IPv6 forwarding disabled disabled IPv6 routing disabled disabled IPv4 routing daemon "/usr/sbin/in.routed" IPv4 routing daemon args "-q" IPv4 routing daemon stop "kill -TERM `cat /var/tmp/in.routed.pid`" IPv6 routing daemon "/usr/lib/inet/in.ripngd" IPv6 routing daemon args "-s" IPv6 routing daemon stop "kill -TERM `cat /var/tmp/in.ripngd.pid`" # routeadm -u |
or,
# routeadm -m route:default quiet_mode=true # routeadm Configuration Current Current Option Configuration System State --------------------------------------------------------------- IPv4 routing enabled disabled IPv6 routing disabled disabled IPv4 forwarding disabled disabled IPv6 forwarding disabled disabled Routing services "route:default ripng:default" Routing daemons: STATE FMRI disabled svc:/network/routing/legacy-routing:ipv4 disabled svc:/network/routing/legacy-routing:ipv6 online svc:/network/routing/ndp:default disabled svc:/network/routing/rdisc:default offline svc:/network/routing/ripng:default disabled svc:/network/routing/ripng:quagga online svc:/network/routing/route:default disabled svc:/network/routing/zebra:quagga disabled svc:/network/routing/rip:quagga disabled svc:/network/routing/ospf:quagga disabled svc:/network/routing/ospf6:quagga disabled svc:/network/routing/bgp:quagga # routeadm -u |