Preface

NetCOBOL Studio is an integrated development environment for COBOL programs.

Intended Readers

This documentation provides information for COBOL program developers who use NetCOBOL Studio. For details on general functions of Eclipse, see “Workbench User Guide” in the Help information. Readers of this documentation are assumed to have a basic knowledge of COBOL programming and the Windows operating system.

Organization of This Documentation

This documentation is organized as follows:

Chapter 1 Overview
Provides an overview of NetCOBOL Studio, describes its starting method, and explains its development workflows.

Chapter 2 Tutorial
Provides a tutorial explaining the basic operations of NetCOBOL Studio.

Chapter 3 COBOL Perspective
Describes the types of views that are displayed when a COBOL project is created.

Chapter 4 Project
Explains how to create a project.

Chapter 5 Editor
Explains the COBOL editor that is used to edit COBOL source files.

Chapter 6 Build Function
Explains how to build a COBOL program using the build tools provided in NetCOBOL Studio.

Chapter 7 Debugging Function
Explains the startup configuration used to debug programs, and the functions provided by the interactive debugger.

Chapter 8 Execution Function
Explains the startup configuration used for project execution.

Chapter 9 Remote Development Function
Explains the procedure for remote development of COBOL programs that run on a server.

Chapter 10 Using based on Eclipse 4.6
Explains the distinction of Eclipse 4.6 base and Eclipse 4.3 base.

Appendix A Compile Options
Explains the compiler options.

Appendix B Troubleshooting Guide
Explains how to resolve NetCOBOL Studio issues.

Appendix C Handling of Workspace and Project
Explains the handling of workspace and project.

Appendix D Various Specification Formats used in Debugging
Explains various specification formats used in the Watch view.

Appendix E Transition from Project Manager
Explains the transfer of COBOL applications from NetCOBOL project manager for Windows(x86) to NetCOBOL Studio, and the project organization converting command that is a transference support tool.
Abbreviations

The following abbreviations are used in this manual:

<table>
<thead>
<tr>
<th>Product Name</th>
<th>Abbreviation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft(R) Windows Server(R) 2016 Datacenter</td>
<td>Windows Server 2016</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2016 Standard</td>
<td></td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2016 Essentials</td>
<td></td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2012 R2 Datacenter</td>
<td>Windows Server 2012 R2</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2012 R2 Standard</td>
<td></td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2012 R2 Essentials</td>
<td></td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2012 R2 Foundation</td>
<td></td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2012 Datacenter</td>
<td>Windows Server 2012</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2012 Standard</td>
<td></td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2012 Essentials</td>
<td></td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2012 Foundation</td>
<td></td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2008 R2 Foundation</td>
<td>Windows Server 2008 R2</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2008 R2 Standard</td>
<td></td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2008 R2 Enterprise</td>
<td></td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2008 R2 Datacenter</td>
<td></td>
</tr>
<tr>
<td>Windows(R) 10 Education</td>
<td>Windows 10</td>
</tr>
<tr>
<td>Windows(R) 10 Home</td>
<td>or</td>
</tr>
<tr>
<td>Windows(R) 10 Pro</td>
<td>Windows 10(x64)</td>
</tr>
<tr>
<td>Windows(R) 10 Enterprise</td>
<td></td>
</tr>
<tr>
<td>Windows(R) 8.1</td>
<td>Windows 8.1</td>
</tr>
<tr>
<td>Windows(R) 8.1 Pro</td>
<td>or</td>
</tr>
<tr>
<td>Windows(R) 8.1 Enterprise</td>
<td>Windows 8.1(x64)</td>
</tr>
<tr>
<td>Windows(R) 7 Home Premium</td>
<td>Windows 7</td>
</tr>
<tr>
<td>Windows(R) 7 Professional</td>
<td>or</td>
</tr>
<tr>
<td>Windows(R) 7 Enterprise</td>
<td>Windows 7(x64)</td>
</tr>
<tr>
<td>Windows(R) 7 Ultimate</td>
<td></td>
</tr>
<tr>
<td>Oracle Solaris</td>
<td>Solaris</td>
</tr>
<tr>
<td>Red Hat(R) Enterprise Linux(R) 5 (for Itanium)</td>
<td>Linux</td>
</tr>
<tr>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td>Linux(Itanium)</td>
</tr>
<tr>
<td>Red Hat(R) Enterprise Linux(R) 5(for Intel64)</td>
<td>Linux</td>
</tr>
<tr>
<td></td>
<td>or</td>
</tr>
<tr>
<td></td>
<td>Linux(x64)</td>
</tr>
<tr>
<td>Red Hat(R) Enterprise Linux(R) 6(for Intel64)</td>
<td></td>
</tr>
</tbody>
</table>

- In this manual, when all the following products are indicates, it is written as "Windows(x64)" or "Windows".
- Windows Server 2016
- Windows Server 2012 R2
- Windows Server 2012
- Windows Server 2008 R2
- Windows 10(x64)
- Windows 8.1(x64)
- Windows 7(x64)

**Trademarks**

NetCOBOL is a trademark or registered trademark of Fujitsu Limited or its subsidiaries in the United States or other countries or in both.

Eclipse is a trademark of Eclipse Foundation, Inc.

Microsoft, Windows, and Internet Explorer are registered trademarks of Microsoft Corporation in the United States and other countries.

Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of their respective owners. Oracle Solaris might be described as Solaris, Solaris Operating System, or Solaris OS.

Linux is a registered trademark of Linus Torvalds in the United States and other countries.

Red Hat, RPM and all Red Hat-based trademarks are trademarks or registered trademarks of Red Hat, Inc. in the United States and other countries.

Intel and Itanium are trademarks or registered trademarks of Intel Corporation or its subsidiaries in the United States and other countries.

All other product names mentioned herein are the trademarks or registered trademarks of their respective owners.

**Export Regulation**

Exportation/release of this document may require necessary procedures in accordance with the regulations of your resident country and/or US export control laws.

October 2017

Copyright 2011-2017 FUJITSU LIMITED
## Contents

### Chapter 1 Overview
- 1.1 NetCOBOL Studio ................................................................. 1
- 1.1.1 Using NetCOBOL ............................................................ 1
- 1.2 Functional Overview ............................................................. 1
- 1.3 Starting NetCOBOL Studio .................................................... 2
- 1.4 Development Flows ............................................................... 4
  - 1.4.1 Development patterns .................................................... 4
  - 1.4.2 Local development flow .................................................. 4
  - 1.4.3 Remote development flow .............................................. 5

### Chapter 2 Tutorial
- 2.1 Creating a COBOL Program ................................................ 6
- 2.2 Creating a COBOL Program by Remote Development ........ 14

### Chapter 3 COBOL Perspective
- 3.1 Dependency View ................................................................ 22
  - 3.1.1 The role of the Dependency view .................................. 23
    - 3.1.1.1 Adding a COBOL source file in the Dependency view .. 25
    - 3.1.1.2 Adding a link file in the Dependency view ................. 25
    - 3.1.1.3 Adding a dependent file ........................................... 25
    - 3.1.1.4 Deleting a dependent file ......................................... 25
  - 3.1.2 Context menu of the Dependency view ......................... 26
    - 3.1.2.1 COBOL project ....................................................... 26
    - 3.1.2.2 COBOL Resource Project ....................................... 31
    - 3.1.2.3 COBOL Solution Project ......................................... 33
  - 3.1.3 Analyze Dependency ..................................................... 34
- 3.2 Structure View .................................................................... 34
  - 3.2.1 The role of the Structure view ....................................... 35
  - 3.2.2 Context menu of the Structure view .............................. 35
      - 3.2.2.1 COBOL Project ...................................................... 35
      - 3.2.2.2 COBOL resource project...................................... 38
      - 3.2.2.3 COBOL solution project ...................................... 39
- 3.3 Navigator View ................................................................... 39
  - 3.3.1 The role of the Navigator view ...................................... 39
    - 3.3.1.1 Applying a filter to the view .................................... 39
    - 3.3.1.2 Sharing files in the Concurrent Versions System (CVS) .. 39
    - 3.3.1.3 Property options ..................................................... 41
  - 3.3.2 Navigator view Tools .................................................... 42
  - 3.3.3 Navigator view Context menu ....................................... 42
- 3.4 Property View ..................................................................... 44
- 3.5 Outline View ...................................................................... 44
  - 3.5.1 Toolbar ....................................................................... 44
- 3.6 Problems View ................................................................... 44
  - 3.6.1 Problems view display .................................................. 45
  - 3.6.2 Using the Problems view to locate an error .................. 45
- 3.7 Tasks View ........................................................................ 45
  - 3.7.1 Tasks view display ....................................................... 46
  - 3.7.2 Associating a task with a COBOL source file ................ 46
- 3.8 Console View ..................................................................... 46
- 3.9 Templates view ................................................................... 46
  - 3.9.1 The role of Templates View ........................................... 47
    - 3.9.1.1 Insert template patterns into source file .................. 48
    - 3.9.1.2 Adding, editing, and deleting a template ................. 48
    - 3.9.1.3 Import and export template .................................... 52
    - 3.9.1.4 Validation/Invalidation of template ....................... 52
  - 3.9.2 Context menu of Templates view .................................. 53
Appendix A Compile Options................................................................................................................................................151
A.1 Compile option details..................................................................................................................................................151
A.1.1 Compiler option list.................................................................151
A.1.2 ALPHAL compile option..........................................................153
A.1.3 ARITHMETIC compile option...............................................153
A.1.4 ASCOMP5 compile option....................................................154
A.1.5 BINARY compile option.......................................................154
A.1.6 CHECK compile option.......................................................155
A.1.7 CONF compile option.........................................................156
A.1.8 COPY compile option..........................................................157
A.1.9 COUNT compile option.......................................................157
A.1.10 CURRENCY compile option...............................................158
A.1.11 DLOAD compile option.....................................................158
A.1.12 DUPCHAR compile option................................................158
A.1.13 ENCODE compile option..................................................159
A.1.14 EQUALS compile option...................................................159
A.1.15 FLAG compile option.......................................................160
A.1.16 FLAGSW compile option...................................................160
A.1.17 FORMLIB compile option................................................161
A.1.18 INITVALUE compile option...............................................161
A.1.19 LANGLEVEL compile option............................................161
A.1.20 LIB compile option..........................................................161
A.1.21 LINECOUNT compile option............................................162
A.1.22 LINESIZE compile option................................................162
A.1.23 LIST compile option........................................................162
A.1.24 MAP compile option........................................................162
A.1.25 MESSAGE compile option...............................................163
A.1.26 MODE compile option.....................................................163
A.1.27 NCW compile option.......................................................163
A.1.28 NSP compile option........................................................164
A.1.29 NSPCOMP compile option..............................................164
A.1.30 NUMBER compile option................................................165
A.1.31 OBJECT compile option...................................................166
A.1.32 OPTIMIZE compile option...............................................166
A.1.33 PRINT compile option.....................................................166
A.1.34 QUOTE/APOST compile option......................................166
A.1.35 RCS compile option........................................................167
Appendix B Troubleshooting Guide......................................................................................................................................176
B.1 Build Problems........................................................................................................................................................................176
B.1.1 After a resource is updated with an external editor, build is not executed when Build Project or Build All is selected........................176
B.1.2 A message "repository file (*.rep) was not found" is displayed in a dependency analysis.................................................................176
B.1.3 A static library (lib) cannot be made........................................................................................................................................176
B.2 Debugger problems.....................................................................................................................................................................176
B.2.1 Menu items in the Run menu cannot be used during debugging................................................................................................176
B.2.2 Values of data items outside the scope are displayed during debugging........................................................................................177
B.2.3 An error dialog box containing the message "Target executable not found. Could not proceed" appears.................................177
B.2.4 Program execution cannot be restarted after it stops at a breakpoint..........................................................................................177
B.3 Execution Problems....................................................................................................................................................................177
B.3.1 A runtime error occurs when an executable file is double-clicked............................................................................................177
B.4 Remote Development Problems..................................................................................................................................................177
B.4.1 The stty command causes an error in link with a server..............................................................................................................177
B.4.2 NetCOBOL Studio freezes when linking with a server................................................................................................................178
B.4.3 The error message "Error occurred while sending command. Remote computer reset connection" is displayed.........................178
B.4.4 The line feed code is not converted when a text file is transferred...............................................................................................178
B.4.5 The error message "Parameter of server command is invalid" is displayed when using remote development functions. ................178
B.4.6 Local project build runs when starting remote debug................................................................................................................178
B.4.7 Nothing appears in the Problems view even though the remote build failed........................................................................179
B.5 NetCOBOL Studio General Problems......................................................................................................................................179
B.5.1 An error dialog box stating "for details refer to log" appears..........................................................................................................179
B.5.2 Entire message containing "..." cannot be displayed......................................................................................................................179
B.5.3 Files, folders, and projects cannot be deleted..............................................................................................................................179
B.5.4 The Export of COBOL Project Fail..............................................................................................................................................180
B.6 Trace log..................................................................................................................................................................................................180

Appendix C Handling of Workspace and Project................................................................................................................................181
C.1 Default workspace..............................................................................................................................................................................181
C.2 Setting and switch method of workspace......................................................................................................................................181
C.2.1 Setting workspace..............................................................................................................................................................................181
C.2.2 Switch of workspace........................................................................................................................................................................183
C.3 Importing Project..............................................................................................................................................................................184

Appendix D Various Specification Formats used in Debugging.....................................................................................................185
D.1 Identifier Name..................................................................................................................................................................................................185
D.2 Program name..................................................................................................................................................................................................188
Chapter 1 Overview

This chapter provides an overview of NetCOBOL Studio and explains its development workflows.

1.1 NetCOBOL Studio

NetCOBOL Studio is an integrated development environment for COBOL programs.

NetCOBOL Studio includes the Assist functions for COBOL programming based on Eclipse, an open-source GUI development environment. With NetCOBOL, users can efficiently perform a series of development work steps, including editing COBOL source programs, and building, debugging, and executing COBOL programs.

Note

- In Windows 64bit NetCOBOL Studio, a 64-bit COBOL application can be developed.
- NetCOBOL Studio is an integrated development environment designed for the COBOL language. The Java development environment and the plug-in development environment that are provided as Eclipse functions are not supported.

1.1.1 Using NetCOBOL

A typical installation of the NetCOBOL development package installs the necessary NetCOBOL Studio components.

Compatibility

In Eclipse, the upward compatibility of a workspace is guaranteed. When a workspace created in NetCOBOL Studio based on Eclipse 4.3 or earlier is opened in NetCOBOL Studio based on Eclipse 4.6, it is converted automatically.

However, it is not backwards compatible. Workspaces that have been converted to NetCOBOL Studio based on Eclipse 4.6 cannot be opened by NetCOBOL Studio based on Eclipse 4.3 or earlier.

When two or more developers and development machines share one workspace for development work, be sure both machines are using the latest version of NetCOBOL Studio.

1.2 Functional Overview

NetCOBOL Studio supports the following COBOL program development functions:

- Development environment management functions
  
  NetCOBOL Studio manages the development environment and development resources of each COBOL program together in a unit called a project. Projects are managed in folders called workspaces.

Note

When developing a 32-bit COBOL application, use NetCOBOL Studio for Windows(x86). When developing a 64-bit COBOL application, use NetCOBOL Studio for Windows(x64).

- Edit functions

  NetCOBOL Studio provides many editing functions such as highlighting key words, displaying and resequencing line numbers, displaying horizontal, vertical, and overview rulers, displaying differences in source code, support of fixed and variable reference formats, automatic indentation, undo/redo, cut/copy/paste, find/replace, etc.

- Build and execution functions

  NetCOBOL Studio provides facilities to set COBOL compiler options and link options, and add version information and set icons for programs using the resource compiler. Tools for dependency analysis, automatic build, and manual build are provided. Compilation errors are displayed, and the line of source code containing a selected error can be displayed in the NetCOBOL Studio Editor.
Debug functions
The interactive debugger can detect logic errors in program processing. It can be used to set breakpoints to halt execution of a program, and to verify execution of a program by confirming data item values. The debugging of multithreaded programs is supported; however, the debugger does not support multiple debug sessions.

Remote development functions
COBOL programs for the Solaris OS, Linux (Itanium), Linux(64) or Windows(64) servers can be developed remotely. After performing standalone tests on a local computer, add the settings for remote development to the project for a smooth transition to test builds and links on a server.

NetCOBOL Studio users must understand the following main basic concepts:

Projects
NetCOBOL Studio manages the resources and information necessary for program development in individual units called "projects". NetCOBOL Studio creates and manages the following projects:

- COBOL projects
  A "COBOL project" is used for COBOL program development. One COBOL project manages the resources of one target (executable program or library). To develop a COBOL program, a COBOL project must first be created.

- COBOL resource projects
  A "COBOL resource project" is used for management of the library file and the descriptor file.

- COBOL solution projects
  A "COBOL solution project" is used for management of multiple projects. Specify the common compiler option for multiples projects.

You can easily create these projects interactively with the help of a wizard.

See

Project Import
A project in another workspace can be used by importing it. For details, refer to "C.3 Importing Project".

Workspaces
A workspace is a folder for storing one or more projects, and for storing setting information for a development environment shared by the projects.

For workspace setting and switching, refer to "Setting and Switching of Workspace". For the default workspace, refer to "C.1 Default workspace".

Note

- Projects for 32-bit and 64-bit COBOL applications cannot be created in the same workspace. Separate workspace folders must be specified for 32-bit and 64-bit COBOL projects.

Perspectives
The operation windows of NetCOBOL Studio consist of editor windows and multiple information display windows (each of these is called a "view"). The type and layout of a displayed view are managed under a concept called "perspectives" each of which is appropriate for the target work.

The COBOL perspective and Debug perspective, which has been prepared for debugging, are used in COBOL program development.

1.3 Starting NetCOBOL Studio
Start NetCOBOL Studio as follows:
Click **Start, select Fujitsu NetCOBOL V12(x64) > NetCOBOL Studio(x64)**. NetCOBOL Studio is started.

Click the **Run** button. The NetCOBOL Studio window appears. The contents of the start screen are shown below.

**Table 1.1 NetCOBOL Studio start screen**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| Run    | Starts NetCOBOL Studio.  
The folder name of the workspace that NetCOBOL Studio uses can be confirmed in the following way.  
- Place the mouse cursor on the **Run** button.  
- Click the **Setup** button and the workspace folder name is displayed. |
| Setup... | Used to make operating environment settings for NetCOBOL Studio.  
When the **Setup...** button is clicked, the **Setup Configuration** dialog box appears. For information about setting the workspace folder, refer to "Appendix C Handling of Workspace and Project".  
For details on the environment settings, see the Help for the **Setup Configuration** dialog box. |
| Cancel | Closes the start screen and does not start NetCOBOL Studio. |

When the **Always show Launch dialog** checkbox is selected in the **Setup Configuration** dialog box, this screen is displayed.

**Table 1.2 Setup Configuration dialog box**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| Workspace folder name | Used to select the folder for the workspace.  
NetCOBOL Studio uses the selected workspace folder.  
To change the workspace folder,  
- Select the folder name and push the F2 key, or  
- Edit by clicking the left mouse button.  
The following characters cannot be used for the workspace folder name.  
```
*#*/ \*:;:*  
```
| Add                   | Adds the existing workspace folder to the workspace list. The dialog box displayed is varies according to the operating system and the Internet Explorer version.  
When specify a non-existent folder name, a new workspace folder is created. |
| Delete                | Deletes the workspace folder name from the workspace list. Even if the workspace folder name is deleted from the list, the actual folder is not deleted.  
Use Explorer to delete unnecessary folders. |
| Execution option      | Used to specify a startup option for NetCOBOL Studio. For a normal startup, do not specify an option.  
- **-clean**  
Deletes the cache data used by Eclipse. When a plug-in is added, updated, or deleted, you should start NetCOBOL Studio by specifying this option.  
- **-nosplash**  
Does not display the splash screen at start-up of NetCOBOL Studio.  
- **-showlocation**  
Displays the workspace-path in the NetCOBOL Studio title bar. When you do not specify this option, the workbench-path can be displayed by the following operations. |
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Start the workbench.</td>
</tr>
<tr>
<td>2.</td>
<td>On the Window menu, click Preferences. The Preferences dialog box appears.</td>
</tr>
<tr>
<td>3.</td>
<td>In the left pane, select General &gt; Workspace. The Workspace page appears.</td>
</tr>
<tr>
<td>4.</td>
<td>Select the Show workspace path in windows title check box.</td>
</tr>
<tr>
<td>5.</td>
<td>To close the Preferences dialog box, click OK.</td>
</tr>
</tbody>
</table>

-vmargs JavaVMoption

Specifies the option for JavaVM.

Only "-Xmx option" can be specified for JavaVMoption. NetCOBOL Studio assumes that "-Xmx1024M" is specified.

For option details, refer to the NetCOBOL Studio help.


Note:

In NetCOBOL Studio, only the above option can be used.

<table>
<thead>
<tr>
<th>Always show Launch dialog</th>
<th>When checked, the start screen is displayed. When not checked, the start screen is not displayed.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>In a non-display state, when NetCOBOL Studio is started while holding the shift key, the start screen is displayed.</td>
</tr>
</tbody>
</table>

## 1.4 Development Flows

This section explains the development work patterns and flows of COBOL programming using NetCOBOL Studio.

### 1.4.1 Development patterns

NetCOBOL Studio provides two patterns of development:

- **Local development flow**
  
  Development pattern for a COBOL program that runs on a local personal computer.

- **Remote development flow**
  
  Development pattern for a COBOL program that runs on a server.

Remote development requires that information specific to the target server be set in each project. A project with a local development pattern can be changed to a remote development pattern by adding server information to the project.

### 1.4.2 Local development flow

This section explains the flow of COBOL program development on a local personal computer.
1. **Create a project**

NetCOBOL Studio manages each COBOL program under development as a "project." The resources (e.g., source files, libraries) required for COBOL program development are managed in blocks in units of projects. A single target (executable program or dynamic link library) is managed with each project. Using a wizard, projects can be defined easily and efficiently. Precompiler settings (e.g., command, parameter) can be specified for COBOL programs including input sources for the precompiler.

2. **Code a source program**

NetCOBOL Studio provides a wizard for creating source program templates. Various Assist functions of the COBOL editor can be used to edit COBOL source programs.

3. **Build**

Compiling and linking are performed according to the information defined in the project (e.g., compile options, link options).

4. **Debug**

The interactive debugger provides various functions, such as setting program breakpoints and referencing and setting data item values. These functions enable the programmer to efficiently debug the COBOL program.

5. **Execute**

The program can be executed after the runtime environment information required for COBOL program execution is set.

### 1.4.3 Remote development flow

For details on remote development of a COBOL program, refer to 9.1.3 Flow of Remote Development".
Chapter 2 Tutorial

This chapter explains the basic operation flow of NetCOBOL Studio using examples.

2.1 Creating a COBOL Program

This section explains the procedure for creating a COBOL program.

Point

The “NetCOBOL Getting Started Guide”, explains the procedures for importing sample projects to the workspace. Procedures to create a new project called SAMPLE1 are explained here.

1. Start NetCOBOL Studio
2. Create a project
3. Create a template by using the COBOL source generation wizard
4. Edit the program
5. Build the project
6. Start the debugger
7. Execute the COBOL program

1. Start NetCOBOL Studio

   1. This section explains how to start NetCOBOL Studio. An executable file is created from a COBOL source program in the project in this example.

      Click Start, select Fujitsu NetCOBOL V12(x64) > NetCOBOL Studio(x64). NetCOBOL Studio is started.

2. To set the workspace, click the Setup... button. For details about setting a workspace, refer to “C.2.1 Setting workspace”. When a workspace is not set, the default workspace is used. For details about the default workspace, refer to “C.1 Default workspace”.

   Copyright 1992 - 2017 FJUITSU LIMITED
3. Click the **Run** button. The NetCOBOL Studio window appears.

![NetCOBOL Studio window](image)
3. This page is used to specify information on the target. Leave the defaults and click the Next button.

<table>
<thead>
<tr>
<th>Field</th>
<th>Entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contents</td>
<td>Create new project in workspace</td>
</tr>
</tbody>
</table>
4. This page is used to select the type of source code to be created. Select **COBOL Source** in the **Available skeleton codes** section, and then click on the Finish button.

![Skeleton Code Selection](image)

**Note**

Projects for 32-bit and 64-bit COBOL applications cannot be created in the same workspace. Separate workspace folders must be specified for 32-bit and 64-bit COBOL projects.

---

3. **Create a template by using the COBOL source generation wizard**

   Using the New COBOL Source Wizard, create a template of a COBOL source file.
Make the following entries in the fields on this screen:

<table>
<thead>
<tr>
<th>Field</th>
<th>Entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>SAMPLE1</td>
</tr>
<tr>
<td>File name</td>
<td>SAMPLE1</td>
</tr>
<tr>
<td>PROGRAM-ID</td>
<td>SAMPLE1</td>
</tr>
<tr>
<td>File comment</td>
<td>Optional: Enter a comment related to the COBOL source file.</td>
</tr>
</tbody>
</table>

Click **Finish**. The SAMPLE1.cob file is created and opened in the COBOL editor.
4. Edit the program

Edit the COBOL source file that was created using the wizard. Add and modify data items and procedures as desired.

WORKING-STORAGE SECTION

```
01  WORD-VALUES.
   02  PIC X(10) VALUE "apple".
   02  PIC X(10) VALUE "black".
   02  PIC X(10) VALUE "cobol".
   02  PIC X(10) VALUE "dog".
   02  PIC X(10) VALUE "eye".
   02  PIC X(10) VALUE "fault".
   02  PIC X(10) VALUE "good".
   02  PIC X(10) VALUE "high".
   02  PIC X(10) VALUE "idea".
   02  PIC X(10) VALUE "junior".
   02  PIC X(10) VALUE "king".
   02  PIC X(10) VALUE "love".
   02  PIC X(10) VALUE "medium".
   02  PIC X(10) VALUE "new".
   02  PIC X(10) VALUE "open".
   02  PIC X(10) VALUE "pig".
   02  PIC X(10) VALUE "queen".
   02  PIC X(10) VALUE "review".
   02  PIC X(10) VALUE "smile".
   02  PIC X(10) VALUE "tomorrow".
   02  PIC X(10) VALUE "understand".
   02  PIC X(10) VALUE "version".
   02  PIC X(10) VALUE "wood".
   02  PIC X(10) VALUE "xylophone".
   02  PIC X(10) VALUE "yesterday".
   02  PIC X(10) VALUE "zoo".
   02  PIC X(10) VALUE "**error**".
01  WORD-TABLE REDEFINES WORD-VALUES.
   02  WORD-ITEM OCCURS 27 TIMES.
      03  FIRST-CHARACTER PIC X.
      03  PIC X(9).
```
01 WORD-INDEX PIC 9(3).
01 INPUT-CHARACTER PIC X.
01 REQUEST-MESSAGE PIC X(42) VALUE "ENTER ONE CHARACTER OF ALPHABETIC-LOWER.=>".

PROCEDURE DIVISION

DATA-INPUT SECTION.
**(1) DISPLAY THE ABOVE MESSAGE
   DISPLAY REQUEST-MESSAGE WITH NO ADVANCING.
**(2) ACCEPT THE INPUT CHARACTER
   ACCEPT INPUT-CHARACTER.
*
SEARCH-WORD SECTION.
**(3) WORDS ARE SEARCHED CORRESPONDING TO THE INPUT CHARACTER
   PERFORM TEST BEFORE
   VARYING WORD-INDEX FROM 1 BY 1
   UNTIL WORD-INDEX > 26
   IF INPUT-CHARACTER = FIRST-CHARACTER (WORD-INDEX)
   THEN EXIT PERFORM
   END-IF
   END-PERFORM.
*
WORD-OUTPUT SECTION.
**(4) THE RESULTING WORD MATCH IS DISPLAYED
   DISPLAY WORD-ITEM (WORD-INDEX).
*
EXIT PROGRAM.

After completing the editing, select Save from the context menu in the COBOL editor.

5. Build the project

   If Project > Build Automatically in the menu bar is enabled, the COBOL program will be built automatically when the source program is saved in the previous step. To manually execute the build, or to execute the build if the automatic build was cancelled, click the Project menu > Build Project.

6. Start the debugger

   Set Breakpoints

   Before starting the debugger, set breakpoints as follows:

   On the vertical ruler at the left edge of the COBOL editor window, position the cursor on the line where a breakpoint is to be set and double-click the left mouse button. A mark indicating a set breakpoint (●) is displayed on the vertical ruler.
Start the debugger

1. After completing the setting of breakpoints, start the debugger:
   - On the Run menu, click **Debug As > COBOL Application**.

2. A message is displayed to confirm switching to the Debug perspective when the first breakpoint is reached. Click **Yes**.
3. The Debug perspective is displayed, and processing is stopped at the first breakpoint.

Change of value of data item

1. Change a value of the “INPUT-CHARACTER” data item.
   Select the “INPUT-CHARACTER” data item in the COBOL editor, and select Add to Watch View from the context menu. “INPUT-CHARACTER” is added into the Watch View.

2. Select the “INPUT-CHARACTER” data item in the Watch view, and select Change Value from the context menu. The Set Value dialog box appears.

3. Change a value in the Set Value dialog box appears. Click OK.

Execution restart

Click either of the following buttons from the Debug View and the application is executed.
- Resume
- Step Into
- Step Over

For additional information, refer to “7.2.1 Debug view”.

---

After completing debugging, to return to the COBOL perspective, click the Window menu > Perspective > Open Perspective > COBOL.

---

7. Execute the COBOL program

To execute the COBOL program you created, click the Run menu > Run As > COBOL Application.

2.2 Creating a COBOL Program by Remote Development

This section explains the procedure for converting an existing COBOL project into a project under remote development, and then creating a COBOL program for a server by remote development.
1. Make server environment settings

Make environment settings for the server to be used for remote development. Check with your server administrator. For details on environment settings of a server, see “9.2.1.1 NetCOBOL Remote Development Service” and “9.2.2 Setting up the user environment on the server.”

2. Set server information

Set information for linkage with the server used for remote development.

1. On the Window menu, click Preferences. When the Preferences dialog box appears.
2. In the left pane, select COBOL > Remote Development. The Remote Development page appears.
3. Click New.

![Preferences dialog box](image)

The New Server Information dialog box appears.

4. Set the information required for linking to the server as follows:

<table>
<thead>
<tr>
<th>Field</th>
<th>Entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server name</td>
<td>Enter an arbitrary name that will be used to manage server information.</td>
</tr>
<tr>
<td>Server OS</td>
<td>Select the operating system of the server used for remote development.</td>
</tr>
<tr>
<td>Server address</td>
<td>Enter a name (FQDN: Fully Qualified Domain Name) or IP address that identifies the server in the network.</td>
</tr>
<tr>
<td>Save user name and password</td>
<td>Check this checkbox.</td>
</tr>
<tr>
<td>User name</td>
<td>Enter the user name of the account used to access the server.</td>
</tr>
<tr>
<td>Password</td>
<td>Enter the password assigned to the user.</td>
</tr>
<tr>
<td>Field</td>
<td>Entry</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>Character-code conversion</td>
<td>This section is for the specification of text file code conversion information.</td>
</tr>
<tr>
<td>COBOL Source character-code on the server side</td>
<td>Select the character-code of the COBOL source file transferred to the server side of remote development.</td>
</tr>
<tr>
<td>Convert character set in the server</td>
<td>Select <strong>Convert character set in the server</strong>, since code conversion processing is executed on the server.</td>
</tr>
<tr>
<td>Convert character set in the client</td>
<td>This field is disabled if &quot;Windows(x64)&quot; is selected at <strong>Server OS</strong> list.</td>
</tr>
<tr>
<td>Information for UNIX Server system</td>
<td>This information should be configured if Solaris, Linux(x86), Linux(itanium), or Linux(x64) is specified at <strong>Server OS</strong> list.</td>
</tr>
<tr>
<td>FTP is used for remote development</td>
<td>If this field is selected, use the ftpd/rexec service as the remote development server-side service.</td>
</tr>
<tr>
<td>Use PASV mode for file transfer(FTP)</td>
<td>Check this box only if file transfer will be in PASV mode. This field is enabled if remote development uses the server-side ftpd/rexec service.</td>
</tr>
<tr>
<td>NetCOBOL Remote Development Service on server side</td>
<td>This information is for the server-side NetCOBOL remote development service.</td>
</tr>
<tr>
<td>Port number</td>
<td>Specify the TCP/IP port number of the NetCOBOL remote development service.</td>
</tr>
<tr>
<td>SSH Port Forwarding</td>
<td>The connection to NetCOBOL remote development services are encrypted. When &quot;Linux(x64)&quot; is selected at <strong>Server OS</strong> list, this item is enabled.</td>
</tr>
<tr>
<td>SSH Port number</td>
<td>Specify the SSH Port number. The default value is 22. When &quot;SSH Port Forwarding&quot; is selected, this item is enabled.</td>
</tr>
<tr>
<td>SSH Server FingerPrint</td>
<td>Specify the FingerPrint by hexadecimal digit string. Ask the server administrator about the value. When &quot;SSH Port Forwarding&quot; is selected, this item is enabled.</td>
</tr>
<tr>
<td>Algorithm</td>
<td>Specify the algorithm of SSH Server FingerPrint (either sha1 or md5). Ask the server administrator about the value. The default value is md5. When &quot;SSH Port Forwarding&quot; is selected, this item is enabled.</td>
</tr>
</tbody>
</table>

5. After setting the information, click **Connection test**. When the information is correct, environmental variable information for the server is displayed.

To return to the **New Server Information** dialog box, click **OK**.
6. In the **New Server Information** dialog box, click **OK**. The **Preferences** dialog box appears. On the **Remote Development** page, the server name is displayed in the "Server name."

![Preferences dialog box](image)

To close the **Preferences** dialog box, click **OK**.

**Point**

Since the server information set in this step is shared among workspaces, the information can be used from another workspace.

---

3. **Set server information for the project**

To convert a COBOL project into one under remote development, set the server information for the project.

1. On the Dependency view or Structure view, select the project, and then click **Property** from the context menu. The property dialog box appears.

2. In the left pane, click **Remote Development**. The **Remote Development** page appears.

3. Set the server information for the project as follows:

<table>
<thead>
<tr>
<th>Field</th>
<th>Entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable project specific setting</td>
<td>This checkbox must be checked.</td>
</tr>
<tr>
<td>Enable remote development</td>
<td>This checkbox must be checked.</td>
</tr>
<tr>
<td>Server name</td>
<td>Select the server name that was entered in the &quot;Set server information&quot;.</td>
</tr>
</tbody>
</table>
Click the OK button to close the property dialog box.

### 4. Create a makefile

Create a makefile that will be used to build a COBOL program on the server.

1. On the Project menu, click Remote Development > Makefile Creation.... The Makefile Creation dialog box appears.
2. Leave the defaults and click OK.

The resources that are required for creating the makefile are sent to the server, and the makefile is created. The created makefile is named "Makefile" and registered in the Other Files folder. To view the contents of the makefile, select the makefile and select Open from the context menu.

---

**Note**

The following confirmation message may be displayed.

> [Build Automatically] is disabled. When [Build Automatically] is enabled, the makefile generation processing on the server cannot be executed.

To disable the automatic build, click OK.

---

**Point**

The makefile creation results on the server can be checked by selecting COBOL Remote from the Open Console icon on the toolbar in the Console view.

### 5. Build the project on the server

To build the COBOL program on the server, click the Project menu > Remote Development > Build.

**Point**

- Compilation errors are displayed in the Problems view. Select a compilation error, and then click Go To from the context menu. The COBOL editor opens the COBOL source file and displays it with the current line at the error location.
- The build results on the server can be checked by selecting COBOL Remote from the Open Console icon on the toolbar in the Console view.

### 6. Debug the COBOL program

To debug the COBOL program running on the server, launch the NetCOBOL interactive remote debugger and start debugging. Use the remote debugger connector, which is a tool for connecting a client to the server.

1. To start remote debugging, execute one of the commands listed below on the server to start the remote debugger connector.

<table>
<thead>
<tr>
<th>Server</th>
<th>Start command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows(x64)</td>
<td>cobrds64</td>
</tr>
<tr>
<td>Solaris</td>
<td>svdrds</td>
</tr>
</tbody>
</table>
2. Before starting the debugger, set breakpoints as follows:

On the vertical ruler at the left edge of the COBOL editor window, position the cursor on the line where a breakpoint is to be set and double-click the left mouse button. A mark indicating a set breakpoint (●) is displayed on the vertical ruler.

After completing the setting of breakpoints, start the debugger:

On the Run menu, click Debug Configurations... The Debug Configurations dialog box appears.

In the left pane, click Remote COBOL Application. To create a configuration, press the "New" button.
In the "Debug Style", select **Normal Debug**. To start debugging, click **Debug**.

Confirm Perspective Switch

This kind of launch is configured to open the Debug perspective when it suspends. This Debug perspective is designed to support application debugging. It incorporates views for displaying the debug stack, variables and breakpoint management. Do you want to open this perspective now?

A message is displayed to confirm switching to the Debug perspective when the first breakpoint is reached. Click **Yes**.
The Debug perspective is displayed, and processing is stopped at the first breakpoint. Click the **Run menu > the target menu item to perform debugging.**

**Point**

After completing debugging, to return to the COBOL perspective, click the **Window menu > Perspective > Open Perspective > COBOL.**
Chapter 3 COBOL Perspective

The NetCOBOL Studio window consists of the editor area and information display windows (views). The types of views displayed and the layout of the views are managed as "perspectives". The COBOL perspective, a perspective designed for COBOL program development, is applied when a COBOL project is created.

The COBOL perspective consists of the COBOL editor and the following views:

- Dependency view(*)
- Structure view(*)
- Navigator view(*)
- Properties view
- Outline view
- Problems view
- Tasks view
- Console view
- Templates view

*: In the properties dialog box, COBOL uses the following pages:

- Resource page
- Target page
- Build page
- Build Tools page
3.1 Dependency View

The Dependency view displays a tree showing dependencies between the files to be compiled and files to be linked when a project coded in COBOL is built. The Dependency view displays the following three types of subfolders:

- **Source Files folder**
  The *Source Files* folder specifies the COBOL source files, precompiler input source files and resource files (.rc) to be compiled. Only files that have been added to this folder are compiled by the corresponding compilers.

- **Linking Files folder**
  The files to be linked are displayed in the *Linking Files* folder. The folder specifies the library files (.lib) and object files (.obj) to be linked, in addition to files to be compiled.

- **Other Files folder**
  Files that are in the project but are registered in neither the *Source Files* folder nor the *Linking Files* folder are displayed in the *Other Files* folder.

3.1.1 The role of the Dependency view

The Dependency view displays dependencies within a project.

---

**Note**

The structure of COBOL source files and the class structure of a COBOL class repository are displayed in the Structure view.

---

The following folders are created in the Dependency view when a COBOL project is created:

- **Source Files folder**
  The *Source Files* folder specifies the files to be compiled in the project. The files displayed in this folder are compiled and linked at program build time.

Files with the following extensions are treated as COBOL source files and compiled by a COBOL compiler.

- .cob
- .cbl
- .cobol
- Extent associated with COBOL source file in *File Content*

Files registered as precompiler input source are called by the precompiler command before compilation. Files with the .rc extension are compiled only when the resource compiler has been added as a build tool to the project.

The files in the *Source Files* folder are compiled in the order displayed, with the dependencies of the files taken into consideration. To change the position of a file in the compilation order, select the file, and use or on the toolbar to move the file up or down, respectively.

For COBOL source files in the *Source Files* folder, the following folders are displayed according to the contents of the files or specified options:
- **Target Repository** folder

  The repository file that is generated when COBOL source files are compiled are automatically analyzed and displayed when the COBOL source files are saved. The generated repository file corresponds to the class defined in the COBOL source files. The name of the generated repository file is "class-name.rep". The repository file displayed in this folder is used to automatically determine the compilation order of the COBOL source files. It is also used to search for files that must be compiled when they are updated.

- **Dependent Files** folder

  The **Dependent Files** folder specifies the files on which COBOL source files depend. It also specifies the libraries referenced by the COBOL source files or the repository files of classes referenced by the COBOL source files. The files specified with this folder are used to automatically determine the compilation order of the COBOL source files. They are also used to search for files that must be compiled when they are updated. To add files, select **Add File...** from the context menu. Executing **Analyze Dependency** from the context menu enables the COBOL source files to be automatically analyzed, and files on which they depend to be added.

- **Target Object Files** folder

  The **Target Object Files** folder is displayed when **Specify Target Object Files** is selected from the context menu. The object files to be generated from COBOL source files are displayed. The object files displayed in this folder are to be linked. The displayed object files are updated when the COBOL source files are saved.

  These folders are used to automatically determine the compilation order of the COBOL source files.

  **Note**

  - To specify the name of a COBOL source file to register, specify a name that is different from the name of any other COBOL source file. If a COBOL source file with the same file name but a different extension is registered in the **Source Files** folder, an error occurs during build.
  
  - Files registered in the **Source Files** folder with the extensions ".cobol" and ".coh" are treated as COBOL source files. Files with the extension ".cbl" are treated as library files.
  
  - Of the COBOL library and descriptor files registered in the **Dependent Files** folder, only those within the project are transferred to the server during remote development. Files in other projects, and COBOL library and descriptor files managed in other folders, are not transferred. The only library files transferred to the server are those with the extension ".cbl".

  **For a remote development**

  - Files with the following extensions registered in the **Source Files** folder are treated as COBOL source files. These file are sent to the server.
    - When File Content are not set
      .coh, .cobol
    - When File Content are set
      Extension associated with COBOL source file in **File Content**

  - Files with the following extension registered in the **Source Files** folder are treated as a COBOL library file. These file are sent to the server.
    - When File Content are not set
      .cbl
    - When File Content are set
      Extent associated with COBOL library file in **File Content**

  - Of the COBOL library and descriptor files registered in the **Dependent Files** folder, only those within the project are transferred to the server during remote development. Files in other projects, and COBOL library and descriptor files managed in other folders, are not transferred.

**Linking Files folder**

The **Linking Files** folder specifies the library files (.lib) and object files (.obj) to be linked at build time. The object files to be generated from the COBOL source files specified with the **Source Files** folder need not be specified.
Other Files folder

Files that are in the project but registered in neither the Source Files folder nor the Linking Files folder are displayed in the Other Files folder.

Point

Operations involving files in the Dependency view are reflected in the Structure view.

3.1.1.1 Adding a COBOL source file in the Dependency view

For a COBOL source file in a project

Follow the steps below to add a COBOL source file to the project.

1. In the Dependency view, select the Source Files folder, and then select Add File... from the context menu. The Add Source Files dialog box for the selected project appears.
2. Select the file to be added to the Source Files folder. Click OK. The selected COBOL source file is added to the Source Files folder in the Dependency view. The addition of that added file is reflected in the Structure view.

Note

When adding COBOL source files stored in a subfolder under the workspace, under the Add Source Files dialog box, select the subfolder, and then select the files to add.

For a COBOL source file that is not in a project

Either of the following methods can be used to add a COBOL source file that is not in the project:

- Using Explorer in the Windows system, select the COBOL source file to be registered, and then select Copy from the context menu. Select the Source Files folder, and select Paste from the context menu.
- Using Explorer in the Windows system, drag and drop the COBOL source file into the Source Files folder.

3.1.1.2 Adding a link file in the Dependency view

To add a link file:

1. Select the Linking Files folder to which the file is to be added.
2. Select Add File... from the context menu. The Open dialog box appears.
3. Select the file to be added to the Linking Files folder.
4. Click Open. The selected file is added to the Linking Files folder in the Dependency view. The addition of that added file is reflected in the Structure view.

3.1.1.3 Adding a dependent file

To add a dependent file:

1. Select the Dependent Files folder to which the file is to be added.
2. Select Add File... from the context menu. The Open dialog box appears.
3. Select the file to be added to the Dependent Files folder.
4. Click Open. The selected file is added to the Dependent Files folder.

3.1.1.4 Deleting a dependent file

To delete a dependent file:

1. Select the file to be deleted from the Dependent Files folder.
2. Select **Delete** from the context menu.

3. When the file deletion confirmation message is displayed, click **Yes**. The file is deleted from the **Dependent Files** folder.

**Note**

The file is deleted only from the **Dependent Files** folder. Even though the file is deleted from the **Dependent Files** folder, it is not deleted from the disk.

### 3.1.2 Context menu of the Dependency view

The following table outlines the context menu items that are unique to the Dependency view.

#### 3.1.2.1 COBOL project

<table>
<thead>
<tr>
<th>Element</th>
<th>Project</th>
<th>Folder</th>
<th>File</th>
<th>Other Files</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source Files</td>
<td>S</td>
<td>S</td>
<td>S</td>
<td>S</td>
<td>New file</td>
<td>New file</td>
</tr>
<tr>
<td>Target Repository</td>
<td>S</td>
<td></td>
<td></td>
<td></td>
<td>COBOL source</td>
<td>Create a new Cobol source file in <strong>Source Files</strong> folder</td>
</tr>
<tr>
<td>Dependent Files</td>
<td>S</td>
<td></td>
<td></td>
<td></td>
<td>Object-Oriented COBOL Source</td>
<td>Create a new object-oriented source file in <strong>Source Files</strong> folder</td>
</tr>
<tr>
<td>Linking Files</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Add File</td>
<td>Add an existing file to the selected element.</td>
</tr>
<tr>
<td>Other Files</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- If the <strong>Source Files</strong> folder or the file under the <strong>Source Files</strong> folder is selected, it is added to the <strong>Source Files</strong> folder. For details, refer to &quot;3.1.1.1 Adding a COBOL source file in the Dependency view&quot;.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- If the <strong>Dependent Files</strong> folder or the file under the <strong>Dependent Files</strong> folder is selected, dependent files such as libraries and repository files are added to the <strong>Dependent Files</strong> folder. For details, see &quot;3.1.1.3 Adding a dependent file&quot;.</td>
</tr>
<tr>
<td>Element</td>
<td>Menu</td>
<td>Description</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-----------------------</td>
<td>-------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Project Source Files</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Folder</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>File</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Source Files</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Target Repository</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dependent Files</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Link Files</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Other Files</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Folder under [Other Files]</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Target Repository</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dependent Files</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Target Object Files</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Linking Files</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Other Files</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- If the **Linking Files** folder or the file under the **Linking Files** folder is selected, it is added to the **Linking Files** folder.

For details, see "3.1.1.2 Adding a link file in the Dependency view".

<table>
<thead>
<tr>
<th>Jump into</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>S S</td>
<td></td>
<td>Makes the selected project, folder or file become the root of the displayed hierarchy.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Jump Back</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>S S</td>
<td></td>
<td>Returns to the previous hierarchy.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Forward</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>S S</td>
<td></td>
<td>Proceeds to the former display hierarchy, when the <strong>Jump &gt; Back</strong> menu item is selected.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Up One Level</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>S S</td>
<td></td>
<td>Proceeds to the former display hierarchy, when the <strong>Jump &gt; Back</strong> menu item is selected.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Open</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>S S S S S S</td>
<td></td>
<td>Opens the selected file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Open From Application</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>S S S S S S</td>
<td></td>
<td>Selects an editor (COBOL editor, text editor, system editor, default editor) to open the selected file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Inheritance</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>C S</td>
<td></td>
<td>Not to be used.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Copy</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>S S S S S S</td>
<td></td>
<td>Copies the selected project, folder or file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Paste</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>C D S C D C C C S S S S D D D D D D D S</td>
<td></td>
<td>Pastes the copied project, folder or file.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Menu can be used when a project is copied.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- When a project is copied, it will be pasted into the workspace.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- When a folder is copied, if the selected element is the <strong>Other Files</strong> folder or the subordinate's element, this menu can be used.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- When a file is copied, if the selected element is a folder, it will be pasted into the folder. If the selected element is a file, it will be pasted into the folder of the selected file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Delete</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>S S S S S S</td>
<td></td>
<td>Deletes the selected elements.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- If the selected element is project, the selected project is deleted from the workspace. You can</td>
</tr>
<tr>
<td>Project</td>
<td>Folder</td>
<td>File</td>
</tr>
<tr>
<td>---------</td>
<td>--------</td>
<td>------</td>
</tr>
<tr>
<td>Source Files</td>
<td>Target Repository</td>
<td>Source Files</td>
</tr>
<tr>
<td></td>
<td>Target Project File</td>
<td>Target Repository</td>
</tr>
<tr>
<td></td>
<td>File</td>
<td>Source Files</td>
</tr>
<tr>
<td></td>
<td>Link Files</td>
<td>Other Files</td>
</tr>
<tr>
<td></td>
<td>Dependent Files</td>
<td>Target Object Files</td>
</tr>
<tr>
<td></td>
<td>Other Files</td>
<td>Linking Files</td>
</tr>
<tr>
<td></td>
<td>Folder under [Other Files]</td>
<td>Other Files</td>
</tr>
</tbody>
</table>

**Menu**

- **Rename**: Renames the selected folder or file.
- **Add To Source**: Adds the selected file to the Source Files folder. When the file is added to the Source Files folder, it will be removed from the Other Files folder. If the file is in a folder other than the project storage location, it is copied to the project storage location.
- **Remove from Source Folder**: Deletes the selected COBOL source files from the Source Files folder and moves them to the Other Files folder. The files are not deleted from the disk.
- **Main program**: Sets the selected source program as the main program of this project.

**Description**

- decide whether to delete the selected project from the disk.
  - If the selected element is a file in the Dependent Files folder, the selected file will be deleted from Dependent Files folder and moved into the Other Files folder. The selected file is not deleted from the disk.
  For details, see "3.1.1.4 Deleting a dependent file".
  - If the "Target Object Files" folder is selected, "specify target object file" will be unchecked and the "Target Object Files" folder is deleted. Files on disk are not deleted.
  - If the selected element is a file in the Linking Files folder, the selected file is not deleted from the disk.
  - If the selected element is a file or a folder other than the above, it will be deleted from the disk.

  *C D*
<table>
<thead>
<tr>
<th>Element</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project</td>
<td>Source Files</td>
<td>Resets the setting of main program from the selected COBOL source file. This menu item is only displayed when the COBOL source file, which is the main program, is selected. For details, see &quot;6.1.2 Setting the main program&quot;.</td>
</tr>
<tr>
<td>Folder</td>
<td>Target Repository File</td>
<td>Specifies Target Object Files: This menu item is selected for COBOL source files containing multiple compilation units (external programs or external classes). The files for which this menu item is selected (checked) are compiled after the NAME compile option is added to the other compile options of the files. The &quot;Target Object Files&quot; folder is added right under COBOL source file of the Dependency view and the object file generated from the COBOL source file is added to the &quot;Target Object Files&quot; folder. Analyzes all COBOL source files in the Source Files folder and extracts the target repositories and dependent files. Adds the target repository files to the Dependent Files folder. These target repository files are generated from library files, screen form descriptor files, dependent repository files to which COBOL source files refer, and COBOL source files.</td>
</tr>
<tr>
<td>File</td>
<td>Other Files</td>
<td>Analyze dependency: Analyzes all COBOL source files in the Source Files folder and extracts the target repositories and dependent files.</td>
</tr>
<tr>
<td>File</td>
<td>Dependent Files</td>
<td>All: Adds target repository files to the Dependent Files folder. These target repository files are generated from library files, screen form descriptor files, dependent repository files to which COBOL source files refer, and COBOL source files.</td>
</tr>
<tr>
<td>File</td>
<td>Other Files</td>
<td>Library: Adds library files and screen form descriptor files to which COBOL source files refer, to the Dependent Files folder.</td>
</tr>
<tr>
<td>File</td>
<td>Dependent Files</td>
<td>All: Adds dependent repository files and target repository files to which the COBOL source files refer, to Dependent Files folder.</td>
</tr>
</tbody>
</table>

- 29 -
<table>
<thead>
<tr>
<th>Project</th>
<th>Folder</th>
<th>File</th>
<th>Element</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source Files</td>
<td>Target Repository</td>
<td>Dependent Files</td>
<td>Target Project File</td>
<td>Link Files</td>
<td>Other Files</td>
</tr>
<tr>
<td>Source Files</td>
<td>Target Repository</td>
<td>Dependent Files</td>
<td>Target Project File</td>
<td>Link Files</td>
<td>Other Files</td>
</tr>
<tr>
<td>Source Files</td>
<td>Target Repository</td>
<td>Dependent Files</td>
<td>Target Project File</td>
<td>Link Files</td>
<td>Other Files</td>
</tr>
</tbody>
</table>

| S | S | S | Target | Adds target repository files generated from COBOL source files to the **Dependent Files** folder. |
| S | S | S | Depends | Adds dependent repository files to which the COBOL source files refer, to the **Dependent Files** folder. |
| S | S | S | Target object | Adds the name of object file generated from the COBOL source file to the "Target Object Files" folder. |
| S | S | S | Clear | Deletes all the files in the **Dependent Files** folder and clears their dependencies. |
| S | S | S | Clear | Deletes all the files in the **Dependent Files** folder and clears their dependencies. |
| C | C | C | Build project | Builds a project. For details, see “Chapter 6 Build Function”. This menu item is displayed only when "Build Automatically" from the "Project" menu is not checked. |
| S | S | S | Rebuild project | Rebuilds a project. For details, see “Chapter 6 Build Function”. |
| S | S | S | Build Debug Mode | When the remote development function is used, specifies whether the project is to be built in release mode or in debug mode for the remote project build. For remote project build details, see “9.5 Remote Build”. |
| S | S | S | Build | If the remote development function is used, builds the project remotely. For remote project build details, see “9.5 Remote Build”. |
| S | S | S | Rebuild | If the remote development function is used, rebuilds the project remotely. For remote project build details, see “9.5 Remote Build”. |
| S | S | S | Makefile Creation | If the remote development function is used, generates the makefile for remote development. For remote project build details, see “9.5 Remote Build”. |
| S | S | S | Debugger | Under the conditions that remote development functions are available and the server OS is the following, the remote debugger connector is started. |

- Solaris
<table>
<thead>
<tr>
<th>Element</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Source Files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Target Repository</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dependency Files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Link Files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Other Files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Folder under [Other Files]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Other Files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remote Debugger Connector</td>
<td>Remote Debugger Connector</td>
<td>Starts the remote debugger connector. Before performing attach debugging, it can be used to set which computers are permitted to connect to the client computer and change the port number for remote debugging. For remote debug connector details, see &quot;9.6.2.2 Remote debugger connector&quot;.</td>
</tr>
<tr>
<td>Transfer</td>
<td>NS</td>
<td>Cannot be used for COBOL projects.</td>
</tr>
<tr>
<td>Compile File</td>
<td>S C D S</td>
<td>Compiles the selected file.</td>
</tr>
<tr>
<td>Refresh</td>
<td>S S S S S S S S S S</td>
<td>Refreshes the selected element and its subordinate.</td>
</tr>
<tr>
<td>Property</td>
<td>S S S S S S</td>
<td>Displays the property of the selected elements.</td>
</tr>
</tbody>
</table>

**Meaning of signs**

S: Menu can be selected  
NS: Menu cannot be selected  
CD: Menu can be displayed under certain conditions  
Space: Menu cannot be displayed.

For the menu below, refer to the "3.3.3 Navigator view Context menu ".

- Team  
- Compare With  
- Replace  
- Restore from Local History  
- Source

3.1.2.2 COBOL Resource Project
<table>
<thead>
<tr>
<th>Element</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>S</td>
<td>New File</td>
<td>Creates a new file.</td>
</tr>
<tr>
<td>S</td>
<td>Jump into</td>
<td>Makes the selected project, folder or file become the root of the displayed hierarchy.</td>
</tr>
<tr>
<td>S</td>
<td>Back</td>
<td>Returns to the previous hierarchy.</td>
</tr>
<tr>
<td>S</td>
<td>Forward</td>
<td>Proceeds to the former display hierarchy, when the Jump &gt; Back menu item is selected.</td>
</tr>
<tr>
<td>S</td>
<td>Up One Level</td>
<td>Changes the display hierarchy to one up from the level of the present display hierarchy.</td>
</tr>
<tr>
<td>S</td>
<td>Open</td>
<td>Opens the selected file.</td>
</tr>
<tr>
<td>S</td>
<td>Open from Application</td>
<td>Selects an editor (COBOL Editor, Text Editor, System Editor or Default Editor) to open the selected file.</td>
</tr>
<tr>
<td>S</td>
<td>Delete</td>
<td>Deletes the selected project, folder or file.</td>
</tr>
<tr>
<td>S</td>
<td>Rename</td>
<td>Changes the name of the selected folder or file.</td>
</tr>
<tr>
<td>N S</td>
<td>Build Debug mode</td>
<td>Cannot be used for COBOL Resource projects.</td>
</tr>
<tr>
<td>N S</td>
<td>Build</td>
<td></td>
</tr>
<tr>
<td>N S</td>
<td>Rebuild</td>
<td></td>
</tr>
<tr>
<td>N S</td>
<td>Makefile Creation</td>
<td></td>
</tr>
<tr>
<td>N S</td>
<td>Debugger</td>
<td></td>
</tr>
<tr>
<td>N S</td>
<td>Remote Debugger</td>
<td></td>
</tr>
<tr>
<td>N S</td>
<td>Connector</td>
<td></td>
</tr>
<tr>
<td>S</td>
<td>Transfer</td>
<td>Transfers the resource of the project to a remote server.</td>
</tr>
<tr>
<td>S</td>
<td>Refresh</td>
<td>Refreshes the selected element and its subordinate.</td>
</tr>
<tr>
<td>S</td>
<td>Property</td>
<td>Displays the property of the selected element.</td>
</tr>
</tbody>
</table>

**Meaning of signs:**

S: Menu can be selected

NS: Menu cannot be selected

Space: Menu cannot be displayed.

For the following menu, see "3.3.3 Navigator view Context menu ".

- Team
- Compare With
- Replace With
- Restore from Local History
### 3.1.2.3 COBOL Solution Project

This section explains the context menu that displays when a COBOL solution project is selected. For information about the context menu that displays when a project added to COBOL solution project is selected, see "3.1.2.1 COBOL project" and "3.1.2.2 COBOL Resource Project".

<table>
<thead>
<tr>
<th>menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jump into</td>
<td>Makes the selected project, folder or file become the root of the displayed hierarchy.</td>
</tr>
<tr>
<td>Back</td>
<td>Returns to the previous hierarchy.</td>
</tr>
<tr>
<td>Forward</td>
<td>Proceeds to the former display hierarchy, when the Jump &gt; Back menu item is selected.</td>
</tr>
<tr>
<td>Up One Level</td>
<td>Changes the display hierarchy to one level up from the present display hierarchy.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected project from the workspace. You can choose whether to delete it from the disk. Projects added to the selected COBOL solution project are not deleted.</td>
</tr>
<tr>
<td>Project Management</td>
<td>Displays the Project Management dialog box. Projects can be added to or removed from the selected COBOL solution project. For the addition and the removal of projects, see &quot;4.3.1 Manage COBOL project. &quot;</td>
</tr>
<tr>
<td>Analyze Dependency</td>
<td>Performs Dependency Analysis for COBOL projects added to the selected COBOL solution project.</td>
</tr>
<tr>
<td>Build Project</td>
<td>Builds COBOL projects added to the selected COBOL solution project. For project build details, see &quot;Chapter 6 Build Function&quot;. This menu is displayed only when &quot;Build Automatically&quot; from the &quot;Project&quot; menu is not checked.</td>
</tr>
<tr>
<td>Rebuild Project</td>
<td>Rebuilds COBOL projects added to the selected COBOL solution project. For project build details, see &quot;Chapter 6 Build Function&quot;.</td>
</tr>
<tr>
<td>Build Debug Mode</td>
<td>Changes the build mode of COBOL projects added to the selected project. Specifies whether projects are to be built in release mode or in debug mode for remote project build. For remote project build details, see &quot;9.5 Remote Build&quot;.</td>
</tr>
<tr>
<td>Build</td>
<td>Builds COBOL projects added to the selected COBOL solution project. For remote project build details, see &quot;9.5 Remote Build&quot;.</td>
</tr>
<tr>
<td>Rebuild</td>
<td>Rebuilds COBOL projects added to the selected COBOL solution project. For remote project build details, see &quot;9.5 Remote Build&quot;.</td>
</tr>
<tr>
<td>Makefile Creation</td>
<td>Cannot be used for COBOL solution projects.</td>
</tr>
<tr>
<td>Debugger</td>
<td></td>
</tr>
<tr>
<td>Remote Debugger Connector</td>
<td></td>
</tr>
<tr>
<td>Transfer</td>
<td></td>
</tr>
<tr>
<td>Refresh</td>
<td>Refreshes the selected element and its subordinate.</td>
</tr>
<tr>
<td>Property</td>
<td>Displays the property of the selected element.</td>
</tr>
</tbody>
</table>

For the following menu, see "3.3.3 Navigator view Context menu ".

- Team
- Compare With
- Restore from Local History
3.1.3 Analyze Dependency

Analyze Dependency is the menu command for adding the following files that the COBOL source files associated with the "Dependent File".

- Library file
- Screen form descriptor file

Execute the Analyze Dependency in any one of the following conditions.

a. The COPY statement is added to or deleted from the COBOL source file.
   1. Execute the Analyze Dependency regarding the modified COBOL source files as target.
   2. Select Analyze Dependency > All from the context menu.

b. When one of the following happens with the workspace:
   - The library file used for projects (COBOL project or COBOL resource project) are added to or deleted from the workspace.
   - The dependent file is added to or deleted from the library file used for projects (COBOL project or COBOL resource project).
   - Under the setting of translation option, the reserved folder appointed library file in the translation option LIB or the reserved folder appointed descriptor file in the translation option FORMLIB, is modified.

   Execute the Analyze Dependency regarding the project that dependency happens in workspace as target in above conditions.
   1. In the Dependency view, select the COBOL project.
   2. Select Analyze Dependency > All from the context menu.

c. Compiler option.

Point

Following are some merits when executing Analyze Dependency.

- The dependent file can be added to the Dependent Files folder automatically.
- The dependent file can be modified (updated, saved) from the COBOL project that the COBOL source files of the reference is registered in.

Note

The screen form descriptor that is added as a dependent file can be updated in PowerFORM.

The form descriptor (.SMU/.PMU) used for UTF-32, which is produced with the Descriptor transformation command used for UTF-32, is not the target of Analyze Dependency. The screen form descriptor (.SMU/.PMU) used for UTF-32 cannot be added to dependent file.

3.2 Structure View

The Structure view hierarchically displays the internal program structure of COBOL source files. The Structure view has the following three types of subfolders:

- Source Files folder
- Linking Files folder
- Other Files folder
3.2.1 The role of the Structure view

Source Files folder

COBOL source files to be compiled are displayed in the Source Files folder. Its contents are equivalent to those of the Source Files folder in the Dependency view. The internal structure of each COBOL source file is hierarchically displayed under the COBOL source file. The structure displayed under each COBOL source file is as follows:

- For an ordinary COBOL source file
  - PROGRAM-ID
  - Environment division and section-name
  - Data division and section-name
  - Procedure division, section-name, and paragraph-name
- For an object-oriented COBOL source file
  - CLASS-ID
  - FACTORY
  - OBJECT
  - METHOD-ID
  - Environment division and section-name
  - Data division and section-name
  - Procedure division, section-name, and paragraph-name

Linking Files folder

Files to be linked but not compiled are displayed in the Linking Files folder. Its contents are equivalent to those of the Linking Files folder in the Dependency view.

Other Files folder

Files that are to be neither compiled nor linked are displayed in the Other Files folder. Its contents are equivalent to those of the Other Files folder in the Dependency view.

3.2.2 Context menu of the Structure view

The following table outlines the context menu items that are unique to the Structure view:

<table>
<thead>
<tr>
<th>Element</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Link file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Other file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Other file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Link file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Other file</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

3.2.2.1 COBOL Project

<table>
<thead>
<tr>
<th>Project</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Link file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Other file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Other file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Link file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Other file</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- S S S New file | A New file is created in the selected folder or the folder that the selected file belongs to.
<table>
<thead>
<tr>
<th>Element</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Source file</strong></td>
<td>S</td>
<td>Adds the new COBOL source file to the Source Files folder.</td>
</tr>
<tr>
<td><strong>Link file</strong></td>
<td>S</td>
<td>Adds the new Object-Oriented COBOL source file to the Source Files folder.</td>
</tr>
<tr>
<td><strong>Folder</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>File</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Other file</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Source file inner</strong></td>
<td>S</td>
<td></td>
</tr>
<tr>
<td><strong>Link file</strong></td>
<td>S</td>
<td></td>
</tr>
<tr>
<td><strong>Other file</strong></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- **Add File**: Adds an existing file to the selected folder or to the folder that the selected file belongs to.
- **Jump into**: Changes the display hierarchy in order that the selected project or folder converts to root.
- **Jump back**: Goes back to the former hierarchy from the current display hierarchy.
- **Jump forward**: Moves forward to the next hierarchy if the Jump Back option was used.
- **Up One Level**: Changes the display hierarchy to up one level from the present display hierarchy.
- **Open**: Opens the selected file.
- **Open From Application**: Selects an editor (COBOL editor, text editor, system editor or default editor) to open the selected file.
- **copy**: Copies the selected project, folder or file.
- **paste**: Pastes the copied project, folder or file. This menu item can be used when a project is copied.
  - When the project is copied, it will be pasted into the workspace.
  - When the folder is copied, if the selected element is the Other Files folder or the subordinate's element, this menu can be used.
  - When the file is copied, if the selected element is folder, it will be pasted into the folder. If the selected element is file, it will be pasted into the folder of the selected file.
- **delete**: Deletes the selected elements.
  - If the selected element is project, the selected project is deleted from the workspace. You can decide whether to delete the selected project from the disk.
  - If the selected element is a file in the Link Files folder, the selected file is not deleted from the disk.
  - If the selected file is other than a file in the Link Files folder, the selected file or folder is deleted from the disk.
<table>
<thead>
<tr>
<th>Element</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project</td>
<td>Source file</td>
<td>S</td>
</tr>
<tr>
<td></td>
<td>Link file</td>
<td>S</td>
</tr>
<tr>
<td></td>
<td>Other file</td>
<td>S</td>
</tr>
<tr>
<td></td>
<td>Other file inner</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Source file</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Link file</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Other file</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Other file inner</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Source file</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Link file</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Other file</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Other file inner</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Source file</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Link file</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Other file</td>
<td></td>
</tr>
<tr>
<td>Element</td>
<td>Menu</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>Project</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Folder</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Source file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Link file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Other file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>File</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Source file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Link file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Other file</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Makefile Creation**

If the remote development function is used, the makefile for remote development is generated. For remote project build details, refer to "9.5 Remote Build".

**Debugger**

Under the conditions that remote development functions are available and the server OS is the following, the remote debugger connector is started.

- Solaris

**Remote Debugger Connector**

Starts the remote debugger connector. Before performing attach debugging, use the remote debug connector when you want to change the restriction and the port number of the computer that performs the remote debug. For remote debug connector details, refer to "9.6.2.2 Remote debugger connector".

**Transfer**

Cannot be used for COBOL projects.

**Compile File**

Compiles the selected file.

**Refresh**

Refreshes the selected element and its subordinate.

**Property**

Displays the property of the selected elements.

### Meaning of signs

S: Menu can be selected

NS: Menu cannot be selected

CD: Menu can be displayed under certain conditions

Space: Menu cannot be displayed.

For the menu below, refer to the "3.3.3 Navigator view Context menu ".

- Team
- Compare With
- Replace
- Restore from Local History
- Source

### 3.2.2.2 COBOL resource project

The context menu of selected COBOL resource project is the same as Dependency view context menu. Refer to "3.1.2.2 COBOL Resource Project" under "Dependency view".
3.2.2.3 COBOL solution project

The context menu of selected COBOL solution project is the same as the Dependency view context menu except that Analyze Dependency is not displayed. Refer to "3.1.2.3 COBOL Solution Project" under "Dependency View".

3.3 Navigator View

The Navigator view hierarchically displays resources in a workspace. This view displays all the files and folders in each project. A file can be opened by double-clicking it. A project can be created, opened, or closed from the context menu of the Navigator view.

3.3.1 The role of the Navigator view

The Navigator view displays files in existing subfolders and folders of a project. The following operations can be performed from the Navigator view:

- Creating a project, file, or folder
- Opening a project, file, or folder
- Closing a project
- Deleting a project, file, or folder
- Renaming a project, file, or folder
- Setting properties for a project
- Applying a filter
- Sharing files in the Concurrent Versions System (CVS)

3.3.1.1 Applying a filter to the view

Follow the procedure below to apply a filter to the view.

1. In the Navigator view, click ☰, and then click Filters…. The Navigator Filters dialog box appears.
2. Select one or more filters to be applied from the option list.
3. To select all filters, click Select All. To clear the filter, click Deselect All.
4. To apply all selected filters to the Navigator view, click OK. The dialog box closes. To close the dialog box without applying the filters to the Navigator view, click Cancel.

3.3.1.2 Sharing files in the Concurrent Versions System (CVS)

In the team programming environment of the Concurrent Versions System (CVS), each team member performs work independently from the other members. A CVS repository can be shared with other team members. Only a project or the files in a project can be shared. If a project is shared, only the files in the project are displayed in the repository. Other team members can access only the files that are explicitly shared.

Sharing an existing CVS repository location and project

To share an existing CVS repository location and project:

1. In the Navigator view, select the project, and then select Team > Share Project from the context menu. The Share Project dialog box appears.
2. To use an existing repository, select Use existing repository location.
3. Select the location from the displayed list.
4. Click Finish. The project is shared at the selected CVS repository location.
Sharing a new CVS repository location and project

To share a new CVS repository location and project:

1. In the Navigator view, select the project, and then select Team > Share Project from the context menu. The Share Project dialog box appears.
2. Specify the following on the Enter Repository Location Information page.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host</td>
<td>Select or enter the host address.</td>
</tr>
<tr>
<td>Repository path</td>
<td>Select or enter the repository path to the host.</td>
</tr>
<tr>
<td>User</td>
<td>Enter the user name for a connection to the host.</td>
</tr>
<tr>
<td>Password</td>
<td>Enter the password for host access.</td>
</tr>
<tr>
<td>Connection type</td>
<td>Select the type of CVS connection to the repository.</td>
</tr>
<tr>
<td>Use Default Port</td>
<td>Select a port for the connection.</td>
</tr>
<tr>
<td>Use Port</td>
<td>Select a port from the list box.</td>
</tr>
<tr>
<td>Save password</td>
<td>When checked, the password is saved to the computer.</td>
</tr>
</tbody>
</table>

3. Click Next.
4. Specify the options on the Enter Module Name page as follows:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use project name as module name</td>
<td>Specify this option to use the project name as a module name.</td>
</tr>
<tr>
<td>Use specified module name</td>
<td>Check this item to not use the project name as a module name, and enter a module name in the text box.</td>
</tr>
</tbody>
</table>

5. Click Finish. The project is shared at the new CVS repository location.

Sharing a file

To share a file:

1. Select the file from a project folder.
2. Select Team > Add to Version Control from the context menu.
3. Select Commit from the context menu of the file or project.
4. The file is shared at the CVS repository location, and other users can access the file.

Accessing a project or file in a CVS repository

To access a project or file in a CVS repository:

1. On the Windows menu, click Perspective > Open Perspective > Other.... The Open perspective dialog box appears.
2. Select CVS Repository Exploring, click OK. The CVS Repository perspective opens.
3. Expand the host that has shared projects and files.
4. Select the project for checkout processing.
5. Select Check Out As from the context menu. The Check Out As dialog box appears. Select Check out as a project in the workspace and enter a project name in the Project Name field.
6. Click Finish. The display returns to the COBOL perspective, where the Navigator view displays the project and the files under the project.
Comparing versions of a source file

To compare the latest version of a COBOL source file with an older version:

1. In the Navigator view, select the version of the COBOL source file whose contents are to be compared with the current version.
2. Select Compare With > Local History from the context menu. The History dialog box appears.
3. Select a version from the Revision Time list.
4. The latest version of the COBOL source file is displayed in the Workspace File area of the Text Compare editor, and the selected version is displayed in the Local History area. Modifications in the text in each file are highlighted.
5. To move to the previous or next modification, select Compare with Each Other.
6. To close the dialog box, click OK.

Replacing a current file with a previous version

To replace the current COBOL source file with a previous version:

1. In the Navigator view, select the COBOL source file to be replaced.
2. Select Replace With > Local History from the context menu. The Compare dialog box appears.
3. Select a version from the Local History list.
4. The current version of the COBOL source file is displayed in the right pane of the Text Compare editor, and the selected version is displayed in the Local History area in the left pane. Modifications in each file are highlighted.
5. To replace the file of the current version with that of the selected version, click Replace. The dialog box closes. To close the dialog box without replacing the file, click Cancel.

Note

Replace With > Previous from Local History is selected; the current version of the file is replaced with that of the last stored version.

To perform a Replace With operation for an open file, first save the replacement file.

3.3.1.3 Property options

The properties of the selected resource are displayed when File is used, or when Properties in the context menu is used. The items displayed in the properties page depend on the selected resource. For example, if a file is selected, only specific properties are displayed; if a project is selected, all setting options are displayed.

Property options are displayed by selecting File > Properties from the menu bar. Options can be displayed, or their settings can be changed using the properties dialog box.

Displaying and setting file properties

To change the read-only status of a file:

1. On the properties dialog box, in the left pane, click Resource.
2. The details of Path, Type, Location, and Last modified are displayed on the Info page.
3. The file properties can be changed by selecting Read only or canceling the selection.

Displaying and setting project reference properties

To enable a resource to reference another project in a workspace:

1. In the properties dialog box, click Project References. The Project References page appears.
2. To enable the resource to reference another project in the workspace, select the other project from the list.
3.3.2 Navigator view Tools

Tools of the Navigator view can be used for various operations.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Arrow Left]</td>
<td>Returns to the previous hierarchical view.</td>
</tr>
<tr>
<td>![Arrow Right]</td>
<td>Proceeds to the next hierarchical view.</td>
</tr>
<tr>
<td>![Folder Down]</td>
<td>Displays the hierarchy at the next higher level.</td>
</tr>
<tr>
<td>![Folder Expand]</td>
<td>Reduces the tree of all resources in the expanded display.</td>
</tr>
<tr>
<td>![Link Editor]</td>
<td>Toggles enabling the link between the Navigator view and the active editor.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Expand]</td>
<td>Displays options such as Sort and Filters in the menu.</td>
</tr>
<tr>
<td>Select Working Set</td>
<td>Selects a working set.</td>
</tr>
<tr>
<td>Deselect Working Set</td>
<td>Cancels a working set.</td>
</tr>
<tr>
<td>Edit Active Working Set</td>
<td>Used to edit a working set.</td>
</tr>
<tr>
<td>Sort by Name</td>
<td>Sorts files in alphabetical order.</td>
</tr>
<tr>
<td>Sort by Type</td>
<td>Sorts file types in alphabetical order.</td>
</tr>
<tr>
<td>Filters</td>
<td>Filters the resources to be displayed.</td>
</tr>
<tr>
<td>Link with Editor</td>
<td>Toggles enabling the link between the Navigator view and the active editor.</td>
</tr>
</tbody>
</table>

3.3.3 Navigator view Context menu

The following table outlines the context menu items for the Navigator view:

<table>
<thead>
<tr>
<th>Element</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project</td>
<td>Folder</td>
<td>File</td>
</tr>
<tr>
<td>Project</td>
<td>Folder</td>
<td>Go Into</td>
</tr>
<tr>
<td>Project</td>
<td>Folder</td>
<td>Open in New Window</td>
</tr>
<tr>
<td>Project</td>
<td>Folder</td>
<td>Open</td>
</tr>
<tr>
<td>Project</td>
<td>Folder</td>
<td>Open With</td>
</tr>
<tr>
<td>Project</td>
<td>Folder</td>
<td>Copy</td>
</tr>
<tr>
<td>Project</td>
<td>Folder</td>
<td>Paste</td>
</tr>
<tr>
<td>Project</td>
<td>Folder</td>
<td>Delete</td>
</tr>
<tr>
<td>Element</td>
<td>Menu</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>Project</td>
<td>Move</td>
<td>Moves a resource to another location. The dialog box into which you can enter the move destination of the resource appears.</td>
</tr>
<tr>
<td>Folder</td>
<td>Rename</td>
<td>Renames a resource.</td>
</tr>
<tr>
<td>File</td>
<td>Import</td>
<td>Opens the <code>Import</code> wizard.</td>
</tr>
<tr>
<td></td>
<td>Export</td>
<td>Opens the <code>Export</code> wizard.</td>
</tr>
<tr>
<td></td>
<td>Build Project</td>
<td>Builds the selected project. This menu item is displayed when the COBOL project or COBOL resource project is selected. And when “build automatically” is not checked.</td>
</tr>
<tr>
<td></td>
<td>Close Project</td>
<td>Closes the selected project. This menu item is displayed when the selected project is opening.</td>
</tr>
<tr>
<td></td>
<td>Open Project</td>
<td>Opens the selected project. This menu item is displayed when the selected project is closed.</td>
</tr>
<tr>
<td></td>
<td>Close Unrelated Project</td>
<td>Closes project that is not the selected project. This menu item is displayed when the unselected project is opening.</td>
</tr>
<tr>
<td></td>
<td>Refresh</td>
<td>Updates the selected resource and view of subsets.</td>
</tr>
<tr>
<td></td>
<td>Run As COBOL Application</td>
<td>This menu item is displayed when a COBOL project, folder in COBOL project, or file in a COBOL project is selected.</td>
</tr>
<tr>
<td></td>
<td>Run Configurations</td>
<td>Opens the <code>Run Configurations</code> dialog. For details, refer to &quot;Chapter 8 Execution Function&quot;.</td>
</tr>
<tr>
<td></td>
<td>Debug As COBOL Application</td>
<td>Start the debugger to debug the selected project. The project must have been built. This menu item is displayed when a COBOL project, folder in COBOL project, or file in a COBOL project is selected.</td>
</tr>
<tr>
<td></td>
<td>Debug Configurations</td>
<td>Opens the <code>Debug Configurations</code> dialog. For details, refer to &quot;7.1.2 The startup configuration&quot;, &quot;9.6.1.2 Starting the remote debugger&quot; or &quot;9.6.2.1 Starting the remote debugger&quot;.</td>
</tr>
<tr>
<td></td>
<td>Team</td>
<td>Shares a project and displays the local history. (The sub-menu of the effective team function is displayed.) The sub-menu &quot;apply to patch&quot; cannot be used.</td>
</tr>
<tr>
<td></td>
<td>Compare with</td>
<td>Compares the selected resource. (Possible comparison targets are displayed as submenu items).</td>
</tr>
<tr>
<td></td>
<td>Replace With</td>
<td>Replaces the selected resource. (Possible replacements are displayed as submenu items).</td>
</tr>
<tr>
<td></td>
<td>Restore from Local History</td>
<td>Restores a deleted resource from the local history.</td>
</tr>
<tr>
<td></td>
<td>Source</td>
<td>This menu item cannot be used.</td>
</tr>
<tr>
<td></td>
<td>Properties</td>
<td>Displays the resource properties.</td>
</tr>
<tr>
<td></td>
<td>Compile File</td>
<td>Compiles the file.</td>
</tr>
</tbody>
</table>
Meaning of signs

S: Menu can be selected
NE: Menu cannot be selected
CD: Menu can be displayed under certain conditions
Space: Menu cannot be displayed.

Point

The functions of the Navigator view context menu, except Move and Replace With, can be used in the Dependency view and Structure view.

3.4 Property View

The Property view displays the properties of resources in the COBOL project selected in the Dependency, Structure, or Navigator view. Buttons are provided in the toolbar to toggle to display properties by category, to filter advanced properties, and to restore a selected property to its default value. For more information regarding a resource, right-click the resource name in one of the navigation views and select Properties from the pop-up menu.

3.5 Outline View

The Outline view displays a structural outline of the COBOL source file that is currently active in the COBOL editor. The contents of the Outline view vary depending on the COBOL program type.

The tree structure displayed in the Outline view is as follows:

- For an ordinary COBOL source file
  - PROGRAM-ID
  - Environment division and section-name
  - Data division and section-name
  - Procedure division, section-name, and paragraph-name

- For an object-oriented COBOL source file
  - CLASS-ID
  - FACTORY
  - OBJECT
  - METHOD-ID
  - Environment division and section-name
  - Data division and section-name
  - Procedure division, section-name, and paragraph-name

Function of the Outline view

The Outline view has the following function:

- Move to an element
  The cursor in the editor is moved to the location of the selected element, such as a program name or method name.

3.5.1 Toolbar
### 3.6 Problems View

The Problems view displays error messages, warning messages, etc. for problems that occur during compilation. Each message displayed in the Problems view is associated with the corresponding COBOL source file or project. For each displayed COBOL compiler error or warning message, the corresponding COBOL source file and line number are indicated.

#### 3.6.1 Problems view display

The information displayed in the Problems view is as follows:

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Severity</td>
<td>Displays an icon representing a severity level (error, warning, or information).</td>
</tr>
<tr>
<td>Description</td>
<td>Provides an explanation of the problem.</td>
</tr>
<tr>
<td>Resource</td>
<td>Displays the names of resources associated with the problem. For global problems, the relevant project name is displayed.</td>
</tr>
<tr>
<td>Path</td>
<td>Displays the folder containing the resources associated with the problem.</td>
</tr>
<tr>
<td>Location</td>
<td>If the problem is in a file, this field displays the line numbers indicating where the problem occurred.</td>
</tr>
<tr>
<td>Type</td>
<td>Displays the type of problem.</td>
</tr>
</tbody>
</table>

#### 3.6.2 Using the Problems view to locate an error

If an error occurs during a build for a project, the Problems view displays the error. To locate an error:

1. Errors are indicated as follows:
   - The Problems view displays a list of errors.
   - The lines containing errors are highlighted in the editor.

2. Double-click on an error in the Problems view, or select an error and then select Go To from the context menu. The file containing the detected error is opened in the editor, and the relevant location is highlighted.

3. Use the editor to modify erroneous coding and re-build the project. When the problem is resolved, the Problems view no longer displays the error.

---

*Note*

If the folder path is not displayed in the Problems view in the Path item, the error position cannot be identified, even Go to is selected from the context menu. This applies if the compile error is in a library external to the project.

### 3.7 Tasks View

The Tasks view can be used to record an issue as a task for future consideration. Tasks can be associated with COBOL source files. For additional information regarding the Tasks view, see the “Workbench User Guide” in the Help information.
3.7.1 Tasks view display

The Tasks view displays the status, priority, and explanation of each task. Tasks that are associated with COBOL source files are displayed together with relevant file names, folders, and line numbers. The information displayed in the Tasks view is as follows:

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Completed</td>
<td>Indicates whether a task has been completed. Each completed task has a checkmark. Checkmarks for completed tasks can be also added manually.</td>
</tr>
<tr>
<td>Priority</td>
<td>Indicates the priority of a task (high, middle, or low). The priority of a task can be changed using the combo box in this column.</td>
</tr>
<tr>
<td>Description</td>
<td>Provides an explanation of a task. To edit the explanation provided by a user for a task, select this column.</td>
</tr>
<tr>
<td>Resource</td>
<td>Displays the names of resources involved in a task. This field is blank for global tasks.</td>
</tr>
<tr>
<td>Path</td>
<td>Displays the folder containing the resources involved in a task. This field is blank for global tasks.</td>
</tr>
<tr>
<td>Location</td>
<td>Displays the line numbers associated with a task.</td>
</tr>
<tr>
<td>Type</td>
<td>Displays the type of a task.</td>
</tr>
</tbody>
</table>

3.7.2 Associating a task with a COBOL source file

Associating a task with a COBOL source file designates the sections to be displayed in a task list. To associate a task with a COBOL source file:

1. Use the COBOL editor to display the COBOL source file.
2. Using the vertical ruler on the left side of the COBOL editor, go to the line in the source file where the new task is to be recorded and select Add Task from the context menu. The Properties dialog box appears.
3. Set the contents and priority of the task, and click OK. The task is added to the Tasks view, and an icon representing the task is displayed to the left of the line on which the task was added.
4. The task in the COBOL source file can be displayed with the COBOL editor by double-clicking on the task in the Tasks view.
5. To delete the task, select Delete from the context menu of the task icon, or select the task in the Tasks view and press the Delete key.

3.8 Console View

The following functions can be used in the Console view:

- COBOL remote
  In remote development, the results of makefile creation and the results of a build on a server can be displayed.
- Build console
  The results of a COBOL program build on a local personal computer can be displayed.

3.9 Templates view

Use the following procedures to display the Templates view.

1. On the Window menu, click Show View > Other.... The Show View dialog box appears.
2. Select \texttt{COBOL > Templates}, click \texttt{OK}. The Templates view appears.

In the Templates view, root category, category and template are displayed as hierarchy.

The root category is "COBOL".

The category is "Reference", "Statement" and so on displayed as hierarchy.

Template is "COPY statement [COPY]", "REPLACE statement [REPLACE]" and so on displayed as hierarchy.

The content of the displayed template in the Templates view is different based on the extension of opening file in the active editor.

For example, the defined [COBOL] root category is associated with the following file extensions

- .cbl
- .cobol
- .cob

When opening a file that has an that is not associated with the defined root category in the editor, or the file cannot be opened in the editor, only the main file ("templates.xml") without the root category is displayed in Templates view.

\textbf{Note}

"COBOL" is the defined root category. The defined root category cannot be deleted or renamed.

\subsection*{3.9.1 The role of Templates View}

In the Templates view, the following functions can be used.

- Insert template pattern (*) into source file.
- Edit, add and delete template.
- Import and export template.
- Activate and invalidate template

*: Also can call Model code which is inserted with using template "template pattern".
3.9.1.1 Insert template patterns into source file

The example below illustrates inserting a PERFORM statement from a template into the procedure division of a COBOL source file.

```
PERFORM WITH TEST BEFORE
   VARYING repeat count FROM 1 BY 1
   UNTIL repeat count > 26
```

1. Opens the edited COBOL source file in the COBOL editor.
2. PERFORM statement is inserted into position at which the cursor is positioned.
3. In the Templates view, displays the inserted template pattern.

**Point**

The content of displayed template in Templates view is different according to the extension of opening file in active editor.

Displays the root category used for COBOL when opening COBOL source file (the file whose extension is .cob, .cobol or .cbl).

4. Selects the inserted template pattern, and then select Insert with Parameter Value... or Insert with Multiple Parameter Values... from context menu. The Input Assistance dialog box appears.
5. Input identifier, initial values, incremental value of PERFORM statement. Click **OK**.

**Table 3.1 Input Assistance dialog box**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pattern preview</td>
<td>Displays the pattern of template.</td>
</tr>
<tr>
<td>Description</td>
<td>Displays the descriptions of template.</td>
</tr>
<tr>
<td>Enter parameter value</td>
<td>In condition that pattern of template includes argument, inputs value to Value field. This graph cannot be displayed when the pattern of template without input argument.</td>
</tr>
</tbody>
</table>

PERFORM statement is inserted into COBOL source file.

The condition that template pattern without arguments.

In the condition that template pattern without arguments, inserts as the following procedures.

1. Displays the Templates view.
2. Opens the source file in COBOL editor.
   
   The content of displayed template in Templates view is different according to the extension of opening file in active editor.
   
   Displays the root category used for COBOL when opening the COBOL source file (the file whose extension is .cob, .cobol or .cbl).
3. In COBOL editor, puts the cursor into the position at which template pattern intends to insert.
4. From Templates view, selects used template and then selects insert from context menu. Template pattern is inserted in COBOL editor.

3.9.1.2 Adding, editing, and deleting a template

The following can be executed.

- Add root category
- Add category
- Add template
- Edit root category
- Edit category
- Edit template
- Delete root category
- Delete category
- Delete template

Create root category

Use the following procedures to create a root category.

1. In the Templates view, select "templates.xml", and then select Add > Root Category... from the context menu. Or, select templates.xml from Categorization of the template in the Templates page, and then click New... .

The Add Root Category dialog box appears.

Table 3.2 Add Root Category dialog box

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Root category name</td>
</tr>
<tr>
<td>Descriptions</td>
<td>Description of the root category.</td>
</tr>
<tr>
<td>File extensions</td>
<td>The summary of the file extent associated with the root category is displayed.</td>
</tr>
</tbody>
</table>

Add... To add the file extent into the File extensions, click Add... . The Select File Extensions dialog box will display and then you can select an extent to add.

Remove To remove the file extent from the File extensions, click Remove.

2. Input the above items. Click OK.

Create category

Use the following procedures to create a category.

1. Select the parental category or root category from the Templates view and then select Add > Category from the context menu. Or, select the parental category or root category from Categorization of template in the Templates page and then click New... .

The Add Category dialog box appears (Add Category/Template dialog box appears when creating from Templates page.)

Table 3.3 Add Category dialog box (Add Category/Template dialog box when creating from Templates page.)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent Name</td>
<td>Displays the selected category or root category as parent.</td>
</tr>
<tr>
<td>Category</td>
<td>Check the &quot;Category&quot;.</td>
</tr>
<tr>
<td>Template</td>
<td>Note: When Add &gt; Category is selected from the Templates view, the &quot;Templates&quot; is unavailable.</td>
</tr>
<tr>
<td>Name</td>
<td>Category name. Category name must specify the identified name in parent category.</td>
</tr>
<tr>
<td>Keyword</td>
<td>Category cannot be inputted when it is checked.</td>
</tr>
<tr>
<td>Descriptions</td>
<td>Category description.</td>
</tr>
<tr>
<td>Pattern</td>
<td>Category cannot be inputted when it is checked.</td>
</tr>
</tbody>
</table>

2. Input the above items. Click OK.
Create template

Use the following procedures to create a template.

1. Select the parental category or root category from the Templates view and then select Add > Category from the context menu. Or, select the parental category or root category from Categorization of template in the Templates page and then click New... .

Add template dialog box appears (Add Category/Template dialog box appears when creating from Templates page.)

Table 3.4 Add template dialog box (Add Category/Template dialog box when creating from template page.)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent name</td>
<td>Displays the selected category or root category as parent.</td>
</tr>
<tr>
<td>Category</td>
<td>Check the &quot;Category&quot;.</td>
</tr>
<tr>
<td>Template</td>
<td>Note: When Add &gt; Templates is selected from the Templates view, the &quot;Category&quot; is unavailable.</td>
</tr>
<tr>
<td>Name</td>
<td>Template name.</td>
</tr>
<tr>
<td>Keyword</td>
<td>Template key word.</td>
</tr>
<tr>
<td>Descriptions</td>
<td>Template description.</td>
</tr>
<tr>
<td>Pattern</td>
<td>Template pattern.</td>
</tr>
</tbody>
</table>

2. Input the above items. Click OK.

**Note**

- The Template cannot be displayed in the Content Assist list without inputting the Keyword box.
- It is necessary to encompass the variable names with "${" and "}" when the variable will be used in the Pattern box.

For example:

COPY$[text-name]

- Variable names that can be used in the Pattern box apply the rule of user-defined words used in COBOL. For user-defined words used in COBOL, refer to "COBOL Language Reference".

Edit root category

Use the following procedures to edit the name of the root category, descriptions and associated file extent. A system-defined Root category can be edited in the same way as a user-defined root category. However, a predefined root category name cannot be edited.

1. In the Templates view, select the root category to be edited, and then select Edit... from the context menu. Or, select the root category to be edited from Categorization of template in Templates page and then click Edit... .

The Edit Root Category dialog box appears.

Table 3.5 Edit Root Category dialog box

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Root category name.</td>
</tr>
<tr>
<td>Description</td>
<td>Descriptions of root category.</td>
</tr>
<tr>
<td>File extensions</td>
<td>Displays the file extent associated with the root category.</td>
</tr>
<tr>
<td>Add...</td>
<td>To add a file extent into the File extensions, click Add... The Select File Extensions dialog box will display, and then you can select extent to be added.</td>
</tr>
<tr>
<td>Remove</td>
<td>To remove the file extent from the File extensions, click Remove.</td>
</tr>
</tbody>
</table>
2. Make any desired changes. Click OK.

**Edit category**

Use the following procedures to edit the category.

1. In the Templates view, select the category to be edited and then select Edit..., from the context menu. Or, select the edited category from the Categorization of the template in Templates page, and then click Edit....

   The Edit Category dialog box appears.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent name</td>
<td>Displays the selected category or root category as parent.</td>
</tr>
<tr>
<td>Category</td>
<td>&quot;Category&quot; is checked.</td>
</tr>
<tr>
<td>Template</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Category name. Category name must specify the identified name in parent category.</td>
</tr>
<tr>
<td>Keyword</td>
<td>Cannot be inputted when the &quot;Category&quot; is checked.</td>
</tr>
<tr>
<td>Description</td>
<td>Category descriptions.</td>
</tr>
<tr>
<td>Pattern</td>
<td>Cannot be inputted when the &quot;Category&quot; is checked.</td>
</tr>
</tbody>
</table>

2. Make any desired changes. Click OK.

**Edit template**

Use the following procedures to edit the existing system-defined template and user-defined template.

1. In the Templates view, select the template to be edited and then select Edit..., from the context menu. Or, selects the category to be edited from the Categorization of the template in Templates page, and then click Edit....

   The Edit Template dialog box appears.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent name</td>
<td>Displays the selected category or root category as parent.</td>
</tr>
<tr>
<td>Category</td>
<td>&quot;Templates&quot; is checked.</td>
</tr>
<tr>
<td>Template</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Template name.</td>
</tr>
<tr>
<td>Keyword</td>
<td>Template keyword.</td>
</tr>
<tr>
<td>Description</td>
<td>Template description.</td>
</tr>
<tr>
<td>Pattern</td>
<td>Template pattern.</td>
</tr>
</tbody>
</table>

2. Make any desired changes. Click OK.

**Delete root category or category**

Use the following procedures to delete a category or root category (except the predefined category). Both user-defined categories and system-defined categories can be deleted.

1. Select the category or root category that you want to delete from the Templates view and then select Delete from the context menu. Alternatively, select the category or root category that you want to delete from the Categorization of the template in Templates page, and then click Delete.

   The Delete dialog box appears.

2. Click Yes.
Delete template

Use the following procedures to delete a template. Both user-defined templates and system-defined templates can be deleted.

1. Select the template that you want to remove from the Templates view, and then select Delete from the context menu. Alternatively, select the template you want to delete from the Categorization of the template in Templates page, and then click Delete. The Delete dialog box appears.

2. Click Yes.

3.9.1.3 Import and export template

Import Template

It is possible to import a template or category into a category or root category. When importing the file that has a category or root category with the same name as the selected category or root category, the contents of category and root category will be merged.

When importing a root category and merging it into an existing root category, the file extent relationship of the existing root category will remain and not be changed.

Use the following procedures to import.

1. Display the Templates page.

2. Select the template or category that you want to import from the Categorization of the template, and then click Import.... The Importing Template dialog box appears.

3. Select the path that is the import source of the template or category, and the file (XML file in valid form), and then click Open. The template or category is imported. An error message is displayed when an invalid XML file is selected.

When importing a template, the name of template can be used repeatedly.

Note

An XML file that only has a template or category (which does not have a route category) cannot be imported into the main root ("templates.xml").

Export template / category

Use the following steps to export the category or template.

1. Display the Templates page.

2. Select the template or category that you want to export from the Categorization of the template, and then click Export.... The Exporting Templates dialog box appears.

3. Input the name of the XML file after selecting the path that is the export destination of the template or category, and then click Save. The template or category is exported.

Export all

Use the following steps to export all templates, categories and root categories.

1. Display the Templates page.

2. Click Export All. The Exporting Templates dialog box appears.

3. Input the name of the XML file after selecting the path that is the export destination of the template or category, and then click Save. The template or category is all exported.

3.9.1.4 Validation/Invalidation of template

Use the context menu for the Templates view to enable or disable the template.
The validated template is displayed in the editor input support candidate list (Content Assist).

- The invalidated template cannot be displayed in the editor input support candidates list (Content Assist).

Select the template from the Templates view, and then select Enable or Disable from the context menu.

### 3.9.2 Context menu of Templates view

<table>
<thead>
<tr>
<th>elements</th>
<th>menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Templates.xml</td>
<td>root category</td>
<td>Add...</td>
</tr>
<tr>
<td></td>
<td>category</td>
<td>Add...</td>
</tr>
<tr>
<td></td>
<td>template</td>
<td>Add...</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Edit...</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Delete</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Insert</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Insert with Parameter Value...</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Insert with Multiple Parameter Values...</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Enable</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Disable</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Copy</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Refresh</td>
</tr>
</tbody>
</table>

**Meaning of signs**

S: Menu can be selected

Space: Menu cannot be displayed.

### 3.9.3 Templates page

Using the Template page, it is possible to create a new template or edit the configuration of an existing template.

Use the following procedures do display the Templates page.

1. On the Window menu, click Preferences. The Preferences dialog box appears.
2. In the left pane, select **COBOL > Templates**. The **Templates** page appears.

<table>
<thead>
<tr>
<th>Items</th>
<th>Descriptions</th>
</tr>
</thead>
</table>
| Categorization of template | Template list appears.  
- When selecting root category  
  Displays the category description in Description, and then displays the file extent in the **File extensions** box.  
- When selecting template  
  Displays the template in the **Descriptions** box, displays the keyword in the **Keyword** box, and then displays the template pattern in the **Pattern preview** box. |
| New...                  | Creates a root category, category or template.                               |
| Edit...                 | Edits the selected category and template.                                    |
| Remove                  | Deletes the selected category and template.                                  |
| Import...               | Imports template.                                                           |
| Export...               | Exports template.                                                           |
| Export All...           | Exports all templates into the file system.                                 |

**Note**

When “Templates.xml” is the root node in “Categorization of template”, removing and changing cannot be executed.
Chapter 4 Project

4.1 Overview

NetCOBOL Studio manages the resources and information necessary for program development in individual units called "projects".
The following projects are used for COBOL program development.
- COBOL Solution project
- COBOL project
- COBOL Resource project

4.1.1 COBOL Solution project

The COBOL solution project contains one or more projects (COBOL project, COBOL solution project).
The COBOL solution project can set the common options for the projects.
For example, when an application is created that consists of an executable file and multiple dynamic link libraries, the project that targets
an executable file can be created. Also the multiple projects that target each dynamic link library can be created. The COBOL solution
project can build and manage these projects.

4.1.2 COBOL project

The COBOL project is used for COBOL program development.
One COBOL project manages the resources of one target (executable program or library).

4.1.3 COBOL Resource project

COBOL resource projects can be used to effectively manage COBOL resources.
For example, a referenced Library-file from multiple COBOL projects can be registered to a COBOL resource project, and also can be
referenced from multiple projects.
COBOL resource projects cannot be built.
COBOL resources that can be managed in a COBOL resource project are as follows.
### File Types and Extensions

<table>
<thead>
<tr>
<th>File type</th>
<th>File extent (recommendation)</th>
</tr>
</thead>
<tbody>
<tr>
<td>COBOL library file</td>
<td><em>.CBL/</em>.COB/*.COBOL</td>
</tr>
<tr>
<td>Screen form descriptor file</td>
<td><em>.SMD/</em>.PMD (*)</td>
</tr>
<tr>
<td>Repository file</td>
<td>*.REP</td>
</tr>
<tr>
<td>Library file</td>
<td>*.LIB</td>
</tr>
<tr>
<td>Object file</td>
<td>*.OBJ</td>
</tr>
</tbody>
</table>

*: If the file is a form descriptor used for UTF-32, the file extension will be .SMU or .PMU. The form descriptor used for UTF-32 is created by the form descriptor used for the CNVMED2UTF32 command. The form descriptor used for UTF-32 (.SMD/.PMD) cannot be directly updated by using FORM and PowerFORM. When you want to update the selected form descriptor file from NetCOBOL Studio, create the form descriptor used for UTF-32 by the form descriptor used for the CNVMED2UTF32 command before building it.

Register the screen form descriptor before conversion (.SMD/.PMD) and the screen form descriptor after conversion (.SMU/.PMU) into a COBOL resource project.

For details about the form descriptor used for CNVMED2UTF32 command, refer to the "NetCOBOL User's Guide".

### 4.1.4 Notes for project management

- Projects for 32-bit and 64-bit COBOL applications cannot be created in the same workspace. Separate workspace folders must be specified for 32-bit and 64-bit COBOL projects.
- The following files that are created in the project folder must not be edited:
  - .Settings\org.eclipse.core.resources.prefs
  - .CobolOptions
  - .project
  - build.xml
- When using a workspace that was used in an old version of NetCOBOL Studio, some menu items do not appear. In this case, perform the following steps.
  1. On the Window menu, click **Perspective > Close All Perspectives** from the menu bar. All open perspectives will be all closed.
  2. On the Window menu, click **Perspective > Open Perspectives > Other...** The **Open Perspective** dialog box appears. Select "COBOL (default)", and then click **OK**.

### 4.2 Wizards

To create a COBOL resource, the following wizards are available in NetCOBOL Studio.

<table>
<thead>
<tr>
<th>Generated resource</th>
<th>Wizard</th>
</tr>
</thead>
<tbody>
<tr>
<td>COBOL Solution project</td>
<td>COBOL Solution project generation wizard</td>
</tr>
<tr>
<td>COBOL project</td>
<td>COBOL project generation wizard</td>
</tr>
<tr>
<td>COBOL Resource project</td>
<td>COBOL Resource project generation wizard</td>
</tr>
<tr>
<td>COBOL Source file</td>
<td>COBOL Source generation wizard</td>
</tr>
<tr>
<td>COBOL Source file(Object-Oriented)</td>
<td>Object-Oriented COBOL Source generation wizard</td>
</tr>
<tr>
<td>COBOL library file</td>
<td>COBOL library generation wizard</td>
</tr>
</tbody>
</table>
**Point**

The encoding of the newly created COBOL source file is as followings.

- When starting the COBOL project generation wizard and creating a COBOL project, it will be the specified "Text file encoding" in the target definition page.
- When adding a new COBOL source file to an existing COBOL project, it will be the selected encode that is the "Text file encoding" in the "Resource" page of project property.

---

### 4.2.1 COBOL solution generation wizard

Use the following procedures to start the COBOL solution generation wizard.

1. On the **File** menu, click **New > COBOL Solution Project**. The COBOL Solution generation wizard is started.
2. In the **COBOL Solution Project** page, enter the basic project information, and click **Next** or **Finish**.

<table>
<thead>
<tr>
<th>Table 4.1 COBOL Solution Project information</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Items</strong></td>
</tr>
<tr>
<td>Project name</td>
</tr>
<tr>
<td>Contents</td>
</tr>
<tr>
<td>Create new project in workspace</td>
</tr>
<tr>
<td>Create new project in external location</td>
</tr>
</tbody>
</table>

3. When the **Next** button is clicked, the **Project Management** page is displayed and projects can be added into the **Solution's projects**. For details about the **Project Management** page, refer to "4.3.1 Manage COBOL project".

---

**Information**

Default values of COBOL solution project settings can be changed. For detail, refer to the "4.6 Default values of New COBOL Project settings".

---

### 4.2.2 COBOL Project generation Wizard

Wizards are used to create COBOL projects and COBOL source files. This section explains the COBOL project wizard used to create a COBOL project. The COBOL project generation wizard defines a target. To create a COBOL project:

1. On the **File** menu, click **New > COBOL Project**. The COBOL Project generation wizard is started.
2. Specify the project information, and click **Next**.

<table>
<thead>
<tr>
<th>Table 4.2 Project information</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Items</strong></td>
</tr>
<tr>
<td>Project name</td>
</tr>
<tr>
<td>Contents</td>
</tr>
<tr>
<td>Create new project in workspace</td>
</tr>
<tr>
<td>Create new project in external location</td>
</tr>
</tbody>
</table>
3. Define a target, and then click **Next**.

Define the target type and target file name of the COBOL program to be created.

**Table 4.3 Defining the target**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target type</td>
<td>Specify the target type of the COBOL program to be created. When creating an executable file (exe), select “Executable”. When creating a dynamic link library (dll), select “Dynamic-link library”.</td>
</tr>
<tr>
<td>Use the DLL specific runtime initialization file(COBOL85.CBR)</td>
<td>For a target type of Dynamic-link library, if this option is selected, an initialization file for DLL-specific execution is used.</td>
</tr>
<tr>
<td>Target name</td>
<td>Specify a file name for the target file (exe/dll) to be created.</td>
</tr>
<tr>
<td>Application format</td>
<td>Specifies the format of the created application.</td>
</tr>
<tr>
<td>COBOL console window</td>
<td>Specifies that a console window created by a COBOL program is the input-output destination of ACCEPT and DISPLAY statements, and that a message box is the output destination of execution-time error messages.</td>
</tr>
<tr>
<td>System console window</td>
<td>Specifies that the system console (command prompt window) is the input-output destination of ACCEPT and DISPLAY statements and execution-time error messages.</td>
</tr>
<tr>
<td>Use precompiler</td>
<td>Select this item to create a COBOL project that uses the precompiler.</td>
</tr>
<tr>
<td>Text file encoding</td>
<td>Select the text file encoding for the files to be created in the project.</td>
</tr>
</tbody>
</table>

**Information**

- After the project is created, text file encoding can be changed as follows:

1. In the Dependency view or Structure view, select the project for which the Text file encoding is to be changed.
2. Select **Property** from the context menu. The Properties dialog box appears.
3. In the left pane, click **Resource**. The **Resource** page is displayed.
4. In the **Text file encoding**, select file encoding to be changed, and then Click **OK**.

- Default values of COBOL project settings can be changed. For detail, refer to the "4.6 Default values of New COBOL Project settings".

**Note**

- If the Text file encoding is changed, file encoding of existing project files are not changed. When the Text file encoding is different from the file encoding of a project, a compile error or a runtime error might occur during the build or the execution. These encodings need to correspond.
- In a remote development, when you build COBOL source file of the text file encode "UTF-8", installs NetCOBOL V10.0.0 or later in the server side.

4. In the **Define the target** page, if the **Use precompiler** check box is selected, the precompiler link information page appears. Enter the precompiler link information, and click **Next**.

**Table 4.4 Precompiler link information**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Precompiler command</td>
<td>Specifies the name of a command that starts the precompiler.</td>
</tr>
<tr>
<td>Precompiler parameters</td>
<td>Specifies the precompiler command parameters.</td>
</tr>
</tbody>
</table>
### Field Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| Precompiler source extension        | Specifies the extension of an input source file for the precompiler. The following extensions cannot be specified:  
- cobol  
- cob  
- cbl  
- lcai |
| Precompiler output source extension | Select the file extension for the output source file from the precompiler. |
| Use original source line numbers for error messages | If this item is checked, COBOL compiler error messages are displayed using the line number in the original source, rather than the line number of the preprocessed source. (The INSDBINF (*) command is invoked.) The default setting is unchecked. |
| INSDBINF parameters                 | This item sets parameters of the INSDBINF command, which develops line information for the precompiler input source in COBOL source files generated by precompilation. Note that input and output source file names cannot be specified because they are determined from precompiler input source file names. |

*: For the INSDBINF command, refer to "6.2.2 INSDBINF command".

Specify precompiler link information for the COBOL project to be created.

For more precompiler link information, see "6.2.1 Setting and changing initial values of precompiler link information".

5. In the Skeleton Code Selection page, click Generate code. Select either “COBOL Source” or “Object-Oriented COBOL Source”, and then click Finish. A COBOL project is generated, and the source generation wizard is displayed.

#### Table 4.5 Making selections

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Do not generate code</td>
<td>A project is created, and no source code is generated with the project.</td>
</tr>
<tr>
<td>Generate code</td>
<td>A project is created using a wizard that generates a template of source code. Select a wizard from &quot;Available skeleton codes&quot;.</td>
</tr>
<tr>
<td>Available skeleton codes</td>
<td>If the Generate code is specified, select a source code generation wizard.</td>
</tr>
<tr>
<td>COBOL Source</td>
<td>Select either &quot;COBOL Source&quot; or &quot;Object-Oriented COBOL Source&quot;</td>
</tr>
<tr>
<td>Object-Oriented COBOL Source</td>
<td></td>
</tr>
</tbody>
</table>

Specify whether to generate source code. To generate source code before creating the project, select the appropriate source code generation wizard from Available skeleton codes.

For details on the source generation wizard, see "4.2.4 COBOL source generation wizard."

---

**Information**

Default values of COBOL Solution Project settings are changed in the following way.

1. On the Window menu, click Preferences. The Preferences dialog box appears.
2. In the left pane, select COBOL > Solution/Project. The Solution/Project page appears.
3. In the Solution/Project page, change the values of settings, and then click OK.

---

### 4.2.3 COBOL resource generation wizard

Use the following procedures to start the COBOL resource generation wizard.
1. On the File menu, click New > COBOL Resource Project. The COBOL resource generation wizard is started.

2. In the COBOL Resource Project page, enter the project information, and then click Finish.

<table>
<thead>
<tr>
<th>Items</th>
<th>Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>Project name.</td>
</tr>
<tr>
<td>Contents</td>
<td>The location where the project resource should be saved.</td>
</tr>
<tr>
<td>Create new project in workspace</td>
<td>Saves the project resource in the workspace folder.</td>
</tr>
<tr>
<td>Create new project in external location</td>
<td>Saves the project source in the external workspace. When this item is selected, the Browse button is enabled. Click the Browse button and selects the folder of the save location.</td>
</tr>
</tbody>
</table>

### 4.2.4 COBOL source generation wizard

To use the COBOL source generation wizard to create a COBOL source file:

1. On the File menu, click New > COBOL Source. The COBOL Source generation wizard is started.

2. In the COBOL Source Information page, enter the basic information for the COBOL source, and then click Finish.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>Enter a name for the project in which the source file is created.</td>
</tr>
<tr>
<td>File name</td>
<td>Specify a name for the COBOL source file to be created.</td>
</tr>
<tr>
<td>PROGRAM-ID</td>
<td>Enter a PROGRAM-ID. The PROGRAM-ID is the same as the File name by default. To change the PROGRAM-ID, enter a new one in this field.</td>
</tr>
<tr>
<td>File comment</td>
<td>Optional: Enter a comment to be added at the beginning of the generated COBOL source code.</td>
</tr>
<tr>
<td>Use precompiler</td>
<td>Select this item to generate a precompiler input source. This item is enabled only if precompiler link information has been set for the workspace. For details on setting precompiler link information for a workspace, see &quot;6.2.1 Setting and changing initial values of precompiler link information&quot;.</td>
</tr>
</tbody>
</table>

**Point**

The extension of the newly created the COBOL source file is the extension selected by Selecting the extension when creating a COBOL source file of Solution/Project page.

### 4.2.5 Object-oriented COBOL source generation wizard

To use the object-oriented COBOL source generation wizard to create an object-oriented COBOL source file:

1. On the File menu, click New > Object-Oriented COBOL Source. The Object-Oriented COBOL Source generation wizard is started.

2. In the Object-Oriented COBOL Source Information page, enter the basic information for the object-oriented COBOL source, and then click Finish.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>Enter a name for the project in which the source file is created.</td>
</tr>
<tr>
<td>File name</td>
<td>Specify a name for the COBOL source file to be created.</td>
</tr>
</tbody>
</table>
4.2.6 COBOL Library generation wizard

To use the COBOL Library generation wizard to create a COBOL library file:

1. On the File menu, click New > COBOL Library. The COBOL Library generation wizard is started.
2. In the COBOL Library Information page, enter the basic information for the COBOL library, and then click Finish.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>COBOL Library File Name</td>
<td>Specify a name for the COBOL Library file to be created.</td>
</tr>
<tr>
<td>Project</td>
<td>Select if the destination of the COBOL Library file is an existing project.</td>
</tr>
<tr>
<td>Project name</td>
<td>Specify a name for the project in which the COBOL Library file is to be created.</td>
</tr>
<tr>
<td>External Folder</td>
<td>Select if the destination of the COBOL Library file is outside of the project.</td>
</tr>
<tr>
<td>Folder</td>
<td>Specify a name for the folder in which the COBOL Library file is to be created.</td>
</tr>
</tbody>
</table>

**Point**

The extension of the newly created the COBOL library file is the extension selected by Selecting the extension when creating a COBOL library file of Solution/Project page.

4.3 COBOL Solution Project

For the summary of COBOL solution, refer to "4.1.1 COBOL Solution project".

4.3.1 Manage COBOL project

4.3.1.1 Adding a project

The following projects can be added to the COBOL solution project:
Use the **Project Management** dialog box to add a project.

1. Select the COBOL solution project, and then select **Project Management** from the context menu. The **Project Management** dialog box appears.
2. In the **Workspace’s projects** list, select the project, and then click **Add--->**. A project is added in the **Solution’s projects** list.
3. Click **Finish**.

**Note**

- A project can only be added to one COBOL solution project. To add it in another COBOL solution project, close the COBOL solution project that already has it or remove it from the COBOL solution project. Close a project by selecting the project to be closed and then selecting "Close Project" from "Project" menu, or by selecting the project to be closed in the Navigator view and then selecting "Close Project" from context menu.
- When the COBOL solution project exists in workspace, if import the other COBOL solution project or update the multiple COBOL solution projects that are shared among projects, the project has been added to the multiple COBOL solutions. In this case, to make sure that the project has been added to one of the COBOL solution, close the COBOL solution project, or remove the project from the COBOL solution project.

### 4.3.1.2 Remove Project

When Remove Project is selected the target project is removed from the COBOL solution project.

Remove a project by using the **Project Management** dialog box.

1. Select the COBOL solution project, and then select **Project Management** from the context menu. The **Project Management** dialog box appears.
2. In the **Solution’s projects** list, select the project, and then click **<-- Remove**. The project is deleted from the **Solution’s projects** and added into the **Workspace’s projects**.
3. Click **Finish**.

**Note**

A project that is in the following state is unable to be added into a **Workspace’s projects** after being removed from a COBOL solution project.
- Project does not exist in the workspace
- The COBOL solution project in operation has been added to another COBOL solution project

### 4.3.2 Operate project together

It is possible to operate the projects together in the COBOL solution project using the COBOL solution project context menu that is available from the Dependency view or Structure view. The context menu is displayed when the COBOL solution project is selected and then right-clicked.

For help on the COBOL solution project context menu, refer to "3.1.2.3 COBOL Solution Project" for the Dependency view, and refer to "3.2.2.3 COBOL solution project" for the Structure view.

### 4.3.3 Setting common options for the projects

It is possible to set the common options for the projects in the COBOL solution project by using the COBOL solution property dialog.
- Build
- Build Tool (Pre-compiler)
Moreover, to enable the build options that are set in the COBOL solution project, uncheck the **Enable project specific setting** check box in the Build page of each constitution project property.

---

### 4.4 COBOL Project

For the summary of COBOL solution, refer to "4.1.2 COBOL project".

#### 4.4.1 Adding Existing COBOL Resources

This section explains how to add existing COBOL resources to a COBOL project.

---

**Note**

- **Text file encoding**
  
  When existing COBOL resources are added to a COBOL project, the project's text file encoding setting is applied for the added resources. The project's text file encoding is specified in the Info page of the Properties dialog box of the project. COBOL resources which have BOM (Byte Order Mark) are treated as UTF-8.

- **Code conversion**
  
  Although the text file encoding of existing COBOL resources are changed when they are added to a COBOL project, code conversion is not invoked. File encoding of the COBOL resources remain unchanged.

---

#### 4.4.1.1 Adding a COBOL source file

COBOL source files registered in the Source Files folder of a COBOL project in the Dependency or Structure view are compilation processing targets. To register an existing COBOL source file in the Source Files folder:

- For a COBOL source file that is in the project
  
  1. In the Dependency view, select the **Source Files** folder of the project.
  2. Select **Add File**, from the context menu. The **Add Source Files** dialog box corresponding to the selected project appears.
  3. Select the file to be added to the Source Files folder, and then click **OK**. The selected source file is added to the Source Files folder in the Dependency view. The added file is reflected in the Structure view.

- For a COBOL source file that is not in the project, either of the following methods can be used:
  
  - Using Windows Explorer, select the COBOL source file to be registered and select "Copy" from the context menu. Select the Source Files folder, and then select "Paste" from the context menu.
  - Using Windows Explorer, drag and drop the COBOL source file into the Source Files folder.

#### 4.4.1.2 Adding a link file

To add a link file:

1. Select the **Linking Files** folder of the project.
2. Select **Add File**, from the context menu. The **Open** dialog box appears.
3. Select the file to be added, and then click **OK**. The selected file is added to the **Linking Files** folder in the Dependency view. The added file is reflected in the Structure view.
4.4.1.3 Adding a dependent file

To add a dependent file:

1. Select the **Dependent Files** folder of the project.
2. Select **Add File...** from the context menu. The **Open** dialog box appears.
3. Select the file to be added, click **OK**. The selected file is added to the **Dependent Files** folder.

### 4.5 COBOL Resource Project

For the summary of COBOL resource project, refer to "4.1.3 COBOL Resource project".

#### 4.5.1 Adding the existing COBOL resource

**Adding a file in the project**

Files in the project can be added as follows.

- Drag & drop files to the COBOL resource project from the registered file in the Dependency view.

**Adding a file outside the project**

Files outside the project, can be added in one of the following ways.

- Add the existing COBOL resource into a COBOL resource project by using the File system option for the import function. For details, refer to the file system of the Import Wizard.
- Drag & drop files to the COBOL resource project from Windows Explorer.

#### 4.5.2 Take reference from other projects

A Resource that is managed by a COBOL resource project can be referenced in other projects.

The steps to reference a library-file of a COBOL resource project from a COBOL project are shown below.

It is assumed that the COBOL project and the COBOL resource project have already been registered in the workspace.

1. Display the **Compiler Options** page of the COBOL project.
   For details about the **Compiler Options** page, see "6.1.3 Setting compile options".
2. Click **Add...**. The **Add Compiler Options** dialog box appears.
3. In the **Compiler options** list, select the "LIB", and then click **Add...**. The **LIB Compiler Option** dialog box appears.
4. Click **Browse...**. The **Folder type selection** dialog box appears.
5. In the **Folder type** list, click **Specify from the project**, and then click **OK**. The **Selection from project** dialog box appears.
6. Select the COBOL resource project that contains the library-file you want to refer to on the tree and then click **OK**.
   In the **LIB Compiler Option** dialog box, click **OK**. The LIB (the path of the selected COBOL resource project) is set in the **Compiler options** list.

#### 4.6 Default values of New COBOL Project settings

Default values that are set when a new project is created from the COBOL solution generation wizard or the COBOL project generation wizard are changed in the following way.

1. On the **Window** menu, click **Preferences**. The Preferences dialog box appears.
2. In the left pane, select **COBOL > Solution/Project**. The **Solution/Project** page appears.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target type</td>
<td>Specifies the type of TARGET to be output. &quot;Executable&quot; or &quot;Dynamic-link library&quot; can be selected. The default is &quot;Executable&quot;.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>-------</td>
<td>-------------</td>
</tr>
<tr>
<td>Application format</td>
<td>Specifies the type of a console window executable applications use.</td>
</tr>
<tr>
<td>Use Precompiler</td>
<td>Check if precompiler is used.</td>
</tr>
<tr>
<td>Select the extension when creating a COBOL Source file.</td>
<td>Specifies the extension of COBOL source files created by the COBOL source generation wizard.</td>
</tr>
<tr>
<td>Select the extension when creating a COBOL library file.</td>
<td>Specifies the extension of COBOL library files created by the COBOL library generation wizard.</td>
</tr>
</tbody>
</table>

3. Change the values of settings, and click OK.

### 4.7 File Content

**Setting file content**

In the setting of the file content, you can associate the following files with the extension.

- COBOL source file
- COBOL library file
- Screen form descriptor file

**To set the file content**

1. In the Dependency view or Structure view, select the COBOL project or COBOL solution project.
2. On the File menu, click Properties, or select Property from the context menu. The Property dialog box appears.
3. In the left pane, select File Content. The File Content page appears.
4. If the COBOL project, you can set the project specific settings by checking the Enable project specific setting check box. When unchecked, the settings of the COBOL solution project become effective.
5. For the extension displayed in Name/Extension, select the file to associate from the Content list. Click OK.

In the file content, the extensions that can be associated with files are as follows.

- For COBOL source files, COBOL library files
  Extension associated with the COBOL source file in the Content Types
- Screen form descriptor file
  Extension associated with the COBOL screen form descriptor in the Content Types

**To set the Content Types**

1. On the Windows menu, click Preferences. The Preferences dialog box appears.
2. In left pane, select General > Content Types. The Content Types page appears.
3. In the Content types list, select Text > COBOL Source File or COBOL Screen form descriptor, and then click Add. The Add Content Type Association dialog box appears.
4. Enter extension name to be newly associated in the text box, click OK (*.*aaa for example)
5. Check the following, click OK.
   - The extension of COBOL source files and COBOL library files are displayed in File Associations when select Text > COBOL Source File in Content Types page.
   - The extension of Screen form descriptor file is displayed in File Associations when you select COBOL Screen form descriptor in Content Types page.
Note

- When the associated extension is not used in the project, select the **Unused extension** in Content list of the **File Content** page.
- You can restore the association of extension and file to the initial state by clicking the **Restore Defaults option**.
- You must not associate the same extension with **COBOL Source File** and **COBOL Screen form descriptor** in **Content Types**.
Chapter 5 Editor

This chapter provides information regarding the COBOL editor, which is used to edit COBOL source files. To start the COBOL editor, select the file to be edited in the Dependency view or Structure view, and double-click the file or select Open from the context menu. An editing window is displayed when the COBOL editor is started, and the name of the file is displayed on the tab of the editing window. When the file has unsaved changes, an asterisk (*) is displayed after the file name.

5.1 Highlighting Key Words

Key words can be highlighted with colored characters or with a bold font style. The following table lists the items that can be highlighted.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comment line</td>
<td>If &quot;*&quot; or &quot;/&quot; is in the indicator area at the beginning of a line, the entire line is commented out. If &quot;D&quot; or &quot;d&quot; is in the indicator area at the beginning of a line, the entire line is commented out, regardless of whether the line contains debugging information.</td>
</tr>
<tr>
<td>Comment in a line</td>
<td>If a line contains &quot;*&gt;&quot;, the part from that point to the end of the line is treated as a comment in the line.</td>
</tr>
<tr>
<td>Reserved word</td>
<td>A reserved word list is defined for each COBOL version. For reserved words, see the NetCOBOL Grammar. Reserved words are not case-sensitive.</td>
</tr>
<tr>
<td>Figurative constant</td>
<td>SPACE, SPACES, ZERO, ZEROS, ZEROES, HIGH-VALUE, HIGH-VALUES, LOW-VALUE, LOW-VALUES, QUOTE, QUOTES, ALL. Figurative constants are not case-sensitive.</td>
</tr>
<tr>
<td>Special register</td>
<td>LINAGE-COUNTER, PROGRAM-STATUS, RETURN-CODE, SORT-STATUS, EDIT-MODE, EDIT-OPTION, EDIT-OPTION2, EDIT-OPTION3, EDIT-COLOR, EDIT-STATUS, EDIT-CURSOR, PAGE-COUNTER, SORT-CORE-SIZE. Special registers are not case-sensitive.</td>
</tr>
<tr>
<td>Character string</td>
<td>A character string is defined with any of the following formats: &quot; &quot;,B&quot; &quot;,X&quot; &quot;,N&quot; &quot;,NC&quot; &quot;,NX&quot; = Character strings are not case-sensitive. Single quotation marks or double quotation marks can be used.</td>
</tr>
</tbody>
</table>

Displaying the highlight setting

To display the highlight setting:

1. On the Window menu, click Preferences. The Preferences dialog box appears.
2. In the left pane, select COBOL > Editor. The Editor page appears.
3. Click the Colors tab. The Foreground, Color, Bold, and Preview areas are displayed.
4. Select an item in the Foreground area. The associated style is displayed in the Color and Bold areas. The current setting is displayed in the Preview area.

Note

By default, reserved words are displayed in bold characters, and other items are displayed in the normal style.

Changing the highlight setting

To change the highlight setting:

1. In the Foreground area, select the item whose highlight setting is to be changed.
2. Select **Color**. The **Color** dialog box appears.

3. Select the color to be applied from the **Basic colors** palette. A color can be created by selecting **Custom colors**.

4. To apply the selected color and close the dialog box, click **OK**. The selected color is reflected in the displayed contents of the dialog box. To close the dialog box without applying the selected color, click **Cancel**.

5. To display text in bold characters, select **Bold** check box

---

**Note**

In the following cases, the color of the COBOL editor is automatically changed from the theme color to the default color.

- Change the **Theme (*)& Appearance** from different theme to “Dark”, or change from Dark to different theme.

* The **Theme of Appearance** can be changed by the following procedure.

1. On the **Windows** menu, click **Preferences**. The **Preferences** dialog box appears.
2. In the left pane, select **General** > **Appearance**. The **Appearance** page appears.
3. Select the **Enable theming (requires restart)** check box.
4. In the **Theme** list, select the theme.
5. Click **OK**. The **Preferences** dialog box is closed

---

### 5.2 Font Setting

The font used in the COBOL editor can be changed in the **Preferences** dialog box.

**Changing the font setting**

To change the font setting:

1. On the **Windows** menu, click **Preferences**. The **Preferences** dialog box appears.
2. In the left pane, select **COBOL** > **Editor**. The **Editor** page appears.
3. Click the **General** tab.
4. Click **Change**... The **Font** dialog box appears.
5. Change the values of Font, Font style, and Size as desired.

**Information**

- You can use the following shortcut keys to increase and decrease the font size.
  - zoom in (Ctrl++ or Ctrl+=)
  - zoom out (Ctrl+-)

  In the above, the numeric keypad on the keyboard cannot be used.

- You can use the following gestures to change the font size.
  - pinch: zoom out
  - stretch: zoom in
  - 45° rotation: reset the font size by using pinch or stretch.
5.3 Changing the width of the tab character

To change the width of the tab character:

1. On the Windows menu, click Preferences. The Preferences dialog box appears.
2. In the left pane, select COBOL > Editor. The Editor page appears.
3. Click the Reference Format tab.
4. In the Tab width, click 4 or 8 as the tab width value.

Note

By default, 4 is set for the tab width value.

5.4 Displaying Line-Numbers

Line numbers can be displayed alongside the vertical ruler of the COBOL editor.

Displaying line-numbers

To display line-numbers:

1. On the Windows menu, click Preferences. The Preferences dialog box appears.
2. In the left pane, select General > Editors > Text Editors. The Text Editors page appears.
3. To display line numbers, select the Show line numbers check box.

Note

Setting information is shared among editors; therefore, changing the settings in the NetCOBOL Studio Editor changes those settings in the other editors also.

5.5 Sequence Numbers

The COBOL editor supports automatic numbering of sequence numbers. The COBOL editor supports the following two patterns of sequence numbers:

Pattern A

Every line in a file has a six-digit sequence number, and the lines are sorted in ascending order.

Pattern B

Patterns other than pattern A.

Sequence numbers can be edited. The following table describes the operation of the COBOL editor when lines are numbered manually.
Adding a new line at the end of a file

In pattern A, the sequence number for a new line is the sequence number of the last line plus the increment value. If the calculated value is greater than 999999, 1 is set as the increment value. If a line is being added after the line whose sequence number is 999999, the numbering is switched to pattern B. In numbering in pattern B, a six-byte space is assigned for the sequence number area of the newly line.

Inserting a new line

In pattern A, the sequence number for a new line is the sequence number of the previous line plus the increment value. If the calculated value is the sequence number of the next line or greater, 1 is set as the increment value. However, if adding 1 to the sequence number of the previous line results in a value equal to or greater than the sequence number of the next line, the next and subsequent lines are renumbered. In pattern B, a six-byte space is assigned for the sequence number area of the new line.

Deleting a line

When a line is deleted, lines are not renumbered.

Pasting a line

The processing is the same as for inserting a new line.

---

**Note**

Sequence numbers are not targeted in revision history comparisons. Therefore, simply reassigning sequence numbers does not correct them. However, when replacing from a revision history, the sequence numbers are also replaced.

---

### 5.5.1 Renumbering Lines

The initial value and increment value for numbering can be changed, and lines can be renumbered. The maximum increment value is 999999.

**Renumbering lines**

To renumber lines:

1. On the **Edit** menu, click **Renumber**, or press the "Ctrl + R" keys. The **Renumber** dialog box appears.
2. Specify values for Initial Value and Increment Value.
3. To renumber the lines and close the dialog box, click **Renumber**. To close the dialog box without renumbering the lines, click **Cancel**.

---

**Note**

By default, 10 is set for Initial Value, and 10 is set for Increment Value. If the values set for Initial Value and Increment Value would result in a line number equal to or greater than 999999 in a file, an error message is displayed in the **Renumber** dialog box.

---

### 5.5.2 Changing the Initial Value and Increment Value for Sequence Numbers

The initial value and increment value for sequence numbers can be changed.

**Changing the initial value and increment value for sequence numbers**

To change the initial value and increment value for sequence numbers:

1. On the **Windows** menu, click **Preferences**. The **Preferences** dialog box appears.
2. In the left pane, select **COBOL > Editor**. The **Editor** page appears.
3. Click the **Reference Format** tab. The **Reference Format** page appears.
4. Specify values for "Initial value" and "Increment value" of "Initial and incremental values for sequence number".
5.6 Display of the Horizontal Ruler

The horizontal ruler is displayed in the upper part of the editor window. This section describes the features of the horizontal ruler.

- Column numbers are displayed in every tenth column. On the ruler, "1" indicates column 10, "+" indicates column 15, "2" indicates column 20, and so on.

- For a fixed format file:
  - The ruler begins with "*" at column 7.
  - "A" in column 8 indicates that the A area begins from this column. The A area is from column 8 to column 11.
  - "B" in column 12 indicates that the B area begins from this column. The B area is from column 12 to column 72.
  - "I" in column 73 indicates that the program identification area begins from this column. The program identification area is column 73 and subsequent columns.
  - The ruler display ends at column 80.

- For a variable format file:
  - The ruler begins with "*" at column 7.
  - "A" in column 8 indicates that the A area begins from this column. The A area is from column 8 to column 11.
  - "B" in column 12 indicates that the B area begins from this column. The B area is from column 12 to column 251.
  - The ruler display ends at column 251.

- For a free format file:
  - The ruler begins at column 1.

A value can be selected for the width of the tab character, which is inserted by pressing the Tab key. Either 4 or 8 can be selected.

5.7 Vertical Ruler

Icons that represent set breakpoints, errors that have occurred during build, and other items are displayed on the vertical ruler in the left part of the COBOL editor window.

The COBOL editor supports the following display items:

- Errors
- Tasks
- Bookmarks
5.8 Display of the Overview Ruler

On the overview ruler in the right part of the editor window, the locations of errors such as those that have occurred during build are indicated by rectangles in different colors representing error categories. Selecting a rectangle on the ruler displays the relevant source line.

The COBOL editor supports the following display items:

- Errors
- Tasks
- Bookmarks
- Breakpoints
- Warnings
- Search results
- Debugging of instruction points
- Debugging of invocation stacks

Changing the display settings

To change the display settings of the overview ruler:

1. On the Windows menu, click Preferences. The Preferences dialog box appears.
2. In the left pane, select General > Editor > Text Editors > Annotations. The Annotations page appears.
3. In the Annotation types list, select a setting item. The setting indicating whether to display the selected item on the vertical ruler can be changed, as well as the color used to display it.

Note

Setting information is shared among editors; therefore, changing the settings in the NetCOBOL Studio Editor changes those settings in the other editors also.
3. In the Annotation types list, select a setting item. The setting indicating whether to display the selected item on the overview ruler can be changed, as well as the color used to display it.

**Note**

Setting information is shared among editors; therefore, changing the settings in the NetCOBOL Studio Editor changes those settings in the other editors also.

### 5.9 Quick Diff Display

Differences between the source code currently being edited and corresponding stored source code can be indicated by different colored blocks alongside the vertical ruler of the editor window.

```
00210 ADD I TO CNT CNT1
+>
00220 IF CNT1 = 10
+>
00230 THEN DISPLAY CNT
+>
00240 MOVE ZERO TO CNT1
+>
00250 MOVE ZERO TO CNT2
```

**Displaying Quick Diff**

To change the Quick Diff display settings:

1. On the Windows menu, click Preferences. The Preferences dialog box appears.
2. In the left pane, select General > Editor > Text Editors > Quick Diff. The Quick Diff page appears.
3. Change the Quick Diff settings as desired.

### 5.10 Reference Formats

When the COBOL editor is used to create or edit a COBOL source file, the file format conforms to the rules specified under a reference format. The COBOL editor supports the following two reference formats:

- Fixed format
- Variable format
- Free format

**Specifying a reference format**

To specify a reference format:

1. On the Windows menu, click Preferences. The Preferences dialog box appears.
2. In the left pane, select COBOL > Editor. The Editor page appears.
3. Click the Reference Format tab. The Reference Format page appears.
4. In the Reference format, click "Fixed format", "Variable format" or "Free format."

"SRF and TAB compile option setting to be consistent with the applicable editor setting" checkbox

If it is checked, the value of SRF is consistent with Reference Format setting, and the value of TAB is consistent with "Tab width" setting. And if it is not checked, these changing settings do not occur.

**COBOL editor operation for the fixed format**

In the fixed format:

- Columns 1 to 6 in the COBOL editor are used for line numbers, which are called sequence numbers.
- Column 7 is used as the indicator column.
- "I", "D", "d", or "*" in the indicator area indicates that the line is a comment line.
  "D" or "d" in the indicator area indicates that the subsequent text is debugging information. This option is valid for builds that are executed in debug mode.
- Columns 8 to 11 are used as the A area, and columns 12 to 72 are used as the B area.
- Column 73 and subsequent columns are used as the program identification area.

**COBOL editor operation for the variable format**

In the variable format:
- Columns 1 to 6 in the COBOL editor are used for line numbers, which are called sequence numbers.
- Column 7 is used as the indicator column.
- "I", "D", "d", or "*" in the indicator column indicates that the line is a comment line.
  "D" or "d" in the indicator area indicates that the subsequent text is debugging information. This option is valid for builds that are executed in debug mode.
- Columns 8 to 11 are used as the A area, and columns 12 to 251 are used as the B area.
- The text in column 252 and subsequent columns is treated as a comment.

**COBOL editor operation for the free format**

In the free format:
- You do not need to distinguish among the sequence number area, the indicator area, the A area, and the B area. You can start the source program at any positions in each line.
- If a line contains "*>", the part from that point to the end of the line is treated as a comment.
- Combining three COBOL characters ">>D" immediately followed by a single-byte space indicates a debugging indicator. A line with zero or one or more blanks before the debugging indicator is called "debugging line". The debugging line leaves debugging information in the source program.
- The text in column 252 and subsequent columns is treated as a comment.

**Note**

A reference format can be changed. If changes have been made in a file but not yet saved, a message prompting the user to save the changes in the file is displayed before the reference format is changed.

To save the changes made in the file and then change the reference format, click **Yes**. To change the reference format without saving the changes, click **No**.

### 5.11 Code Formatter

The following table outlines the automatic indentation supported by the COBOL editor.

<table>
<thead>
<tr>
<th>When the ENTER key is pressed</th>
<th>All of the space and tab characters at or after the cursor position are moved to the next line together with the text, and the cursor is moved to the beginning of the line.</th>
</tr>
</thead>
<tbody>
<tr>
<td>When multiple lines of text are pasted</td>
<td>The text is pasted at the current cursor position, and then is pasted in subsequent lines without placing any extra space or tab characters at the beginning of each subsequent line.</td>
</tr>
<tr>
<td>When the text selected from the input support candidate list is inserted</td>
<td>All of the space and tab characters at the beginning of the current line are also pasted to each new line.</td>
</tr>
</tbody>
</table>
### 5.12 Comment Styles

The following table lists comment styles supported by the COBOL editor.

<table>
<thead>
<tr>
<th>Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Style A</td>
<td>If &quot;*&quot;, &quot;/&quot;, &quot;D&quot;, or &quot;d&quot; is in the indicator area (column 7) of a line, the entire line is treated as a comment line.</td>
</tr>
<tr>
<td>Style B</td>
<td>If a line contains &quot;*&gt;&quot;, the part from that point to the end of the line is treated as a comment.</td>
</tr>
<tr>
<td>Style C</td>
<td>Characters described in the program identification area (column 73 and subsequent columns) are also treated as a comment.</td>
</tr>
</tbody>
</table>

**Note**

The fixed format supports all of the above comment styles.

The variable format supports style A and style B. In the variable format, column 252 and subsequent columns are treated as a comment.

The free format supports style B.

### 5.13 Input Support Candidate List (Contents Assist)

The input support candidate list displays key words of the COBOL language syntax, class names, method names (factory method names or object method names), program names, and subprogram names.

Input support candidates are displayed according to the following conditions:

- When the Ctrl + Space keys are pressed in a file, the candidate list displays class names and template key words. Example: MOVE<Ctrl + Space>

  If no space character has been entered after the last input characters when the Ctrl + Space keys are pressed, the list displays the class names and template key words that begin with the last input characters. In the following example, the list displays the class names and template key words that begin with "DA".

  Example: MOVE DA<Ctrl + Space>.

- When the Ctrl + Space keys are pressed with the cursor to the right of a space character following the key word INVOKE, the candidate list displays class names, method names, and template key words. Example: INVOKE <Ctrl + Space>

  If no space character has been entered after the last input characters when the Ctrl + Space keys are pressed, the list displays the class names, method names, and template key words that begin with the last input characters. In the following example, the list displays the class names, method names, and template key words that begin with "DA".

  Example: INVOKE DA<Ctrl + Space>.

- When the Ctrl + Space keys are pressed with the cursor to the right of a space character that is entered two characters after the key word [CALL], the candidate list displays program names, subprogram names, and template key words.

  Example: CALL <Ctrl + Space>
If no space character has been entered after the last input characters when the Ctrl + Space keys are pressed, the list displays the program names and template key words that begin with the last input characters. In the following example, the list displays the program names and template key words that begin with "DA".

Example: CALL DA<Ctrl + Space>

When a template key word is selected, an auxiliary window that displays template patterns is displayed.

5.14 Insert and Overwrite Modes

Text can be inserted and overwritten in the COBOL editor. The insert/overwrite mode can be toggled by pressing the "Insert" key. The current mode is indicated in the status bar.

For example, if "1234567890" is displayed in the text editor with the cursor to the left of the "1" and you type "abcde":

In Insert mode, the result will be: abcde1234567890

In Overwrite mode, the result will be: abcde67890

5.15 Select All

All of the text in the active file of the editor can be selected by choosing Select All from the Edit menu or by pressing the Ctrl + A keys. 

Note: Sequence numbers in the sequence number area of fixed and variable format files cannot be selected.

5.16 Undo and Redo

Editing operations can be undone and redone.

Undo

Up to 25 previous editing operations can be undone by selecting Undo from the Edit menu, or by pressing the Ctrl + Z keys, or by clicking in the toolbar.

Redo

Editing operations that have been undone can be redone by selecting Redo from the Edit menu, or by pressing the Ctrl + Y keys, or by clicking in the toolbar.

5.17 Shift Left/Right

The selected text in the COBOL editor window can be shifted left and shifted right.

Shift left

The selected text can be shifted left in the COBOL editor window by selecting Shift Left from the Edit menu, or by pressing the Shift + Tab keys. The length of the text shift in units of columns is determined by the value set for Tab width on the COBOL > Editor page of the Preferences dialog box.

Shift right

The selected text can be shifted right in the COBOL editor window by selecting Shift Right from the Edit menu, or pressing the Tab key. The length of the text shift in units of columns is determined by the value set for Tab width on the COBOL > Editor page of the Preferences dialog box.

Note

These operations cannot be performed in the sequence number area.
5.18 Cut, Copy, and Paste

The selected text in the editor window can be cut, copied, and pasted.

Cut

The selected text can be cut by selecting **Cut** from the Edit menu or context menu, or by pressing the Ctrl + X keys, or by clicking ![Cut] on the toolbar.

Copy

The selected text can be copied by selecting **Copy** from the Edit menu or context menu, or by pressing the Ctrl + C keys, or by clicking ![Copy] on the toolbar.

Paste

The cut or copied text can be pasted by selecting **Paste** from the Edit menu or context menu, or by pressing the Ctrl + V keys, or by clicking ![Paste] on the toolbar.

5.19 Find and Replace

A key word can be found and/or replaced by selecting **Find/Replace** from the Edit menu, or by pressing the Ctrl + F keys, or by clicking ![Find] on the toolbar.

Finding a key word

To find a key word:

1. On the **Edit** menu, click **Find/Replace**. The **Find/Replace** dialog box appears.

2. Enter the key word, and then Click **Find**. If the key word is found, it is highlighted in the editor window.

Replacing a character string

To replace a character string:

1. On the **Edit** menu, click **Find/Replace**. The **Find/Replace** dialog box appears.

2. In the **Find** field, enter the search target character string. In the **Replace with** field, enter the replacement character string.

3. To replace text that has been found, click **Replace**.

The items in the **Find/Replace** dialog box are as follows:

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Forward</td>
<td>A downward (forward) search is performed starting from the current cursor position.</td>
</tr>
<tr>
<td>Backward</td>
<td>An upward (backward) search is performed starting from the current cursor position.</td>
</tr>
<tr>
<td>All</td>
<td>The entire file is searched.</td>
</tr>
<tr>
<td>Select lines</td>
<td>The selected range in the file is searched.</td>
</tr>
<tr>
<td>Case sensitive</td>
<td>Uppercase and lowercase letters are treated as different characters in a key word search.</td>
</tr>
<tr>
<td>Wrap search</td>
<td>The search operation is performed until it reaches the end of the file, and then it continues at the start of the file. The search operation is repeated cyclically until it is canceled.</td>
</tr>
<tr>
<td>Whole word</td>
<td>The search target is a word that exactly matches the key word.</td>
</tr>
</tbody>
</table>
### Item Description

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Incremental</td>
<td>The cursor is positioned at a matching character string in the file as soon as each character in a character string search target is entered.</td>
</tr>
<tr>
<td>Regular expressions</td>
<td>The specified key word is assumed to be a regular expression.</td>
</tr>
</tbody>
</table>

- When the **Find /Replace** button is clicked, the character string that was found to match is replaced, and the cursor is moved to the next matching character string.

- When the **Replace All** button is clicked, all matching character strings are replaced.

- If the Incremental option is selected, the search is conducted as soon as the search string is input, without the use of the **Find** button.

### 5.20 Jumping to a Specified Line or Sequence Number

By selecting Go to Line from the Navigate menu or pressing the Ctrl + L keys, you can move to a specified line number or sequence number.

To jump to a specified line number or sequence number in a fixed or variable format file:

1. On the **Navigate** menu, click **Go to Line**... The **Go to Line** dialog box appears.

2. Click **Line Number**, enter a line number in the **Enter line number** field. Or click **Sequence Number**, and then enter a sequence number in the **Enter Sequence number** field. The default selection is Sequence Number.

3. If the sequence number is represented by zeros followed by integers, you can jump to the line by entering just the integer part of the number, without the leading zeros. For example, if the sequence number is 000100, you can enter 100 instead of 000100.

4. After selecting to move to the specified line, click **OK** to close the dialog box. The cursor moves to the beginning of the specified line. To close the dialog box without moving to the specified line, click **Cancel**.

**Note**

The range of sequence numbers that can be specified for a fixed or variable format file is displayed in the header of the **Enter Sequence number** field.

### 5.21 Bookmarks

A bookmark can be added to a source code line by selecting "Add Bookmark" from the **Edit** menu, or by using the context menu of the vertical ruler of the editor.

**Note**

To display your bookmark list:

1. On the **Windows** menu, click **Show View > Other**... The **Show View** dialog box appears.

2. Select **General > Bookmarks** and then click **OK**

### 5.22 Tasks

Task settings can be made by selecting **Add Task**... from the **Edit** menu or context menu of the editor. A task can be used, for example, as a memorandum for a file. The tasks that have been set are displayed in the Task view, which is used to manage task completion. For details on tasks, see the "Workbench User Guide" in the Help information.

To insert a task in source code:

1. Select **Add Task**..., from the context menu of the vertical ruler. The **Properties** dialog box appears.

2. In the **Description** field, enter an explanation of the task.
3. Select a priority and select the **Completed** check box when the task has been completed.

4. Default values are displayed for "On element", "In folder", and "Location".

### 5.23 Split editor view

To split the editor:

1. On the **Windows** menu, click **Editor > Toggle Split Editor (Horizontal)** or **Toggle Split Editor (Vertical)**. The editor is divided into two panels.

2. After splitting, drag the border with the mouse, you can change the windows size.

   To restore, select the same menu or use shortcut key.

---

**Information**

To display a clone of the currently active editor, on the **Windows** menu, click **Editor > Clone**. The clone editor displays the same file as the original editor. Multiple clone editors can be displayed. You can display the clones in different places.

---

### 5.24 Wrap of line

When using the shortcut key (Alt+Shift+Y), the wrap of line can be displayed. If you use the shortcut key (Alt+Shift+Y) again, the wrap of line will be canceled.

### 5.25 Auto Save

When the Auto Save is enabled if the keyboard or the mouse is not operated for a fixed amount of time, the edited file is automatically saved.

1. On the **Windows** menu, click **Preferences**. The **Preferences** dialog box appears.

2. In the left pane, select **General > Editor > Autosave**. The **Autosave** page appears.

3. Select the **Enable autosave for dirty editors** check box.

4. Specify the time in the **Dirty editors autosave interval (in seconds)**.

5. Click **OK**. The **Preferences** dialog box is closed

### 5.26 Associate the extension with the COBOL editor

To edit the COBOL source file and COBOL library file with the COBOL editor, you must associate the extension with the COBOL editor.

The following extensions are associated with the COBOL editor by default.

- .cob
- .cobol
- .cbl
- .cpy

Associate the other extensions with the following steps.

1. On the **Windows** menu, click **Preferences**. The **Preferences** dialog box appears.

2. In the left pane, select **General > Editor > File Associations**. The **File Associations** page appears.

3. On the right side of the **File types** list, click **Add**. The **Add File type** dialog box appears.

4. Enter the extension, and then click **OK**. The extension is displayed in the **File Types** list.
5. In the File Types list, select the extension. And then, on the right side of the Associated editors list, click Add. The Editor Selection dialog box appears.

6. Click Internal editors, and then select the "COBOL Editor" from the editor list. Click OK. The "COBOL Editor" is added to the Associated editors list.

Note

- The extensions associated with the COBOL source file in Content Types are automatically associated with the COBOL editor.
- By selecting the content in the File Content, the extension .cpy can be associated with the COBOL source file or COBOL library file. For details, refer to "4.7 File Content."
Chapter 6 Build Function

Build is a process that uses a set of build tools according to definitions in a project. COBOL program build tool settings are made when a project is created. During a project build, build tools are used in the order specified. Build tool settings and options can be made by project. If a build contains errors, they are displayed in the Problems view. A detailed build log can be checked in the Console view. To display the build log, select “Build Console” from the “Open Console” icon in the toolbar of the Console view.

**Point**

Error information detected by the precompiler is not displayed in the Problems view. The error information is displayed in the Console view under Build Console.

**Note**

- The build.xml file that is created in each project folder is used for build. This file must not be edited, and an Ant build (execution of an Ant script) must not be executed for the file.
- When you build COBOL source file of the text file encode “UTF-8”, installs NetCOBOL V10.0.0 or later.

Build Tools

NetCOBOL Studio combines build tools to execute build processing. When creating a new COBOL project, the COBOL compiler and linker are set as build tools. If you specify to use the precompiler in creating the project, the Precompiler build tool is also set. The resource compiler can be added to existing COBOL projects as a build tool.

6.1 COBOL compiler

A project can be compiled using the COBOL compiler.

6.1.1 Files associated with compilation

The following table lists the files associated with the COBOL compiler.

<table>
<thead>
<tr>
<th>Files used by the COBOL compiler</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source files (*.cob, *.cobol, *.cbl)</td>
</tr>
<tr>
<td>Library files (*.cbl)</td>
</tr>
<tr>
<td>Screen form descriptor file (*.smd, *.pmd, *.smu, *.pmu)</td>
</tr>
<tr>
<td>Repository files (*.rep)</td>
</tr>
</tbody>
</table>

Source files displayed in the Source Files folder of the Dependency view are the objects of compilation. The following table lists the files created by the COBOL compiler.

<table>
<thead>
<tr>
<th>Files created by the COBOL compiler</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object files (*.obj)</td>
</tr>
<tr>
<td>Repository files (*.rep)</td>
</tr>
<tr>
<td>Debugging information files (*.svd)</td>
</tr>
<tr>
<td>Compilation list files (*.lst)</td>
</tr>
<tr>
<td>Source Analysis Information (*.sai)</td>
</tr>
<tr>
<td>Executable files (*.exe)</td>
</tr>
<tr>
<td>Dynamic link libraries (*.dll)</td>
</tr>
</tbody>
</table>
The following table lists details of the files used for compilation.

<table>
<thead>
<tr>
<th>File contents</th>
<th>File name format</th>
<th>I/O</th>
<th>Use and creation conditions</th>
<th>Relevant compilation options</th>
<th>Relevant environment variables(*2)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source files</td>
<td>arbitrary-file-name.cob</td>
<td>I</td>
<td>Required</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td></td>
<td>arbitrary-file-name.cobol</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>arbitrary-file-name.cbl</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Library files</td>
<td>arbitrary-file-name.cbl</td>
<td>I</td>
<td>For compiling a source program that uses the COPY statement</td>
<td>LIB</td>
<td>COB_COBCOPY COB_LIBSUFFIX COB_library-name</td>
</tr>
<tr>
<td>Screen form descriptor file</td>
<td>screen form descriptor.smd</td>
<td>I</td>
<td>For compiling a source program that has the screen form descriptor</td>
<td>FORMLIB</td>
<td>SMED_SUFFIX</td>
</tr>
<tr>
<td></td>
<td>screen form descriptor.pmd(*3)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Object files</td>
<td>source-file-name.obj</td>
<td>O</td>
<td>Created when compilation is performed correctly</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Repository files</td>
<td>class-name.rep</td>
<td>I</td>
<td>For compiling a source program that has the REPOSITORY paragraph</td>
<td>REPIN REP</td>
<td>COB_REPIN</td>
</tr>
<tr>
<td></td>
<td></td>
<td>O</td>
<td>Created when a class definition is compiled correctly</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Debugging information files</td>
<td>source-file-name.svd</td>
<td>O</td>
<td>- Used when debug mode is set as the build mode</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td></td>
<td>source-file-name.pdb</td>
<td></td>
<td>- When the TEST compiler option is specified</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Source analysis information file</td>
<td>source-file-name.sai</td>
<td>O</td>
<td>When the SAI compiler option is specified</td>
<td>SAI</td>
<td>-</td>
</tr>
<tr>
<td>Compilation list files</td>
<td>*.lst</td>
<td>O</td>
<td>For output of a compilation list</td>
<td>PRINT</td>
<td>-</td>
</tr>
</tbody>
</table>

*1: I and O are as follows:
- I: source file for compilation
- O: output file as a result of compilation

*2: For detail, refer to the "NetCOBOL User's Guide".

*3: When the encoding of the form data is UTF-32, the UTF-32 form descriptor is created using "Form descriptor conversion command for UTF-32 (CNVMED2UTF32)". The extension of the created descriptor is .smu or .pmu.

For details of CNVMED2UTF32, refer to the "NetCOBOL User's Guide".

The UTF-32 form descriptor is used when the encoding of the national item is UTF-32. In this case, the search order of the files is .pmu and .smu.

**Note**

The form descriptor for UTF-32 (*.pmu, *.smu) cannot be updated by using FORM and PowerFORM. In this case, you update the original form descriptor (*.pmd/*.smd), and convert it by using CNVMED2UTF32.
In the resource management of NetCOBOL Studio, an original descriptor (*.smd/*.pmd) is registered.

### 6.1.2 Setting the main program

Before performing a build of a COBOL project with an executable file as the target type, specify one of the source files of the project as the main program. If the main program is not specified, a link error will occur. The two types of main programs, determined according to types of programs created, are described below. The main program type is specified with a wizard when a COBOL project is created.

- **Application that uses the COBOL console**
  
  Specifies that a console window created by a COBOL program is the input-output destination of ACCEPT and DISPLAY statements, and that a message box is the output destination of execution-time error messages.

- **Application that uses the system console**
  
  Specifies that the system console (command prompt window) is the input-output destination of ACCEPT and DISPLAY statements and execution-time error messages.

**Point**

If the COBOL console window is specified as the main program, and the application is executed from NetCOBOL Studio, the Console view is used instead of the system console.

### Specifying the main program

To specify the main program:

1. In the Dependency view or Structure view, select a source file.
2. Select **Main Program** from the context menu.
3. The selected COBOL source file is set as the main program, and the icon of the file is changed.

### Changing the main program type

To change the main program type:

1. In the Dependency view or Structure view, select the appropriate project.
2. On the **File** menu, click **Properties**. Or select **Property** from the context menu. The **Properties** dialog box appears.
3. In the left pane, select **Target**. The **Target** page appears.
4. In the **Application format** option, select "COBOL console window" or "System console window". Click **OK**.

### 6.1.3 Setting compile options

This section explains how to set the compile options that are required for building a project.

**See**

For details of the compile options, refer to the "Appendix A Compile Options".

Compile options are set for each project. The set options are sent to the COBOL compiler as parameters.

To display the Compiler Options page and set compile options:

1. In the Dependency view or Structure view, select a COBOL project.
2. On the **File** menu, click **Properties**. Or select **Property**..., from the context menu. The property dialog box appears.
3. In the left pane, select **Build**. The **Build** page appears.
4. Click the **Compiler Options** tab. The **Compiler Options** page appears.

### Table 6.1 Compiler Options page

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compiler options</td>
<td>Displays the compile options to be sent to the COBOL compiler.</td>
</tr>
<tr>
<td>Add</td>
<td>Adds the compile options. To add compile options, select the compile options in <strong>Compiler Options</strong> in the <strong>Add Compiler Options</strong> dialog box, and then click the <strong>Add</strong> button. For details on compile options, see &quot;A.1 Compile option details.&quot;</td>
</tr>
<tr>
<td>Change</td>
<td>Changes the compile options selected in Compiler options.</td>
</tr>
<tr>
<td>Remove</td>
<td>Deletes the compile options selected in Compiler options.</td>
</tr>
<tr>
<td>The CHECK(ALL) compile option is automatically added when the build mode is Debug.</td>
<td>Specifies whether the compiler option CHECK(ALL) is added automatically or not when the build mode is debug. If checked, compiler option CHECK(ALL) is added. To specify CHECK option except for ALL, deselect the CHECK option and then select the CHECK option again, and select the other Check items in the CHECK Compiler Option dialog.</td>
</tr>
<tr>
<td>Other compiler options</td>
<td>Specifies the compile options that cannot be added from the <strong>Add Compiler Options</strong> dialog box.</td>
</tr>
</tbody>
</table>

**Note**

- Compiler option specifies file extension
  
  The following compile options are not displayed in the **Add Compiler Options** dialog box:
  
  - FORMEXT
  - LIBEXT
  
  These compiler options can be specified in the environment variables. For details, see the "NetCOBOL User's Guide."

- Compiler option specifies text file encoding of COBOL source files
  
  The compiler option SCS that specifies the text file encoding of COBOL source files is not displayed in the **Add Compiler Options** dialog. The text file encoding is determined from the file property Text file encoding. When the Text file encoding of the file property is "UTF-8", SCS(UTF8) is set for compiler option SCS. If the Text file encoding is other than "UTF-8", SCS(ASCII) is set.

- The following compiler options cannot be specified for NetCOBOL for Windows(x64) edition
  
  - AIMLIB compiler option
  - FILELIB compiler option
  - GEN compiler option
  - CHECK(LINKAGE) compiler option

- The compile options are sent to COBOL compiler as a parameter of the -WC option etc. Maximum length of the compiler-option-list of -WC option is 234 bytes.

### 6.1.4 Use the Compiler Option File

The compiler option file has the following information on the compiler option.

- Project manager (for Windows(x86) NetCOBOL)
- WINCBO (for Windows(x86) NetCOBOL)

Windows(x64) NetCOBOL cannot use the compiler option file. Set the content of the compiler option file by the following.

- The **Compiler Options** page of the property dialog box.

- The environment variable
For details of the environment variable, refer to the "NetCOBOL User's Guide".

### 6.1.5 Setting Library names

To build a source COBOL program that includes the COPY statement specifying library names, use the Library Name option to specify the library names and the library file storage folder.

#### Adding a library name

To add a library name:

1. In the Dependency view or Structure view, select a COBOL project.
2. On the **File** menu, click **Properties**. Or select **Property**... from the context menu. The property dialog box appears.
3. In the left pane, select **Build**. The **Build** page appears.
4. Click the **Library Names** tab. The **Library names** page appears.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Adds a library option. Click <strong>Add</strong>. The <strong>Add Library Name</strong> dialog box appears. Specify a library name in &quot;Library name&quot;. Specify the library file storage folder in &quot;Select folder&quot;. The folder can also be selected by clicking the <strong>Browse</strong> button.</td>
</tr>
<tr>
<td>Change</td>
<td>Changes the selected library folder. Click <strong>Change</strong>. The <strong>Modify Library Name</strong> dialog box appears. Change the folder. (Library names cannot be changed in the <strong>Modify Library Name</strong> dialog box.)</td>
</tr>
<tr>
<td>Remove</td>
<td>Deletes the selected library option.</td>
</tr>
</tbody>
</table>

**Note**

- In compilation with the **ALPHAL(ALL)** or **ALPHAL(WORD)** option, and a library name described in lowercase letters in the source program, the library name is treated as being coded in uppercase letters. If the library name specified in the source program is coded in lowercase letters, the intended library file cannot be read. To perform compilation with the **ALPHAL(ALL)** or **ALPHAL(WORD)** option, specify the library name in uppercase letters as described above.

- When compiling the source program including the COPY statement without specifying the COBOL library name, specify the COBOL library folder using the compiler option **LIB**.

### 6.1.6 Setting the file folder option

When you set the file folder option (LIB, FORMLIB, REPIN, REP, etc.), specify the folder using the **Select** dialog box.

In this example, another project folder is specified for the LIB compiler option.

1. In the Dependency view or Structure view, select a COBOL project.
2. On the **File** menu, click **Property** or **Property** from the context menu. The Property dialog box appears.
3. In the left pane, select **Build**. The **Build** page appears.
4. Click the **Compiler Options** tab, and click **Add**. The **Add Compiler Options** dialog box appears.
5. In the **Compiler Options** list, click **LIB**, and then click **Add**. The **LIB Compiler Option** dialog box appears.
6. To specify the library File folder, click **Browse**. The **Folder type selection** dialog box appears.
7. In this example, you specify another project folder in the same workspace. In the **Folder Type** list, click "Specify from project", and then click **OK**. The **Selection from project** dialog box appears.

<table>
<thead>
<tr>
<th>select item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>${NETCOBOL}</td>
<td>Refer to the folder based on the NetCOBOL installation folder.</td>
</tr>
</tbody>
</table>
8. In the Select the project or the folder list, select the project to which the library file is saved, and then click OK. The path of the library file is displayed in the LIB Compiler Option dialog box.

9. To close the LIB Compiler Option dialog box, click OK.

10. In the Add Compiler Options dialog box, click Done.

11. In the Compiler Options tab of the property dialog box, and click OK. The following message boxes appear.

   Build options has been changed. To enable the changes, it is necessary to clean the project. Do you want to clean the project now? [Yes] [No] [Cancel]

12. Click Yes.

### 6.2 Precompiler

COBOL programs, including input sources for the precompiler, can be developed with the precompiler link function.

#### 6.2.1 Setting and changing initial values of precompiler link information

The initial values used when a precompiler command is invoked can be set and changed. The initial values for setting the precompiler link information are shared by the COBOL projects in a workspace.

To set or change the initial values of the precompiler link information:

1. On the Window menu, click Preferences. The Preferences dialog box appears.

2. In the left pane, select COBOL > Precompiler, and set or change initial values on the displayed Precompiler page.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Precompiler</td>
<td>Select this item to use a precompiler for a COBOL project in the current workspace.</td>
</tr>
<tr>
<td>Precompiler command</td>
<td>Specifies the name of a command that starts the precompiler.</td>
</tr>
<tr>
<td>Precompiler parameters</td>
<td>Specifies precompiler command parameters.</td>
</tr>
<tr>
<td>Precompiler source extension</td>
<td>Specifies the extension of an input source file for the precompiler. The following extensions cannot be specified:</td>
</tr>
<tr>
<td></td>
<td>- cobol</td>
</tr>
<tr>
<td></td>
<td>- cob</td>
</tr>
<tr>
<td></td>
<td>- cbl</td>
</tr>
<tr>
<td></td>
<td>- lcai</td>
</tr>
<tr>
<td>Precompiler output source</td>
<td>Selects the file extension for the output source file from the precompiler.</td>
</tr>
<tr>
<td>extension</td>
<td></td>
</tr>
<tr>
<td>Use original source line</td>
<td>If this item is checked, COBOL compiler error messages are displayed using the line number in the original source, rather than the line number of the preprocessed source. (The INSDBINF command is invoked.) The default setting is unchecked.</td>
</tr>
<tr>
<td>numbers for error messages.</td>
<td></td>
</tr>
<tr>
<td>INSDBINF parameters</td>
<td>This item sets parameters of the INSDBINF command, which develops line information for the precompiler input source in COBOL source files generated by precompilation. Note that input and output source file names cannot be specified because they are determined from precompiler input source file names.</td>
</tr>
</tbody>
</table>
**Note**

- When Symfoware Server is used for the pre-compiler, the sqlpcob command must be specified for the pre-compiler command. If the sqlcobol command is specified, a compilation error may be generated.
- Setting the pre-compiler is also required for remote builds. For details, see "9.4.4.2 Precompiler tab "

### Method for specifying file names for precompiler command parameters

If file names must be specified for precompiler command parameters, use the macros listed below. File names are automatically generated when the precompiler is invoked.

<table>
<thead>
<tr>
<th>Macro name</th>
<th>Description of macro</th>
</tr>
</thead>
<tbody>
<tr>
<td>%INFILE%</td>
<td>Name of the source file that is input to the precompiler</td>
</tr>
<tr>
<td>%INFILE_BASE%</td>
<td>Name of the source file that is input to the precompiler without an extension.</td>
</tr>
<tr>
<td>%OUTFILE%</td>
<td>Name of the source file that is output from the precompiler.</td>
</tr>
</tbody>
</table>

**Note**

- Use the following macro for the file specified for the command parameter in the precompiler.
  - Input file of the precompiler: %INFILE%
  - Output file of the precompiler: %OUTFILE%
- When the input file to the precompiler is in the subfolder, the expansion of the above macro includes the subfolder.

### 6.2.2 INSDBINF command

If an Oracle link is used, the INSDBINF command solves the following problems in linking between the COBOL compiler and the precompiler:

- The compiler outputs line numbers where compilation errors have been detected, but these line numbers belong to lines in an intermediate file (source file after precompilation). To modify the original source program (COBOL source program with embedded SQL statements before precompilation), the user must reference the intermediate file.
- A line with an error in the original source program cannot be correctly located using Go To in the Problems view.
- The original source program cannot be debugged.

The INSDBINF command generates an intermediate file that contains embedded line number control information and file name control information. Line number control information (#LINE information) is used to report the line numbers of lines in the original source program, before it is precompiled, to the compiler or precompiler. File name control information (#FILE information) is used to report original source program file names or the names of files included by the precompiler.

An intermediate file generated by the INSDBINF command can be input to the COBOL compiler. This allows referencing the line number control information and file name control information. From that information, a modified original source program, in which line numbers in the original source files correspond to line numbers in precompiled source files, and file names of include files, can be obtained. Thus, problems that occur in linking between the COBOL compiler and precompiler can be resolved.

**INSDBINF command parameters**

Different INSDBINF command parameters are used for the different operating systems of the servers that perform remote development. For details, see the "NetCOBOL User's Guide".

---

- **Note**
- **Method for specifying file names for precompiler command parameters**
- **6.2.2 INSDBINF command**
6.2.3 Creating a COBOL program by using the precompiler

To develop COBOL programs including input sources for the precompiler from creating new project, the "Build Tools" settings can be set automatically if Use precompiler is checked in the New COBOL Project wizard.

To specify the Build Tools for the precompiler to the existing COBOL project:

1. Adding the precompiler to "Build Tools".
2. Setting precompiler link information.
3. Creating and adding precompiler input sources.

6.2.3.1 Build tool settings

To invoke the precompiler during build for a COBOL project, Precompiler must be set for Build Tools.

Adding Precompiler to build tools

If Precompiler is not specified for the Build Tools, follow the procedure below, and select Precompiler.

1. In the Dependency view or Structure view, select the project.
2. Select Property... from the context menu. The property dialog box appears.
3. In the left pane, select Build Tools. The Build Tools page appears.
4. Click the Add Build Tool... The Add Build Tool dialog box appears.
5. Select Precompiler, and then click OK.

Confirm that Precompiler has been added to the "List of build tools associated with COBOL Builder" on the Build Tools page, and then click OK in the property dialog box.

Deleting Precompiler from build tools

To delete Precompiler from a COBOL project:

1. In the Dependency view or Structure view, select the project.
2. Select Property... from the context menu. The property dialog box appears.
3. In the left pane, select Build Tools. The Build Tools page appears.
4. In the List of build tools associated with COBOL builder list, click Precompiler, and then click Remove.
5. Confirm that Precompiler has been deleted from the List of build tools associated with COBOL builder list, and then click OK.

Note

If a precompiler input source is registered in the Source Files folder, Precompiler cannot be deleted from Build Tools. Delete the precompiler input source from the Source Files folder before deleting Precompiler from Build Tools.

6.2.3.2 Setting and changing precompiler link information

Information can be set and changed for the precompiler command used to build COBOL projects. Existing precompiler link settings are used as the defaults.

Setting and changing precompiler link information

Follow the procedure below to set or change precompiler information for a COBOL project.

1. In the Dependency view or Structure view, select the project.
2. Select Property... from the context menu. The property dialog box appears.
3. In the left pane, select Build Tools > Precompiler. The Precompiler page appears.
Examples of settings for the Oracle precompiler

INAME=%INFILE%  ONAME=%OUTFILE%

For details on the Precompiler page, see "6.2.1 Setting and changing initial values of precompiler link information".

Note

- If a precompiler input source is registered in the Source Files folder, no change can be made in "Precompiler source extension" on the Precompiler page. Delete the precompiler input source from the Source Files folder before making a change in "Precompiler source extension".
- The extensions associated with the COBOL source file in File Content cannot be specified as the extension of the input file of the precompiler.

6.2.3.3 Creating and adding a precompiler input source

To add a precompiler input source to a project, precompiler link information must be set in the project in advance. The precompiler input source must be registered in the Source Files folder of the COBOL project. The following two methods can be used to register a precompiler input source in the Source Files folder:

- Create a precompiler input source and registering the new source
- Register an existing precompiler input source

Creating a precompiler input source and registering the new source in the Source Files folder

To create a precompiler input source and register the new source in the Source Files folder, use the COBOL Source generation wizard or the Object-Oriented COBOL Source generation wizard. Check the "Use precompiler" check box on the first page of the wizard. Then, the created COBOL source or object-oriented COBOL source is registered as a precompiler input source in the Source Files folder.

To start the wizard:

1. In the Dependency view or Structure view, select the Source Files folder of the COBOL project.
2. On the File menu, click New > COBOL Source or Object-Oriented COBOL Source, or select New > COBOL Source or Object-Oriented COBOL Source from the context menu. The wizard is started.

Note

If no precompiler link information is set for the project, the check box for "Use precompiler" is disabled. Set the precompiler link information, and then restart the wizard.

Registering an existing precompiler input source in the Source Files folder

An existing precompiler input source can be registered in the Source Files folder of a COBOL project.

- For a precompiler input source that is inside a project:

To add a precompiler input source that is inside a project:

1. In the Dependency view or Structure view, select the Source Files folder.
2. Select Add File..., from the context menu. The Add Source Files dialog box appears.
3. Select the precompiler input source to be added to the Source Files folder.
4. Click OK. The selected precompiler input source is registered in the Source Files folder.
- For a precompiler input source outside a project:

Use either of the following methods to add a precompiler input source that is outside a project:

- Using Windows Explorer, select the precompiler input source to be registered, and then select "Copy" from the context menu. Select the Source Files folder, and then select "Paste" from the context menu.

- Using Windows Explorer, drag and drop the precompiler input source onto the Source Files folder.

Note

If no precompiler link information is registered for the project concerned, an error occurs. The file is registered in the Source Files folder, but it is not registered as a precompiler input source. In this state, even if precompiler link information is set for the project, the file added by the above operation is not automatically registered as a precompiler input source. Move it from the Source Files folder to the Other Files folder then register the file in the Source Files folder again.

6.2.3.4 Editing a precompiler input source

To edit the contents of a precompiler input source with the COBOL editor, the extension of the precompiler input source file must be associated with the Content Types and COBOL editor. The association is invoked automatically when the Precompiler setting is set. If the precompiler input file is not opened by the COBOL editor, follow the procedure below and associate the file extension with the Content Types and COBOL editor.

1. On the Window menu, click Preferences. The Preferences dialog box appears.
2. In the left pane, select General > Content Types. The Content Types page appears.
3. In the Content Types list, select Text > COBOL Source File.
4. Click Add. The Add Content Type Association dialog box appears.
5. In the Content Type field, enter the extension of the precompiler input source file and then click OK.
6. In the File Association field, enter the extension of the precompiler input source file and then click OK.
7. In the File Association field, the extension of the precompiler input source file is displayed. Click OK.
8. On the right side of the File types list, click Add.... The Add File Type dialog box appears.
9. In the File type field, enter the extension of the precompiler input source file, and then click OK. The specified extension is added to the File types list of the File Associations page.
10. In the File types list, click the added extension. And then on the right of the Associated editors list, click Add.... The Editor Selection dialog box appears.
11. Select Internal editors, and select COBOL Editor from the editor list.
12. In the Associated editors list, COBOL Editor is added.

6.3 Linker

Executable files or dynamic link libraries can be created by linking object files or libraries.

6.3.1 Setting link options

To display the Linker Options page and set link options:

1. In the Dependency view or Structure view, select a COBOL project.
2. On the File menu, click Properties. Or select Property... from the context menu. The property dialog box appears.
3. In the left pane, select Build. The Build page appears.
4. Click the Linker Options tab. The Linker Options page appears.
**Item** | **Description**
---|---
Linker options | Displays a list of the set libraries and object files.
Add | Adds libraries and object files to be linked. Click the Add button to display the Add Linker Option dialog box so that libraries and object files can be selected. Click the Browse button to display the Folder type selection dialog box so that files can be selected. One or more libraries and object files can be added.
Change | Changes the selected library or object file.
Remove | Deletes the selected library or object file.
Remove All | Deletes all the libraries and object files displayed in Linker options.
Up | Changes the linking order of the selected library file.
Down | Changes the linking order of the selected library file.
Use C function | Used to select whether the TARGET type is a dynamic link library and whether the TARGET uses the C functions. This item defaults to unchecked.
C Run-time Library Name | Specifies the filename of the C run-time library to be linked during linkage. If the C run-time library name is omitted, "LIBCMT.lib" is linked. In the following cases, specify "MSVCRT.lib."
- When two or more DLLs execute in one process.
- The called C program is created with Microsoft Visual C++ and compiled with the /MD option.
For details of the C run-time libraries linkage, refer to "NetCOBOL User's Guide."
DLL Entry Object | Specifies whether only object files created in COBOL are used to create the dynamic link library, or whether object files created in other languages are also used.
For COBOL program only | Creates a dynamic link library using only object files created in COBOL.
For linking with non-COBOL Program | Creates a dynamic link library using object files created in other languages as well as COBOL.
Output debugging information | Used to select whether to output debug information to the program data base file(PDB). This item defaults to check.
Other options | Used to enter additional link options. To enter multiple options, insert space characters as delimiters.

---

**Specification format** | **Description**
---|---
/OUT:filename | Specifies the name of the main output file.
/STACK:stack-size | Specifies a change in the stack size. The default is 1 MB. Specify a stack size in units of bytes.
/MAP:filename | Specified this when creating a map file.

---

**Note**

When specifying the project from Selection from the project dialog in selecting Link options, the path separator backslash is displayed as a forward slash. The forward slash is treated as a backslash.

The following table lists link options that can specified for Other options. For details on the link options, see the "NetCOBOL User's Guide".
6.3.2 Setting TARGET options

The following TARGET options can be set for each project:

- TARGET name
- TARGET type
- Build mode

To display the Target page and specify TARGET options:

1. In the Dependency view or Structure view, select a COBOL project.
2. On the File menu, click Properties. Or select Property... from the context menu. The property dialog box appears.
3. In the left pane, select Target. The Target page appears.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target name</td>
<td>Specifies a TARGET name. The current project name is set as the initial value.</td>
</tr>
<tr>
<td>Target type</td>
<td>Specifies the type of TARGET to be output. &quot;Executable&quot; or &quot;Dynamic-link library&quot; can be selected. The default is &quot;Executable&quot;.</td>
</tr>
<tr>
<td>Use the DLL specific runtime initialization file (COBOL85.CBR)</td>
<td>For a target type of Dynamic-link library, if this option is selected, an initialization file for DLL-specific execution is used.</td>
</tr>
<tr>
<td>Application format</td>
<td>Specifies the format of the created application.</td>
</tr>
<tr>
<td>COBOL console window</td>
<td>Specifies that a console window created by a COBOL program is the input-output destination of ACCEPT and DISPLAY statements, and that a message box is the output destination of execution-time error messages.</td>
</tr>
<tr>
<td>System console window</td>
<td>Specifies that the system console (command prompt window) is the input-output destination of ACCEPT and DISPLAY statements and execution-time error messages.</td>
</tr>
<tr>
<td>Build mode</td>
<td>Specifies &quot;Release&quot; or &quot;Debug&quot; as the build mode. The default is &quot;Debug&quot;.</td>
</tr>
</tbody>
</table>

**Note**

When you specify Debug for a build mode, the "CHECK(ALL)" compiler option is added.

6.4 Resource compiler

The resource compiler is a build tool used to add version information to a program or set icons for a program. This build tool is valid when resource definitions have been described to a resource definition file (.rc file) and this resource definition file has been added to the Source Files folder. For details on the specification format and description method of resource definition files, see the Microsoft(R) Resource Compiler manual.

6.4.1 Build Tool Settings

To invoke the resource compiler during a build for a COBOL project, the Resource compiler must be set for Build Tools. When creating a new COBOL project, the Resource compiler is not set for Build tools.

Adding the Resource compiler to the build tools

To add the Resource compiler to a COBOL project:

1. In the Dependency view or Structure view, select the project.
2. Select Property... from the context menu. The property dialog box appears.
3. In the left pane, select Build Tools. The Build Tools page appears.
4. Click Add Build Tool…. The Add Build Tool dialog box appears.
5. Select Resource compiler, and then click OK.
6. Confirm that Resource compiler has been added to the List of build tools associated with COBOL builder list, and click OK.

Deleting the Resource compiler from the build tools

To delete the Resource compiler from a COBOL project:
1. In the Dependency view or Structure view, select the project.
2. Select Property... from the context menu. The property dialog box appears.
3. In the left pane, select Build Tools. The Build Tools page appears.
4. In the List of build tools associated with COBOL builder list, click Resource compiler, and then click Remove.
5. Confirm that the Resource compiler has been deleted from the List of build tools associated with COBOL builder list, and click OK.

6.4.2 Setting the Resource compiler options

To display the Resource compiler page, specify the Resource compiler options as follows:
1. In the Dependency view or Structure view, select the project.
2. On the File menu, click Properties. Or select Property... from the context menu. The property dialog box appears.
3. In the left pane, select Build Tools > Resource compiler. The Resource compiler page appears.

6.5 Building a COBOL Program

Several methods can be used to build a COBOL program. The range of build targets can be one or more selected projects, or an entire workspace.

6.5.1 Manual build

If Project > Build Automatically on the menu bar is checked, build is automatically executed when a resource is saved. If the developer needs to control execution of build, the checkmark can be cleared from Build Automatically, and build can be executed manually.

Build Project
To execute a build for one or more selected projects:
1. In the Dependency view or Structure view, select the projects.
2. On the Project menu, click Build Project. Or select Build Project from the context menu.
A Build is executed only for the resources that have been updated since the last build.

Build All
To build all of the projects in a workspace:
1. On the Project menu, click Build All.
A Build is executed only for the resources that have been updated since the last build.

Rebuild Project
To execute a build for all project resources including those not updated since the last build:
1. In the Dependency view or Structure view, select each target project for the build.
2. On the Project menu, click Clean.... Or select Rebuild Project from the context menu.
Build Working set

The working set is a grouping of the project and the resource. Create the working set, and divide the build targets into groups. A Build is executed only for the projects that have been updated since the last build.

Creating Working set

1. On the Project menu, click Build Working Set > Select Working Set. The Select Working Set dialog box appears.
2. Click New... The New Working Set wizard is started.
3. In the Working set type list, select the Resource, and click Next.
4. In the Working set name field, enter an arbitrary name. In the Working set contents list, select the project, and click Finish.

Build

1. On the Project menu, click Build Working Set > Select Working Set. The Select Working Set dialog box appears.
2. Select the working set, and click the OK button. The build of the project selected in the working set is executed.

After the build, the selected working set name is added to the submenu of Project > Build Working Set. A build of the working set can be executed by the selection of this menu.

Note

When the file not included in the project is referred by the compiler option, even if the reference files that are not included in the project are changed, changing the resource for the project will not be recognized. For this reason, even if Build Project is executed or Build Automatically is checked, the target file is not updated.

When the files that are not included in the project are changed, execute the "Rebuild project" for the project that is using the files.

Point

Follow the procedure below to automatically save modified resources before manual build execution.

1. On the Window menu, click Preferences. The Preferences dialog box appears.
2. In the left pane, select General > Workspace. The Workspace page appears.
3. Select the Save automatically before build check box.
4. To close the Preferences page, click OK.

6.5.2 Automatic build

If Project > Build Automatically on the menu bar is checked, the build is automatically executed when the following things occur.

- The project has been imported.
- The resource was saved.
- The build option was changed.

6.5.3 Analyzing dependency of repository file

To build a project including object-oriented COBOL source files, the dependency between the COBOL source files must be set before the build. By setting that dependency, the COBOL source files are built in the correct sequence. If the dependency is not set correctly, a compile error may occur during the build. When a project is created or COBOL source files are added to the Source Files folder, the added source files are analyzed and the dependency is set automatically. However, when the REPOSITORY paragraph of a COBOL source program has been edited, the dependency must be analyzed manually before a build is executed.

In the Dependency view, select a project, and then select Analyze Dependency > All from the context menu to analyze the dependency.
Note

The message "abc.rep: dose not exist" is displayed in the Console view when the dependency is analyzed. Repository files (*.rep) for the object-oriented COBOL source files in a project are created only after the source files are compiled. Therefore, if the dependency is analyzed before the build, that message is displayed. When the dependency analysis itself has been correctly performed, the project can be built without any special measure taken.

6.6 Correcting Compilation Errors

Compilation errors during build are displayed in the Problems view. To edit a COBOL source file containing a compilation error, double-click the information on the compilation error in the Problems view, or select Go To from the context menu. The COBOL source file is opened with the editor, and the current line is the one that contains the compilation error. If the file is already open in the COBOL editor, the line containing the compilation error becomes the current line.
Chapter 7 Debugging Function

This chapter describes the debugger, which is used to detect logic errors in programs. The debugger can be used to set breakpoints to halt execution of a program and to verify execution of a program by confirming data item values. The debugger supports debugging of multithreaded programs; however it does not support multiple debug sessions.

7.1 Debugging an Application

The program to be debugged is executed at the same time that the debugger is started. The startup configuration of the application is used at debugger startup.

7.1.1 Creating the debugging information file

In the debugging of the COBOL program, the debugging information file is prepared. When the build is executed by the following settings, the debugging information file is created.

1. Display the property dialog box of the COBOL project.
2. In the left pane, select the Target. The Target page appears.
3. Select the Build mode. When Debug has been selected, the debugging information file is created at build.

The setting of the build mode is effective only for the specified project.

Point

The COBOL compiler creates the SVD File of each COBOL source file. At debugging, store the SVD file in the same folder as the executable file. In remote debugging, when a local machine is selected as a server, you copy the debugging information File with the execution file.

7.1.2 The startup configuration

The startup of the debugger uses the startup composition. NetCOBOL Studio supports the local debug and the remote debug.

- Local debug
  Use the COBOL application startup configuration.
  For details, refer to "7.1.3 Starting debugging"

- Remote debug
  Use the Remote COBOL application startup configuration.
  - Normal Debug: "9.6.1.2 Starting the remote debugger"
  - Attach Debug: "9.6.2.1 Starting the remote debugger".

Note

When debugging it by the same startup composition, on the Run menu, click Debug History. Alternatively, click in the toolbar, and select the Name. The Debugger is started.

7.1.3 Starting debugging

This section explains the procedure for debugging a program.

1. In the Dependency view or Structure view, select a COBOL project.
2. On the **Run** menu, click **Debug Configurations...** Alternatively, click in the toolbar, and select **Debug Configurations...** The **Debug Configurations** dialog box appears.

3. In the left pane, double-click **COBOL Application**. The startup configuration setting page displays in the right pane.

4. The default startup configuration name is displayed in the **Name** field. The startup configuration name can be changed.

5. Check the contents of the **Main** tab, and add or modify the contents as necessary.
   a. “Project name” is the COBOL project name selected in step 1.
   b. “Executable File” is the program to be executed first at the start of debugging. If the specified TARGET of the project is an executable file, it cannot be changed. If the specified TARGET is a dynamic link library, specify the relevant file.
   c. Specify the current folder at execution time in the **Working folder** field. If the dynamic link libraries required for execution are stored in this folder, they can be loaded during execution, even if other settings such as path settings have not been made.
   d. For “Program arguments”, enter the arguments specified for Executable File in the format used for the command line interface.

6. Select **Debug** to start debugging.

**Point**

In the Dependency view or Structure view, select the project. On the **Run** menu, click **Debug As > COBOL Application**, and then debugging can be started with the default settings.

**Note**

Other debuggers (e.g. COBOL, Java) cannot be started while debugging a COBOL program. The same workspace folder cannot be used from more than one NetCOBOL Studio.

### 7.1.3.1 Setting items of the COBOL application startup configuration

This section explains setting items of the COBOL application startup configuration.

#### Main tab

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>The select project name is displayed.</td>
</tr>
<tr>
<td>Executable File</td>
<td>This file is executed first at the debugging. When the target is an execution file, cannot be changed. When the target is a dynamic link library, specify an appropriate file.</td>
</tr>
<tr>
<td>Working folder</td>
<td>Specify the current folder at execution time. The dynamic library stored in this folder is loaded without other path settings.</td>
</tr>
<tr>
<td>Program arguments</td>
<td>The argument of the program is input.</td>
</tr>
</tbody>
</table>

#### Source tab

This tab specifies search paths for COBOL source files and COBOL library files. Searches for sources are performed in the order displayed in “Source lookup path”. Projects and folders can be added to the search paths. The order of the added search paths can be changed using “Up” or “Down”.

**Note**

If an external folder is specified in a search path, the following functions do not work correctly for the COBOL source programs in the external folder:

- Breakpoint operations
To use either of the above functions, Fujitsu recommends specifying the corresponding project in the source search paths. When debugging a COBOL source file in an external folder, debug each line using **Step Into** or **Step Over**.

---

**Environment tab**

This tab sets information used by a COBOL runtime module. Before the start of its processing, the COBOL runtime module uses this information to obtain environment-specific information.

To add the environment variable information set here to existing system environment variables or user environment variables, select **Append environment to native environment**. To replace the existing environment, select "Replace native environment with specified environment".

**Note**

If the same setting in an environment variable is made both on the **Environment** tab and in the runtime initialization file, the information set in the runtime initialization file is valid. For details on runtime environment information, see the "NetCOBOL User's Guide".

---

**Common tab**

This tab specifies how to save the startup configuration, which perspective to open after the start of execution or debugging, and other settings. For details, see the description of the **Common** tab in "8.2 Executing a COBOL Program".

---

**7.1.4 Debug perspective**

A COBOL program is debugged in the Debug perspective. The Debug perspective consists of views that are suitable for debugging, and facilitate debugging operations. For details on the debug perspective, see "7.2 Debug Perspective". Debugging can also be performed in the COBOL perspective.

---

**7.1.5 Outline of the debugging functions**

The debugger has the following functions:

- Setting breakpoints
- Unconditional execution
- Single-step execution
- Execution to the specified line
- Referencing a data item
- Changing the value of a data item
- Monitoring data items

For details on each debugging function, see "7.3 Debugger Functions."

---

**7.1.6 Exiting debugging**

Use any of the following methods to exit debugging:

- Click the toolbar button in the Debug view.
- Select **Terminate** from the context menu of the Debug view.
- Select **Run > Terminate** from the menu bar.
7.1.7 Notes

To invoke a dynamic link library of another project linked through the dynamic link structure from the project to be debugged, the storage location of the dynamic link library must be set using either of the following methods:

- Specify the project of the dynamic link library for the "Source lookup path" on the Source tab of Debug.
- Specify the dynamic link library by adding a PATH variable to "Environment variables to set " and specify the folder containing the dynamic link library in the Environment tab of Debug.

7.2 Debug Perspective

The Debug perspective consists of the COBOL editor and the following views that facilitate debugging operations:

- Debug view
- Breakpoints view
- Watch view
- Outline view

Note

In NetCOBOL Studio, use the Watch view when referring and setting data items. The Variables view cannot be used in NetCOBOL Studio.
7.2.1 Debug view

The Debug view displays a project name, the name of the program being executed, and other information in a tree structure, enabling the user to check the program execution status (status of threads and stacks), calling paths, and other information. Buttons and context menus can be used to perform debugging operations such as starting, executing, or exiting a program.

7.2.1.1 Context menu of the Debug view

The following table lists the context menu items used in the Debug view.

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step Into</td>
<td><img src="image1.png" alt="Button" /></td>
<td>Executes one statement in a program. If the executed statement invokes another process such as a CALL statement, control jumps to the called process, and execution is halted. When Step Into is executed just before a COPY statement, execution is halted at the first statement in the COBOL Library.</td>
</tr>
<tr>
<td>Step Over</td>
<td><img src="image2.png" alt="Button" /></td>
<td>Executes one statement in a program. If the executed statement invokes another process such as a CALL statement, the entire called process is executed, and execution is halted at the next statement following the calling statement. When Step Over is executed just before a COPY statement, execution is halted at the first statement in the COBOL Library.</td>
</tr>
<tr>
<td>Step Return</td>
<td><img src="image3.png" alt="Button" /></td>
<td>Executes a program until control returns to the calling process. When Step Return is executed in a COBOL library, the program is executed until returning to the call process of the program in which the COBOL library is specified.</td>
</tr>
<tr>
<td>Resume</td>
<td><img src="image4.png" alt="Button" /></td>
<td>Restarts the halted execution of a program.</td>
</tr>
<tr>
<td>Suspend</td>
<td><img src="image5.png" alt="Button" /></td>
<td>Halts execution of a program.</td>
</tr>
<tr>
<td>Terminate</td>
<td><img src="image6.png" alt="Button" /></td>
<td>Exits debugging.</td>
</tr>
<tr>
<td>Terminate and Relaunch</td>
<td>-</td>
<td>Exits the current debugging and starts debugging of the same target again.</td>
</tr>
</tbody>
</table>

7.2.2 Breakpoints view

The Breakpoints view displays all of the breakpoints set for a project. When a breakpoint is double-clicked, the editor displays the breakpoint locations. Breakpoints can be enabled, disabled, and deleted in this view.

7.2.2.1 Context menu of the Breakpoints view

The following table lists the context menu items used in the Breakpoints view.

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Go to File</td>
<td><img src="image7.png" alt="Button" /></td>
<td>Displays in the COBOL editor the location at which the selected breakpoint is set.</td>
</tr>
<tr>
<td>Hit Count...</td>
<td>-</td>
<td>Displays the Set Breakpoint Hit Count dialog box.</td>
</tr>
<tr>
<td>Condition...</td>
<td>-</td>
<td>Displays the Set Breakpoint Condition dialog box.</td>
</tr>
<tr>
<td>Enable</td>
<td>-</td>
<td>Enables a disabled breakpoint.</td>
</tr>
<tr>
<td>Disable</td>
<td>-</td>
<td>Disables an enabled breakpoint.</td>
</tr>
</tbody>
</table>
7.2.2.2 Breakpoint properties

By using these properties, the following settings are possible.

- Enable and disable breakpoint
- The hit count of a breakpoint
- Enable and disable the hit count of a breakpoint
- The condition of a breakpoint
- Enable and disable the condition of a breakpoint

1. Set a breakpoint using the COBOL editor.
2. In the Breakpoints view, select the breakpoint, and then select **Properties...** from the context menu. The COBOL Line Breakpoint Properties dialog box appears.
3. Enable or disable the breakpoint. This dialog box is also used to set the hit count of a breakpoint, and enable or disable the hit count of the breakpoint.

7.2.3 Watch view

The Watch view is used to perform debugging operations for data items. This view enables the user to add and delete data items, and change their values.

7.2.3.1 Context menus of the Watch view

The following table lists the context menu items used in the Watch view.

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Data Item...</td>
<td><img src="image" alt="Button" /></td>
<td>Displays the <strong>Add Data Item</strong> dialog box used to add data items to the Watch view.</td>
</tr>
<tr>
<td>Add Condition</td>
<td><img src="image" alt="Button" /></td>
<td>Displays the <strong>Add Condition</strong> dialog box used to add condition items to the Watch view.</td>
</tr>
<tr>
<td>Change Value</td>
<td>-</td>
<td>Displays the <strong>Set Value</strong> dialog box used to change the values of the selected data items.</td>
</tr>
<tr>
<td>Change Hex Value</td>
<td>-</td>
<td>Displays the <strong>Set Value</strong> dialog box used to change the values of the selected data items, where the values are specified in hexadecimal format.</td>
</tr>
<tr>
<td>Suspend by Value</td>
<td>-</td>
<td>Specifies whether to halt execution of the program when the values of the selected data items are changed.</td>
</tr>
<tr>
<td>Remove</td>
<td><img src="image" alt="Button" /></td>
<td>Deletes the selected data item from the Watch view.</td>
</tr>
<tr>
<td>Remove All</td>
<td><img src="image" alt="Button" /></td>
<td>Deletes all the data items from the Watch view.</td>
</tr>
<tr>
<td>Show Data Type</td>
<td>-</td>
<td>Specifies whether to display data types in the Watch view.</td>
</tr>
</tbody>
</table>

7.2.3.2 Adding data items to the Watch view

Data items can be added to the Watch view by selecting Add Data Item from the context menu or toolbar.
1. Select **Add Data Item** from the context menu or toolbar. The **Add Data Item** dialog box appears.

2. Specify information such as data item names, a program name, and whether to halt execution when values are changed, and add the data items to the Watch view.

<table>
<thead>
<tr>
<th>Table 7.1 Add Data Item dialog box</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>item</strong></td>
</tr>
</tbody>
</table>
| Data name                         | When adding data items for monitoring to the Watch view, specify identifier name as data name. One of the following is the identifier name.  
- Identifier  
- Condition-name  
- Index Name  
- Special Register  
- Symbolic-constant  
- Named Literal  
- Function  
For details, refer to "D.1 Identifier Name". |
| Program name                      | Specify the program name. For details, "D.2 Program name". |
| Suspend by Value Change           | If this item is checked, when the value of the data changes, the program execution is stopped. |

To add data items defined in methods of a class, specify "class-name:method-name" as the program name.

A data item can be added to the Watch view by double-clicking the data item in the COBOL editor and then selecting **Add to Watch view** from the context menu.

---

**Note**

Data items can be added to the Watch view during debugging. First, start debugging of the program. Then, when execution of the program is halted, such as at a breakpoint, add data items to the Watch view.

---

### 7.2.3.3 Display formats of the values in the Watch view

Hexadecimal format or ASCII character format can be used as the data display format of the Watch view, or both formats can be used for data display as an added format.

To add or change a display format:

1. On the **Window** menu, click **Preferences**. The **Preferences** dialog box appears.
2. In the left pane, select **COBOL > Debug**. The **Debug** page appears.
3. Select a display format from Watch view display options, and then click the **OK** or **Apply**.

### 7.2.3.4 Adding conditions to the Watch view

Conditions can be added to the Watch view by selecting **Add Condition** from the context menu or toolbar.

1. Select **Add Condition** from the context menu or toolbar. The **Add Condition** dialog box appears.
2. Specify information such as conditions, a program name, and whether to halt execution when values are changed, and add the conditions to the Watch view.
Table 7.2 Add Condition dialog box

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Condition</td>
<td>Specify the condition to stop the execution of the program at debugging time. For details, refer to &quot;D.3 Conditional Expression.&quot;</td>
</tr>
<tr>
<td>Program name</td>
<td>Specify the program name of the program for which data included in the condition is declared. For details, refer to &quot;D.2 Program name&quot;.</td>
</tr>
</tbody>
</table>

### 7.2.4 Outline view

The Outline view displays a structural outline of the COBOL source file that is currently the active one in the COBOL editor. For details, see "Outline View."

### 7.3 Debugger Functions

This section describes the main debugger functions.

#### 7.3.1 Breakpoints

A breakpoint is represented by a mark indicating a specified point in a program at which the debugger can be stopped. This section shows how to add and delete breakpoints, as well as how to use breakpoints.

##### 7.3.1.1 Adding a breakpoint

To add a breakpoint:

1. Use the COBOL editor to open the file to which to add a breakpoint.
2. Immediately to the left of the line to which to add the breakpoint, select Add Breakpoint from the context menu of the vertical ruler.
3. The breakpoint mark is displayed on the vertical ruler. The breakpoint is displayed in the list of the Breakpoints view.

**Point**

A breakpoint can also be set by double-clicking on the vertical ruler.

**Note**

If a breakpoint is set in a COBOL library, and that library is used by multiple COPY statements, the breakpoint will be hit in each of those cases and the program will be interrupted.

##### 7.3.1.2 Deleting a breakpoint

To delete a breakpoint:

1. In the Breakpoints view, select the breakpoint to be deleted.
2. Select Remove Breakpoint from the context menu.

**Point**

A breakpoint can also be deleted by double-clicking on it in the marker bar.
7.3.1.3 Using breakpoints

When control reaches a breakpoint during execution of a program, the debugger halts execution. The program calling path and data item values can be referenced at this point in time.

You can perform the following using breakpoint properties.

- Enable and disable breakpoint
- Specification of the hit count
- Specification of the condition

The breakpoint properties can be displayed using the context menu of the vertical ruler or the context menu of the Breakpoints view.

If both the hit count and the condition are specified, when either condition is satisfied, the debugger halts execution.

Once a breakpoint is set, it is maintained across multiple sessions until it is explicitly deleted. Breakpoints are saved even when their file, which is open in the COBOL editor, is closed. The set breakpoints are displayed the next time the file is opened.

7.3.1.4 Hit count of a breakpoint

Execution of a program can be halted by using the hit count of a breakpoint. Execution is halted when the line at which the breakpoint is set has been executed the number of times specified for the hit count.

1. Set a breakpoint using the COBOL editor.
2. Select the breakpoint from the Breakpoints view, and then select Hit Count... from the context menu.
3. Set the hit count of the breakpoint, and enable or disable the hit count of the breakpoint in the Set Breakpoint Hit Count dialog box.

Note

The hit count of the breakpoint in the COBOL library is the total execution count of the breakpoint, even though the COBOL library may be used by several COPY statements.

7.3.1.5 Condition of a breakpoint

Execution of a program can be halted by using the condition of a breakpoint.

1. Set a breakpoint using the COBOL editor.
2. In the Breakpoints view, select the breakpoint, and then select Condition... from the context menu. The Set Breakpoint Condition dialog box appears.
3. Set the Enter the new condition for the breakpoint and Enable Condition, and then click OK.

Information

For detailed specification of the condition, refer to "D.3 Conditional Expression."

7.3.2 Execution

The debugger can execute a series of statements up to the next breakpoint or the specified statement all at once, or it can execute it statement by statement for checking of the behavior of each statement in the execution path. However, if a breakpoint is detected during execution of the program, execution is halted at this breakpoint even when it has not reached any specified statement.

Note

If the path of the executable program to be debugged is not displayed for the selected tree element in the Debug view, the execution operation of the debugger is disabled. If the correct tree element has not been selected, select a tree element for which the path of an executable program is displayed, and run the debugger.
7.3.2.1 Unconditional execution

In unconditional execution, a program is executed without any halt statement specified. The program is executed until either the next breakpoint is reached or the program exits.

Use any of the following methods to perform unconditional execution:

- In the Debug view, select the toolbar button.
- In the Debug view, select Resume from the context menu.
- On the Run menu, click Resume.
- Press the F8 shortcut key.

7.3.2.2 Step Into

Step-into executes only one statement in a program. If the executed statement invokes another process such as a CALL statement, control jumps to the called process, and execution is halted.

Use any of the following methods to perform Step Into:

- In the Debug view, select the toolbar button.
- In the Debug view, select Step Into from the context menu.
- On the Run menu, click Step Into.
- Press the F5 shortcut key.

**Note**

When Step Into is executed just before a COPY statement, execution is halted at the first statement in the COBOL Library.

7.3.2.3 Step Over

Step-over executes only one statement in a program. If the executed statement invokes another process such as a CALL statement, execution is not halted in the called process. Instead, all of the called process is executed, and execution is halted at the next statement following the calling statement.

Use any of the following methods to perform Step Over:

- In the Debug view, select the toolbar button.
- In the Debug view, select Step Over from the context menu.
- On the Run menu, click Step Over.
- Press the F6 shortcut key.

**Note**

When Step Over is executed just before a COPY statement, execution is halted at the first statement in the COBOL Library.

7.3.2.4 Execution until control returns to the calling process

When execution has been halted within a subprogram or method, this function performs execution until control returns to the calling process.

Use any of the following methods to perform execution until control returns to the calling process:

- In the Debug view, select the toolbar button.
- In the Debug view, select **Step Return** from the context menu.
- On the **Run** menu, click **Step Return**.
- Press the **F7** shortcut key.

**Note**

When Step Return is executed in a COBOL library, the program is executed until returning to the call process of the program in which the COBOL library is specified.

### 7.3.2.5 Execution until control reaches the specified statement

The program is executed from the current halt statement to the statement at which the cursor is positioned in the COBOL editor.

To execute the program to the specified statement:

- Select **Run to Line** from the context menu of the COBOL editor.

**Note**

Run to Line cannot be executed from a COBOL library. In order to execute to the specified statement, use one of the operations below.

- Set the breakpoint to the target line and use Unconditional execution.
- Repeat Step Into or Step Over until the control reaches the target line.

### 7.3.3 Debugging functions for data items

Data item values can be checked and changed with the debugger. This section explains debugging functions for data items.

**Note**

When a REPLACE statement or a COPY statement with a REPLACING phrase, DISJOINING phrase, or JOINING phrase is described in the source program, the source program before string replacement is displayed. In order to reference, change, or monitor the value of the data item to be replaced, specify the data item name after replacing.

#### 7.3.3.1 Referencing the value of a data item

This section explains methods that can be used to reference a data item value.

**Displaying the value in a tooltip**

When the mouse cursor is positioned on a data item displayed in the COBOL editor, a tooltip appears with the value of the data item.

**Using the Watch view**

The value of a data item and more detailed information on it can be referenced by adding the data item to the Watch view. For details on the Watch view, see “7.2.3 Watch view.”

#### 7.3.3.2 Changing the value of a data item

This section explains the methods that can be used to change the value of a data item added to the Watch view.

**Changing a data item in automatic format**

To change the value of a data item in automatic format:

1. In the Watch view, select the data item whose value is to be changed.
2. Select **Change Value** from the context menu. The **Set Value** dialog box appears.

3. Enter the replacement value for the current value, and click **OK**.

### Changing a data item in hexadecimal format

Follow the procedure below to change the value of a data item in hexadecimal format.

1. In the **Watch** view, select the data item whose value is to be changed.
2. Select **Change Hex Value** from the context menu. The **Set Value** dialog box appears.
3. Enter the replacement value for the current value, and click **OK**.

### 7.3.3.3 Monitoring changes in the values of data items

Data items can be monitored so that execution of the program can be halted when the value of a data item is changed. Use either of the following methods to specify whether to halt execution of the program when such a value is changed:

- During registration in the **Watch** view:
  
  Check the **Suspend by Value Change** checkbox in the **Add Data Item** dialog box.

- For a data item registered in the **Watch** view:
  
  Select **Suspend by Value Change** from the context menu of the **Watch** view.

### 7.3.4 Notes

- The following alphanumeric data items are considered as Int type binary integer data items.

<table>
<thead>
<tr>
<th><strong>Int type binary integer data item</strong></th>
<th><strong>Treatment in Debug</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>BINARY-CHAR PIC X(1)</td>
<td>Alphanumeric data item for 1 byte</td>
</tr>
<tr>
<td>BINARY-SHORT PIC X(2)</td>
<td>Alphanumeric data item for 2 bytes</td>
</tr>
<tr>
<td>BINARY-LONG PIC X(4)</td>
<td>Alphanumeric data item for 4 bytes</td>
</tr>
<tr>
<td>BINARY-DOUBLE PIC X(8)</td>
<td>Alphanumeric data item for 8 bytes</td>
</tr>
</tbody>
</table>

In addition, set the hexadecimal format if you want to set the value in int type binary integer data item.

- When using the debug function to handle the data (value reference, value change, and interruption in changing value), if the area length is specified in an extremely large data item, the debugging operation may be very slow. Although it is not possible to say unconditionally that the limit of the data length depends on the ability and environment of the debugging machine, pay attention to the data size in the debugging operation.

  When considering the slow operation during debugging due to using a large area length data item, specify the reference modification and limit the scope of the data area that is taken as the handle target.

### 7.3.4 Adding data items to the Watch view from the COBOL editor

Data items can be added to the **Watch** view from the COBOL editor as the following steps when execution of the program is halted, such as at a breakpoint.

1. In the COBOL editor, drag the data item to be added to the **Watch** view.
2. Select **Add to Watch view** from the context menu.

---

**Note**

Data items of the COBOL library files in the COBOL editor cannot be added to the **Watch** view from the context menu. Use “Add Data Item” in the **Watch** view. For details, see “7.2.3.2 Adding data items to the Watch view”.

---
7.3.5 Changing the beginning of the execution

The point where a program is stopped can be changed to the point where the cursor is set as the following steps. And then, the point after changed gets to be the beginning of the execution.

1. In the COBOL editor, move the cursor to the line to be changed.
2. Select Run from Line from the context menu.
8.1 Runtime Environment Information

The information necessary for executing a COBOL program is called runtime environment information. The two types of runtime environment information are environment variable information and entry information. The COBOL runtime uses environment variable information to obtain environment-specific information at the start of processing. Entry information is used to specify information on the dynamic program structure.

In NetCOBOL Studio, the Runtime Environment Setup Tool is used to set runtime environment information. The Run-time Environment Setup Tool can be started by double-clicking the runtime initialization file (COBOL85.CBR) that is generated when a project is created in the Dependency or Structure view. Environment variable information can be specified from the Run Configurations dialog box.

For details on runtime environment information, see the NetCOBOL User's Guide.

**Note**

In NetCOBOL that operates on Windows(x64), neither the Run-time Environment Setup Tool nor the files are related by initialization file for execution (COBOL85.CBR).

To edit the run-time initialization file with the Run-time Environment Setup Tool, follow the procedure below.

1. Click Start, select Fujitsu NetCOBOL V12(x64) > NetCOBOL Studio(x64) > Run-time Environment Setup Utility. The Run-time Environment Setup Tool is started.
3. Select the initialization file.

8.2 Executing a COBOL Program

This section explains the procedure for executing a COBOL program.

**Executing a COBOL program**

To execute a COBOL program:

1. In the Dependency or Structure view, select the COBOL project.
2. On the Run menu, click Run Configurations.... The Run Configurations dialog box appears.
3. In the left pane, double-click the COBOL Application. The startup configuration setting page displays.
4. In the Name field, the project name is the initial value displayed. The startup configuration name can be changed.
5. On the Main tab,
   - In the Project name field, enter the COBOL project name. Alternatively, in the right side of the Project name field, click Browse... . The Project Selection dialog appears. Select the COBOL project.
   - If the TARGET of the specified project is a dynamic link library, specify the "Executable File".
   - In the Working folder field, specify the current folder at the execution time. If the dynamic link libraries required for execution are stored in this folder, they can be loaded during execution time.
   - In the Program arguments field, enter parameters in the format used for the command line interface.
6. To execute the program, click Run.

Once the COBOL program has been executed using the steps detailed above, it can also be executed using the following steps:

1. On the Run menu, click Run history.
2. Select the startup configuration name that was specified in the **Name** field in Procedure 4 above.

If the COBOL program is executed using any method other than those described here, the values set in the Run dialog box do not take effect.

**Note**

For example, a user may execute a COBOL program by double-clicking an executable file from a view. In this case, the work directory settings specified in the Run dialog box are not reflected. Problems may occur, if for example, the relative path name specified in the runtime initialization file (COBOL85.CBR) is not the intended path.

**Setting the COBOL application startup configuration**

Setting items of the COBOL application startup configuration.

**Main tab**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>The select project name is displayed.</td>
</tr>
<tr>
<td>Executable File</td>
<td>It is a program executed first at the debugging. When the target is an execution file, cannot be changed. When the target is a dynamic link library, specify an appropriate File.</td>
</tr>
<tr>
<td>Working folder</td>
<td>Specify the current folder at execution time. When you store the dynamic link library in this folder, the load of dynamic link library can be done at execution time even if other paths are not set.</td>
</tr>
<tr>
<td>Program arguments</td>
<td>The argument of the program is input.</td>
</tr>
</tbody>
</table>

**Source tab**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source lookup path</td>
<td>This page contains the paths used to search source files in debugging. The information in the &quot;Source&quot; tab is not used at execution time</td>
</tr>
</tbody>
</table>

**Environment tab**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Environment variables to set</td>
<td>This item contains information that is used by the COBOL runtime module to obtain environment-specific information at the start of processing. For details on environment-specific information, see the &quot;NetCOBOL User's Guide&quot;.</td>
</tr>
<tr>
<td>Variable</td>
<td></td>
</tr>
<tr>
<td>Value</td>
<td></td>
</tr>
<tr>
<td>Append environment to native</td>
<td>To add the environment variable information set here to existing system environment variables or user environment variables.</td>
</tr>
<tr>
<td>environment</td>
<td></td>
</tr>
<tr>
<td>Replace native environment</td>
<td>To replace the existing environment.</td>
</tr>
<tr>
<td>with specified environment</td>
<td></td>
</tr>
</tbody>
</table>

**Note**

If the same environment variable is set in both the "Environment" tab and the runtime initialization file, the information in the runtime initialization file is used.

**Common tab**

The "Common" tab specifies how to save startup configuration information, the perspective to open after the start of execution or debugging, and other related settings.
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Save as</strong></td>
<td>Either Local file or Shared file is selected for the startup configuration type. If &quot;Local file&quot; is selected, startup configuration information is saved locally in workspace metadata. If &quot;Shared file&quot; is selected, startup configuration information is saved at the specified location, and can be shared.</td>
</tr>
<tr>
<td>Local file</td>
<td></td>
</tr>
<tr>
<td>Shared file</td>
<td></td>
</tr>
<tr>
<td><strong>Display in favorites menu</strong></td>
<td>To add Run or Debug to the favorites menu, select &quot;Run&quot; or &quot;Debug&quot;. These items are not selected by default.</td>
</tr>
<tr>
<td>Debug</td>
<td></td>
</tr>
<tr>
<td>Run</td>
<td></td>
</tr>
<tr>
<td><strong>Console Encoding</strong></td>
<td>Default is “Cp1252”.</td>
</tr>
<tr>
<td><strong>Standard Input and Output</strong></td>
<td>In the COBOL application startup configuration, any changes made to the standard input-output settings are ignored.</td>
</tr>
<tr>
<td>Allocate Console</td>
<td></td>
</tr>
<tr>
<td>File</td>
<td></td>
</tr>
<tr>
<td>Append</td>
<td></td>
</tr>
<tr>
<td><strong>Launch in background</strong></td>
<td>To start COBOL applications in the background, select Launch in back ground. Launch in background is selected by default.</td>
</tr>
</tbody>
</table>
Chapter 9 Remote Development Function

This chapter explains NetCOBOL remote development.

9.1 Overview of Remote Development

9.1.1 What is Remote Development?

Using the remote development support functions of NetCOBOL Studio on the client side and NetCOBOL on the server side, you can develop COBOL applications efficiently with a variety of Windows systems.

Server Side

NetCOBOL must be installed on the server.

<table>
<thead>
<tr>
<th>Operating system</th>
<th>NetCOBOL Product</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows(64)</td>
<td>Windows 64bit NetCOBOL</td>
</tr>
<tr>
<td>Solaris</td>
<td>Solaris 32bit NetCOBOL</td>
</tr>
<tr>
<td>Linux(64)</td>
<td>Linux 64bit NetCOBOL</td>
</tr>
<tr>
<td>Linux(Itanium)</td>
<td>Linux(Itanium) 64bit NetCOBOL</td>
</tr>
</tbody>
</table>

Client Side

NetCOBOL and NetCOBOL Studio must be installed on the client system in order to enable NetCOBOL Studio to perform development tasks. NetCOBOL Studio can be connected to a server to perform tasks such as compilation, with the results displaying in NetCOBOL Studio.

9.1.2 Advantages of Remote Development

Many COBOL applications run on expensive server machines. Developing a COBOL application on such a machine causes the following problems:

- You must use a command line interface because many of these systems do not enable a GUI-based environment.
- The server side system must be shared among the developers.

On the other hand, a Windows system is easily available as a personal machine and the developer can occupy its GUI-based environment exclusively.

Remote development solves the above problems by performing development tasks on a Windows system as far as possible.

- You can develop a COBOL application efficiently using a GUI-based development environment.
- You can reduce the load on the server side system by performing development tasks such as source editing on the client side as far as possible.

9.1.3 Flow of Remote Development

The flow of remote development is as follows:

- 112 -
[1] Business Specification Design and Screen/Form Design

Design the application.

[2] Prepare the server

Set the environment for remote development on the server side. Start the remote service, and start the service for the remote development function.
Create and edit the project and source program

COBOL sources and other program resources are created or updated on a local personal computer.
- COBOL source programs
- COBOL library text (COPY clause)
- Screen form descriptors
- Overlay patterns

The program resources that are created or updated at this time are registered in a COBOL project in NetCOBOL Studio.

Build the project (Compilation and linkage - check Syntax)

NetCOBOL Studio is used to compile and link created or updated program resources. This work is performed for the following purposes:
- To confirm that the created program resources do not contain errors or discrepancies
- To check the dependency among the program resources registered in NetCOBOL Studio
- To create an executable program for unit testing

Debug and Execute

A program that has been compiled and linked on a local personal computer is used to test functions within the closed scope in the program. Errors in the program can be detected on the local personal computer by using compile options of the debugging functions provided by NetCOBOL (CHECK, COUNT, and TRACE), and using the COBOL debugger of NetCOBOL Studio.

Prepare to connect to the server

To connect to the server from NetCOBOL Studio, the operating environment of NetCOBOL Studio and the operating environment of the project are set.

Create a Makefile and Send resources

Resources on the local personal computer are sent to the server, and a makefile required for a build on the server is created.

Remote build

Compiling and linking are performed on the server according to the information defined in the project (e.g., compile options, link options).

Remote debug

The remote debug function is used to debug the COBOL program on the server.
9.1.4 Notes on Remote Development

Generally, COBOL programs have high portability and, in many cases, you can perform tasks from the creation of your program, to unit testing on the client side.

However, if your program contains server-specific features or platform dependent features, you must test your program on the server side.

Following items are examples of platform dependent features:

- **Literals or hexadecimal literals**
  - If the client side and the server side use different character encoding, a value that can be compiled on one side may cause a compilation error on the other side.

- **Key sequence or sort key sequence for character comparison or indexed files**
  - The result of descending order of characters may differ based on the difference between the runtime character encoding on the client side and the server side.

- **Class conditions**
  - If the runtime character encoding on the client side and the server side are different, the identification results may also differ.

- **Printing**
  - Available characters and fonts differ according to the target platform

- **Database functions**
  - The execution results may also differ based on the differences in the database products being used.

- **Web linkage function**
  - The available functions differ depending on the target platform. In addition, Windows and UNIX systems have different file and path name rules.

  **Note**

  This system does not support the Web linkage function.

9.1.5 Server side and Client side Combinations

Refer to the "NetCOBOL Software Release Guide" for the supported combinations of the server side and the client side NetCOBOL products.

9.2 Work on server side

9.2.1 Start Service

To use remote development, the services required by this function must be operating at the server system side. Accordingly, these services must be installed and started.

The services that must be installed at the server side are determined by the server OS and NetCOBOL product version.
<table>
<thead>
<tr>
<th>Server OS</th>
<th>NetCOBOL Product on Server</th>
<th>Service to start</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows(64)</td>
<td>Windows 64bit NetCOBOL</td>
<td>NetCOBOL Remote Development Service (*1)</td>
</tr>
<tr>
<td>Solaris</td>
<td>Solaris 32bit NetCOBOL V10 or earlier</td>
<td>rtpd/rexec service telnetd(*2)</td>
</tr>
<tr>
<td>Linux(Itanium)</td>
<td>Linux(Itanium) 64bit NetCOBOL</td>
<td>rtpd/rexec service telnetd(*2)</td>
</tr>
<tr>
<td>Linux(64)</td>
<td>Linux 64bit NetCOBOL</td>
<td>NetCOBOL Remote Development Service(*1)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>telnelt(*2)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>sshd(*3)</td>
</tr>
</tbody>
</table>

*1: The remote development service is a service that NetCOBOL provides. Refer to the following for the service startup procedure.

- For a Windows server
  Refer to "9.2.1.1 NetCOBOL Remote Development Service".
- For a Linux(64) server
  Refer to "NetCOBOL User's Guide" of Linux 64bit NetCOBOL.

*2: This service is required in order to use the remote debug function.

*3: This service is required in order to encode communication contents by SSH port forwarding.

### 9.2.1.1 NetCOBOL Remote Development Service

The NetCOBOL Remote Development Service (referred as "Remote Development Service" after in this chapter) must be run on the server side system to make use of the remote development functions from NetCOBOL Studio on the client side. The Remote Development Service accepts a request from NetCOBOL Studio, logs on the server side system with the specified account and performs tasks on the server side system with the account.

For security reasons, the Remote Development Service is not configured to start automatically in its installation. You must start the Remote Development Service before you use remote development functions.

**Note**

**Security Notes**

For security reasons, the Remote Development Service is not configured to start automatically in its installation.

In order to maintain security, make sure to disclose the Remote Development Service only for the limited period required. When the release of the Remote Development Service is stopped, restore the changes made in the firewall settings or Remote Development Service "Startup type".

Make sure to use remote development functions with the Remote Development Service only inside a safe network such as an intranet with security that is appropriately managed.

When you connect to the Linux(64) server to use Remote Development Service, you can encode communication contents by SSH port forwarding.

In this case, SSH must be running at the server system side, and you need to notify the NetCOBOL Studio user of the public key fingerprint used on the SSH server.

**Information**

Generally, execute the following command to get the public key fingerprint (typical md5).
ssh-keygen -lf /etc/ssh/ssh_host_rsa_key.pub

For details, refer to the manual for ssh-keygen command.

9.2.1.1 Starting and Stopping the Remote Development Service

This section explains how to start and stop the Remote Development Service.

Starting the Remote Development Service

To start the Remote Development Service, log on the server side system with an administrator account and take the following steps:

2. From the list of services, select NetCOBOL Remote Development Services.
3. In the window menu, select Action > Properties, and open the NetCOBOL Remote Development Services Properties dialog.
4. In the NetCOBOL Remote Development Services Properties dialog, select the General tab.
5. Click Start.
6. If you want the Remote Development Service to start automatically when the system is started, change the "Startup type" to "Automatic".

The Remote Development Service uses port 61999 by default, to disclose its services. If port 61999 is already being used in the system, the port number must be changed. Refer to the description of port setting in "9.2.1.1.4 Configuring the Remote Development Service" for details.

If the Windows Firewall or other firewall software is running on the server, you must configure it in a way that it does not block the port which is used by the Remote Development Service. The configuration method for the firewall differs according to the type of firewall software being used. Refer to the document of each firewall software.

Before starting the Remote Development Service, read "Security Notes" under "9.2.1.1 NetCOBOL Remote Development Service".

9.2.1.2 Stopping the Remote Development Service

To stop the Remote Development Service, log on the server side system with an administrator account and take the following steps:

2. From the list of services, select NetCOBOL Remote Development Services.
3. In the window menu, select Action > Properties, and open the NetCOBOL Remote Development Services Properties dialog.
4. In the NetCOBOL Remote Development Services Properties dialog, select the General tab.
5. Click the Stop.
6. If you do not want the Remote Development Service to start automatically when the system is started, change the "Startup type" to "Manual".

When Remote Development Service no longer needs to be disclosed, restore the settings changes that were made in the firewall software or so.

9.2.1.3 Log files of the Remote Development Service

This section explains the log files output by the remote development service.

Contents of the Log file

The following information is recorded in the log file:
- Connection start date and time
- Client IP address
- Account name
- Whether or not log-on was successful
- Connection end date and time

The commands executed under each user account after logon are not recorded.

The time output to the log file is Universal Time and Coordinated (UTC): coordinated universal time.

**The path of the Log file**

The path of the log file is as follows:

```
%ProgramData%\Fujitsu\NetCOBOL\RDS\Log\rds.log
```

%ProgramData% is a common application data folder for Windows.

You can change the folder to output the log file by configuration of the Remote Development Service. See the explanation for the logdir setting in "9.2.1.1.4 Configuring the Remote Development Service" for details.

**Generations of the Log file**

When the size of a log file reaches the maximum size, a backup is made for that log file and a new log file is created.

You can change the maximum size of log files by configuration of the Remote Development Service. Refer to the explanation for the maxlogsize setting in "9.2.1.1.4 Configuring the Remote Development Service" for details.

Backup files are located in the same folder as the log file output folder and have the below name.

```
rds.<sequence number>.log
```

Where <sequence number> is a number starting at 001 and has a maximum value of 999. When new backup file is created, a new sequence number is allocated for it. This sequence number is the next sequence number of the backup file with the most recently updated time amongst the backup files in the same folder. If there is no backup file in the same folder, the sequence number 001 is allocated. 001 is also regarded as the next number of 999.

When a new backup file with sequence number n is created, only the backup files which have sequence number between (n - the number of backup generation + 1) and n are retained. All other backup files are deleted. For example, if the new backup file is rds.007.log and the number of backup generations is 3, all backup files are deleted except for rds.005.log, rds.006.log, and rds.007.log.

You can change the number of backup generation by configuration of the Remote Development Service. See the explanation for the maxloggen setting in "9.2.1.1.4 Configuring the Remote Development Service" for details.

**9.2.1.1.4 Configuring the Remote Development Service**

This section describes the Remote Development Service settings that can be changed and explains how to set them.

The following settings can be changed:

- Port number to be used
- The output folder, maximum size, and number of backup generations for log files

Specify the settings that you want to change as service start parameters. The Remote Development Service must then be restarted for the changes to take effect.

**Changing setting of the Remote Development Service**

To change setting of the Remote Development Service, log on the server side system with an administrator account and perform the following steps:

2. In the services list, select NetCOBOL Remote Development Services.
4. On the General tab, in the Start parameters field, enter the settings.
Note

- To enter more than one setting in the **Start parameters** field, separate the settings with spaces.
- To enter a setting that contains a space, enclose it in quotation marks (").

  **Example** /port:61999 "logdir:C:\log data" /maxlogsize:128 /maxloggen:2

- The contents of the **Start parameters** field are not saved. If you configure the Remote Development Service to start automatically when the system is started, the Remote Development Service starts with default setting when the system is started next time.

Refer to the list below for the settings that can be entered in the **Start parameters** field.

### Setting list of the Remote Development Service

The following table shows the settings that can be changed.

<table>
<thead>
<tr>
<th>Setting name</th>
<th>Form to specify in start parameters</th>
<th>Default value</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>port</td>
<td>/port:&lt;number&gt;</td>
<td>61999</td>
<td>Specify the TCP/IP port number used by the Remote Development Service. In &lt;number&gt;, specify the port number in decimal form.</td>
</tr>
<tr>
<td>logdir</td>
<td>/logdir:&lt;path&gt;</td>
<td>Windows shared application data folder (*)</td>
<td>Specify the folder to which remote development service log files are output. In &lt;path&gt;, specify the folder path. To use a path that contains spaces, enclose the start parameter in quotation marks (&quot;).</td>
</tr>
<tr>
<td>maxlogsize</td>
<td>/maxlogsize:&lt;size&gt;</td>
<td>128</td>
<td>Specify the maximum size of the Remote Development Service log file. In &lt;size&gt;, specify the maximum size in decimal form. Its unit is kilobytes. If 0 is specified, the Remote Development Service does not output log file</td>
</tr>
<tr>
<td>maxloggen</td>
<td>/maxloggen:&lt;number of generations&gt;</td>
<td>2</td>
<td>Specify the number of generations of Remote Development Service log file backups to be retained. In &lt;number of generations&gt;, specify the number of generations in decimal form. If n is specified, n backups (rds.xxx.log) are retained. If a number greater than 999 is specified, 999 is considered to be specified. If 0 is specified, no backup is retained.</td>
</tr>
</tbody>
</table>

*: This depends on the version of Windows. Refer to "The path of the log file" under "9.2.1.1.3 Log files of the Remote Development Service".

### 9.2.1.2 ftpd/rexec services

This section explains how to install and start the ftpd and rexec services at the server.

#### 9.2.1.2.1 On a Solaris server

The ftpd services are installed with their default settings when the operating system is installed on the Solaris server, and always start automatically.

**Note**

No start setting for the rexec service are already configured when the Solaris operating system is installed. The following operations must be performed:

- Checking the status

  Execute the following command to check the status:
If "disabled" is displayed at the beginning of the execution results, start the rexec service.

- Starting the rexec service

Execute the following command to start the rexec service:

```
# svcadm enable svc:/network/rexec:default
```

In most cases, to change the system settings of the Solaris server involves checking the contents of the setting file, and modifying them as necessary.

1. Check the service status.

   inetd (Internet daemon) invokes the ftpd and rexec services on the Solaris server. Therefore, the contents of the following files should be checked:

   - `/etc/services`
   - `/etc/inetd.conf`

   If valid descriptions of the ftpd and rexec services are found in `/etc/services` and `/etc/inetd.conf`, skip the remaining steps in this section. See the examples below. If the line in which ftpd or rexec or both are set is commented out ("#" is added at the beginning of the relevant line), then the remaining steps must be performed.

   **Example for `/etc/services`**

   ```
   #
   # Network services, Internet style
   #
   ftp 21/tcp
   #
   ## UNIX specific services
   ## these are NOT officially assigned
   #
   ```

   **Example for `/etc/inetd.conf`**

   ```
   : # FTPD - FTP server daemon
   ftp stream tcp6 nowait root /usr/sbin/in.ftpd in.ftpd -a
   :
   # REXECD - rexec daemon (BSD protocols)
   exec stream tcp nowait root /usr/sbin/in.rexecd in.rexecd
   exec stream tcp6 nowait root /usr/sbin/in.rexecd in.rexecd
   :
   ```

2. Change the settings of the services.

   Modify `/etc/services` and `/etc/inetd.conf`.

3. Start the services.

   Restart inetd because the ftpd and rexec services are started under the control of inetd.

   Execute either the following command:

   ```
   # kill -HUP `cat /var/run/inetd.pid`
   ```

   Or execute the following:
9.2.1.2.2 On a Linux(Itanium) server

The ftpd and rexec services may not be installed along with the operating system on the Linux server. Therefore, the first step is to determine if their packages are installed. A Linux system may provide tools with a GUI that can be used to configure system settings. Since there are considerable differences between the versions and individual system settings in differing GUI tools, a method for using commands to perform operations is presented below.

1. Check the packages.

   Execute the `rpm` command in the following format to determine if the packages are installed:
   
   ```
   # rpm -query package-name
   ```

   Enter the following package names for ftpd and rexec:
   - `ftpd : vsftpd`
   - `rexec : rsh and rsh-server`

   If the following information is displayed, the packages have been installed, and you can proceed to checking the service status.
   
   ```
   # rpm -query vsftpd
   vsftpd-2.0.1-5
   # rpm -query rsh
   rsh-0.17-17
   # rpm -query rsh-server
   rsh-server0.17-17
   ```

   If the package information is not displayed, one or more packages must be installed.

   **Note**

   The type of ftpd package used for the Linux system depends on the version and distribution. The following may be used:
   - `wu-ftpd`
   - `proftpd`

2. Install packages.

   Execute the `rpm` command to install each package.
   
   ```
   rpm -Uvh package-name
   ```

3. Check the service status.

   Execute the `/sbin/chkconfig` command in the following format to determine if the services are configured to start when the system starts.
   
   ```
   /sbin/chkconfig --list service-name
   ```

   For example, if the following results are obtained, startup of ftpd (vsftpd) and rexec when system starts has been disabled using their respective settings.
   
   ```
   # /sbin/chkconfig --list vsftpd
   vsftpd 0:off 1:off 2:off 3:off 4:off 5:off 6:off
   # /sbin/chkconfig --list rexec
   rexec off
   ```

4. Change the setting for a service as necessary.

   Execute the `/sbin/chkconfig` command in the following format to confirm that the service will start when the system starts:
In the following example, the setting is changed so that the service is started when the system starts, and the changed setting is checked:

```
# /sbin/chkconfig --level 5 vsftpd on
# /sbin/chkconfig --list vsftpd
vsftpd: 0:off 1:off 2:off 3:off 4:off 5:on 6:off
# /sbin/chkconfig rexec on
# /sbin/chkconfig --list rexec
reexec: on
```

5. Start the services.

Execute the `/sbin/service command in the format shown below to start the services. Since the rexec service is started under the control of xinetd, restart xinetd.

```
# /sbin/service vsftpd start
vsftpd start: [ OK ]
# /sbin/service xinetd stop
xinetd stop: [ OK ]
# /sbin/service xinetd start
xinetd start: [ OK ]
```

### 9.2.2 Setting up the user environment on the server

#### 9.2.2.1 On a Solaris server, Linux(64) or Linux(Itanium) server

**For build**

- **PATH**

  Add the following to the PATH environment variable to specify the storage path of the COBOL compile command:

  ```
  $(COB_BASED)/bin
  ```

- **LD_LIBRARY_PATH**

  Add the following to the LD_LIBRARY_PATH environment variable to specify the storage path of the COBOL runtime shared library:

  ```
  $(COB_BASED)/lib
  ```

- **NLSPATH**

  Add the following to the NLSPATH environment variable to specify the storage locations of the messages output at compile time or execution time of COBOL programs:

  ```
  $(COB_BASED)/lib/nls/%L/%N.cat:$(COB_BASED)/lib/nls/C/%N.cat
  ```

- **LANG**

  Specify each character code set that is used by a COBOL program. This specification is used to determine whether COBOL sources contain national characters, and which character sets are used in COBOL sources at compile time.

  For the Solaris and Linux (Itanium) operating systems, C is specified for the LANG environment variable, which identifies the Unicode (UTF8) character code set en_US.UTF-8 used by COBOL programs.

  Dedicated shell scripts provided in the NetCOBOL product on each UNIX system is used to set individual environment variables except LANG. The following table outlines shell scripts for setting the required environment variables for compilation and linkage.

<table>
<thead>
<tr>
<th>NetCOBOL product</th>
<th>Storage location</th>
<th>File name</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Solaris 32bit NetCOBOL</td>
<td>/opt/FJSVcbl/config</td>
<td>cobol.sh</td>
<td>For sh/ksh</td>
</tr>
</tbody>
</table>
Specify the following other environment settings as necessary:

- **COBOLOPTS**
  
  Use this environment variable to commonly and independently specify some compile options from individual programs under development. This is useful for specifying the following:
  
  - Options for COBOL debugging functions
  
  - Options for compilation lists

- **COBCOPY/FORMLIB/FILELIB**
  
  Specify the storage directories of COBOL libraries, screen form descriptors, and file descriptors to be shared by multiple developers.

- **Library names**
  
  Set the library file storage directories in the environment variables whose names are library names specified with IN/OF.

---

**Note**

If the LC_ALL environment variable is required, use the same value as that used in the LANG environment variable.

---

**Examples of shell scripts for setting environment variables**

In the examples shown below, the environment variables are assumed to be set as follows:

- Environment variables related to build
  
  - Environment variables required for compilation and linkage of a COBOL program are set using shell scripts provided by NetCOBOL.
  
  - UTF-8 is the character code set used by programs under development. It is specified in the LANG environment variable.
  
  - The compilation list of COBOL source programs is stored in a common directory.
  
  - The common storage directory of libraries referenced by developers is specified.

On a Solaris server

For remote development using a Solaris server, csh or bash must be used as the login shell. When using csh, you set up the environment by .cshrc that is found in the home directory used by each developer, and add the text shown below.

In the following example, .cshrc is modified for a Solaris server.

```bash
## COBOL environment setting
source /opt/FJSVcbl/config/cobol.csh
## Setting for compilation and link that is common to developers
setenv COBOLOPTS "-dp ../list"
setenv COBCOPY ../COPYLIB:${COBCOPY}
## Character code set used by the program to be developed
setenv LANG en_US.UTF-8
```

When using bash, you set up the environment by .bashrc that is found in the home directory used by each developer, and add the text shown below.

In the following example, .bashrc is modified for a Solaris server.

```bash
## COBOL environment setting
source /opt/FJSVcbl/config/cobol.sh
## Setting for compilation and link that is common to developers
setenv COBOLOPTS "-dp ../list"
setenv COBCOPY ../COPYLIB:${COBCOPY}
## Character code set used by the program to be developed
setenv LANG en_US.UTF-8
```
On a Linux(Itanium) or Linux(64) server

For remote development using a Linux server, csh or bash can be used as the login shell.

To use csh as the login shell, edit .cshrc that is found in the home directory used by each developer, and add the text shown below.

```bash
## COBOL environment setting
source /opt/FJSVcbl/config/cobol.csh
## Setting for compilation and link that is common to developers
setenv COBOLOPTS "-dp ../list"
setenv COBCOPY ../COPYLIB:${COBCOPY}
## Character code set used by the program to be developed
setenv LANG en_US.UTF-8
```

To use bash as the login shell, edit .bashrc that is found in the home directory used by each developer, and add the text shown below.

```bash
## COBOL environment setting
source /opt/FJSVcbl/config/cobol.sh
## Setting for compilation and link that is common to developers
COBOLOPTS="-dp ../list"; export COBOLOPTS
COBCOPY=../COPYLIB:${COBCOPY}; export COBCOPY
## Character code set used by the program to be developed
LANG=en_US.UTF-8; export LANG
```

9.2.2.2 On a Windows server

For remote development using a Windows server, a user account for the server environment is used to perform development work. Unless remote development work is performed with an existing user account, a new user account for remote development work must be created in the server environment. When creating a user account, consult the server administrator.

Generally, to add a local user account to the server machine, log on to the server with an administrator account. Click Start, select Control Panel > System and Security > Administrative Tools > Computer Management. The Computer Management window appears. In the left pane, select Local Users and Groups.

If an additional environment setting must be made for remote development work, add the setting to the environment of the relevant user account.

---

When registering a user account, register it as a member of a user group. Its password cannot be changed while the associated local personal computer is connected to the server. Therefore, when making settings for the user account, do not set a password change while the local personal computer is connected to the server.

---

Notes:

There are two types of environment variables: user environment variables and system environment variables. The user environment variables are generally used. However, for PATH environment variables, the system environment variables are used.

When giving priority to an original path, the COB_RDENV_X64 environment variable is used.

When a file is specified for the COB_RDENV_X64 environment variable, the file is considered to be a batch file.

A NetCOBOL remote build executes the file first by the CALL batch command.
COB_RDENV_X64=C:\MyTools\myenv.bat

Content of "C:\MyTools\myenv.bat"

path C:\MyCommand;%PATH%

As a result, "C:\MyCommand" is given a higher priority than the path of the system environment variable in a remote build.

Windows(64)

The environment variable "PATH" will be set to the folder name of the user account at the installation destination of NetCOBOL. Remote Build is executed in the same environment as the "NetCOBOL command prompt" on the NetCOBOL server side.

9.3 Preparation to connect to the server

To connect to the server, set NetCOBOL Studio as follows.

- Set the server information
- Set the Project setting for remote development

When the ftpd/rexec service is used without using the NetCOBOL remote development service on the server side, a Windows firewall exception message will display.

9.3.1 Setting the NetCOBOL Studio operating environment

The information that is used by each developer’s NetCOBOL Studio for link with the server must be set. These settings are shared among workspaces.

Setting server information

To display the New Server Information dialog box and set server information.

1. On the Window menu, click Preferences. The Preferences dialog box appears.
2. In the left pane, select COBOL > Remote Development. The Remote Development page appears.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server name</td>
<td>Specify an arbitrary name, which will be displayed in Server name on the Remote Development page of the Preferences dialog box. The server name is used to specify the target server of a COBOL project. A server name that is already defined cannot be specified.</td>
</tr>
<tr>
<td>Server OS</td>
<td>Select the operating system of the server.</td>
</tr>
<tr>
<td>Server address</td>
<td>Specify a name (FQDN: Fully Qualified Domain Name) or IP address that identifies the server in the network.</td>
</tr>
<tr>
<td>Save user name and password</td>
<td>Specify whether the user name and password are used to connect the server. If this item is checked, the user name and password specified in this dialog box will be used. If the item is unchecked, the dialog box for Inputting user name and password for connecting to the server appears when the server is initially connected after NetCOBOL Studio is launched. The default setting is unchecked.</td>
</tr>
<tr>
<td>User name</td>
<td>Specify the user name of an account used to access the server.</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Password</strong></td>
<td>Specify the password assigned to the user. If Save user name and password is checked, a &quot;Password&quot; must be specified.</td>
</tr>
<tr>
<td><strong>Character-code conversion</strong></td>
<td>Code conversion information for files is transmitted to and received from the server. Code conversion processing is usually executed by the code conversion function provided in the system.</td>
</tr>
<tr>
<td><strong>COBOL Source character-code on the server side</strong></td>
<td>Select the character-code of the COBOL source file transferred to the server side of remote development.</td>
</tr>
<tr>
<td></td>
<td>The following character-codes can be selected.</td>
</tr>
<tr>
<td></td>
<td>- UTF-8</td>
</tr>
<tr>
<td></td>
<td>- C</td>
</tr>
<tr>
<td><strong>Convert character set in the server</strong></td>
<td>Specify whether the server or the local PC converts code for sending or receiving a text file. The default setting is with &quot;Convert character set in the server&quot; checked.</td>
</tr>
<tr>
<td><strong>Convert character set in the client</strong></td>
<td>If &quot;Windows(x64)&quot; is selected at &quot;Server OS&quot;, this item is disabled.</td>
</tr>
<tr>
<td><strong>Information for UNIX Server system</strong></td>
<td>This information is specified if the selection at &quot;Server OS&quot; is Solaris or Linux(Itanium).</td>
</tr>
<tr>
<td><strong>FTP is used for remote development</strong></td>
<td>When this option is selected, the ftpd/rexec services are used as the remote development server-side services.</td>
</tr>
<tr>
<td><strong>Use PASV mode for file transfer(FTP)</strong></td>
<td>If this item is checked, files are transferred in PASV mode. The server may not be connected when files are transferred to or from an FTP server outside the firewall. For such cases, this item must be checked. The default setting is unchecked.</td>
</tr>
<tr>
<td><strong>NetCOBOL Remote Development Service on server side</strong></td>
<td>This information is for the server-side NetCOBOL remote development service.</td>
</tr>
<tr>
<td><strong>Port number</strong></td>
<td>Specify the TCP/IP port number of the NetCOBOL remote development services. If the port number of the NetCOBOL remote development services has been changed on the server side, adjust this value to the changed port number. The default value is 61999. This option is enabled if remote development uses the server-side NetCOBOL remote development service.</td>
</tr>
<tr>
<td><strong>SSH Port Forwarding</strong></td>
<td>The connection to NetCOBOL remote development services are encrypted. When &quot;Linux(x64)&quot; is selected at &quot;Server OS&quot;, this item is enabled.</td>
</tr>
<tr>
<td><strong>SSH Port number</strong></td>
<td>Specify the SSH Port number. The default value is 22. When “SSH Port Forwarding” is selected, this item is enabled.</td>
</tr>
<tr>
<td><strong>SSH Server FingerPrint</strong></td>
<td>Specify the FingerPrint by hexadecimal digit string.</td>
</tr>
<tr>
<td></td>
<td>Ask the server administrator about the value.</td>
</tr>
<tr>
<td></td>
<td>When “SSH Port Forwarding” is selected, this item is enabled.</td>
</tr>
<tr>
<td><strong>Algorithm</strong></td>
<td>Specify the algorithm of SSH Server FingerPrint (either sha1 or md5).</td>
</tr>
<tr>
<td></td>
<td>Ask the server administrator about the value. The default value is md5.</td>
</tr>
</tbody>
</table>
When “SSH Port Forwarding” is selected, this item is enabled.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connection test</td>
<td>The server is connected using the current set values when this button is clicked, and the connection results are displayed in the Connection test dialog box.</td>
</tr>
</tbody>
</table>

Verifying a connection to the server

The server is connected using the values specified in the New Server Information or Modify Server Information dialog box of server information when the Connection test button is clicked. The results are displayed in the Connection test dialog box. When a connection is successfully established, the information set for the server environment variables is displayed. If the connection attempt fails, error information is displayed.

Inputting user name and password for connecting to the server

If Save user name and password is not checked in the New Server Information or Modify Server Information dialog box of server information, the dialog box for specifying a user name and password appears when the server is initially connected after NetCOBOL Studio is launched. The user name and password are used to connect the server.

Changing server information

To display the Modify Server Information dialog box and change server information:

1. On the Window menu, click Preferences. The Preferences dialog box appears.
2. In the left pane, select COBOL > Remote Development. The Remote Development page appears.
3. In the Server name list, select the name of the server whose information is to be changed, and then click Modify. The Modify Server Information dialog box appears.

Deleting server information

To delete server information:

1. On the Window menu, click Preferences. The Preferences dialog box appears.
2. In the left pane, select COBOL > Remote Development. The Remote Development page appears.
3. In the Server name list, select the name of the server whose information is to be deleted, and then click Delete. The server information is deleted.

9.3.2 Setting server information for a COBOL project

No server information for remote development is set for newly created COBOL projects, so the remote development function cannot be used.

To set information for remote development of the COBOL project:

1. In the Dependency view or Structure view, select the project.
2. Select Property... from the context menu. The property dialog box appears.
3. In the left pane, select Remote Development. The Remote Development page appears.

Table 9.2 Remote Development page

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable project specific setting</td>
<td>When the “Enable project specific setting” checkbox is unchecked, the options that were specified in each COBOL project are disabled.</td>
</tr>
<tr>
<td>Enable remote development</td>
<td>If this project is for remote development, this item must be checked. If no server information is set, this item is disabled. The default setting is unchecked.</td>
</tr>
</tbody>
</table>
### Item Description

**Server name**
Specify the name of the server that is the target of this project. A list of server names can be displayed by selecting COBOL > Remote Development in the Preferences dialog box. If "Enable remote development" is unchecked or no server name is defined, this item is disabled.

**Server directory**
Specify the full path name of the folder of server resources. The makefile creation function and build function use this folder as the current folder to execute their processing.

- If Solaris, Linux(Itanium) or Linux(64) is the operating system of the server, the root folder cannot be specified.
- If Windows is the operating system of the server, the location immediately under a drive name cannot be specified.

The server folder can be referenced by clicking the Browse... button.

If "Enable remote development" is unchecked or no server name is defined, this item is disabled.

**Make subdirectory**
If the COBOL source file, screen form descriptor file, or COBOL library file are stored under the subfolder of project folder, when Make subdirectory check box is selected, a subdirectory (*) is made under the directory specified in Server directory. And then, these files are sent from the subfolder to the subdirectory.

*: The subdirectory name is the same as the subfolder name where the COBOL source file, screen form descriptor file, and COBOL library file are stored.

---

**Note**
If the directory that is specified in Server directory is not found on the server, it is created at the makefile creation time.

The directory that is specified in Server directory must be unique to each COBOL project on a local personal computer. If multiple COBOL projects share one such directory on the server, makefiles is not executed correctly.

### 9.3.3 Exception registration of Windows firewall

If Windows Firewall, the remote development function cannot be used. To prevent this problem, change settings so that Windows Firewall does not check the program outlined in the following table.

<table>
<thead>
<tr>
<th>Program name</th>
<th>Storage folder</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>COBRDC32.exe</td>
<td>NetCOBOL installation folder</td>
<td>Remote debugger connector</td>
</tr>
</tbody>
</table>

To register COBRDC32.exe as an exception:
1. Click Start, select Control Panel > System and Security > Allow an app through Windows Firewall.
2. Click the Change settings button, and then click the Allow another app button in the Allowed apps window.
3. Click the Browse button in the Add an app dialog box.
4. Select COBRDC32.exe and click the Open button in the NetCOBOL installation folder in the Browse dialog box.
5. Click the Add button in the Add an app dialog box, and then click the OK button in the Allowed apps window.

### Changing the scope

To change the scope:
1. In the Windows Firewall setting window, click the Advanced settings tab.
2. Click the **Inbound Rules** button in **Windows Firewall with Advanced Security** dialog box. Select the program whose scope is changed, and then select **Properties** menu from the context menu.

3. In the **Scope** tab of properties dialog box, select the "These IP addresses", and then click the **Add** button.

4. Enter the IP address, and then click the **OK** button in the **IP address** dialog box.

5. Check the IP address is displayed in the **These IP addresses** window, and then click **OK** in the properties dialog box.

**On a Linux (Itanium) server**

In the event that there is a connection to a Linux server and the Windows firewall is enabled, and the ftpd/rexec service is utilized instead of the server-side NetCOBOL remote development service, the linkage to the Linux server might exhibit extremely slow processing time. To alleviate this, follow the procedure below to register port 113 as an exception.

1. In the Windows Firewall setting window, click the **Advanced settings** tab.

2. Click the **Inbound Rules** button in **Windows Firewall with Advanced Security** dialog box. Click the "New Rule" in the **Actions** menu list.

3. Select the "Port", and then click the **Next** button in the **New Inbound Rule Wizard**.

4. In the **Protocol and Ports** page, select the "TCP" and the "Specific local ports", and then enter "113". Click the **Next** button.

5. Select the "Allow the connection", and click the **Next** button. Set the remaining items following instructions of the wizard.

**9.4 Creating a makefile and Sending resources**

A makefile is required for build processing executed on the server in remote build. This makefile can be created using the makefile creation function.

**9.4.1 Creating a makefile**

To create a makefile:

1. In the Dependency view or Structure view, select the project.

2. On the **Project** menu, click **Remote Development > Makefile Creation**. Or select **Remote Development > Makefile Creation** from the context menu. The **Makefile Creation** dialog box appears.

3. Makefile creation conditions are displayed in "Create Condition" in the **Makefile Creation** dialog box. To create a makefile, under "Create Condition" displayed, click the **OK** button. To change the "Create Condition" displayed, click the **Option setting** button and change the contents of "Create Condition".

The created makefile is named "Makefile", and it is stored on both the server and the local personal computer. The makefile on the local personal computer is registered in the Other Files folder of the COBOL project. The makefile on the server is stored in the Server directory as specified on the **Remote Development** page of project properties.

**Point**

Makefile creation processing is executed on the server. The results of execution on the server can be reviewed by selecting "COBOL Remote" from an icon (Open Console) on the toolbar in the Console view.

**Note**

In Makefile creation, files(*) with the following extensions are treated as COBOL source files.

- When File Content is not set
  
  .cob, .cobol

- When File Content is set

  Extension associated with COBOL source file in File Content
9.4.2 Changing makefile creation conditions

The following makefile creation conditions, displayed in the Makefile Creation dialog box, can be changed:

- TARGET names
- Precompiler options
- Compile options
- Link options

To change these conditions, click the "Option" setting button in the Makefile Creation dialog box. The Option setting dialog box appears, and the creation conditions of the TARGET names, compile options, and link options at makefile creation can be changed.

9.4.3 Makefile Creation dialog box

- Target Name
  The name of an executable file or dynamic link library (shared library) that is a TARGET of the makefile is displayed.

- Send files
  A list of files to be transferred to the server when the makefile is created is displayed. Files are displayed by file type as follows:
  - COBOL source files
  - COBOL libraries and descriptor files
  - Precompiler input sources

- Compile Options
  Compile options that are used in the makefile at compile time of a COBOL source are displayed.

- Link options
  Link options that are used in the makefile during linkage of a COBOL source are displayed.

- Precompiler link
  If precompiler link is used, the following precompiler information is displayed:
  - Extensions of precompiler input sources
  - Extensions of precompiler output sources
  - Precompiler command name and parameters
  - Indication of whether to display error messages of the COBOL compiler with the line numbers of lines in precompiler input sources

Values in the Makefile Creation dialog box

Values displayed for Create Condition in the Makefile Creation dialog box vary according to whether the first makefile is being created or the second or subsequent makefile is being created:

First makefile is being created

The values set on the Target, Build and Precompiler page of project properties are referenced. However, the information set on the Build page will be partially modified. The tabs on the Build page are as follows:

- Compiler Options tab
  - A copy of the information is created for compile options that have formats that are common to the systems.
  - Specifications for compile options not supported by the operating system of the server are ignored.
- **Library Names** tab
  
The values specified in the **Library Names** tab are not reflected in the makefile. Set the library file storage folder in the server-side environment variables whose names are library names specified with IN/OF.

⚠️ **Note**

When the server side is Windows (x64), the library file storage folder is defined in the COB_library-name environment variable.

- **Linker Options** tab
  
  - The storage paths and names of the object files and library files provided by NetCOBOL are replaced with the storage paths and names of files provided by the server-side NetCOBOL.
  
  - The following applies to object and library files not provided by NetCOBOL:
    - If the server operating system is Windows(x64), a copy of the information is created.
    - If the server operating system is Solaris or Linux, information for the object files and library files is deleted.

**Second or subsequent makefile is being created**

The values used for the previous makefile are used for second and subsequent makefiles.

### 9.4.4 Option Setting dialog box

#### 9.4.4.1 TARGET tab

TARGET names can be changed by clicking the **Target** tab in the **Option setting** dialog box.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target Name</td>
<td>Specifies a TARGET name.</td>
</tr>
<tr>
<td>Initialize</td>
<td>Changes the values to the ones specified on the <strong>Target</strong> page of project properties.</td>
</tr>
</tbody>
</table>

⚠️ **Note**

The types of executable files and dynamic link libraries (shared libraries) become the values selected for **Target type** on the **Target** page of project properties. To change TARGET types, change the values selected for **Target type** on the **Target** page of project properties.

#### 9.4.4.2 Precompiler tab

Precompiler settings can be changed by clicking the **Precompiler** tab in the **Option setting** dialog box.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Precompiler</td>
<td>Select this item to create precompiler link information in the makefile for the COBOL project.</td>
</tr>
<tr>
<td></td>
<td>When using the precompiler, first add the precompiler build tool and set precompiler link information for the project properties.</td>
</tr>
<tr>
<td></td>
<td>If the precompiler build tool is not suitable for the project, makefile could not be created correctly.</td>
</tr>
<tr>
<td></td>
<td>If not selected, precompiler link information is not created in the makefile even though the information is set.</td>
</tr>
<tr>
<td></td>
<td>For details about the precompiler setting method, refer to &quot;6.2.3 Creating a COBOL program by using the precompiler&quot;.</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Precompiler command</td>
<td>Specifies the name of the command that starts the precompiler.</td>
</tr>
<tr>
<td>Precompiler parameters</td>
<td>Specifies the precompiler command parameters.</td>
</tr>
<tr>
<td>Precompiler source extension</td>
<td>Specifies the extension of the input source file for the precompiler. The</td>
</tr>
<tr>
<td></td>
<td>following extensions cannot be specified:</td>
</tr>
<tr>
<td></td>
<td>- cobol</td>
</tr>
<tr>
<td></td>
<td>- cob</td>
</tr>
<tr>
<td></td>
<td>- cbl</td>
</tr>
<tr>
<td></td>
<td>- lcai</td>
</tr>
<tr>
<td></td>
<td>- Extension associated with COBOL source file in File Content</td>
</tr>
<tr>
<td>Precompiler output source extension</td>
<td>Specifies the extension of an output source file for the precompiler.</td>
</tr>
<tr>
<td>Use original source line numbers</td>
<td>If this item is checked, COBOL compiler error messages are displayed using</td>
</tr>
<tr>
<td>for error messages</td>
<td>the line number in the original source, rather than the line number of the</td>
</tr>
<tr>
<td></td>
<td>preprocessed source. (The INSDBINF command is invoked.) The default</td>
</tr>
<tr>
<td></td>
<td>setting is unchecked.</td>
</tr>
<tr>
<td>INSDBINF parameters</td>
<td>This item sets the parameters of the INSDBINF command (*), which develops</td>
</tr>
<tr>
<td></td>
<td>line information for the precompiler input source in COBOL source files</td>
</tr>
<tr>
<td></td>
<td>generated by precompilation. Note that input and output source file names</td>
</tr>
<tr>
<td></td>
<td>cannot be specified because they are determined from precompiler input source</td>
</tr>
<tr>
<td></td>
<td>file names.</td>
</tr>
<tr>
<td>Initialize</td>
<td>Changes the values to those specified in the precompiler link information on</td>
</tr>
<tr>
<td></td>
<td>the preferences Precompiler page.</td>
</tr>
</tbody>
</table>

*: For the INSDBINF command, refer to "6.2.2 INSDBINF command".

For more information about precompiler link information, see "6.2.1 Setting and changing initial values of precompiler link information"

Note

".cobol" cannot be specified as the extension of the precompiler output source if the server side NetCOBOL is listed below.
- Solaris 32bit NetCOBOL or Linux(Itanium) 64bit NetCOBOL
- V9.1 or before

9.4.4.3 Compiler Options tab

Compile options can be changed by clicking the Compiler Options tab in the Option setting dialog box.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compiler Options</td>
<td>Displays the compile options used in the makefile at COBOL source compile</td>
</tr>
<tr>
<td>Add</td>
<td>Adds the compile options. To add compile options, select the compile options</td>
</tr>
<tr>
<td></td>
<td>to add in Compiler Options in the Add Compiler Options dialog box, and</td>
</tr>
<tr>
<td></td>
<td>click the Add button.</td>
</tr>
<tr>
<td>Change</td>
<td>Changes the compile options selected in Compiler Options.</td>
</tr>
<tr>
<td>Remove</td>
<td>Deletes the compile options selected in Compiler Options.</td>
</tr>
</tbody>
</table>
### Initialize
Changes the values to the ones specified on the Compiler Options tab on the project properties Build page.

### Specify other compiler options
Specifies the compile options that cannot be added from the Compiler options dialog box.

---

#### Compile options that cannot be used during remote development

When the server side is Solaris, the following compiler option cannot be used.

- **ASCOMP5 compiler option**
  
  When the server side is the following, the following compiler option can be used. When the server side is Solaris the following compiler option cannot be used.
  
  - Windows 64bit NetCOBOL V11.0 or later

- **ENCODE compiler option**
  
  When the server side is the following, this compiler option can be used.
  
  - Windows 64bit NetCOBOL V11.0 or later
  - Linux 64bit NetCOBOL V11.0 or later

- **CONVCHAR compiler option**
  
  When the server side is the following, this compiler option can be used.
  
  - Linux 64bit NetCOBOL V11.0 or later

#### Compile options specific to remote development

Some compile options specific to remote development are accessed in the Option setting dialog box Compiler Options tab.

The following table lists the compile options that are specific to remote development and specifies whether or not these compile options can be used with particular target operating systems.

<table>
<thead>
<tr>
<th>Compile options</th>
<th>Solaris</th>
<th>Linux</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>64</td>
<td>64</td>
<td></td>
</tr>
<tr>
<td>CODECHK</td>
<td>Y</td>
<td>Y</td>
<td>N</td>
</tr>
<tr>
<td>KANA</td>
<td>Y</td>
<td>Y</td>
<td>N</td>
</tr>
<tr>
<td>LALIGN</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
</tr>
</tbody>
</table>

Y: Can be used.

N: Cannot be used.

Details of the compile options specific to remote development are as follows:

##### CODECHK compile option

This option specifies whether to perform a compile-time check of the national language code system at execution time (CODECHK) or not (NOCODECHK). When creating a program that does not depend on the national language code system (program common to ASCII, EUC, and Unicode), specify NOCODECHK.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>National language code system check at execution time</td>
<td>Specifies whether to perform a compile-time check of the national language code system at execution time. The default is CODECHK.</td>
</tr>
<tr>
<td>CODECHK</td>
<td>Performs a compile-time check of the national language code system at execution time.</td>
</tr>
</tbody>
</table>
**NOCODECHK**

Does not perform a compile-time check of the national language code system at execution time.

**KANA compile option**

This option specifies the code sets for kana characters in non-numeric literals, alphabetic and alphanumeric data items.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>KANA character code processing</td>
<td>Specifies how to process the kana character code set. The default is KANA(EUC).</td>
</tr>
<tr>
<td>KANA(EUC)</td>
<td>Two-byte codes (EUC) are used for kana character codes.</td>
</tr>
<tr>
<td>KANA(JIS8)</td>
<td>One-byte codes (JIS) are used for kana character codes.</td>
</tr>
</tbody>
</table>

**LALIGN compile option**

This option specifies whether to generate objects based on an assumption that data is aligned on an eight-byte boundary (LALIGN) or not (NOLALIGN) when data declared in the linkage section is referenced. The data processing speed is faster when objects are generated based on an assumption that data is aligned on an eight-byte boundary.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processing of data declared in LINKAGE SECTION</td>
<td>Specifies how to process data declaration in the linkage section. The default is NOLALIGN.</td>
</tr>
<tr>
<td>NOLALIGN</td>
<td>Does not assume that data is aligned on an eight-byte boundary.</td>
</tr>
<tr>
<td>LALIGN</td>
<td>Assumes that data is aligned on an eight-byte boundary.</td>
</tr>
</tbody>
</table>

**Compile option with different specification format during remote development**

- **RCS compile option**

  When the server side is Solaris, this compiler option cannot be used.

  When the server side is Linux (itanium), this compiler option has different specification formats for the local personal computer environment.

  When the server side is Linux(x64) or Windows(x64), this compiler option can be used in the same specification formats as the local personal computer environment.

**RCS compile option**

The RCS compile option has different specification formats for the local personal computer environment and the Linux (Itanium) environment. The following information pertains to the dialog box that appears when the server operating system is Linux (Itanium). The encoding form of national items in a Unicode environment is UTF-16.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Encoding of national items with Unicode environment</td>
<td>Specifies an endian of UTF-16. The default is LE (little-endian).</td>
</tr>
<tr>
<td>BE</td>
<td>Specifies big-endian as the endian of UTF-16.</td>
</tr>
<tr>
<td>LE</td>
<td>Specifies little-endian as the endian of UTF-16.</td>
</tr>
</tbody>
</table>
9.4.4.4 Library Name tab

The values specified in the Library Name tab of the Build page of project properties can be referenced by selecting the Library Name tab in the Option setting dialog box. The values specified on the Library Name tab are not reflected in the makefile. Specify the library file storage folder in the server-side environment variables with library names specified with IN/OF.

Note

When the server side is Windows (x64), the library file storage folder is defined in the COB_library-name environment variable.

9.4.4.5 Linker Options1 tab, Linker Options2 tab

Link options are configured on the two tabs in the Option setting dialog box as follows:

- **Linker Options1 tab**
  Libraries and object files can be specified to be linked with COBOL programs on the server side.

- **Linker Options2 tab**
  Link options specific to the operating system of the server can be specified.

Changing the libraries and object files to be linked

The libraries and object files to be linked on the server side can be changed by selecting the Linker Options1 tab in the Option setting dialog box.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Adds libraries or object files to those to be linked with a COBOL program. The Add Linker Option dialog box appears when the Add button is clicked. The added libraries and object files are displayed in &quot;Select library or object&quot;. One or more libraries or object files can be added.</td>
</tr>
<tr>
<td>Change</td>
<td>Changes the specification of the library or object file selected in &quot;Select library or object&quot;. The Modify Linker Option dialog box appears when the Change button is clicked.</td>
</tr>
<tr>
<td>Remove</td>
<td>Deletes the libraries and object files selected in &quot;Linker options&quot;.</td>
</tr>
<tr>
<td>Remove All</td>
<td>Deletes all of the libraries and object files in Linker options.</td>
</tr>
</tbody>
</table>
| C Run-time Library Name     | Specify the file name of the C run-time library to be linked. This option is enabled if the server OS is Windows(x64). If the C run-time library name is omitted, "LIBCMT.lib" is linked. In the following cases, specify "MSVCRT.lib."
  - When two or more DLLs execute in one process.
  - The called C program is created with Microsoft Visual C++ and compiled with /MD option.
  For details of the C run-time libraries linkage, refer to "NetCOBOL User's Guide." |
| COBOL Entry Object          | Specify whether only object files created in COBOL are used to create the dynamic link library, or whether object files created in other languages are also used to create it. This option is enabled if the server OS is Windows(x64). |
| Link COBOL program only     | The dynamic link library is created using only object files created in COBOL.                    |
| Other                       | Object files created in other languages are also used to create the dynamic link library.         |
| Initialize                  | The item is initialized by the value specified on the build page of the property of the project.  |

Adding and changing libraries and object files

The Add Linker Option dialog box appears when the Add or Change button on the Linker Options1 tab in the Option setting dialog box is clicked. A library or object file can be added or changed from this dialog box. ‘Linker options ’ specifies the name of the library or object
file to be added or changed. The absolute path name or relative path name of the library or object file is specified. The file name itself cannot be specified alone. The dialog box for referencing server-side files appears when the **Browse** button is clicked, and a library or object file can then be selected.

### Changing link options specific to the operating system of the server

Link options specific to the operating system of the server can be changed by selecting the **Linker Options2** tab in the **Option setting** dialog box. For details on server-side link options, see the NetCOBOL User’s Guide on the server side.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linkage mode</td>
<td>Specify a linkage mode. The default is Dynamic linkage[-dy]. This option is valid only if the server operating system is Solaris OS, Linux(64) or Linux(Itanium).</td>
</tr>
<tr>
<td>Dynamic linkage[-dy]</td>
<td>Creates a COBOL program through dynamic linkage.</td>
</tr>
<tr>
<td>Static linkage[-dn]</td>
<td>Creates a COBOL program through static linkage.</td>
</tr>
<tr>
<td>Use screen form descriptor</td>
<td>Used to select whether the linked program uses a screen form descriptor. This item defaults to unchecked. This option is valid only if the server operating system is Solaris.</td>
</tr>
<tr>
<td>Use screen handling function</td>
<td>Used to select whether the linked program performs screen handling. This item defaults to unchecked. This option is valid only if the server operating system is Solaris.</td>
</tr>
<tr>
<td>Use C-ISAM</td>
<td>Used to select whether the linked program uses C-ISAM. This item defaults to unchecked. This option is valid only if the server operating system is Solaris.</td>
</tr>
<tr>
<td>Program invoked from C</td>
<td>Used to select whether the linked program is invoked by coding in the C language. This item defaults to unchecked. This option is valid only if the server operating system is Solaris.</td>
</tr>
<tr>
<td>Use C functions</td>
<td>Used to select whether the TARGET type is a dynamic link library and the TARGET uses the C functions. This item defaults to unchecked. This option is valid only if the server operating system is Windows(x64).</td>
</tr>
<tr>
<td>Output debug information</td>
<td>Used to select whether to output debug information to the program data base file (PDB). This item defaults to check. This option is valid only if the server operating system is Windows(x64).</td>
</tr>
<tr>
<td>Link Option[-WI]</td>
<td>Specifies the link options used by the ld command. This option is valid only if the server operating system is Solaris, Linux(64) or Linux(Itanium)</td>
</tr>
</tbody>
</table>

**Note**

If “THREAD (MULTI)” is specified on the project properties **Build** page **Compiler Options** tab, the -Tm option, which is used for linking a multithread model program, is automatically set.

### 9.4.5 Editing a makefile

A created makefile can usually be used for a build on the server side without any modification. However, the makefile can be edited.

- Editing a makefile on the local personal computer:
  - The edited makefile is automatically sent to the server before it is used for a Build or a Rebuild,
- Editing a makefile on the server:
  - During creation of another makefile, a confirmation message asks if you want to replace the edited makefile on the server with the makefile being created. If “No”, makefile creation is canceled.

### 9.4.6 Creating another makefile

Even if the organization of a COBOL project is changed, another makefile is not automatically created. When performing any of the following operations and changing components of a COBOL project, create another makefile:

- Adding or renaming a COBOL source file registered in the **Source Files** folder, or deleting such a file from the folder.
Adding or renaming a library file, descriptor file, or repository file registered in the Dependent Files folder, or deleting such a file from the folder.

- Adding a file to the Linking Files folder, deleting one from the folder, or renaming one in the folder.
- Adding or changing precompiler link information.

Follow the procedure below to create another makefile.

1. Select a project in the Dependency view or Structure view.
2. Select Project > Remote Development > Makefile Creation... from the menu bar, or select Remote Development > Makefile Creation... from the context menu.

The same values used for TARGET names, precompiler link information, compile options, and link options when the last makefile was created are used to create another makefile. To change the values for the current makefile, create another makefile and then change those values.

9.4.7 Sending resources

9.4.7.1 COBOL project

To create a makefile, files that are managed in the following folders of a COBOL project are required on the server side:

- COBOL source files and precompiler input sources registered in Source Files folder
- COBOL library files and descriptor files registered in "Dependent Files" folder

These files are automatically sent to the server when a makefile is created. The names of the files sent to the server when a makefile is created are displayed in "Create Condition" in the Makefile Creation dialog box.

Note

- Files with the following extension are treated as a COBOL source file. These files are sent to the server.
  - When File Content is not set
    .cob, .cobol
  - When File Content is set
    Extension associated with COBOL source file in File Content

- Of the COBOL library files and descriptor files registered in the "Dependent Files" folder, only those in the project are sent. COBOL library files and descriptor files that are in other projects or managed in other folders are not sent.

Files with the following extension are treated as a COBOL library file. These files are sent to the server.

- When File Content is not set
  .cbl
- When File Content is set
  Extension(*) associated with COBOL library file in File Content
  *: The library files with the extension .cobol are not sent to the server.

9.4.7.2 COBOL resource project

Use the following procedures to transfer the resource included in the COBOL resource project.

1. In the Dependency view or Structure view, select the COBOL resource project.

2. On the Project menu, click Remote Development > Transfer.... Or select Remote Development > Transfer... from the context menu.

The server information and files to be transferred are displayed.

3. Click OK. The file is transferred.
9.5 Remote Build

A COBOL program that operates on the server can be created by executing a remote build for compilation and linkage on the server. Use a makefile created by the makefile creation function for compilation and linkage.

9.5.1 Executing a build

To execute a remote build:

1. In the Dependency view or Structure view, select a project.
2. On the Project menu, click Remote Development > Build. Or select Remote Development > Build from the context menu.

In remote build, only those resources that have been changed since the last build are the target. To build all resources regardless of whether changes have been made since the last build, use the following method:

1. To execute a rebuild for a project, in the Dependency view or Structure view, select the project.

Point

Compilation errors are displayed in the Problems view. The execution results of a remote build on the server can be viewed by clicking the Open Console icon on the toolbar in the Console view, and selecting "COBOL Remote".

9.5.2 Setting a build mode

A COBOL program that is created with remote target can be built as a release version or as a debug version by setting the proper build mode.

To change a build mode:

1. In the Dependency view or Structure view, select the project.
2. On the Project menu, click Remote Development > Build Debug mode. Or select Remote Development > Build Debug mode from the context menu. If "Build Debug" mode is selected, a debug version is created. Otherwise, a release version is created.

The release or debug state of each program that has been built is stored in the project.

Note

Even if "Do not generate DEBUG information" is specified for the TEST compile option to build the target as a debug version, the build is executed as though "Generate WINSVD DEBUG information" were specified.

9.5.3 Transfer of resources

Any files that are managed in the following folders of a COBOL project and that have been updated since the last remote build are automatically sent to the server prior to the next remote build:

- COBOL source files and precompiler input sources registered in the Source Files folder
- COBOL library files and descriptor files registered in the Dependent Files folder

Note

- Files with the following extension are treated as a COBOL source file. These files are sent to the server.
  - When File Content is not set
    - .cob, .cobol
9.5.4 Correcting compilation errors

Compilation error information for a remote build is displayed in the Problems view. To edit COBOL source files containing compilation errors on the local personal computer side, double-click the compilation error information in the Problems view or select Go To from the context menu. The relevant COBOL source file is opened with the editor, and the current line contains the compilation error. If the COBOL source file is already open in the editor, the line containing the compilation error becomes the current line. When modification of the errors is completed, execute a remote build. The corrected files are automatically sent to the server, and the build is executed.

- Point

Error information detected by the precompiler is not displayed in the Problems view. Error information can be checked from the Console view toolbar icon (Open Console) by selecting “COBOL Remote”.

9.6 Remote Debugging

A COBOL program that has been built on the server is debugged with the remote debug function. This section explains how to start remote debugging, and provides an overview of the remote debugger connector.

The following two methods can be used to start debugging:

- Normal Debug
  In this method, the remote debugger is called from the local personal computer to start debugging. The remote debugger connector must be started on the server in advance.

- Attach Debug
  In this method, the remote debugger is called from a COBOL program that runs on the server. This start method is used for debugging a COBOL application that runs in an Interstage Application Server environment, on a Web server, or in another environment.

- Point

Other debuggers (e.g., COBOL, Java) cannot be started while debugging a COBOL program.

9.6.1 Normal Debug

This section explains the procedures for starting normal debugging, including starting the remote debugger connector on the server, and starting the remote debugger.
9.6.1.1 Starting the remote debugger connector on the server

To perform remote debugging, the remote debugger connector, which monitors instructions from the debugger on a client, must be started on the server first. Start the remote debugger connector from the server-side "NetCOBOL Command Prompt".

Use the following command format to start the remote debugger connector on the server.

<table>
<thead>
<tr>
<th>Server</th>
<th>Start command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows (64)</td>
<td>cobrds64 [ [ port-specification] [connection-limitation-specification] ]</td>
</tr>
<tr>
<td>Solaris</td>
<td>svdrds [ [ port-specification] [connection-limitation-specification] ]</td>
</tr>
<tr>
<td>Linux (Itanium)</td>
<td></td>
</tr>
<tr>
<td>Linux (64)</td>
<td></td>
</tr>
</tbody>
</table>

- **Port Format:**

  `[-p port number]`

  For the port number, specify the same value detailed in NetCOBOL Studio Starting the remote debugger.

  Specify a port number in the range 1024 to 65535. If omitted, it defaults to 59998.

- **Connect restriction format:**

  `[-h host name | -s connect restriction file name [ -e ]]`

  - **-h host name**
    Specify a host name or an IP address to allow connection.

  - **-s connect restriction file name**
    Specify the connect restriction file.

  - **-e**
    The processing result of the contents of the specified connect restriction file are displayed.

- If `s` and `-h` are both omitted, connection will be allowed from all computers.

- After the remote debugger connector is started, the IP address and port number are displayed, and orders from the client to start debugging are monitored.

---

**Note**

- If you have to specify an environment variable for the program you want to debug, set this before you start the remote debugger connector.

- If you have to start each program that you want to debug in a different environment, you have to run the remote debugger connector in each environment. Like the environment variable, the environment here determines the operation when the remote debugger connector is started, and its settings cannot be modified later.

- Since the remote debugger connector on the server does not exit automatically when the debugger exits, end the connection when remote debugging ends. To end the remote debugger connection on the server, press the Ctrl + C keys in the command input window from which the remote debugger connection was started.

- If you have to start each program that you want to debug in a different environment, or if several developers debug at the same time, specify `-p` when the remote debugger connector starts, and then use a different port.

---

**Example**

Examples of starting the Windows(64) server remote debugger connector
- Several developers debug at the same time

```
  cobrds64  -p 10001  -h client-1
  cobrds64  -p 10002  -h client-2
  cobrds64  -p 10003  -h client-3
```

- This is the case when three developers use the remote debugger at the same time.
- Choose the port number to be used by each developer and specify this using \(-p\).
- Specify \(-h\) to accept only the specific computer's request for remote debugging and to reject incorrect connections by other developers.

**Format of the connect restriction file**

Specify the format of the connect restriction file as shown below:

```
[ ALLOW={ ALL | connection-target [connection-target ...] } ]
[ DENY={ ALL | connection-target [connection-target ...] } ]
```

- This allows connection from the connection target specified in ALLOW. If this is omitted, it is assumed that ALL has been specified.
- This denies connection from the connection target specified in DENY. If this is omitted, it is assumed that ALL has been specified.
- If you specify ALLOW, connection is allowed or denied from all computers.
- If ALLOW and DENY are both specified, and ALLOW is described, ALLOW has priority.
- If this is register on several lines, write \("\) at the end of the line.

**Example**

```
ALLOW=192.168.0.1 192.168.0.3 \n192.168.0.8-192.168.0.10
```

The connection target format is shown below.

**Table 9.3 Connection target format (IPv4)**

<table>
<thead>
<tr>
<th>Format</th>
<th>Example</th>
<th>Example of IP address application range</th>
</tr>
</thead>
<tbody>
<tr>
<td>IP address</td>
<td>192.168.0.1</td>
<td>192.168.0.1</td>
</tr>
<tr>
<td>Range</td>
<td>192.168.0.1-192.168.0.10</td>
<td>192.168.0.1 to 192.168.0.10</td>
</tr>
<tr>
<td>Wildcard (*1)</td>
<td>192.168.0.*</td>
<td>192.168.0.0 to 192.168.0.255</td>
</tr>
<tr>
<td>Host name (*2)</td>
<td>Hostname</td>
<td>192.168.0.1</td>
</tr>
</tbody>
</table>

*1: You can specify "*" instead of the decimal parts (8-bit) delimited by "."

*2: This example assumes that a host name called "Hostname" has been assigned for an IP address of 192.168.0.1.

**Table 9.4 Connection target format (IPv6)**

<table>
<thead>
<tr>
<th>Format</th>
<th>Example</th>
<th>Example of IP address application range</th>
</tr>
</thead>
<tbody>
<tr>
<td>IP address</td>
<td>fe80::1:23:456:789a</td>
<td>fe80::1:23:456:789a</td>
</tr>
<tr>
<td>Wildcard (*3)</td>
<td>fe80::1:23:*:789a</td>
<td>fe80::1:23:0:789a to fe80::1:23:ffff:789a</td>
</tr>
<tr>
<td>Host name (*4)</td>
<td>Hostname</td>
<td>fe80::1:23:456:789a</td>
</tr>
</tbody>
</table>

*3: You can specify "*" instead of the hexadecimal parts (16-bit) delimited by ":"

*4: This example assumes that a host name called "Hostname" has been assigned for an IP address of fe80::1:23:456:789a.
Note

If there is an error in the contents of the connect restriction file, the specified details will be invalid, and connection will be allowed from all computers.

Windows firewall

If the server-side OS is Windows(x64), the remote debugger connector cannot be used if the "Windows firewall" is enabled. Therefore, use the "9.3.3 Exception registration of Windows firewall" to register "cobrrds64.exe" as a Windows firewall check exception:

9.6.1.2 Starting the remote debugger

To start the remote debugger:

1. In the Dependency view or Structure view, select a COBOL project
2. On the Run menu, click Debug Configurations.... Or click of on the toolbar, select Debug Configurations.... The Debug Configurations dialog box appears.
3. In the left pane, select Remote COBOL Application.
4. In the left pane, click . The startup configuration settings page appears.
5. In the Name field, the default startup configuration name is displayed. The startup configuration name can be changed.
6. On the Main tab, check each setting item, and change it as necessary.

<table>
<thead>
<tr>
<th>item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>The selected project name is displayed.</td>
</tr>
<tr>
<td>Debug Style</td>
<td>Select Normal Debug.</td>
</tr>
<tr>
<td>Server name</td>
<td>The server name that is set in the project properties is displayed.</td>
</tr>
<tr>
<td>Port number</td>
<td>Specify the port number used for communication with the server during debugging. Specify the same port number as that specified when the remote debugger connector started on the server. The initial setting value of the remote debugger connector on the server is 59998.</td>
</tr>
</tbody>
</table>
| Executable file | Specify the executable file to be debugged. The initial setting value is either of the following, depending on whether there is a makefile:  
- With a created makefile: Target name specified in the makefile  
- Without a created makefile: Target name of the project  
If the debug target is a dynamic link library, specify the target file. |
| Workspace Directory | Specify the work directory of the application to be debugged. The initial setting value is the directory of the executable file. |
| Argument(s)     | Specify program arguments in the format used for the command line interface. |

7. Start debugging by selecting "Debug". Once debugging is started with a particular configuration, the startup configuration is registered as a shortcut in the toolbar and you can restart debugging by selecting Run > Debug History or using the shortcut.

Note

If no information for remote development is set in the project, "Normal Debug" cannot be selected for "Debug Style".
9.6.2 Attach Debug

The remote debugger can be used for attachment-type remote debugging. In the attach format, once the remote debugger is started on the local PC, it stays in the standby state until a COBOL application is executed on the server. Remote debugging is started when a COBOL application is executed and the environment variable for requesting the start of attachment debugging has been set on the server.

Note

When multiple NetCOBOL Studio is in a standby state of attached debugging, attached debugging is not supported.

9.6.2.1 Starting the remote debugger

1. In the Dependency view or Structure view, select a COBOL project.

2. On the Run menu, click Debug Configurations.... Or click of on the toolbar, select Debug Configurations.... The Debug Configurations dialog box appears.

3. In left pane, select Remote COBOL Application.

4. Click at the top of the left pane. The startup configuration settings page is displayed in the right pane.

5. In the Name field, the default startup configuration name is displayed. The startup configuration name can be changed.

6. On the Main tab, check each setting item, and change it as necessary.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>The selected project name is displayed.</td>
</tr>
<tr>
<td>Debug Style</td>
<td>Select Attach Debug.</td>
</tr>
<tr>
<td>Debug Information Directory</td>
<td>If the debugging information file is placed in a directory that is different from the server directory (Server directory of Remote Development page of project property), specify the directory path.</td>
</tr>
<tr>
<td></td>
<td>Multiple directories can be specified as follows:</td>
</tr>
<tr>
<td></td>
<td>- For Solaris or Linux server, connect directory paths with &quot;.&quot; (colon).</td>
</tr>
<tr>
<td></td>
<td>- For Windows server, connect directory paths with &quot;;&quot; (semicolon).</td>
</tr>
</tbody>
</table>

7. Start the debugger by selecting "Debug". The debugger stays in the standby state until an application to be debugged is reported to have started. Once debugging is started with a particular configuration, the startup configuration is registered as a shortcut in the toolbar and you can restart debugging by selecting Run > Debug History or using the shortcut.

Note

If the server operating system is Solaris or Linux and the debug target is a COBOL application that uses a dynamic link library stored in a directory other than the one containing the executable file, start debugging after copying the debugging information file (extension "svd") of the dynamic link library to the directory containing the executable file.
9.6.2.2 Remote debugger connector

After the remote debugger connector starts, the following icon is displayed in the task tray, and the settings are the same as those the previous time the remote debugger connector was started. The order from the server to start debugging is monitored.

Note

When the debugger ends, the remote debugger connector is not automatically closed. On the task tray icon, select Exit from the context menu, and then the remote debugger connector close.

Remote Debugger Connector dialog box

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connect Information</td>
<td></td>
</tr>
<tr>
<td>Network Condition:</td>
<td>IP address of the machine or hostname where the remote debugger connector is activating, and the port number monitored by the remote debugger connector are displayed. When you select Change Port Number, Change Port Number dialog box opens.</td>
</tr>
<tr>
<td>Connect Restriction</td>
<td></td>
</tr>
</tbody>
</table>
| Connect Allowed Target:         | Set the connect-allowed targets.  
If you select Allow All the Connection, all computers are allowed to connect. 
Allow Target displays the list of the connect-allowed targets. Using each button, Add, Edit and Remove, you can modify the list of connect-allowed targets. |
| Connect Denied Target:          | Set the connect-denied target.  
If you select Deny All the Connection, all computers are denied to connect. 
Deny target displays the list of the connect-denied targets. Using each button, Add, Edit and Remove, you can modify the list of the connect-denied targets. |

9.6.2.3 Restricting connection to computers that allow remote debugging

The way to restrict connections to computers that allow remote debugging is shown in the table below. This table uses the IPv4 address. The IPv6 address can also be used.

In this table, the server remote debugger connector is expressed by "server", and the client remote debugger connector is expressed by "client".

The connect restriction file is used in the server. For details, refer to "Format of connect restriction file".

In the client, make the settings in the Connect Restriction page of the Remote Debugger Connector dialog box. For details, refer to "Remote Debugger Connector dialog box."
### Table 9.5 Typical examples of restricting connection

<table>
<thead>
<tr>
<th>Format</th>
<th>Server</th>
<th>Client</th>
</tr>
</thead>
</table>
| This allows connection for only a specific target. The IP address to be allowed connection is as follows: 192.168.0.1 | ALLOW=192.168.0.1  \nDENY=ALL | Setting for “Connect Allowed Target”:  
- Select "Allow Target".  
- Set as follows in the edit box:  
  192.168.0.1  
Setting for “Connect Denied Target”:  
- Select "Deny All the Connection". |
| This allows connection for several specific targets. The IP addresses to be allowed connection are as follows: 192.168.0.1 192.168.0.2 192.168.0.10 | ALLOW=192.168.0.1 \n192.168.0.2 192.168.0.10  \nDENY=ALL | Setting for “Connect Allowed Target”:  
- Select "Allow Target".  
- Set as follows in the edit box:  
  192.168.0.1  
  192.168.0.2  
  192.168.0.10  
Setting for “Connect Denied Target”:  
- Select "Deny All the Connection". |
| This allows connection for a specific range. The range of IP addresses to be allowed connection is as follows: Lower limit: 192.168.0.1 Upper limit: 192.168.0.10 | ALLOW=192.168.0.1-192.168.0.10  \nDENY=ALL | Setting for “Connect Allowed Target”:  
- Select "Allow Target".  
- Set as follows in the edit box:  
  192.168.0.1-192.168.0.10  
Setting for “Connect Denied Target”:  
- Select "Deny All the Connection". |
| This allows connection in octet units. The range of IP addresses to be allowed connection is as follows: Lower limit: 192.168.0.0 Upper limit: 192.168.0.255 | ALLOW=192.168.*  \nDENY=ALL | Setting for “Connect Allowed Target”:  
- Select "Allow Target".  
- Set as follows in the edit box:  
  192.168.*  
Setting for “Connect Denied Target”:  
- Select "Deny All the Connection". |
| This allows connection for all computers. | ALLOW=ALL  \nDENY=ALL | Setting for “Connect Allowed Target”:  
- Select "Allow All the Connection".  
Setting for “Connect Denied Target”:  
- Select "Deny All the Connection". |

### 9.6.2.4 Executing an application on the server

On the server, set the environment variable required for reporting the start of execution of a debug target application to the remote debugger as shown in the table below. Specify the IP address or host name of the local PC for "connection-destination" and specify its port number. For details on how to set the environment variable, see the NetCOBOL User's Guide.

**COBOL application**
<table>
<thead>
<tr>
<th>Server</th>
<th>Environment variable</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows(x64)</td>
<td>@CBR_ATTACH_TOOL= connection-destination/STUDIO [path-list]</td>
</tr>
<tr>
<td>Solaris</td>
<td>CBR_ATTACH_TOOL= connection-destination/STUDIO [path-list]</td>
</tr>
<tr>
<td>Linux(Itanium)</td>
<td></td>
</tr>
<tr>
<td>Linux(x64)</td>
<td></td>
</tr>
</tbody>
</table>

- For "connection-destination", specify the client side port number for the remote debugger connector and the operating computer in the following format:

{IP address | host name}[::port number]

Specify the IP address in IPv4 or IPv6 format.
Specify a port number in the range 1024 to 65535. If the port number is omitted, it defaults to 59999.
The IPv6 format can specify the scope address. The scope address specifies the scope identifier after the address.
If a port number is specified in an IPv6 address, enclose the address part with "[ ]".

Example:

- Specification with IPv4 address (192.168.0.1) and port number (2000)

@CBR_ATTACH_TOOL=192.168.0.1:2000/STUDIO

- Specification with IPv6 address (fe80::1:23:456:789a) and port number (2000)

@CBR_ATTACH_TOOL=[fe80::1:23:456:789a]:2000/STUDIO

- Specification with IPv6 address (fe80::1:23:456:789a) and scope identifier (%eth0)

@CBR_ATTACH_TOOL= fe80::1:23:456:789a%eth0/STUDIO

- Specification with IPv6 address (fe80::1:23:456:789a), scope identifier (%5) and port number (2000)

@CBR_ATTACH_TOOL=[fe80::1:23:456:789a%5]:2000/STUDIO

- Specification with host name (client-1) and port number (2000)

@CBR_ATTACH_TOOL=client-1:2000/STUDIO

- Specification with port number omitted (IPv4 address)

@CBR_ATTACH_TOOL=192.168.0.1/STUDIO

- Specification with port number omitted (IPv6 address)

@CBR_ATTACH_TOOL=fe80::1:23:456:789a/STUDIO

An IPv6 address cannot be specified if the server OS is Linux(Itanium).

⚠️ Note

For the Linux (Itanium) operating system, the IPv6 address cannot be specified.

Remote debugging corresponds to the IPv6 address within the following scopes.

**Table 9.6 For IPv6 of remote debugging**

<table>
<thead>
<tr>
<th>Item</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network</td>
<td>It corresponds to the following environments.</td>
</tr>
</tbody>
</table>
## IPv6 address

The following IPv6 addresses are used.

- Aggregatable Global Unicast Address (GUA)
- Unique Local Unicast Addresses (ULA)
- link local address (LLA)

## IPv4/IPv address selection

In the IPv4/IPv6 dual stack environment, IPv6 is used by priority.

The following are not supported

- Use limited (IPv4 only or IPv6 only)
- Switch of priority
- When failing in the connection by IPv6, it connects it by IPv4. (fallback)

## IP address notation

The following not supported

1. Specifying a port number ([])
2. The notation hex.
3. Recommended notation of IPv6 addresses (RFC5952)
4. Uppercase letters section
5. Lowercase letters section
6. Mixed-case notation of letters section

In the following cases, use the IPv4 address notation

- IPv4/IPv6 Dual stack operating system.
- Using of IPv4 and IPv6 together

---

### Note

Privacy Extensions are not supported. When an IP address is changed, it is necessary to restart a remote debugger connector and a remote debugger.

- For path-list, specify the directory that contains the debugging information file. The debugging information is retrieved in the following order, and is used for debugging.

1. The specified order of the additional path list (delimit by semicolon ";" and enter the full path name when you specify two or more folders).
2. The current folder when the COBOL program began to run.
3. The folder that contains the COBOL program.

### Note

2. and 3. do not need to be added to PATHLIST.

---

### Canceling the standby state

To stop debugging with the remote debugger in the standby state after it was started in the attach format, click ![icon] in the bottom right of the window, and then click ![icon] in the displayed Progress view.
Attached debugging for a COBOL application on the client

Attached debugging can also be performed for a COBOL application built on the client. To perform attachment debugging on the client, set an environment variable on the client. This variable is used to report the start of an application to the debugger.

To perform attachment debugging on the client:

1. Set the environment variable shown below on the local PC. This variable is used for reporting the start of an application to the debugger.
   
   ```
   @CBR_ATTACH_TOOL=localhost/STUDIO
   ```

2. In the Dependency view or Structure view, select a COBOL project.

3. On the Run menu, click **Debug Configurations...**. Or click ![ ] on the toolbar, select **Debug Configurations...**. The **Debug Configurations** dialog box appears.

4. In the left pane, select **Remote COBOL Application**.

5. In the left pane, click ![ ] . The **startup configuration setting** page is displayed in the right pane.

6. The default startup configuration name is displayed in "Name". The startup configuration name can be changed.

7. On the **Main** tab, check each setting item, and change it as necessary.

<table>
<thead>
<tr>
<th>item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>Displays the selected project name.</td>
</tr>
<tr>
<td>Debug Style</td>
<td>Select &quot;Attach Debug&quot;.</td>
</tr>
<tr>
<td>Debug Information Directory</td>
<td>Specify the storage folder for the debugging information file. When it is stored in the folder displayed by the Location on the <strong>Resource</strong> page (*), it is omissible. If you specify more than one directory, the folder is delimited by the semicolon (;).</td>
</tr>
</tbody>
</table>

*: The resource page is in the properties dialog box of the project.

8. Start the debugger by selecting "Debug". The debugger stays in the standby state until an application to be debugged is reported to have started.

9. Execute a COBOL application to start debugging.

9.7 Notes on using the remote development function

Use the version of NetCOBOL Studio that corresponds to the version of the NetCOBOL product that is installed on the server.

If the version of NetCOBOL on the server is newer than the version of NetCOBOL Studio, some of the server side NetCOBOL functions might not be available for use. For example:

- Newly changed or added compiler options cannot be specified by the **Compiler Option** dialog.
- Newly added reserved words are not recognized as reserved words in the COBOL editor.
- When remotely debugging, the message "An error detected in the debugger." is displayed.
# Chapter 10 Using based on Eclipse 4.6

Some menu names and window names of NetCOBOL Studio on Eclipse 4.6 are different from that on Eclipse 4.3. See "10.1 Comparing table of display name in NetCOBOL Studio between Eclipse bases".

## 10.1 Comparing table of display name in NetCOBOL Studio between Eclipse bases

<table>
<thead>
<tr>
<th>Function</th>
<th>Display name in NetCOBOL Studio on Eclipse 4.6</th>
<th>Display name in NetCOBOL Studio on Eclipse 4.3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print button</td>
<td>The print button is not displayed on the toolbar. (default)</td>
<td>The print button is displayed on the toolbar. (default)</td>
</tr>
<tr>
<td></td>
<td>You can display the print button on the toolbar by the following steps.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>1. Click the COBOL perspective, select Customize... from the context menu. The Customize Perspective dialog box appears.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>2. On the Tool Bar Visibility tab, in the Tool Bar Structure list, click File for more information. And then select Print (Ctrl+P).</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3. Click OK.</td>
<td></td>
</tr>
<tr>
<td>Perspective menu</td>
<td>To access the perspective menu, on the Window menu, click Perspective.</td>
<td>To access the perspective menu, click the Window menu,</td>
</tr>
<tr>
<td>Rename</td>
<td>In the Rename Resource dialog box, only the base name of the file is selected.</td>
<td>In the Rename Resource dialog box, all file names are selected.</td>
</tr>
<tr>
<td>Copy Project</td>
<td>On the Copy Project dialog box, in the Project name field, the project name that added the ordinal(*2) at the end of an original name(*1) is set.</td>
<td>On the Copy Project dialog box, in the Project name field, the project name that adds “Copy of” to the head of an original name is set.</td>
</tr>
<tr>
<td></td>
<td>*1: Name excluding the number at the end of the original file name.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>*2: Numbers not overlapping in the workspace.</td>
<td></td>
</tr>
<tr>
<td>Copy file</td>
<td>In the Name Conflict dialog box, the file name that added the ordinal(*2) at the end of an original name(*1) is set.</td>
<td>In the Name Conflict dialog box, the file name that adds “Copy of” to the head of an original file-name is set.</td>
</tr>
<tr>
<td></td>
<td>*1: Name excluding the number at the end of the original file name.</td>
<td>All file names are selected.</td>
</tr>
<tr>
<td></td>
<td>*2: Numbers not overlapping in the workspace.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Only the base name of the file is selected.</td>
<td></td>
</tr>
<tr>
<td>Perspective Tool box button</td>
<td>The text name of the perspective tool box button is not displayed.(default)</td>
<td>The text name of the perspective tool box button is displayed.(default)</td>
</tr>
<tr>
<td></td>
<td>You can display the text name by the following steps.</td>
<td>You can hide the text name by the following steps.</td>
</tr>
<tr>
<td></td>
<td>1. Click the perspective, select Show Text from the context menu.</td>
<td>1. Click the perspective, clear Show Text from the context menu.</td>
</tr>
<tr>
<td>File Search</td>
<td>Use the COBOL Search to search and replace the COBOL source files.</td>
<td>The File Search function operates as the COBOL Search function of Eclipse 4.6.</td>
</tr>
<tr>
<td>Function</td>
<td>Display name in NetCOBOL Studio on Eclipse 4.6</td>
<td>Display name in NetCOBOL Studio on Eclipse 4.3</td>
</tr>
<tr>
<td>----------</td>
<td>-----------------------------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>In the <strong>COBOL Search</strong> function, when replacing, the sequence number area of the COBOL source file is excluded.</td>
<td></td>
</tr>
</tbody>
</table>
Appendix A  Compile Options

A.1  Compile option details

A dialog box for specifying detailed information is displayed according to the options selected from the Compiler options list in the Add Compiler Options dialog box.

Options not specified by the Compiler Options dialog box follows the NetCOBOL compiler option default. For details about NetCOBOL compile options, refer to "NetCOBOL User's Guide".

Note

- When specifying the project from the Selection from project dialog in selecting compiler options, the path separator backslash is displayed as a forward slash. The forward slash is treated as backslash.
- The compiler option that cannot be selected from the Add Compiler Option dialog box can be specified by using the Other compiler options on the Compiler Options page.

A.1.1  Compiler option list

Compilation resources options
A.1.17 FORMLIB compile option
A.1.20 LIB compile option
A.1.36 REP compile option
A.1.37 REPIN compile option

Compilation list options
A.1.8 COPY compile option
A.1.21 LINECOUNT compile option
A.1.22 LINESIZE compile option
A.1.23 LIST compile option
A.1.24 MAP compile option
A.1.25 MESSAGE compile option
A.1.30 NUMBER compile option
A.1.33 PRINT compile option
A.1.43 SOURCE compile option
A.1.54 XREF compile option

Compilation messages options
A.1.7 CONF compile option
A.1.15 FLAG compile option
A.1.16 FLAGSW compile option

COBOL program interpretation options
A.1.2 ALPHAL compile option
A.1.5 BINARY compile option
A.1.10 CURRENCY compile option
A.1.12 DUPCHAR compile option
A.1.18 INITVALUE compile option
A.1.19 LANGLEVEL compile option
A.1.27 NCW compile option
A.1.28 NSP compile option
A.1.29 NSPCOMP compile option
A.1.34 QUOTE/APOST compile option
A.1.38 RSV compile option
A.1.40 SDS compile option
A.1.41 SHREXT compile option
A.1.44 SQLGRP compile option
A.1.45 SRF compile option
A.1.48 STD1 compile option
A.1.49 TAB compile option
A.1.55 ZWB compile option

**Source program analysis options**

A.1.39 SAI compile option

**Object program creation options**

A.1.3 ARITHMETIC compile option
A.1.4 ASCOMP5 compile option
A.1.13 ENCODE compile option
A.1.11 DLOAD compile option
A.1.26 MODE compile option
A.1.31 OBJECT compile option
A.1.32 OPTIMIZE compile option
A.1.35 RCS compile option
A.1.51 THREAD compile option

**Execution time processing options**

A.1.14 EQUALS compile option
A.1.53 TRUNC compile option

**Execution time resources options**

A.1.42 SMSIZE compile option
A.1.46 SSIN compile option
A.1.47 SSOUT compile option

**Debugging functions at execution time options**

A.1.6 CHECK compile option
A.1.9 COUNT compile option
A.1.50 TEST compile option
A.1.52 TRACE compile option

A.1.2 ALPHAL compile option

This option specifies whether to treat lowercase letters in source programs the same as uppercase letters (ALPHAL) or not (NOALPHAL).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lower-case character usage</td>
<td>Specifies how to treat lowercase letters in source programs. ALPHAL is the default value.</td>
</tr>
<tr>
<td>ALPHAL</td>
<td>Treats lowercase letters the same as uppercase letters (not case-sensitive).</td>
</tr>
<tr>
<td>NOALPHAL</td>
<td>Distinguishes between lowercase letters and uppercase letters (case-sensitive).</td>
</tr>
<tr>
<td>Scope of words taken as upper case</td>
<td>This item can be selected only if ALPHAL is selected for Lower-case character usage. ALL is the default value.</td>
</tr>
<tr>
<td>ALL</td>
<td>Treats the lowercase letters that appear in program-name literals and literals in the CALL, CANCEL, ENTRY, and INVOKE statements the same as uppercase letters.</td>
</tr>
<tr>
<td>WORD</td>
<td>Treats literals as they are described.</td>
</tr>
</tbody>
</table>

A.1.3 ARITHMETIC compile option

This option specifies whether to use 18-digit compatible arithmetic mode or 31-digit extended arithmetic mode.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculation mode</td>
<td>Specifies which calculation mode to use. The default is 18 digits compatible arithmetic mode.</td>
</tr>
<tr>
<td>18 digits compatible arithmetic mode</td>
<td>Uses the 18-digit compatible arithmetic mode.</td>
</tr>
<tr>
<td>31 digits extended arithmetic mode</td>
<td>Uses the 31-digit extended arithmetic mode.</td>
</tr>
<tr>
<td>Show I-level diagnostic message</td>
<td>Checks for the following:</td>
</tr>
<tr>
<td></td>
<td>- When compiling using 18 digits compatible arithmetic mode, the following message is output:</td>
</tr>
<tr>
<td></td>
<td>JMN3024I-W The intermediate result cannot contain more than 30 digits. The intermediate result is assumed to have 30 digits.</td>
</tr>
<tr>
<td></td>
<td>- Checks for arithmetic expressions with an intermediate result (fixed-point or floating-point) that is not in 18 digits compatible arithmetic mode.</td>
</tr>
</tbody>
</table>

Note

- When 31 digits extended arithmetic mode is specified, compiler option BINARY can specify only BINARY(WORD,MLBON).
- Specify 18 digits compatible arithmetic mode for compatibility with V10.2.0 or earlier, or with other systems.
- Refer to "Operation mode" in Chapter 1 of the "NetCOBOL Language Reference" for details.
### A.1.4 ASCOMP5 compile option

This option specifies how to interpret binary items.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specification of interpretation binary data</td>
<td>Specifies how to treat binary items. The default is NONE.</td>
</tr>
<tr>
<td>NONE</td>
<td>Treats binary items as they are declared.</td>
</tr>
<tr>
<td>ALL</td>
<td>Treats binary items declared as USAGE BINARY, USAGE COMP, or USAGE COMPUTATIONAL as USAGE COMP-5 items.</td>
</tr>
<tr>
<td>BINARY</td>
<td>Treats binary items declared as USAGE BINARY as USAGE COMP-5 items.</td>
</tr>
<tr>
<td>COMP</td>
<td>Treats binary items declared as USAGE COMP or USAGE COMPUTATIONAL as USAGE COMP-5 items.</td>
</tr>
</tbody>
</table>

**Note**

- Using this option may affect the internal format of data.
- Note that care is required if you use this option with code that is aware of internal binary numeric formats because the ALL, BINARY, and COMP options will cause the internal formats to change.
- NONE must be specified when using the CBL routine.

### A.1.5 BINARY compile option

This option specifies whether to assign an elementary item of binary data to an area of a length in units of words (2, 4, or 8) (BINARY(WORD)) or bytes (1 to 8) (BINARY(BYTE)), which is calculated based on the number of digits. This option can also specify how to treat the high-order-end bit of an unsigned binary item.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Binary data item usage</td>
<td>Specifies how to treat binary items. The default is WORD,MLBON.</td>
</tr>
<tr>
<td>WORD,MLBON</td>
<td>The area length is in units of words, and the high-order-end bit is treated as a sign symbol.</td>
</tr>
<tr>
<td>WORD,MLBOFF</td>
<td>The area length is in units of words, and the high-order-end bit is treated as a numerical value.</td>
</tr>
<tr>
<td>BYTE</td>
<td>The area length is in units of bytes, and the high-order-end bit is treated as a sign symbol.</td>
</tr>
</tbody>
</table>

**Note**

- BINARY(BYTE) cannot be used in a class definition.
- If BINARY(BYTE) is specified, the high order end bit is treated as a numeric value.
- BINARY(WORD, MLBON) cannot be excluded when specifying ARITHMETIC(31).

**Information**

The following table shows the relationship between the number of declared digits and the area length.
<table>
<thead>
<tr>
<th>Number of PIC Digits</th>
<th>Assigned Area Length</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Signed</strong></td>
<td><strong>unsigned</strong></td>
</tr>
<tr>
<td>1 - 2</td>
<td>1 - 2</td>
</tr>
<tr>
<td>3 - 4</td>
<td>3 - 4</td>
</tr>
<tr>
<td>5 - 6</td>
<td>5 - 7</td>
</tr>
<tr>
<td>7 - 9</td>
<td>8 - 9</td>
</tr>
<tr>
<td>10 - 11</td>
<td>10 - 12</td>
</tr>
<tr>
<td>12 - 14</td>
<td>13 - 14</td>
</tr>
<tr>
<td>15 - 16</td>
<td>15 - 16</td>
</tr>
<tr>
<td>17 - 18</td>
<td>17 - 18</td>
</tr>
<tr>
<td>19 - 28 (*)</td>
<td>19 - 28</td>
</tr>
<tr>
<td>29 - 31 (*)</td>
<td>29 - 31</td>
</tr>
</tbody>
</table>

*: For 31-digit extension operation mode.

---

### A.1.6 CHECK compile option

This option specifies whether to use the CHECK function (CHECK) or not (NOCHECK). An integer ranging from 0 to 999999 is specified for n as the number of messages to be displayed. If the option is omitted, 1 is assumed to be specified.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check function</td>
<td>Specifies whether the CHECK function can be used. The default is NOCHECK.</td>
</tr>
<tr>
<td>CHECK</td>
<td>Uses the CHECK function.</td>
</tr>
<tr>
<td>NOCHECK</td>
<td>Does not use the CHECK function.</td>
</tr>
<tr>
<td>Number of messages to be displayed</td>
<td>Specifies the number of messages to be displayed.</td>
</tr>
</tbody>
</table>

**Check items**

| ALL | Checks all of NUMERIC, BOUND, ICONF, LINKAGE, and PRM. |
| BOUND | Checks whether subscripts, indexes, and reference modifications are in their correct ranges. |
| ICONF | Checks whether the INVOKE statement parameters are compatible with the tentative parameters of the method to be called. |
| NUMERIC | Checks for a data exception. If a numeric item contains a value that does not match its attribute, or if the divisor of division operation is 0, a data exception occurs. |
| PRM | Checks the following during compilation related to data items described in the USING or RETURNING phrases of the CALL statement (except call identifiers) invoking internal programs, and the USING or RETURNING phrase of the internal programs: |
| - Whether the number of parameters in the USING phrases match |
| - Consistency in the parameters of individual RETURNING phrases |
| - Whether the lengths of data items that do not reference objects match. This check of the lengths is performed only if the length is determined during compilation. |
- Whether the class names specified for the USAGE OBJECT REFERENCE clause match, the FACTORY phrase matches, and the ONLY phrase matches if the data items reference objects.

A check of the following is performed during execution related to data items described in both the USING or RETURNING phrase of the CALL statement invoking external programs, and the USING or RETURNING phrase of the external programs:

- Whether the number of parameters in the USING phrases match, and whether the data items lengths match.

**Note:** If the USING phrases have four or more parameter number mismatch errors, an error may not be detected.

- Whether the lengths of parameters in the USING phrases match. If the RETURNING phrase is not specified, data items with a length of four bytes are assumed specified because PROGRAM-STATUS is implicitly handed over. Also, if the length of a parameter is determined during execution, this check is performed during compilation, using the maximum value of the length described.

---

**A.1.7 CONF compile option**

This option specifies whether to output diagnostic messages when items are detected for which there are incompatibilities between new and old COBOL standards (CONF) or not (NOCONF). If CONF is specified, I-level diagnostic messages will be output when items with such...
incompatibilities are detected. CONF is useful for converting programs that were created in conformance to old standards into programs conforming to the '85 ANSI COBOL standard.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Posting of incompatibility with the COBOL standards</td>
<td>Specifies whether to output messages on items for which there are incompatibilities between new and old COBOL standards. The default is NOCONF.</td>
</tr>
<tr>
<td>CONF</td>
<td>Outputs messages on items for which there are incompatibilities between new and old COBOL standards.</td>
</tr>
<tr>
<td>NOCONF</td>
<td>Does not generate messages when incompatibilities between new and old COBOL standards are detected.</td>
</tr>
<tr>
<td>indicating post items</td>
<td>This item is enabled only if CONF is selected for Posting of incompatibility with the COBOL standards. The default value is 68.</td>
</tr>
<tr>
<td>68</td>
<td>Outputs messages when items are detected for which there are incompatibilities between '68 ANSI COBOL and '85 ANSI COBOL. The specification is valid only if LANGLVL (85) is specified as a compile option.</td>
</tr>
<tr>
<td>74</td>
<td>Outputs messages when items are detected for which there are incompatibilities between '74 ANSI COBOL and '85 ANSI COBOL. The specification is valid only if LANGLVL (85) is specified as a compile option.</td>
</tr>
<tr>
<td>OBS</td>
<td>Outputs messages when obsolete elements in language specifications and functions are detected.</td>
</tr>
</tbody>
</table>

**Note**

The compiler options CONF(68) and CONF(74) are effective only if the compiler option LANGLVL(85) is specified.

**A.1.8 COPY compile option**

This option specifies whether to display library text embedded by the COPY statement in a source program list (COPY) or not (NOCOPY). The COPY statement is valid only if the SOURCE compile option is specified.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Library text output option</td>
<td>Specifies whether to display library text. The default is NOCOPY.</td>
</tr>
<tr>
<td>COPY</td>
<td>Displays library text.</td>
</tr>
<tr>
<td>NOCOPY</td>
<td>Does not display library text.</td>
</tr>
</tbody>
</table>

**Note**

COPY is only effective when the compiler option SOURCE is specified.

**A.1.9 COUNT compile option**

This option specifies whether to use the COUNT function (COUNT) or not (NOCOUNT).
### A.1.10 CURRENCY compile option

This option specifies whether to use $ (CURRENCY($)) or to use another symbol (CURRENCY(currency-symbol)) as the character for the currency symbol. If CURRENCY(currency-symbol) is specified, refer to the CURRENCY SIGN clause explained in the "COBOL Language Reference" for the currency symbol that can be used.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specification of currency sign</td>
<td>Specifies what to use as the currency symbol. The default is $.</td>
</tr>
<tr>
<td>$</td>
<td>Uses $ as the currency symbol.</td>
</tr>
<tr>
<td>Specify currency symbol character</td>
<td>Uses another symbol.</td>
</tr>
<tr>
<td>Currency symbol character</td>
<td>The currency symbol character is specified.</td>
</tr>
</tbody>
</table>

### A.1.11 DLOAD compile option

This option specifies whether to adopt the dynamic program structure for the program structure (DLOAD) or not (NODLOAD).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Program structure</td>
<td>Specifies the program structure. The default is NODLOAD.</td>
</tr>
<tr>
<td>DLOAD</td>
<td>Uses the dynamic program structure.</td>
</tr>
<tr>
<td>NODLOAD</td>
<td>Does not use the dynamic program structure.</td>
</tr>
</tbody>
</table>

### A.1.12 DUPCHAR compile option

Specify whether the JIS non-Kanji minus sign is "MINUS SIGN (STD)" or "FULLWIDTH HYPHEN-MINUS (EXT)" when source programs and library texts are created in UTF-8.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Duplicate characters</td>
<td>Specifies how duplicate characters are treated. The default is EXT.</td>
</tr>
<tr>
<td>STD</td>
<td>MINUS SIGN</td>
</tr>
<tr>
<td>EXT</td>
<td>FULLWIDTH HYPHEN-MINUS</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Item</th>
<th>UTF-8</th>
<th>UTF-16</th>
</tr>
</thead>
<tbody>
<tr>
<td>MINUS SIGN</td>
<td>X“E28892”</td>
<td>X“2212”</td>
</tr>
</tbody>
</table>
A.1.13 ENCODE compile option

Specify the encoding of the alphanumeric data item and the national data item.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Encoding of an alphanumeric character item</td>
<td>The default is SJIS.</td>
</tr>
<tr>
<td>SJIS - Shift-JIS</td>
<td>The encoding of an alphanumeric character item is specified as SJIS.</td>
</tr>
<tr>
<td>UTF-8</td>
<td>The encoding of an alphanumeric character item is specified as UTF8.</td>
</tr>
<tr>
<td>Encoding of a national item</td>
<td>The default is SJIS.</td>
</tr>
<tr>
<td>SJIS - Shift-JIS</td>
<td>The encoding of a national item is specified as SJIS.</td>
</tr>
<tr>
<td>UTF-16</td>
<td>The encoding of a national item is specified as UTF16.</td>
</tr>
<tr>
<td>UTF-32</td>
<td>The encoding of a national item is specified as UTF32.</td>
</tr>
<tr>
<td>Endian of a national item</td>
<td>When the national item is UTF16 or UTF32, then specify little endian or big endian.</td>
</tr>
<tr>
<td>LE - Little Endian</td>
<td>The national item is little endian.</td>
</tr>
<tr>
<td>BE - Big Endian</td>
<td>The national item is big endian.</td>
</tr>
</tbody>
</table>

When compilation option ENCODE is specified, then the runtime code will be Unicode. However, when compilation option RCS is specified, then it is given priority.

**Point**

When compile option ENCODE (UTF8, UTF16) or ENCODE (UTF8, UTF32) is specified explicitly or implicitly, then spaces related to a national item become national spaces (alphabetic character spaces). This handling can be done by specifying the compile option NSP.

A.1.14 EQUALS compile option

For multiple records with the same key in the SORT statement, this option specifies whether to guarantee that the SORT output records are in the same order as the SORT input records at execution time (EQUALS), or not (NOEQUALS).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processing mode of same key data in SORT statement</td>
<td>Specifies how to process data with the same key in the SORT statement. The default is NOEQUALS.</td>
</tr>
<tr>
<td>EQUALS</td>
<td>Guarantees that the SORT output records are in the same order as the SORT input records at execution time.</td>
</tr>
<tr>
<td>NOEQUALS</td>
<td>Does not guarantee that the SORT output records are in the same order as the SORT input records at execution time.</td>
</tr>
</tbody>
</table>

**Note**

If EQUALS is specified, special processing is executed to guarantee the order of input during the sorting operation, and the execution speed decreases.
A.1.15  FLAG compile option

This option specifies the diagnostic messages to be displayed.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Level of diagnostic message</td>
<td>Specifies a level of diagnostic messages. The default is I.</td>
</tr>
<tr>
<td>I</td>
<td>Displays all diagnostic messages.</td>
</tr>
<tr>
<td>W</td>
<td>Displays diagnostic messages of only W-level or higher.</td>
</tr>
<tr>
<td>E</td>
<td>Displays diagnostic messages of only E-level or higher.</td>
</tr>
</tbody>
</table>

**Note**

The diagnostic message specified in the compiler option CONF is displayed regardless of the FLAG specification.

A.1.16  FLAGSW compile option

This option specifies whether to display messages that identify types of COBOL language elements (FLAGSW) or not (NOFLAGSW).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display messages COBOL syntax language construction</td>
<td>Specifies whether to display messages that identify language elements. The default is NOFLAGSW.</td>
</tr>
<tr>
<td>FLAGSW</td>
<td>Displays messages that identify COBOL language elements.</td>
</tr>
<tr>
<td>NOFLAGSW</td>
<td>Does not display messages that identify COBOL language elements.</td>
</tr>
<tr>
<td>Language constructions</td>
<td>Select the language elements to be identified.</td>
</tr>
<tr>
<td>STDM</td>
<td>Identifies all non-low-level ’85 ANSI COBOL standard language elements.</td>
</tr>
<tr>
<td>STDI</td>
<td>Identifies all non-mid-level ’85 ANSI COBOL standard language elements.</td>
</tr>
<tr>
<td>STDH</td>
<td>Identifies all non-high-level ’85 ANSI COBOL standard language elements.</td>
</tr>
<tr>
<td>SIA</td>
<td>Identifies language elements that are outside the range of the Fujitsu System Integration Architecture (SIA).</td>
</tr>
<tr>
<td>RPW</td>
<td>Identifies language elements of the report writer function of the ’85 ANSI COBOL standard. This item can be selected only if STDM, STDI, or STDH is selected.</td>
</tr>
</tbody>
</table>

**Point**

FLAGSW (SIA) is useful when creating a program that will run in another system.

**Note**

FLAGSW sub operands {STDM | STDI | STDH} and RPW cannot be omitted simultaneously.
A.1.17 FORMLIB compile option

This option specifies the folder of the screen form descriptor files from which record definitions are imported by the COPY statement with the IN/OF XMDLIB phrase. If the screen form descriptor files are stored in multiple folders, specify these folders using semicolon delimiters. If multiple folders are specified, the folders are searched in the order specified.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Screen form definition file folder</td>
<td>Specifies a folder of screen form descriptor files. Multiple folders can be specified using semicolons as delimiters. Click Browse to display the Folder type selection dialog box. Specify the absolute path of the folder. For some items selected in this way, the Folder selection dialog box appears, and you can select the folder to be specified.</td>
</tr>
</tbody>
</table>

A.1.18 INITVALUE compile option

This option specifies whether to initialize items without the VALUE clause in working-storage section data to their specified values (INITVALUE) or not (NOINITVALUE).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initialize value of data item in WORKING-STORAGE</td>
<td>Specifies whether to initialize items without the VALUE clause in working-storage section data to their specified values. The default is NOINITVALUE.</td>
</tr>
<tr>
<td>INITVALUE</td>
<td>Initializes the items.</td>
</tr>
<tr>
<td>NOINITVALUE</td>
<td>Does not initialize the items.</td>
</tr>
<tr>
<td>Value</td>
<td>Specifies a two-digit hexadecimal number if INITVALUE is selected. If INITVALUE is selected, an entry must be made for this item.</td>
</tr>
</tbody>
</table>

A.1.19 LANGLVL compile option

This option specifies the base standard for interpreting source program items for which there are differences between new and old COBOL standards.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specification of the ANSI COBOL standards</td>
<td>Specifies the base standard for interpreting a source program. The default is 85.</td>
</tr>
<tr>
<td>85</td>
<td>Interpretation is based on the '85 ANSI COBOL standard.</td>
</tr>
<tr>
<td>74</td>
<td>Interpretation is based on the '74 ANSI COBOL standard.</td>
</tr>
<tr>
<td>68</td>
<td>Interpretation is based on the '68 ANSI COBOL standard.</td>
</tr>
</tbody>
</table>

A.1.20 LIB compile option

This option specifies a folder of library files used for a library function (COPY statement). If the library files are stored in multiple folders, use semicolons to delimit the folders. If multiple folders are specified, the folders are searched in the order specified.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Folder where the library texts exist</td>
<td>Specifies a folder of library files. Multiple folders can be specified by using semicolon delimiters. Click Browse to display the Folder type selection dialog box. Specify the absolute path of the folder. For some items selected in this way, the Folder selection dialog box appears, and you can select the folder to be specified.</td>
</tr>
</tbody>
</table>
A.1.21 LINECOUNT compile option

This option specifies the number of lines contained on each page of a compilation list. If the specified number is in a range of 0 to 12, the compilation list is not organized into pages, and data is output continuously across pages.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of lines per page for the compiler listings</td>
<td>Specifies the number of lines contained on each page of a compilation list. The default is 60. Specify an integer consisting of three or fewer digits. If this item is not specified, 60 is assumed.</td>
</tr>
</tbody>
</table>

A.1.22 LINESIZE compile option

This option specifies the maximum number of characters per line in a compilation list (i.e., A/N characters displayed in the list).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of characters per line for the compiler listings</td>
<td>Specifies the maximum number of characters per line in a compilation list. The default is 136. The specified value can be 80 or a three-digit integer ranging from 120 to 136. If this item is not specified 136 is assumed.</td>
</tr>
</tbody>
</table>

Note
- Source program lists, option information lists, diagnostic message lists, and compilation unit statistical information lists are output in a format with a fixed number of characters per line (120), regardless of the maximum number of characters specified for the LINESIZE compile option.
- The maximum valid value for the number of characters is 136. If a value exceeding 136 is specified for the LINESIZE compile option, 136 is assumed.

A.1.23 LIST compile option

This option specifies whether to output an object program list (LIST) or not (NOLIST). If enabled, an object program is output to the folder specified by the PRINT compile option.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print program list or not</td>
<td>Specifies whether to output an object program list. The default is NOLIST.</td>
</tr>
<tr>
<td>LIST</td>
<td>Outputs an object program list.</td>
</tr>
<tr>
<td>NOLIST</td>
<td>Does not output an object program list.</td>
</tr>
</tbody>
</table>

Note
If the PRINT compile option is not specified, no object program list is output regardless of the specification of this option.

A.1.24 MAP compile option

This option specifies whether to output a data map list, program control information list, and section size list (MAP) or not (NOMAP). If enabled, a data map list, program control information list, and section size list are output to the file specified by the PRINT compile option.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output data map list</td>
<td>Specifies whether to output a data map list, program control information list, and section size list. The default is NOMAP.</td>
</tr>
<tr>
<td>MAP</td>
<td>Outputs a data map list, program control information list, and section size list.</td>
</tr>
</tbody>
</table>
### A.1.25 MESSAGE compile option

This option specifies whether to output an option information list and compilation unit statistical information list (MESSAGE) or not (NOMESSAGE).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output of compiler options and statistical information</td>
<td>Specifies whether to output an option information list and a compilation unit statistical information list. The default is NOMESSAGE.</td>
</tr>
<tr>
<td>MESSAGE</td>
<td>Outputs an option information list and a compilation unit statistical information list.</td>
</tr>
<tr>
<td>NOMESSAGE</td>
<td>Does not output an option information list or a compilation unit statistical information list.</td>
</tr>
</tbody>
</table>

### A.1.26 MODE compile option

This option specifies whether use right justification (MODE(STD)) or left justification (MODE(CCVS)) for copying numeric data during execution of the ACCEPT statement. This option specifies right or left justification when moving numeric data to an item on the receiving side, with a numeric receiving-side item in the coding format of "ACCEPT identifier FROM mnemonic-name".

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specification of ACCEPT statement's action</td>
<td>Specifies the operation of the ACCEPT statement. The default is STD.</td>
</tr>
<tr>
<td>STD</td>
<td>Copies numeric data with right justification.</td>
</tr>
<tr>
<td>CCVS</td>
<td>Copies numeric data with left justification.</td>
</tr>
</tbody>
</table>

**Note**

If MODE(CCVS) is specified, only an external decimal data item can be specified as a receiving item in the ACCEPT statement.

### A.1.27 NCW compile option

This option specifies whether the national language character set that can be specified in user-defined words is the common one in the system (NCW(STD)) or the national character set of the computer (NCW(SYS)).

If STD is specified, the following national language character sets can be used for national language user-defined words:

- JIS level-1 set
- JIS level-2 set
- JIS non-kanji set
If SYS is specified, the following national language character sets can be used for national language user-defined words:

- Character set with STD specified
- Extended characters
- Extended non-kanji set
- User-defined characters
- JIS non-kanji set

A.1.28 NSP compile option

Specify whether spaces related to a national data item are handled as national spaces (NSP) or as alphabetic character spaces (NONSP). In this option, encode is enabled for handling the trailing spaces related to a national data item of Unicode and a figurative constant SPACE. It is irrelevant when the encoding of national data items is other than Unicode.

A.1.29 NSPCOMP compile option

Use this option to specify how to treat a national space in a comparison. Specify NSPCOMP(NSP) to treat the national space as a national space; specify NSPCOMP(ASP) to treat the national space as an ANK space.

When NSPCOMP(ASP) is specified, an encode national space decided by compiler options is treated the same as the ANK blank in two bytes for UTF16, and treated to the same as the ANK blank in four bytes for UTF32.

The NSPCOMP(ASP) option is valid for the following comparisons:

- National character comparison that has a national item as an operand
- Nonnumeric comparison that has a group item as an operand
The NSPCOMP(ASP) option is invalid for the following comparisons:

- Comparison between group items that do not include national items
- Comparison between group items that include items that are not explicitly or implicitly used for display
- Comparison between group items including a national item with a different encode method
- Comparison of a national character that has an encode method different from the encode decided by the compiler options

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Japanese-language space comparison specification</td>
<td>Use this option to specify how to treat a national space in a comparison. The default is NSP.</td>
</tr>
<tr>
<td>NSP</td>
<td>Treats national spaces as national spaces.</td>
</tr>
<tr>
<td>ASP</td>
<td>Treats national spaces as ANK spaces.</td>
</tr>
</tbody>
</table>

**Note**
- In a non-numeric comparison or national character comparison in processing INSPECT, STRING, or UNSTRING statements, or in a key operation for an index file, national spaces are not treated as equivalent to ANK spaces regardless of the specification of the NSPCOMP(ASP) option.
- If NSPCOMP(ASP) is specified, each ANK space is treated as a national character under the JAPANESE class condition.

**A.1.30 NUMBER compile option**

Information that identifies each line in a source program is contained in different lists that are output at compilation time and at execution time. This option specifies whether to use values in the sequence number area of a source program (NUMBER), or values generated by the compiler (NONUMBER) for such line number information.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Treatment of sequential number area of source program</td>
<td>Specifies how to treat the sequence number area of a source program. The default is NONUMBER.</td>
</tr>
<tr>
<td>NUMBER</td>
<td>If a data item on any line in the sequence number area contains a character that is not a digit, or if sequence numbers are not assigned in ascending order, the line number of this line is changed to the number of the previous line (a correct sequence number) plus 1. If sequence numbers are assigned in descending order, a unique compensated number is added in the same format as that of a COPY qualification-value.</td>
</tr>
<tr>
<td>NONUMBER</td>
<td>Line numbers are assigned in ascending order beginning from 1, in increments of 1.</td>
</tr>
</tbody>
</table>

**Note**
- If the same sequence number is repeated on two contiguous lines and NUMBER is specified, it is not regarded as an error.
- If NUMBER is specified, Go To on the context menu of the Problems view cannot be used.
- If the sequence number is in descending order, the source analysis information file output with compiler option SAI specified can only be used by a project browser. See “A.1.39 SAI compile option”.
- When NUMBER is specified, you cannot debug it. Specify NONUMBER when debugging it.
- NUMBER cannot be specified for the pre-compiler. Specify NONUMBER.
A.1.31 OBJECT compile option

This option specifies whether to output an object program (OBJECT) or not (NOOBJECT). When an object program is output, its file is usually created in the same folder as that of the source program. To change the folder, specify a storage folder.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output of object program</td>
<td>Specifies whether to output an object program. The default is OBJECT.</td>
</tr>
<tr>
<td>OBJECT</td>
<td>Outputs an object program.</td>
</tr>
<tr>
<td>NOOBJECT</td>
<td>Does not output an object program.</td>
</tr>
<tr>
<td>Folder for object program</td>
<td>Specifies the storage folder other than the source program folder for output of an object program. Click Browse to display the Folder type selection dialog box. Specify the absolute path of the folder. For some items selected this way, the Folder selection dialog box appears, and you can select the folder to be specified.</td>
</tr>
</tbody>
</table>

**Note**

In NetCOBOL Studio, when the object program folder and the source program folder are different, the target file cannot be created. When you create the target file, specify the same folder for the source program folder and for the object program folder.

A.1.32 OPTIMIZE compile option

This option specifies whether to create a globally optimized object program (OPTIMIZE) or not (NOOPTIMIZE).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global optimization</td>
<td>Specifies whether a globally optimized object program is to be created. The default is: NOOPTIMIZE.</td>
</tr>
<tr>
<td>OPTIMIZE</td>
<td>Creates a globally optimized object program.</td>
</tr>
<tr>
<td>NOOPTIMIZE</td>
<td>Does not create a globally optimized object program.</td>
</tr>
</tbody>
</table>

**Note**

If this option is specified at the same time as the TEST compile option, the created debug information file can be used by the diagnostic function but not by the interactive debugger.

A.1.33 PRINT compile option

This option is used to specify the output of a compilation list. When a compilation list is output, its file is usually created in the same folder as the source program. To change the folder, specify a storage folder.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compiler listing folder</td>
<td>Specifies the name of the compilation list output folder. Click Browse to display the Folder type selection dialog box. Specify the absolute path of the folder. For some items selected this way, the Folder selection dialog box appears, and you can select the folder to be specified.</td>
</tr>
</tbody>
</table>

A.1.34 QUOTE/APOST compile option

This option specifies whether to use a quotation mark (”) (QUOTE) or an apostrophe (’) (APOST) as the figurative constants QUOTE and QUOTES.
Either the quotation mark or the apostrophe can be used in a source program to indicate a quotation mark, regardless of the specification of this option. However, the same character - quotation mark or apostrophe - must be used on the left and right sides of items in quotations. Examples of correct usage: "ABC", 'ABC'. Examples of incorrect usage: "ABC", 'ABC'.

### A.1.35 RCS compile option

This option specifies whether to use ASCII (RCS(ASCII)) or Shift-JIS (RCS(SJIS)) or Unicode (RCS(UTF16) or RCS(UCS2)) as the code set during execution. When ANSI code page (RCS(ACP)) is specified, it is specified in the Other compiler options text box.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Runtime code set</td>
<td>Specifies whether to use ASCII or Unicode during execution. The default</td>
</tr>
<tr>
<td>ASCII</td>
<td>Uses ASCII as the code set during execution.</td>
</tr>
<tr>
<td>SJIS</td>
<td>Uses Shift-JIS as the code set during execution.</td>
</tr>
<tr>
<td>UTF16</td>
<td>Uses Unicode as the code set during execution.</td>
</tr>
<tr>
<td>UCS2</td>
<td>Uses Unicode as the code set during execution.</td>
</tr>
<tr>
<td>Endian in Unicode environment</td>
<td>Specifies which endianness is used when runtime code set is Unicode. The</td>
</tr>
<tr>
<td>LE</td>
<td>Unicode Little Endian is specified for the runtime code set.</td>
</tr>
<tr>
<td>BE</td>
<td>Unicode Big Endian is specified for the runtime code set.</td>
</tr>
</tbody>
</table>

### Point

UTF16 and UCS2 are equivalent, but UTF16 is recommended.

### Note

- For V11 and later specifying the ENCODE compile option is recommended.
- When compile option RCS is specified, it is assumed that the ENCODE compile option is specified in the following way.
  - When RCS(ACP) or RCS(ASCII) is specified explicitly, the ENCODE compile option cannot be specified.
  - When RCS(SJIS) is specified, it is as assumed that ENCODE(SJIS,SJIS) is specified.
  - When RCS(UTF16) or RCS(UCS2) is specified, it is as assumed that ENCODE(UTF8,UTF16) is specified.
- If the system locale is Japanese, the RCS(ACP) or RCS(ASCII) or RCS(SJIS) settings produce the same result.

However, if you explicitly specify the RCS (ACP) or RCS(ASCII), the encoding of an alphanumeric character item works as ASCII. Behavior of National item is not guaranteed. In addition, it does not allow you to specify the ENCODING clause.
For the operation when the system locale is not Japanese, refer to the "The system locale in Windows system" of the "NetCOBOL User's Guide."

---

### A.1.36 REP compile option

Repository files are usually created in the same folder as that of the source program. Use this option to change the storage folder.

The specified folder can be the repository file input folder.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Repository file input and output folder</td>
<td>Specifies the repository file input-output folder. Click <strong>Browse</strong> to display the <strong>Folder type selection</strong> dialog box. Specify the absolute path of the folder. For some items selected in this way, the Folder selection dialog box appears, and you can select the folder to be specified.</td>
</tr>
</tbody>
</table>

---

### A.1.37 REPIN compile option

This option specifies the repository file input folder. If repository files are stored in multiple folders, use semicolons to delimit the folders. If multiple folders are specified, the folders are searched in the order specified.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Repository file input folders</td>
<td>Specifies the repository file input folder. Multiple folders can be specified using semicolons as delimiters. Click <strong>Browse</strong> to display the <strong>Folder type selection</strong> dialog box. Specify the absolute path of the folder. For some items selected in this way, the Folder selection dialog box appears, and you can select the folder to be specified.</td>
</tr>
</tbody>
</table>

---

### A.1.38 RSV compile option

This option specifies types of reserved words.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Kinds of reserved word</td>
<td>Specifies types of reserved words. The default is ALL.</td>
</tr>
<tr>
<td>ALL</td>
<td>For this product (Fujitsu NetCOBOL latest version)</td>
</tr>
<tr>
<td>V111</td>
<td>For OSIV COBOL85 V11L11</td>
</tr>
<tr>
<td>V112</td>
<td>For OSIV COBOL85 V11L20</td>
</tr>
<tr>
<td>V122</td>
<td>For OSIV COBOL85 V12L20</td>
</tr>
<tr>
<td>V125</td>
<td>For COBOL85 V12L50</td>
</tr>
<tr>
<td>V30</td>
<td>For COBOL85 V30</td>
</tr>
<tr>
<td>V40</td>
<td>For COBOL97 V40</td>
</tr>
<tr>
<td>V61</td>
<td>For COBOL97 V61</td>
</tr>
<tr>
<td>V70</td>
<td>For NetCOBOL V7.0</td>
</tr>
<tr>
<td>V81</td>
<td>For NetCOBOL V8.0</td>
</tr>
<tr>
<td>V90</td>
<td>For NetCOBOL V9,0</td>
</tr>
<tr>
<td>V1020</td>
<td>For NetCOBOL V10.0, V10.1, and V10.2</td>
</tr>
<tr>
<td>V1040</td>
<td>For NetCOBOL V10.4</td>
</tr>
<tr>
<td>V1100</td>
<td>For NetCOBOL V11.0</td>
</tr>
<tr>
<td>VSR2</td>
<td>For VS COBOLII REL2.0</td>
</tr>
<tr>
<td>VSR3</td>
<td>For VS COBOLII REL3.0</td>
</tr>
</tbody>
</table>
A.1.39 SAI compile option

This option specifies whether to output a source analysis information file (SAI) or not (NOSAI). When a source analysis information file is output, its file is usually created in the same folder as that of the source program. Use this option to change the storage folder.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source analysis information file</td>
<td>Specifies whether to output a source analysis information file. The default is NOSAI.</td>
</tr>
<tr>
<td>SAI</td>
<td>Outputs a source analysis information file.</td>
</tr>
<tr>
<td>NOSAI</td>
<td>Does not output a source analysis information file.</td>
</tr>
<tr>
<td>Output location folder</td>
<td>Specifies the source analysis information file output folder. This item can be selected only if SAI is selected for Source analysis information file. Click Browse to display the Folder type selection dialog box. Specify the absolute path of the folder. For some items selected in this way, the Folder selection dialog box appears, and you can select the folder to be specified.</td>
</tr>
</tbody>
</table>

A.1.40 SDS compile option

When moving a signed packed-decimal item to another signed packed-decimal item, this option specifies whether to move the sign of a sending-side item as is (SDS) or move a formatted sign (NOSDS). There are two types of negative signs: ‘XB’ and ‘XD’. The others are treated as positive signs. Here, formatting a sign means to convert the sign of the sending-side item from either the positive sign to ‘XC’ or the negative sign to ‘XD’.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrangement of sign of decimal item</td>
<td>Specifies whether to format the sign of a signed decimal item. The default is SDS.</td>
</tr>
<tr>
<td>SDS</td>
<td>Moves the sign as is.</td>
</tr>
<tr>
<td>NOSDS</td>
<td>Formats the sign before moving it.</td>
</tr>
</tbody>
</table>

When NOSDS is specified, if it is a value for the sign to mean negative, it changes in minus symbol and if it is a value for the sign to mean positive, it changes to plus symbol. When minus symbol attaches to value 0, it changes to plus symbol.

Example

Program into which operation changes by option

```plaintext
01 A PIC S9V9 VALUE -0.1
01 B PIC S9.

MOVE A TO B.
```

When SDS is specified, the decimal point of -0.1 is rounded down and -0 is stored in B.

When NOSDS is specified, the decimal point of -0.1 is rounded down, it becomes -0, convert of the sign is done, and +0 is stored in B.

A.1.41 SHREXT compile option

In cases where the object format is multithread (THREAD(MULTI) phrase), this option specifies whether to share data and files with the external attribute (EXTERNAL phrase) among multiple threads (SHREXT) or not (NOSHREXT).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>External data and files usage</td>
<td>Select whether to share data and files with EXTERNAL phrase among multiple threads or not. The default is NOSHREXT.</td>
</tr>
<tr>
<td>SHREXT</td>
<td>Share data and files with the EXTERNAL phrase among multiple threads.</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>NOSHREXT</td>
<td>Do not share data and files with the EXTERNAL phrase among multiple threads.</td>
</tr>
</tbody>
</table>

**Note**

If the object format is single thread (THREAD(SINGLE)), SHREXT is displayed for the fixed compilation option, but compilation is performed under the condition of NOSHREXT.

### A.1.42 SMSIZE compile option

This option specifies the amount of memory used by PowerBSORT, in kilobytes.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specified capacity of memory used by PowerBSORT</td>
<td>Specifies the amount of memory used by PowerBSORT, in kilobytes. The default is 0 KByte.</td>
</tr>
</tbody>
</table>

**Note**

- If the PowerBSORT product is installed, this option is valid. If PowerBSORT is not installed, this option is ignored.
- Specify this option to limit the memory space used by PowerBSORT, which is invoked by the SORT and MERGE statements. For details on whether a specified value is valid, see the online manual for PowerBSORT.
- This option is equivalent to the values specified for the execution-time option smsgize and the special register SORT-CORE-SIZE. If they are specified concurrently, the special register SORT-CORE-SIZE has highest priority, the execution-time option smsgize has second priority, and the SMSIZE () compile option has third priority.

**Example**

- Special register

  ```plaintext
  MOVE 102400 TO SORT-CORE-SIZE
  (102400 = 100 kilobytes)
  ```
- Compile option

  ```plaintext
  SMSIZE (500 KB)
  ```
- Execution-time option

  ```plaintext
  smsgize 300 KB
  ```

In the above example, the value of 100 KB for the special register SORT-CORE-SIZE, which has top priority, is used.

### A.1.43 SOURCE compile option

This option specifies whether to output a source program list (SOURCE) or not (NOSOURCE). If output, a source program list is output to the folder specified by the PRINT compile option.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output of the source program list</td>
<td>Specifies whether to output a source program list. The default is NOSOURCE.</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>------------------------------------</td>
</tr>
<tr>
<td>SOURCE</td>
<td>Outputs a source program list.</td>
</tr>
<tr>
<td>NOSOURCE</td>
<td>Does not output a source program list.</td>
</tr>
</tbody>
</table>

**Note**

If the PRINT compile option is not specified, no source program list is output, regardless of the specification of this option.

### A.1.44 SQLGRP compile option

This option specifies whether to expand the definition method of SQL host variables (SQLGRP) or not (NOSQLGRP). When NOSQLGRP is specified, a REDEFINE clause cannot be specified to the host variable.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQL host variable definition expansion</td>
<td>Specifies whether to expand the definition method of SQL host variables. The default is SQLGRP.</td>
</tr>
<tr>
<td>SQLGRP</td>
<td>Expands the definition method.</td>
</tr>
<tr>
<td>NOSQLGRP</td>
<td>Does not expand the definition method.</td>
</tr>
</tbody>
</table>

**Note**

When SQLGRP is specified, you cannot determine whether the data item has a correct format as a host variable just with the data description entry. This means that the syntax check for the host variable definitions during compilation differs as follows:

- The host variables not referenced in an embedded SQL statement are not subject to syntax check. Here, only the host variable names for the group items having global attribute are checked.
- More strict syntax check is made to variable-length character-type host variables. Group items containing items of level number 49 are handled as variable-length character-type host variables.

Specify NOSQLGRP for the conventional syntax check without using the host variables which are defined as group items.

### A.1.45 SRF compile option

This option specifies whether to use the fixed format, variable format or free format for the reference format types of COBOL source programs and library files.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source reference format</td>
<td>Specify the reference formats of a COBOL source program and library. “SRF and TAB compile option setting to be consistent with the applicable editor setting”. If the checkbox is selected, SRF setting is to be consistent with the applicable editor setting. The value of SRF is initialized according to the applicable editor setting.</td>
</tr>
<tr>
<td>Source program</td>
<td>To specify the reference format for a COBOL source program, select Fixed, Variable or Free for Source program.</td>
</tr>
<tr>
<td>Library text</td>
<td>To specify the reference format for a library, select Fixed, Variable or Free for Library text.</td>
</tr>
</tbody>
</table>

### A.1.46 SSIN compile option

This option specifies the data input source for the ACCEPT statement of the ACCEPT/DISPLAY function.
### A.1.47 SSOUT compile option

This option specifies the data output destination for the DISPLAY statement of the ACCEPT/DISPLAY function.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DISPLAY statement data output</td>
<td>Specifies the data output destination for the DISPLAY statement. The default is SSOUT(SYSOUT).</td>
</tr>
<tr>
<td>SSOUT</td>
<td>Uses a file as the data output destination.</td>
</tr>
<tr>
<td>SSOUT(SYSOUT)</td>
<td>Uses the console window as the data output destination.</td>
</tr>
<tr>
<td>Environment variable to specify an output file</td>
<td>Specifies the name of the environment variable that sets the output destination file.</td>
</tr>
</tbody>
</table>

Note: The environment variable information name must consist of eight or fewer upper-case letters and/or numeric characters, beginning with an upper-case letter (A to Z). The environment variable information name must not match one used by another file (file identifier name).

### A.1.48 STD1 compile option

This option specifies that alphanumeric codes (standard one-byte character codes) in the EBCDIC phrase of the ALPHABET clause be treated as ASCII codes (ASCII), JIS8 unit codes (JIS1), or JIS7 unit Roman letter codes (JIS2).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Treatment code of alphanumeric character EBCDIC in ALPHABET clause</td>
<td>Specifies how to treat alphanumeric codes in the EBCDIC phrase of the ALPHABET clause. The default is JIS2(JIS7 code).</td>
</tr>
<tr>
<td>ASCII(ASCII)</td>
<td>Uses EBCDIC (ASCII) for the character code convention set.</td>
</tr>
<tr>
<td>JIS1(JIS8 code)</td>
<td>Uses EBCDIC (kana) for the character code convention set.</td>
</tr>
<tr>
<td>JIS2(JIS7 code)</td>
<td>Uses EBCDIC (lower-case alphabetic characters) for the character code convention set.</td>
</tr>
</tbody>
</table>

### A.1.49 TAB compile option

This option specifies whether to treat the tab character as having a width of four columns (TAB(4)) or eight columns (TAB(8)).
### A.1.50 TEST compile option

This option specifies whether to enable the NetCOBOL Studio debugging function and the COBOL Error Report at the execution time (TEST) or not (NOTEST). If TEST is specified, a debugging information file for use by the NetCOBOL Studio debugging function and the COBOL Error Report is created. The file is usually stored in the same folder as that of the source program. You can use this option to change the storage folder.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using the debugger</td>
<td>Specifies whether to use the debugging function of NetCOBOL Studio. The default is NOTEST. If debugging is the target, NOTEST is cleared and EST is selected.</td>
</tr>
<tr>
<td>TEST</td>
<td>Uses the debugging function of NetCOBOL Studio.</td>
</tr>
<tr>
<td>NOTEST</td>
<td>Does not use the debugging function of NetCOBOL Studio.</td>
</tr>
<tr>
<td>Folder for debugging information</td>
<td>Specifies the debugging information file storage folder.</td>
</tr>
</tbody>
</table>

**Note**
- If this option is specified with OPTIMIZE, the debugging information file can be used by the COBOL Error Report, and cannot be used by the debugging function of NetCOBOL Studio. Do not specify OPTIMIZE when you use the debugging function of NetCOBOL Studio.
- When debugging, store the debugging information file in the same folder as the target file.

### A.1.51 THREAD compile option

This option specifies whether the object format is multithread (THREAD(MULTI)) or single thread (THREAD(SINGLE)).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type of thread mode</td>
<td>Specifies an attribute of an object file as multi-thread or single thread. The default is SINGLE.</td>
</tr>
<tr>
<td>MULTI</td>
<td>Specifies an attribute of an object file as multi-thread.</td>
</tr>
<tr>
<td>SINGLE</td>
<td>Specifies an attribute of an object file as single thread</td>
</tr>
</tbody>
</table>

### A.1.52 TRACE compile option

This option specifies whether to use the TRACE function (TRACE) or not (NOTRACE).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tracing procedure names</td>
<td>Specifies whether to use the TRACE function. The default is NOTRACE.</td>
</tr>
<tr>
<td>TRACE</td>
<td>Uses the TRACE function.</td>
</tr>
<tr>
<td>NOTRACE</td>
<td>Does not use the TRACE function.</td>
</tr>
</tbody>
</table>
### Note

- If TRACE is specified, processing to display trace information is embedded in an object program, decreasing execution performance. After debugging, recompile the program with NOTRACE specified.
- TRACE cannot be specified together with the COUNT compile option. If both of these options are specified together, the option specified last is valid.

#### A.1.53 TRUNC compile option

This option specifies whether to truncate upper digits in numeric characters when converting into binary (TRUNC), or to give priority to execution speed regarding truncation (NOTRUNC).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Truncation of high-order digits when converting into binary items</td>
<td>Specifies whether to truncate the upper digits of numeric characters when converting to binary. The default is NOTRUNC.</td>
</tr>
<tr>
<td>TRUNC</td>
<td>Truncates the number of upper digits according to the PICTURE clause of the receiving-side item, and saves the resultant value in the receiving-side item. If this item is specified with the OPTIMIZE compile option, optimization truncates the number of upper digits of data items that are from zoned decimal items or packed decimal items. The number of upper digits is truncated as described above only if the number of digits in the integer part of the sending-side item is greater than that of the receiving-side item.</td>
</tr>
<tr>
<td>NOTRUNC</td>
<td>Gives priority to the object program execution speed. If the execution speed would be higher without truncation of the upper digits, the digits will not be truncated.</td>
</tr>
</tbody>
</table>

#### Point

In the PICTURE clause:
- Moving S999V9 (three-digit integer part) to S99V99 (two-digit integer part): The digits are truncated.
- Moving S9V999 (one-digit integer part) to S99V99 (two-digit integer part): The digits are not truncated.

#### Note

- If NOTRUNC is specified and the number of digits in the integer part of the sending-side item is greater than that of the receiving-side item, the results are not defined.
- To specify NOTRUNC, the applicable program must be designed such that no value exceeding the digit number in the PICTURE clause is stored in the receiving-side item, even if the truncation of digits is not applied.
- The criteria for whether to truncate the digits in cases where NOTRUNC is specified are different for different compilers. The compatibility with another system is not guaranteed for a program that depends on the specification of NOTRUNC to suppress truncation.
A.1.54 XREF compile option

This option specifies whether to output a cross reference list (XREF) or not (NOXREF). A cross reference list displays information such as user-defined words and special registers in ascending order of the collating sequence. If XREF is specified, the cross reference list is output to the folder specified by the PRINT compile option.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output of the cross-reference list</td>
<td>Specifies whether to output a cross reference list. The default is NOXREF.</td>
</tr>
<tr>
<td>XREF</td>
<td>Outputs a cross reference list.</td>
</tr>
<tr>
<td>NOXREF</td>
<td>Does not output a cross reference list.</td>
</tr>
</tbody>
</table>

**Note**

- If the PRINT compile option is not specified, no cross reference list is output regardless of the specification of this option.
- If the maximum severity code is S level or higher as a result of compilation with the XREF compile option specified, output of a cross reference list is suppressed.

A.1.55 ZWB compile option

In a comparison between a signed zoned decimal item and an alphanumeric character field, this option specifies whether to ignore the sign part of the zoned decimal item (ZWB) or not (NOZWB). Here, an alphanumeric character means an alphanumeric data item, alphabetic item, alphanumeric edited data item, numeric edited data item, nonnumeric literal, or figurative constant other than ZERO.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comparison of signed external decimal item and alphanumeric item</td>
<td>Specifies a method for comparing a signed zoned decimal item and an alphanumeric character field. The default is ZWB.</td>
</tr>
<tr>
<td>ZWB</td>
<td>Compares the items ignoring the signed part.</td>
</tr>
<tr>
<td>NOZWB</td>
<td>Compares the items including the signed part.</td>
</tr>
</tbody>
</table>

**Example**

77 ED PIC S9(3) VALUE +123.
77 AN PIC X(3) VALUE "123".

Under these conditions, the logical value of the conditional expression ED = AN is as follows:

- If ZWB is specified ... True
- If NOZWB is specified ... False
Appendix B Troubleshooting Guide

B.1 Build Problems

B.1.1 After a resource is updated with an external editor, build is not executed when Build Project or Build All is selected.

**Issue:** Resource changes have not been reflected in the workspace concerned.

**Solution:** Take any of the following actions:

- Select **Window > Preferences > General > Workspace** from the menu bar, and then select “Refresh automatically”. If this option is selected, resources in the workspace are automatically synchronized with the corresponding resources in the file system.

- When an external editor has been used to update a resource, before executing a build, select the updated resource or the folder containing it in the **Dependency** or **Structure view**, and then select **File > Refresh** from the menu bar.

B.1.2 A message "repository file (*.rep) was not found" is displayed in a dependency analysis.

**Issue:** The **Console view** displays the following error message in a dependency analysis:

full-path-name-for-a-cobol-source-file: line-number: repository-file-name: does not exist.

**Solution:** Check for the following:

- A repository file of COBOL source files in the project. Since a project contains no repository file immediately after the project is created or cleaned, this error message is displayed. Repository files are created when a build for the project is executed, so no special response is required for this message.

- A repository file outside the project. Confirm that coding in the COBOL source files is correct and that all the necessary repository files have been provided.

B.1.3 A static library (lib) cannot be made

**Issue:** Static library (lib) cannot be made with NetCOBOL Studio though executable file (exe) or dynamic link library (dll) can be made.

**Solution:** Use the LIB command to make static library (lib). Refer to the technical intelligence of Microsoft Corporation for detail of the LIB command.

B.2 Debugger problems

B.2.1 Menu items in the Run menu cannot be used during debugging.

**Issue:** The following menu items in the Run menu are grayed out and their functions are disabled during debugging of a COBOL application:

- Run to Line
- Use Step Filters
- Watch
- Inspect
- Display
- Execute
- Step Into Selection
- Toggle Line Breakpoint
- Toggle Method Breakpoint
- Toggle Watchpoint

**Solution:** These menu items are used for debugging a Java application, and cannot be used for a COBOL application.

- To add or delete a breakpoint, right-click on the vertical ruler of the COBOL editor, and select *Add Breakpoint* or *Remove Breakpoint* from the context menu.

- To execute a program up to the specified line, select "Run to Line" from the context menu of the COBOL editor.

**B.2.2 Values of data items outside the scope are displayed during debugging.**

**Issue:** Values of data items outside the scope are also displayed, but they are not correct values.

**Solution:** Do not use the values displayed for data items outside the scope.

**B.2.3 An error dialog box containing the message "Target executable not found. Could not proceed" appears.**

**Issue:** If a COBOL application is executed or debugged in a workspace created by copying or moving a workspace folder containing the COBOL project, an error dialog box containing the message "Target executable not found. Could not proceed." appears.

**Solution:** Although the workspace folder containing the COBOL project was copied or moved, the path name used before the copy or move remains defined in Executable file on the Main tab of Debug or Run for the COBOL application. This discrepancy causes this message. In this case, click the Browse button of Project name on the Main tab of Debug or Run, and select the project name again in the Project Selection dialog box. The path name is changed to the correct one.

**B.2.4 Program execution cannot be restarted after it stops at a breakpoint.**

In the Debug view, if a selection is made outside the tree element displaying the path of the program being debugged, the program remains stopped even if "Resume" or "Step Into" is selected to restart program execution.

**Solution:** In the Debug view, make a selection from the tree element displaying the path of the program, and then select "Resume" or "Step Into" to restart program execution.

**B.3 Execution Problems**

**B.3.1 A runtime error occurs when an executable file is double-clicked.**

**Issue:** When you double-click an executable file (.exe), a runtime initialization failure occurs.

**Solution:** See Chapter 8 Execution Function", and verify that the correct folder is specified in the Working folder field.

**B.4 Remote Development Problems**

**B.4.1 The stty command causes an error in link with a server.**

**Issue:** The stty command causes an error and fails when linking to a Solaris or Linux server that uses the ftpd/rexec service.

**Solution:** Comment out the stty command coded in the .bashrc file (if bash is used) or .cshrc file (if csh is used).

Before modification:

```
stty erase ^H
```

After modification:

```
#stty erase ^H
```
B.4.2 NetCOBOL Studio freezes when linking with a server.

**Issue:** The server does not respond when linking to a Solaris or Linux server that uses the ftpd/rexec service and NetCOBOL Studio freezes.

**Solution:** This problem occurs when the .bashrc file (if bash is used) or .cshrc file (if csh is used) has been coded with a script that requests user input and involves waiting for a response. Delete the script that causes waiting for a response, such as one that requests user input, from the file.

B.4.3 The error message "Error occurred while sending command. Remote computer reset connection" is displayed.

**Issue:** The "Error occurred while sending command. Remote computer reset connection," error occurs when linking to a Solaris or Linux server that uses the ftpd/rexec service, and connection to the server is not possible.

**Solution:** The domain name system (DNS) controls domain names and IP addresses. With some DNS settings, the rexec daemon fails in a reverse search for the host name of a personal computer connected to the server. Edit the /etc/hosts file on the server to add the following information about the client personal computer:

<table>
<thead>
<tr>
<th>IP address</th>
<th>host name</th>
</tr>
</thead>
</table>

B.4.4 The line feed code is not converted when a text file is transferred.

**Issue:** If vsftpd is used for file transfer (FTP) in Linux server remote development, when a text file is transferred the line feed codes remain as Windows line feed codes (0x0d0a) rather than changing to Unix line feed codes (0x0a).

**Solution:** To enable conversion of the line feed code, delete # at the beginning of the following lines, which are commented out, in the /etc/vsftpd/vsftpd.conf file:

**Before modification**

```ini
#ascii_upload_enable=YES
#ascii_download_enable=YES
```

**After modification**

```ini
ascii_upload_enable=YES
ascii_download_enable=YES
```

B.4.5 The error message "Parameter of server command is invalid" is displayed when using remote development functions.

**Issue:** The line feed code is not converted according to vsftpd settings.

**Solution:** To enable conversion of the line feed code, delete # at the beginning of the following lines, which are commented out, in the /etc/vsftpd/vsftpd.conf file:

**Before modification**

```ini
#ascii_upload_enable=YES
#ascii_download_enable=YES
```

**After modification**

```ini
ascii_upload_enable=YES
ascii_download_enable=YES
```

B.4.6 Local project build runs when starting remote debug.

**Issue:** The Build (if required) before launching checkbox is checked.

**Solution:** Following the steps below to uncheck the checkbox.

1. Select **Window > Preferences** from the menu bar. The **Preferences** dialog box is displayed.
2. Select Run/Debug > Launching from the left pane. The Launching page is displayed.

3. Uncheck the Build (if required) before launching checkbox in the General Options group box.

B.4.7 Nothing appears in the Problems view even though the remote build failed.

For remote builds, the Problems view displays only compile errors. To check other errors, select "COBOL Remote" from the toolbar icon ("Open Console") in the Console view.

B.5 NetCOBOL Studio General Problems

B.5.1 An error dialog box stating "for details refer to log" appears.

**Issue:** An error occurs directing you to refer to the log for more information.

**Solution:** The log can be referenced by selecting Help > About NetCOBOL Studio(x64) from the menu bar, selecting "Configuration Details" in the dialog box that appears, and then selecting "View Error Log" in the Configuration Details dialog box.

To display the Error Log view and reference the log:

1. On the Window menu, click Show View > Other.
2. Select General > Error Log in the tree in the Show View dialog box that appears.
3. Click OK to display the Error Log view.

Information such as when each workspace was created, when NetCOBOL Studio was started, and what errors have occurred in NetCOBOL Studio are recorded in the log. Some log information will indicate normal NetCOBOL Studio operation. Problems are recorded at the time they occur in NetCOBOL Studio. If no NetCOBOL Studio operation problems are indicated in the error log, the error dialog box display may be caused by an erroneous operation, such as trying to do a build for remote development with incorrect server information. If a NetCOBOL Studio operation problem does occur in the error log, collect the log information listed below and contact a Fujitsu certified service engineer.

The log files are created in the following folder:

```<work-space-folder>\.metadata\```

The log files are named as follows:

```
.bak_0.log
.bak_1.log
.
.
.bak_9.log
```

Existing log files contain information sorted in descending time stamp order, with the most recent item at the top of the list.

B.5.2 Entire message containing "..." cannot be displayed.

**Issue:** If a message to be displayed in a dialog box is longer than the message display field, the middle of the message may be represented by "...".

**Solution:** The entire message can be displayed using one of the following methods:

- Move the mouse cursor onto the displayed message whose middle part is omitted. A tooltip appears displaying the entire message.
- If the dialog box can be resized, expand the width of the dialog box so that the entire message can be displayed.

B.5.3 Files, folders, and projects cannot be deleted.

**Issue:** If a file is generated with a path that exceeds the maximum value for file system path lengths, deletion fails for that file and for the folder and project that include that file.
Solution: Use the method below to delete the file and folder

```
java -classpath (NetCOBOL install folder) \eclipse\f5drprfc.jar RemoveFolderContents folder name
```

This command requests confirmation on each file and folder in the specified folder, before deleting them. The specified folder itself is not deleted.

### B.5.4 The Export of COBOL Project Fail

**Issue:** After a resource is updated with an external editor, changes are not reflected in the workspace.

**Solution:** Take any of the following actions:

- Select `Window > Preferences > General > Workspace` from the menu bar, and then select "Refresh automatically". When this option is selected, resources in the workspace are automatically synchronized with the corresponding resources in the file system.

- When an external editor is used to update a resource, before executing the export, select the updated resource, or the folder containing it in the **Dependency** or **Structure view**, and then select "Refresh" from the context menu.

### B.6 Trace log

Eclipse has the tracing function that output the execution state of Plug-in to logs. This function facilitates inquiry of causes at the occurrence of troubles.

To use the tracing function in NetCOBOL Studio, select `Window > Preferences > General > Tracing > Enable tracing`.

Please output to log when asked by Fujitsu certified service engineer.

The default select state is off, but it is recommended to check box.
Appendix C Handling of Workspace and Project

This section explains the handling of workspace and project.

C.1 Default workspace

The default workspace is in the following folder. It is created when NetCOBOL Studio is first started.

```
My documents folder (*) \NetCOBOL Studio V12.0.0(x64)\workspace4.6
```

*: The “My documents” folder is used to save each user's data. The location of the “My documents” folder varies based on the Windows OS.

C.2 Setting and switch method of workspace

Workspace

A workspace is the place where development resources and the user's working state are maintained. Development resources are managed in the workspace as a project. Multiple projects can be created in a workspace. The working state is information such as workbench setting and the break point set in the source file, and is maintained in the workspace.

The workspace can fall into several categories, such as workspace for development, workspace for investigation, and workspace for test.

Note

- A workspace can be shared among multiple users or machines, but the same workspace cannot be used among multiple Eclipse bases at the same time.
- A project can be placed out of workspace folder, but do not refer to the same project in multiple workspaces. If a project is used by multiple workspaces, the alteration of project information cannot function normally.

C.2.1 Setting workspace

The Workspace is set using the Setup Configuration dialog box according to the following procedures.

1. Click Start, select Fujitsu NetCOBOL V12(x64) > NetCOBOL Studio(x64). NetCOBOL Studio is started.
2. Click the **Setup...** button. The **Setup Configuration** dialog box is displayed.

![Setup Configuration dialog box]

3. Click the **Add** button. The **Select Folder** dialog box is displayed.

4. Select the folder used as the workspace. A "New folder" is made in the selected folder when the **Make New Folder** button is clicked. It can be used by changing the name.

![Select Folder dialog box]

Select a folder, and click the **OK** button. In this example, "C:\NetCOBOL Studio\workspace" is set as the new workspace.
5. Click the **Yes** button since the following message box is displayed.

![NetCOBOL message box]

The list of workspaces is displayed in the "Workspace folder name".

6. Select the Workspace, and click the **OK** button.

![Setup Configuration dialog box]

NetCOBOL Studio Start screen displays.

7. Click the **Run** button on the Start screen.

NetCOBOL Studio is started. The Workspace becomes "C:\NetCOBOL Studio\workspace".

**Point**

When NetCOBOL Studio starts next time, this setting becomes effective.

---

### C.2.2 Switch of workspace

The Workspace can be switched to another workspace when NetCOBOL Studio is active.

1. In the **File** menu, click **Switch Workspace > Other**. The **Workspace Launcher** dialog box appears. The present workspace is displayed in "workspace".

2. Enter the switched new workspace name for "Workspace" using the full path. The folder can be selected by using the **Browse** button.
Moreover, when the "Workspace" drop-down button is selected, the history of the workspaces used so far is displayed. The Workspace can be selected from the list displayed.

3. Click the OK button.

NetCOBOL Studio is re-started. The Workspace becomes the specified workspace.

C.3 Importing Project

In the following cases, the projects are imported and used.

- When you want to use the project made in Windows 32bit NetCOBOL Studio in Windows 64bit NetCOBOL Studio.

Use the following method to import an existing project in batch mode.

1. Set the workspace of the copy destination, and start NetCOBOL Studio.
2. Select File > Import from the NetCOBOL Studio menu bar. The Import wizard is started.
3. Select General > Existing Projects into Workspace, and click the Next button.
4. Select "Select root directory", and click the Browse button. The Browse For Folder dialog box is displayed.
5. Select the workspace folder that includes the project, and click the OK button.
6. Confirm that the projects are displayed in the "Projects" section, click the Select All button. Select "Copy projects into workspace", and click the Finish button.

Note

A link error might occur when "Build" is selected for output files that are built on each different platform.

In case of the first time building projects that are imported from NetCOBOL Studio on each different platform, select "Rebuild".
Appendix D Various Specification Formats used in Debugging

This section explains various specification formats used in the Watch view.

D.1 Identifier Name

When adding data items for monitoring to the Watch view, use the identifier name as data name.

One of the following is the identifier name.
- Identifier
- Condition-name
- Index Name
- Special Register
- Symbolic-constant
- Named Literal
- Function

It is necessary to enclose the identifier name in parenthesis when it contains spaces. See the example below.

```
LIST (DATA01 OF DATA02)
```

Identifier

The identifier can be specified with the same scope of COBOL language specifications in debugging.

In addition, the data described in the factory definition and the object definition can be handled from external, by using the same specification as the original identifier.

**Specification Format of Identifier**

It is the same as the language specification of COBOL with the exception of the following restrictions for subscript and reference modifier.

- Subscript is specified by the following formats.

```
  Subscript                       \{ Integer | Identifier[ \{+|-\}Integer ] | Index Name[ \{+|-\}Integer ] | Symbolic-constant[ \{+|-\}Integer ] | Named Literal[ \{+|-\}Integer ] \}
```

- Reference modification is specified by the following formats.

```
  Reference Modifier             \{ High order end character position: [Length] \}
    \{ Integer | Identifier[ \{+|-\}Integer ] | Symbolic-constant[ \{+|-\}Integer ] | Named Literal[ \{+|-\}Integer ] \}
```

- Predefined object identifier can be specified except SUPER.
- Identifier is specified by the following formats. Underlined part is the part which is extended originally.
### Identifier

| Identifier | \[\{pointer qualifier | object reference qualifier\} data name \[\{IN | OF\} data name\]... \[\{IN | OF\}{file name | report-name \}]\[\{\{subscript\}...\}\] | [reference modifier ] |

**Pointer Qualifier**

\[\{\} ... \{object reference qualifier\}\{\{data name\{IN | OF\}data name \}...\} \{\{data name\{IN | OF\} data name\}...\{\{subscript\}...\}\} | ADDR function \rightarrow \{\{data name\{IN | OF\}data name \}...\} \{\{data name\{IN | OF\} data name\}...\{\{subscript\}...\}\} \rightarrow \]

**Object Reference Qualifier**

| Object Reference Qualifier | \{class-name\{predefined object identifier SUPER \} :: | object reference item \{\{IN | OF\}data name \}... \{\{\{subscript\}...\}\} | predefined object identifier SUPER \} :: |... |

**Predefined Object Identifier**

| Predefined Object Identifier SUPER | AS class-name |

- Identifier is specified by the internal name under the class condition.
- Object reference qualifier is specified under the condition that handling data which is described in factory definition or object definition from external. The class-name of object reference qualifier specifies the internal name.
- Under the condition that identifying super-class data, predefined object identifier SUPER specifies the super-class name. Super-class name specifies the internal name or the external name.

### Condition-name

Condition-name can be specified with the same scope of COBOL language specifications in debugging.

In addition, the condition-name described in the factory definition and the object definition can be handled from external, by using the same specification as the original condition-name.

**Specification Format of condition-name**

It is the same as the language specification of COBOL with the exception of the following restrictions for subscript.

- Subscript is specified by the following formats.

| Subscript | \{Integer \} | Identifier\{+ | -Integer \} || Index Name\{+ | -Integer \} || Symbolic-constant\{+ | -Integer \} || Named Literal\{+ | -Integer \} |

- Condition-name is specified by the following formats. The underlined part is the part that is extended originally.

| Condition-name | \{\{pointer qualifier | object reference qualifier\} condition-name \{\{IN | OF\} data name\}... \{\{IN | OF\}{file name} |

- 186 -
<table>
<thead>
<tr>
<th>Pointer Qualifier</th>
<th>([{subscript}...])</th>
</tr>
</thead>
<tbody>
<tr>
<td>{object reference qualifier}</td>
<td></td>
</tr>
<tr>
<td></td>
<td>[ ] ...</td>
</tr>
<tr>
<td></td>
<td>{object reference qualifier}</td>
</tr>
<tr>
<td></td>
<td>[ ] data name [{IN</td>
</tr>
<tr>
<td></td>
<td>(data name [{IN</td>
</tr>
<tr>
<td></td>
<td>ADDR function</td>
</tr>
<tr>
<td></td>
<td>-&gt; [{ data name [{IN</td>
</tr>
<tr>
<td></td>
<td>(data name [{IN</td>
</tr>
<tr>
<td>Object Reference Qualifier</td>
<td>[class-name [predefined object identifier SUPER ] :: ]</td>
</tr>
<tr>
<td></td>
<td>[object reference item [{IN</td>
</tr>
<tr>
<td></td>
<td>([{subscript}...])</td>
</tr>
<tr>
<td></td>
<td>[predefined object identifier SUPER] :: ] ...</td>
</tr>
<tr>
<td>Predefined Object Identifier SUPER</td>
<td>AS class-name</td>
</tr>
</tbody>
</table>

- Object reference qualifier is specified under the condition that handling condition-name which is described in factory definition or object definition from external. The class-name of the object reference qualifier specifies the internal name.
- Under the condition that identifying super-class data, predefined object identifier SUPER specifies the super-class name.Super-class name specifies the internal name or the external name.

**Index-name**

Index-name can be specified with the same scope of COBOL language specifications in debugging.

In addition, the index-name described in the factory definition and the object definition can be handled from external, by using the same specification as the original index-name.

**Specification Format of Index-name**

It is the same as the language specification of COBOL. The underlined part is the part that is extended originally.

<table>
<thead>
<tr>
<th>Index-name</th>
<th>[object reference qualifier] index-name</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>[{IN</td>
</tr>
<tr>
<td></td>
<td>[{IN</td>
</tr>
<tr>
<td>Object Reference Qualifier</td>
<td>[class-name[predefined object identifier SUPER ] :: ]</td>
</tr>
<tr>
<td></td>
<td>[object reference item [{IN</td>
</tr>
<tr>
<td></td>
<td>([{subscript}...])</td>
</tr>
<tr>
<td></td>
<td>[predefined object identifier SUPER] :: ] ...</td>
</tr>
<tr>
<td>Predefined Object Identifier SUPER</td>
<td>AS class-name</td>
</tr>
</tbody>
</table>

- Object reference qualifier is specified under the condition that handling index-name which is described in factory definition or object definition from external. The class-name of the object reference qualifier specifies the internal name.
- Under the condition that identifying super-class data, predefined object identifier SUPER specifies the super-class name. Super-class name specifies the internal name or the external name.

**Special Register**

Special register can be specified with the same scope of COBOL language specifications in debugging.
**Symbolic-constant**
Symbolic-constant can be specified with the same scope of COBOL language specifications in debugging.

**Named Literal**
Named literal can be specified with the same scope of COBOL language specifications in debugging.

**Function**
The following functions can be specified in debugging.

<table>
<thead>
<tr>
<th>Function</th>
<th>FunctionADDR Function</th>
<th>LENG Function</th>
<th>LENGTH Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADDR Function</td>
<td>FUNCTION ADDR( argument )</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LENG Function</td>
<td>FUNCTION LENG( argument )</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LENGTH Function</td>
<td>FUNCTION LENGTH( argument )</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- The argument of the ADDR function must be an identifier beyond Internal Boolean data item and object reference item.
- The argument for the LENG function and LENGTH function must be either data item, nonnumeric literal, hexadecimal nonnumeric literal or national nonnumeric literal.

**D.2 Program name**
The specification formats for program name are as follows.

{external program name | [external program name].internal program name | [class-name] :method-name}

- external program name
  Specify program definition (external program).
- [external program name].internal program name
  Specify program definition (internal program). It is considered that an external program name of implied program name is specified when the external program name is omitted. The internal program name referred here is the program that contains the external and internal program.
- [class-name]:method-name
  Specify method definition (factory) or method definition (object). When a user-defined property method is specified, refer to Specification Formats of Property Method. It is considered that class-name of implied program name is specified when the class-name is omitted.

To use a program name that contains a period (.), colon (: ) or other special character, specify the external name and internal name with a nonnumeric literal.

**Specification Formats of Property Method**
When debugging a user-defined property method, specify the method-name using the following formats.

- GET method _ GET _ property name
- SET method _ SET _ property name

**D.3 Conditional Expression**
A conditional expression can be specified in the following format:

- Conditional expression:
  or-condition-of-compound-conditions
- or-condition-of-compound-conditions:
  { and-condition-of-compound-conditions
   or-condition-of-compound-conditions OR and-condition-of-compound-conditions }

- and-condition-of-compound-condition:
  { relational-condition-of-simple-conditions
   and-condition-of-compound-conditions AND relational-condition-of-simple-conditions }

- relational-condition-of-simple-conditions:
  { identifier | literal | arithmetic-expression | index-name | symbolic-constant | named literal | addr-function
   relational-operator
   identifier | literal | arithmetic-expression | index-name | symbolic-constant | named literal | addr-function }

- relational-operator:
  { [IS][NOT] GREATER [THAN] ]
  [IS][NOT] LESS [THAN] ]
  [IS][NOT] EQUAL [TO] ]
  [IS][NOT] > ]
  [IS][NOT] < ]
  [IS][NOT] = ]
  [IS] GREATER [THAN] OR EQUAL [TO] ]
  [IS] >= ]
  [IS] LESS [THAN] OR EQUAL [TO] ]
  [IS] <= ]

- addr-function:
  FUNCTION ADDR ( argument )

Literal must not be specified on both the left side and right side of a conditional expression.

One or more spaces must be placed before and after the logical operators OR or AND. No spaces need be placed before or after the relational operators >, <, =, >= and <=.

If one of the following conditional expressions is used, the relational operator must be "[IS][NOT]EQUAL[TO]" or "[IS][NOT]=".

- A relational condition for Boolean objects
- A relational condition for point data (including the ADDR function)
- A relational condition for an object reference item
- A relational condition for a class name
- A relational condition for a defined object (NULL and NULL cannot be compared.)

The argument of the ADDR function must be an identifier other than an internal Boolean data item or object reference item.

To specify spaces in a conditional expression, the conditional expression must be enclosed in parentheses.
Appendix E  Transition from Project Manager

This section explains how to transfer COBOL application development environment from NetCOBOL project manager for Windows (x86) to NetCOBOL Studio, and how to use the project organization converting command that is the transference support tool.

E.1 Difference Between Project Manager and NetCOBOL Studio

Project manager and NetCOBOL Studio are both development environment tools for developing COBOL applications. Project manager has provided as COBOL development environment tool in NetCOBOL for Windows(x86) from the older version of NetCOBOL for Windows. Now, more companies are using COBOL alongside of JAVA, and the NetCOBOL Studio IDE allows people to choose a more flexible development environment in terms of easily linking in multiple types of objects. And since the NetCOBOL studio is developed in open-source Eclipse, it is a very flexible and extensible development environment.

Note

NetCOBOL Studio is the only allowable development IDE for NetCOBOL for Windows(x64). You cannot use the NetCOBOL Project Manager for development in that environment.

Projects developed in different IDEs use different storage methods; thus, projects are stored in NetCOBOL Project Manager and NetCOBOL Studio with different internal formats. Particularly in NetCOBOL Studio, it is imperative to store projects in a directory structure that exactly matches that shown in the IDE workspace. The same is not true with NetCOBOL Project Manager. When you convert from NetCOBOL Project Manager to NetCOBOL Studio, you will need to handle the differences in how the individual components of the project are actually stored.

Project Manager

The Project Manager is a tool to manage the resources and the compiler options as a project.

The project manager can register two or more targets (dynamic link library (.DLL) or executable file (.EXE)) in one project file. And the place of the managed resource files can be flexibility decided.
NetCOBOL Studio

Based on Eclipse, an open-source integrated development environment, the COBOL development environment includes assist functions for COBOL program development. In NetCOBOL Studio, folders called Projects are used for creating target files, and managing necessary information such as resources and compile options. It is necessary to configure COBOL source files and target files in the project folder. In addition, it is necessary to create or import a project in the user's workspace in NetCOBOL Studio.
E.2 Project Transition Procedure

The procedure for changing a project in project manager to a project in NetCOBOL Studio is as follows.
(1) Understand the original project configuration
Organize the resources managed by the Project manager project.

(2) Understand the destination project configuration
Become familiar with the resources that are managed in the NetCOBOL Studio project and how they are arranged.

(3) Back up the original project
It is recommended that you back up the conversion source project before using the project configuration conversion command.

(4) Create a shared resources project
Create a COBOL resource project on NetCOBOL Studio, and then copy the shared file that is used by multiple projects, which contains the library and descriptor, into the COBOL resource project.

One method for creating a COBOL resource project is to use the wizard provided by NetCOBOL Studio. Another method is to use the project configuration conversion command.
a. Using NetCOBOL Studio
   2. Select File > New > COBOL Resource Project from menu bar to start the wizard for creating a COBOL resource project.
   3. Run the wizard, and follow the instructions to create the OBOL resource project. For details, refer to the “4.2.3 COBOL resource generation wizard”.
   4. Copy the existing shared COBOL resource into the created COBOL resource project. For details, refer to “4.5.1 Adding the existing COBOL resource.

b. Using the Project configuration conversion command
   1. Use the "E.3.2 COBOL Resource Project Writer Module e” of the project configuration conversion command. This function executes the procedure from step 2 to step 4. For details, refer to "E.3.2 COBOL Resource Project Writer Module”.
   2. Use the import function of NetCOBOL Studio to import a COBOL resource project that has been created into any workspace.

(5) Convert the Project Organization
Create NetCOBOL Studio COBOL project in each target (exe and dll). Copy the COBOL resources into the COBOL project folder. The compiler option with the path specification changes according to the COBOL project configuration of NetCOBOL Studio.

a. Using NetCOBOL Studio
   1. Start NetCOBOL Studio
   2. Select File > New > COBOL Project from the menu bar to start the wizard for creating a COBOL project.
   3. Follow the wizard instructions to create a COBOL project that corresponds to the target file. For details, refer to "4.2.2 COBOL Project generation Wizard”.
   4. Add the existing COBOL resource into the COBOL project. For details, refer to "4.4.1 Adding Existing COBOL Resources”.
   5. Select File > New > COBOL Solution Project from menu bar to start the wizard for creating a COBOL solution project.
   6. Follow the wizard instructions to create a COBOL solution project that corresponds to the project manager project file. For details, refer to "4.2.1 COBOL solution generation wizard”.
   7. Add the COBOL project into the COBOL solution project.
   8. Set the build options in the COBOL solution project property dialog box.
   9. Deselect the Enable project specific setting checkbox in the build page of every COBOL project. When building a COBOL project, build options of the COBOL solution project become effective. For details, refer to "4.3.3 Setting common options for the projects”.
10. When using a precompiler, add the precompiler build tool in the property dialog box of the COBOL solution project. For details, refer to "6.2.3 Creating a COBOL program by using the precompiler”.

b. The Method of using Project Configuration Conversion Command
   a. Use the "Project Organization-converting Function” of the project configuration conversion command. This function does processing from step 2 to 10 when above-mentioned Using NetCOBOL Studio. For details, refer to “E.3.3 Usage of Project Configuration Conversion Command (PM2NS Command) “. Confirm the project configuration conversion command output message. If necessary, change the conversion destination project setting after starting NetCOBOL Studio.
   b. Using the Import function of NetCOBOL Studio, import the COBOL solution project and the COBOL project that has been created in any workspace.

(6) Confirm the destination project
Confirm the project organization of NetCOBOL Studio and make sure that it can be built correctly.
When the conversion destination project is converted with the project configuration conversion command, confirm the message that is output at the time of converting and correct the conversion destination project setting as necessary.

### E.3 Transition of Project According to Project Configuration Conversion Command

Provide the project configuration conversion command as a transfer support tool in order to convert the project in project manager to the project in NetCOBOL Studio. In the following two functions are parts of the project configuration conversion command.

- Function that converts the project in project manager to the project in NetCOBOL Studio (project organization-converting function).
- Function that summarizes shared files such as library and create COBOL resource project (COBOL resource project created function).

#### E.3.1 Project Configuration Conversion Function

A NetCOBOL Studio project creates a target. As the project manager, when setting common build options for multiple targets, set the same build options for all COBOL projects, or use a COBOL solution project. For more about COBOL solution projects, refer to "4.1.1 COBOL Solution project".

The project configuration conversion command provides a function that converts the project manager project to a COBOL solution project, and converts every target to a COBOL project.

It is necessary for the following COBOL resource files to exist in the COBOL project folder in the NetCOBOL Studio COBOL project. Therefore, the project configuration conversion command copies those files into the project folder or the subfolder of the project folder.

<table>
<thead>
<tr>
<th>Table E.1 COBOL resource</th>
</tr>
</thead>
<tbody>
<tr>
<td>File Types</td>
</tr>
<tr>
<td>COBOL source file (input of compiler)</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Library file (input of compiler)</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Descriptor file (input of compiler)</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Repository file (input of compiler)</td>
</tr>
<tr>
<td>Other files</td>
</tr>
<tr>
<td>Object file(input of linker)</td>
</tr>
<tr>
<td>Library file(input of linker)</td>
</tr>
<tr>
<td>File Types</td>
</tr>
<tr>
<td>----------------------------------------</td>
</tr>
<tr>
<td>Include file (input of precompiler)</td>
</tr>
<tr>
<td>Object file (output of compiler)</td>
</tr>
<tr>
<td>Debugging information file (output of compiler)</td>
</tr>
<tr>
<td>SAI file (output of compiler)</td>
</tr>
<tr>
<td>Target repository file (output of compiler)</td>
</tr>
<tr>
<td>Target file (output of linker)</td>
</tr>
<tr>
<td>MAP file (output of linker)</td>
</tr>
<tr>
<td>Resource script file (output of project manager)</td>
</tr>
<tr>
<td>Resource file (output of project manager)</td>
</tr>
</tbody>
</table>

In addition, when files with the same name exist in the conversion destination folder and the -F option is not specified, the project configuration conversion command outputs an error and stops conversion.

### E.3.2 COBOL Resource Project Writer Module

Use a project relative path specification to refer to shared files such as library in the NetCOBOL Studio COBOL resource project. When using compile options such as LIB and referring to shared files such as library by relative path in project manager, by adding shared files in the NetCOBOL Studio COBOL resource project, compile options can be specified by relative path even in the NetCOBOL Studio project.

The project configuration conversion command summarizes shared files such as library, and provides the function for creating the COBOL resource project. For details, refer to "E.3.3 Usage of Project Configuration Conversion Command (PM2NS Command) ".

### E.3.3 Usage of Project Configuration Conversion Command (PM2NS Command)

Use the project configuration conversion command at the NetCOBOL command prompt.

**Project Configuration Conversion Function**

```
PM2NS [options list] [project manager project file]
```

**COBOL Resource Project creation Function**

```
PM2NS [options list] -RCOBOL-resource-project-name -Ishared-files-original-folder
```
<table>
<thead>
<tr>
<th>Options</th>
<th>Specify whether or not</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-R COBOL-resource-project-name</td>
<td>Yes</td>
<td>When creating a COBOL resource project, specify the COBOL resource project name.</td>
</tr>
<tr>
<td>-I shared-files-original-folder</td>
<td>Yes</td>
<td>-R option must be specified. When creating a COBOL resource project, specify the original shared file path.</td>
</tr>
<tr>
<td>-O output-folder</td>
<td>Yes</td>
<td>Specify the project output folder. When options are omitted, the output folder is the current folder. In the output folder, create a project folder used for NetCOBOL Studio, and then create the file or copy the file from the original folder.</td>
</tr>
<tr>
<td>-F</td>
<td>Yes</td>
<td>When an error occurs at the time of converting, output a warning message and continue to convert.</td>
</tr>
<tr>
<td>-E extent</td>
<td>Yes</td>
<td>When creating a COBOL resource project, specify the extent of shared files that are copied. When options are omitted, copy all files. When multiple extents are specified, separate them with semicolons (;).</td>
</tr>
<tr>
<td>-MINI file</td>
<td>Yes</td>
<td>Specify INI files that are described as follows.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Path that is specified in compile options and mapping of COBOL resource project</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Mapping of subfolder at the time of copying the COBOL source file</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Formats of INI files are as follows.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>[COBOLResourceProject]</td>
</tr>
<tr>
<td></td>
<td></td>
<td>original-path=COBOL resource project name</td>
</tr>
<tr>
<td></td>
<td></td>
<td>...</td>
</tr>
<tr>
<td></td>
<td></td>
<td>[COBOLSourceFile]</td>
</tr>
<tr>
<td></td>
<td></td>
<td>original-path=relative path of destination project</td>
</tr>
<tr>
<td></td>
<td></td>
<td>...</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For example, when the conversion source project file is &quot;C:\PM\PRJ&quot;, the library file is &quot;C:\PM\ACBL&quot;, the LIB compile option is &quot;.\A\ACBL&quot;, by specifying the following INI files, convert LIB compile option of COBOL project of conversion destination to &quot;./A_CBL&quot;.</td>
</tr>
<tr>
<td>-S [Y</td>
<td>N]</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>When omit options or specify Y, COBOL solution project is created.</td>
</tr>
<tr>
<td>Options</td>
<td>Specify whether or not</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>When N is specified, the COBOL solution project is not created. Option information that is set in the conversion source project is set in every option of the conversion destination COBOL project.</td>
</tr>
<tr>
<td>-?</td>
<td>Yes</td>
<td>Output the usage of the PM2NS command.</td>
</tr>
</tbody>
</table>

Yes: it can be specified

**E.3.4 Project Conversion Using the Project Configuration Conversion Command**

Use the project configuration conversion command to convert the management resource on the file system as shown in the following figure.

In the example above, execute the following command to convert into the project used for NetCOBOL Studio management.

1. Create the COBOL resource project (CBL).
   ```
   PM2NS -OC:\NS -RCBL -IC:\PM\CBL
   ```

2. Create the COBOL resource project (OTHER).
   ```
   PM2NS -OC:\NS -Etxt -ROTHER -IC:\PM\SRC -OC:\NS
   ```

3. Convert the project.
   ```
   PM2NS -OC:\NS C:\PM\TEST.prj
   ```

   - TEST.CBI is compile option file. The content of compile option file is reflected in build option of COBOL solution project.
E.4 Notes

E.4.1 Project that Cannot Be Transferred

In project manager, the project that uses the following functions cannot be transferred to the NetCOBOL Studio project. When an attempt is made to convert using the project configuration conversion command, an error message is output and the conversion stops.

- Multiple pre-compiler (use multiple pre-compiler setting for one target)
- Multistage pre-compiler (use output of pre-compiler as input for another pre-compiler)
- JEF (applications that use JEF options)
- COM server
- CORBA
- OSIV distributed development

Use project manager for NetCOBOL for Windows (x86) as the project for the functions described above, please use project manager of NetCOBOL for Windows (x86).

E.4.2 Project Which Include Functions that are not supported in NetCOBOL Studio

When the conversion source project includes a function that is not supported in NetCOBOL Studio, the project configuration conversion command handles the non-supported function one of two ways.

- Outputs an error message and stops project conversion
  However, when the -F option is specified, after disabling the object function, it outputs a warning message and continues project conversion.

- Outputs a warning message and continues project conversion

Detailed information by function follows.

Function that outputs error message and stops project conversion

When converting a project that includes the following functions, the project configuration conversion command outputs an error message and stops conversion.

However, when specifying the -F option, after disabling the object function, it outputs a warning message and continues conversion.

- An error is generated when the following compile options are specified
  - FLAGSW(GSW), FLAGSW(GSS)
  - LIBEXT
  - FORMEXT
  - SRF(FREE)
- library file creation (create library file as the input of module definition file)

Function that outputs warning message and continues project conversion

When converting a project that includes the following functions, the project configuration conversion command outputs a warning message and continues conversion.

- When %OUTFOLDER% is contained in the pre-compiler parameter
- When the extension of the input file for the pre-compiler is one of the following
  - cobol
  - cob
When converting a project using the project configuration conversion command, change the extension to "pco" and continue.

- When the extension of the output file for the pre-compiler is none of the following
  - cob
  - cobol

When converting a project using the project configuration conversion command, change the extension to ".cob" and continue.

- When the base-name of the output file for the pre-compiler is different from the input file.
  When converting a project using the project configuration conversion command, change the base-name of the output file to the base-name of the input file and continue.

- When there are two or more kinds of extensions of the input file for the pre-compiler
  When converting a project using the project configuration conversion command, change the extension to "pco" and continue.

- When there are two or more kinds of extensions of the output file for the pre-compiler
  When converting a project using the project configuration conversion command, change the extension to ".cob" and continue.

- When the following OS-dependent compile options are specified in the build management file on the Unix distributed development application
  - LALIGN
  - FILELIB
  - CODECHECK
  - KANA

When converting a project using the project configuration conversion command, the command doesn't distinguish server OS. Convert and continue using them in the raw format.

- When server link information can be obtained by a Unix distributed development application

  Server link information cannot be set as the project information. When converting a project using the project configuration conversion command, output server link information in ini file with the following format and continue.

```
[ServerName]
ServerAddress=***
UserName=***
ServerOS=***
HostCode=***
HostClientCodeChange=***
PASVSendMessage=***
```

- When server link information cannot be obtained by a Unix distributed development application
  When converting a project using the project configuration conversion command, output only a warning message and continue.

- When multiple build management files exist by a Unix distributed development application
  When converting a project using the project configuration conversion command, output a warning message about the build management file that has not converted and continue.

- When the following link options used for Solaris are specified in the build management file of a Unix distributed development application
  - pm
  - pc
  - pi
  - Ns
When converting a project using the project configuration conversion command, the command does not distinguish server OS. Convert and continue using them in the raw format.

- When send function information is set by a Unix distributed development application
  When converting a project using the project configuration conversion command, output only a warning message and continue.

- When a reference library name is set by a Unix distributed development application
  When converting a project using the project configuration conversion command, output only a warning message and continue.
# Index

<p>| [A] | A area................................................................. | 71,74 |
| [A] | AIMLIB................................................................. | 84 |
| [A] | ALPHAL................................................................. | 85,153 |
| [A] | APOST................................................................. | 166 |
| [A] | Application format................................................. | 58 |
| [A] | ASCOMPS................................................................. | 154 |
| [A] | attach debug.......................................................... | 139 |
| [A] | attached debugging.................................................. | 148 |
| [A] | Automatic build....................................................... | 94 |
| [B] | B area........................................................................ | 71,74 |
| [B] | BINARY......................................................................... | 154 |
| [B] | bookmark.................................................................... | 78 |
| [B] | breakpoint.................................................................. | 103 |
| [B] | Breakpoints view...................................................... | 100 |
| [B] | build.......................................................................... | 46 |
| [B] | build mode.................................................................. | 92,138 |
| [B] | Build Tools.................................................................. | 81,88 |
| [C] | CHECK.......................................................................... | 84,155 |
| [C] | COBOL85.CBR............................................................ | 92,109 |
| [C] | COBOL Entry Object.................................................. | 91,135 |
| [C] | COBOL Remote.......................................................... | 138 |
| [C] | CODECHK..................................................................... | 133 |
| [C] | comment in a line...................................................... | 67 |
| [C] | comment line............................................................ | 67,74,75 |
| [C] | compile........................................................................ | 23,81 |
| [C] | compile options......................................................... | 83,132 |
| [C] | CONF............................................................................ | 156 |
| [C] | Console view............................................................. | 46,81 |
| [C] | Contents Assist.......................................................... | 75 |
| [C] | COPY............................................................................. | 157 |
| [C] | COUNT.......................................................................... | 157,174 |
| [C] | C Run-time Library Name............................................ | 91,135 |
| [C] | CURRENCY..................................................................... | 158 |
| [D] | debugger..................................................................... | 96 |
| [D] | Debugging information file......................................... | 82 |
| [D] | Debug Dependency view............................................... | 100 |
| [D] | Dependent Files folder............................................... | 24,64,137,138 |
| [D] | descriptor files........................................................| 137 |
| [D] | DLOAD......................................................................... | 158 |
| [D] | DUPCHAR...................................................................... | 158 |
| [E] | entry information...................................................... | 109 |
| [E] | environment variable information................................| 109 |
| [E] | EQUALS........................................................................ | 159 |
| [F] | Figurative constant....................................................| 67 |
| [F] | file descriptor..........................................................| 123 |
| [F] | FILELIB....................................................................... | 84 |
| [F] | fixed format..............................................................| 71,73,75,76,171 |
| [F] | FLAG...........................................................................| 160 |
| [F] | FLAGSW.......................................................................| 160 |
| [F] | FORMEXT.....................................................................| 84 |
| [F] | FORMLIB.....................................................................| 161 |
| [F] | free format...............................................................| 74,75,171 |
| [F] | ftpd.............................................................................| 119 |
| [G] | GEN............................................................................| 84 |
| [H] | horizontal ruler........................................................| 71 |
| [I] | indicator column.......................................................| 74 |
| [I] | INITVALUE...................................................................| 161 |
| [I] | INSDBINFO...................................................................| 87 |
| [K] | KANA.........................................................................| 133 |
| [L] | LALIGN........................................................................| 133 |
| [L] | LANGLEVEL..................................................................| 161 |
| [L] | LIB.............................................................................| 85,161 |
| [L] | LIBEXT........................................................................| 84 |
| [L] | Library.......................................................................| 24,61,85,123,137,161 |
| [L] | Library file..................................................................| 82 |
| [L] | library name.............................................................| 123,131,135 |
| [L] | LINECOUNT...................................................................| 162 |
| [L] | line number.................................................................| 69,78 |
| [L] | LINESIZE.....................................................................| 162 |
| [L] | link............................................................................| 23,90 |
| [L] | Linking Files folder...................................................| 24,35,63,137 |
| [L] | link options.................................................................| 90,135 |
| [L] | LIST.............................................................................| 162 |
| [M] | main program...........................................................| 83 |
| [M] | makefile....................................................................| 129 |
| [M] | Manual build............................................................| 93 |
| [M] | MAP............................................................................| 162 |
| [M] | MESSAGE.....................................................................| 163 |
| [M] | MODE..........................................................................| 163 |
| [N] | Navigator view.........................................................| 39 |
| [N] | NCW..........................................................................| 163 |
| [N] | normal debug...........................................................| 139 |
| [N] | normal debugging......................................................| 139 |
| [N] | NSP...........................................................................| 164 |
| [N] | NSPCOMP..................................................................| 164 |
| [N] | NUMBER.....................................................................| 165 |</p>
<table>
<thead>
<tr>
<th>[O]</th>
<th>[T]</th>
</tr>
</thead>
<tbody>
<tr>
<td>OBJECT.......................................................</td>
<td>166</td>
</tr>
<tr>
<td>Object file...........................................</td>
<td>82</td>
</tr>
<tr>
<td>OPTIMIZE....................................................</td>
<td>166</td>
</tr>
<tr>
<td>Other Files folder.........................</td>
<td>25,35</td>
</tr>
<tr>
<td>Outline view...........................................</td>
<td>44,103</td>
</tr>
<tr>
<td>overview ruler......................................</td>
<td>72</td>
</tr>
<tr>
<td>perspective...........................................</td>
<td>2</td>
</tr>
<tr>
<td>PM2NS Command.......................................</td>
<td>196</td>
</tr>
<tr>
<td>port number..........................................</td>
<td>16,126,142,145</td>
</tr>
<tr>
<td>precompiler...........................................</td>
<td>58,60,61,88</td>
</tr>
<tr>
<td>precompiler link information...............</td>
<td>59,86</td>
</tr>
<tr>
<td>PRINT.......................................................</td>
<td>162,166,170,175</td>
</tr>
<tr>
<td>Problems view........................................</td>
<td>45,81,95,139,165</td>
</tr>
<tr>
<td>program identification area................</td>
<td>75</td>
</tr>
<tr>
<td>project................................................</td>
<td>2</td>
</tr>
<tr>
<td>Property view........................................</td>
<td>44</td>
</tr>
<tr>
<td>QUOTE......................................................</td>
<td>166</td>
</tr>
<tr>
<td>RCS.........................................................</td>
<td>167</td>
</tr>
<tr>
<td>reference format.................................</td>
<td>73</td>
</tr>
<tr>
<td>remote debugger connector..................</td>
<td>140</td>
</tr>
<tr>
<td>remote debugging.................................</td>
<td>139</td>
</tr>
<tr>
<td>REP........................................................</td>
<td>168</td>
</tr>
<tr>
<td>REPIN......................................................</td>
<td>168</td>
</tr>
<tr>
<td>repository file......................................</td>
<td>24,168</td>
</tr>
<tr>
<td>Repository file......................................</td>
<td>82</td>
</tr>
<tr>
<td>Reserved word........................................</td>
<td>67</td>
</tr>
<tr>
<td>resource compiler...............................</td>
<td>92</td>
</tr>
<tr>
<td>rexec......................................................</td>
<td>119</td>
</tr>
<tr>
<td>RSV........................................................</td>
<td>168</td>
</tr>
<tr>
<td>runtime environment information..........</td>
<td>109</td>
</tr>
<tr>
<td>Runtime Environment Setup Tool............</td>
<td>109</td>
</tr>
<tr>
<td>SA1.........................................................</td>
<td>169</td>
</tr>
<tr>
<td>screen form descriptor......................</td>
<td>123,136</td>
</tr>
<tr>
<td>SCS.........................................................</td>
<td>84</td>
</tr>
<tr>
<td>SDS.........................................................</td>
<td>169</td>
</tr>
<tr>
<td>sequence number....................................</td>
<td>69,70,78,165</td>
</tr>
<tr>
<td>server information..............................</td>
<td>127</td>
</tr>
<tr>
<td>SHREXT....................................................</td>
<td>169</td>
</tr>
<tr>
<td>SMSIZE....................................................</td>
<td>170</td>
</tr>
<tr>
<td>SOURCE....................................................</td>
<td>170</td>
</tr>
<tr>
<td>Source file............................................</td>
<td>82</td>
</tr>
<tr>
<td>Source Files folder............................</td>
<td>23,35,63,81,92,136,137,138</td>
</tr>
<tr>
<td>Special register.....................................</td>
<td>67</td>
</tr>
<tr>
<td>SQLGRP....................................................</td>
<td>171</td>
</tr>
<tr>
<td>SRF.........................................................</td>
<td>171</td>
</tr>
<tr>
<td>SSIN.......................................................</td>
<td>171</td>
</tr>
<tr>
<td>SSOUT....................................................</td>
<td>172</td>
</tr>
<tr>
<td>STD1.......................................................</td>
<td>172</td>
</tr>
<tr>
<td>Structure view.......................................</td>
<td>34</td>
</tr>
<tr>
<td>variable format.................................</td>
<td>71,74,75,76,171</td>
</tr>
<tr>
<td>vertical ruler........................................</td>
<td>71,73</td>
</tr>
<tr>
<td>Watch view..............................................</td>
<td>101,106</td>
</tr>
<tr>
<td>workspace..............................................</td>
<td>2</td>
</tr>
<tr>
<td>XREF......................................................</td>
<td>175</td>
</tr>
<tr>
<td>ZWB.......................................................</td>
<td>175</td>
</tr>
</tbody>
</table>