NetCOBOL Studio User's Guide
Preface

NetCOBOL Studio is an integrated development environment for COBOL programs.

Intended Readers
This documentation provides information for COBOL program developers who use NetCOBOL Studio. For details on general functions of Eclipse, see "Workbench User Guide" in the Help information. Readers of this documentation are assumed to have a basic knowledge of COBOL programming and the Windows operating system.

Organization of This Documentation
This documentation is organized as follows:

Chapter 1 Overview
Provides an overview of NetCOBOL Studio, describes its starting method, and explains its development workflows.

Chapter 2 Tutorial
Provides a tutorial explaining the basic operations of NetCOBOL Studio.

Chapter 3 COBOL Perspective
Describes the types of views that are displayed when a COBOL project is created.

Chapter 4 Project
Explains how to create a project.

Chapter 5 Editor
Explains the COBOL editor that is used to edit COBOL source files.

Chapter 6 Build Function
Explains how to build a COBOL program using the build tools provided in NetCOBOL Studio.

Chapter 7 Debugging Function
Explains the startup configuration used to debug programs, and the functions provided by the interactive debugger.

Chapter 8 Execution Function
Explains the startup configuration used for project execution.

Chapter 9 Remote Development Function
Explains the procedure for remote development of COBOL programs that run on a server.

Appendix A Compile Options
Explains the compiler options.

Appendix B Troubleshooting Guide
Explains how to resolve NetCOBOL Studio issues.

Appendix C Handling of Workspace and Project
Explains the handling of workspace and project.

Appendix D Various Specification Formats used in Debugging
Explains various specification formats used in the Watch view.

Appendix E Transition from Project Manager
Explains the transfer of COBOL applications from NetCOBOL project manager for Windows(x86) to NetCOBOL Studio, and the project organization converting command that is a transference support tool.
## Product Names

The following product names are abbreviated in this manual as follows:

<table>
<thead>
<tr>
<th>Product Name</th>
<th>Abbreviation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft(R) Windows Server(R) 2012 R2 Datacenter</td>
<td>Windows Server 2012 R2</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2012 R2 Standard</td>
<td>Windows Server 2012 R2</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2012 R2 Essentials</td>
<td>Windows Server 2012 R2</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2012 R2 Foundation</td>
<td>Windows Server 2012 R2</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2012 Datacenter</td>
<td>Windows Server 2012 R2</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2012 Standard</td>
<td>Windows Server 2012 R2</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2012 Essentials</td>
<td>Windows Server 2012 R2</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2012 Foundation</td>
<td>Windows Server 2012 R2</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2008 R2 Foundation</td>
<td>Windows Server 2008 R2</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2008 R2 Standard</td>
<td>Windows Server 2008 R2</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2008 R2 Enterprise</td>
<td>Windows Server 2008 R2</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2008 R2 Datacenter</td>
<td>Windows Server 2008 R2</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2008 for Itanium-Based Systems</td>
<td>Windows Server 2008(Itanium)</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2003, Standard x64 Edition</td>
<td>Windows Server 2003</td>
</tr>
<tr>
<td>Microsoft(R) Windows Server(R) 2003, Enterprise x64 Edition</td>
<td>Windows Server 2003(x64)</td>
</tr>
<tr>
<td>Windows(R) 8.1</td>
<td>Windows 8.1</td>
</tr>
<tr>
<td>Windows(R) 8.1 Pro</td>
<td>Windows 8.1(x64)</td>
</tr>
<tr>
<td>Windows(R) 8.1 Enterprise</td>
<td>Windows 8.1(x64)</td>
</tr>
<tr>
<td>Windows(R) 8</td>
<td>Windows 8</td>
</tr>
<tr>
<td>Windows(R) 8 Pro</td>
<td>Windows 8(x64)</td>
</tr>
<tr>
<td>Windows(R) 8 Enterprise</td>
<td>Windows 8(x64)</td>
</tr>
<tr>
<td>Windows(R) 7 Home Premium</td>
<td>Windows 7</td>
</tr>
<tr>
<td>Windows(R) 7 Professional</td>
<td>Windows 7(x64)</td>
</tr>
<tr>
<td>Windows(R) 7 Enterprise</td>
<td>Windows 7(x64)</td>
</tr>
<tr>
<td>Product Name</td>
<td>Abbreviation</td>
</tr>
<tr>
<td>---------------------------------------------------------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>Windows(R) 7 Ultimate</td>
<td></td>
</tr>
<tr>
<td>Oracle Solaris</td>
<td>Solaris</td>
</tr>
<tr>
<td>Red Hat(R) Enterprise Linux(R) 5 (for Itanium)</td>
<td>Linux or Linux(Itanium)</td>
</tr>
<tr>
<td>Red Hat(R) Enterprise Linux(R) 5 (for Intel64)</td>
<td>Linux or Linux(x64)</td>
</tr>
</tbody>
</table>

- In this manual, when all the following products are indicates, it is written as "Windows (Itanium)".
  - Windows Server 2003 (Itanium)
  - Windows Server 2008 (Itanium)

- In this manual, when all the following products are indicates, it is written as "Windows(x64)" or "Windows".
  - Windows Server 2012 R2
  - Windows Server 2012
  - Windows Server 2008 R2
  - Windows 8.1 (x64)
  - Windows 8 (x64)
  - Windows 7 (x64)

**Trademarks**

NetCOBOL is a trademark or registered trademark of Fujitsu Limited or its subsidiaries in the United States or other countries or in both.

Eclipse is a trademark of Eclipse Foundation, Inc.

Microsoft, Windows, and Internet Explorer are registered trademarks of Microsoft Corporation in the United States and other countries.

Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of their respective owners. Oracle Solaris might be described as Solaris, Solaris Operating System, or Solaris OS.

Linux is a registered trademark of Linus Torvalds in the United States and other countries.

Red Hat, RPM and all Red Hat-based trademarks are trademarks or registered trademarks of Red Hat, Inc. in the United States and other countries.

Intel and Itanium are trademarks or registered trademarks of Intel Corporation or its subsidiaries in the United States and other countries.

All other product names mentioned herein are the trademarks or registered trademarks of their respective owners.

**Export Regulation**

Exportation/release of this document may require necessary procedures in accordance with the regulations of the Foreign Exchange and Foreign Trade Control Law of Japan and/or US export control laws.

March 2014
Copyright 2011-2014 FUJITSU LIMITED
## Contents

Chapter 1 Overview............................................................................................................................................................................. 1  
  1.1 NetCOBOL Studio.................................................................................................................................................................. 1  
  1.1.1 Using NetCOBOL .......................................................................................................................................................... 1  
  1.1.2 Using Interstage Studio................................................................................................................................................ 2  
  1.2 Functional Overview .......................................................................................................................................................... 2  
  1.3 Starting NetCOBOL Studio.................................................................................................................................................. 3  
  1.4 Development Flows.............................................................................................................................................................. 5  
  1.4.1 Development patterns...................................................................................................................................................... 5  
  1.4.2 Local development flow................................................................................................................................................. 5  
  1.4.3 Remote development flow.............................................................................................................................................. 6

Chapter 2 Tutorial................................................................................................................................................................................7  
  2.1 Creating a COBOL Program.................................................................................................................................................. 7  
  2.2 Creating a COBOL Program by Remote Development.....................................................................................................17

Chapter 3 COBOL Perspective..........................................................................................................................................................26  
  3.1 Dependency View................................................................................................................................................................. 27  
  3.1.1 The role of the Dependency view..................................................................................................................................... 27  
  3.1.1.1 Adding a COBOL source file in the Dependency view................................................................................................. 28  
  3.1.1.2 Adding a link file in the Dependency view....................................................................................................................... 29  
  3.1.1.3 Adding a dependent file................................................................................................................................................. 29  
  3.1.1.4 Deleting a dependent file............................................................................................................................................ 29  
  3.1.2 Context menu of the Dependency view.................................................................................................................................. 29  
  3.1.2.1 COBOL project............................................................................................................................................................ 29  
  3.1.2.2 COBOL Resource Project.......................................................................................................................................... 35  
  3.1.2.3 COBOL Solution Project.......................................................................................................................................... 36  
  3.1.3 Analyze Dependency........................................................................................................................................................ 37  
  3.2 Structure View...................................................................................................................................................................... 38  
  3.2.1 The role of the Structure view.......................................................................................................................................... 38  
  3.2.2 Context menu of the Structure view.................................................................................................................................. 39  
  3.2.2.1 COBOL Project............................................................................................................................................................ 39  
  3.2.2.2 COBOL resource project............................................................................................................................................ 42  
  3.2.2.3 COBOL solution project........................................................................................................................................... 42  
  3.3 Navigator View..................................................................................................................................................................... 42  
  3.3.1 The role of the Navigator view........................................................................................................................................ 42  
  3.3.1.1 Applying a filter to the view.......................................................................................................................................... 42  
  3.3.1.2 Sharing files in the Concurrent Versions System (CVS)............................................................................................... 42  
  3.3.1.3 Property options......................................................................................................................................................... 44  
  3.3.2 Navigator view Tools ....................................................................................................................................................... 45  
  3.3.3 Navigator view Context menu ........................................................................................................................................ 45  
  3.4 Property View...................................................................................................................................................................... 47  
  3.5 Outline View....................................................................................................................................................................... 47  
  3.5.1 Toolbar.............................................................................................................................................................................. 47  
  3.6 Problems View................................................................................................................................................................... 48  
  3.6.1 Problems view display...................................................................................................................................................... 48  
  3.7 Tasks View............................................................................................................................................................................. 49  
  3.7.1 Tasks view display......................................................................................................................................................... 49  
  3.7.2 Associating a task with a COBOL source file.................................................................................................................. 49  
  3.8 Console View.................................................................................................................................................................... 50  
  3.9 Templates view.................................................................................................................................................................... 50  
  3.9.1 The role of Templates View........................................................................................................................................... 51
3.9.1.1 Insert template patterns into source file.......................................................................................................................... 51
3.9.1.2 Adding, editing, and deleting a template.......................................................................................................................... 52
3.9.1.3 Import and export template................................................................................................................................................ 55
3.9.1.4 Validation/Invalidation of template.................................................................................................................................. 56
3.9.2 Context menu of Templates view........................................................................................................................................... 56
3.9.3 Templates page........................................................................................................................................................................... 57

Chapter 4 Project.................................................................................................................................................................................. 59

4.1 Overview..................................................................................................................................................................................... 59
4.1.1 COBOL Solution project....................................................................................................................................................... 59
4.1.2 COBOL project......................................................................................................................................................................... 59
4.1.3 COBOL Resource project....................................................................................................................................................... 59
4.1.4 Notes for project management............................................................................................................................................... 60

4.2 Wizards.......................................................................................................................................................................................... 60
4.2.1 COBOL solution generation wizard.................................................................................................................................. 61
4.2.2 COBOL Project generation Wizard...................................................................................................................................... 61
4.2.3 COBOL resource generation wizard...................................................................................................................................... 63
4.2.4 COBOL source generation wizard........................................................................................................................................ 64
4.2.5 Object-oriented COBOL source generation wizard............................................................................................................... 64
4.2.6 COBOL Library generation wizard......................................................................................................................................... 64

4.3 COBOL Solution Project............................................................................................................................................................. 65
4.3.1 Manage COBOL project......................................................................................................................................................... 65
4.3.1.1 Adding a project............................................................................................................................................................... 65
4.3.1.2 Remove Project............................................................................................................................................................... 65
4.3.2 Operate project together............................................................................................................................................................ 66
4.3.3 Setting common options for the projects.................................................................................................................................. 66

4.4 COBOL Project.............................................................................................................................................................................. 66
4.4.1 Adding Existing COBOL Resources...................................................................................................................................... 66
4.4.1.1 Adding a COBOL source file........................................................................................................................................ 67
4.4.1.2 Adding a link file............................................................................................................................................................... 67
4.4.1.3 Adding a dependent file.................................................................................................................................................... 67

4.5 COBOL Resource Project........................................................................................................................................................... 67
4.5.1 Adding the existing COBOL resource........................................................................................................................................ 67
4.5.2 Take reference from other projects......................................................................................................................................... 68

Chapter 5 Editor.................................................................................................................................................................................. 69

5.1 Highlighting Key Words................................................................................................................................................................. 69
5.2 Font Setting.................................................................................................................................................................................... 70
5.3 Displaying Line-Numbers............................................................................................................................................................... 70
5.4 Sequence Numbers...................................................................................................................................................................... 70
5.5 Renumbering Lines..................................................................................................................................................................... 71
5.6 Changing the Initial Value and Increment Value for Sequence Numbers.................................................................................. 72
5.7 Display of the Horizontal Ruler.................................................................................................................................................... 72
5.8 Vertical Ruler.................................................................................................................................................................................. 73
5.9 Display of the Overview Ruler..................................................................................................................................................... 73
5.10 Quick Diff Display..................................................................................................................................................................... 74
5.11 Reference Formats....................................................................................................................................................................... 75
5.12 Code Formatter.............................................................................................................................................................................. 76
5.13 Comment Styles............................................................................................................................................................................. 76
5.14 Input Support Candidate List (Contents Assist).................................................................................................................... 76
5.15 Insert and Overwrite Modes...................................................................................................................................................... 77
5.16 Select All....................................................................................................................................................................................... 77
5.17 Undo and Redo.............................................................................................................................................................................. 77
5.18 Shift Left/Right............................................................................................................................................................................ 78
Chapter 1     Overview

This chapter provides an overview of NetCOBOL Studio and explains its development workflows.

1.1 NetCOBOL Studio

NetCOBOL Studio is an integrated development environment for COBOL programs.

NetCOBOL Studio includes the Assist functions for COBOL programming based on Eclipse, an open-source GUI development environment. With NetCOBOL, users can efficiently perform a series of development work steps, including editing COBOL source programs, and building, debugging, and executing COBOL programs.

There are two ways of using NetCOBOL Studio. One way is to do NetCOBOL application development. The other way is to integrate the COBOL plug-in of NetCOBOL Studio into Interstage Studio, which provides an Integrated Development Environment that includes Java language.

Note
- In NetCOBOL Studio for Windows(x64), a 64-bit COBOL application can be developed.
- NetCOBOL Studio is an integrated development environment designed for the COBOL language. The Java development environment and the plug-in development environment that are provided as Eclipse functions are not supported.

1.1.1 Using NetCOBOL

A typical installation of the NetCOBOL development package installs the necessary NetCOBOL Studio components.

Compatibility

In Eclipse, the upward compatibility of a workspace is guaranteed. When a workspace created in NetCOBOL Studio based on Eclipse 3.2 is opened in NetCOBOL Studio based on Eclipse 3.4, it is converted automatically.

However, it is not backwards compatible. Workspaces that have been converted to Net COBOL Studio based on Eclipse 3.4 cannot be opened by Net COBOL Studio based on Eclipse 3.2.
When two or more developers and development machines share one workspace for development work, be sure both machines are using the latest version of NetCOBOL Studio.

**Information**

The relationship of NetCOBOL to NetCOBOL Studio based on Eclipse are as follows:

<table>
<thead>
<tr>
<th>NetCOBOL version</th>
<th>NetCOBOL Studio based on Eclipse 3.2</th>
<th>NetCOBOL Studio based on Eclipse 3.4</th>
</tr>
</thead>
<tbody>
<tr>
<td>NetCOBOLV10.4 or earlier</td>
<td>provided</td>
<td>not provided</td>
</tr>
<tr>
<td>NetCOBOLV11</td>
<td>not provided</td>
<td>provided</td>
</tr>
</tbody>
</table>

### 1.1.2 Using Interstage Studio

The COBOL development function of NetCOBOL Studio can be used from Interstage Studio by integrating the COBOL plug-in into the Eclipse 3.4 workbench provided in Interstage Studio Standard-J Edition V10 or later.

Interstage Studio is not bundled with NetCOBOL. It must be purchased separately.

**Installing the COBOL plug-in**

Install the "COBOL plug-in for Interstage Studio" in addition to Interstage Studio and the NetCOBOL development package. Refer to "Interstage Studio COBOL Plug-in SOFTWARE RELEASE GUIDE".

**Eclipse-based**

Use Eclipse version is 3.4- from Interstage Studio.

### 1.2 Functional Overview

NetCOBOL Studio supports the following COBOL program development functions:

- **Development environment management functions**
  
  NetCOBOL Studio manages the development environment and development resources of each COBOL program together in a unit called a project. Projects are managed in folders called workspaces.

**Note**

When developing a 32-bit COBOL application, use NetCOBOL Studio for Windows(x86). When developing a 64-bit COBOL application, use NetCOBOL Studio for Windows(x64).

- **Edit functions**
  
  NetCOBOL Studio provides many editing functions such as highlighting key words, displaying and resequencing line numbers, displaying horizontal, vertical, and overview rulers, displaying differences in source code, support of fixed and variable reference formats, automatic indentation, undo/redo, cut/copy/paste, find/replace, etc.

- **Build and execution functions**
  
  NetCOBOL Studio provides facilities to set COBOL compiler options and link options, and add version information and set icons for programs using the resource compiler. Tools for dependency analysis, automatic build, and manual build are provided. Compilation errors are displayed, and the line of source code containing a selected error can be displayed in the NetCOBOL Studio Editor.

- **Debug functions**
  
  The interactive debugger can detect logic errors in program processing. It can be used to set breakpoints to halt execution of a program, and to verify execution of a program by confirming data item values. The debugging of multithreaded programs is supported; however, the debugger does not support multiple debug sessions.
Remote development functions

COBOL programs for the Solaris OS, Linux (Itanium), Linux(x64), Windows (Itanium) or Windows(x64) servers can be developed remotely. After performing standalone tests on a local computer, add the settings for remote development to the project for a smooth transition to test builds and links on a server.

NetCOBOL Studio users must understand the following main basic concepts:

Projects

NetCOBOL Studio manages the resources and information necessary for program development in individual units called "projects". NetCOBOL Studio creates and manages the following projects.

- COBOL projects
  A "COBOL project" is used for COBOL program development. One COBOL project manages the resources of one target (executable program or library). To develop a COBOL program, a COBOL project must first be created.

- COBOL resource projects
  A "COBOL resource project" is used for management of the library file and the descriptor file.

- COBOL solution projects
  A "COBOL solution project" is used for management of multiple projects. Specify the common compiler option for multiples projects.

You can easily create these projects interactively with the help of a wizard.

See

Project Import

A project in another workspace can be used by importing it. For details, refer to "C.3 Importing Project".

Workspaces

A workspace is a folder for storing one or more projects, and for storing setting information for a development environment shared by the projects.

For workspace setting and switching, refer to "Setting and Switching of Workspace". For the default workspace, refer to "Default Workspace".

Note

- Projects for 32-bit and 64-bit COBOL applications cannot be created in the same workspace. Separate workspace folders must be specified for 32-bit and 64-bit COBOL projects.
- Workspaces cannot be shared between NetCOBOL Studio and Interstage Studio.
- The workspace created with NetCOBOL Studio cannot be opened with Interstage Studio. Also, the workspace created with Interstage Studio cannot be opened with NetCOBOL Studio.

Perspectives

The operation windows of NetCOBOL Studio consist of editor windows and multiple information display windows (each of these is called a "view"). The type and layout of a displayed view are managed under a concept called "perspectives" each of which is appropriate for the target work.

The COBOL perspective and Debug perspective, which has been prepared for debugging, are used in COBOL program development.

1.3 Starting NetCOBOL Studio

Start NetCOBOL Studio as follows:
Select "Apps" > "Fujitsu NetCOBOL V11(x64)" > "NetCOBOL Studio(x64)" from the "Start" menu.

If the start screen appears, select the "Run" button. The NetCOBOL Studio window is displayed. The contents of the start screen are shown below.

Table 1.1 NetCOBOL Studio start screen

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Run</td>
<td>Starts NetCOBOL Studio. The folder name of the workspace that NetCOBOL Studio uses can be confirmed in the following way.</td>
</tr>
<tr>
<td></td>
<td>- Place the mouse cursor on the &quot;Run&quot; button.</td>
</tr>
<tr>
<td></td>
<td>- Click the &quot;Setup&quot; button and the workspace folder name is displayed.</td>
</tr>
<tr>
<td>Setup...</td>
<td>Used to make operating environment settings for NetCOBOL Studio. When the &quot;Setup&quot; button is clicked, the &quot;Setup Configuration&quot; dialog box appears. For information about setting the workspace folder, refer to &quot;Appendix C Handling of Workspace and Project&quot;.</td>
</tr>
<tr>
<td></td>
<td>For details on the environment settings, see the Help for the &quot;Setup Configuration&quot; dialog box.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Closes the start screen and does not start NetCOBOL Studio.</td>
</tr>
</tbody>
</table>

When the "Always show Launch dialog" checkbox is selected in the "Setup Configuration" dialog box, this screen is displayed.

Table 1.2 "Setup Configuration" dialog box

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Workspace folder name</td>
<td>Used to select the folder for the workspace. NetCOBOL Studio uses the selected workspace folder. To change the workspace folder,</td>
</tr>
<tr>
<td></td>
<td>- Select the folder name and push the F2 key, or</td>
</tr>
<tr>
<td></td>
<td>- Edit by clicking the left mouse button.</td>
</tr>
<tr>
<td></td>
<td>The following characters cannot be used for the workspace folder name.</td>
</tr>
<tr>
<td></td>
<td>&quot;#, %, ;&quot;</td>
</tr>
<tr>
<td>Add</td>
<td>Adds the existing workspace folder to the workspace list. The dialog box displayed is varies according to the operating system and the Internet Explorer version. When specify a non-existent folder name, a new workspace folder is created.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the workspace folder name from the workspace list. Even if the workspace folder name is deleted from the list, the actual folder is not deleted. Use Explorer to delete unnecessary folders.</td>
</tr>
<tr>
<td>Execution option</td>
<td>Used to specify a startup option for NetCOBOL Studio. For a normal startup, do not specify an option.</td>
</tr>
<tr>
<td></td>
<td>-clean</td>
</tr>
<tr>
<td></td>
<td>Deletes the cash data used by Eclipse. When a plug-in is added, updated, or deleted, you should start NetCOBOL Studio by specifying this option.</td>
</tr>
<tr>
<td></td>
<td>-nosplash</td>
</tr>
<tr>
<td></td>
<td>Does not display the splash screen at start-up of NetCOBOL Studio.</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>-showlocation</td>
<td>Displays the workspace location in the NetCOBOL Studio title bar.</td>
</tr>
<tr>
<td>-vmargs JavaVMoption</td>
<td>Specifies the option for JavaVM.</td>
</tr>
<tr>
<td></td>
<td>Only &quot;-Xmx option&quot; and &quot;-XX:MaxPermSize option&quot; can be specified for JavaVMOption.</td>
</tr>
<tr>
<td></td>
<td>NetCOBOL Studio assumes that &quot;-Xmx256M -XX:MaxPermSize=64M&quot; is specified.</td>
</tr>
<tr>
<td></td>
<td>For option details, refer to the NetCOBOL Studio help.</td>
</tr>
<tr>
<td></td>
<td>&quot;Workbench User's Guide&quot; &gt; &quot;Task&quot; &gt; &quot;Running Eclipse&quot; &gt; &quot;Eclipse Startup Parameters&quot;</td>
</tr>
<tr>
<td></td>
<td>Note:</td>
</tr>
<tr>
<td></td>
<td>In NetCOBOL Studio, only the above option can be used.</td>
</tr>
<tr>
<td>Always show Launch dialog</td>
<td>When checked, the start screen is displayed. When not checked, the start screen is not displayed.</td>
</tr>
<tr>
<td></td>
<td>In a non-display state, when NetCOBOL Studio is started while holding the shift key, the start screen is displayed.</td>
</tr>
</tbody>
</table>

1.4 Development Flows

This section explains the development work patterns and flows of COBOL programming using NetCOBOL Studio.

1.4.1 Development patterns

NetCOBOL Studio provides two patterns of development:

- Local development flow
  Development pattern for a COBOL program that runs on a local personal computer.

- Remote development flow
  Development pattern for a COBOL program that runs on a server.

Remote development requires that information specific to the target server be set in each project. A project with a local development pattern can be changed to a remote development pattern by adding server information to the project.

1.4.2 Local development flow

This section explains the flow of COBOL program development on a local personal computer.
1. Create a project
   NetCOBOL Studio manages each COBOL program under development as a "project." The resources (e.g., source files, libraries) required for COBOL program development are managed in blocks in units of projects. A single target (executable program or dynamic link library) is managed with each project. Using a wizard, projects can be defined easily and efficiently. Precompiler settings (e.g., command, parameter) can be specified for COBOL programs including input sources for the precompiler.

2. Code a source program
   NetCOBOL Studio provides a wizard for creating source program templates. Various Assist functions of the COBOL editor can be used to edit COBOL source programs.

3. Build
   Compiling and linking are performed according to the information defined in the project (e.g., compile options, link options).

4. Debug
   The interactive debugger provides various functions, such as setting program breakpoints and referencing and setting data item values. These functions enable the programmer to efficiently debug the COBOL program.

5. Execute
   The program can be executed after the runtime environment information required for COBOL program execution is set.

1.4.3 Remote development flow
For details on remote development of a COBOL program, refer to 9.1.3 Flow of Remote Development".
Chapter 2 Tutorial

This chapter explains the basic operation flow of NetCOBOL Studio using examples.

2.1 Creating a COBOL Program

This section explains the procedure for creating a COBOL program.

Point

The "NetCOBOL Getting Started Guide", explains the procedures for importing sample projects to the workspace. Procedures to create a new project called SAMPLE1 are explained here.

1. Start NetCOBOL Studio
2. Create a project
3. Create a template by using the COBOL source generation wizard
4. Edit the program
5. Build the project
6. Start the debugger
7. Execute the COBOL program

1. Start NetCOBOL Studio

1. This section explains how to start NetCOBOL Studio. An executable file is created from a COBOL source program in the project in this example.

   Select "Apps" > "Fujitsu NetCOBOL V11(x64)" > "NetCOBOL Studio(x64)" from the "Start" menu.

   The start screen appears when NetCOBOL Studio is started.

2. Click the "Setup..." button to set the workspace. For details about setting a workspace, refer to "C.2.1 Setting workspace". When a workspace is not set, the default workspace is used. For details about the default workspace, refer to "C.1 Default workspace".
3. Click the "Run" button. The NetCOBOL Studio window is displayed.

2. Create a project
   1. To create a COBOL project:
      Select "File" > "New" > "COBOL Project" from the menu bar. The new project wizard is displayed.
2. Specify a project name and a storage folder on the second page.

<table>
<thead>
<tr>
<th>Field</th>
<th>Entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>SAMPLE1</td>
</tr>
<tr>
<td>Contents</td>
<td>Create new project in workspace</td>
</tr>
<tr>
<td>Directory</td>
<td>C:\NetCOBOL\workspace\SAMPLE1</td>
</tr>
</tbody>
</table>
3. This page is used to specify information on the target. Leave the defaults and click the "Next" button.
4. This page is used to select the type of source code to be created. Select "COBOL Source" in the "Available skeleton codes" section, and then click on the "Finish" button.

![Skeleton Code Selection](image)

**Note**

Projects for 32-bit and 64-bit COBOL applications cannot be created in the same workspace. Separate workspace folders must be specified for 32-bit and 64-bit COBOL projects.

3. **Create a template by using the COBOL source generation wizard**

   Using the COBOL source generation wizard, create a template of a COBOL source file.
Make the following entries in the fields on this screen:

<table>
<thead>
<tr>
<th>Field</th>
<th>Entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>SAMPLE1</td>
</tr>
<tr>
<td>File name</td>
<td>SAMPLE1</td>
</tr>
<tr>
<td>PROGRAM-ID</td>
<td>SAMPLE1</td>
</tr>
<tr>
<td>File comment</td>
<td>Optional: Enter a comment related to the COBOL source file.</td>
</tr>
</tbody>
</table>

Click on the "Finish" button. The SAMPLE1.cob file is created and opened in the COBOL editor.
4. Edit the program

Edit the COBOL source file that was created using the wizard. Add and modify data items and procedures as desired.

**WORKING-STORAGE SECTION**

```cobol
01  WORD-VALUES.
  02  PIC X(10) VALUE "apple".
  02  PIC X(10) VALUE "black".
  02  PIC X(10) VALUE "cobol".
  02  PIC X(10) VALUE "dog".
  02  PIC X(10) VALUE "eye".
  02  PIC X(10) VALUE "fault".
  02  PIC X(10) VALUE "good".
  02  PIC X(10) VALUE "high".
  02  PIC X(10) VALUE "idea".
  02  PIC X(10) VALUE "junior".
  02  PIC X(10) VALUE "king".
  02  PIC X(10) VALUE "love".
  02  PIC X(10) VALUE "medium".
  02  PIC X(10) VALUE "new".
  02  PIC X(10) VALUE "open".
  02  PIC X(10) VALUE "pig".
  02  PIC X(10) VALUE "queen".
  02  PIC X(10) VALUE "review".
  02  PIC X(10) VALUE "smile".
  02  PIC X(10) VALUE "tomorrow".
  02  PIC X(10) VALUE "understand".
  02  PIC X(10) VALUE "version".
  02  PIC X(10) VALUE "wood".
  02  PIC X(10) VALUE "xylophone".
```
DATA-INPUT SECTION.
**(1) DISPLAY THE ABOVE MESSAGE
   DISPLAY REQUEST-MESSAGE WITH NO ADVANCING.
**(2) ACCEPT THE INPUT CHARACTER
   ACCEPT INPUT-CHARACTER.
*
SEARCH-WORD SECTION.
**(3) WORDS ARE SEARCHED CORRESPONDING TO THE INPUT CHARACTER
   PERFORM TEST BEFORE
   VARYING WORD-INDEX FROM 1 BY 1
   UNTIL WORD-INDEX > 26
   IF INPUT-CHARACTER = FIRST-CHARACTER (WORD-INDEX)
   THEN EXIT PERFORM
   END-IF
   END-PERFORM.
*
WORD-OUTPUT SECTION.
**(4) THE RESULTING WORD MATCH IS DISPLAYED
   DISPLAY WORD-ITEM (WORD-INDEX).
*
EXIT PROGRAM.

After completing the editing, select "Save" from the COBOL editor menu or click the "Save" icon.

5. Build the project

If "Project" > "Build Automatically" in the menu bar is enabled, the COBOL program will be built automatically when the source program is saved in the previous step. To manually execute the build, or to execute the build if the automatic build was cancelled, select "Project" > "Build Project" from the menu bar.

6. Start the debugger

Set Breakpoints

Before starting the debugger, set breakpoints as follows:

On the vertical ruler at the left edge of the COBOL editor window, position the cursor on the line where a breakpoint is to be set and double-click the left mouse button. A mark indicating a set breakpoint (●) is displayed on the vertical ruler.
Start the debugger

1. After completing the setting of breakpoints, start the debugger:
   Select "Run" > "Debug As" > "COBOL Application" from the menu bar.

2. A message is displayed to confirm switching to the Debug perspective when the first breakpoint is reached. Click the "Yes" button.
3. The Debug perspective is displayed, and processing is stopped at the first breakpoint.

![Debug perspective image](image)

**Change of value of data item**

1. Change a value of the "INPUT-CHARACTER" data item.
   Select the "INPUT-CHARACTER" data item in the COBOL editor, and select "Add to Watch View" from the context menu. "INPUT-CHARACTER" is added into the "Watch" view.

2. Select the "INPUT-CHARACTER" data item in the "Watch" view, and select "Change Value" from the context menu. The "Set Value" dialog box appears.

3. Change a value in the "Set Value" dialog box appears. Click the "OK" button.

**Execution restart**

Click either of the following buttons from the "Debug" view and the application is executed.

- Resume
- Step Into
- Step Over

For additional information, refer to "7.2.1 Debug view".

**Point**

After completing debugging, select "Window" > "Open Perspective" > "COBOL" from the menu bar to return to the COBOL perspective.

**7. Execute the COBOL program**

To execute the COBOL program you created, select "Run" > "Run As" > "COBOL Application" from the menu bar.
2.2 Creating a COBOL Program by Remote Development

This section explains the procedure for converting an existing COBOL project into a project under remote development, and then creating a COBOL program for a server by remote development.

1. Make server environment settings
2. Set server information
3. Set server information for the project
4. Create a makefile
5. Build the project on the server
6. Debug the COBOL program

1. Make server environment settings

Make environment settings for the server to be used for remote development. Check with your server administrator. For details on environment settings of a server, see "9.2.1.1 NetCOBOL Remote Development Service" and "9.2.2 Setting up the user environment on the server."

2. Set server information

Set information for linkage with the server used for remote development.

1. Select "Window" > "Preferences" from the menu bar. When the "Preferences" dialog box appears, select "COBOL" > "Remote Development". The "Remote Development" page is displayed.

2. Select the "New" button on the "Remote Development" page.

   ![Preferences dialog box](image)

   The "New Server Information" dialog box appears.

3. Set the information required for linking to the server as follows:

<table>
<thead>
<tr>
<th>Field</th>
<th>Entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server name</td>
<td>Enter an arbitrary name that will be used to manage server information.</td>
</tr>
<tr>
<td>Field</td>
<td>Entry</td>
</tr>
<tr>
<td>------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Server OS</td>
<td>Select the operating system of the server used for remote development.</td>
</tr>
<tr>
<td>Server address</td>
<td>Enter a name (FQDN: Fully Qualified Domain Name) or IP address that identifies the server in the network.</td>
</tr>
<tr>
<td>Save user name and password</td>
<td>Check this checkbox.</td>
</tr>
<tr>
<td>User name</td>
<td>Enter the user name of the account used to access the server.</td>
</tr>
<tr>
<td>Password</td>
<td>Enter the password assigned to the user.</td>
</tr>
<tr>
<td>Character-code conversion</td>
<td>This section is for the specification of text file code conversion information.</td>
</tr>
<tr>
<td>COBOL Source character-code on the server side</td>
<td>Select the character-code of the COBOL source file transferred to the server side of remote development.</td>
</tr>
<tr>
<td>Convert character set in the server</td>
<td>Select &quot;Convert character set in the server&quot;, since code conversion processing is executed on the server.</td>
</tr>
<tr>
<td>Convert character set in the client</td>
<td>This field is disabled if &quot;Windows(Itanium)&quot; or &quot;Windows(x64)&quot; is selected at &quot;Server OS&quot;.</td>
</tr>
<tr>
<td>Information for UNIX Server system</td>
<td>This information should be configured if Solaris, Linux(x86), Linux(Itanium), or Linux(x64) is specified at &quot;Server OS&quot;.</td>
</tr>
<tr>
<td>FTP is used for remote development</td>
<td>If this field is selected, use the ftpd/rexec service as the remote development server-side service.</td>
</tr>
<tr>
<td>Use PASV mode for file transfer(FTP)</td>
<td>Check this box only if file transfer will be in PASV mode.</td>
</tr>
<tr>
<td>NetCOBOL Remote Development Service on server side</td>
<td>This information is for the server-side NetCOBOL remote development service.</td>
</tr>
<tr>
<td>Port number</td>
<td>This item is enabled if the Server OS is &quot;Windows (Itanium)&quot;, and is used to specify the TCP/IP port number of the NetCOBOL remote development service.</td>
</tr>
</tbody>
</table>
4. After setting the information in the "New" dialog box, click the "Connection test" button. When the information is correct, environmental variable information for the server is displayed.

![Connection Test Dialog Box](image)

Click the "OK" button in the "Connection test" dialog box to return to the "New Server Information" dialog box.

5. Click the "OK" button in the "New Server Information" dialog box. The "Preferences" dialog box appears. The server name entered in the "New Server Information" dialog box is displayed in Server name on the "Remote Development" page.

![Preferences Dialog Box](image)

Click the "OK" button to close the "Preferences" dialog box.

**Point**

Since the server information set in this step is shared among workspaces, the information can be used from another workspace.

3. Set server information for the project

To convert a COBOL project into one under remote development, set the server information for the project.
1. Select the project in the "Dependency" or "Structure" view, and select "Property" from the context menu. The property dialog box appears.

2. Select "Remote Development" in the left pane of the property dialog box. The "Remote Development" page is displayed.

3. Set the server information for the project as follows:

   ![Properties for SAMPLE1](image)

<table>
<thead>
<tr>
<th>Field</th>
<th>Entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable project specific setting</td>
<td>This checkbox must be checked.</td>
</tr>
<tr>
<td>Enable remote development</td>
<td>This checkbox must be checked.</td>
</tr>
<tr>
<td>Server name</td>
<td>Select the server name that was entered in the &quot;Set server information&quot;.</td>
</tr>
<tr>
<td>Server directory</td>
<td>Specify the full path name of the storage directory of the resources used for remote development. The server directory can be selected by clicking the &quot;Browse&quot; button. The makefile creation function and remote build function use this directory as the current directory for processing.</td>
</tr>
</tbody>
</table>

   Click the "OK" button to close the property dialog box.

4. **Create a makefile**

   Create a makefile that will be used to build a COBOL program on the server.

   1. Select "Project" > "Remote Development" > "Makefile Creation..." from the menu bar. The "Makefile Creation" dialog box appears.
2. Leave the defaults and click the "OK" button.

The resources that are required for creating the makefile are sent to the server, and the makefile is created. The created makefile is named "Makefile" and registered in the "Other Files" folder. To view the contents of the makefile, select the makefile and select "Open" from the context menu.

Note

The following confirmation message may be displayed.

Click the "OK" button to disable the automatic build.

Point

The makefile creation results on the server can be checked by selecting "COBOL Remote" from the "Open Console" icon on the toolbar in the "Console" view.
5. Build the project on the server

To build the COBOL program on the server, select "Project" > "Remote Development" > "Build" from the menu bar.

**Point**

- Compilation errors are displayed in the "Problems" view. Select a compilation error in the "Problem" view, and select "Go To" from the context menu. The COBOL editor opens the COBOL source file and displays it with the current line at the error location.
- The build results on the server can be checked by selecting "COBOL Remote" from the "Open Console" icon on the toolbar in the "Console" view.

6. Debug the COBOL program

To debug the COBOL program running on the server, launch the NetCOBOL interactive remote debugger and start debugging. Use the remote debugger connector, which is a tool for connecting a client to the server.

1. To start remote debugging, execute one of the commands listed below on the server to start the remote debugger connector.

<table>
<thead>
<tr>
<th>Server</th>
<th>Start command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows (Itanium)</td>
<td>cobrds64</td>
</tr>
<tr>
<td>Windows(x64)</td>
<td></td>
</tr>
<tr>
<td>Solaris</td>
<td>svdrds</td>
</tr>
<tr>
<td>Linux(Itanium)</td>
<td></td>
</tr>
<tr>
<td>Linux(x64)</td>
<td></td>
</tr>
<tr>
<td>Linux(x86)</td>
<td></td>
</tr>
</tbody>
</table>
1. Before starting the debugger, set breakpoints as follows:

On the vertical ruler at the left edge of the COBOL editor window, position the cursor on the line where a breakpoint is to be set and double-click the left mouse button. A mark indicating a set breakpoint (●) is displayed on the vertical ruler.

After completing the setting of breakpoints, start the debugger:

Select "Run" > "Debug Configurations..." from the menu bar. The "Debug Configurations" dialog box appears. Select "Remote COBOL Application" from the left pane and press the "New" button to create a configuration.
Select "Normal Debug" for "Debug Style", and select "Debug" button to start debugging.

A message is displayed to confirm switching to the Debug perspective when the first breakpoint is reached. Click the "Yes" button.
The Debug perspective is displayed, and processing is stopped at the first breakpoint. To perform debugging, select the target menu item from "Run" in the menu bar.

**Point**

After completing debugging, select "Window" > "Open Perspective" > "COBOL" from the menu bar to return to COBOL perspective.
Chapter 3  COBOL Perspective

The NetCOBOL Studio window consists of the editor area and information display windows (views). The types of views displayed and the layout of the views are managed as "perspectives". The COBOL perspective, a perspective designed for COBOL program development, is applied when a COBOL project is created.

The COBOL perspective consists of the COBOL editor and the following views:
- Dependency view(*)
- Structure view(*)
- Navigator view(*)
- Properties view
- Outline view
- Problems view
- Tasks view
- Console view
- Templates view

*: In the properties dialog box, COBOL uses the following pages:
- Info page
- Target page
- Build page
- Builders page
3.1 Dependency View

The "Dependency" view displays a tree showing dependencies between the files to be compiled and files to be linked when a project coded in COBOL is built. The "Dependency" view displays the following three types of subfolders:

- Source Files folder
  
  The Source Files folder specifies the COBOL source files, precompiler input source files and resource files (.rc) to be compiled. Only files that have been added to this folder are compiled by the corresponding compilers.

- Linking Files folder
  
  The files to be linked are displayed in the Linking Files folder. The folder specifies the library files (.lib) and object files (.obj) to be linked, in addition to files to be compiled.

- Other Files folder
  
  Files that are in the project but are registered in neither the Source Files folder nor the Linking Files folder are displayed in the Other Files folder.

3.1.1 The role of the Dependency view

The "Dependency" view displays dependencies within a project.

Note

The structure of COBOL source files and the class structure of a COBOL class repository are displayed in the "Structure" view.

The following folders are created in the "Dependency" view when a COBOL project is created:

- Source Files folder
- Linking Files folder
- Other Files folder

Source Files folder

The Source Files folder specifies the files to be compiled in the project. The files displayed in this folder are compiled and linked at program build time. Files with .cob, .cbl, and .cobol extensions are treated as COBOL source files and compiled by a COBOL compiler. Files registered as precompiler input source are called by the precompiler command before compilation. Files with the .rc extension are compiled only when the resource compiler has been added as a build tool to the project.

The files in the Source Files folder are compiled in the order displayed, with the dependencies of the files taken into consideration. To change the position of a file in the compilation order, select the file, and use or on the toolbar to move the file up or down, respectively.

For COBOL source files in the Source Files folder, the following folders are displayed according to the contents of the files or specified options:

- Target Repository folder

  The repository file that is generated when COBOL source files are compiled are automatically analyzed and displayed when the COBOL source files are saved. The generated repository file corresponds to the class defined in the COBOL source files. The name of the generated repository file is "class-name.rep". The repository file displayed in this folder is used to automatically determine the compilation order of the COBOL source files. It is also used to search for files that must be compiled when they are updated.
- **Dependent Files folder**

The Dependent Files folder specifies the files on which COBOL source files depend. It also specifies the libraries referenced by the COBOL source files or the repository files of classes referenced by the COBOL source files. The files specified with this folder are used to automatically determine the compilation order of the COBOL source files. They are also used to search for files that must be compiled when they are updated. To add files, select "Add File..." from the context menu. Executing "Analyze Dependency" from the context menu enables the COBOL source files to be automatically analyzed, and files on which they depend to be added.

- **Target Object Files folder**

The Target Object Files folder is displayed when "Specify Target Object Files" is selected from the context menu. The object files to be generated from COBOL source files are displayed. The object files displayed in this folder are to be linked. The displayed object files are updated when the COBOL source files are saved.

These folders are used to automatically determine the compilation order of the COBOL source files.

---

**Note**

- To specify the name of a COBOL source file to register, specify a name that is different from the name of any other COBOL source file. If a COBOL source file with the same file name but a different extension is registered in the Source Files folder, an error occurs during build.
- Files registered in the Source Files folder with the extensions ".cobol" and ".cob" are treated as COBOL source files. Files with the extension ".cbl" are treated as library files.
- Of the COBOL library and descriptor files registered in the Dependent Files folder, only those within the project are transferred to the server during remote development. Files in other projects, and COBOL library and descriptor files managed in other folders, are not transferred. The only library files transferred to the server are those with the extension ".cbl".

---

**Linking Files folder**

The Linking Files folder specifies the library files (.lib) and object files (.obj) to be linked at build time. The object files to be generated from the COBOL source files specified with the Source Files folder need not be specified.

**Other Files folder**

Files that are in the project but registered in neither the Source Files folder nor the Linking Files folder are displayed in the Other Files folder.

---

**Point**

Operations involving files in the "Dependency" view are reflected in the "Structure" view.

---

### 3.1.1.1 Adding a COBOL source file in the Dependency view

For a COBOL source file in a project

Follow the steps below to add a COBOL source file to the project.

1. Select the "Source Files" folder in the "Dependency" view.
2. Select "Add File..." from the context menu.
3. The "Add Source Files" dialog box for the selected project appears.
4. Select the file to be added to the "Source Files" folder.
5. Click the "OK" button. The selected COBOL source file is added to the "Source Files" folder in the "Dependency" view. The addition of that added file is reflected in the "Structure" view.

For a COBOL source file that is not in a project

Either of the following methods can be used to add a COBOL source file that is not in the project:
Using Explorer in the Windows system, select the COBOL source file to be registered, and then select "Copy" from the context menu. Select the "Source Files" folder, and select "Paste" from the context menu.

Using Explorer in the Windows system, drag and drop the COBOL source file into the "Source Files" folder.

3.1.1.2 Adding a link file in the Dependency view
To add a link file:
1. Select the "Linking Files" folder to which the file is to be added.
2. Select "Add File..." from the context menu. The "Open" dialog box appears.
3. Select the file to be added to the "Linking Files" folder.
4. Click the "Open" button. The selected file is added to the Linking Files folder in the "Dependency" view. The addition of that added file is reflected in the "Structure" view.

3.1.1.3 Adding a dependent file
To add a dependent file:
1. Select the "Dependent Files" folder to which the file is to be added.
2. Select "Add File..." from the context menu. The "Open" dialog box appears.
3. Select the file to be added to the "Dependent Files" folder.
4. Click the "Open" button. The selected file is added to the "Dependent Files" folder.

3.1.1.4 Deleting a dependent file
To delete a dependent file:
1. Select the file to be deleted from the "Dependent Files" folder.
2. Select "Delete" from the context menu.
3. Click the "Yes" button when the file deletion confirmation message is displayed. The file is deleted from the "Dependent Files" folder.

Note
The file is deleted only from the "Dependent Files" folder. Even though the file is deleted from the "Dependent Files" folder, it is not deleted from the disk.

3.1.2 Context menu of the Dependency view
The following table outlines the context menu items that are unique to the "Dependency" view.

3.1.2.1 COBOL project
<table>
<thead>
<tr>
<th>Element</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target Repository</td>
<td>S</td>
<td>Makes the selected project, folder or file become the root of the displayed hierarchy.</td>
</tr>
<tr>
<td>Element</td>
<td>Menu</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>--------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Project</td>
<td>S S S S S S</td>
<td>Open <strong>Opens the selected file.</strong></td>
</tr>
<tr>
<td>Source Files</td>
<td>S C D S C D</td>
<td>Open From Application <strong>Selects an editor (COBOL editor, text editor, system editor, default editor) to open the selected file.</strong></td>
</tr>
<tr>
<td>Dependent Files</td>
<td>C D C D C D</td>
<td>Inheritance <strong>Not to be used.</strong></td>
</tr>
<tr>
<td>Target Repository</td>
<td>S S S S S S</td>
<td>Copy <strong>Copies the selected project, folder or file.</strong></td>
</tr>
<tr>
<td>Link Files</td>
<td>S C D C D C</td>
<td>Paste <strong>Pastes the copied project, folder or file.</strong> Menu can be used when a project is copied.</td>
</tr>
<tr>
<td>Other Files</td>
<td>S D S S S S</td>
<td>- When a project is copied, it will be pasted into the workspace.</td>
</tr>
<tr>
<td>Dependent Files</td>
<td>C D D S S S</td>
<td>- When a folder is copied, if the selected element is the &quot;Other Files&quot; folder or the subordinate's element, this menu can be used.</td>
</tr>
<tr>
<td>Target Repository</td>
<td>C D D C D D</td>
<td>- When a file is copied, if the selected element is folder, it will be pasted into the folder. If the selected element is file, it will be pasted into the folder of the selected file.</td>
</tr>
<tr>
<td>Linking Files</td>
<td>C D C D D D</td>
<td>Delete <strong>Deletes the selected elements.</strong></td>
</tr>
<tr>
<td>Other Files</td>
<td>S C D C D D</td>
<td>- If the selected element is project, the selected project is deleted from the workspace. You can decide whether to delete the selected project from the disk.</td>
</tr>
<tr>
<td>Dependent Files</td>
<td>S D S S S S</td>
<td>- If the selected element is a file in the &quot;Dependent Files&quot; folder, the selected file will be deleted from &quot;Dependent Files&quot; folder and moved into the &quot;Other Files&quot; folder. The selected file is not deleted from the disk.</td>
</tr>
<tr>
<td>Other Files</td>
<td>S D S S S S</td>
<td>For details, see &quot;3.1.1.4 Deleting a dependent file&quot;.</td>
</tr>
<tr>
<td>Dependent Files</td>
<td>S D S S S S</td>
<td>- If the &quot;Target Object Files&quot; folder is selected, &quot;specify target object file&quot; will be unchecked and the &quot;Target Object Files&quot; folder is deleted. Files on disk are not deleted.</td>
</tr>
<tr>
<td>Element</td>
<td>Menu</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>Project Folder</td>
<td>Rename</td>
<td>Renames the selected folder or file.</td>
</tr>
<tr>
<td>Project File</td>
<td>Add To Source</td>
<td>Adds the selected file to the Source Files folder. When the file is added to the <em>Source Files</em> folder, it will be removed from the <em>Other Files</em> folder. If the file is in a folder other than the project storage location, it is copied to the project storage location.</td>
</tr>
<tr>
<td>Other Files</td>
<td>Remove from Source Folder</td>
<td>Deletes the selected COBOL source files from the <em>Source Files</em> folder and moves them to the <em>Other Files</em> folder. The files are not deleted from the disk.</td>
</tr>
<tr>
<td>Target Repository Folder</td>
<td>Main program</td>
<td>Sets the selected source program as the main program of this project.</td>
</tr>
<tr>
<td>Target Repository File</td>
<td>Reset Main Program</td>
<td>Releases the setting of main program from the selected COBOL source file. This menu item is only displayed when the COBOL source file, which is the main program, is selected.</td>
</tr>
<tr>
<td>Link Files Folder</td>
<td>Specify Target Object Files</td>
<td>This menu item is selected for COBOL source files containing multiple compilation units (external programs or external classes). The files for which this menu item is selected (checked) are compiled after the NAME compile option is added to the other compile options of the files.</td>
</tr>
</tbody>
</table>

- If the selected element is a file in the "Link Files" folder, the selected file is not deleted from the disk.
- If the selected element is a file or a folder other than the above, it will be deleted from the disk.

For details, see "6.1.2 Setting the main program".
<table>
<thead>
<tr>
<th>Project</th>
<th>Folder</th>
<th>File</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source Files</td>
<td>Target Repository</td>
<td>Source Files</td>
<td>S</td>
<td><strong>Analyze dependency</strong></td>
</tr>
<tr>
<td></td>
<td>Target Project File</td>
<td>Target Object Files</td>
<td>S</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Link Files</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Other Files</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Folder under (Other Files)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Target Repository</td>
<td>Target Object Files</td>
<td>S</td>
<td>Adds the target repository files to the &quot;Dependent Files&quot; folder. These target repository files are generated from library files, screen form descriptor files, dependent repository files to which COBOL source files refer, and COBOL source files.</td>
</tr>
<tr>
<td>Library</td>
<td>S</td>
<td>S</td>
<td>Add target repository files to which COBOL source files refer, to the &quot;Dependent Files&quot; folder.</td>
<td></td>
</tr>
<tr>
<td>Repository</td>
<td>S</td>
<td>S</td>
<td>Add dependent repository files to which the COBOL source files refer, to &quot;Dependent Files&quot; folder.</td>
<td></td>
</tr>
<tr>
<td>Depends</td>
<td>S</td>
<td>S</td>
<td>Add dependent repository files to which the COBOL source files refer, to &quot;Dependent Files&quot; folder.</td>
<td></td>
</tr>
<tr>
<td>Target object</td>
<td>S</td>
<td>S</td>
<td>Add the name of object file generated from the COBOL source file to the &quot;Target Object Files&quot; folder.</td>
<td></td>
</tr>
<tr>
<td>Clear</td>
<td>S</td>
<td>S</td>
<td>Deletes all the files in the &quot;Dependent Files&quot; folder and clears their dependencies.</td>
<td></td>
</tr>
</tbody>
</table>

Object file generated from the COBOL source file is added to the "Target Object Files" folder.
<table>
<thead>
<tr>
<th>Project</th>
<th>Folder</th>
<th>File</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source Files</td>
<td></td>
<td></td>
<td>C D</td>
<td>Build project</td>
</tr>
<tr>
<td></td>
<td>Target Repository</td>
<td></td>
<td>C D</td>
<td>Rebuild project</td>
</tr>
<tr>
<td></td>
<td>Target Project File</td>
<td></td>
<td>C D</td>
<td>Build Debug Mode</td>
</tr>
<tr>
<td></td>
<td>Dependent Files</td>
<td></td>
<td>C D</td>
<td>Build</td>
</tr>
<tr>
<td></td>
<td>Link Files</td>
<td></td>
<td>C D</td>
<td>Rebuild</td>
</tr>
<tr>
<td></td>
<td>Other Files</td>
<td></td>
<td>C D</td>
<td>Makefile Creation</td>
</tr>
<tr>
<td></td>
<td>Other Files</td>
<td></td>
<td>C D</td>
<td>Remote Debugger Connector</td>
</tr>
<tr>
<td></td>
<td>Source Files</td>
<td></td>
<td>C D</td>
<td>Transfer</td>
</tr>
<tr>
<td></td>
<td>Target Repository</td>
<td></td>
<td>C D</td>
<td>Compile File</td>
</tr>
<tr>
<td></td>
<td>Dependent Files</td>
<td></td>
<td>C D</td>
<td>Refresh</td>
</tr>
<tr>
<td></td>
<td>Link Files</td>
<td></td>
<td>C D</td>
<td>Property</td>
</tr>
<tr>
<td></td>
<td>Other Files</td>
<td></td>
<td>C D</td>
<td></td>
</tr>
</tbody>
</table>

Meaning of signs

- "C": Can be selected.
- "D": Displayed.
- "S": Selected (default).
For the menu below, refer to the "3.3.3 Navigator view Context menu ".

- Team
- Compare With
- Replace
- Restore from Local History
- Source

### 3.1.2.2 COBOL Resource Project

<table>
<thead>
<tr>
<th>Element</th>
<th>Project</th>
<th>File</th>
<th>Folder</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>S</td>
<td></td>
<td>Jump into</td>
<td>Makes the selected project, folder or file become the root of the displayed hierarchy.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>S</td>
<td></td>
<td>Back</td>
<td>Returns to the previous hierarchy.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>S</td>
<td></td>
<td>Forward</td>
<td>Proceeds to the former display hierarchy, when the &quot;Jump&quot; &gt; &quot;Back&quot; menu item is selected.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>S</td>
<td></td>
<td>Up One Level</td>
<td>Changes the display hierarchy to one up from the level of the present display hierarchy.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>S</td>
<td></td>
<td>Open</td>
<td>Opens the selected file.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>S</td>
<td></td>
<td>Open from Application</td>
<td>Selects an editor (COBOL Editor, Text Editor, System Editor or Default Editor) to open the selected file.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>S</td>
<td>S</td>
<td>Delete</td>
<td>Deletes the selected project, folder or file.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>S</td>
<td></td>
<td></td>
<td>- When a project is selected, the COBOL Resource project will be deleted. You can choose whether to delete from disk.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>S</td>
<td></td>
<td></td>
<td>- When a folder or file is selected, it will be deleted from the disk.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>S</td>
<td>S</td>
<td>Rename</td>
<td>Changes the name of the selected folder or file.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>N</td>
<td>S</td>
<td>Remote Development Build Debug mode</td>
<td>Cannot be used for COBOL Resource projects.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Build</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Rebuild</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Makefile Creation</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Remote Debugger Connector</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>S</td>
<td></td>
<td>Transfer</td>
<td>Transfers the resource of the project to a remote server.</td>
</tr>
</tbody>
</table>
### Project 

<table>
<thead>
<tr>
<th>Element</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project</td>
<td></td>
<td></td>
</tr>
<tr>
<td>File</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Folder</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

| S       | Refresh  | Refreshes the selected element and its subordinate. |
| S       | Property | Displays the property of the selected element.   |

**Meaning of signs:**

- **S**: Menu can be selected
- **NS**: Menu cannot be selected
- **Space**: Menu cannot be displayed.

For the following menu, see *3.3.3 Navigator view Context menu*.
- Team
- Compare With
- Replace With
- Restore from Local History
- Source

### 3.1.2.3 COBOL Solution Project

This section explains the context menu that displays when a COBOL solution project is selected. For information about the context menu that displays when a project added to COBOL solution project is selected, see *3.1.2.1 COBOL project* and *3.1.2.2 COBOL Resource Project*.

<table>
<thead>
<tr>
<th>menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jump into</td>
<td>Makes the selected project, folder or file become the root of the displayed hierarchy.</td>
</tr>
<tr>
<td>Jump</td>
<td></td>
</tr>
<tr>
<td>Back</td>
<td>Returns to the previous hierarchy.</td>
</tr>
<tr>
<td>Forward</td>
<td>Proceeds to the former display hierarchy, when the &quot;Jump&quot; &gt; &quot;Back&quot; menu item is selected.</td>
</tr>
<tr>
<td>Up One Level</td>
<td>Changes the display hierarchy to one level up from the present display hierarchy.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected project from the workspace. You can choose whether to delete it from the disk. Projects added to the selected COBOL solution project are not deleted.</td>
</tr>
<tr>
<td>Project Management</td>
<td>Displays the &quot;Project Management&quot; dialog box. Projects can be added to or removed from the selected COBOL solution project. For the addition and the removal of projects, see <em>4.3.1 Manage COBOL project</em>.</td>
</tr>
<tr>
<td>Analyze Dependency</td>
<td>Performs Dependency Analysis for COBOL projects added to the selected COBOL solution project.</td>
</tr>
<tr>
<td>Build Project</td>
<td>Builds COBOL projects added to the selected COBOL solution project. For project build details, see <em>Chapter 6 Build Function</em>. This menu is displayed only when &quot;Build Automatically&quot; from the &quot;Project&quot; menu is not checked.</td>
</tr>
</tbody>
</table>
### menu

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rebuild Project: Rebuilds COBOL projects added to the selected COBOL solution project. For project build details, see &quot;Chapter 6 Build Function&quot;.</td>
</tr>
<tr>
<td>Remote Development: Build Debug Mode: Changes the build mode of COBOL projects added to the selected project. Specifies whether projects are to be built in release mode or in debug mode for remote project build. For remote project build details, see &quot;9.5 Remote Build&quot;.</td>
</tr>
<tr>
<td>Build: Builds COBOL projects added to the selected COBOL solution project. For remote project build details, see &quot;9.5 Remote Build&quot;.</td>
</tr>
<tr>
<td>Rebuild: Rebuilds COBOL projects added to the selected COBOL solution project. For remote project build details, see &quot;9.5 Remote Build&quot;.</td>
</tr>
<tr>
<td>Makefile Creation: Cannot be used for COBOL solution projects.</td>
</tr>
<tr>
<td>Remote Debugger Connector</td>
</tr>
<tr>
<td>Transfer: Refresh: Refreshes the selected element and its subordinate.</td>
</tr>
<tr>
<td>Property: Displays the property of the selected element.</td>
</tr>
</tbody>
</table>

For the following menu, see "3.3.3 Navigator view Context menu".

- Team
- Compare With
- Restore from Local History

#### 3.1.3 Analyze Dependency

"Analyze Dependency" is the menu command for adding the following files that the COBOL source files associated with the "Dependent File".

- Library file
- Screen form descriptor file

Execute the "Analyze Dependency" in any one of the following conditions.

a. The COPY statement is added to or deleted from the COBOL source file.

   Execute the "Analyze Dependency" regarding the modified COBOL source files as target.

   1. Select the modified COBOL source file in the "Dependency" view.
   2. Select "Analyze Dependency" > "All" from the context menu.

b. When one of the following happens with the workspace:

   - The library file used for projects (COBOL project or COBOL resource project) are added to or deleted from the workspace.
   - The dependent file is added to or deleted from the library file used for projects (COBOL project or COBOL resource project).
   - Under the setting of translation option, the reserved folder appointed library file in the translation option LIB or the reserved folder appointed descriptor file in the translation option FORMLIB, is modified.

   Execute the "Analyze Dependency" regarding the project that dependency happens in workspace as target in above conditions.

   1. Select the COBOL project in the "Dependency" view.
   2. From the context menu, select "Analyze Dependency" > "All".

c. Compiler option.
Following are some merits when executing "Analyze Dependency".

- The dependent file can be added to the "Dependent Files" folder automatically.
- The dependent file can be modified (updated, saved) from the COBOL project that the COBOL source files of the reference is registered in.

The screen form descriptor that is added as a dependent file can be updated in PowerFORM.

The form descriptor (.SMU/.PMU) used for UTF-32, which is produced with the Descriptor transformation command used for UTF-32, is not the target of "Analyze Dependency". The screen form descriptor (.SMU/.PMU) used for UTF-32 cannot be added to dependent file.

3.2 Structure View

The "Structure" view hierarchically displays the internal program structure of COBOL source files. The "Structure" view has the following three types of subfolders:

- Source Files folder
- Linking Files folder
- Other Files folder

3.2.1 The role of the Structure view

Source Files folder

COBOL source files to be compiled are displayed in the Source Files folder. Its contents are equivalent to those of the Source Files folder in the "Dependency" view. The internal structure of each COBOL source file is hierarchically displayed under the COBOL source file. The structure displayed under each COBOL source file is as follows:

- For an ordinary COBOL source file
  - PROGRAM-ID
  - Environment division and section-name
  - Data division and section-name
  - Procedure division, section-name, and paragraph-name

- For an object-oriented COBOL source file
  - CLASS-ID
  - FACTORY
  - OBJECT
  - METHOD-ID
  - Environment division and section-name
  - Data division and section-name
  - Procedure division, section-name, and paragraph-name
Linking Files folder

Files to be linked but not compiled are displayed in the Linking Files folder. Its contents are equivalent to those of the Linking Files folder in the "Dependency" view.

Other Files folder

Files that are to be neither compiled nor linked are displayed in the Other Files folder. Its contents are equivalent to those of the Other Files folder in the "Dependency" view.

3.2.2 Context menu of the Structure view

The following table outlines the context menu items that are unique to the "Structure" view:

<table>
<thead>
<tr>
<th>Element</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Folder</td>
<td>File</td>
</tr>
<tr>
<td></td>
<td>Source file</td>
<td>Link file</td>
</tr>
<tr>
<td></td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td></td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td></td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td></td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td></td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td></td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td></td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td></td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td></td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td></td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td></td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td></td>
<td>C</td>
<td>D</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- When the project is copied, it will be pasted into the workspace.</td>
</tr>
<tr>
<td>Project</td>
<td>Folder</td>
<td>File</td>
</tr>
<tr>
<td>---------</td>
<td>--------</td>
<td>------</td>
</tr>
<tr>
<td>Source file</td>
<td>Link file</td>
<td>Other file</td>
</tr>
<tr>
<td>delete</td>
<td></td>
<td></td>
</tr>
<tr>
<td>S</td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td>delete from Source file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>S</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add To Source</td>
<td></td>
<td></td>
</tr>
<tr>
<td>S</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Main program</td>
<td></td>
<td></td>
</tr>
<tr>
<td>C</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Reset Main Program</td>
<td></td>
<td></td>
</tr>
<tr>
<td>C</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Specify Target Object Files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>S</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- When the folder is copied, if the selected element is the [Other Files] folder or the subordinate's element, this menu can be used.
- When the file is copied, if the selected element is folder, it will be pasted into the folder. If the selected element is file, it will be pasted into the folder of the selected file.

- Deletes the selected elements.
  - If the selected element is project, the selected project is deleted from the workspace. You can decide whether to delete the selected project from the disk.
  - If the selected element is a file in the [Link Files] folder, the selected file is not deleted from the disk.
  - If the selected file is other than a file in the [Link Files] folder, the selected file or folder is deleted from the disk.

- Renames the selected folder or file.

- Adds the selected file to the Source Files folder. When the file is added to the *Source Files* folder, it will be removed from the *Other Files* folder. If the file is in a folder other than the project storage location, it is copied to the project storage location.

- Deletes the COBOL source files from *Source Files* folder and moves them to the *Other Files* folder. The files are not deleted from the disk.

- Sets the selected source program as the main program of this project.
  
  This menu item is displayed when the selected COBOL source is not the main program. When the target of the project is an executable file, it is possible to select it.

  Only one main program can be set for each project.
  
  For details, refer to "6.1.2 Setting the main program".

- Releases the setting of main program from the selected COBOL source file. This menu item is displayed when the selected COBOL source file is the main program. For details, refer to "6.1.2 Setting the main program".

- Select this menu item for COBOL source files containing multiple compilation units (external programs or external classes). The NAME compile option is added to the other compile options and then the checked files are built.
<table>
<thead>
<tr>
<th>Element</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project</td>
<td>Build project</td>
<td>Builds the selected project. For details, refer to &quot;Chapter 6 Build Function&quot;. This menu is displayed only when &quot;Build Automatically&quot; in the &quot;Project&quot; menu is not checked.</td>
</tr>
<tr>
<td>Project</td>
<td>Rebuild project</td>
<td>Rebuilds the selected project. For details, refer to &quot;Chapter 6 Build Function&quot;.</td>
</tr>
<tr>
<td>Remote development</td>
<td>Build Debug Mode</td>
<td>When remote development function is used, this specifies whether the project is to be built in release mode or in debug mode for a remote project build. For remote project build details, see &quot;9.5 Remote Build&quot;.</td>
</tr>
<tr>
<td>Remote development</td>
<td>Build</td>
<td>If the remote development function is used, this builds the project remotely. For remote project build details, see &quot;9.5 Remote Build&quot;.</td>
</tr>
<tr>
<td>Remote development</td>
<td>Rebuild</td>
<td>If the remote development function is used, this rebuilds the project remotely. For remote project build, see &quot;9.5 Remote Build&quot;.</td>
</tr>
<tr>
<td>Remote development</td>
<td>Makefile Creation</td>
<td>If the remote development function is used, the makefile for remote development is generated. For remote project build details, refer to &quot;9.5 Remote Build&quot;.</td>
</tr>
<tr>
<td>Remote development</td>
<td>Remote Debugger Connector</td>
<td>Starts the remote debugger connector. Before performing attach debugging, use the remote debug connector when you want to change the restriction and the port number of the computer that performs the remote debug. For remote debug connector details, refer to &quot;9.6.2.2 Remote debugger connector&quot;.</td>
</tr>
<tr>
<td>Transfer</td>
<td>Transfer</td>
<td>Cannot be used for COBOL projects.</td>
</tr>
<tr>
<td>Compile File</td>
<td>Compile File</td>
<td>Compiles the selected file.</td>
</tr>
<tr>
<td>Refresh</td>
<td>Refresh</td>
<td>Refreshes the selected element and its subordinate.</td>
</tr>
<tr>
<td>Property</td>
<td>Property</td>
<td>Displays the property of the selected elements.</td>
</tr>
</tbody>
</table>

**Meaning of signs**

S: Menu can be selected  
NS: Menu cannot be selected  
CD: Menu can be displayed under certain conditions  
Space: Menu cannot be displayed.

For the menu below, refer to the "3.3.3 Navigator view Context menu ".

- Team
3.2.2.2 COBOL resource project

The context menu of selected COBOL resource project is the same as "Dependency" view context menu. Refer to "3.1.2.2 COBOL Resource Project" under "Dependency view".

3.2.2.3 COBOL solution project

The context menu of selected COBOL solution project is the same as the "Dependency" view context menu except that "Analyze Dependency" is not displayed. Refer to "3.1.2.3 COBOL Solution Project" under "Dependency View".

3.3 Navigator View

The "Navigator" view hierarchically displays resources in a workspace. This view displays all the files and folders in each project. A file can be opened by double-clicking it. A project can be created, opened, or closed from the context menu of the "Navigator" view.

3.3.1 The role of the Navigator view

The "Navigator" view displays files in existing subfolders and folders of a project. The following operations can be performed from the "Navigator" view:

- Creating a project, file, or folder
- Opening a project, file, or folder
- Closing a project
- Deleting a project, file, or folder
- Renaming a project, file, or folder
- Setting properties for a project
- Applying a filter
- Sharing files in the Concurrent Versions System (CVS)

3.3.1.1 Applying a filter to the view

Follow the procedure below to apply a filter to the view.

1. Click \[\] in the "Navigator" view.
2. Select "Filters..." from the option list. The "Navigator Filters" dialog box appears.
3. Select one or more filters to be applied from the option list.
4. To select all filters, click the "Select All" button. To clear the filter, click the "Deselect All" button.
5. To apply all selected filters to the "Navigator" view, click the "OK" button. The dialog box closes. To close the dialog box without applying the filters to the "Navigator" view, click the "Cancel" button.

3.3.1.2 Sharing files in the Concurrent Versions System (CVS)

In the team programming environment of the Concurrent Versions System (CVS), each team member performs work independently from the other members. A CVS repository can be shared with other team members. Only a project or the files in a project can be shared. If a project is shared, only the files in the project are displayed in the repository. Other team members can access only the files that are explicitly shared.
Sharing an existing CVS repository location and project

To share an existing CVS repository location and project:

1. Select the project from the "Navigator" view, and select "Team" > "Share Project" from the context menu.
2. The "Share Project" dialog box appears.
3. Select "Use existing repository location" to use an existing repository.
4. Select the location from the displayed list.
5. Click the "Finish" button. The project is shared at the selected CVS repository location.

Sharing a new CVS repository location and project

To share a new CVS repository location and project:

1. Select the project from the "Navigator" view, and select "Team" > "Share Project" from the context menu.
2. The "Share Project" dialog box appears.
3. Select "Create a new repository location" to create a repository.
4. Click the "Next" button.
5. Specify the following on the "Enter Repository Location Information" page.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host</td>
<td>Select or enter the host address.</td>
</tr>
<tr>
<td>Repository path</td>
<td>Select or enter the repository path to the host.</td>
</tr>
<tr>
<td>User</td>
<td>Enter the user name for a connection to the host.</td>
</tr>
<tr>
<td>Password</td>
<td>Enter the password for host access.</td>
</tr>
<tr>
<td>Connection type</td>
<td>Select the type of CVS connection to the repository.</td>
</tr>
<tr>
<td>Use Default Port</td>
<td>Select a port for the connection.</td>
</tr>
<tr>
<td>Use Port</td>
<td>Select a port from the list box.</td>
</tr>
<tr>
<td>Save password</td>
<td>When checked, the password is saved to the computer.</td>
</tr>
</tbody>
</table>

6. Click the "Next" button.
7. Specify the options on the Enter Module Name page as follows:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use project name as module name</td>
<td>Specify this option to use the project name as a module name.</td>
</tr>
<tr>
<td>Use specified module name</td>
<td>Check this item to not use the project name as a module name, and enter a module name in the text box.</td>
</tr>
</tbody>
</table>

8. Click the "Finish" button. The project is shared at the new CVS repository location.

Sharing a file

To share a file:

1. Select the file from a project folder.
2. Select "Team" > "Add to Version Control" from the context menu.
3. Select "Commit" from the context menu of the file or project.
4. The file is shared at the CVS repository location, and other users can access the file.
Accessing a project or file in a CVS repository

To access a project or file in a CVS repository:
1. Select "Windows" > "Open Perspective" > "Other..." > "CVS Repository Exploring" from the menu bar. The CVS Repository perspective opens.
2. Expand the host that has shared projects and files.
3. Select the project for checkout processing.
4. Select "Check Out As" from the context menu. The Check Out As dialog box appears. Select "Check out as a project in the workspace" and enter a project name in the Project Name field.
5. Click the "Finish" button. The display returns to the COBOL perspective, where the "Navigator" view displays the project and the files under the project.

Comparing versions of a source file

To compare the latest version of a COBOL source file with an older version:
1. In the "Navigator" view, select the version of the COBOL source file whose contents are to be compared with the current version.
2. Select "Compare With" > "Local History" from the context menu. The "Compare with Local History" dialog box appears.
3. Select a version from the Local History list.
4. The latest version of the COBOL source file is displayed in the Workspace File area of the Text Compare editor, and the selected version is displayed in the Local History area. Modifications in the text in each file are highlighted.
5. To move to the previous or next modification, select the appropriate button.
6. To close the dialog box, click the "OK" button.

Replacing a current file with a previous version

To replace the current COBOL source file with a previous version:
1. In the "Navigator" view, select the COBOL source file to be replaced.
2. Select "Replace With" > "Local History" from the context menu. The Replace from Local History dialog box appears.
3. Select a version from the Local History list.
4. The current version of the COBOL source file is displayed in the right pane of the Text Compare editor, and the selected version is displayed in the Local History area in the left pane. Modifications in each file are highlighted.
5. To replace the file of the current version with that of the selected version, click the "Replace" button. The dialog box closes. To close the dialog box without replacing the file, click the "Cancel" button.

Note
*Replace With" > "Previous from Local History" is selected; the current version of the file is replaced with that of the last stored version.

To perform a Replace With operation for an open file, first save the replacement file.

3.3.1.3 Property options

The properties of the selected resource are displayed when File is used, or when Properties in the context menu is used. The items displayed in the Properties page depend on the selected resource. For example, if a file is selected, only specific properties are displayed; if a project is selected, all setting options are displayed. Property options are displayed by selecting "File" > "Properties" from the menu bar. Options can be displayed, or their settings can be changed using the Properties dialog box.
Displaying and setting file properties
To change the read-only status of a file:
1. Select “Info” in the Properties dialog box.
2. The details of Path, Type, Location, and Last modified are displayed on the Info page.
3. The file properties can be changed by selecting Read Only or canceling the selection.

Displaying and setting project reference properties
To enable a resource to reference another project in a workspace:
1. Select "Project References" in the Properties dialog box.
2. The Project References page is displayed.
3. To enable the resource to reference another project in the workspace, select the other project from the list.

3.3.2 Navigator view Tools
Tools of the "Navigator" view can be used for various operations.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>←</td>
<td>Returns to the previous hierarchical view.</td>
</tr>
<tr>
<td>→</td>
<td>Proceeds to the next hierarchical view.</td>
</tr>
<tr>
<td>🡶</td>
<td>Displays the hierarchy at the next higher level.</td>
</tr>
<tr>
<td>🡴</td>
<td>Reduces the tree of all resources in the expanded display.</td>
</tr>
<tr>
<td>🡵</td>
<td>Toggles enabling the link between the &quot;Navigator&quot; view and the active editor.</td>
</tr>
<tr>
<td>🡵</td>
<td>Displays options such as Sort and Filters in the menu.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Working Set</td>
<td>Selects a working set.</td>
</tr>
<tr>
<td>Deselect Working Set</td>
<td>Cancels a working set.</td>
</tr>
<tr>
<td>Edit Active Working Set</td>
<td>Used to edit a working set.</td>
</tr>
<tr>
<td>Sort</td>
<td></td>
</tr>
<tr>
<td>by Name</td>
<td>Sorts files in alphabetical order.</td>
</tr>
<tr>
<td>by Type</td>
<td>Sorts file types in alphabetical order.</td>
</tr>
<tr>
<td>Filters</td>
<td>Filters the resources to be displayed.</td>
</tr>
<tr>
<td>Link with Editor</td>
<td>Toggles enabling the link between the &quot;Navigator&quot; view and the active editor.</td>
</tr>
</tbody>
</table>

3.3.3 Navigator view Context menu
The following table outlines the context menu items for the "Navigator" view:
<table>
<thead>
<tr>
<th>Element</th>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Project</strong></td>
<td><strong>Folder</strong></td>
<td><strong>File</strong></td>
</tr>
<tr>
<td><strong>Go Into</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Open in New Window</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Open With</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Copy</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Paste</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Delete</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Move</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Rename</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Import</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Export</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>build project</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>close project</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>open project</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>close unrelated project</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>refresh</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>execute</strong></td>
<td><strong>COBOL Application</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Open the organization and execution dialog</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>debug</strong></td>
<td><strong>COBOL Application</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>remote COBOL Application</strong></td>
</tr>
</tbody>
</table>
### Element List

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>open debug dialog</td>
<td>Opens the &quot;Open debug&quot; dialog. For details, refer to &quot;7.1.2 The startup configuration&quot;, &quot;9.6.1.2 Starting the remote debugger&quot; or &quot;9.6.2.1 Starting the remote debugger&quot;.</td>
</tr>
<tr>
<td>Team</td>
<td>Shares a project and displays the local history. (The sub-menu of the effective team function is displayed.) The sub-menu &quot;apply to patch&quot; cannot be used.</td>
</tr>
<tr>
<td>Compare with</td>
<td>Compares the selected resource. (Possible comparison targets are displayed as submenu items).</td>
</tr>
<tr>
<td>Replace With</td>
<td>Replaces the selected resource. (Possible replacements are displayed as submenu items).</td>
</tr>
<tr>
<td>Restore from Local History</td>
<td>Restores a deleted resource from the local history.</td>
</tr>
<tr>
<td>Source</td>
<td>This menu item cannot be used.</td>
</tr>
<tr>
<td>Properties</td>
<td>Displays the resource properties.</td>
</tr>
<tr>
<td>Compile file</td>
<td>Compiles the file.</td>
</tr>
</tbody>
</table>

**Meaning of signs**

- S: Menu can be selected
- NE: Menu cannot be selected
- CD: Menu can be displayed under certain conditions
- Space: Menu cannot be displayed.

---

**Point**

The functions of the "Navigator" view context menu, except Move and Replace With, can be used in the "Dependency" view and "Structure" view.

---

### 3.4 Property View

The Property view displays the properties of resources in the COBOL project selected in the Dependency, Structure, or "Navigator" view. Buttons are provided in the toolbar to toggle to display properties by category, to filter advanced properties, and to restore a selected property to its default value. For more information regarding a resource, right-click the resource name in one of the navigation views and select Properties from the pop-up menu.

### 3.5 Outline View

The Outline view displays a structural outline of the COBOL source file that is currently active in the COBOL editor. The contents of the Outline view vary depending on the COBOL program type. The tree structure displayed in the Outline view is as follows:
- For an ordinary COBOL source file
  - PROGRAM-ID
  - Environment division and section-name
  - Data division and section-name
  - Procedure division, section-name, and paragraph-name

- For an object-oriented COBOL source file
  - CLASS-ID
  - FACTORY
  - OBJECT
  - METHOD-ID
  - Environment division and section-name
  - Data division and section-name
  - Procedure division, section-name, and paragraph-name

Function of the Outline view

The Outline view has the following function:
- Move to an element
  The cursor in the editor is moved to the location of the selected element, such as a program name or method name.

3.5.1 Toolbar

<table>
<thead>
<tr>
<th>Operation</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sort</td>
<td>![Sort Icon]</td>
<td>Toggles the listing order of the section-name, paragraph-name, METHOD-ID elements between alphabetical order and the order specified in a COBOL source file. The listing order of divisions and FACTORY OBJECTs cannot be changed.</td>
</tr>
<tr>
<td>Procedure division</td>
<td>![Procedure Icon]</td>
<td>Toggles between displaying the contents of all divisions (procedure, environment, and data) and displaying the contents of only the procedure division.</td>
</tr>
</tbody>
</table>

3.6 Problems View

The Problems view displays error messages, warning messages, etc. for problems that occur during compilation. Each message displayed in the Problems view is associated with the corresponding COBOL source file or project. For each displayed COBOL compiler error or warning message, the corresponding COBOL source file and line number are indicated.

3.6.1 Problems view display

The information displayed in the Problems view is as follows

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Severity</td>
<td>Displays an icon representing a severity level (error, warning, or information).</td>
</tr>
<tr>
<td>Description</td>
<td>Provides an explanation of the problem.</td>
</tr>
<tr>
<td>Resource</td>
<td>Displays the names of resources associated with the problem. For global problems, the relevant project name is displayed.</td>
</tr>
<tr>
<td>Path</td>
<td>Displays the folder containing the resources associated with the problem.</td>
</tr>
</tbody>
</table>
3.6.2 Using the Problems view to locate an error

If an error occurs during a build for a project, the Problems view displays the error. To locate an error:

1. Errors are indicated as follows:
   - The Problems view displays a list of errors.
   - The lines containing errors are highlighted in the editor.

2. Double-click on an error in the Problems view, or select an error and then select **Go To** from the context menu. The file containing the detected error is opened in the editor, and the relevant location is highlighted.

3. Use the editor to modify erroneous coding and re-build the project. When the problem is resolved, the Problems view no longer displays the error.

**Note**

If the folder path is not displayed in the Problems view in the Path item, the error position cannot be identified, even **Go to** is selected from the context menu. This applies if the compile error is in a library external to the project.

3.7 Tasks View

The Tasks view can be used to record an issue as a task for future consideration. Tasks can be associated with COBOL source files. For additional information regarding the Tasks view, see the "Workbench User's Guide" in the Help information.

3.7.1 Tasks view display

The Tasks view displays the status, priority, and explanation of each task. Tasks that are associated with COBOL source files are displayed together with relevant file names, folders, and line numbers. The information displayed in the Tasks view is as follows:

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Completed</td>
<td>Indicates whether a task has been completed. Each completed task has a checkmark. Checkmarks for completed tasks can be also added manually.</td>
</tr>
<tr>
<td>Priority</td>
<td>Indicates the priority of a task (high, middle, or low). The priority of a task can be changed using the combo box in this column.</td>
</tr>
<tr>
<td>Description</td>
<td>Provides an explanation of a task. To edit the explanation provided by a user for a task, select this column.</td>
</tr>
<tr>
<td>Resource</td>
<td>Displays the names of resources involved in a task. This field is blank for global tasks.</td>
</tr>
<tr>
<td>In Folder</td>
<td>Displays the folder containing the resources involved in a task. This field is blank for global tasks.</td>
</tr>
<tr>
<td>Location</td>
<td>Displays the line numbers associated with a task.</td>
</tr>
</tbody>
</table>

3.7.2 Associating a task with a COBOL source file

Associating a task with a COBOL source file designates the sections to be displayed in a task list. To associate a task with a COBOL source file:

1. Use the COBOL editor to display the COBOL source file.
2. Using the vertical ruler on the left side of the COBOL editor, go to the line in the source file where the new task is to be recorded and select **Add Task** from the context menu.

3. Set the contents and priority of the task in the **New Task** dialog box, and click the **OK** button. The task is added to the Tasks view, and an icon representing the task is displayed to the left of the line on which the task was added.

4. The task in the COBOL source file can be displayed with the COBOL editor by double-clicking on the task in the Tasks view.

5. To delete the task, select **Remove Task** from the context menu of the task icon, or select the task in the Tasks view and press the **Delete** key.

### 3.8 Console View

The following functions can be used in the Console view:

- **COBOL remote**
  - In remote development, the results of makefile creation and the results of a build on a server can be displayed.

- **Build console**
  - The results of a COBOL program build on a local personal computer can be displayed.

### 3.9 Templates view

Use the following procedures to display the *Templates* view.

1. Select "Window" > "Show View" > "Other" from the menu bar. The "Show View" dialog box is displayed.

2. Select "COBOL" > "Templates" and the *Templates* view is displayed.

In the *Templates* view, root category, category and template are displayed as hierarchy.

The root category is "COBOL".

The category is "Reference", "Statement" and so on displayed in icon.

Template is "COPY statement [COPY]", "REPLACE statement [REPLACE]" and so on displayed in icon.

The content of the displayed template in the *Templates* view is different based on the extension of opening file in the active editor. For example, the defined [COBOL] root category is associated with the following file extensions.
When opening a file that has an extension that is not associated with the defined root category in the editor, or the file cannot be opened in the editor, only the main file ("templates.xml") without the root category is displayed in "Templates" view.

**Note**

"COBOL" is the defined root category. The defined root category cannot be deleted or renamed.

### 3.9.1 The role of Templates View

In the "Templates" view, the following functions can be used.

- Insert template pattern (*1) into source file.
- Edit, add and delete template.
- Import and export template.
- Activate and invalidate template

*1: Also can call Model code which is inserted with using template "template pattern".

"Templates" view is useful for when inserting the syntax of the COBOL language into the source file, it.

#### 3.9.1.1 Insert template patterns into source file

The example below illustrates inserting a PERFORM statement from a template into the procedure division of a COBOL source file.

```
PERFORM WITH TEST BEFORE
   VARYING repeat count FROM 1 BY 1
   UNTIL repeat count > 26
```

1. Opens the edited COBOL source file in the COBOL editor.
2. PERFORM statement is inserted into position at which the cursor is positioned.
3. Displays the inserted template pattern in the "Templates" view.

**Point**

The content of displayed template in "Templates" view is different according to the extension of opening file in active editor. Displays the root category used for COBOL when opening COBOL source file (the file whose extension is .cob, .cobol or .cbl).

4. Selects the inserted template pattern, and then select "Insert with Parameter Value..." or "Insert with Multiple Parameter Values..." from context menu, "Input Assistance" dialog box displays.
5. Input identifier, initial values, incremental value of PERFORM statement and then click "OK" button.

<table>
<thead>
<tr>
<th>Table 3.1 Input Assistance dialog box</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Item</strong></td>
</tr>
<tr>
<td>Pattern preview</td>
</tr>
<tr>
<td>Description</td>
</tr>
<tr>
<td>Enter parameter value</td>
</tr>
</tbody>
</table>
PERFORM statement is inserted into COBOL source file.

The condition that template pattern without arguments.

In the condition that template pattern without arguments, inserts as the following procedures.

1. Displays the "Templates" view.
2. Opens the source file in COBOL editor.
   - The content of displayed template in "Templates" view is different according to the extension of opening file in active editor.
   - Displays the root category used for COBOL when opening the COBOL source file (the file whose extension is .cob, .cobol or .cbl).
3. In COBOL editor, puts the cursor into the position at which template pattern intends to insert.
4. From "Templates" view, selects used template and then selects [insert] from context menu. Template pattern is inserted in COBOL editor.

3.9.1.2 Adding, editing, and deleting a template

The following can be executed.

- Add root category
- Add category
- Add template
- Edit root category
- Edit category
- Edit template
- Delete root category
- Delete category
- Delete template

Create root category

Use the following procedures to create a root category.

1. Select "templates.xml" in the "Templates" view, and then select "Add" > "Root Category..." from the context menu. Or, select "templates.xml" from "Categorization of the template" in the "Templates" page, and then click the "New..." button.
   - The "Add Root Category" dialog box appears.

Table 3.2 Add Root Category dialog box

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Root category name</td>
</tr>
<tr>
<td>Descriptions</td>
<td>Description of the root category.</td>
</tr>
<tr>
<td>File extensions</td>
<td>The summary of the file extent associated with the root category is displayed.</td>
</tr>
<tr>
<td>Add...</td>
<td>Click the &quot;Add...&quot; button to add the file extent into the &quot;File extensions&quot;. The &quot;Select File Extensions&quot; dialog box will display and then you can select an extent to add.</td>
</tr>
<tr>
<td>Remove</td>
<td>Click the &quot;Remove&quot; button to remove the file extent from the &quot;File extensions&quot;.</td>
</tr>
</tbody>
</table>
2. Input the above items and then click the "OK" button.

Create category

Use the following procedures to create a category.

1. Select the parental category or root category from the "Templates" view and then select "Add" > "Category" from the context menu. Or, select the parental category or root category from "Categorization of template" in the "Templates" page and then click the "New..." button.

The "Add Category" dialog box appears ("Add Category/Template" dialog box appears when creating from "Templates" page.)

Table 3.3 Add Category dialog box (Add Category/Template dialog box when creating from "Templates" page.)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent Name</td>
<td>Displays the selected category or root category as parent.</td>
</tr>
<tr>
<td>Category</td>
<td>Check the &quot;Category&quot;.</td>
</tr>
<tr>
<td>Template</td>
<td>Note:</td>
</tr>
<tr>
<td></td>
<td>When &quot;Add&quot; &gt; &quot;Category&quot; is selected from the &quot;Templates&quot; view, the &quot;Templates&quot; is unavailable.</td>
</tr>
<tr>
<td>Name</td>
<td>Category name.</td>
</tr>
<tr>
<td></td>
<td>Category name must specify the identified name in parent category.</td>
</tr>
<tr>
<td>Keyword</td>
<td>Category cannot be inputted when it is checked.</td>
</tr>
<tr>
<td>Descriptions</td>
<td>Category description.</td>
</tr>
<tr>
<td>Pattern</td>
<td>Category cannot be inputted when it is checked.</td>
</tr>
</tbody>
</table>

2. Input the above items, and then click the "OK" button.

Create template

Use the following procedures to create a template.

1. Select the parental category or root category from the "Templates" view and then select "Add" > "Category" from the context menu. Or, select the parental category or root category from "Categorization of template" in the "Templates" page and then click the "New..." button.

"Add template" dialog box appears ("Add Category/Template" dialog box appears when creating from "Templates" page.)

Table 3.4 Add template dialog box (Add Category/Template dialog box when creating from template page.)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent Name</td>
<td>Displays the selected category or root category as parent.</td>
</tr>
<tr>
<td>Category</td>
<td>Check the &quot;Category&quot;.</td>
</tr>
<tr>
<td>Template</td>
<td>Note:</td>
</tr>
<tr>
<td></td>
<td>When &quot;Add&quot; &gt; &quot;Templates&quot; is selected from the &quot;Templates&quot; view, the &quot;Category&quot; is unavailable.</td>
</tr>
<tr>
<td>Name</td>
<td>Template name.</td>
</tr>
<tr>
<td>Keyword</td>
<td>Template key word.</td>
</tr>
<tr>
<td>Descriptions</td>
<td>Template description.</td>
</tr>
<tr>
<td>Pattern</td>
<td>Template pattern.</td>
</tr>
</tbody>
</table>

2. Input the above items, and then click the "OK" button.
Note

- The Template cannot be displayed in the Content Assist list without inputting the "Keyword".
- It is necessary to encompass the variable names with "${"and"}" when the variable will be used in "Pattern".

For example:

```
COPY${[text-name]}
```

- Variable names that can be used in "Pattern" apply the rule of user-defined words used in COBOL. For user-defined words used in COBOL, refer to "COBOL Language Reference".

Edit root category

Use the following procedures to edit the name of the root category, descriptions and associated file extent. A system-defined Root category can be edited in the same way as a user-defined root category. However, a predefined root category name cannot be edited.

1. From the "Templates" view, select the root category to be edited, and then select "Edit..." from the context menu. Or, select the root category to be edited from "Categorization of template" in "Templates" page and then click the "Edit..." button.

The "Edit Root Category" dialog box appears.

Table 3.5 Edit Root Category dialog box

<table>
<thead>
<tr>
<th>Item</th>
<th>Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Root category name.</td>
</tr>
<tr>
<td>Description</td>
<td>Descriptions of root category.</td>
</tr>
<tr>
<td>File extensions</td>
<td>Displays the file extent associated with the root category.</td>
</tr>
<tr>
<td>Add...</td>
<td>Click the &quot;Add...&quot; button to add a file extent into the &quot;File extensions&quot;. The &quot;Select File Extensions&quot; dialog box will display, and then you can select extent to be added.</td>
</tr>
<tr>
<td>Remove</td>
<td>Click the &quot;Remove&quot; button to remove the file extent from the &quot;File extensions&quot;.</td>
</tr>
</tbody>
</table>

2. Make any desired changes and then click the **OK** button.

Edit category

Use the following procedures to edit the category.

1. From the "Templates" view, select the category to be edited and then select "Edit..." from the context menu. Or, select the edited category from the "Categorization of the template" in "Templates" page, and then click the "Edit..." button.

The "Edit Category" dialog box is displayed.

Table 3.6 Edit Category dialog box

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent name</td>
<td>Displays the selected category or root category as parent.</td>
</tr>
<tr>
<td>Category</td>
<td>&quot;Category&quot; is checked.</td>
</tr>
<tr>
<td>Template</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Category name.</td>
</tr>
<tr>
<td>Keyword</td>
<td>Category name must specify the identified name in parent category. Cannot be inputted when the &quot;Category&quot; is checked.</td>
</tr>
<tr>
<td>Description</td>
<td>Category descriptions.</td>
</tr>
<tr>
<td>Pattern</td>
<td>Cannot be inputted when the &quot;Category&quot; is checked.</td>
</tr>
</tbody>
</table>
2. Make any desired changes, and then click the "OK" button.

**Edit template**

Use the following procedures to edit the existing system-defined template and user-defined template.

1. From the "Templates" view, select the template to be edited and then select "Edit..." from the context menu. Or, selects the category to be edited from the "Categorization of the template" in "Templates" page, and then click the "Edit..." button.

The "Edit Template" dialog box is displayed.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent name</td>
<td>Displays the selected category or root category as parent.</td>
</tr>
<tr>
<td>Category</td>
<td>&quot;Templates&quot; is checked.</td>
</tr>
<tr>
<td>Template</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Template name.</td>
</tr>
<tr>
<td>Keyword</td>
<td>Template keyword.</td>
</tr>
<tr>
<td>Description</td>
<td>Template description.</td>
</tr>
<tr>
<td>Pattern</td>
<td>Template pattern.</td>
</tr>
</tbody>
</table>

2. Make any desired changes, and then click the "OK" button.

**Delete root category or category**

Use the following procedures to delete a category or root category (except the predefined category). Both user-defined categories and system-defined categories can be deleted.

1. Select the category or root category that you want to delete from the "Templates" view and then select "Delete" from the context menu. Alternatively, select the category or root category that you want to delete from the "Categorization of the template" in "Templates" page, and then click the "Delete" button.

The "Delete" dialog box is displayed.

2. Click the "Yes" button.

**Delete template**

Use the following procedures to delete a template. Both user-defined templates and system-defined templates can be deleted.

1. Select the template that you want to remove from the "Templates" view, and then select "Delete" from the context menu. Alternatively, select the template you want to delete from the "Categorization of the template" in "Templates" page, and then click the "Delete" button.

The "Delete" dialog box is displayed.

2. Click the "Yes" button.

**3.9.1.3 Import and export template**

**Import Template**

It is possible to import a template or category into a category or root category. When importing the file that has a category or root category with the same name as the selected category or root category, the contents of category and root category will be merged. When importing a root category and merging it into an existing root category, the file extent relationship of the existing root category will remain and not be changed.

Use the following procedures to import.

1. Display the "Templates" page.
2. Select the template or category that you want to import from the "Categorization of the template", and then click the "Import..." button. The "Importing Template" dialog box is displayed.

3. Select the path that is the import source of the template or category, and the file (XML file in valid form), and then click the "Open" button. The template or category is imported. An error message is displayed when an invalid XML file is selected.

When importing a template, the name of template can be used repeatedly.

Note

An XML file that only has a template or category (which does not have a route category) cannot be imported into the main root ("templates.xml").

Export template / category

Use the following steps to export the category or template.

1. Display the "Templates" page.
2. Select the template or category that you want to export from the "Categorization of the template", and then click the "Export..." button. The "Exporting Templates" dialog box is displayed.
3. Input the name of the XML file after selecting the path that is the export destination of the template or category, and then click the save button. The template or category is exported.

Export all

Use the following steps to export all templates, categories and root categories.

1. Display the "Templates" page.
2. Clicks the "Export All" button. The "Exporting Templates" dialog box is displayed.
3. Input the name of the XML file after selecting the path that is the export destination of the template or category, and then click the save button. The template or category is all exported.

3.9.1.4 Validation/Invalidation of template

Use the context menu for the "Templates" view to enable or disable the template.

- The validated template is displayed in the editor input support candidate list (Content Assist).
- The invalidated template cannot be displayed in the editor input support candidates list (Content Assist).

Select the template from the "Templates" view, and then select "Enable" or "Disable" from the context menu.

3.9.2 Context menu of Templates view
### 3.9.3 Templates page

Using the Template page, it is possible to create a new template or edit the configuration of an existing template.

Use the following procedures to display the "Templates" page.

1. From menu bar select "Window" > "Preferences".
   The "Preferences" dialog box is displayed.

2. From the left pane select "COBOL" > "Templates". The "Templates" page is displayed.
Table 3.8 Templates page

<table>
<thead>
<tr>
<th>Items</th>
<th>Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Categorization of template</td>
<td>Template list appears.</td>
</tr>
</tbody>
</table>
|                        | - When selecting root category  
|                        | Displays the category description in "Description", and then displays the file extent in "File extensions".  
|                        | - When selecting template  
|                        | Displays the template in "Descriptions", displays the keyword in "Keyword", and then displays the template pattern in "Pattern preview". |
| New...                 | Creates a root category, category or template.                                                                                               |
| Edit...                | Edits the selected category and template.                                                                                                   |
| Remove                 | Deletes the selected category and template.                                                                                                   |
| Import...              | Imports template.                                                                                                                            |
| Export...              | Exports template.                                                                                                                             |
| Export All...          | Exports all templates into the file system.                                                                                                  |

**Note**

When "Templates.xml" is the root node in "Categorization of template", removing and changing cannot be executed.
Chapter 4  Project

4.1  Overview

NetCOBOL Studio manages the resources and information necessary for program development in individual units called "projects".

The following projects are used for COBOL program development.
- COBOL Solution project
- COBOL project
- COBOL Resource project

4.1.1  COBOL Solution project

The COBOL solution project contains one or more projects (COBOL project, COBOL solution project).

The COBOL solution project can set the common options for the projects.

For example, when an application is created that consists of an executable file and multiple dynamic link libraries, the project that targets an executable file can be created. Also the multiple projects that target each dynamic link library can be created. The COBOL solution project can build and manage these projects.

4.1.2  COBOL project

The COBOL project is used for COBOL program development.

One COBOL project manages the resources of one target (executable program or library).

4.1.3  COBOL Resource project

COBOL resource projects can be used to effectively manage COBOL resources.

For example, a referenced Library-file from multiple COBOL projects can be registered to a COBOL resource project, and also can be referenced from multiple projects.

COBOL resource projects cannot be built.

COBOL resources that can be managed in a COBOL resource project are as follows.
4.1.4 Notes for project management

- Projects for 32-bit and 64-bit COBOL applications cannot be created in the same workspace. Separate workspace folders must be specified for 32-bit and 64-bit COBOL projects.

- The following files that are created in the project folder must not be edited:
  - .Settings/org.eclipse.core.resources.prefs
  - .CobolOptions
  - .project
  - build.xml

- When using a workspace that was used in an old version of NetCOBOL Studio, some menu items do not appear. In this case, perform the following steps.
  1. Select "Window" > "Close All Perspectives" from the menu bar.
     All open perspectives will be all closed.
  2. Select "Window" > "Open Perspectives" > "Other..." from the menu bar.
     The "Open Perspective" dialog box is displayed.
  3. Select "COBOL (default)"*, and then click the "OK" button.

4.2 Wizards

To create a COBOL resource, the following wizards are available in NetCOBOL Studio.

<table>
<thead>
<tr>
<th>Generated resource</th>
<th>Wizard</th>
</tr>
</thead>
<tbody>
<tr>
<td>COBOL Solution project</td>
<td>COBOL Solution project generation wizard</td>
</tr>
<tr>
<td>COBOL project</td>
<td>COBOL project generation wizard</td>
</tr>
<tr>
<td>COBOL Resource project</td>
<td>COBOL Resource project generation wizard</td>
</tr>
<tr>
<td>COBOL Source file</td>
<td>COBOL Source generation wizard</td>
</tr>
<tr>
<td>COBOL Source file(Object-Oriented)</td>
<td>Object-Oriented COBOL Source generation wizard</td>
</tr>
<tr>
<td>COBOL library file</td>
<td>COBOL library generation wizard</td>
</tr>
</tbody>
</table>
The encoding of the newly created COBOL source file is as follows.

- When starting the COBOL project generation wizard and creating a COBOL project, it will be the specified "Text file encoding" in the target definition page.
- When adding a new COBOL source file to an existing COBOL project, it will be the selected encode that is the "Text file encoding" in the "Resource" page of project property.

4.2.1 COBOL solution generation wizard

Use the following procedures to start the COBOL solution generation wizard.

1. Select "File" > "New" > "COBOL Solution Project" from the menu bar. The "New COBOL Solution Project" wizard is started.
2. Input the basic project information into the "COBOL Solution Project" page, and click the "Next" or "Finish" button.

Table 4.1 Project information

<table>
<thead>
<tr>
<th>Items</th>
<th>Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>Project name.</td>
</tr>
<tr>
<td>Contents</td>
<td>Specify the location where the project resource should be saved.</td>
</tr>
<tr>
<td>Create new project in workspace</td>
<td>Saves the project resource in the workspace folder.</td>
</tr>
<tr>
<td>Create new project in external location</td>
<td>Saves the project source in the external workspace. When this item is selected, the &quot;reference&quot; button is enabled, Click the &quot;reference&quot; button and select the folder of the save location.</td>
</tr>
</tbody>
</table>

3. When the "Next" button is clicked, the "Project Management" page is displayed and projects can be added into the "Solution's projects". For details about the "Project Management" page, refer to "4.3.1 Manage COBOL project".

4.2.2 COBOL Project generation Wizard

Wizards are used to create COBOL projects and COBOL source files. This section explains the COBOL project wizard used to create a COBOL project. The COBOL project generation wizard defines a target. To create a COBOL project:

1. Select "File" > "New" > "COBOL Project" from the menu bar.
2. Specify the project information, and click the "Next" button.

Table 4.2 Project information

<table>
<thead>
<tr>
<th>Items</th>
<th>Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>Specify a name for the project.</td>
</tr>
<tr>
<td>Contents</td>
<td>Specify the storage location of project resources.</td>
</tr>
<tr>
<td>Create new project in workspace</td>
<td>If this is selected, project resources are stored in the workspace folder.</td>
</tr>
<tr>
<td>Create new project in external location</td>
<td>If this is selected, project resources are stored in a folder other than the workspace folder. The storage folder can be selected by clicking the &quot;Browse&quot; button.</td>
</tr>
</tbody>
</table>

3. Define a target, and click the "Next" button.

Define the target type and target file name of the COBOL program to be created.
Table 4.3 Defining the target

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target type</td>
<td>Specify the target type of the COBOL program to be created. When creating an executable file (exe), select &quot;Executable&quot;. When creating a dynamic link library (dll), select &quot;Dynamic-link library&quot;.</td>
</tr>
<tr>
<td>Use the DLL specific runtime initialization file (COBOL85.CBR)</td>
<td>For a target type of Dynamic-link library, if this option is selected, an initialization file for DLL-specific execution is used.</td>
</tr>
<tr>
<td>Target name</td>
<td>Specify a file name for the target file (exe/dll) to be created.</td>
</tr>
<tr>
<td>Application format</td>
<td>Specifies the format of the created application.</td>
</tr>
<tr>
<td>COBOL console window</td>
<td>Specifies that a console window created by a COBOL program is the input-output destination of ACCEPT and DISPLAY statements, and that a message box is the output destination of execution-time error messages.</td>
</tr>
<tr>
<td>System console window</td>
<td>Specifies that the system console (command prompt window) is the input-output destination of ACCEPT and DISPLAY statements and execution-time error messages.</td>
</tr>
<tr>
<td>Use precompiler</td>
<td>Select this item to create a COBOL project that uses the precompiler.</td>
</tr>
<tr>
<td>Text file encoding</td>
<td>Select the text file encoding for the files to be created in the project.</td>
</tr>
</tbody>
</table>

Information

After the project is created, text file encoding can be changed as follows:

1. Select the project for which the Text file encoding is to be changed from the "Dependency" view or the "Structure" view.
2. Select "Property" from the context menu. The Properties dialog box is displayed.
3. Select Info from the left pane. The Info page is displayed.
4. Select file encoding to be changed from "Text file encoding" in the Info page. Click "OK" in the Properties dialog box.

Note

- If the Text file encoding is changed, file encoding of existing project files are not changed.
- In a remote development, when you build COBOL source file of the text file encode "UTF-8", installs NetCOBOLV10.0.0 or later in the server side.

4. If "Use precompiler" is checked in the Define the target page, then specify the precompiler link information, and click the "Next" button.

Table 4.4 Precompiler link information

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Precompiler command</td>
<td>Specifies the name of a command that starts the precompiler.</td>
</tr>
<tr>
<td>Precompiler parameters</td>
<td>Specifies the precompiler command parameters.</td>
</tr>
<tr>
<td>Precompiler source extension</td>
<td>Specifies the extension of an input source file for the precompiler. The following extensions cannot be specified:</td>
</tr>
<tr>
<td></td>
<td>- cobol</td>
</tr>
<tr>
<td></td>
<td>- cob</td>
</tr>
<tr>
<td></td>
<td>- cbl</td>
</tr>
</tbody>
</table>
Precompiler output source extension
Select the file extension for the output source file from the precompiler.

Use original source line numbers for error messages
If this item is checked, COBOL compiler error messages are displayed using the line number in the original source, rather than the line number of the preprocessed source. (The INSDBINF (*1) command is invoked.) The default setting is unchecked.

INSDBINF parameters
This item sets parameters of the INSDBINF command, which develops line information for the precompiler input source in COBOL source files generated by precompilation. Note that input and output source file names cannot be specified because they are determined from precompiler input source file names.

*1: For the INSDBINF command, refer to "6.2.2 INSDBINF command".

Specify precompiler link information for the COBOL project to be created.

For more precompiler link information, see "6.2.1 Setting and changing initial values of precompiler link information".

5. Select "Generate code". Select either "COBOL Source" or "Object-Oriented COBOL Source" and click the "Finish" button. A COBOL project is generated, and the source generation wizard is displayed.

Table 4.5 Making selections

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Do not generate code</td>
<td>A project is created, and no source code is generated with the project.</td>
</tr>
<tr>
<td>Generate code</td>
<td>A project is created using a wizard that generates a template of source code. Select a wizard from &quot;Available skeleton codes&quot;.</td>
</tr>
<tr>
<td>Available skeleton codes</td>
<td>If &quot;Generate code&quot; is specified, select a source code generation wizard.</td>
</tr>
<tr>
<td>COBOL Source</td>
<td>Select either &quot;COBOL Source&quot; or &quot;Object-Oriented COBOL Source&quot;</td>
</tr>
<tr>
<td>Object-Oriented COBOL Source</td>
<td></td>
</tr>
</tbody>
</table>

Specify whether to generate source code. To generate source code before creating the project, select the appropriate source code generation wizard from Available skeleton codes.

For details on the source generation wizard, see "4.2.4 COBOL source generation wizard."

### 4.2.3 COBOL resource generation wizard

Use the following procedures to start the COBOL resource generation wizard.

1. Select "File" > "New" > "COBOL Resource Project" from the menu bar. The "New COBOL Resource project" wizard is started.

2. Input the project information into the "COBOL Resource Project" page, and click the "Finish" button.

Table 4.6 Project information

<table>
<thead>
<tr>
<th>Items</th>
<th>Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>Project name.</td>
</tr>
<tr>
<td>Contents</td>
<td>The location where the project resource should be saved.</td>
</tr>
<tr>
<td>Create new project in workspace</td>
<td>Saves the project resource in the workspace folder.</td>
</tr>
<tr>
<td>Create new project in external location</td>
<td>Saves the project source in the external workspace. When this item is selected, the &quot;Browse...&quot; button is enabled. Click the &quot;Browse...&quot; button and selects the folder of the save location.</td>
</tr>
</tbody>
</table>
4.2.4 COBOL source generation wizard

To use the COBOL source generation wizard to create a COBOL source file:

1. Select "File" > "New" > "COBOL Source" from the menu bar.
2. Specify basic information for the COBOL source on the COBOL Source Information page, and click the "Finish" button.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>Enter a name for the project in which the source file is created.</td>
</tr>
<tr>
<td>File name</td>
<td>Specify a name for the COBOL source file to be created.</td>
</tr>
<tr>
<td>PROGRAM-ID</td>
<td>Enter a PROGRAM-ID. The PROGRAM-ID is the same as the File name by default.</td>
</tr>
<tr>
<td></td>
<td>To change the PROGRAM-ID, enter a new one in this field.</td>
</tr>
<tr>
<td>File comment</td>
<td>Optional: Enter a comment to be added at the beginning of the generated COBOL</td>
</tr>
<tr>
<td></td>
<td>source code.</td>
</tr>
<tr>
<td>Use precompiler</td>
<td>Select this item to generate a precompiler input source. This item is enabled only</td>
</tr>
<tr>
<td></td>
<td>if precompiler link information has been set for the workspace. For details on</td>
</tr>
<tr>
<td></td>
<td>setting precompiler link information for a workspace, see &quot;6.2.1 Setting and</td>
</tr>
<tr>
<td></td>
<td>changing initial values of precompiler link information&quot;.</td>
</tr>
</tbody>
</table>

4.2.5 Object-oriented COBOL source generation wizard

To use the object-oriented COBOL source generation wizard to create an object-oriented COBOL source file:

1. Select "File" > "New" > "Object-Oriented COBOL Source" from the menu bar.
2. Specify basic information for the object-oriented COBOL source on the Object-Oriented COBOL Source Information page, and click the "Finish" button.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>Enter a name for the project in which the source file is created.</td>
</tr>
<tr>
<td>File name</td>
<td>Specify a name for the COBOL source file to be created.</td>
</tr>
<tr>
<td>CLASS-ID</td>
<td>Enter a CLASS-ID. The CLASS-ID is the same as the File name by default.</td>
</tr>
<tr>
<td></td>
<td>To change the CLASS-ID, enter a new one in this field.</td>
</tr>
<tr>
<td>Superclass</td>
<td>Optional: Specify the parent class name of the class to be generated.</td>
</tr>
<tr>
<td></td>
<td>Specification of the parent class name can be omitted. In that case,</td>
</tr>
<tr>
<td></td>
<td>FJBASE is assumed to be the parent class.</td>
</tr>
<tr>
<td>File comment</td>
<td>Optional: Enter a comment to be added at the beginning of the generated COBOL</td>
</tr>
<tr>
<td></td>
<td>source code.</td>
</tr>
<tr>
<td>Use precompiler</td>
<td>Select this item to generate a precompiler input source. This item is accessible only if precompiler link information has been set for the workspace. For details on setting precompiler link information for a workspace, see &quot;6.2.1 Setting and changing initial values of precompiler link information&quot;.</td>
</tr>
</tbody>
</table>

4.2.6 COBOL Library generation wizard

To use the COBOL Library generation wizard to create a COBOL library file:

1. Select "File" > "New" > "COBOL Library" from the menu bar.
2. Specify basic information for the COBOL library on the New COBOL Library Generation page, and click the "Finish" button.
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>COBOL Library File Name</td>
<td>Specify a name for the COBOL Library file to be created.</td>
</tr>
<tr>
<td>Project</td>
<td>Select if the destination of the COBOL Library file is an existing project.</td>
</tr>
<tr>
<td>Project name</td>
<td>Specify a name for the project in which the COBOL Library file is to be</td>
</tr>
<tr>
<td></td>
<td>created.</td>
</tr>
<tr>
<td>External Folder</td>
<td>Select if the destination of the COBOL Library file is outside of the project.</td>
</tr>
<tr>
<td>Folder</td>
<td>Specify a name for the folder in which the COBOL Library file is to be</td>
</tr>
<tr>
<td></td>
<td>created.</td>
</tr>
</tbody>
</table>

### 4.3 COBOL Solution Project

For the summary of COBOL solution, refer to "4.1.1 COBOL Solution project".

#### 4.3.1 Manage COBOL project

#### 4.3.1.1 Adding a project

The following projects can be added to the COBOL solution project:

- COBOL project
- COBOL resource project

Use the "Project Management" dialog box to add a project.

1. Select "Project Management" from the context menu of the COBOL solution project.
   The "Project Management" dialog box is displayed.
2. Select the project to be added and select a project from "Workspace's" projects", and then click the "Add-->" button.
   A project is added in "Solution's projects".
3. Click the "Finish" button.

**Note**

- A project can only be added to one COBOL solution project. To add it in another COBOL solution project, close the COBOL solution project that already has it or remove it from the COBOL solution project. Close a project by selecting the project to be closed and then selecting "Close Project" from "Project" menu, or by selecting the project to be closed in the "Navigator" view and then selecting "Close Project" from context menu.

- When the COBOL solution project exists in workspace, if import the other COBOL solution project or update the multiple COBOL solution projects that are shared among projects, the project has been added to the multiple COBOL solutions. In this case, to make sure that the project has been added to one of the COBOL solution, close the COBOL solution project, or remove the project from the COBOL solution project.

#### 4.3.1.2 Remove Project

When Remove Project is selected the target project is removed from the COBOL solution project.

Remove a project by using the "Project Management" dialog box.

1. Select the "Project Management" from the context menu of the COBOL solution project.
   The "Project Management" dialog box is displayed.
2. Select the project that you want to remove from the "Solution's projects" and then click the "<-- Remove" button.
   The selected project is deleted from the "Solution's projects" and added into the "Workspace's projects".
3. Click the "Finish" button.
A project that is in the following state is unable to be added into a "Workspace's projects" after being removed from a COBOL solution project.

- Project does not exist in the workspace
- The COBOL solution project in operation has been added to another COBOL solution project

### 4.3.2 Operate project together

It is possible to operate the projects together in the COBOL solution project using the COBOL solution project context menu that is available from the "Dependency" view or "Structure" view. The context menu is displayed when the COBOL solution project is selected and then right-clicked.

For help on the COBOL solution project context menu, refer to "3.1.2.3 COBOL Solution Project" for the "Dependency" view, and refer to "3.2.2.3 COBOL solution project" for the "Structure" view.

### 4.3.3 Setting common options for the projects

It is possible to set the common options for the projects in the COBOL solution project by using the COBOL solution property dialog.

- Build
- Build Tool (Pre-compiler)
- Build Tool (Resource Compiler)
- Remote Development

Moreover, to enable the build options that are set in the COBOL solution project, uncheck the "Enable project specific setting" check box in the "Build" page of each constitution project property.

### Information

When the "Enable project specific setting" check box is unchecked, the options that were specified in each COBOL project are disabled.

### 4.4 COBOL Project

For the summary of COBOL solution, refer to "4.1.2 COBOL project".

### 4.4.1 Adding Existing COBOL Resources

This section explains how to add existing COBOL resources to a COBOL project.

### Note

- Text file encoding

  When existing COBOL resources are added to a COBOL project, the project's text file encoding setting is applied for the added resources. The project's text file encoding is specified in the Info page of the Properties dialog box of the project. COBOL resources which have BOM (Byte Order Mark) are treated as UTF-8.

- Code conversion

  Although the text file encoding of existing COBOL resources are changed when they are added to a COBOL project, code conversion is not invoked. File encoding of the COBOL resources remain unchanged.
4.4.1.1 Adding a COBOL source file

COBOL source files registered in the Source Files folder of a COBOL project in the Dependency or "Structure" view are compilation processing targets. To register an existing COBOL source file in the Source Files folder:

- For a COBOL source file that is in the project
  1. Select the "Source Files" folder in the "Dependency" view.
  2. Select "Add File..." from the context menu.
  3. The "Add Source Files" dialog box corresponding to the selected project appears.
  4. Select the file to be added to the Source Files folder.
  5. Click the "OK" button. The selected source file is added to the Source Files folder in the "Dependency" view. The added file is reflected in the "Structure" view.

- For a COBOL source file that is not in the project, either of the following methods can be used:
  - Using Windows Explorer, select the COBOL source file to be registered and select "Copy" from the context menu. Select the Source Files folder, and then select "Paste" from the context menu.
  - Using Windows Explorer, drag and drop the COBOL source file into the Source Files folder.

4.4.1.2 Adding a link file

To add a link file:

1. Select the "Linking Files" folder of the relevant project.
2. Select "Add File..." from the context menu. The "Open" dialog box appears.
3. Select the file to be added to the "Linking Files" folder.
4. Click the "OK" button. The selected file is added to the "Linking Files" folder in the "Dependency" view. The added file is reflected in the "Structure" view.

4.4.1.3 Adding a dependent file

To add a dependent file:

1. Select the "Dependent Files" folder to which the file is to be added.
2. Select "Add File..." from the context menu. The "Open" dialog box appears.
3. Select the file to be added to the "Dependent Files" folder.
4. Click the "OK" button. The selected file is added to the "Dependent Files" folder.

4.5 COBOL Resource Project

For the summary of COBOL resource project, refer to "4.1.3 COBOL Resource project".

4.5.1 Adding the existing COBOL resource

Adding a file in the project

Files in the project can be added as follows.

- Drag & drop files to the COBOL resource project from the registered file in the "Dependency" view.

Adding a file outside the project

Files outside the project can be added in one of the following ways.

- Add the existing COBOL resource into a COBOL resource project by using the File system option for the import function. For details, refer to the file system of the Import Wizard.
4.5.2 Take reference from other projects

A Resource that is managed by a COBOL resource project can be referenced in other projects.

The steps to reference a library-file of a COBOL resource project from a COBOL project are shown below.

It is assumed that the COBOL project and the COBOL resource project have already been registered in the workspace.

1. Display the "Compiler Options" page of the COBOL project.
   For details about the display method of the "Compiler Options" page, see "6.1.3 Setting compile options".
2. Click the "Add..." button.
   The "Add Compiler Options" dialog box is displayed.
3. Select the "LIB" from the "Compiler options" list, and then click the "Add..." button.
   The "LIB Compiler Option" dialog box is displayed.
4. Click the "Browse..." button.
   The "Folder type selection" dialog box is displayed.
5. Select "Specify from the project" from the "Folder type" list and then click the "OK" button.
   The "Selection from project" dialog box is displayed.
6. Select the COBOL resource project that contains the library-file you want to refer to on the tree, and then click the "OK" button.
   Click the "OK" button of the "LIB Compiler Option" dialog box.
   The LIB (the path of the selected COBOL resource project) is set in the "Compiler options" list.
Chapter 5 Editor

This chapter provides information regarding the COBOL editor, which is used to edit COBOL source files. To start the COBOL editor, select the file to be edited in the Dependency or Structure view, and double-click the file or select "Open" from the context menu. An editing window is displayed when the COBOL editor is started, and the name of the file is displayed on the tab of the editing window. When the file has unsaved changes, an asterisk (*) is displayed after the file name.

5.1 Highlighting Key Words

Key words can be highlighted with colored characters or with a bold font style. The following table lists the items that can be highlighted.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comment line</td>
<td>If *** or */ is in the indicator area at the beginning of a line, the entire line is commented out. If &quot;D&quot; or &quot;d&quot; is in the indicator area at the beginning of a line, the entire line is commented out, regardless of whether the line contains debugging information.</td>
</tr>
<tr>
<td>Comment in a line</td>
<td>If a line contains **&gt;, the part from that point to the end of the line is treated as a comment in the line.</td>
</tr>
<tr>
<td>Reserved word</td>
<td>A reserved word list is defined for each COBOL version. For reserved words, see the NetCOBOL Grammar. Reserved words are not case-sensitive.</td>
</tr>
<tr>
<td>Figurative constant</td>
<td>SPACE, SPACES, ZERO, ZEROS, ZEROES, HIGH-VALUE, HIGH-VALUES, LOW-VALUE, LOW-VALUES, QUOTE, QUOTES, ALL</td>
</tr>
<tr>
<td>Special register</td>
<td>LINAGE-COUNTER, PROGRAM-STATUS, RETURN-CODE, SORT-STATUS, EDIT-MODE, EDIT-OPTION, EDIT-OPTION2, EDIT-OPTION3, EDIT-COLOR, EDIT-STATUS, EDIT-CURSOR, LINE-COUNTER, PAGE-COUNTER, SORT-CORE-SIZE</td>
</tr>
<tr>
<td>Character string</td>
<td>A character string is defined with any of the following formats: &quot;&quot;, B&quot;, &quot;&quot;, X&quot;, &quot;&quot;, N&quot;, &quot;&quot;, NC&quot;, &quot;&quot;, NX&quot; &quot;</td>
</tr>
</tbody>
</table>

Character strings are not case-sensitive. Single quotation marks or double quotation marks can be used.

Displaying the highlight setting

To display the highlight setting:

1. Select "Window" > "Preferences" from the menu bar. The Preferences dialog box appears.
2. Select "COBOL" > "Editor" in the left pane. The Editor page is displayed.
3. Click on the "Colors" tab. The Foreground, Color, Bold, and Preview areas are displayed.
4. Select an item in the Foreground area. The associated style is displayed in the Color and Bold areas. The current setting is displayed in the Preview area.

Note

By default, reserved words are displayed in bold characters, and other items are displayed in the normal style.

Changing the highlight setting

To change the highlight setting:

1. In the Foreground area, select the item whose highlight setting is to be changed.
2. Select "Color". The "Color" dialog box appears.
3. Select the color to be applied from the "Basic colors" palette. A color can be created by selecting "Custom colors".
4. To apply the selected color and close the dialog box, click the "OK" button. The selected color is reflected in the displayed contents of the dialog box. To close the dialog box without applying the selected color, click the "Cancel" button.
5. To display text in bold characters, select "Bold".

5.2 Font Setting

The font used in the COBOL editor can be changed in the Preferences dialog box.

Changing the font setting

To change the font setting:
1. Select "Window" > "Preferences" from the menu bar. The "Preferences" dialog box appears.
2. Select "COBOL" > "Editor" in the left pane. The "Editor" page is displayed.
3. Click on the "General" tab.
4. Select "Change...". The "Font" dialog box appears.
5. Change the values of Font, Font style, and Size as desired.

5.3 Displaying Line-Numbers

Line numbers can be displayed alongside the vertical ruler of the COBOL editor.

Displaying line-numbers

To display line-numbers:
1. Select "Window" > "Preferences" from the menu bar. The Preferences dialog box appears.
2. Select "General" > "Editors" > "Text Editors" in the left pane. The "Text Editors" page is displayed.
3. Select "Show line numbers" to display line numbers.

Note

Setting information is shared among editors; therefore, changing the settings in the NetCOBOL Studio Editor changes those settings in the other editors also.

5.4 Sequence Numbers

The COBOL editor supports automatic numbering of sequence numbers. The COBOL editor supports the following two patterns of sequence numbers:
Pattern A
Every line in a file has a six-digit sequence number, and the lines are sorted in ascending order.

Pattern B
Patterns other than pattern A.
Sequence numbers can be edited. The following table describes the operation of the COBOL editor when lines are numbered manually.

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding a new line at the end of a file</td>
<td>In pattern A, the sequence number for a new line is the sequence number of the last line plus the increment value. If the calculated value is greater than 999999, 1 is set as the increment value. If a line is being added after the line whose sequence number is 999999, the numbering is switched to pattern B. In numbering in pattern B, a six-byte space is assigned for the sequence number area of the newly line.</td>
</tr>
<tr>
<td>Inserting a new line</td>
<td>In pattern A, the sequence number for a new line is the sequence number of the previous line plus the increment value. If the calculated value is the sequence number of the next line or greater, 1 is set as the increment value. However, if adding 1 to the sequence number of the previous line results in a value equal to or greater than the sequence number of the next line, the next and subsequent lines are renumbered. In pattern B, a six-byte space is assigned for the sequence number area of the new line.</td>
</tr>
<tr>
<td>Deleting a line</td>
<td>When a line is deleted, lines are not renumbered.</td>
</tr>
<tr>
<td>Pasting a line</td>
<td>The processing is the same as for inserting a new line.</td>
</tr>
</tbody>
</table>

Note
Sequence numbers are not targeted in revision history comparisons. Therefore, simply reassigning sequence numbers does not correct them. However, when replacing from a revision history, the sequence numbers are also replaced.

5.5 Renumbering Lines
The initial value and increment value for numbering can be changed, and lines can be renumbered. The maximum increment value is 999999.

Renumbering lines
To renumber lines:

1. Select "Edit" > "Renumber" from the menu bar, or press the "Ctrl + R" keys. The "Renumber" dialog box appears.
2. Specify values for Initial Value and Increment Value.
3. Click the "Renumber" button to renumber the lines and close the dialog box. To close the dialog box without renumbering the lines, click the "Cancel" button.

Note
By default, 10 is set for Initial Value, and 10 is set for Increment Value. If the values set for Initial Value and Increment Value would result in a line number equal to or greater than 999999 in a file, an error message is displayed in the Renumber dialog box.
5.6 Changing the Initial Value and Increment Value for Sequence Numbers

The initial value and increment value for sequence numbers can be changed.

Changing the initial value and increment value for sequence numbers

To change the initial value and increment value for sequence numbers:

1. Select "Window" > "Preferences" from the menu bar. The Preferences dialog box appears.
2. Select "COBOL" > "Editor" in the left pane. The Editor page is displayed.
3. Click on the "Reference Format" tab. The "Reference Format" page is displayed.
4. Specify values for "Initial value" and "Increment value" of "Initial and incremental values for sequence number".

Note

By default, 10 is set for the Initial value and the Increment value.

5.7 Display of the Horizontal Ruler

The horizontal ruler is displayed in the upper part of the editor window. This section describes the features of the horizontal ruler.

- Column numbers are displayed in every tenth column. On the ruler, "1" indicates column 10, "+" indicates column 15, "2" indicates column 20, and so on.
- For a fixed format file:
  - The ruler begins with "***" at column 7.
  - "A" in column 8 indicates that the A area begins from this column. The A area is from column 8 to column 11.
  - "B" in column 12 indicates that the B area begins from this column. The B area is from column 12 to column 72.
  - "I" in column 73 indicates that the program identification area begins from this column. The program identification area is column 73 and subsequent columns.
  - The ruler display ends at column 80.
- For a variable format file:
  - The ruler begins with "***" at column 7.
  - "A" in column 8 indicates that the A area begins from this column. The A area is from column 8 to column 11.
  - "B" in column 12 indicates that the B area begins from this column. The B area is from column 12 to column 251.
  - The ruler display ends at column 251.

A value can be selected for the width of the tab character, which is inserted by pressing the Tab key. Either 4 or 8 can be selected.

Changing the width of the tab character

To change the width of the tab character:

1. Select "Window" > "Preferences" from the menu bar. The Preferences dialog box appears.
2. Select "COBOL" > "Editor" in the left pane. The Editor page is displayed.
3. Click the "Reference Format" tab.
4. Specify 4 or 8 as the tab width value for "Tab width".

**Note**

By default, 4 is set for the tab width value.

### 5.8 Vertical Ruler

Icons that represent set breakpoints, errors that have occurred during build, and other items are displayed on the vertical ruler in the left part of the COBOL editor window.

The COBOL editor supports the following display items:
- Errors
- Tasks
- Bookmarks
- Breakpoints
- Warnings
- Search results
- Debugging of instruction points
- Debugging of invocation stacks

**Changing the display settings**

To change the display settings of the vertical ruler:

1. Select "Window" > "Preferences" from the menu bar. The "Preferences" dialog box appears.
2. Select "General" > "Editor" > "Text Editors" > "Annotations" in the left pane. The "Annotations" page is displayed.
3. Select a setting item from "Annotation types". The setting indicating whether to display the selected item on the vertical ruler can be changed, as well as the color used to display it.

**Note**

Setting information is shared among editors; therefore, changing the settings in the NetCOBOL Studio Editor changes those settings in the other editors also.

### 5.9 Display of the Overview Ruler

On the overview ruler in the right part of the editor window, the locations of errors such as those that have occurred during build are indicated by rectangles in different colors representing error categories. Selecting a rectangle on the ruler displays the relevant source line.
The COBOL editor supports the following display items:

- Errors
- Tasks
- Bookmarks
- Breakpoints
- Warnings
- Search results
- Debugging of instruction points
- Debugging of invocation stacks

Changing the display settings

To change the display settings of the overview ruler:

1. Select "Window" > "Preferences" from the menu bar. The Preferences dialog box appears.
2. Select "General" > "Editor" > "Text Editors" > "Annotations" in the left pane. The "Annotations" page is displayed.
3. Select a setting item from "Annotation types". The setting indicating whether to display the selected item on the overview ruler can be changed, as well as the color used to display it.

Note

Setting information is shared among editors; therefore, changing the settings in the NetCOBOL Studio Editor changes those settings in the other editors also.

5.10 Quick Diff Display

Differences between the source code currently being edited and corresponding stored source code can be indicated by different colored blocks alongside the vertical ruler of the editor window.

Displaying Quick Diff

To change the Quick Diff display settings:

1. Select "Window" > "Preferences" from the menu bar. The "Preferences" dialog box appears.
2. Select "General" > "Editor" > "Text Editors" > "Quick Diff" in the left pane. The "Quick Diff" page is displayed.
3. Change the Quick Diff settings as desired.
5.11 Reference Formats

When the COBOL editor is used to create or edit a COBOL source file, the file format conforms to the rules specified under a reference format. The COBOL editor supports the following two reference formats:

- Fixed format
- Variable format

Note

NetCOBOL Studio does not support Free format.

Specifying a reference format

To specify a reference format:

1. Select "Window" > "Preferences" from the menu bar. The "Preferences" dialog box appears.
2. Select "COBOL" > "Editor" in the left pane. The "Editor" page is displayed.
3. Click the "Reference Format" tab. The "Reference Format" page is displayed.
4. Select "Fixed format" or "Variable format" for the "Reference format".

COBOL editor operation for the fixed format

In the fixed format:

- Columns 1 to 6 in the COBOL editor are used for line numbers, which are called sequence numbers.
- Column 7 is used as the indicator column.
- ",", "D", "d", or "***" in the indicator area indicates that the line is a comment line.
- "D" or "d" in the indicator area indicates that the subsequent text is debugging information. This option is valid for builds that are executed in debug mode.
- Columns 8 to 11 are used as the A area, and columns 12 to 72 are used as the B area.
- Column 73 and subsequent columns are used as the program identification area.

COBOL editor operation for the variable format

In the variable format:

- Columns 1 to 6 in the COBOL editor are used for line numbers, which are called sequence numbers.
- Column 7 is used as the indicator column.
- ",", "D", "d", or "***" in the indicator area indicates that the line is a comment line.
- "D" or "d" in the indicator area indicates that the subsequent text is debugging information. This option is valid for builds that are executed in debug mode.
- Columns 8 to 11 are used as the A area, and columns 12 to 251 are used as the B area.
- The text in column 252 and subsequent columns is treated as a comment.

Note

A reference format can be changed. If changes have been made in a file but not yet saved, a message prompting the user to save the changes in the file before the reference format is changed.

To save the changes made in the file and then change the reference format, click the Yes button. To change the reference format without saving the changes, click the No button.
5.12 Code Formatter

The following table outlines the automatic indentation supported by the COBOL editor.

<table>
<thead>
<tr>
<th>When the ENTER key is pressed</th>
<th>All of the space and tab characters at or after the cursor position are moved to the next line together with the text, and the cursor is moved to the beginning of the line.</th>
</tr>
</thead>
<tbody>
<tr>
<td>When multiple lines of text are pasted</td>
<td>The text is pasted at the current cursor position, and then is pasted in subsequent lines without placing any extra space or tab characters at the beginning of each subsequent line.</td>
</tr>
<tr>
<td>When the text selected from the input support candidate list is inserted</td>
<td>All of the space and tab characters at the beginning of the current line are also pasted to each new line.</td>
</tr>
</tbody>
</table>

5.13 Comment Styles

The following table lists comment styles supported by the COBOL editor.

<table>
<thead>
<tr>
<th>Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Style A</td>
<td>If &quot;*&quot;, &quot;/&quot;, &quot;D&quot;, or &quot;d&quot; is in the indicator area (column 7) of a line, the entire line is treated as a comment line.</td>
</tr>
<tr>
<td>Style B</td>
<td>If a line contains &quot;*&gt;&quot;, the part from that point to the end of the line is treated as a comment.</td>
</tr>
<tr>
<td>Style C</td>
<td>Characters described in the program identification area (column 73 and subsequent columns) are also treated as a comment.</td>
</tr>
</tbody>
</table>

Note
The fixed format supports all of the above comment styles. The variable format supports style A and style B. In the variable format, column 252 and subsequent columns are treated as a comment.

5.14 Input Support Candidate List (Contents Assist)

The input support candidate list displays key words of the COBOL language syntax, class names, method names (factory method names or object method names), program names, and subprogram names.

Input support candidates are displayed according to the following conditions:
- When the Ctrl + Space keys are pressed in a file, the candidate list displays class names and template key words. Example: MOVE<Ctrl + Space>

If no space character has been entered after the last input characters when the Ctrl + Space keys are pressed, the list displays the class names and template key words that begin with the last input characters. In the following example, the list displays the class names and template key words that begin with "DA".

Example: MOVE DA<Ctrl + Space>.

- When the Ctrl + Space keys are pressed with the cursor to the right of a space character following the key word INVOKE, the candidate list displays class names, method names, and template key words. Example: INVOKE <Ctrl + Space>

If no space character has been entered after the last input characters when the Ctrl + Space keys are pressed, the list displays the class names, Method names, and template key words that begin with the last input characters. In the following example, the list displays the class names, method names, and template key words that begin with "DA".

Example: INVOKE DA<Ctrl + Space>

- When the Ctrl + Space keys are pressed with the cursor to the right of a space character that is entered two characters after the key word [CALL], the candidate list displays program names, subprogram names, and template key words.

Example: CALL <Ctrl + Space>

If no space character has been entered after the last input characters when the Ctrl + Space keys are pressed, the list displays the program names and template key words that begin with the last input characters. In the following example, the list displays the program names and template key words that begin with "DA".

Example: CALL DA<Ctrl + Space>

When a template key word is selected, an auxiliary window that displays template patterns is displayed.

### 5.15 Insert and Overwrite Modes

Text can be inserted and overwritten in the COBOL editor. The insert/overwrite mode can be toggled by pressing the "Insert" key. The current mode is indicated in the status bar.

For example, if "1234567890" is displayed in the text editor with the cursor to the left of the "1" and you type "abcde":

In Insert mode, the result will be: abcde1234567890

In Overwrite mode, the result will be: abcde67890

### 5.16 Select All

All of the text in the active file of the editor can be selected by choosing **Select All** from the Edit menu or by pressing the Ctrl + A keys.

**Note:** Sequence numbers in the sequence number area of fixed and variable format files cannot be selected.

### 5.17 Undo and Redo

Editing operations can be undone and redone.

**Undo**

Up to 25 previous editing operations can be undone by selecting **Undo** from the Edit menu, or by pressing the Ctrl + Z keys, or by clicking ⌡ in the toolbar.

**Redo**

Editing operations that have been undone can be redone by selecting **Redo** from the Edit menu, or by pressing the Ctrl + Y keys, or by clicking ⌢ in the toolbar.
5.18 Shift Left/Right

The selected text in the COBOL editor window can be shifted left and shifted right.

Shift left

The selected text can be shifted left in the COBOL editor window by selecting *Shift Left* from the Edit menu, or by pressing the Shift + Tab keys. The length of the text shift in units of columns is determined by the value set for *Tab width* on the COBOL > Editor page of the Preferences dialog box.

Shift right

The selected text can be shifted right in the COBOL editor window by selecting *Shift Right* from the Edit menu, or pressing the Tab key. The length of the text shift in units of columns is determined by the value set for *Tab width* on the COBOL > Editor page of the Preferences dialog box.

![Note]

These operations cannot be performed in the sequence number area.

5.19 Cut, Copy, and Paste

The selected text in the editor window can be cut, copied, and pasted.

Cut

The selected text can be cut by selecting *Cut* from the Edit menu or context menu, or by pressing the Ctrl + X keys, or by clicking on the toolbar.

Copy

The selected text can be copied by selecting *Copy* from the Edit menu or context menu, or by pressing the Ctrl + C keys, or by clicking on the toolbar.

Paste

The cut or copied text can be pasted by selecting *Paste* from the Edit menu or context menu, or by pressing the Ctrl + V keys, or by clicking on the toolbar.

5.20 Find and Replace

A key word can be found and/or replaced by selecting *Find / Replace* from the Edit menu, or by pressing the Ctrl + F keys, or by clicking on the toolbar.

Finding a key word

To find a key word:

1. Select *Edit* > *Find/Replace...* from the menu bar. The *Find/Replace* dialog box appears.
2. Enter the key word.
3. Click on the *Find* button. If the key word is found, it is highlighted in the editor window.

Replacing a character string

To replace a character string:

1. Select *Edit* > *Find/Replace* from the menu bar. The *Find/Replace* dialog box appears.
2. Enter the search target character string in the "Find" field, and the replacement character string in the "Replace with" field.

3. Click the "Replace" button to replace text that has been found.

The items in the "Find/Replace" dialog box are as follows:

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Forward</td>
<td>A downward (forward) search is performed starting from the current cursor position.</td>
</tr>
<tr>
<td>Backward</td>
<td>An upward (backward) search is performed starting from the current cursor position.</td>
</tr>
<tr>
<td>All</td>
<td>The entire file is searched.</td>
</tr>
<tr>
<td>Select lines</td>
<td>The selected range in the file is searched.</td>
</tr>
<tr>
<td>Case sensitive</td>
<td>Uppercase and lowercase letters are treated as different characters in a key word search.</td>
</tr>
<tr>
<td>Wrap search</td>
<td>The search operation is performed until it reaches the end of the file, and then it continues at the start of the file. The search operation is repeated cyclically until it is canceled.</td>
</tr>
<tr>
<td>Whole word</td>
<td>The search target is a word that exactly matches the key word.</td>
</tr>
<tr>
<td>Incremental</td>
<td>The cursor is positioned at a matching character string in the file as soon as each character in a character string search target is entered.</td>
</tr>
<tr>
<td>Regular expressions</td>
<td>The specified key word is assumed to be a regular expression.</td>
</tr>
</tbody>
</table>

- When the Find /Replace button is clicked, the character string that was found to match is replaced, and the cursor is moved to the next matching character string.
- When the Replace All button is clicked, all matching character strings are replaced.
- If the Incremental option is selected, the search is conducted as soon as the search string is input, without the use of the Find button.

### 5.21 Jumping to a Specified Line or Sequence Number

By selecting Go to Line from the Navigate menu or pressing the Ctrl + L keys, you can move to a specified line number or sequence number.

To jump to a specified line number or sequence number in a fixed or variable format file:

1. Select "Navigate" > "Go to Line..." from the menu bar. The "Go to Line" dialog box appears.

2. Select "Line Number" to enter a line number in the "Enter line number" field, or select "Sequence Number" to enter a sequence number in the "Enter Sequence number" field. The default selection is Sequence Number.

3. If the sequence number is represented by zeros followed by integers, you can jump to the line by entering just the integer part of the number, without the leading zeros. For example, if the sequence number is 000100, you can enter 100 instead of 000100.

4. After selecting to move to the specified line, click the "OK" button to close the dialog box. The cursor moves to the beginning of the specified line. Select the "Cancel" button to close the dialog box without moving to the specified line.

Note

The range of sequence numbers that can be specified for a fixed or variable format file is displayed in the header of the "Enter Sequence number" field.
5.22 Bookmarks

A bookmark can be added to a source code line by selecting "Add Bookmark" from the "Edit" menu, or by using the context menu of the vertical ruler of the editor.

Note

To display your bookmark list, select "Window" > "Show View" > "Other..." from the menu bar. Select "General" > "Bookmarks" in the "Show View" dialog box.

5.23 Tasks

Task settings can be made by selecting "Add Task..." from the "Edit" menu or context menu of the editor. A task can be used, for example, as a memorandum for a file. The tasks that have been set are displayed in the Task view, which is used to manage task completion. For details on tasks, see the "Workbench User's Guide" in the Help information.

To insert a task in source code:

1. Select "Add Task..." from the context menu of the vertical ruler.
2. Enter an explanation of the task in the "Description" field of the "Properties" dialog box.
3. Select a priority and click the "Completed" check box when the task has been completed.
4. Default values are displayed for "On element", "In folder", and "Location".
Chapter 6  Build Function

Build is a process that uses a set of build tools according to definitions in a project. COBOL program build tool settings are made when a project is created. During a project build, build tools are used in the order specified. Build tool settings and options can be made by project. If a build contains errors, they are displayed in the "Problems" view. A detailed build log can be checked in the Console view. To display the build log, select "Build Console" from the "Open Console" icon in the toolbar of the Console view.

Point

Error information detected by the precompiler is not displayed in the "Problems" view. The error information is displayed in the Console view under Build Console.

Note

The build.xml file that is created in each project folder is used for build. This file must not be edited, and an Ant build (execution of an Ant script) must not be executed for the file.

Build Tools

NetCOBOL Studio combines build tools to execute build processing. When creating a new COBOL project, the COBOL compiler and linker are set as build tools. If you specify to use the precompiler in creating the project, the Precompiler build tool is also set. The resource compiler can be added to existing COBOL projects as a build tool.

6.1  COBOL compiler

A project can be compiled using the COBOL compiler.

6.1.1  Files associated with compilation

The following table lists the files associated with the COBOL compiler.

<table>
<thead>
<tr>
<th>Files used by the COBOL compiler</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source files (*.cob, *.cobol, *.cbl)</td>
</tr>
<tr>
<td>Library files (*.cbl)</td>
</tr>
<tr>
<td>Screen form descriptor file (*.smd, *.pmd, *.smu, *.pmu)</td>
</tr>
<tr>
<td>Repository files (*.rep)</td>
</tr>
</tbody>
</table>

Source files displayed in the Source Files folder of the "Dependency" view are the objects of compilation. The following table lists the files created by the COBOL compiler.

<table>
<thead>
<tr>
<th>Files created by the COBOL compiler</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object files (*.obj)</td>
</tr>
<tr>
<td>Repository files (*.rep)</td>
</tr>
<tr>
<td>Debugging information files (<em>.svd), Program Debug database file (</em>.pdb)</td>
</tr>
<tr>
<td>Compilation list files (*.lst)</td>
</tr>
<tr>
<td>Source Analysis Information (*.sai)</td>
</tr>
<tr>
<td>Executable files (*.exe)</td>
</tr>
<tr>
<td>Dynamic link libraries (*.dll)</td>
</tr>
</tbody>
</table>
The following table lists details of the files used for compilation.

<table>
<thead>
<tr>
<th>File contents</th>
<th>File name format</th>
<th>I/O (*)</th>
<th>Use and creation conditions</th>
<th>Relevant compilation options</th>
<th>Relevant environment variables(*2)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source files</td>
<td><code>arbitrary-file-name.cob</code></td>
<td>I</td>
<td>Required</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td></td>
<td><code>arbitrary-file-name.cobol</code></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td><code>arbitrary-file-name.cbl</code></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Library files</td>
<td><code>arbitrary-file-name.cbl</code></td>
<td>I</td>
<td>For compiling a source program that uses the COPY statement</td>
<td>LIB</td>
<td>COB_COBCOPY, COB_LIBSUFFIX, COB_library-name</td>
</tr>
<tr>
<td>Screen form</td>
<td><code>screen form descriptor.smd</code></td>
<td>I</td>
<td>For compiling a source program that has the screen form</td>
<td>FORMLIB</td>
<td>SMED_SUFFIX</td>
</tr>
<tr>
<td>descriptor file</td>
<td><code>screen form descriptor.pmd</code></td>
<td></td>
<td>descriptor.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Object files</td>
<td><code>source-file-name.obj</code></td>
<td>O</td>
<td>Created when compilation is performed correctly</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Repository files</td>
<td><code>class-name.rep</code></td>
<td>I</td>
<td>For compiling a source program that has the REPOSITORY paragraph</td>
<td>REPIN</td>
<td>COB_REPIN</td>
</tr>
<tr>
<td></td>
<td></td>
<td>O</td>
<td>Created when a class definition is compiled correctly</td>
<td>REPIN</td>
<td>COB_REPIN</td>
</tr>
<tr>
<td>Debugging</td>
<td><code>source-file-name.svd</code></td>
<td>O</td>
<td>- Used when debug mode is set as the build mode</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>information files</td>
<td><code>source-file-name.pdb</code></td>
<td></td>
<td>- When the TEST compiler option is specified</td>
<td></td>
<td></td>
</tr>
<tr>
<td>(for compilation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>in debug mode)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Source analysis</td>
<td><code>source-file-name.sai</code></td>
<td>O</td>
<td>When the SAI compiler option is specified</td>
<td>SAI</td>
<td>-</td>
</tr>
<tr>
<td>information file</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Compilation list</td>
<td><code>*.lst</code></td>
<td>O</td>
<td>For output of a compilation list</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>files</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*1: I and O are as follows:
- I: source file for compilation
- O: output file as a result of compilation

*2: For detail, refer to the "NetCOBOL User's Guide".

*3: When the encoding of the form data is UTF-32, the UTF-32 form descriptor is created using "Form descriptor conversion command for UTF-32 (CNVMED2UTF32)". The extension of the created descriptor is .smu or .pmu.

For details of CNVMED2UTF32, refer to the "NetCOBOL User's Guide".

The UTF-32 form descriptor is used when the encoding of the national item is UTF-32. In this case, the search order of the files is .pmu and .smu.

Note

The form descriptor for UTF-32 (*.pmu, *.smu) cannot be updated by using FORM and PowerFORM. In this case, you update the original form descriptor (*.pmd/*.smd), and convert it by using CNVMED2UTF32.

In the resource management of NetCOBOL Studio, an original descriptor (*.smd/*.pmd) is registered.
6.1.2 Setting the main program

Before performing a build of a COBOL project with an executable file as the target type, specify one of the source files of the project as the main program. If the main program is not specified, a link error will occur. The two types of main programs, determined according to types of programs created, are described below. The main program type is specified with a wizard when a COBOL project is created.

- Application that uses the COBOL console
  Specifies that a console window created by a COBOL program is the input-output destination of ACCEPT and DISPLAY statements, and that a message box is the output destination of execution-time error messages.

- Application that uses the system console
  Specifies that the system console (command prompt window) is the input-output destination of ACCEPT and DISPLAY statements and execution-time error messages.

Point

If the COBOL console window is specified as the main program, and the application is executed from NetCOBOL Studio, the Console view is used instead of the system console.

Specifying the main program

To specify the main program:

1. Select a source file in the "Dependency" or "Structure" view.
2. Select "Main Program" from the context menu.
3. The selected COBOL source file is set as the main program, and the icon of the file is changed.

Changing the main program type

To change the main program type:

1. Select the appropriate project from the "Dependency" or "Structure" view.
2. Select "File" > "Properties" from the menu bar, or select "Property" from the context menu. The Properties dialog box appears.
3. Select "Target" in the left pane. The "Target" page is displayed.
4. Select "COBOL console window" or "System console window" from "Application format", and click "OK" button.

6.1.3 Setting compile options

This section explains how to set the compile options that are required for building a project.

See

For details of the compile options, refer to the "Appendix A Compile Options".

Compile options are set for each project. The set options are sent to the COBOL compiler as parameters.

To display the Compiler Options page and set compile options:

1. Select a COBOL project in the "Dependency" or "Structure" view.
2. Select "File" > "Property..." from the menu bar or "Property..." from the context menu. The Property dialog box appears.
3. Select "Build" in the left pane. The "Build" page is displayed.
4. Select the "Compiler Options" tab. The "Compiler Options" page is displayed.
Table 6.1 Compiler Options page

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compiler options</td>
<td>Displays the compile options to be sent to the COBOL compiler.</td>
</tr>
<tr>
<td>Add</td>
<td>Adds the compile options. To add compile options, select the compile options in &quot;Compiler options&quot; in the Add Compiler Options dialog box, and then click the &quot;Add&quot; button. For details on compile options, see &quot;A.1 Compile option details.&quot;</td>
</tr>
<tr>
<td>Change</td>
<td>Changes the compile options selected in Compiler options.</td>
</tr>
<tr>
<td>Remove</td>
<td>Deletes the compile options selected in Compiler options.</td>
</tr>
<tr>
<td>The CHECK(ALL) compile option is automatically added when the build mode is Debug.</td>
<td>Specifies whether the compiler option CHECK(ALL) is added automatically or not when the build mode is debug. If checked, compiler option CHECK(ALL) is added. To specify CHECK option except for ALL, deselect the CHECK option and then select the CHECK option again, and select the other Check items in the CHECK Compiler Option dialog.</td>
</tr>
<tr>
<td>Other compiler options</td>
<td>Specifies the compile options that cannot be added from the Add Compiler options dialog box.</td>
</tr>
</tbody>
</table>

Note

- Compiler option specifies file extension
  The following compile options are not displayed in the Add Compiler Options dialog box:
  - FORMEXT
  - LIBEXT
  These compiler options can be specified in the environment variables. For details, see the "NetCOBOL User's Guide."

- Compiler option specifies text file encoding of COBOL source files
  The compiler option SCS that specifies the text file encoding of COBOL source files is not displayed in the Add Compiler Options dialog. The text file encoding is determined from the file property Text file encoding. When the Text file encoding of the file property is "UTF-8", SCS(UTF8) is set for compiler option SCS. If the Text file encoding is other than "UTF-8", SCS(ASCII) is set.

- The following compiler options cannot be specified for NetCOBOL for Windows(x64) edition
  - AIMLIB compiler option
  - FILELIB compiler option
  - GEN compiler option
  - CHECK(LINKAGE) compiler option

6.1.4 Use the Compiler Option File

The compiler option file has the following information on the compiler option.
- Project manager (for Windows(x86) NetCOBOL)
- WINCOB (for Windows(x86) NetCOBOL)

Windows(x64) NetCOBOL cannot use the compiler option file. Set the content of the compiler option file by the following.
- The "Compiler Options" page of the property dialog box.
- The environment variable

For details of the environment variable, refer to the "NetCOBOL User's Guide."
6.1.5 Setting Library names

To build a source COBOL program that includes the COPY statement specifying library names, use the Library Name option to specify the library names and the library file storage folder.

Adding a library name

To add a library name:

1. Select a COBOL project in the "Dependency" or "Structure" view.
2. Select "File" > "Properties" from the menu bar, or "Property..." from the context menu. The property dialog box appears.
3. Select "Build" in the left pane. The "Build" page is displayed.
4. Select the "Library Names" tab. The "Library names" page is displayed.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Adds a library option. Click the &quot;Add&quot; button. The &quot;Add Library Name&quot; dialog box appears. Specify a library name in &quot;Library name&quot;. Specify the library file storage folder in &quot;Select folder&quot;. The folder can also be selected by clicking the &quot;Browse&quot; button.</td>
</tr>
<tr>
<td>Change</td>
<td>Changes the selected library folder. Click the &quot;Change&quot; button. The &quot;Modify Library Name&quot; dialog box appears. Change the folder. (Library names cannot be changed in the &quot;Modify Library Name&quot; dialog box.)</td>
</tr>
<tr>
<td>Remove</td>
<td>Deletes the selected library option.</td>
</tr>
</tbody>
</table>

Note

- In compilation with the ALPHAL(ALL) or ALPHAL(WORD) option, and a library name described in lowercase letters in the source program, the library name is treated as being coded in uppercase letters. If the library name specified in the source program is coded in lowercase letters, the intended library file cannot be read. To perform compilation with the ALPHAL(ALL) or ALPHAL(WORD) option, specify the library name in uppercase letters as described above.
- When compiling the source program including the COPY statement without specifying the COBOL library name, specify the COBOL library folder using the compiler option LIB.

6.1.6 Setting the file folder option

When you set the file folder option (LIB, FORMLIB, REPIN, REP, etc.), specify the folder using the "Select" dialog box.

In this example, another project folder is specified for the LIB compiler option.

1. Select a COBOL project in the "Dependency" or "Structure" view.
2. Select "File" > "Property" from the menu bar, or "Property" from the context menu. The Property dialog box appears.
3. Select "Build" in the left pane. The "Build" page is displayed.
4. Select the "Compiler Options" tab, and click the "Add..." button. The "Add Compiler Options" dialog box appears.
5. Select the "LIB" option, and click the "Add..." button. The "LIB Compiler Option" dialog box appears.
6. Click the "Browse..." button to specify the library File folder. The "Folder type selection" dialog box appears.
7. In this example, you specify another project folder in the same workspace. Select "Specify from project", and click the "OK" button. The "Selection from project" dialog box appears.

Table 6.2 Folder type selection dialog box

<table>
<thead>
<tr>
<th>select item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>${NETCOBOL}</td>
<td>Refer to the folder based on the NetCOBOL installation folder.</td>
</tr>
</tbody>
</table>
8. Select the project to which the library file is saved, and click the "OK" button. The path of the library file is displayed in the "LIB Compiler Option" dialog box.

9. Click the "OK" button in the "LIB Compiler Option" dialog box.

10. Click the "Done" button in the "Add Compiler Options" dialog box.

11. Select the "Compiler Options" tab, and click the "OK" button in the "Build" page of Property dialog box. The following message boxes appear.

   Build options has been changed. To enable the changes, it is necessary to clean the project. Do you want to clean the project now? [Yes] [No] [Cancel]

12. Click the "Yes" button.

6.2 Precompiler

COBOL programs, including input sources for the precompiler, can be developed with the precompiler link function.

6.2.1 Setting and changing initial values of precompiler link information

The initial values used when a precompiler command is invoked can be set and changed. The initial values for setting the precompiler link information are shared by the COBOL projects in a workspace.

To set or change the initial values of the precompiler link information.

1. Select "Window" > "Preferences" from the menu bar. The "Preferences" dialog box appears.

2. Select "COBOL" > "Precompiler" in the left pane of the "Preferences" dialog box, and set or change initial values on the displayed "Precompiler" page.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Precompiler</td>
<td>Select this item to use a precompiler for a COBOL project in the current workspace.</td>
</tr>
<tr>
<td>Precompiler command</td>
<td>Specifies the name of a command that starts the precompiler.</td>
</tr>
<tr>
<td>Precompiler parameters</td>
<td>Specifies precompiler command parameters.</td>
</tr>
<tr>
<td>Precompiler source extension</td>
<td>Specifies the extension of an input source file for the precompiler. The following extensions cannot be specified:</td>
</tr>
<tr>
<td></td>
<td>- cobol</td>
</tr>
<tr>
<td></td>
<td>- cob</td>
</tr>
<tr>
<td></td>
<td>- cbl</td>
</tr>
<tr>
<td></td>
<td>- lcai</td>
</tr>
<tr>
<td>Precompiler output source extension</td>
<td>Selects the file extension for the output source file from the precompiler.</td>
</tr>
<tr>
<td>Use original source line numbers for error messages.</td>
<td>If this item is checked, COBOL compiler error messages are displayed using the line number in the original source, rather than the line number of the preprocessed source. (The INSDBINF command is invoked.) The default setting is unchecked.</td>
</tr>
<tr>
<td>INSDBINF parameters</td>
<td>This item sets parameters of the INSDBINF command, which develops line information for the precompiler input source in COBOL source files</td>
</tr>
</tbody>
</table>
### Note

- When Symfoware Server is used for the pre-compiler, the sqlcob command must be specified for the pre-compiler command. If the sqlcobol command is specified, a compilation error may be generated.
- Setting the pre-compiler is also required for remote builds. For details, see "9.4.4.2 Precompiler tab "

#### Method for specifying file names for precompiler command parameters

If file names must be specified for precompiler command parameters, use the macros listed below. File names are automatically generated when the precompiler is invoked.

<table>
<thead>
<tr>
<th>Macro name</th>
<th>Description of macro</th>
</tr>
</thead>
<tbody>
<tr>
<td>%INFILE%</td>
<td>Name of the source file that is input to the precompiler</td>
</tr>
<tr>
<td>%INFILE_BASE%</td>
<td>Name of the source file that is input to the precompiler without an extension.</td>
</tr>
<tr>
<td>%OUTFILE%</td>
<td>Name of the source file that is output from the precompiler.</td>
</tr>
</tbody>
</table>

**Note**

Use the following macro for the file specified for the command parameter in the precompiler.

- Input file of the precompiler: %INFILE%
- Output file of the precompiler: %OUTFILE%

#### 6.2.2 INSDBINF command

If an Oracle link is used, the INSDBINF command solves the following problems in linking between the COBOL compiler and the precompiler:

- The compiler outputs line numbers where compilation errors have been detected, but these line numbers belong to lines in an intermediate file (source file after precompilation). To modify the original source program (COBOL source program with embedded SQL statements before precompilation), the user must reference the intermediate file.
- A line with an error in the original source program cannot be correctly located using "Go To" in the "Problems" view.
- The original source program cannot be debugged.

The INSDBINF command generates an intermediate file that contains embedded line number control information and file name control information. Line number control information (#LINE information) is used to report the line numbers of lines in the original source program, before it is precompiled, to the compiler or precompiler. File name control information (# FILE information) is used to report original source program file names or the names of files included by the precompiler.

An intermediate file generated by the INSDBINF command can be input to the COBOL compiler. This allows referencing the line number control information and file name control information. From that information, a modified original source program, in which line numbers in the original source files correspond to line numbers in precompiled source files, and file names of include files, can be obtained. Thus, problems that occur in linking between the COBOL compiler and precompiler can be resolved.
INSDBINF command parameters

Different INSDBINF command parameters are used for the different operating systems of the servers that perform remote development. For details, see the “NetCOBOL User’s Guide”.

6.2.3 Creating a COBOL program by using the precompiler

To develop COBOL programs including input sources for the precompiler from creating new project, the “Build Tools” settings can be set automatically if Use precompiler is checked in the New COBOL Project wizard.

To specify the Build Tools for the precompiler to the existing COBOL project:

1. Adding the precompiler to "Build Tools".
2. Setting precompiler link information.
3. Creating and adding precompiler input sources.

6.2.3.1 Build tool settings

To invoke the precompiler during build for a COBOL project, Precompiler must be set for Build Tools.

Adding Precompiler to build tools

If Precompiler is not specified for the Build Tools, follow the procedure below, and select Precompiler.

   1. Select the project in the "Dependency" or "Structure" view.
   2. Select "Property..." from the context menu. The property dialog box appears.
   3. Select "Build Tools" in the left pane. The "Build Tools" page is displayed.
   4. Click the "Add Build Tool..." button. The "Add Build Tool" dialog box appears.
   5. Select "Precompiler", and then click the "OK" button.

   Confirm that Precompiler has been added to the "List of build tools associated with COBOL Builder" on the "Build Tools" page, and then click the "OK" button in the property dialog box.

Deleting Precompiler from build tools

To delete Precompiler from a COBOL project:

   1. Select the project from the "Dependency" or "Structure" view.
   2. Select "Property..." from the context menu. The property dialog box appears.
   3. Select "Build Tools" in the left pane. The "Build Tools" page is displayed.
   4. Select "Precompiler" from "List of build tools associated with COBOL builder" on the "Build Tools" page, and click the "Remove" button.
   5. Confirm that Precompiler has been deleted from "List of build tools associated with COBOL builder", and click the "OK" button in the property dialog box.

Note

If a precompiler input source is registered in the "Source Files" folder, Precompiler cannot be deleted from "Build Tools". Delete the precompiler input source from the "Source Files" folder before deleting Precompiler from "Build Tools".

6.2.3.2 Setting and changing precompiler link information

Information can be set and changed for the precompiler command used to build COBOL projects. Existing precompiler link settings are used as the defaults.
Setting and changing precompiler link information

Follow the procedure below to set or change precompiler information for a COBOL project.

1. Select the project in the "Dependency" or "Structure" view.
2. Select "Property..." from the context menu. The property dialog box appears.
3. Select "Build Tools" > "Precompiler" in the left pane. The "Precompiler" page is displayed.

For details on the "Precompiler" page, see 6.2.1 Setting and changing initial values of precompiler link information.

Note

If a precompiler input source is registered in the "Source Files" folder, no change can be made in "Precompiler source extension" on the "Precompiler" page. Delete the precompiler input source from the "Source Files" folder before making a change in "Precompiler source extension".

6.2.3.3 Creating and adding a precompiler input source

To add a precompiler input source to a project, precompiler link information must be set in the project in advance. The precompiler input source must be registered in the Source Files folder of the COBOL project. The following two methods can be used to register a precompiler input source in the Source Files folder:

- Create a precompiler input source and registering the new source
- Register an existing precompiler input source

Creating a precompiler input source and registering the new source in the Source Files folder

To create a precompiler input source and register the new source in the "Source Files" folder, use the COBOL Source generation wizard or the Object-Oriented COBOL Source generation wizard. Check the "Use precompiler" check box on the first page of the wizard. Then, the created COBOL source or object-oriented COBOL source is registered as a precompiler input source in the "Source Files" folder.

To start the wizard:

1. In the "Dependency" or "Structure" view, select the Source Files folder of the COBOL project.
2. Select "File" > "New" > "COBOL Source" or "Object-Oriented COBOL Source" from the menu bar, or select "New" > "COBOL Source" or "Object-Oriented COBOL Source" from the context menu. The wizard is started.

Note

If no precompiler link information is set for the project, the check box for "Use precompiler" is disabled. Set the precompiler link information, and then restart the wizard.

Registering an existing precompiler input source in the Source Files folder

An existing precompiler input source can be registered in the "Source Files" folder of a COBOL project.

- For a precompiler input source inside a project:
   To add a precompiler input source that is inside a project:
   1. Select the "Source Files" folder in the "Dependency" or "Structure" view.
   2. Select "Add File..." from the context menu. The "Add Source Files" dialog box corresponding to the selected project appears.
   3. Select the precompiler input source to be added to the "Source Files" folder.
   4. Click the "OK" button. The selected precompiler input source is registered in the "Source Files" folder.

- For a precompiler input source outside a project:

Use either of the following methods to add a precompiler input source that is outside a project:
- Using Windows Explorer, select the precompiler input source to be registered, and then select "Copy" from the context menu. Select the "Source Files" folder, and then select "Paste" from the context menu.
- Using Windows Explorer, drag and drop the precompiler input source onto the "Source Files" folder.

**Note**

If no precompiler link information is registered for the project concerned, an error occurs. The file is registered in the Source Files folder, but it is not registered as a precompiler input source. In this state, even if precompiler link information is set for the project, the file added by the above operation is not automatically registered as a precompiler input source. Move it from the Source Files folder to the Other Files folder then register the file in the Source Files folder again.

### 6.2.3.4 Editing a precompiler input source

To edit the contents of a precompiler input source with the COBOL editor, the extension of the precompiler input source file must be associated with the Content Types and COBOL editor. The association is invoked automatically when the Precompiler setting is set. If the precompiler input file is not opened by the COBOL editor, follow the procedure below and associate the file extension with the Content Types and COBOL editor.

1. Select "Window" > "Preferences" from the menu bar. The "Preferences" dialog box appears.
2. In the left pane of the "Preferences" dialog box, select "General" > "Content Types". This displays the "Content Types" page.
3. In the "Content Types" page, select "Text" > "COBOL Source File".
4. Click the "Add" button, The "Add Content Type Association" dialog box displays.
5. In the "Add Content Type Association" dialog box, enter the extension of the precompiler input source file at "Content type" and click the "OK" button.
6. In the "Content Types" page, check that the extension of the precompiler input source file is displayed at "File associations ", and click the "OK" button.
7. Select "General" > "Editors" > "File Associations" in the left pane of the "Preferences" dialog box. The "File Associations" page is displayed.
8. Click the "Add..." button to the right of File types on the "File Associations" page. The "Add File Type" dialog box appears.
9. Enter the extension of the precompiler input source file in "File type" in the "Add File Type" dialog box, and click the "OK" button. The specified extension is added to "File types" on the "File Associations" page.
10. Select the added extension from "File types" on the "File Associations" page, and click the "Add..." button to the right of "Associated editors". The "Editor Selection" dialog box appears.
11. Confirm that Internal Editors is selected in the "Editor Selection" dialog box, and select "COBOL Editor".
12. "COBOL Editor" is added to "Associated editors" on the "File Associations" page.

### 6.3 Linker

Executable files or dynamic link libraries can be created by linking object files or libraries.

#### 6.3.1 Setting link options

To display the Linker Options page and set link options:

1. Select a COBOL project in the "Dependency" or "Structure" view.
2. Select "File" > "Properties" from the menu bar or "Property..." from the context menu. The property dialog box appears.
3. Select "Build" in the left pane. The "Build" page is displayed.
4. Select the "Linker Options" tab. The "Linker Options" page is displayed.
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linker options</td>
<td>Displays a list of the set libraries and object files.</td>
</tr>
<tr>
<td>Add</td>
<td>Adds libraries and object files to be linked. Click the &quot;Add&quot; button to display the Add Linker Option dialog box so that libraries and object files can be selected. Click the &quot;Browse&quot; button to display the Folder type selection dialog box so that files can be selected. One or more libraries and object files can be added.</td>
</tr>
<tr>
<td>Change</td>
<td>Changes the selected library or object file.</td>
</tr>
<tr>
<td>Remove</td>
<td>Deletes the selected library or object file.</td>
</tr>
<tr>
<td>Remove All</td>
<td>Deletes all the libraries and object files displayed in Linker options.</td>
</tr>
<tr>
<td>Up</td>
<td>Changes the linking order of the selected library file.</td>
</tr>
<tr>
<td>Down</td>
<td>Changes the linking order of the selected library file.</td>
</tr>
<tr>
<td>Use C function</td>
<td>Used to select whether the TARGET type is a dynamic link library and whether the TARGET uses the C functions. This item defaults to unchecked.</td>
</tr>
<tr>
<td>C Run-time Library Name</td>
<td>Specifies the filename of the C run-time library to be linked during linkage. If the C run-time library name is omitted, &quot;LIBCMT.lib&quot; is linked.</td>
</tr>
<tr>
<td>DLL Entry Object</td>
<td>Specifies whether only object files created in COBOL are used to create the dynamic link library, or whether object files created in other languages are also used.</td>
</tr>
<tr>
<td>For COBOL program only</td>
<td>Creates a dynamic link library using only object files created in COBOL.</td>
</tr>
<tr>
<td>For linking with non-COBOL Program</td>
<td>Creates a dynamic link library using object files created in other languages as well as COBOL.</td>
</tr>
<tr>
<td>Output debugging information</td>
<td>Used to select whether to output debug information to the program data base file (PDB). This item defaults to check.</td>
</tr>
<tr>
<td>Other options</td>
<td>Used to enter additional link options. To enter multiple options, insert space characters as delimiters.</td>
</tr>
</tbody>
</table>

**Note**

When specifying the project from Selection from the project dialog in selecting Link options, the path separator backslash is displayed as a forward slash. The forward slash is treated as a backslash.

The following table lists link options that can be specified for Other options. For details on the link options, see the NetCOBOL User’s Guide.

<table>
<thead>
<tr>
<th>Specification format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/OUT:filename</td>
<td>Specifies the name of the main output file.</td>
</tr>
<tr>
<td>/STACK:stack-size</td>
<td>Specifies a change in the stack size. The default is 1 MB. Specify a stack size in units of bytes.</td>
</tr>
<tr>
<td>/MAP:filename</td>
<td>Specified this when creating a map file.</td>
</tr>
</tbody>
</table>

### 6.3.2 Setting TARGET options

The following TARGET options can be set for each project:

- TARGET name
- **TARGET type**
- **Build mode**

To display the Target page and specify TARGET options:

1. Select a COBOL project in the "Dependency" or "Structure" view.
2. Select "File" > "Properties" from the menu bar, or "Property..." from the context menu. The property dialog box appears.
3. Select "Target" in the left pane. The "Target" page is displayed.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target name</td>
<td>Specifies a TARGET name. The current project name is set as the initial value.</td>
</tr>
<tr>
<td>Target type</td>
<td>Specifies the type of TARGET to be output. &quot;Executable&quot; or &quot;Dynamic-link library&quot; can be selected. The default is &quot;Executable&quot;.</td>
</tr>
<tr>
<td>Use the DLL specific runtime initialization file (COBOL85.CBR)</td>
<td>For a target type of Dynamic-link library, if this option is selected, an initialization file for DLL-specific execution is used.</td>
</tr>
<tr>
<td>Application format</td>
<td>Specifies the format of the created application.</td>
</tr>
<tr>
<td>COBOL console window</td>
<td>Specifies that a console window created by a COBOL program is the input-output destination of ACCEPT and DISPLAY statements, and that a message box is the output destination of execution-time error messages.</td>
</tr>
<tr>
<td>System console window</td>
<td>Specifies that the system console (command prompt window) is the input-output destination of ACCEPT and DISPLAY statements and execution-time error messages.</td>
</tr>
<tr>
<td>Build mode</td>
<td>Specifies &quot;Release&quot; or &quot;Debug&quot; as the build mode. The default is &quot;Debug&quot;.</td>
</tr>
</tbody>
</table>

**Note**

When you specify Debug for a build mode, the "CHECK(ALL)" compiler option is added.

### 6.4 Resource compiler

The resource compiler is a build tool used to add version information to a program or set icons for a program. This build tool is valid when resource definitions have been described to a resource definition file (.rc file) and this resource definition file has been added to the Source Files folder. For details on the specification format and description method of resource definition files, see the Microsoft(R) Resource Compiler manual.

#### 6.4.1 Build Tool Settings

To invoke the resource compiler during a build for a COBOL project, the Resource compiler must be set for Build Tools. When creating a new COBOL project, the Resource compiler is not set for Build tools.

**Adding the Resource compiler to the build tools**

To add the Resource compiler to a COBOL project:

1. Select the project in the "Dependency" or "Structure" view.
2. Select "Property..." from the context menu. The property dialog box appears.
3. Select "Build Tools" in the left pane. The "Build Tools" page is displayed.
4. Click the "Add Build Tool..." button. The "Add Build Tool" dialog box appears.
5. Select "Resource compiler", and then click the "OK" button.
6. Confirm that "Resource compiler" has been added to the "List of build tools associated with COBOL builder" on the "Build Tools" page, and click the "OK" button in the property dialog box.

Deleting the Resource compiler from the build tools

To delete the Resource compiler from a COBOL project:

1. Select the project in the "Dependency" or "Structure" view.
2. Select "Property..." from the context menu. The property dialog box appears.
3. Select "Build Tools" in the left pane. The "Build Tools" page is displayed.
4. Select "Resource compiler" from the "List of build tools associated with COBOL builder" on the "Build Tools" page, and then click the "Remove" button.
5. Confirm that the "Resource compiler" has been deleted from the "List of build tools associated with COBOL builder", and click the "OK" button in the property dialog box.

6.4.2 Setting the Resource compiler options

To display the Resource compiler page, specify the Resource compiler options as follows:

1. Select the COBOL project from "Dependency" view or "Structure" view.
2. Select "File" > "Properties" from the menu bar, or select "Property..." from the context menu. The properties dialog box appears.
3. Select "Build Tools" > "Resource compiler" in the left pane, the "Resource compiler" page is displayed.

6.5 Building a COBOL Program

Several methods can be used to build a COBOL program. The range of build targets can be one or more selected projects, or an entire workspace.

6.5.1 Manual build

If "Project" > "Build Automatically" on the menu bar is checked, build is automatically executed when a resource is saved. If the developer needs to control execution of build, the checkmark can be cleared from "Build Automatically", and build can be executed manually.

Build Project

To execute a build for one or more selected projects, select the projects in the "Dependency" or "Structure" view, and then select "Project" > "Build Project" from the menu bar or "Build Project" from the context menu.

A build is executed only for the resources that have been updated since the last build.

Build All

To build all of the projects in a workspace, select "Project" > "Build All" from the menu bar.

A Build is executed only for the resources that have been updated since the last build.

Rebuild Project

To execute a build for all project resources including those not updated since the last build, select each target project for the build in the "Dependency" or "Structure" view, and then select either "Project" > "Clean..." from the menu bar or "Rebuild Project" from the context menu.

Build Working set

The working set is a grouping of the project and the resource. Create the working set, and divide the build targets into groups. A Build is executed only for the projects that have been updated since the last build.

Creating Working set

1. Select "Project" > "Build Working Set" > "Select Working Set" from the menu bar. The "Select Working Set" dialog box appears.
2. Click the "New..." button. The "New Working Set" wizard appears.
3. Select the "Resource" in the "Working set type", and click the "Next" button.
4. Input an arbitrary name to the "Working set name", and select the project of working set target. Click the "Finish" button.

Build

1. Select "Project" > "Build Working Set" > "Select Working Set" from the menu bar. The "Select Working Set" dialog box appears.
2. Select the working set, and click the "OK" button. The build of the project selected in the working set is executed.

After the build, the selected working set name is added to the submenu of "Project" > "Build Working Set". A build of the working set can be executed by the selection of this menu.

**Note**

When the file not included in the project is referred by the compiler option, even if the reference files that are not included in the project are changed, changing the resource for the project will not be recognized. For this reason, even if "Build project" is executed or "Build Automatically" is checked, the target file is not updated.

When the files that are not included in the project are changed, execute the "Rebuild project" for the project that is using the files.

**Point**

Follow the procedure below to automatically save modified resources before manual build execution.

1. Select "Window" > "Preferences" from the menu bar. The "Preferences" dialog box appears.
2. Select "General" > "Workspace" in the left pane. The "Workspace" page is displayed.
3. Select "Save automatically before build" on the "Workspace" page.
4. Click the "OK" button to close the "Preferences" page.

### 6.5.2 Automatic build

If "Project" > "Build Automatically" on the menu bar is checked, the build is automatically executed when the following things occur.
- The project has been imported.
- The resource was saved.
- The build option was changed.

### 6.5.3 Analyzing dependency of repository file

To build a project including object-oriented COBOL source files, the dependency between the COBOL source files must be set before the build. By setting that dependency, the COBOL source files are built in the correct sequence. If the dependency is not set correctly, a compile error may occur during the build. When a project is created or COBOL source files are added to the Source Files folder, the added source files are analyzed and the dependency is set automatically. However, when the REPOSITORY paragraph of a COBOL source program has been edited, the dependency must be analyzed manually before a build is executed.

To analyze the dependency, select a project in the "Dependency" view of NetCOBOL Studio, and then select "Analyze Dependency" > "All" from the context menu.

**Note**

The message "abc.rep: does not exist" is displayed in the Console view when the dependency is analyzed. Repository files (*.rep) for the object-oriented COBOL source files in a project are created only after the source files are compiled. Therefore, if the dependency
is analyzed before the build, that message is displayed. When the dependency analysis itself has been correctly performed, the project can be built without any special measure taken.

6.6 Correcting Compilation Errors

Compilation errors during build are displayed in the "Problems" view. To edit a COBOL source file containing a compilation error, double-click the information on the compilation error in the "Problems" view, or select "Go To" from the context menu. The COBOL source file is opened with the editor, and the current line is the one that contains the compilation error. If the file is already open in the COBOL editor, the line containing the compilation error becomes the current line.
Chapter 7 Debugging Function

This chapter describes the debugger, which is used to detect logic errors in programs. The debugger can be used to set breakpoints to halt execution of a program and to verify execution of a program by confirming data item values. The debugger supports debugging of multithreaded programs; however, it does not support multiple debug sessions.

7.1 Debugging an Application

The program to be debugged is executed at the same time that the debugger is started. The startup configuration of the application is used at debugger startup.

7.1.1 Creating the debugging information file

In the debugging of the COBOL program, the debugging information file is prepared. When the build is executed by the following settings, the debugging information file is created.

1. Display the property dialog box of the COBOL project.
2. Select the "Target" in the left pane. The "Target" page is displayed.
3. Check the "Build mode" of "Target" page. When "Debug" has been selected in the "Build mode", the debugging information file is created at build.

The setting of the build mode is effective only for the specified project.

**Point**

The COBOL compiler creates the SVD File of each COBOL source file. At debugging, store the SVD file in the same folder as the executable file. In remote debugging, when a local machine is selected as a server, you copy the debugging information File with the execution file.

7.1.2 The startup configuration

The startup of the debugger uses the startup composition. NetCOBOL Studio supports the local debug and the remote debug.

- **Local debug**
  Use the COBOL application startup configuration.
  For details, refer to "7.1.3 Starting debugging",

- **Remote debug**
  Use the Remote COBOL application startup configuration.
  - Normal Debug: "9.6.1.2 Starting the remote debugger"
  - Attach Debug: "9.6.2.1 Starting the remote debugger".

**Note**

When debugging it by the same startup composition, select "Run" > "Debug History" from the menu bar. Alternatively, click on the toolbar, and select the Name. The Debugger is started.

7.1.3 Starting debugging

This section explains the procedure for debugging a program.

1. Select a COBOL project in the Dependency or Structure view.
2. Select "Run" > "Debug Configurations..." from the menu bar. Alternatively, click in the toolbar, and select "Debug Configurations...". The "Debug Configurations" dialog box appears.

3. Double-click "COBOL Application" in the left pane. The startup configuration setting page displays in the right pane.

4. The default startup configuration name is displayed in the Name field. The startup configuration name can be changed.

5. Check the contents of the "Main" tab, and add or modify the contents as necessary.
   a. "Project name" is the COBOL project name selected in step 1.
   b. "Executable File" is the program to be executed first at the start of debugging. If the specified TARGET of the project is an executable file, it cannot be changed. If the specified TARGET is a dynamic link library, specify the relevant file.
   c. Specify the current folder at execution time in the "Working folder" field. If the dynamic link libraries required for execution are stored in this folder, they can be loaded during execution, even if other settings such as path settings have not been made.
   d. For "Program arguments", enter the arguments specified for Executable File in the format used for the command line interface.

6. Select Debug to start debugging.

**Point**

Debugging can be started with the default settings by selecting a project in the Dependency or Structure view and then selecting "Run" > "Debug As" > "COBOL Application" from the menu bar.

**Note**

Other debuggers (e.g. COBOL, Java) cannot be started while debugging a COBOL program.
The same workspace folder cannot be used from more than one NetCOBOL Studio.

7.1.3.1 Setting items of the COBOL application startup configuration

This section explains setting items of the COBOL application startup configuration.

**Main tab**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>The select project name is displayed.</td>
</tr>
<tr>
<td>Executable File</td>
<td>This file is executed first at the debugging. When the target is an execution file, cannot be changed. When the target is a dynamic link library, specify an appropriate file.</td>
</tr>
<tr>
<td>Working folder</td>
<td>Specify the current folder at execution time. The dynamic library stored in this folder is loaded without other path settings.</td>
</tr>
<tr>
<td>Program arguments</td>
<td>The argument of the program is input.</td>
</tr>
</tbody>
</table>

**Source tab**

This tab specifies search paths for COBOL source files and COBOL library files. Searches for sources are performed in the order displayed in "Source lookup path". Projects and folders can be added to the search paths. The order of the added search paths can be changed using "Up" or "Down".
If an external folder is specified in a search path, the following functions do not work correctly for the COBOL source programs in the external folder:

- Breakpoint operations
- Run to Line of the context menu of the COBOL editor

To use either of the above functions, Fujitsu recommends specifying the corresponding project in the source search paths. When debugging a COBOL source file in an external folder, debug each line using "Step Into" or "Step Over".

**Environment tab**

This tab sets information used by a COBOL runtime module. Before the start of its processing, the COBOL runtime module uses this information to obtain environment-specific information.

To add the environment variable information set here to existing system environment variables or user environment variables, select "Append environment to native environment". To replace the existing environment, select "Replace native environment with specified environment".

**Note**

If the same setting in an environment variable is made both on the "Environment" tab and in the runtime initialization file, the information set in the runtime initialization file is valid. For details on runtime environment information, see the "NetCOBOL User's Guide".

**Common tab**

This tab specifies how to save the startup configuration, which perspective to open after the start of execution or debugging, and other settings. For details, see the description of the "Common" tab in "8.2 Executing a COBOL Program".

### 7.1.4 Debug perspective

A COBOL program is debugged in the Debug perspective. The Debug perspective consists of views that are suitable for debugging, and facilitate debugging operations. For details on the debug perspective, see "7.2 Debug Perspective". Debugging can also be performed in the COBOL perspective.

### 7.1.5 Outline of the debugging functions

The debugger has the following functions:

- Setting breakpoints
- Unconditional execution
- Single-step execution
- Execution to the specified line
- Referencing a data item
- Changing the value of a data item
- Monitoring data items

For details on each debugging function, see "7.3 Debugger Functions."

### 7.1.6 Exiting debugging

Use any of the following methods to exit debugging:
- Click the toolbar button in the "Debug" view.
- Select "Terminate" from the context menu of the "Debug" view.
- Select "Run" > "Terminate" from the menu bar.

### 7.1.7 Notes

To invoke a dynamic link library of another project linked through the dynamic link structure from the project to be debugged, the storage location of the dynamic link library must be set using either of the following methods:

- Specify the project of the dynamic link library for the "Source lookup path" on the "Source" tab of Debug.
- Specify the dynamic link library by adding a PATH variable to "Environment variables to set" and specify the folder containing the dynamic link library in the "Environment" tab of Debug.

### 7.2 Debug Perspective

The Debug perspective consists of the COBOL editor and the following views that facilitate debugging operations:

- Debug view
- Breakpoints view
- Watch view
- Outline view

**Note**

In NetCOBOL Studio, the "Watch" view is used to reference and set data items. The Variables view cannot be used in NetCOBOL Studio.
7.2.1 Debug view

The "Debug" view displays a project name, the name of the program being executed, and other information in a tree structure, enabling the user to check the program execution status (status of threads and stacks), calling paths, and other information. Buttons and context menus can be used to perform debugging operations such as starting, executing, or exiting a program.

7.2.1.1 Context menu of the Debug view

The following table lists the context menu items used in the "Debug" view.

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
</table>
| Step Into               | ![Step Into](image) | Executes one statement in a program. If the executed statement invokes another process such as a CALL statement, control jumps to the called process, and execution is halted.  
  When Step Into is executed just before a COPY statement, execution is halted at the first statement in the COBOL Library. |
| Step Over               | ![Step Over](image) | Executes one statement in a program. If the executed statement invokes another process such as a CALL statement, the entire called process is executed, and execution is halted at the next statement following the calling statement.  
  When Step Over is executed just before a COPY statement, execution is halted at the first statement in the COBOL Library. |
| Step Return             | ![Step Return](image) | Executes a program until control returns to the calling process.  
  When Step Return is executed in a COBOL library, the program is executed until returning to the call process of the program in which the COBOL library is specified. |
| Resume                  | ![Resume](image) | Restarts the halted execution of a program. |
| Suspend                 | ![Suspend](image) | Halts execution of a program. |
| Terminate               | ![Terminate](image) | Exits debugging. |
| Terminate and Relaunch  | ![Relaunch](image) | Exits the current debugging and starts debugging of the same target again. |

7.2.2 Breakpoints view

The "Breakpoints" view displays all of the breakpoints set for a project. When a breakpoint is double-clicked, the editor displays the breakpoint locations. Breakpoints can be enabled, disabled, and deleted in this view.

7.2.2.1 Context menu of the Breakpoints view

The following table lists the context menu items used in the "Breakpoints" view.

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Go to File</td>
<td><img src="image" alt="Go to File" /></td>
<td>Displays in the COBOL editor the location at which the selected breakpoint is set.</td>
</tr>
<tr>
<td>Hit Count...</td>
<td><img src="image" alt="Hit Count..." /></td>
<td>Displays the Set Breakpoint Hit Count dialog box.</td>
</tr>
<tr>
<td>Enable</td>
<td><img src="image" alt="Enable" /></td>
<td>Enables a disabled breakpoint.</td>
</tr>
<tr>
<td>Disable</td>
<td><img src="image" alt="Disable" /></td>
<td>Disables an enabled breakpoint.</td>
</tr>
<tr>
<td>Remove</td>
<td><img src="image" alt="Remove" /></td>
<td>Deletes the selected breakpoint.</td>
</tr>
</tbody>
</table>
7.2.2.2 Breakpoint properties

A breakpoint can be enabled or disabled by using these properties. The properties can also be used to set, enable, and disable the hit count of a breakpoint.

1. Set a breakpoint using the COBOL editor.
2. Select the breakpoint from the "Breakpoints" view, and then select "Properties..." from the context menu.
3. Enable or disable the breakpoint in the "COBOL Line Breakpoint Properties" dialog box. This dialog box is also used to set the hit count of a breakpoint, and enable or disable the hit count of the breakpoint.

7.2.3 Watch view

The "Watch" view is used to perform debugging operations for data items. This view enables the user to add and delete data items, and change their values.

7.2.3.1 Context menus of the Watch view

The following table lists the context menu items used in the "Watch" view.

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Data Item...</td>
<td><img src="image" alt="Add Item" /></td>
<td>Displays the Add Data Item dialog box used to add data items to the &quot;Watch&quot; view.</td>
</tr>
<tr>
<td>Change Value</td>
<td><img src="image" alt="Change Value" /></td>
<td>Displays the Set Value dialog box used to change the values of the selected data items.</td>
</tr>
<tr>
<td>Change Hex Value</td>
<td><img src="image" alt="Change Hex Value" /></td>
<td>Displays the Set Value dialog box used to change the values of the selected data items, where the values are specified in hexadecimal format.</td>
</tr>
<tr>
<td>Suspend by Value</td>
<td><img src="image" alt="Suspend by Value" /></td>
<td>Specifies whether to halt execution of the program when the values of the selected data items are changed.</td>
</tr>
<tr>
<td>Remove</td>
<td><img src="image" alt="Remove" /></td>
<td>Deletes the selected data item from the &quot;Watch&quot; view.</td>
</tr>
<tr>
<td>Remove All</td>
<td><img src="image" alt="Remove All" /></td>
<td>Deletes all the data items from the &quot;Watch&quot; view.</td>
</tr>
<tr>
<td>Show Data Type</td>
<td><img src="image" alt="Show Data Type" /></td>
<td>Specifies whether to display data types in the &quot;Watch&quot; view.</td>
</tr>
</tbody>
</table>

7.2.3.2 Adding data items to the Watch view

Data items can be added to the "Watch" view by selecting Add Data Item from the context menu or toolbar.

1. Select "Add Data Item" from the context menu or toolbar. The "Add Data Item" dialog box appears.
2. Specify information such as data item names, a program name, and whether to halt execution when values are changed, and add the data items to the "Watch" view.
3. To add data items defined in methods of a class, specify "class-name.method-name" as the program name. A data item can be added to the "Watch" view by double-clicking the data item in the COBOL editor and then selecting "Add to Watch View" from the context menu.
Table 7.1 Add Data Item dialog box

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data name</td>
<td>When adding data items for monitoring to the &quot;Watch&quot; view, specify identifier name as data name. One of the following is the identifier name.</td>
</tr>
<tr>
<td></td>
<td>- Identifier</td>
</tr>
<tr>
<td></td>
<td>- Condition-name</td>
</tr>
<tr>
<td></td>
<td>- Index Name</td>
</tr>
<tr>
<td></td>
<td>- Special Register</td>
</tr>
<tr>
<td></td>
<td>- Symbolic-constant</td>
</tr>
<tr>
<td></td>
<td>- Named Literal</td>
</tr>
<tr>
<td></td>
<td>- Function</td>
</tr>
<tr>
<td></td>
<td>For details, refer to &quot;D.1 Identifier Name&quot;.</td>
</tr>
<tr>
<td>Program name</td>
<td>Specify the program name. For details, &quot;D.2 Program name&quot;.</td>
</tr>
<tr>
<td>Suspend by Value Change</td>
<td>If this item is checked, when the value of the data changes, the program execution is stopped.</td>
</tr>
</tbody>
</table>

**Note**
- Data items can be added to the "Watch" view during debugging. First, start debugging of the program. Then, when execution of the program is halted, such as at a breakpoint, add data items to the "Watch" view.
- The data item cannot be added to the "Watch" view from the context menu of the COBOL editor where the COBOL library is displayed. Select Add Data Item from the context menu or the toolbar of the "Watch" view instead.

### 7.2.3.3 Display formats of the values in the Watch view

Hexadecimal format or ASCII character format can be used as the data display format of the "Watch" view, or both formats can be used for data display as an added format.

To add or change a display format:
1. Select "Window" > "Preferences" from the menu bar. The "Preferences" dialog box appears.
2. Select "COBOL" > "Debug" in the left pane.
3. Select a display format from "Watch" view display options in the right pane, and then click the "OK" or "Apply" button.

### 7.2.4 Outline view

The "Outline" view displays a structural outline of the COBOL source file that is currently the active one in the COBOL editor. For details, see "Outline View."

### 7.3 Debugger Functions

This section describes the main debugger functions.

#### 7.3.1 Breakpoints

A breakpoint is represented by a mark indicating a specified point in a program at which the debugger can be stopped. This section shows how to add and delete breakpoints, as well as how to use breakpoints.
7.3.1.1 Adding a breakpoint

To add a breakpoint:

1. Use the COBOL editor to open the file to which to add a breakpoint.
2. Immediately to the left of the line to which to add the breakpoint, select "Add Breakpoint" from the context menu of the vertical ruler.
3. The breakpoint mark is displayed on the vertical ruler. The breakpoint is displayed in the list of the "Breakpoints" view.

**Point**

A breakpoint can also be set by double-clicking on the vertical ruler.

**Note**

If a breakpoint is set in a COBOL library, and that library is used by multiple COPY statements, the breakpoint will be hit in each of those cases and the program will be interrupted.

7.3.1.2 Deleting a breakpoint

To delete a breakpoint:

1. Select the breakpoint to be deleted, from the "Breakpoints" view.
2. Select "Remove Breakpoint" from the context menu.

**Point**

A breakpoint can also be deleted by double-clicking on it in the marker bar.

7.3.1.3 Using breakpoints

When control reaches a breakpoint during execution of a program, the debugger halts execution. The program calling path and data item values can be referenced at this point in time. The breakpoint can be enabled or disabled, and its hit count can be specified using breakpoint properties. The breakpoint properties can be displayed using the context menu of the vertical ruler or the context menu of the "Breakpoints" view.

Once a breakpoint is set, it is maintained across multiple sessions until it is explicitly deleted. Breakpoints are saved even when their file, which is open in the COBOL editor, is closed. The set breakpoints are displayed the next time the file is opened.

7.3.1.4 Hit count of a breakpoint

Execution of a program can be halted by using the hit count of a breakpoint. Execution is halted when the line at which the breakpoint is set has been executed the number of times specified for the hit count.

1. Set a breakpoint using the COBOL editor.
2. Select the breakpoint from the "Breakpoints" view, and then select "Hit Count..." from the context menu.
3. Set the hit count of the breakpoint, and enable or disable the hit count of the breakpoint in the "Set Breakpoint Hit Count" dialog box.

**Note**

The hit count of the breakpoint in the COBOL library is the total execution count of the breakpoint, even though the COBOL library may be used by several COPY statements.
7.3.2 Execution

The debugger can execute a series of statements up to the next breakpoint or the specified statement all at once, or it can execute it statement by statement for checking of the behavior of each statement in the execution path. However, if a breakpoint is detected during execution of the program, execution is halted at this breakpoint even when it has not reached any specified statement.

Note

If the path of the executable program to be debugged is not displayed for the selected tree element in the "Debug" view, the execution operation of the debugger is disabled. If the correct tree element has not been selected, select a tree element for which the path of an executable program is displayed, and run the debugger.

7.3.2.1 Unconditional execution

In unconditional execution, a program is executed without any halt statement specified. The program is executed until either the next breakpoint is reached or the program exits.

Use any of the following methods to perform unconditional execution:

- Select the toolbar button of the "Debug" view.
- Select "Resume" from the context menu of the "Debug" view.
- Select "Run" > "Resume" from the menu bar.
- Press the F8 shortcut key.

7.3.2.2 Step Into

Step-into executes only one statement in a program. If the executed statement invokes another process such as a CALL statement, control jumps to the called process, and execution is halted.

Use any of the following methods to perform Step Into:

- Select the toolbar button of the "Debug" view.
- Select "Step Into" from the context menu of the "Debug" view.
- Select "Run" > "Step Into" from the menu bar.
- Press the F5 shortcut key.

Note

When Step Into is executed just before a COPY statement, execution is halted at the first statement in the COBOL Library.

7.3.2.3 Step Over

Step-over executes only one statement in a program. If the executed statement invokes another process such as a CALL statement, execution is not halted in the called process. Instead, all of the called process is executed, and execution is halted at the next statement following the calling statement.

Use any of the following methods to perform Step Over:

- Select the toolbar button of the "Debug" view.
- Select "Step Over" from the context menu of the "Debug" view.
- Select "Run" > "Step Over" from the menu bar.
- Press the F6 shortcut key.
7.3.2.4 Execution until control returns to the calling process

When execution has been halted within a subprogram or method, this function performs execution until control returns to the calling process.

Use any of the following methods to perform execution until control returns to the calling process:

- Select the toolbar button of the "Debug" view.
- Select "Step Return" from the context menu of the "Debug" view.
- Select "Run" > "Step Return" from the menu bar.
- Press the F7 shortcut key.

7.3.2.5 Execution until control reaches the specified statement

The program is executed from the current halt statement to the statement at which the cursor is positioned in the COBOL editor.

To execute the program to the specified statement:

- Select "Run to Line" from the context menu of the COBOL editor.

Run to Line cannot be executed from a COBOL library. In order to execute to the specified statement, use one of the operations below.

- Set the breakpoint to the target line and use Unconditional execution.
- Repeat Step Into or Step Over until the control reaches the target line.

7.3.3 Debugging functions for data items

Data item values can be checked and changed with the debugger. This section explains debugging functions for data items.

7.3.3.1 Referencing the value of a data item

This section explains methods that can be used to reference a data item value.

Displaying the value in a tooltip

When the mouse cursor is positioned on a data item displayed in the COBOL editor, a tooltip appears with the value of the data item.
Using the Watch view

The value of a data item and more detailed information on it can be referenced by adding the data item to the "Watch" view. For details on the "Watch" view, see "7.2.3 Watch view."

7.3.3.2 Changing the value of a data item

This section explains the methods that can be used to change the value of a data item added to the "Watch" view.

Changing a data item in automatic format

To change the value of a data item in automatic format:
1. In the "Watch" view, select the data item whose value is to be changed.
2. Select "Change Value" from the context menu.
3. Enter the replacement value for the current value in the "Set Value" dialog box, and click the "OK" button.

Changing a data item in hexadecimal format

Follow the procedure below to change the value of a data item in hexadecimal format.
1. In the "Watch" view, select the data item whose value is to be changed.
2. Select "Change Hex Value" from the context menu.
3. Enter the replacement value for the current value in the "Set Value" dialog box, and click the "OK" button.

7.3.3.3 Monitoring changes in the values of data items

Data items can be monitored so that execution of the program can be halted when the value of a data item is changed.

Use either of the following methods to specify whether to halt execution of the program when such a value is changed:
- During registration in the "Watch" view:
  Check the "Suspend by Value Change" checkbox in the "Add Data Item" dialog box.
- For a data item registered in the "Watch" view:
  Select "Suspend by Value Change" from the context menu of the "Watch" view.

7.3.3.4 Notes

- The following alphanumeric data items are considered as Int type binary integer data items.

<table>
<thead>
<tr>
<th>int type binary integer data item</th>
<th>Treatment in Debug</th>
</tr>
</thead>
<tbody>
<tr>
<td>BINARY-CHAR</td>
<td>Alphanumeric data item for 1 byte</td>
</tr>
<tr>
<td>BINARY-SHORT</td>
<td>Alphanumeric data item for 2 bytes</td>
</tr>
<tr>
<td>BINARY-LONG</td>
<td>Alphanumeric data item for 4 bytes</td>
</tr>
<tr>
<td>BINARY-DOUBLE</td>
<td>Alphanumeric data item for 8 bytes</td>
</tr>
</tbody>
</table>

In addition, set the hexadecimal format if you want to set the value in int type binary integer data item.

- When using the debug function to handle the data (value reference, value change, and interruption in changing value), if the area length is specified in an extremely large data item, the debugging operation may be very slow. Although it is not possible to say unconditionally that the limit of the data length depends on the ability and environment of the debugging machine, pay attention to the data size in the debugging operation.

When considering the slow operation during debugging due to using a large area length data item, specify the reference modification and limit the scope of the data area that is taken as the handle target.
Chapter 8  Execution Function

A new program can be executed after it has been built. This chapter describes the procedure for executing a COBOL program.

8.1 Runtime Environment Information

The information necessary for executing a COBOL program is called runtime environment information. The two types of runtime environment information are environment variable information and entry information. The COBOL runtime uses environment variable information to obtain environment-specific information at the start of processing. Entry information is used to specify information on the dynamic program structure.

In NetCOBOL Studio, the Runtime Environment Setup Tool is used to set runtime environment information. The Run-time Environment Setup Tool can be started by double-clicking the runtime initialization file (COBOL85.CBR) that is generated when a project is created in the "Dependency" or "Structure" view. Environment variable information can be specified from the "Run Configurations" dialog box.

For details on runtime environment information, see the NetCOBOL User's Guide.

Note

In NetCOBOL that operates on Windows(x64), neither the Run-time Environment Setup Tool nor the files are related by initialization file for execution (COBOL85.CBR). Please select the "Apps" > "Fujitsu NetCOBOL V11(x64)" > "Run-time Environment Setup Tool" from the start menu. The Run-time Environment Setup Tool is started. Select "File" > "Open" from the Run-time Setup Tool menu bar, and select the initialization file in the "Select Run-time Initialization file" dialog box.

8.2 Executing a COBOL Program

This section explains the procedure for executing a COBOL program.

Executing a COBOL program

To execute a COBOL program:

1. Select the COBOL project in the "Dependency" or "Structure" view.
2. Select "Run" > "Run Configurations..." from the menu bar. The "Run Configurations" dialog box appears.
3. Double-click "COBOL Application" in the left pane. The startup configuration setting page displays in the right pane.
4. The project name is the initial value displayed in the "Name" field. The startup configuration name can be changed.
5. Click the "Main" tab.
   - Enter the COBOL project name in the "Project name" field. Alternatively, click the "Browse..." button and select the COBOL project.
   - If the TARGET of the specified project is a dynamic link library, specify the "Executable File".
   - Specify the current folder at the execution time in the "Working folder" field. If the dynamic link libraries required for execution are stored in this folder, they can be loaded during execution time.
   - For "Program arguments", enter parameters in the format used for the command line interface.
6. Click the "Run" button to execute the program.

Once the COBOL program has been executed using the steps detailed above, it can also be executed using the following steps:

1. From the menu bar, select "Run" > "Run history".
2. Select the startup configuration name that was specified in "Name" field in Procedure 4 above.

If the COBOL program is executed using any method other than those described here, the values set in the Run dialog box do not take effect.
Note

For example, a user may execute a COBOL program by double-clicking an executable file from a view. In this case, the work directory settings specified in the Run dialog box are not reflected. Problems may occur, if for example, the relative path name specified in the runtime initialization file (COBOL85.CBR) is not the intended path.

Setting the COBOL application startup configuration

Setting items of the COBOL application startup configuration.

Main tab

<table>
<thead>
<tr>
<th>item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>The select project name is displayed.</td>
</tr>
<tr>
<td>Executable File</td>
<td>It is a program executed first at the debugging. When the target is an execution file, cannot be changed. When the target is a dynamic link library, specify an appropriate File.</td>
</tr>
<tr>
<td>Working folder</td>
<td>Specify the current folder at execution time. When you store the dynamic link library in this folder, the load of dynamic link library can be done at execution time even if other paths are not set.</td>
</tr>
<tr>
<td>Program arguments</td>
<td>The argument of the program is input.</td>
</tr>
</tbody>
</table>

Source tab

<table>
<thead>
<tr>
<th>item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source lookup path</td>
<td>This page contains the paths used to search source files in debugging. The information in the &quot;Source&quot; tab is not used at execution time</td>
</tr>
</tbody>
</table>

Environment tab

<table>
<thead>
<tr>
<th>item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Environment variables to set</td>
<td>This item contains information that is used by the COBOL runtime module to obtain environment-specific information at the start of processing. For details on environment-specific information, see the &quot;NetCOBOL User's Guide&quot;.</td>
</tr>
<tr>
<td>Variable</td>
<td></td>
</tr>
<tr>
<td>Value</td>
<td></td>
</tr>
<tr>
<td>Append environment to native environment</td>
<td>To add the environment variable information set here to existing system environment variables or user environment variables.</td>
</tr>
<tr>
<td>Replace native environment with specified environment</td>
<td>To replace the existing environment.</td>
</tr>
</tbody>
</table>

Note

If the same environment variable is set in both the "Environment" tab and the runtime initialization file, the information in the runtime initialization file is used.

Common tab

The "Common" tab specifies how to save startup configuration information, the perspective to open after the start of execution or debugging, and other related settings.
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save as</td>
<td>Either Local file or Shared file is selected for the startup configuration type. If &quot;Local file&quot; is selected, startup configuration information is saved locally in workspace metadata. If &quot;Shared file&quot; is selected, startup configuration information is saved at the specified location, and can be shared.</td>
</tr>
<tr>
<td>Local file</td>
<td></td>
</tr>
<tr>
<td>Shared file</td>
<td></td>
</tr>
<tr>
<td>Display in favorites menu</td>
<td>To add Run or Debug to the favorites menu, select &quot;Run&quot; or &quot;Debug&quot;. These items are not selected by default.</td>
</tr>
<tr>
<td>Debug</td>
<td></td>
</tr>
<tr>
<td>Run</td>
<td></td>
</tr>
<tr>
<td>Console Encoding</td>
<td>Default is &quot;Cp1252&quot;.</td>
</tr>
<tr>
<td>Standard Input and Output</td>
<td>In the COBOL application startup configuration, any changes made to the standard input-output settings are ignored.</td>
</tr>
<tr>
<td>Allocate Console</td>
<td></td>
</tr>
<tr>
<td>File</td>
<td></td>
</tr>
<tr>
<td>Append</td>
<td></td>
</tr>
<tr>
<td>Launch in background</td>
<td>To start COBOL applications in the background, select Launch in background. Launch in background is selected by default.</td>
</tr>
</tbody>
</table>

- 109 -
Chapter 9  Remote Development Function

This chapter explains NetCOBOL remote development.

9.1  Overview of Remote Development

9.1.1  What is Remote Development?

Using the remote development support functions of NetCOBOL Studio on the client side and NetCOBOL on the server side, you can develop COBOL applications efficiently with a variety of Windows systems.

Server Side

NetCOBOL must be installed on the server.

<table>
<thead>
<tr>
<th>Operating system</th>
<th>CPU architecture</th>
<th>NetCOBOL Product</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Server 2012 R2</td>
<td>x64</td>
<td>Windows(x64) NetCOBOL (64bit)</td>
</tr>
<tr>
<td>Windows Server 2012</td>
<td>x64</td>
<td>Windows(x64) NetCOBOL (64bit)</td>
</tr>
<tr>
<td>Windows Server 2008 R2</td>
<td>Itanium</td>
<td>Windows(Itanium) NetCOBOL (64bit)</td>
</tr>
<tr>
<td>Windows Server 2008</td>
<td>x64</td>
<td>Windows(x64) NetCOBOL (64bit)</td>
</tr>
<tr>
<td>Windows Server 2003 R2</td>
<td>Itanium</td>
<td>Windows(Itanium) NetCOBOL (64bit)</td>
</tr>
<tr>
<td>Solaris</td>
<td>SPARC</td>
<td>Solaris NetCOBOL (32bit)</td>
</tr>
<tr>
<td>Red Hat Enterprise Linux AS</td>
<td>Itanium</td>
<td>Linux(Itanium) NetCOBOL (64bit)</td>
</tr>
<tr>
<td></td>
<td>x64</td>
<td>Linux(x64) NetCOBOL (64bit)</td>
</tr>
</tbody>
</table>

Client Side

NetCOBOL and NetCOBOL Studio must be installed on the client system in order to enable NetCOBOL Studio to perform development tasks. NetCOBOL Studio can be connected to a server to perform tasks such as compilation, with the results displaying in NetCOBOL Studio.

9.1.2  Advantages of Remote Development

Many COBOL applications run on expensive server machines. Developing a COBOL application on such a machine causes the following problems:

- You must use a command line interface because many of these systems do not enable a GUI-based environment.
- The server side system must be shared among the developers.

On the other hand, a Windows system is easily available as a personal machine and the developer can occupy its GUI-based environment exclusively.

Remote development solves the above problems by performing development tasks on a Windows system as far as possible.

- You can develop a COBOL application efficiently using a GUI-based development environment.
- You can reduce the load on the server side system by performing development tasks such as source editing on the client side as far as possible.

9.1.3  Flow of Remote Development

The flow of remote development is as follows:
[1] Business Specification Design and Screen/Form Design
Design the application.

[2] Prepare the server
Set the environment for remote development on the server side. Start the remote service, and start the service for the remote development function.
[3] Create and edit the project and source program

COBOL sources and other program resources are created or updated on a local personal computer.
- COBOL source programs
- COBOL library text (COPY clause)
- Screen form descriptors
- Overlay patterns

The program resources that are created or updated at this time are registered in a COBOL project in NetCOBOL Studio.

[4] Build the project (Compilation and linkage - check Syntax)

NetCOBOL Studio is used to compile and link created or updated program resources. This work is performed for the following purposes:
- To confirm that the created program resources do not contain errors or discrepancies
- To check the dependency among the program resources registered in NetCOBOL Studio
- To create an executable program for unit testing

[5] Debug and Execute

A program that has been compiled and linked on a local personal computer is used to test functions within the closed scope in the program. Errors in the program can be detected on the local personal computer by using compile options of the debugging functions provided by NetCOBOL (CHECK, COUNT, and TRACE), and using the COBOL debugger of NetCOBOL Studio.

[6] Prepare to connect to the server

To connect to the server from NetCOBOL Studio, the operating environment of NetCOBOL Studio and the operating environment of the project are set.

[7] Create a Makefile and Send resources

Resources on the local personal computer are sent to the server, and a makefile required for a build on the server is created.

[8] Remote build

Compiling and linking are performed on the server according to the information defined in the project (e.g., compile options, link options).

[9] Remote debug

The remote debug function is used to debug the COBOL program on the server.
Note

An executable program on a server cannot be started with NetCOBOL Studio. The executable program must be started directly on the server.

9.1.4 Notes on Remote Development

Generally, COBOL programs have high portability and, in many cases, you can perform tasks from the creation of your program, to unit testing on the client side.

However, if your program contains server-specific features or platform dependent features, you must test your program on the server side.

Following items are examples of platform dependent features:

- Literals or hexadecimal literals
  If the client side and the server side use different character encoding, a value that can be compiled on one side may cause a compilation error on the other side.

- Key sequence or sort key sequence for character comparison or indexed files
  The result of descending order of characters may differ based on the difference between the runtime character encoding on the client side and the server side.

- Class conditions
  If the runtime character encoding on the client side and the server side are different, the identification results may also differ.

- Printing
  Available characters and fonts differ according to the target platform

- Database functions
  The execution results may also differ based on the differences in the database products being used.

- Web linkage function
  The available functions differ depending on the target platform. In addition, Windows and UNIX systems have different file and path name rules.

Note

This system does not support the Web linkage function.

9.1.5 Server side and Client side Combinations

Refer to the "NetCOBOL Software Relese Guide" for the supported combinations of the server side and the client side NetCOBOL products.
9.2 Work on server side

9.2.1 Start Service

To use remote development, the services required by this function must be operating at the server system side. Accordingly, these services must be installed and started.

The services that must be installed at the server side are determined by the server OS and NetCOBOL product version.

<table>
<thead>
<tr>
<th>Server OS</th>
<th>Architecture</th>
<th>NetCOBOL Product on Server</th>
<th>Service to start</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Server 2012</td>
<td>x64</td>
<td>Windows(x64) NetCOBOL (64bit)</td>
<td>NetCOBOL Remote Development Service (*1)</td>
</tr>
<tr>
<td>Windows Server 2012 R2</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows Server 2008</td>
<td>Itanium</td>
<td>Windows(Itanium) NetCOBOL (64bit)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>x64</td>
<td>Windows(x64) NetCOBOL (64bit)</td>
<td></td>
</tr>
<tr>
<td>Windows Server 2003 R2</td>
<td>Itanium</td>
<td>Windows(Itanium) NetCOBOL (64bit)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>x64</td>
<td>Windows(x64) NetCOBOL (64bit)</td>
<td></td>
</tr>
<tr>
<td>Solaris</td>
<td>SPARC</td>
<td>Solaris NetCOBOL (32bit) V10 or earlier</td>
<td>rtpd/reexec service</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>telnodel(*2)</td>
</tr>
<tr>
<td>Red Hat Enterprise Linux ES</td>
<td>Itanium</td>
<td>Linux(Itanium NetCOBOL (64bit)</td>
<td>rtpd/reexec service</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>telnodel(*2)</td>
</tr>
<tr>
<td></td>
<td>x64</td>
<td>Linux(x64) NetCOBOL (64bit)</td>
<td>NetCOBOL Remote Development Service (*1)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>telnodel(*2)</td>
</tr>
</tbody>
</table>

*1: The remote development service is a service that NetCOBOL provides. Refer to the following for the service startup procedure.
- For a Windows server
  Refer to "9.2.1.1 NetCOBOL Remote Development Service".
- For a Linux(x64) server
  Refer to "NetCOBOL User's Guide" of Linux (x64) NetCOBOL.

*2: This service is required in order to use the remote debug function.

9.2.1.1 NetCOBOL Remote Development Service

The NetCOBOL Remote Development Service (referred as "Remote Development Service" after in this chapter) must be run on the server side system to make use of the remote development functions from NetCOBOL Studio on the client side. The Remote Development Service accepts a request from NetCOBOL Studio, logs on the server side system with the specified account and performs tasks on the server side system with the account.

For security reasons, the Remote Development Service is not configured to start automatically in its installation. You must start the Remote Development Service before you use remote development functions.

Note

Security Notes

For security reasons, the Remote Development Service is not configured to start automatically in its installation.
In order to maintain security, make sure to disclose the Remote Development Service only for the limited period required. When the release of the Remote Development Service is stopped, restore the changes made in the firewall settings or Remote Development Service "Startup type".

Make sure to use remote development functions with the Remote Development Service only inside a safe network such as an intranet with security that is appropriately managed.

9.2.1.1 Starting and Stopping the Remote Development Service

This section explains how to start and stop the Remote Development Service.

Starting the Remote Development Service

To start the Remote Development Service, log on the server side system with an administrator account and take the following steps:

1. From the Windows start menu, select "Apps" > "Control Panel" > "System and Security" > "Administrative Tools" > "Services".
2. From the list of services, select "NetCOBOL Remote Development Services".
3. In the window menu, select "Action" > "Properties", and open the "NetCOBOL Remote Development Services Properties" dialog.
4. In the "NetCOBOL Remote Development Services Properties" dialog, select the "General" tab.
5. Click the "Start" button.
6. If you want the Remote Development Service to start automatically when the system is started, change the "Startup type" to "Automatic".

The Remote Development Service uses port 61999 by default, to disclose its services. If port 61999 is already being used in the system, the port number must be changed. Refer to the description of port setting in "9.2.1.1.4 Configuring the Remote Development Service" for details.

If the Windows Firewall or other firewall software is running on the server, you must configure it in a way that it does not block the port which is used by the Remote Development Service. The configuration method for the firewall differs according to the type of firewall software being used. Refer to the document on each firewall software.

Before starting the Remote Development Service, read "Security Notes "under "9.2.1.1 NetCOBOL Remote Development Service".

9.2.1.1.2 Stopping the Remote Development Service

To stop the Remote Development Service, log on the server side system with an administrator account and take the following steps:

1. From the Windows start menu, select "Apps" > "Control Panel" > "System and Security" > "Administrative Tools" > "Services".
2. From the list of services, select "NetCOBOL Remote Development Services".
3. In the window menu, select "Action" > "Properties", and open the "NetCOBOL Remote Development Services Properties" dialog.
4. In the "NetCOBOL Remote Development Services Properties" dialog, select the "General" tab.
5. Click the "Stop" button.
6. If you do not want the Remote Development Service to start automatically when the system is started, change the "Startup type" to "Manual".

When Remote Development Service no longer needs to be disclosed, restore the settings changes that were made in the firewall software or so.

9.2.1.1.3 Log files of the Remote Development Service

This section explains the log files output by the remote development service.

Contents of the Log file

The following information is recorded in the log file:

- Connection start date and time
- Client IP address
- Account name
- Whether or not log-on was successful
- Connection end date and time

The commands executed under each user account after logon are not recorded.
The time output to the log file is Universal Time and Coordinated (UTC): coordinated universal time.

**The path of the Log file**
The path of the log file is as follows:

```plaintext
%ProgramData%\Fujitsu\NetCOBOL\RDS\Log\rds.log
```

%ProgramData% is a common application data folder for Windows. The default path for this is as follows:

<table>
<thead>
<tr>
<th>Windows</th>
<th>default path</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Vista or later</td>
<td>C:\ProgramData</td>
</tr>
<tr>
<td>Windows Server 2003 or earlier</td>
<td>C:\Documents and Settings\All Users\Application Data</td>
</tr>
</tbody>
</table>

You can change the folder to output the log file by configuration of the Remote Development Service. See the explanation for the logdir setting in "9.2.1.1.4 Configuring the Remote Development Service" for details.

You must log on with an administrative account to change or delete log files.

**Generations of the Log file**
When the size of a log file reaches the maximum size, a backup is made for that log file and a new log file is created.

You can change the maximum size of log files by configuration of the Remote Development Service. Refer to the explanation for the maxlogsize setting in "9.2.1.1.4 Configuring the Remote Development Service" for details.

Backup files are located in the same folder as the log file output folder and have the below name.

```plaintext
rds.<sequence number>.log
```

Where <sequence number> is a number starting at 001 and has a maximum value of 999. When new backup file is created, a new sequence number is allocated for it. This sequence number is the next sequence number of the backup file with the most recently updated time amongst the backup files in the same folder. If there is no backup file in the same folder, the sequence number 001 is allocated. 001 is also regarded as the next number of 999.

When a new backup file with sequence number n is created, only the backup files which have sequence number between (n - the number of backup generation + 1) and n are retained. All other backup files are deleted. For example, if the new backup file is rds.007.log and the number of backup generations is 3, all backup files are Deleted except for rds.005.log, rds.006.log, and rds.007.log.

You can change the number of backup generation by configuration of the Remote Development Service. See the explanation for the maxloggen setting in "9.2.1.1.4 Configuring the Remote Development Service" for details.

**9.2.1.1.4 Configuring the Remote Development Service**
This section describes the Remote Development Service settings that can be changed and explains how to set them.

The following settings can be changed:
- Port number to be used
- The output folder, maximum size, and number of backup generations for log files

Specify the settings that you want to change as service start parameters. The Remote Development Service must then be restarted for the changes to take effect.
Changing setting of the Remote Development Service

To change setting of the Remote Development Service, log on the server side system with an administrator account and perform the following steps:

1. From the Windows start menu, select "Apps" > "Control Panel" > "System and Security" > "Administrative Tools" > "Services".
2. From the list of services, select "NetCOBOL Remote Development Services".
3. In the window menu, select "Action" > "Properties", and open the "NetCOBOL Remote Development Services Properties" dialog.
4. In the "NetCOBOL Remote Development Services Properties" dialog, select the "General" tab.
5. Enter the settings in the "Start parameters".

Note

- To enter more than one setting in the "Start parameters", separate the settings with spaces.
- To enter a setting that contains a space, enclose it in quotation marks (").


- The contents of "Start parameters" are not saved. If you configure the Remote Development Service to start automatically when the system is started, the Remote Development Service starts with default setting when the system is started next time.

Refer to the list below for the settings that can be entered in the "Start parameters".

Setting list of the Remote Development Service

The following table shows the settings that can be changed.

<table>
<thead>
<tr>
<th>Setting name</th>
<th>Form to specify in start parameters</th>
<th>Default value</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>port</td>
<td>/port:&lt;number&gt;</td>
<td>61999</td>
<td>Specify the TCP/IP port number used by the Remote Development Service. In &lt;number&gt;, specify the port number in decimal form.</td>
</tr>
<tr>
<td>logdir</td>
<td>/logdir:&lt;path&gt;</td>
<td>Windows shared application data folder (*)</td>
<td>Specify the folder to which remote development service log files are output. In &lt;path&gt;, specify the folder path. To use a path that contains spaces, enclose the start parameter in quotation marks (*).</td>
</tr>
<tr>
<td>maxlogsize</td>
<td>/maxlogsize:&lt;size&gt;</td>
<td>128</td>
<td>Specify the maximum size of the Remote Development Service log file. In &lt;size&gt;, specify the maximum size in decimal form. Its unit is kilobytes. If 0 is specified, the Remote Development Service does not output log file</td>
</tr>
<tr>
<td>maxloggen</td>
<td>/maxloggen:&lt;number of generations&gt;</td>
<td>2</td>
<td>Specify the number of generations of Remote Development Service log file backups to be retained. In &lt;number of generations&gt;, specify the number of generations in decimal form. If n is specified, n backups (rds.xxx.log) are retained. If a number greater than 999 is specified, 999 is considered to be specified. If 0 is specified, no backup is retained.</td>
</tr>
</tbody>
</table>

*: This depends on the version of Windows. Refer to "The path of the log file" under "9.2.1.1.3 Log files of the Remote Development Service".

9.2.1.2 ftpd/rexec services

This section explains how to install and start the ftpd and rexec services at the server.
9.2.1.2.1 On a Solaris server

The ftpd services are installed with their default settings when the operating system is installed on the Solaris server, and always start automatically.

Note

No start setting for the rexec service are already configured when the Solaris operating system is installed. The following operations must be performed:

- Checking the status
  
  Execute the following command to check the status:

  ```
  # svcs -a | grep rexec
  disabled 10:28:10 svc:/network/rexec:default
  ```

  If "disabled" is displayed at the beginning of the execution results, start the rexec service.

- Starting the rexec service
  
  Execute the following command to start the rexec service:

  ```
  # svcadm enable svc:/network/rexec:default
  ```

In most cases, to change the system settings of the Solaris server involves checking the contents of the setting file, and modifying them as necessary.

1. Check the service status.

   inetd (Internet daemon) invokes the ftpd and rexec services on the Solaris server. Therefore, the contents of the following files should be checked:

   - `/etc/services`
   - `/etc/inetd.conf`

   If valid descriptions of the ftpd and rexec services are found in `/etc/services` and `/etc/inetd.conf`, skip the remaining steps in this section. See the examples below. If the line in which ftpd or rexec or both are set is commented out ("#" is added at the beginning of the relevant line), then the remaining steps must be performed.

   Example for `/etc/services`

   ```
   #
   # Network services, Internet style
   #:
   ftp 21/tcp
   #
   #: UNIX specific services
   #: these are NOT officially assigned
   #
   ```

   Example for `/etc/inetd.conf`

   ```
   # FTPD - FTP server daemon
   ftp stream tcp6 nowait root /usr/sbin/in.ftpd in.ftpd -a
   :
   # REXECD - rexec daemon (BSD protocols)
   exec stream tcp nowait root /usr/sbin/in.rexecd in.rexecd
   exec stream tcp6 nowait root /usr/sbin/in.rexecd in.rexecd
   ```
2. Change the settings of the services.
   Modify /etc/services and /etc/inetd.conf.

3. Start the services.
   Restart inetd because the ftpd and rexec services are started under the control of inetd.
   Execute either the following command:

   ```bash
   # kill -HUP `cat /var/run/inetd.pid`
   ```

   Or execute the following:

   ```bash
   # ps -ea | grep inetd
   inetd process id is displayed.
   # kill -HUP inetd process id D
   ```

9.2.1.2.2 On a Linux server

The ftpd and rexec services may not be installed along with the operating system on the Linux server. Therefore, the first step is to
determine if their packages are installed. A Linux system may provide tools with a GUI that can be used to configure system settings.
Since there are considerable differences between the versions and individual system settings in differing GUI tools, a method for using
commands to perform operations is presented below.

1. Check the packages.
   Execute the rpm command in the following format to determine if the packages are installed:

   ```bash
   # rpm -query package-name
   ```

   Enter the following package names for ftpd and rexec:
   - ftpd : vsftpd
   - rexec : rsh and rsh-server

   If the following information is displayed, the packages have been installed, and you can proceed to checking the service status.

   ```bash
   # rpm -query vsftpd
   vsftpd-2.0.1-5
   # rpm -query rsh
   rsh-0.17-17
   # rpm -query rsh-server
   rsh-server0.17-17
   ```

   If the package information is not displayed, one or more packages must be installed.

   **Note**

   The type of ftpd package used for the Linux system depends on the version and distribution. The following may be used:
   - wu-ftpd
   - proftpd

2. Install packages.
   Execute the rpm command to install each package.

   ```bash
   rpm -Uvh package-name
   ```

3. Check the service status.
   Execute the /sbin/chkconfig command in the following format to determine if the services are configured to start when the
   system starts.
For example, if the following results are obtained, startup of ftpd (vsftpd) and rexec when system starts has been disabled using their respective settings.

```
# /sbin/chkconfig --list vsftpd
vsftpd 0:off 1:off 2:off 3:off 4:off 5:off 6:off
# /sbin/chkconfig --list rexec
rexec off
```

4. Change the setting for a service as necessary.

Execute the `/sbin/chkconfig` command in the following format to confirm that the service will start when the system starts:

```
/sbin/chkconfig [--level run-level] service-name on
```

In the following example, the setting is changed so that the service is started when the system starts, and the changed setting is checked:

```
# /sbin/chkconfig --level 5 vsftpd on
# /sbin/chkconfig --list vsftpd
vsftpd 0:off 1:off 2:off 3:off 4:off 5:on 6:off
# /sbin/chkconfig rexec on
# /sbin/chkconfig --list rexec
rexec on
```

5. Start the services.

Execute the `/sbin/service` command in the format shown below to start the services. Since the rexec service is started under the control of xinetd, restart xinetd.

```
# /sbin/service vsftpd start
vsftpd start: [ OK ]
# /sbin/service xinetd stop
xinetd stop: [ OK ]
# /sbin/service xinetd start
xinetd start: [ OK ]
```

### 9.2.2 Setting up the user environment on the server

#### 9.2.2.1 On a Solaris server or Linux server

**For code conversion**

When the code conversion is done with Interstage Charset Manager on the server side in the sending and receiving of the resource, the following environment variables are set.

- **LD_LIBRARY_PATH**
  
  This must be set to use Interstage Charset Manager on the server for the code conversion required for transmitting and receiving program resources.

  ```
  $(CHARSET_BASED)/lib
  ```

  (CHARSET_BASED): Interstage Charset Manager installation folder.

**For build**

- **PATH**

  Add the following to the PATH environment variable to specify the storage path of the COBOL compile command:

  ```
  $(COB_BASED)/bin
  ```
LD_LIBRARY_PATH
Add the following to the LD_LIBRARY_PATH environment variable to specify the storage path of the COBOL runtime shared library:

${COB_BASED}/lib

NLS_PATH
Add the following to the NLS_PATH environment variable to specify the storage locations of the messages output at compile time or execution time of COBOL programs:

${COB_BASED}/lib/nls/%L/%N.cat:(COB_BASED)/lib/nls/C/%N.cat

LANG
Specify each character code set that is used by a COBOL program. This specification is used to determine whether COBOL sources contain national characters, and which character sets are used in COBOL sources at compile time.

For the Solaris and Linux (Itanium) operating systems, C is specified for the LANG environment variable, which identifies the Unicode (UTF8) character code set en_US.UTF-8 used by COBOL programs.

Dedicated shell scripts provided in the NetCOBOL product on each UNIX system is used to set individual environment variables except LANG. The following table outlines shell scripts for setting the required environment variables for compilation and linkage.

<table>
<thead>
<tr>
<th>System</th>
<th>Storage location</th>
<th>File name</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Solaris</td>
<td>/opt/FJSvcl/config</td>
<td>cobol.csh</td>
<td>For csh</td>
</tr>
<tr>
<td>Linux(Itanium)</td>
<td>/opt/FJSvcl/config</td>
<td>cobol.sh</td>
<td>For sh/bash</td>
</tr>
<tr>
<td></td>
<td></td>
<td>cobol.csh</td>
<td>For csh/tcsh</td>
</tr>
<tr>
<td>Linux(x64)</td>
<td>/opt/FJSvcl64/config</td>
<td>cobol.sh</td>
<td>For sh/bash</td>
</tr>
<tr>
<td></td>
<td></td>
<td>cobol.csh</td>
<td>For csh/tcsh</td>
</tr>
</tbody>
</table>

Specify the following other environment settings as necessary:

COBOLOPTS
Use this environment variable to commonly and independently specify some compile options from individual programs under development. This is useful for specifying the following:

- Options for COBOL debugging functions
- Options for compilation lists

COBCOPY/FORMLIB/FILELIB
Specify the storage directories of COBOL libraries, screen form descriptors, and file descriptors to be shared by multiple developers.

- Library names
  Set the library file storage directories in the environment variables whose names are library names specified with IN/OF.

Note
If the LC_ALL environment variable is required, use the same value as that used in the LANG environment variable.

Examples of shell scripts for setting environment variables
In the examples shown below, the environment variables are assumed to be set as follows:

- Environment variable related to transfer of resources
  A setting for using Interstage Charset Manager on the server side is added to the LD_LIBRARY_PATH environment variable.
Environment variables related to build
- Environment variables required for compilation and linkage of a COBOL program are set using shell scripts provided by NetCOBOL.
- UTF-8 is the character code set used by programs under development. It is specified in the LANG environment variable.
- The compilation list of COBOL source programs is stored in a common directory.
- The common storage directory of libraries referenced by developers is specified.

On a Solaris server
For remote development using a Solaris server, csh must be used as the login shell. Edit .cshrc that is found in the home directory used by each developer, and add the text shown below.

In the following example, .cshrc is modified for a Solaris server.

```
## COBOL environment setting
source /opt/FJSVcbl/config/cobol.csh

## Environment setting for Interstage Charset Manager
if($?LD_LIBRARY_PATH) then
  setenv LD_LIBRARY_PATH /opt/FSUNiconv/lib:$LD_LIBRARY_PATH
else
  setenv LD_LIBRARY_PATH /opt/FSUNiconv/lib
endif

## Setting for compilation and link that is common to developers
setenv COBOLOPTS "-dp ../list"
setenv COBCOPY ../COPYLIB:${COBCOPY}

## Character code set used by the program to be developed
setenv LANG en_US.UTF-8
```

On a Linux server
For remote development using a Linux server, csh or bash can be used as the login shell.

To use csh as the login shell, edit .cshrc that is found in the home directory used by each developer, and add the text shown below.

```
## COBOL environment setting
source /opt/FJSVcbl/config/cobol.csh

## Environment setting for Interstage Charset Manager
if(${?LD_LIBRARY_PATH}) then
  setenv LD_LIBRARY_PATH /opt/FSUNiconv/lib:${LD_LIBRARY_PATH}
else
  setenv LD_LIBRARY_PATH /opt/FSUNiconv/lib
endif

## Setting for compilation and link that is common to developers
setenv COBOLOPTS "-dp ../list"
setenv COBCOPY ../COPYLIB:${COBCOPY}

## Character code set used by the program to be developed
setenv LANG en_US.UTF-8
```

To use bash as the login shell, edit .bashrc that is found in the home directory used by each developer, and add the text shown below.

```
## COBOL environment setting
source /opt/FJSVcbl/config/cobol.sh

## Environment setting for Interstage Charset Manager
if  ${LD_LIBRARY_PATH:-""} = "" ; then
  LD_LIBRARY_PATH=/opt/FSUNiconv/lib; export LD_LIBRARY_PATH
else
  LD_LIBRARY_PATH=/opt/FSUNiconv/lib:${LD_LIBRARY_PATH};export LD_LIBRARY_PATH
fi

## Setting for compilation and link that is common to developers
COBOLOPTS="-dp ../list";export COBOLOPTS
COBCOPY=../COPYLIB:${COBCOPY}; export COBCOPY
```
### Character code set used by the program to be developed

```bash
LANG=en_US.UTF-8; export LANG
```

#### 9.2.2.2 On a Windows server

For remote development using a Windows server, a user account for the server environment is used to perform development work. Unless remote development work is performed with an existing user account, a new user account for remote development work must be created in the server environment. When creating a user account, consult the server administrator.

Generally, to add a local user account to the server machine, log on to the server with an administrator account. Then, select "Apps" > "Control Panel" > "System and Security" > "Administrative Tools" > "Computer Management" from the Start menu to display "Computer Management" window, and use "Local Users and Groups". If an additional environment setting must be made for remote development work, add the setting to the environment of the relevant user account.

**Note**

When registering a user account, register it as a member of a user group. Its password cannot be changed while the associated local personal computer is connected to the server. Therefore, when making settings for the user account, do not set a password change while the local personal computer is connected to the server.

**Note**

There are two types of environment variables: user environment variables and system environment variables. The user environment variables are generally used. However, for PATH environment variables, the system environment variables are used.

When giving priority to an original path, the COB_RDENV_X64 environment variable is used.

When a file is specified for the COB_RDENV_X64 environment variable, the file is considered to be a batch file. A NetCOBOL remote build executes the file first by the CALL batch command.

```bash
COB_RDENV_X64=C:\MyTools\myenv.bat
```

**Content of "C:\MyTools\myenv.bat"**

```bash
path C:\MyCommand;%PATH%
```

As a result, "C:\MyCommand" is given a higher priority than the path of the system environment variable in a remote build.

**Windows (Itanium)**

SDK information must be set in the environment variables of each user account. SDK information varies according to which SDK is used.

- **Microsoft Platform SDK**
  
  The names and setting values of the environment variables are listed in the following table.

  - "%NetCOBOL%" is the name of the NetCOBOL install destination folder.
  - "%MSSdk%" denotes the name of the Microsoft Platform SDK installation folder.

<table>
<thead>
<tr>
<th>Environment variable name</th>
<th>Setting values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Path</td>
<td>%NetCOBOL%</td>
</tr>
<tr>
<td></td>
<td>%MSSdk%\Bin\Win64\IA64</td>
</tr>
<tr>
<td></td>
<td>%MSSdk%\Bin\Win64</td>
</tr>
<tr>
<td></td>
<td>%MSSdk%\Bin</td>
</tr>
</tbody>
</table>
### Environment variable name | Setting values
---|---
Path | %NetCOBOL%
%MSdk%\Bin
%MSdk%\Bin\IA64
%VCRoot%\Bin\IA64
%VCRoot%\vcpackages
Lib | %NetCOBOL%
%MSdk%\Lib\IA64
%VCRoot%\Lib\IA64
Include | %MSdk%\Include
%MSdk%\Include\gl
%VCRoot%\Include

---

The names and setting values of the environment variables are listed in the following table.

- "%MSdk%" and "%VCRoot%" are the names of the Windows SDK for Windows Server 2008 and .NET Framework 3.5 (V6.1) install destination folders. "%MSdk%" and "%VCRoot%" have the following default install destinations:

<table>
<thead>
<tr>
<th>Environment variable name</th>
<th>Setting values</th>
</tr>
</thead>
</table>
| Path                      | %NetCOBOL%
%MSdk%\Bin
%MSdk%\Bin\IA64
%VCRoot%\Bin\IA64
%VCRoot%\vcpackages |
| Lib                       | %NetCOBOL%
%MSdk%\Lib\IA64
%VCRoot%\Lib\IA64 |
| Include                   | %MSdk%\Include
%MSdk%\Include\gl
%VCRoot%\Include |

### Note

CPU architecture according to bit rate of the server, IA64 of the folder name becomes x64 or amd64. Set it after confirming the software development installation folder.

### Windows(x64)

The environment variable "PATH" will be set to the folder name of the user account at the installation destination of NetCOBOL. Remote Build is executed in the same environment as the "NetCOBOL command prompt" on the NetCOBOL server side.
9.3 Preparation to connect to the server

To connect to the server, set NetCOBOL Studio as follows.
- Set the server information
- Set the Project setting for remote development

When the ftpd/rexec service is used without using the NetCOBOL remote development service on the server side, a Windows firewall exception message will display.

9.3.1 Setting the NetCOBOL Studio operating environment

The information that is used by each developer's NetCOBOL Studio for link with the server must be set. These settings are shared among workspaces.

Setting server information

To display the New Server Information dialog box and set server information.

1. Select "Window" > "Preferences" from the menu bar. The "Preferences" dialog box appears.
2. Select "COBOL" > "Remote Development" in the left pane of the "Preferences" dialog box. The "Remote Development" page is displayed.
3. Click the "New" button on the "Remote Development" page. The "New Server Information" dialog box appears.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server name</td>
<td>Specify an arbitrary name, which will be displayed in Server name on the Remote Development page of the Preferences dialog box. The server name is used to specify the target server of a COBOL project. A server name that is already defined cannot be specified.</td>
</tr>
<tr>
<td>Server OS</td>
<td>Select the operating system of the server.</td>
</tr>
<tr>
<td>Server address</td>
<td>Specify a name (FQDN: Fully Qualified Domain Name) or IP address that identifies the server in the network.</td>
</tr>
<tr>
<td>Save user name and password</td>
<td>Specify whether the user name and password are used to connect the server. If this item is checked, the user name and password specified in this dialog box will be used. If the item is unchecked, the dialog box for Inputting user name and password for connecting to the server appears when the server is initially connected after NetCOBOL Studio is launched. The default setting is unchecked.</td>
</tr>
<tr>
<td>User name</td>
<td>Specify the user name of an account used to access the server. If Save user name and password is checked, a &quot;User name&quot; must be specified.</td>
</tr>
<tr>
<td>Password</td>
<td>Specify the password assigned to the user. If Save user name and password is checked, a &quot;Password&quot; must be specified.</td>
</tr>
<tr>
<td>Character-code conversion</td>
<td>Code conversion information for files is transmitted to and received from the server. Code conversion processing is usually executed by the code conversion function provided in the system. However, if ADJUST (only for Windows) or Interstage Charset Manager is installed, it is used for code conversion.</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>COBOL Source character-code on the server side</td>
<td>Select the character-code of the COBOL source file transferred to the server side of remote development.</td>
</tr>
<tr>
<td>Convert character set in the server</td>
<td>Specify whether the server or the local PC converts code for sending or receiving a text file. The default setting is with &quot;Convert character set in the server&quot; checked.</td>
</tr>
<tr>
<td>Convert character set in the client</td>
<td>If &quot;Windows (Itanium)&quot; or &quot;Windows(x64)&quot; is selected at &quot;Server OS&quot;, this item is disabled.</td>
</tr>
<tr>
<td>Information for UNIX Server system</td>
<td>This information is specified if the selection at &quot;Server OS&quot; is Solaris or Linux(Itanium).</td>
</tr>
<tr>
<td>FTP is used for remote development</td>
<td>When this option is selected, the ftpd/rexec services are used as the remote development server-side services.</td>
</tr>
<tr>
<td>Use PASV mode for file transfer(FTP)</td>
<td>If this item is checked, files are transferred in PASV mode. The server may not be connected when files are transferred to or from an FTP server outside the firewall. For such cases, this item must be checked. The default setting is unchecked. This option is enabled for remote development that uses the server-side ftpd/rexec services.</td>
</tr>
<tr>
<td>NetCOBOL Remote Development Service on server side</td>
<td>This information is for the server-side NetCOBOL remote development service.</td>
</tr>
<tr>
<td>Port number</td>
<td>Specify the TCP/IP port number of the NetCOBOL remote development services. If the port number of the NetCOBOL remote development services has been changed on the server side, adjust this value to the changed port number. The default value is 61999. This option is enabled if remote development uses the server-side NetCOBOL remote development service.</td>
</tr>
<tr>
<td>Connection test</td>
<td>The server is connected using the current set values when this button is clicked, and the connection results are displayed in the <strong>Connection test dialog box.</strong></td>
</tr>
</tbody>
</table>

**Verifying a connection to the server**

The server is connected using the values specified in the "New Server Information" or "Modify Server Information" dialog box of server information when the "Connection test" button is clicked. The results are displayed in the "Connection test" dialog box. When a connection is successfully established, the information set for the server environment variables is displayed. If the connection attempt fails, error information is displayed.

**Inputting user name and password for connecting to the server**

If Save user name and password is not checked in the New Server Information or Modify Server Information dialog box of server information, the dialog box for specifying a user name and password appears when the server is initially connected after NetCOBOL Studio is launched. The user name and password are used to connect the server.

**Changing server information**

To display the Modify Server Information dialog box and change server information:

1. Select "Window" > "Preferences" from the menu bar. The "Preferences" dialog box appears.
2. Select "COBOL" > "Remote Development" in the left pane of the "Preferences" dialog box. The "Remote Development" page is displayed.
3. In the "Remote Development" page, select the name of the server whose information is to be changed from the "Server name list, and click the "Modify" button. The "Modify Server Information" dialog box appears.
Deleting server information

To delete server information:

1. Select "Window" > "Preferences" from the menu bar. The "Preferences" dialog box appears.
2. Select "COBOL" > "Remote Development" in the left pane of the "Preferences" dialog box. The "Remote Development" page is displayed.
3. In the "Remote Development" page, select the name of the server whose information is to be deleted from the "Server name" list, and click the "Delete" button. The server information is deleted.

9.3.2 Setting server information for a COBOL project

No server information for remote development is set for newly created COBOL projects, so the remote development function cannot be used.

To set information for remote development of the COBOL project:

1. Select the project in the "Dependency" or "Structure" view.
2. Select "Property..." from the context menu. The property dialog box appears.
3. Select "Remote Development" in the left pane of the property dialog box. The "Remote Development" page is displayed.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable project specific setting</td>
<td>When the &quot;Enable project specific setting&quot; checkbox is unchecked, the options that were specified in each COBOL project are disabled.</td>
</tr>
<tr>
<td>Enable remote development</td>
<td>If this project is for remote development, this item must be checked. If no server information is set, this item is disabled. The default setting is unchecked.</td>
</tr>
<tr>
<td>Server name</td>
<td>Specify the name of the server that is the target of this project. A list of server names can be displayed by selecting &quot;COBOL&quot; &gt; &quot;Remote Development&quot; in the &quot;Preferences&quot; dialog box. If &quot;Enable remote development&quot; is unchecked or no server name is defined, this item is disabled.</td>
</tr>
</tbody>
</table>
| Server directory      | Specify the full path name of the folder of server resources. The makefile creation function and build function use this folder as the current folder to execute their processing.  
- If Solaris or Linux is the operating system of the server, the root folder cannot be specified.  
- If Windows is the operating system of the server, the location immediately under a drive name cannot be specified.  
The server folder can be referenced by clicking the "Browse..." button.  
If "Enable remote development" is unchecked or no server name is defined, this item is disabled. |

Note

If the directory that is specified for "Server directory" is not found on the server, it is created at the makefile creation time.

The directory that is specified for "Server directory" must be unique to each COBOL project on a local personal computer. If multiple COBOL projects share one such directory on the server, makefiles is not executed correctly.
9.3.3 Exception registration of Windows firewall

If Windows Firewall, the remote development function cannot be used. To prevent this problem, change settings so that Windows Firewall does not check the program outlined in the following table.

<table>
<thead>
<tr>
<th>Program name</th>
<th>Storage folder</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>COBRDC32.exe</td>
<td>NetCOBOL installation folder</td>
<td>Remote debugger connector</td>
</tr>
</tbody>
</table>

To register COBRDC32.exe as an exception:

1. In the Windows Firewall setting window, click the "Exceptions" tab and select "Add Program".
2. Click the "Browse" button in the "Add Program" dialog box. Select "COBRDC32.exe" in the NetCOBOL installation folder. Click the "OK" button to add this program as an exception item.

Changing the scope

To change the scope:

1. In the Windows Firewall setting window, click the "Exceptions" tab. From the registered programs listed, select the program whose scope is to be changed, and then click the "Edit" button.
2. Click the "Change scope" button in the Change Scope dialog box that appears.
3. Select "My network subnet only" or "Custom list" in the Change Scope dialog box.
4. If Custom list was selected, select the IP address of the target computer, and then click the "OK" button.

On a Linux server

When there is a linkage to a Linux server, if "Windows firewall" is enabled and the ftpd/rexec service is used instead of the server-side NetCOBOL remote development service, the linkage to the Linux server might make the processing time extremely slow. To alleviate this, follow the procedure below to register port 113 as an exception.

1. In the Windows Firewall setting window, click on the "Exceptions" tab. Click the "Add Port" button. The "Add Port" dialog box appears.
2. Set values in the "Add Port" dialog box as follows:
   - Name: Set an arbitrary name.
   - Port number: Set 113.
   - TCP/UDP: Select TCP.
3. To narrow the scope of the server that accepts connections, click the "Change Scope" button and make changes in the Change Scope dialog box.

9.4 Creating a makefile and Sending resources

A makefile is required for build processing executed on the server in remote build. This makefile can be created using the makefile creation function.

9.4.1 Creating a makefile

To create a makefile.

1. Select the project in the "Dependency" or "Structure" view.
2. Select "Project" > "Remote Development" > "Makefile Creation..." from the menu bar, or select "Remote Development" > "Makefile Creation..." from the context menu. The "Makefile Creation" dialog box appears.
3. Makefile creation conditions are displayed in "Create Condition" in the "Makefile Creation" dialog box. To create a makefile, under "Create Condition" displayed, click the "OK" button. To change the "Create Condition" displayed, click the "Option setting..." button and change the contents of "Create Condition".

- 128 -
The created makefile is named "Makefile", and it is stored on both the server and the local personal computer. The makefile on the local personal computer is registered in the Other Files folder of the COBOL project. The makefile on the server is stored in the Server directory as specified on the Remote Development page of project properties.

**Point**

Makefile creation processing is executed on the server. The results of execution on the server can be reviewed by selecting "COBOL Remote" from an icon ("Open Console") on the toolbar in the Console view.

**Note**

Makefile generation handles as COBOL source files any files with the extension ".cobol" or ".cob" that are directly under the directory specified on the project "Property" > "Remote Development" page at "Server directory".

### 9.4.2 Changing makefile creation conditions

The following makefile creation conditions, displayed in the Makefile Creation dialog box, can be changed:

- TARGET names
- Precompiler options
- Compile options
- Link options

To change these conditions, click the *Option* setting button in the Makefile Creation dialog box. The Option setting dialog box appears, and the creation conditions of the TARGET names, compile options, and link options at makefile creation can be changed.

### 9.4.3 Makefile Creation dialog box

- **Target Name**
  The name of an executable file or dynamic link library (shared library) that is a TARGET of the makefile is displayed.

- **Send files**
  A list of files to be transferred to the server when the makefile is created is displayed. Files are displayed by file type as follows:
  - COBOL source files
  - COBOL libraries and descriptor files
  - Precompiler input sources

- **Compile Options**
  Compile options that are used in the makefile at compile time of a COBOL source are displayed.

- **Link options**
  Link options that are used in the makefile during linkage of a COBOL source are displayed.

- **Precompiler link**
  If precompiler link is used, the following precompiler information is displayed:
  - Extensions of precompiler input sources
  - Extensions of precompiler output sources
  - Precompiler command name and parameters
  - Indication of whether to display error messages of the COBOL compiler with the line numbers of lines in precompiler input sources
Values in the Makefile Creation dialog box

Values displayed for Create Condition in the Makefile Creation dialog box vary according to whether the first makefile is being created or the second or subsequent makefile is being created:

First makefile is being created

The values set on the Target, Build and Precompiler page of project properties are referenced. However, the information set on the Build page will be partially modified. The tabs on the Build page are as follows:

- **Compiler Options** tab
  - A copy of the information is created for compile options that have formats that are common to the systems.
  - Specifications for compile options not supported by the operating system of the server are ignored.

- **Library Names** tab
  The values specified in the "Library Names" tab are not reflected in the makefile. Set the library file storage folder in the server-side environment variables whose names are library names specified with IN/OF.

  **Note**

  When the server side is Windows (Itanium) or Windows (x64), the library file storage folder is defined in the COB_library-name environment variable.

- **Linker Options** tab
  - The storage paths and names of the object files and library files provided by NetCOBOL are replaced with the storage paths and names of files provided by the server-side NetCOBOL.
  - The following applies to object and library files not provided by NetCOBOL:
    - If the server operating system is Windows (Itanium) or Windows (x64), a copy of the information is created.
    - If the server operating system is Solaris or Linux, information for the object files and library files is deleted.

Second or subsequent makefile is being created

The values used for the previous makefile are used for second and subsequent makefiles.

### 9.4.4 Option Setting dialog box

#### 9.4.4.1 TARGET tab

TARGET names can be changed by clicking the **Target** tab in the Option Setting dialog box.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target Name</td>
<td>Specifies a TARGET name.</td>
</tr>
<tr>
<td>Initialize</td>
<td>Changes the values to the ones specified on the Target page of project properties.</td>
</tr>
</tbody>
</table>

**Note**

The types of executable files and dynamic link libraries (shared libraries) become the values selected for Target type on the Target page of project properties. To change TARGET types, change the values selected for Target type on the Target page of project properties.
9.4.4.2 **Precompiler tab**

Precompiler settings can be changed by clicking the **Precompiler** tab in the Option Setting dialog box.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Precompiler</td>
<td>Select this item to create precompiler link information in the makefile for the COBOL project. When using the precomplier, first add the precomplier build tool and set precomplier link information for the project properties. If the precomplier build tool is not suitable for the project, makefile could not be created correctly. If not selected, precompiler link information is not created in the makefile even though the information is set. For details about the precomplier setting method, refer to &quot;6.2.3 Creating a COBOL program by using the precomplier&quot;.</td>
</tr>
<tr>
<td>Precompiler command</td>
<td>Specifies the name of the command that starts the precompiler.</td>
</tr>
<tr>
<td>Precompiler parameters</td>
<td>Specifies the precompiler command parameters.</td>
</tr>
<tr>
<td>Precompiler source extension</td>
<td>Specifies the extension of the input source file for the precompiler. The following extensions cannot be specified: - cobol - cob - cbl - lace</td>
</tr>
<tr>
<td>Precompiler output source extension</td>
<td>Specifies the extension of an output source file for the precompiler.</td>
</tr>
<tr>
<td>Use original source line numbers for error messages</td>
<td>If this item is checked, COBOL compiler error messages are displayed using the line number in the original source, rather than the line number of the preprocessed source. (The INSDBINF command is invoked.) The default setting is unchecked.</td>
</tr>
<tr>
<td>INSDBINF parameters</td>
<td>This item sets the parameters of the INSDBINF command (*), which develops line information for the precompiler input source in COBOL source files generated by precompilation. Note that input and output source file names cannot be specified because they are determined from precompiler input source file names.</td>
</tr>
<tr>
<td>Initialize</td>
<td>Changes the values to those specified in the precompiler link information on the preferences Precompiler page.</td>
</tr>
</tbody>
</table>

*: For the INSDBINF command, refer to "6.2.2 INSDBINF command".

For more information about precompiler link information, see "6.2.1 Setting and changing initial values of precompiler link information".

**Note**

".cobol" cannot be specified as the extension of the precompiler output source if the server side NetCOBOL is listed below.

- NetCOBOL for Solaris or Linux(Itanium)
  V9.1 or before
9.4.4.3 Compiler Options tab

Compile options can be changed by clicking the **Compiler Options** tab in the Option setting dialog box.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compiler Options</td>
<td>Displays the compile options used in the makefile at COBOL source compile time.</td>
</tr>
<tr>
<td>Add</td>
<td>Adds the compile options. To add compile options, select the compile options to add in &quot;Compiler options&quot; in the Add Compiler Options dialog box, and click the &quot;Add&quot; button.</td>
</tr>
<tr>
<td>Change</td>
<td>Changes the compile options selected in &quot;Compiler options&quot;.</td>
</tr>
<tr>
<td>Remove</td>
<td>Deletes the compile options selected in &quot;Compiler options&quot;.</td>
</tr>
<tr>
<td>Initialize</td>
<td>Changes the values to the ones specified on the &quot;Compiler Options&quot; tab on the project properties Build page.</td>
</tr>
<tr>
<td>Specify other compiler options</td>
<td>Specifies the compile options that cannot be added from the Compiler options dialog box.</td>
</tr>
</tbody>
</table>

**Compile options that cannot be used during remote development**

When the server side is Solaris, the following compiler option cannot be used.

- **ASCOMP5 compiler option**

When the server side is Windows (x64) and NetCOBOL V11.0 or later, the following compiler option can be used. When the server side is Solaris, Linux (itanium) or Linux (x64) the following compiler option cannot be used.

- **ENCODE compiler option**

**Compile options specific to remote development**

Some compile options specific to remote development are accessed in the Option setting dialog box **Compiler Options** tab.

The following table lists the compile options that are specific to remote development and specifies whether or not these compile options can be used with particular target operating systems.

<table>
<thead>
<tr>
<th>Compile options</th>
<th>Solaris</th>
<th>Linux</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Itanium</td>
<td>x64</td>
</tr>
<tr>
<td>CODECHK</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
</tr>
<tr>
<td>KANA</td>
<td>Y</td>
<td>Y</td>
<td>N</td>
</tr>
<tr>
<td>LNGN</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
</tr>
<tr>
<td>FILELIB</td>
<td>Y</td>
<td>N</td>
<td>N</td>
</tr>
</tbody>
</table>

Y: Can be used.

N: Cannot be used.

Details of the compile options specific to remote development are as follows:
CODECHK compile option

This option specifies whether to perform a compile-time check of the national language code system at execution time (CODECHK) or not (NOCODECHK). When creating a program that does not depend on the national language code system (program common to ASCII, EUC, and Unicode), specify NOCODECHK.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>National language code system</td>
<td>Specifies whether to perform a compile-time check of the national language code system at execution time. The default is CODECHK.</td>
</tr>
<tr>
<td>check at execution time</td>
<td></td>
</tr>
<tr>
<td>CODECHK</td>
<td>Performs a compile-time check of the national language code system at execution time.</td>
</tr>
<tr>
<td>NOCODECHK</td>
<td>Does not perform a compile-time check of the national language code system at execution time.</td>
</tr>
</tbody>
</table>

KANA compile option

This option specifies the code sets for kana characters in non-numeric literals, alphabetic and alphanumeric data items.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>KANA character code processing</td>
<td>Specifies how to process the kana character code set. The default is KANA(EUC).</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>KANA(EUC)</td>
<td>Two-byte codes (EUC) are used for kana character codes.</td>
</tr>
<tr>
<td>KANA(JIS8)</td>
<td>One-byte codes (JIS) are used for kana character codes.</td>
</tr>
</tbody>
</table>

LALIGN compile option

This option specifies whether to generate objects based on an assumption that data is aligned on an eight-byte boundary (LALIGN) or not (NOLALIGN) when data declared in the linkage section is referenced. The data processing speed is faster when objects are generated based on an assumption that data is aligned on an eight-byte boundary.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processing of data declared in</td>
<td>Specifies how to process data declaration in the linkage section. The default is NOLALIGN.</td>
</tr>
<tr>
<td>LINKAGE SECTION</td>
<td></td>
</tr>
<tr>
<td>NOLALIGN</td>
<td>Does not assume that data is aligned on an eight-byte boundary.</td>
</tr>
<tr>
<td>LALIGN</td>
<td>Assumes that data is aligned on an eight-byte boundary.</td>
</tr>
</tbody>
</table>

RCS compile option

The RCS compile option has different specification formats for the local personal computer environment and the Linux (Itanium) environment. The following information pertains to the dialog box that appears when the server operating system is Linux (Itanium). The encoding form of national items in a Unicode environment is UTF-16.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Encoding of national items with</td>
<td>Specifies an endian of UTF-16. The default is LE (little-endian).</td>
</tr>
<tr>
<td>Unicode environment</td>
<td></td>
</tr>
<tr>
<td>BE</td>
<td>Specifies big-endian as the endian of UTF-16.</td>
</tr>
<tr>
<td>LE</td>
<td>Specifies little-endian as the endian of UTF-16.</td>
</tr>
</tbody>
</table>
9.4.4.4 **Library Name tab**

The values specified in the "Library Name" tab of the Build page of project properties can be referenced by selecting the "Library Name" tab in the Option setting dialog box. The values specified on the "Library Name" tab are not reflected in the makefile. Specify the library file storage folder in the server-side environment variables with library names specified with IN/OF.

**Note**

When the server side is Windows (Itanium) or Windows (x64), the library file storage folder is defined in the COB_library-name environment variable.

9.4.4.5 **Linker Options1 tab, Linker Options2 tab**

Link options are configured on the two tabs in the Option setting dialog box as follows:

- **"Linker Options1" tab**
  Libraries and object files can be specified to be linked with COBOL programs on the server side.

- **"Linker Options2" tab**
  Link options specific to the operating system of the server can be specified.

### Changing the libraries and object files to be linked

The libraries and object files to be linked on the server side can be changed by selecting the **Linker Options1** tab in the Option setting dialog box.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Adds libraries or object files to those to be linked with a COBOL program. The Add Linker Option dialog box appears when the Add button is clicked. The added libraries and object files are displayed in &quot;Select library or object&quot;. One or more libraries or object files can be added.</td>
</tr>
<tr>
<td>Change</td>
<td>Changes the specification of the library or object file selected in &quot;Select library or object&quot;. The Modify Linker Option dialog box appears when the Change button is clicked.</td>
</tr>
<tr>
<td>Remove</td>
<td>Deletes the libraries and object files selected in &quot;Linker options&quot;.</td>
</tr>
<tr>
<td>Remove All</td>
<td>Deletes all of the libraries and object files in Linker options.</td>
</tr>
<tr>
<td>C Run-time Library Name</td>
<td>Specify the file name of the C runtime library to be linked. This option is enabled if the server OS is Windows(Itanium) or Windows(x64). If the C runtime library name is omitted, &quot;LIBCMT.lib&quot; is linked.</td>
</tr>
<tr>
<td>COBOL Entry Object</td>
<td>Specify whether only object files created in COBOL are used to create the dynamic link library, or whether object files created in other languages are also used to create it. This option is enabled if the server OS is Windows(Itanium) or Windows(x64).</td>
</tr>
<tr>
<td>Link COBOL program only</td>
<td>The dynamic link library is created using only object files created in COBOL.</td>
</tr>
<tr>
<td>Other</td>
<td>Object files created in other languages are also used to create the dynamic link library.</td>
</tr>
<tr>
<td>Initialize</td>
<td>Deletes all of the libraries and object files in &quot;Linker options&quot;, and resets the settings to the values used when the first makefile was created.</td>
</tr>
</tbody>
</table>

### Adding and changing libraries and object files

The Add Linker Option dialog box appears when the Add or Change button on the "Linker Options1" tab in the Option setting dialog box is clicked. A library or object file can be added or changed from this dialog box. "Linker options" specifies the name of the library or object file to be added or changed. The absolute path name or relative path name of the library or object file is specified. The file name itself cannot be specified alone. The dialog box for referencing server-side files appears when the Browse button is clicked, and a library or object file can then be selected.
Changing link options specific to the operating system of the server

Link options specific to the operating system of the server can be changed by selecting the Linker Options tab in the Option setting dialog box. For details on server-side link options, see the NetCOBOL User's Guide on the server side.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linkage mode</td>
<td>Specify a linkage mode. The default is Dynamic linkage[-dy]. This option is valid only if the server operating system is Solaris OS or Linux.</td>
</tr>
<tr>
<td>Dynamic linkage[-dy]</td>
<td>Creates a COBOL program through dynamic linkage.</td>
</tr>
<tr>
<td>Static linkage[-dn]</td>
<td>Creates a COBOL program through static linkage.</td>
</tr>
<tr>
<td>Use screen form descriptor</td>
<td>Used to select whether the linked program uses a screen form descriptor. This item defaults to unchecked. This option is valid only if the server operating system is Solaris.</td>
</tr>
<tr>
<td>Use screen handling function</td>
<td>Used to select whether the linked program performs screen handling. This item defaults to unchecked. This option is valid only if the server operating system is Solaris.</td>
</tr>
<tr>
<td>Use C-ISAM</td>
<td>Used to select whether the linked program uses C-ISAM. This item defaults to unchecked. This option is valid only if the server operating system is Solaris.</td>
</tr>
<tr>
<td>Program invoked from C</td>
<td>Used to select whether the linked program is invoked by coding in the C language. This item defaults to unchecked. This option is valid only if the server operating system is Solaris.</td>
</tr>
<tr>
<td>Use C functions</td>
<td>Used to select whether the TARGET type is a dynamic link library and the TARGET uses the C functions. This item defaults to unchecked. This option is valid only if the server operating system is Windows (Itanium) or Windows(x64).</td>
</tr>
<tr>
<td>Output debugging information</td>
<td>Used to select whether to output debug information to the program data base file (PDB). This item defaults to check. This option is valid only if the server operating system is Windows(Itanium) or Windows(x64).</td>
</tr>
<tr>
<td>Link Option[-Wl]</td>
<td>Specifies the link options used by the ld command. This option is valid only if the server operating system is Solaris or Linux.</td>
</tr>
</tbody>
</table>

Note

If "THREAD (MULTI)" is specified on the project properties Build page Compiler Options tab, the -Tm option, which is used for linking a multithread model program, is automatically set.

### 9.4.5 Editing a makefile

A created makefile can usually be used for a build on the server side without any modification. However, the makefile can be edited.

- Editing a makefile on the local personal computer:
  
  The edited makefile is automatically sent to the server before it is used for a Build or a Rebuild,

- Editing a makefile on the server:

  During creation of another makefile, a confirmation message asks if you want to replace the edited makefile on the server with the makefile being created. If "No", makefile creation is canceled.

### 9.4.6 Creating another makefile

Even if the organization of a COBOL project is changed, another makefile is not automatically created. When performing any of the following operations and changing components of a COBOL project, create another makefile:

- Adding or renaming a COBOL source file registered in the Source Files folder, or deleting such a file from the folder.
- Adding or renaming a library file, descriptor file, or repository file registered in the Dependent Files folder, or deleting such a file from the folder.

- Adding a file to the Linking Files folder, deleting one from the folder, or renaming one in the folder.

- Adding or changing precompiler link information.

Follow the procedure below to create another makefile.

1. Select a project in the Dependency or Structure view.

2. Select "Project" > "Remote Development" > "Makefile Creation..." from the menu bar, or select "Remote Development" > "Makefile Creation..." from the context menu.

The same values used for TARGET names, precompiler link information, compile options, and link options when the last makefile was created are used to create another makefile. To change the values for the current makefile, create another makefile and then change those values.

### 9.4.7 Sending resources

#### 9.4.7.1 COBOL project

To create a makefile, files that are managed in the following folders of a COBOL project are required on the server side:

- COBOL source files and precompiler input sources registered in "Source Files" folder
- COBOL library files and descriptor files registered in "Dependent Files" folder

These files are automatically sent to the server when a makefile is created. The names of the files sent to the server when a makefile is created are displayed in "Create Condition" in the "Makefile Creation" dialog box.

**Note**

The files that are registered in the "Source Files" folder and have the extension .cbl are not sent to the server. Of the COBOL library files and descriptor files registered in the "Dependent Files" folder, only those in the project are sent. COBOL library files and descriptor files that are in other projects or managed in other folders are not sent. Also, only the library files with a .cbl extension are sent to the server.

#### 9.4.7.2 COBOL resource project

Use the following procedures to transfer the resource included in the COBOL resource project.

1. Select the COBOL resource project in "Dependency" or "Structure" view.

   Select "Project" > "Remote Development" > "Transfer..." from the menu bar, or select "Remote Development" > "Transfer..." from the context menu. The server information and files to be transferred are displayed,

2. Click the "OK" button. The file is transferred.

### 9.5 Remote Build

A COBOL program that operates on the server can be created by executing a remote build for compilation and linkage on the server. Use a makefile created by the makefile creation function for compilation and linkage.

#### 9.5.1 Executing a build

To execute a remote build:

1. Select a project in the "Dependency" or "Structure" view.

2. Select "Project" > "Remote Development" > "Build" from the menu bar, or select "Remote Development" > "Build" from the context menu.
In remote build, only those resources that have been changed since the last build are the target. To build all resources regardless of whether changes have been made since the last build, use the following method:

1. To execute a rebuild for a project, select the project in the "Dependency" or "Structure" view.
2. Select "Project" > "Remote Development" > "Rebuild" from the menu bar, or select "Remote Development" > "Rebuild" from the context menu.

**Point**

Compilation errors are displayed in the Problems view. The execution results of a remote build on the server can be viewed by clicking the "Open Console" icon on the toolbar in the Console view, and selecting "COBOL Remote".

### 9.5.2 Setting a build mode

A COBOL program that is created with remote target can be built as a release version or as a debug version by setting the proper build mode.

To change a build mode:

1. Select the project in the "Dependency" or "Structure" view.
2. Select "Project" > "Remote Development" > "Build Debug mode" from the menu bar, or select "Remote Development" > "Build Debug mode" from the context menu. If "Build Debug" mode is selected, a debug version is created. Otherwise, a release version is created.

The release or debug state of each program that has been built is stored in the project.

**Note**

Even if "Do not generate DEBUG information" is specified for the TEST compile option to build the target as a debug version, the build is executed as though "Generate WINSVD DEBUG information" were specified.

### 9.5.3 Transfer of resources

Any files that are managed in the following folders of a COBOL project and that have been updated since the last remote build are automatically sent to the server prior to the next remote build:

- COBOL source files and precompiler input sources registered in the Source Files folder
- COBOL library files and descriptor files registered in the Dependent Files folder

**Note**

Files that are registered in the Source Files folder and have the extension .cbl are not sent to the server. Of the COBOL library files and descriptor files registered in the Dependent Files folder, only those in the project are sent. COBOL library files and descriptor files that are in other projects or managed in other folders are not sent. Only library files with the extension .cbl are sent to the server.

### 9.5.4 Correcting compilation errors

Compilation error information for a remote build is displayed in the Problems view. To edit COBOL source files containing compilation errors on the local personal computer side, double-click the compilation error information in the "Problems" view or select "Go To" from the context menu. The relevant COBOL source file is opened with the editor, and the current line contains the compilation error. If the COBOL source file is already open in the editor, the line containing the compilation error becomes the current line. When modification of the errors is completed, execute a remote build. The corrected files are automatically sent to the server, and the build is executed.
Error information detected by the precomplier is not displayed in the Problems view. Error information can be checked from the Console view toolbar icon ("Open Console") by selecting "COBOL Remote".

9.6 Remote Debugging

A COBOL program that has been built on the server is debugged with the remote debug function. This section explains how to start remote debugging, and provides an overview of the remote debugger connector.

The following two methods can be used to start debugging:

- Normal Debug
  In this method, the remote debugger is called from the local personal computer to start debugging. The remote debugger connector must be started on the server in advance.

- Attach Debug
  In this method, the remote debugger is called from a COBOL program that runs on the server. This start method is used for debugging a COBOL application that runs in an Interstage Application Server environment, on a Web server, or in another environment.

Note

Other debuggers (e.g. COBOL, Java) cannot be started while debugging a COBOL program.

9.6.1 Normal Debug

This section explains the procedures for starting normal debugging, including starting the remote debugger connector on the server, and starting the remote debugger.

9.6.1.1 Starting the remote debugger connector on the server

To perform remote debugging, the remote debugger connector, which monitors instructions from the debugger on a client, must be started on the server first. Start the remote debugger connector from the server-side "NetCOBOL Command Prompt".

Use the following command format to start the remote debugger connector on the server.

<table>
<thead>
<tr>
<th>Server</th>
<th>Start command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows (Itanium)</td>
<td>cobrds64 [ [ port-specification] [connection-limitation-specification] ]</td>
</tr>
<tr>
<td>Windows (x64)</td>
<td></td>
</tr>
<tr>
<td>Solaris</td>
<td>svrdrds [ [ port-specification] [connection-limitation-specification] ]</td>
</tr>
<tr>
<td>Linux (Itanium)</td>
<td></td>
</tr>
<tr>
<td>Linux (x64)</td>
<td></td>
</tr>
</tbody>
</table>

- Port Format:

  -p port number

  For the port number, specify the same value detailed in NetCOBOL Studio Starting the remote debugger.

  Specify a port number in the range 1024 to 65535. If omitted, it defaults to 59998.

- Connect restriction format:

  -h host name  | -s connect restriction file name [ -e ]
-h host name
   Specify a host name or an IP address to allow connection.

-s connect restriction file name
   Specify the connect restriction file.

-e
   The processing result of the contents of the specified connect restriction file are displayed.

- If -s and -h are both omitted, connection will be allowed from all computers.
- After the remote debugger connector is started, the IP address and port number are displayed, and orders from the client to start debugging are monitored.

Note
- If you have to specify an environment variable for the program you want to debug, set this before you start the remote debugger connector.
- If you have to start each program that you want to debug in a different environment, you have to run the remote debugger connector in each environment. Like the environment variable, the environment here determines the operation when the remote debugger connector is started, and its settings cannot be modified later.
- Since the remote debugger connector on the server does not exit automatically when the debugger exits, end the connection when remote debugging ends. To end the remote debugger connection on the server, press the Ctrl + C keys in the command input window from which the remote debugger connection was started.
- If you have to start each program that you want to debug in a different environment, or if several developers debug at the same time, specify -p when the remote debugger connector starts, and then use a different port.

Example
Examples of starting the server remote debugger connector
- Several developers debug at the same time

```bash
cobrds32 -p 10001 -h client-1
cobrds32 -p 10002 -h client-2
cobrds32 -p 10003 -h client-3
```
- This is the case when three developers use the remote debugger at the same time.
- Choose the port number to be used by each developer and specify this using -p.
- Specify -h to accept only the specific computer's request for remote debugging and to reject incorrect connections by other developers.

Format of the connect restriction file
Specify the format of the connect restriction file as shown below:

```bash
[ ALLOW=( ALL | connection-target [connection-target ...] ) ]
[ DENY=( ALL | connection-target [connection-target ...] ) ]
```
- This allows connection from the connection target specified in ALLOW. If this is omitted, it is assumed that ALL has been specified.
- This denies connection from the connection target specified in DENY. If this is omitted, it is assumed that ALL has been specified.
- If you specify ALL, connection is allowed or denied from all computers.
- If ALLOW and DENY are both specified, and ALLOW is described, ALLOW has priority.
The connection target format is shown below.

**Table 9.3 Connection target format (IPv4)**

<table>
<thead>
<tr>
<th>Format</th>
<th>Example</th>
<th>Example of IP address application range</th>
</tr>
</thead>
<tbody>
<tr>
<td>IP address</td>
<td>192.168.0.1</td>
<td>192.168.0.1</td>
</tr>
<tr>
<td>Range</td>
<td>192.168.0.1-192.168.0.10</td>
<td>192.168.0.1 to 192.168.0.10</td>
</tr>
<tr>
<td>Wildcard (*1)</td>
<td>192.168.0.*</td>
<td>192.168.0.0 to 192.168.0.255</td>
</tr>
<tr>
<td>Host name (*2)</td>
<td>Hostname</td>
<td>192.168.0.1</td>
</tr>
</tbody>
</table>

*1: You can specify "*" instead of the decimal parts (8-bit) delimited by "."  
*2: This example assumes that a host name called "Hostname" has been assigned for an IP address of 192.168.0.1.

**Table 9.4 Connection target format (IPv6)**

<table>
<thead>
<tr>
<th>Format</th>
<th>Example</th>
<th>Example of IP address application range</th>
</tr>
</thead>
<tbody>
<tr>
<td>IP address</td>
<td>fe80::1:23:456:789a</td>
<td>fe80::1:23:456:789a</td>
</tr>
<tr>
<td>Wildcard (*3)</td>
<td>fe80::1:23:*:789a</td>
<td>fe80::1:23:0:789a to fe80::1:23:ffff:789a</td>
</tr>
<tr>
<td>Host name (*4)</td>
<td>Hostname</td>
<td>fe80::1:23:456:789a</td>
</tr>
</tbody>
</table>

*3: You can specify "*" instead of the hexadecimal parts (16-bit) delimited by ":"  
*4: This example assumes that a host name called "Hostname" has been assigned for an IP address of fe80::1:23:456:789a.

**Note**

If there is an error in the contents of the connect restriction file, the specified details will be invalid, and connection will be allowed from all computers.

---

**Windows firewall**

If the server-side OS is Windows(Itanium) or Windows(x64), the remote debugger connector cannot be used if the "Windows firewall" is enabled. Therefore, use the **9.3.3 Exception registration of Windows firewall** register "cobrds64.exe" as a Windows firewall check exception:

**9.6.1.2 Starting the remote debugger**

To start the remote debugger:

1. Select a COBOL project from the "Dependency" or "Structure" view.

2. Select "Run" > "Debug Configurations..." from the menu bar, or click ☰ of ☰ on the toolbar and select "Debug Configurations...". The "Debug Configurations" dialog box appears.

3. Select "Remote COBOL Application" in the left pane.

4. Click ☰ at the top of the left pane. The startup configuration settings page is displayed in the right pane.
5. The default startup configuration name is displayed in the "Name" field. The startup configuration name can be changed.

6. Click the "Main" tab, check each setting item, and change it as necessary.

<table>
<thead>
<tr>
<th>item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>The selected project name is displayed.</td>
</tr>
<tr>
<td>Debug Style</td>
<td>Select Normal Debug.</td>
</tr>
<tr>
<td>Server name</td>
<td>The server name that is set in the project properties is displayed.</td>
</tr>
<tr>
<td>Port number</td>
<td>Specify the port number used for communication with the server during debugging. Specify the same port number as that specified when the remote debugger connector started on the server. The initial setting value of the remote debugger connector on the server is 59998.</td>
</tr>
</tbody>
</table>
| Executable file       | Specify the executable file to be debugged. The initial setting value is either of the following, depending on whether there is a makefile:
                          - With a created makefile: Target name specified in the makefile
                          - Without a created makefile: Target name of the project
                          If the debug target is a dynamic link library, specify the target file.                                                                 |
| Workspace Directory   | Specify the work directory of the application to be debugged. The initial setting value is the directory of the executable file.                                                     |
| Argument(s)           | Specify program arguments in the format used for the command line interface.                                                                                   |

7. Start debugging by selecting "Debug". Once debugging is started with a particular configuration, the startup configuration is registered as a shortcut in the toolbar and you can restart debugging by selecting "Run" > "Debug History" or using the shortcut.

**Note**

If no information for remote development is set in the project, "Normal Debug" cannot be selected for "Debug Style".

**Point**

The debugger can be started with the default settings by selecting the project in the Dependency or Structure view, and then selecting "Run" > "Debug As" > "Remote COBOL Application" from the menu bar.

### 9.6.2 Attach Debug

The remote debugger can be used for attachment-type remote debugging. In the attach format, once the remote debugger is started on the local PC, it stays in the standby state until a COBOL application is executed on the server. Remote debugging is started when a COBOL application is executed and the environment variable for requesting the start of attachment debugging has been set on the server.

**Note**

When multiple NetCOBOL Studio is a standby state of attached debugging, attached debugging is not supported.

### 9.6.2.1 Starting the remote debugger

1. Select a COBOL project from the Dependency or Structure view.

2. Select "Run" > "Debug Configurations..." from the menu bar, or click on the toolbar and select "Debug Configurations...". The "Debug Configurations" dialog box appears.
3. Select "Remote COBOL Application" in the left pane.

4. Click at the top of the left pane. The startup configuration settings page is displayed in the right pane.

5. The default startup configuration name is displayed in "Name". The startup configuration name can be changed.

6. Click the "Main" tab, check each setting item, and change it as necessary.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>The selected project name is displayed.</td>
</tr>
<tr>
<td>Debug Style</td>
<td>Select Attach Debug.</td>
</tr>
<tr>
<td>Debug Information Directory</td>
<td>If the debugging information file is placed in a directory that is different from the server directory (Server directory of Remote Development page of project property), specify the directory path. Multiple directories can be specified as follows: - For Solaris or Linux server, connect directory paths with &quot;:&quot; (colon). - For Windows server, connect directory paths with &quot;;&quot; (semicolon).</td>
</tr>
</tbody>
</table>

7. Start the debugger by selecting "Debug". The debugger stays in the standby state until an application to be debugged is reported to have started. Once debugging is started with a particular configuration, the startup configuration is registered as a shortcut in the toolbar and you can restart debugging by selecting "Run" > "Debug History" or using the shortcut.

**Note**

If the server operating system is Solaris or Linux and the debug target is a COBOL application that uses a dynamic link library stored in a directory other than the one containing the executable file, start debugging after copying the debugging information file (extension "svd") of the dynamic link library to the directory containing the executable file.

**Point**

The debugger can be started with the default settings by selecting the project in the Dependency or Structure view, and then selecting "Run" > "Debug As" > "Remote COBOL Application" from the menu bar.

9.6.2.2 Remote debugger connector

After the remote debugger connector starts, the following icon is displayed in the task tray, and the settings are the same as those the previous time the remote debugger connector was started. The order from the server to start debugging is monitored.

**Note**

When the debugger ends, the remote debugger connector is not automatically closed. To close the remote debugger connector, right-click the task tray icon, and then select Exit from the displayed menu.

Remote Debugger Connector dialog box

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connect Information</td>
<td>Network Condition: IP address of the machine or hostname where the remote debugger connector is activating, and the port number monitored by the remote debugger connector are displayed.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Connect Port Number</td>
<td>When you select Change Port Number, Change Port Number dialog box opens.</td>
</tr>
<tr>
<td>Connect Restriction</td>
<td><strong>Connect Allowed Target:</strong> Set the connect-allowed targets. If you select Allow All the Connection, all computers are allowed to connect. Allow Target displays the list of the connect-allowed targets. Using each button, Add, Edit and Remove, you can modify the list of connect-allowed targets.</td>
</tr>
<tr>
<td></td>
<td><strong>Connect Denied Target:</strong> Set the connect-denied target. If you select Deny All the Connection, all computers are denied to connect. Deny target displays the list of the connect-denied targets. Using each button, Add, Edit and Remove, you can modify the list of connect-denied targets.</td>
</tr>
</tbody>
</table>

### 9.6.2.3 Restricting connection to computers that allow remote debugging

The way to restrict connections to computers that allow remote debugging is shown in table below. This table uses the IPv4 address. The IPv6 address can also be used.

In this table, the server remote debugger connector is expressed by "server", and the client remote debugger connector is expressed by "client".

The connect restriction file is used in the server. For details, refer to "Format of connect restriction file".

In the client, make the settings in the Connect Restriction page of the Remote Debugger Connector dialog box. For details, refer to "Remote Debugger Connector dialog box".

#### Table 9.5 Typical examples of restricting connection

<table>
<thead>
<tr>
<th>Format</th>
<th>Server</th>
<th>Client</th>
</tr>
</thead>
</table>
|        | ALLOW=192.168.0.1 DENY=ALL | Setting for "Connect Allowed Target":  
- Select "Allow Target". 
- Set as follows in the edit box:  
  192.168.0.1 |
| This allows connection for only a specific target. The IP address to be allowed connection is as follows: 192.168.0.1 | ALLOW=192.168.0.1 | Setting for "Connect Denied Target":  
- Select "Deny All the Connection". |
|        | ALLOW=192.168.0.1 \ 192.168.0.2 192.168.0.10 DENY=ALL | Setting for "Connect Allowed Target":  
- Select "Allow Target". 
- Set as follows in the edit box:  
  192.168.0.1 \ 192.168.0.2 \ 192.168.0.10 |
| This allows connection for several specific targets. The IP addresses to be allowed connection are as follows: 192.168.0.1 192.168.0.2 192.168.0.10 | ALLOW=192.168.0.1 \ 192.168.0.2 192.168.0.10 DENY=ALL | Setting for "Connect Denied Target":  
- Select "Deny All the Connection". |
This allows connection for a specific range.
The range of IP addresses to be allowed connection is as follows:
Lower limit: 192.168.0.1
Upper limit: 192.168.0.10

<table>
<thead>
<tr>
<th>Format</th>
<th>Server</th>
<th>Client</th>
</tr>
</thead>
</table>
| ALLOW=192.168.0.1-192.168.0.10 | | Setting for "Connect Allowed Target":
- Select "Allow Target".
- Set as follows in the edit box:
  192.168.0.1-192.168.0.10
Setting for "Connect Denied Target":
- Select "Deny All the Connection".

This allows connection in octet units.
The range of IP addresses to be allowed connection is as follows:
Lower limit: 192.168.0.0
Upper limit: 192.168.0.255

<table>
<thead>
<tr>
<th>Format</th>
<th>Server</th>
<th>Client</th>
</tr>
</thead>
</table>
| ALLOW=192.168.* | | Setting for "Connect Allowed Target":
- Select "Allow Target".
- Set as follows in the edit box:
  192.168.0.*
Setting for "Connect Denied Target":
- Select "Deny All the Connection".

This allows connection for all computers.

<table>
<thead>
<tr>
<th>Format</th>
<th>Server</th>
<th>Client</th>
</tr>
</thead>
</table>
| ALLOW=ALL | | Setting for "Connect Allowed Target":
- Select "Allow All the Connection".
Setting for "Connect Denied Target":
- Select "Deny All the Connection".

### 9.6.2.4 Executing an application on the server

On the server, set the environment variable required for reporting the start of execution of a debug target application to the remote debugger as shown in the table below. Specify the IP address or host name of the local PC for "connection-destination" and specify its port number. For details on how to set the environment variable, see the NetCOBOL User's Guide.

**COBOL application**

<table>
<thead>
<tr>
<th>Server</th>
<th>Environment variable</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows(itanium)</td>
<td>@CBR_ATTACH_TOOL= connection-destination!STUDIO [path-list]</td>
</tr>
<tr>
<td>Windows(x64)</td>
<td>CBR_ATTACH_TOOL= connection-destination!STUDIO [path-list]</td>
</tr>
<tr>
<td>Solaris</td>
<td></td>
</tr>
<tr>
<td>Linux(itanium)</td>
<td></td>
</tr>
<tr>
<td>Linux(x64)</td>
<td></td>
</tr>
</tbody>
</table>

- For "connection-destination", specify the client side port number for the remote debugger connector and the operating computer in the following format:

  {IP address | host name}[:port number]

  Specify the IP address in IPv4 or IPv6 format.
  Specify a port number in the range 1024 to 65535. If the port number is omitted, it defaults to 59999.
  The IPv6 format can specify the scope address. The scope address specifies the scope identifier after the address.
  If a port number is specified in an IPv6 address, enclose the address part with "["].

Example:
- Specification with IPv4 address (192.168.0.1) and port number (2000)
  @CBR_ATTACH_TOOL=192.168.0.1:2000/STUDIO

- Specification with IPv6 address (fe80::1:23:456:789a) and port number (2000)
  @CBR_ATTACH_TOOL=[fe80::1:23:456:789a]:2000/STUDIO

- Specification with IPv6 address (fe80::1:23:456:789a) and scope identifier (%eth0)
  @CBR_ATTACH_TOOL= fe80::1:23:456:789a%eth0/STUDIO

- Specification with IPv6 address (fe80::1:23:456:789a), scope identifier (%5) and port number (2000)
  @CBR_ATTACH_TOOL=[fe80::1:23:456:789a%5]:2000/STUDIO

- Specification with host name (client-1) and port number (2000)
  @CBR_ATTACH_TOOL=client-1:2000/STUDIO

- Specification with port number omitted (IPv4 address)
  @CBR_ATTACH_TOOL=192.168.0.1/STUDIO

- Specification with port number omitted (IPv6 address)
  @CBR_ATTACH_TOOL=fe80::1:23:456:789a/STUDIO

An IPv6 address cannot be specified if the server OS is Linux(Itanium).

⚠️ Note

For the Linux (Itanium) operating system, the IPv6 address cannot be specified.

Remote debugging corresponds to the IPv6 address within the following scopes.

### Table 9.6 For IPv6 of remote debugging

<table>
<thead>
<tr>
<th>item</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network</td>
<td>It corresponds to the following environments.</td>
</tr>
<tr>
<td></td>
<td>- IPv4/IPv6 Dual stack</td>
</tr>
<tr>
<td></td>
<td>- IPv6 only.</td>
</tr>
<tr>
<td>IPv6 address</td>
<td>The following IPv6 addresses are used.</td>
</tr>
<tr>
<td></td>
<td>- Aggregatable Global Unicast Address (GUA)</td>
</tr>
<tr>
<td></td>
<td>- Unique Local Unicast Addresses (ULA)</td>
</tr>
<tr>
<td></td>
<td>- link local address (LLA)</td>
</tr>
<tr>
<td>IPv4/IPv6 address selection</td>
<td>In the IPv4/IPv6 dual stack environment, IPv6 is used by priority.</td>
</tr>
<tr>
<td></td>
<td>The following are not supported</td>
</tr>
<tr>
<td></td>
<td>- Use limited (IPv4 only or IPv6 only)</td>
</tr>
<tr>
<td></td>
<td>- Switch of priority</td>
</tr>
<tr>
<td></td>
<td>- When failing in the connection by IPv6, it connects it by IPv4. (fallback)</td>
</tr>
<tr>
<td>IP address notation</td>
<td>The following not supported</td>
</tr>
<tr>
<td></td>
<td>1. Specifying a port number ([])</td>
</tr>
<tr>
<td>item</td>
<td>Specification</td>
</tr>
<tr>
<td>------</td>
<td>---------------</td>
</tr>
<tr>
<td>2.</td>
<td>The notation hex.</td>
</tr>
<tr>
<td>3.</td>
<td>Recommended notation of IPv6 addresses (RFC5952)</td>
</tr>
<tr>
<td>4.</td>
<td>Uppercase letters section</td>
</tr>
<tr>
<td>5.</td>
<td>Lowercase letters section</td>
</tr>
<tr>
<td>6.</td>
<td>Mixed-case notation of letters section</td>
</tr>
</tbody>
</table>

In the following cases, use the IPv4 address notation
- IPv4/IPv6 Dual stack operating system.
- Using of IPv4 and IPv6 together

**Note**
Privacy Extensions are not supported. When an IP address is changed, it is necessary to restart a remote debugger connector and a remote debugger.

- For path-list, specify the directory that contains the debugging information file. The debugging information is retrieved in the following order, and is used for debugging.

  1. The specified order of the additional path list (delimit by semicolon `;` and enter the full path name when you specify two or more folders).
  2. The current folder when the COBOL program began to run.
  3. The folder that contains the COBOL program.

**Note**
2. and 3. do not need to be added to PATHLIST.

**Canceling the standby state**
To stop debugging with the remote debugger in the standby state after it was started in the attach format, click 🔄 in the bottom right of the window, and then click 🔄 in the displayed Progress view.

**Attached debugging for a COBOL application on the client**
Attached debugging can also be performed for a COBOL application built on the client. To perform attachment debugging on the client, set an environment variable on the client. This variable is used to report the start of an application to the debugger.

To perform attachment debugging on the client:

1. Set the environment variable shown below on the local PC. This variable is used for reporting the start of an application to the debugger.

   ```
   @CBR_ATTACH_TOOL=localhost/STUDIO
   ```

2. Select a COBOL project from the Dependency or Structure view.

3. Select "Run" > "Debug Configurations..." from the menu bar, or click 🔄 of 🔄 on the toolbar and select "Debug Configurations...". The "Debug Configurations" dialog box appears.

4. Select "Remote COBOL Application" in the left pane.

5. Click 🔄 at the top of the left pane. The startup configuration setting page is displayed in the right pane.
6. The default startup configuration name is displayed in "Name". The startup configuration name can be changed.

7. Click the "Main" tab, check each setting item, and change it as necessary.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project name</td>
<td>Displays the selected project name.</td>
</tr>
<tr>
<td>Debug Style</td>
<td>Select &quot;Attach Debug&quot;.</td>
</tr>
<tr>
<td>Debug Information Directory</td>
<td>Specify the storage folder for the debugging information file. When it is stored in the folder displayed by the Location on the Resource page (*), it is omissible. If you specify more than one directory, the folder is delimited by the semicolon (;).</td>
</tr>
</tbody>
</table>

*: The resource page is in the properties dialog box of the project.

8. Start the debugger by selecting "Debug". The debugger stays in the standby state until an application to be debugged is reported to have started.

9. Execute a COBOL application to start debugging.

10.

9.7 Notes on using the remote development function

Use the version of NetCOBOL Studio that corresponds to the version of the NetCOBOL product that is installed on the server.

If the version of NetCOBOL on the server is newer than the version of NetCOBOL Studio, some of the server side NetCOBOL functions might not be available for use. For example:

- Newly changed or added compiler options cannot be specified by the compiler option dialog.
- Newly added reserved words are not recognized as reserved words in the COBOL editor.
- When remotely debugging, the message "An error detected in the debugger." is displayed.
Appendix A  Compile Options

A.1  Compile option details

A dialog box for specifying detailed information is displayed according to the options selected from the Compiler options list in the Add Compiler Options dialog box.

Options not specified by the "compiler option" dialog box follows the NetCOBOL compiler option default. For details about NetCOBOL compile options, refer to "NetCOBOL User's Guide".

Note

When specifying the project from the Selection from project dialog in selecting compiler options, the path separator backslash is displayed as a forward slash. The forward slash is treated as backslash.

A.1.1  Compiler option list

Compilation resources options

A.1.17 FORMLIB compile option
A.1.20 LIB compile option
A.1.36 REP compile option
A.1.37 REPIN compile option

Compilation list options

A.1.8 COPY compile option
A.1.21 LINECOUNT compile option
A.1.22 LINESIZE compile option
A.1.23 LIST compile option
A.1.24 MAP compile option
A.1.25 MESSAGE compile option
A.1.30 NUMBER compile option
A.1.33 PRINT compile option
A.1.43 SOURCE compile option
A.1.54 XREF compile option

Compilation messages options

A.1.7 CONF compile option
A.1.15 FLAG compile option
A.1.16 FLAGSW compile option

COBOL program interpretation options

A.1.2 ALPHAL compile option
A.1.5 BINARY compile option
A.1.10 CURRENCY compile option
A.1.12 DUPCHAR compile option
A.1.18 INITVALUE compile option
A.1.19 LANGVL compile option
A.1.27 NCW compile option
A.1.28 NSP compile option
A.1.29 NSPCOMP compile option
A.1.34 QUOTE/APOST compile option
A.1.38 RSV compile option
A.1.40 SDS compile option
A.1.41 SHREXT compile option
A.1.44 SQLGRP compile option
A.1.45 SRF compile option
A.1.48 STD1 compile option
A.1.49 TAB compile option
A.1.55 ZWB compile option

Source program analysis options
A.1.39 SAI compile option

Object program creation options
A.1.3 ARITHMETIC compile option
A.1.4 ASCOMP5 compile option
A.1.13 ENCODE compile option
A.1.11 DLOAD compile option
A.1.26 MODE compile option
A.1.31 OBJECT compile option
A.1.32 OPTIMIZE compile option
A.1.35 RCS compile option
A.1.51 THREAD compile option

Execution time processing options
A.1.14 EQUALS compile option
A.1.53 TRUNC compile option

Execution time resources options
A.1.42 SMSIZE compile option
A.1.46 SSIN compile option
A.1.47 SSOUT compile option

Debugging functions at execution time options
A.1.6 CHECK compile option
A.1.9 COUNT compile option
A.1.50 TEST compile option
A.1.52 TRACE compile option
A.1.2 ALPHAL compile option

This option specifies whether to treat lowercase letters in source programs the same as uppercase letters (ALPHAL) or not (NOALPHAL).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lower-case character usage</td>
<td>Specifies how to treat lowercase letters in source programs. ALPHAL is the default value.</td>
</tr>
<tr>
<td>ALPHAL</td>
<td>Treats lowercase letters the same as uppercase letters (not case-sensitive).</td>
</tr>
<tr>
<td>NOALPHAL</td>
<td>Distinguishes between lowercase letters and uppercase letters (case-sensitive).</td>
</tr>
<tr>
<td>Scope of words taken as upper case</td>
<td>This item can be selected only if ALPHAL is selected for Lower-case character usage. ALL is the default value.</td>
</tr>
<tr>
<td>ALL</td>
<td>Treats the lowercase letters that appear in program-name literals and literals in the CALL, CANCEL, ENTRY, and INVOKE statements the same as uppercase letters.</td>
</tr>
<tr>
<td>WORD</td>
<td>Treats literals as they are described.</td>
</tr>
</tbody>
</table>

A.1.3 ARITHMETIC compile option

This option specifies whether to use 18-digit compatible arithmetic mode or 31-digit extended arithmetic mode.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculation mode</td>
<td>Specifies which calculation mode to use. The default is 18 digits compatible arithmetic mode.</td>
</tr>
<tr>
<td>18 digits compatible arithmetic mode</td>
<td>Uses the 18-digit compatible arithmetic mode.</td>
</tr>
<tr>
<td>31 digits extended arithmetic mode</td>
<td>Uses the 31-digit extended arithmetic mode.</td>
</tr>
</tbody>
</table>
| Show I-level diagnostic message | Checks for the following:  
- When compiling using 18 digits compatible arithmetic mode, the following message is output:  
  JMN3024I-W The intermediate result cannot contain more than 30 digits. The intermediate result is assumed to have 30 digits.  
- Checks for arithmetic expressions with an intermediate result (fixed-point or floating-point) that is not in 18 digits compatible arithmetic mode. |

Note

- When 31 digits extended arithmetic mode is specified, compiler option BINARY can specify only BINARY(WORD,MLBON).
- Specify 18 digits compatible arithmetic mode for compatibility with V10.2.0 or earlier, or with other systems.
- Refer to "Operation mode" in Chapter 1 of the "NetCOBOL Language Reference" for details.

A.1.4 ASCOMP5 compile option

This option specifies how to interpret binary items.
### Specification of interpretation binary data

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NONE</td>
<td>Treats binary items as they are declared.</td>
</tr>
<tr>
<td>ALL</td>
<td>Treats binary items declared as USAGE BINARY, USAGE COMP, or USAGE COMPUTATIONAL as USAGE COMP-5 items.</td>
</tr>
<tr>
<td>BINARY</td>
<td>Treats binary items declared as USAGE BINARY as USAGE COMP-5 items.</td>
</tr>
<tr>
<td>COMP</td>
<td>Treats binary items declared as USAGE COMP or USAGE COMPUTATIONAL as USAGE COMP-5 items.</td>
</tr>
</tbody>
</table>

**Note**

- Using this option may affect the internal format of data.
- Note that care is required if you use this option with code that is aware of internal binary numeric formats because the ALL, BINARY, and COMP options will cause the internal formats to change.
- NONE must be specified when using the CBL routine.

### A.1.5 BINARY compile option

This option specifies whether to assign an elementary item of binary data to an area of a length in units of words (2, 4, or 8) (BINARY(WORD)) or bytes (1 to 8) (BINARY(BYTE)), which is calculated based on the number of digits. This option can also specify how to treat the high-order-end bit of an unsigned binary item.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Binary data item usage</td>
<td>Specifies how to treat binary items. The default is WORD,MLBON.</td>
</tr>
<tr>
<td>WORD,MLBON</td>
<td>The area length is in units of words, and the high-order-end bit is treated as a sign symbol.</td>
</tr>
<tr>
<td>WORD,MLBOFF</td>
<td>The area length is in units of words, and the high-order-end bit is treated as a numerical value.</td>
</tr>
<tr>
<td>BYTE</td>
<td>The area length is in units of bytes, and the high-order-end bit is treated as a sign symbol.</td>
</tr>
</tbody>
</table>

**Note**

- BINARY(BYTE) cannot be used in a class definition.
- If BINARY(BYTE) is specified, the high order end bit is treated as a numeric value.
- BINARY(WORD, MLBON) cannot be excluded when specifying ARITHMETIC(31).

**Information**

The following table shows the relationship between the number of declared digits and the area length.
<table>
<thead>
<tr>
<th>Number of PIC Digits</th>
<th>Assigned Area Length</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Signed</strong></td>
<td><strong>unsigned</strong></td>
</tr>
<tr>
<td>1 - 2</td>
<td>1 - 2</td>
</tr>
<tr>
<td>3 - 4</td>
<td>3 - 4</td>
</tr>
<tr>
<td>5 - 6</td>
<td>5 - 7</td>
</tr>
<tr>
<td>7 - 9</td>
<td>8 - 9</td>
</tr>
<tr>
<td>10 - 11</td>
<td>10 - 12</td>
</tr>
<tr>
<td>12 - 14</td>
<td>13 - 14</td>
</tr>
<tr>
<td>15 - 16</td>
<td>15 - 16</td>
</tr>
<tr>
<td>17 - 18</td>
<td>17 - 18</td>
</tr>
<tr>
<td>19 - 28 (*)</td>
<td>19 - 28</td>
</tr>
<tr>
<td>29 - 31 (*)</td>
<td>29 - 31</td>
</tr>
</tbody>
</table>

* For 31-digit extension operation mode.

### A.1.6 CHECK compile option

This option specifies whether to use the CHECK function (CHECK) or not (NOCHECK). An integer ranging from 0 to 999999 is specified for n as the number of messages to be displayed. If the option is omitted, 1 is assumed to be specified.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check function</td>
<td>Specifies whether the CHECK function can be used. The default is NOCHECK.</td>
</tr>
<tr>
<td>CHECK</td>
<td>Uses the CHECK function.</td>
</tr>
<tr>
<td>NOCHECK</td>
<td>Does not use the CHECK function.</td>
</tr>
<tr>
<td>Number of messages to be displayed</td>
<td>Specifies the number of messages to be displayed.</td>
</tr>
<tr>
<td>Check items</td>
<td></td>
</tr>
<tr>
<td>ALL</td>
<td>Checks all of NUMERIC, BOUND, ICONF, LINKAGE, and PRM.</td>
</tr>
<tr>
<td>BOUND</td>
<td>Checks whether subscripts, indexes, and reference modifications are in their correct ranges.</td>
</tr>
<tr>
<td>ICONF</td>
<td>Checks whether the INVOKE statement parameters are compatible with the tentative parameters of the method to be called.</td>
</tr>
<tr>
<td>NUMERIC</td>
<td>Checks for a data exception. If a numeric item contains a value that does not match its attribute, or if the divisor of division operation is 0, a data exception occurs.</td>
</tr>
<tr>
<td>PRM</td>
<td>Checks the following during compilation related to data items described in the USING or RETURNING phrases of the CALL statement (except call identifiers) invoking internal programs, and the USING or RETURNING phrase of the internal programs:</td>
</tr>
<tr>
<td></td>
<td>- Whether the number of parameters in the USING phrases match</td>
</tr>
<tr>
<td></td>
<td>- Consistency in the parameters of individual RETURNING phrases</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>- Whether the lengths of data items that do not reference objects match. This check of the lengths is performed only if the length is determined during compilation.</td>
<td></td>
</tr>
<tr>
<td>- Whether the class names specified for the USAGE OBJECT REFERENCE clause match, the FACTORY phrase matches, and the ONLY phrase matches if the data items reference objects</td>
<td></td>
</tr>
</tbody>
</table>

A check of the following is performed during execution related to data items described in both the USING or RETURNING phrase of the CALL statement invoking external programs, and the USING or RETURNING phrase of the external programs:

- Whether the number of parameters in the USING phrases match, and whether the data items lengths match.

*Note:* If the USING phrases have four or more parameter number mismatch errors, an error may not be detected.

- Whether the lengths of parameters in the USING phrases match. If the RETURNING phrase is not specified, data items with a length of four bytes are assumed specified because PROGRAM-STATUS is implicitly handed over. Also, if the length of a parameter is determined during execution, this check is performed during compilation, using the maximum value of the length described.

---

- While the CHECK function is enabled, the program continues running until the n-th message is output. However, the program may not run as expected due to destruction of an area or other issue. If 0 is specified for n, the program continues running regardless of the number of messages that have been displayed.

- If CHECK is specified, processing for the checks described above is embedded in an object program, decreasing execution performance. After debugging, recompile the program with NOCHECK specified.

- A check for a zero divisor for ON SIZE ERROR is performed on an arithmetic statement with the ON SIZE ERROR or NOT ON SIZE ERROR phrase. However, this divisor check is not performed on CHECK (NUMERIC).

- A check for a data exception on CHECK (NUMERIC) is performed only if zoned decimal items or packed decimal items are referenced, or alphanumeric data items or group items are moved to zoned decimal items or packed decimal items. However, the following are not checked:
  - Table element for which ALL is specified as a subscript
  - Key items in the SEARCH ALL statement, except in cases where the subscripts for the key items are one-dimensional and a single WHEN condition is specified
  - Key items for the SORT/MERGE statement
  - Host variables used in SQL statements
  - BY REFERENCE parameter of the CALL statement, the INVOKE statement, and an in-line invocation
  - Arguments of the following intrinsic functions:
    - FUNCTION ADDR
    - FUNCTION LENG
    - FUNCTION LENGTH
  - Moving of alphanumeric data items or group data items to object properties of zoned decimal items or packed decimal items.
A.1.7  CONF compile option

This option specifies whether to output diagnostic messages when items are detected for which there are incompatibilities between new and old COBOL standards (CONF) or not (NOCONF). If CONF is specified, I-level diagnostic messages will be output when items with such incompatibilities are detected. CONF is useful for converting programs that were created in conformance to old standards into programs conforming to the '85 ANSI COBOL standard.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Posting of incompatibility with the COBOL standards</td>
<td>Specifies whether to output messages on items for which there are incompatibilities between new and old COBOL standards. The default is NOCONF.</td>
</tr>
<tr>
<td>CONF</td>
<td>Outputs messages on items for which there are incompatibilities between new and old COBOL standards.</td>
</tr>
<tr>
<td>NOCONF</td>
<td>Does not generate messages when incompatibilities between new and old COBOL standards are detected.</td>
</tr>
<tr>
<td>indicating post items</td>
<td>This item is enabled only if CONF is selected for Posting of incompatibility with the COBOL standards. The default value is 68.</td>
</tr>
<tr>
<td>68</td>
<td>Outputs messages when items are detected for which there are incompatibilities between '68 ANSI COBOL and '85 ANSI COBOL. The specification is valid only if LANGLVL (85) is specified as a compile option.</td>
</tr>
<tr>
<td>74</td>
<td>Outputs messages when items are detected for which there are incompatibilities between '74 ANSI COBOL and '85 ANSI COBOL. The specification is valid only if LANGLVL (85) is specified as a compile option.</td>
</tr>
<tr>
<td>OBS</td>
<td>Outputs messages when obsolete elements in language specifications and functions are detected.</td>
</tr>
</tbody>
</table>

Note

The compiler options CONF(68) and CONF(74) are effective only if the compiler option LANGLVL(85) is specified.

A.1.8  COPY compile option

This option specifies whether to display library text embedded by the COPY statement in a source program list (COPY) or not (NOCOPY). The COPY statement is valid only if the SOURCE compile option is specified.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Library text output option</td>
<td>Specifies whether to display library text. The default is NOCOPY.</td>
</tr>
<tr>
<td>COPY</td>
<td>Displays library text.</td>
</tr>
<tr>
<td>NOCOPY</td>
<td>Does not display library text.</td>
</tr>
</tbody>
</table>

Note

COPY is only effective when the compiler option SOURCE is specified.
A.1.9 COUNT compile option

This option specifies whether to use the COUNT function (COUNT) or not (NOCOUNT).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Determines whether to use COUNT function</td>
<td>Specifies whether the COUNT function can be used. The default is NOCOUNT.</td>
</tr>
<tr>
<td>COUNT</td>
<td>Uses the COUNT function.</td>
</tr>
<tr>
<td>NOCOUNT</td>
<td>Does not use the COUNT function.</td>
</tr>
</tbody>
</table>

**Note**
- If COUNT is specified, processing to output COUNT information is embedded in an object program, decreasing execution performance. After debugging, recompile the program with NOCOUNT specified.
- COUNT cannot be specified together with the TRACE compile option. If both of these options are specified together, the option specified last is used.

A.1.10 CURRENCY compile option

This option specifies whether to use $ (CURRENCY($)) or to use another symbol (CURRENCY(currency-symbol)) as the character for the currency symbol. If CURRENCY(currency-symbol) is specified, refer to the CURRENCY SIGN clause explained in the "COBOL Language Reference" for the currency symbol that can be used.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specification of currency sign</td>
<td>Specifies what to use as the currency symbol. The default is $.</td>
</tr>
<tr>
<td>$</td>
<td>Uses $ as the currency symbol.</td>
</tr>
<tr>
<td>Specify currency symbol character</td>
<td>Uses another symbol.</td>
</tr>
<tr>
<td>Currency symbol character</td>
<td>The currency symbol character is specified.</td>
</tr>
</tbody>
</table>

A.1.11 DLOAD compile option

This option specifies whether to adopt the dynamic program structure for the program structure (DLOAD) or not (NODLOAD).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Program structure</td>
<td>Specifies the program structure. The default is NODLOAD.</td>
</tr>
<tr>
<td>DLOAD</td>
<td>Uses the dynamic program structure.</td>
</tr>
<tr>
<td>NODLOAD</td>
<td>Does not use the dynamic program structure.</td>
</tr>
</tbody>
</table>

A.1.12 DUPCHAR compile option

Specify whether the JIS non-Kanji minus sign is "MINUS SIGN (STD)" or "FULLWIDTH HYPHEN-MINUS (EXT)" when source programs and library texts are created in UTF-8.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Duplicate characters</td>
<td>Specifies how duplicate characters are treated. The default is EXT.</td>
</tr>
<tr>
<td>STD</td>
<td>MINUS SIGN</td>
</tr>
</tbody>
</table>

- 155 -
### A.1.13 ENCODE compile option

Specify the encoding of the alphanumeric data item and the national data item.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Encoding of an alphanumeric character item</td>
<td>The default is SJIS.</td>
</tr>
<tr>
<td>SJIS - Shift-JIS</td>
<td>The encoding of an alphanumeric character item is specified as SJIS.</td>
</tr>
<tr>
<td>UTF-8</td>
<td>The encoding of an alphanumeric character item is specified as UTF8.</td>
</tr>
<tr>
<td>Encoding of a national item</td>
<td>The default is SJIS.</td>
</tr>
<tr>
<td>SJIS - Shift-JIS</td>
<td>The encoding of a national item is specified as SJIS.</td>
</tr>
<tr>
<td>UTF-16</td>
<td>The encoding of a national item is specified as UTF16.</td>
</tr>
<tr>
<td>UTF-32</td>
<td>The encoding of a national item is specified as UTF32.</td>
</tr>
<tr>
<td>Endian of a national item</td>
<td>When the national item is UTF16 or UTF32, then specify little endian or big endian.</td>
</tr>
<tr>
<td>LE - Little Endian</td>
<td>The national item is little endian.</td>
</tr>
<tr>
<td>BE - Big Endian</td>
<td>The national item is big endian.</td>
</tr>
</tbody>
</table>

When compilation option ENCODE is specified, then the runtime code will be Unicode. However, when compilation option RCS is specified, then it is given priority.

---

**Point**

When compile option ENCODE (UTF8, UTF16) or ENCODE (UTF8, UTF32) is specified explicitly or implicitly, then spaces related to a national item become national spaces (alphabetic character spaces). This handling can be done by specifying the compile option NSP.

### A.1.14_EQUALS compile option

For multiple records with the same key in the SORT statement, this option specifies whether to guarantee that the SORT output records are in the same order as the SORT input records at execution time (EQUALS), or not (NOEQUALS).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processing mode of same key data in SORT statement</td>
<td>Specifies how to process data with the same key in the SORT statement. The default is NOEQUALS.</td>
</tr>
<tr>
<td>EQUALS</td>
<td>Guarantees that the SORT output records are in the same order as the SORT input records at execution time.</td>
</tr>
<tr>
<td>NOEQUALS</td>
<td>Does not guarantee that the SORT output records are in the same order as the SORT input records at execution time.</td>
</tr>
</tbody>
</table>
Note

If EQUALS is specified, special processing is executed to guarantee the order of input during the sorting operation, and the execution speed decreases.

A.1.15 FLAG compile option

This option specifies the diagnostic messages to be displayed.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Level of diagnostic message</td>
<td>Specifies a level of diagnostic messages. The default is I.</td>
</tr>
<tr>
<td>I</td>
<td>Displays all diagnostic messages.</td>
</tr>
<tr>
<td>W</td>
<td>Displays diagnostic messages of only W-level or higher.</td>
</tr>
<tr>
<td>E</td>
<td>Displays diagnostic messages of only E-level or higher.</td>
</tr>
</tbody>
</table>

Note

The diagnostic message specified in the compiler option CONF is displayed regardless of the FLAG specification.

A.1.16 FLAGSW compile option

This option specifies whether to display messages that identify types of COBOL language elements (FLAGSW) or not (NOFLAGSW).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display messages COBOL syntax language construction</td>
<td>Specifies whether to display messages that identify language elements. The default is NOFLAGSW.</td>
</tr>
<tr>
<td>FLAGSW</td>
<td>Displays messages that identify COBOL language elements.</td>
</tr>
<tr>
<td>NOFLAGSW</td>
<td>Does not display messages that identify COBOL language elements.</td>
</tr>
<tr>
<td>Language constructions</td>
<td>Select the language elements to be identified.</td>
</tr>
<tr>
<td>STDM</td>
<td>Identifies all non-low-level '85 ANSI COBOL standard language elements.</td>
</tr>
<tr>
<td>STDI</td>
<td>Identifies all non-mid-level '85 ANSI COBOL standard language elements.</td>
</tr>
<tr>
<td>STDH</td>
<td>Identifies all non-high-level '85 ANSI COBOL standard language elements.</td>
</tr>
<tr>
<td>SIA</td>
<td>Identifies language elements that are outside the range of the Fujitsu System Integration Architecture (SIA).</td>
</tr>
<tr>
<td>RPW</td>
<td>Identifies language elements of the report writer function of the '85 ANSI COBOL standard. This item can be selected only if STDM, STDI, or STDH is selected.</td>
</tr>
</tbody>
</table>
## A.1.17 FORMLIB compile option

This option specifies the folder of the screen form descriptor files from which record definitions are imported by the COPY statement with the IN/OF XMDLIB phrase. If the screen form descriptor files are stored in multiple folders, specify these folders using semicolon delimiters. If multiple folders are specified, the folders are searched in the order specified.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Screen form definition file folder</td>
<td>Specifies a folder of screen form descriptor files. Multiple folders can be specified using semicolons as delimiters. Click &quot;Browse&quot; to display the Folder type selection dialog box. Specify the absolute path of the folder. For some items selected in this way, the Folder selection dialog box appears, and you can select the folder to be specified.</td>
</tr>
</tbody>
</table>

## A.1.18 INITVALUE compile option

This option specifies whether to initialize items without the VALUE clause in working-storage section data to their specified values (INITVALUE) or not (NOINITVALUE).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initialize value of data item in WORKING-STORAGE</td>
<td>Specifies whether to initialize items without the VALUE clause in working-storage section data to their specified values. The default is NOINITVALUE.</td>
</tr>
<tr>
<td>INITVALUE</td>
<td>Initializes the items.</td>
</tr>
<tr>
<td>NOINITVALUE</td>
<td>Does not initialize the items.</td>
</tr>
<tr>
<td>Value</td>
<td>Specifies a two-digit hexadecimal number if INITVALUE is selected. If INITVALUE is selected, an entry must be made for this item.</td>
</tr>
</tbody>
</table>

## A.1.19 LANGLVL compile option

This option specifies the base standard for interpreting source program items for which there are differences between new and old COBOL standards.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specification of the ANSI COBOL standards</td>
<td>Specifies the base standard for interpreting a source program. The default is 85.</td>
</tr>
<tr>
<td>85</td>
<td>Interpretation is based on the '85 ANSI COBOL standard.</td>
</tr>
<tr>
<td>74</td>
<td>Interpretation is based on the '74 ANSI COBOL standard.</td>
</tr>
<tr>
<td>68</td>
<td>Interpretation is based on the '68 ANSI COBOL standard.</td>
</tr>
</tbody>
</table>
A.1.20 LIB compile option

This option specifies a folder of library files used for a library function (COPY statement). If the library files are stored in multiple folders, use semicolons to delimit the folders. If multiple folders are specified, the folders are searched in the order specified.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Folder where the library texts exist</td>
<td>Specifies a folder of library files. Multiple folders can be specified by using semicolon delimiters. Click &quot;Browse&quot; to display the Folder type selection dialog box. Specify the absolute path of the folder. For some items selected in this way, the Folder selection dialog box appears, and you can select the folder to be specified.</td>
</tr>
</tbody>
</table>

A.1.21 LINECOUNT compile option

This option specifies the number of lines contained on each page of a compilation list. If the specified number is in a range of 0 to 12, the compilation list is not organized into pages, and data is output continuously across pages.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of lines per page for the compiler listings</td>
<td>Specifies the number of lines contained on each page of a compilation list. The default is 60. Specify an integer consisting of three or fewer digits. If this item is not specified, 60 is assumed.</td>
</tr>
</tbody>
</table>

A.1.22 LINESIZE compile option

This option specifies the maximum number of characters per line in a compilation list (i.e., A/N characters displayed in the list).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of characters per line for the compiler listings</td>
<td>Specifies the maximum number of characters per line in a compilation list. The default is 136. The specified value can be 80 or a three-digit integer ranging from 120 to 136. If this item is not specified, 136 is assumed.</td>
</tr>
</tbody>
</table>

Note

- Source program lists, option information lists, diagnostic message lists, and compilation unit statistical information lists are output in a format with a fixed number of characters per line (120), regardless of the maximum number of characters specified for the LINESIZE compile option.
- The maximum valid value for the number of characters is 136. If a value exceeding 136 is specified for the LINESIZE compile option, 136 is assumed.

A.1.23 LIST compile option

This option specifies whether to output an object program list (LIST) or not (NOLIST). If enabled, an object program is output to the folder specified by the PRINT compile option.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print program list or not</td>
<td>Specifies whether to output an object program list. The default is NOLIST.</td>
</tr>
<tr>
<td>LIST</td>
<td>Outputs an object program list.</td>
</tr>
<tr>
<td>NOLIST</td>
<td>Does not output an object program list.</td>
</tr>
</tbody>
</table>
A.1.24 MAP compile option

This option specifies whether to output a data map list, program control information list, and section size list (MAP) or not (NOMAP). If enabled, a data map list, program control information list, and section size list are output to the file specified by the PRINT compile option.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output data map list</td>
<td>Specifies whether to output a data map list, program control information list, and section size list. The default is NOMAP.</td>
</tr>
<tr>
<td>MAP</td>
<td>Outputs a data map list, program control information list, and section size list.</td>
</tr>
<tr>
<td>NOMAP</td>
<td>Does not output a data map list, program control information list, and section size list.</td>
</tr>
</tbody>
</table>

Note

If the PRINT compile option is not specified, no object program list is output regardless of the specification of this option.

A.1.25 MESSAGE compile option

This option specifies whether to output an option information list and compilation unit statistical information list (MESSAGE) or not (NOMESSAGE).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output of compiler options and statistical information</td>
<td>Specifies whether to output an option information list and a compilation unit statistical information list. The default is NOMESSAGE.</td>
</tr>
<tr>
<td>MESSAGE</td>
<td>Outputs an option information list and a compilation unit statistical information list.</td>
</tr>
<tr>
<td>NOMESSAGE</td>
<td>Does not output an option information list or a compilation unit statistical information list.</td>
</tr>
</tbody>
</table>

A.1.26 MODE compile option

This option specifies whether use right justification (MODE(STD)) or left justification (MODE(CCVS)) for copying numeric data during execution of the ACCEPT statement. This option specifies right or left justification when moving numeric data to an item on the receiving side, with a numeric receiving-side item in the coding format of "ACCEPT identifier FROM mnemonic-name".

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specification of ACCEPT statement's action</td>
<td>Specifies the operation of the ACCEPT statement. The default is STD.</td>
</tr>
<tr>
<td>STD</td>
<td>Copies numeric data with right justification.</td>
</tr>
<tr>
<td>CCVS</td>
<td>Copies numeric data with left justification.</td>
</tr>
</tbody>
</table>
Note

If MODE(VCVS) is specified, only an external decimal data item can be specified as a receiving item in the ACCEPT statement.

A.1.27 NCW compile option

This option specifies whether the national language character set that can be specified in user-defined words is the common one in the system (NCW(STD)) or the national character set of the computer (NCW(SYS)).

If STD is specified, the following national language character sets can be used for national language user-defined words:
- JIS level-1 set
- JIS level-2 set
- JIS non-kanji set
  - 0, 1, ..., 9
  - A, B, ..., Z
  - a, b, ..., z
  - め, あ, い, う, え, お, ょ, ょ, る, や, か, け
  - ー (長音), - (ハイフン), － (負号), 々

If SYS is specified, the following national language character sets can be used for national language user-defined words:
- Character set with STD specified
- Extended characters
- Extended non-kanji set
- User-defined characters
- JIS non-kanji set

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Character set of Japanese user-defined word</td>
<td>Specifies a character set for national language user-defined words. The default is STD.</td>
</tr>
<tr>
<td>STD</td>
<td>Specifies the national language character set that is the common one in the system.</td>
</tr>
<tr>
<td>SYS</td>
<td>Specifies the national language character set of the computer.</td>
</tr>
</tbody>
</table>

A.1.28 NSP compile option

Specify whether spaces related to a national data item are handled as national spaces (NSP) or as alphabetic character spaces (NONSP). In this option, encode is enabled for handling the trailing spaces related to a national data item of Unicode and a figurative constant SPACE. It is irrelevant when the encoding of national data items is other than Unicode.
### A.1.29 NSPCOMP compile option

Use this option to specify how to treat a national space in a comparison. Specify NSPCOMP(NSP) to treat the national space as a national space; specify NSPCOMP(ASP) to treat the national space as an ANK space.

When NSPCOMP(ASP) is specified, an encode national space decided by compiler options is treated the same as the ANK blank in two bytes for UTF16, and treated to the same as the ANK blank in four bytes for UTF32.

The NSPCOMP(ASP) option is valid for the following comparisons:
- National character comparison that has a national item as an operand
- Nonnumeric comparison that has a group item as an operand

The NSPCOMP(ASP) option is invalid for the following comparisons:
- Comparison between group items that do not include national items
- Comparison between group items that include items that are not explicitly or implicitly used for display
- Comparison between group items including a national item with a different encode method
- Comparison of a national character that has an encode method different from the encode decided by the compiler options

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Handling of spaces related to</td>
<td>Specify whether spaces related to a national data item are handled.</td>
</tr>
<tr>
<td>national data item</td>
<td>The default is NONSP.</td>
</tr>
<tr>
<td>NSP</td>
<td>The national data item are handled as national spaces.</td>
</tr>
<tr>
<td>NONSP</td>
<td>The national data item are handled as alphabetic character spaces.</td>
</tr>
</tbody>
</table>

**Note**
- In a non-numeric comparison or national character comparison in processing INSPECT, STRING, or UNSTRING statements, or in a key operation for an index file, national spaces are not treated as equivalent to ANK spaces regardless of the specification of the NSPCOMP(ASP) option.
- If NSPCOMP(ASP) is specified, each ANK space is treated as a national character under the JAPANESE class condition.

### A.1.30 NUMBER compile option

Information that identifies each line in a source program is contained in different lists that are output at compilation time and at execution time. This option specifies whether to use values in the sequence number area of a source program (NUMBER), or values generated by the compiler (NONNUMBER) for such line number information.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Treatment of sequential number</td>
<td>Specifies how to treat the sequence number area of a source program.</td>
</tr>
<tr>
<td>area of source program</td>
<td>The default is NONNUMBER.</td>
</tr>
</tbody>
</table>
If a data item on any line in the sequence number area contains a character that is not a digit, or if sequence numbers are not assigned in ascending order, the line number of this line is changed to the number of the previous line (a correct sequence number) plus 1. If sequence numbers are assigned in descending order, a unique compensated number is added in the same format as that of a COPY qualification-value.

**NONUMBER**

Line numbers are assigned in ascending order beginning from 1, in increments of 1.

---

**Note**

- If the same sequence number is repeated on two contiguous lines and NUMBER is specified, it is not regarded as an error.
- If NUMBER is specified, Go To on the context menu of the "Problems" view cannot be used.
- If the sequence number is in descending order, the source analysis information file output with compiler option SAI specified can only be used by a project browser. See "A.1.39 SAI compile option".
- When NUMBER is specified, you cannot debug it. Specify NONUMBER when debugging it.
- NUMBER cannot be specified for the pre-compiler. Specify NONUMBER.

### A.1.31  OBJECT compile option

This option specifies whether to output an object program (OBJECT) or not (NOOBJECT). When an object program is output, its file is usually created in the same folder as that of the source program. To change the folder, specify a storage folder.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output of object program</td>
<td>Specifies whether to output an object program. The default is OBJECT.</td>
</tr>
<tr>
<td>OBJECT</td>
<td>Outputs an object program.</td>
</tr>
<tr>
<td>NOOBJECT</td>
<td>Does not output an object program.</td>
</tr>
<tr>
<td>Folder for object program</td>
<td>Specifies the storage folder other than the source program folder for output of an object program. Click &quot;Browse&quot; to display the Folder type selection dialog box. Specify the absolute path of the folder. For some items selected this way, the Folder selection dialog box appears, and you can select the folder to be specified.</td>
</tr>
</tbody>
</table>

---

**Note**

In NetCOBOL Studio, when the object program folder and the source program folder are different, the target file cannot be created. When you create the target file, specify the same folder for the source program folder and for the object program folder.

### A.1.32  OPTIMIZE compile option

This option specifies whether to create a globally optimized object program (OPTIMIZE) or not (NOOPTIMIZE).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global optimization</td>
<td>Specifies whether a globally optimized object program is to be created. The default is: NOOPTIMIZE.</td>
</tr>
<tr>
<td>OPTIMIZE</td>
<td>Creates a globally optimized object program.</td>
</tr>
</tbody>
</table>
A.1.33 PRINT compile option

This option is used to specify the output of a compilation list. When a compilation list is output, its file is usually created in the same folder as the source program. To change the folder, specify a storage folder.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compiler listing folder</td>
<td>Specifies the name of the compilation list output folder. Click &quot;Browse&quot; to display the Folder type selection dialog box. Specify the absolute path of the folder. For some items selected this way, the Folder selection dialog box appears, and you can select the folder to be specified.</td>
</tr>
</tbody>
</table>

A.1.34 QUOTE/APOST compile option

This option specifies whether to use a quotation mark (") (QUOTE) or an apostrophe (') (APOST) as the figurative constants QUOTE and QUOTES.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value of figurative constants QUOTE and QUOTES</td>
<td>Specifies how to treat the figurative constants QUOTE and QUOTES. The default is QUOTE.</td>
</tr>
<tr>
<td>QUOTE</td>
<td>Uses the quotation mark (&quot;).</td>
</tr>
<tr>
<td>APOST</td>
<td>Uses the apostrophe (').</td>
</tr>
</tbody>
</table>

Note

Either the quotation mark or the apostrophe can be used in a source program to indicate a quotation mark, regardless of the specification of this option. However, the same character - quotation mark or apostrophe - must be used on the left and right sides of items in quotations. Examples of correct usage: "ABC", 'ABC. Examples of incorrect usage: "ABC", 'ABC".

A.1.35 RCS compile option

This option specifies whether to use ASCII (RCS(ASCII)) or Shift-JIS (RCS(SJIS)) or Unicode (RCS=UTF-16 or RCS(UCS2)) as the code set during execution.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Runtime code set</td>
<td>Specifies whether to use ASCII or Unicode during execution. The default value is ASCII.</td>
</tr>
<tr>
<td>ASCII</td>
<td>Uses ASCII as the code set during execution.</td>
</tr>
<tr>
<td>SJIS</td>
<td>Uses Shift-JIS as the code set during execution.</td>
</tr>
<tr>
<td>UTF-16</td>
<td>Uses Unicode as the code set during execution.</td>
</tr>
</tbody>
</table>
### UCS2

Uses Unicode as the code set during execution.

### Endian in Unicode environment

Specifies which endianness is used when runtime code set is Unicode. The default value is LE.

<table>
<thead>
<tr>
<th>LE</th>
<th>Unicode Little Endian is specified for the runtime code set.</th>
</tr>
</thead>
<tbody>
<tr>
<td>BE</td>
<td>Unicode Big Endian is specified for the runtime code set.</td>
</tr>
</tbody>
</table>

**Point**

UTF16 and UCS2 are equivalent, but UTF16 is recommended.

**Note**

- For V11 and later specifying the ENCODE compile option is recommended.
- When compile option RCS is specified, it is assumed that the ENCODE compile option is specified in the following way.
  - When RCS(SJIS) is specified, it is as assumed that ENCODE(SJIS,SJIS) is specified.
  - When RCS(UTF16) or RCS(UCS2) is specified, it is as assumed that ENCODE(UTF8,UTF16) is specified.
- Under the following conditions, the compiler option RCS (UTF16) is automatically added. Specify the compiler option ENCODE as required.
  - The encoding of the COBOL source file is UTF-8.
  - And, the compiler option RCS or the compiler option ENCODE is not specified.

#### A.1.36 REP compile option

Repository files are usually created in the same folder as that of the source program. Use this option to change the storage folder. The specified folder can be the repository file input folder.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Repository file input and output folder</td>
<td>Specifies the repository file input-output folder. Click &quot;Browse&quot; to display the Folder type selection dialog box. Specify the absolute path of the folder. For some items selected in this way, the Folder selection dialog box appears, and you can select the folder to be specified.</td>
</tr>
</tbody>
</table>

#### A.1.37 REPIN compile option

This option specifies the repository file input folder. If repository files are stored in multiple folders, use semicolons to delimit the folders. If multiple folders are specified, the folders are searched in the order specified.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Repository file input folders</td>
<td>Specifies the repository file input folder. Multiple folders can be specified using semicolons as delimiters. Click &quot;Browse&quot; to display the Folder type selection dialog box. Specify the absolute path of the folder. For some items selected in this way, the Folder selection dialog box appears, and you can select the folder to be specified.</td>
</tr>
</tbody>
</table>
A.1.38  RSV compile option

This option specifies types of reserved words.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALL</td>
<td>Specifies types of reserved words. The default is ALL.</td>
</tr>
<tr>
<td>V111</td>
<td>For this product (Fujitsu NetCOBOL latest version)</td>
</tr>
<tr>
<td>V112</td>
<td>For OSIV COBOL85 V11L11</td>
</tr>
<tr>
<td>V122</td>
<td>For OSIV COBOL85 V11L20</td>
</tr>
<tr>
<td>V125</td>
<td>For COBOL85 V12L50</td>
</tr>
<tr>
<td>V30</td>
<td>For COBOL85 V30</td>
</tr>
<tr>
<td>V40</td>
<td>For COBOL97 V40</td>
</tr>
<tr>
<td>V61</td>
<td>For COBOL97 V61</td>
</tr>
<tr>
<td>V70</td>
<td>For NetCOBOL V7.0</td>
</tr>
<tr>
<td>V81</td>
<td>For NetCOBOL V8.0</td>
</tr>
<tr>
<td>V90</td>
<td>For NetCOBOL V9.0</td>
</tr>
<tr>
<td>V1020</td>
<td>For NetCOBOL V10.0, V10.1, and V10.2</td>
</tr>
<tr>
<td>V1040</td>
<td>For NetCOBOL V10.4</td>
</tr>
<tr>
<td>VSR2</td>
<td>For VS COBOLII REL2.0</td>
</tr>
<tr>
<td>VSR3</td>
<td>For VS COBOLII REL3.0</td>
</tr>
</tbody>
</table>

A.1.39  SAI compile option

This option specifies whether to output a source analysis information file (SAI) or not (NOSAI). When a source analysis information file is output, its file is usually created in the same folder as that of the source program. Use this option to change the storage folder.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAI</td>
<td>Specifies whether to output a source analysis information file. The default is NOSAI.</td>
</tr>
<tr>
<td>NOSAI</td>
<td>Outputs a source analysis information file.</td>
</tr>
</tbody>
</table>

Output location folder

Specifies the source analysis information file output folder. This item can be selected only if SAI is selected for Source analysis information file. Click "Browse" to display the Folder type selection dialog box. Specify the absolute path of the folder. For some items selected in this way, the Folder selection dialog box appears, and you can select the folder to be specified.

A.1.40  SDS compile option

When moving a signed packed-decimal item to another signed packed-decimal item, this option specifies whether to move the sign of a sending-side item as is (SDS) or move a formatted sign (NOSDS). There are two types of negative signs: 'X'B' and 'XD'. The others are treated as positive signs. Here, formatting a sign means to convert the sign of the sending-side item from either the positive sign to 'XC' or the negative sign to 'XD'.
Arrangement of sign of decimal item

Specifies whether to format the sign of a signed decimal item. The default is SDS.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SDS</td>
<td>Moves the sign as is.</td>
</tr>
<tr>
<td>NOSDS</td>
<td>Formats the sign before moving it.</td>
</tr>
</tbody>
</table>

When NOSDS is specified, if it is a value for the sign to mean negative, it changes in minus symbol and if it is a value for the sign to mean positive, it changes to plus symbol. When minus symbol attaches to value 0, it changes to plus symbol.

**Example**

Program into which operation changes by option

```
01  A PIC S9V9 VALUE -0.1
01  B PIC S9.
  
MOVE A TO B.
```

When SDS is specified, the decimal point of -0.1 is rounded down and -0 is stored in B.

When NOSDS is specified, the decimal point of -0.1 is rounded down, it becomes -0, convert of the sign is done, and +0 is stored in B.

### A.1.41 SHREXT compile option

In cases where the object format is multithread (THREAD(MULTI) phrase), this option specifies whether to share data and files with the external attribute (EXTERNAL phrase) among multiple threads (SHREXT) or not (NOSHREXT).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>External data and files usage</td>
<td>Select whether to share data and files with EXTERNAL phrase among multiple threads or not. The default is NOSHREXT.</td>
</tr>
<tr>
<td>SHREXT</td>
<td>Share data and files with the EXTERNAL phrase among multiple threads.</td>
</tr>
<tr>
<td>NOSHREXT</td>
<td>Do not share data and files with the EXTERNAL phrase among multiple threads.</td>
</tr>
</tbody>
</table>

**Note**

If the object format is single thread (THREAD(SINGLE)), SHREXT is displayed for the fixed compilation option, but compilation is performed under the condition of NOSHREXT.

### A.1.42 SMSIZE compile option

This option specifies the amount of memory used by PowerBSORT, in kilobytes.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specified capacity of memory used by PowerBSORT</td>
<td>Specifies the amount of memory used by PowerBSORT, in kilobytes. The default is 0 KByte.</td>
</tr>
</tbody>
</table>

**Note**

- If the PowerBSORT product is installed, this option is valid. If PowerBSORT is not installed, this option is ignored.
- Specify this option to limit the memory space used by PowerBSORT, which is invoked by the SORT and MERGE statements. For details on whether a specified value is valid, see the online manual for PowerBSORT.

- This option is equivalent to the values specified for the execution-time option smsize and the special register SORT-CORE-SIZE. If they are specified concurrently, the special register SORT-CORE-SIZE has highest priority, the execution-time option smsize has second priority, and the SMSIZE () compile option has third priority.

**Example**

- Special register
  
  ```plaintext
  MOVE 102400 TO SORT-CORE-SIZE
  ```

  (102400 = 100 kilobytes)

- Compile option
  
  ```plaintext
  SMSIZE (500 KB)
  ```

- Execution-time option
  
  ```plaintext
  smsize 300 KB
  ```

In the above example, the value of 100 KB for the special register SORT-CORE-SIZE, which has top priority, is used.

### A.1.43 SOURCE compile option

This option specifies whether to output a source program list (SOURCE) or not (NOSOURCE). If output, a source program list is output to the folder specified by the PRINT compile option.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output of the source program list</td>
<td>Specifies whether to output a source program list. The default is NOSOURCE.</td>
</tr>
<tr>
<td>SOURCE</td>
<td>Outputs a source program list.</td>
</tr>
<tr>
<td>NOSOURCE</td>
<td>Does not output a source program list.</td>
</tr>
</tbody>
</table>

**Note**

If the PRINT compile option is not specified, no source program list is output, regardless of the specification of this option.

### A.1.44 SQLGRP compile option

This option specifies whether to expand the definition method of SQL host variables (SQLGRP) or not (NOSQLGRP). When NOSQLGRP is specified, a REDEFINE clause cannot be specified to the host variable.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQL host variable definition expansion</td>
<td>Specifies whether to expand the definition method of SQL host variables. The default is SQLGRP.</td>
</tr>
<tr>
<td>SQLGRP</td>
<td>Expands the definition method.</td>
</tr>
<tr>
<td>NOSQLGRP</td>
<td>Does not expand the definition method.</td>
</tr>
</tbody>
</table>
When SQLGRP is specified, you cannot determine whether the data item has a correct format as a host variable just with the data description entry. This means that the syntax check for the host variable definitions during compilation differs as follows:

- The host variables not referenced in an embedded SQL statement are not subject to syntax check. Here, only the host variable names for the group items having global attribute are checked.
- More strict syntax check is made to variable-length character-type host variables. Group items containing items of level number 49 are handled as variable-length character-type host variables.

Specify NOSQLGRP for the conventional syntax check without using the host variables which are defined as group items.

### A.1.45 SRF compile option

This option specifies whether to use the fixed format or variable format for the reference format types of COBOL source programs and library files.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source reference format</td>
<td>Specify the reference formats of a COBOL source program and library. The value of SRF is initialized according to the applicable editor setting.</td>
</tr>
<tr>
<td>Source program</td>
<td>To specify the reference format for a COBOL source program, select Fixed or Variable for Source program.</td>
</tr>
<tr>
<td>Library text</td>
<td>To specify the reference format for a library, select Fixed or Variable for Library text.</td>
</tr>
</tbody>
</table>

**Note**

NetCOBOL Studio does not support Free format.

### A.1.46 SSIN compile option

This option specifies the data input source for the ACCEPT statement of the ACCEPT/DISPLAY function.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACCEPT statement data input</td>
<td>Specifies the data input source for the ACCEPT statement. The default is SSIN(SYSIN).</td>
</tr>
<tr>
<td>SSIN</td>
<td>Uses a file as the data input source.</td>
</tr>
<tr>
<td>SSIN(SYSIN)</td>
<td>Uses the console window as the data input source.</td>
</tr>
<tr>
<td>Environment variable to specify an input file</td>
<td>Specifies the name of the environment variable that sets the input source file.</td>
</tr>
</tbody>
</table>

**Note**

The environment variable information name must consist of eight or fewer upper-case letters and/or numeric characters, beginning with an upper-case letter (A to Z). The environment variable information name must not match one used by another file (file identifier name).
A.1.47  **SSOUT compile option**  
This option specifies the data output destination for the DISPLAY statement of the ACCEPT/DISPLAY function.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DISPLAY statement data output</td>
<td>Specifies the data output destination for the DISPLAY statement. The default is SSOUT(SYSOUT).</td>
</tr>
<tr>
<td>SSOUT</td>
<td>Uses a file as the data output destination.</td>
</tr>
<tr>
<td>SSOUT(SYSOUT)</td>
<td>Uses the console window as the data output destination.</td>
</tr>
<tr>
<td>Environment variable to specify an output file</td>
<td>Specifies the name of the environment variable that sets the output destination file.</td>
</tr>
</tbody>
</table>

**Note**

The environment variable information name must consist of eight or fewer upper-case letters and/or numeric characters, beginning with an upper-case letter (A to Z). The environment variable information name must not match one used by another file (file identifier name).

A.1.48  **STD1 compile option**  
This option specifies that alphanumeric codes (standard one-byte character codes) in the EBCDIC phrase of the ALPHABET clause be treated as ASCII codes (ASCII), JIS8 unit codes (JIS1), or JIS7 unit Roman letter codes (JIS2).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Treatment code of alphanumeric character EBCDIC in ALPHABET clause</td>
<td>Specifies how to treat alphanumeric codes in the EBCDIC phrase of the ALPHABET clause. The default is JIS2(JIS7 code).</td>
</tr>
<tr>
<td>ASCII(ASCII)</td>
<td>Uses EBCDIC (ASCII) for the character code convention set.</td>
</tr>
<tr>
<td>JIS1(JIS8 code)</td>
<td>Uses EBCDIC (kana) for the character code convention set.</td>
</tr>
<tr>
<td>JIS2(JIS7 code)</td>
<td>Uses EBCDIC (lower-case alphabetic characters) for the character code convention set.</td>
</tr>
</tbody>
</table>

A.1.49  **TAB compile option**  
This option specifies whether to treat the tab character as having a width of four columns (TAB(4)) or eight columns (TAB(8)).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set tab positions</td>
<td>Specifies whether to treat the tab character as having a width of four or eight columns. The value set for editors is the default.</td>
</tr>
<tr>
<td>8</td>
<td>Designates a width of 8 columns to the tab character.</td>
</tr>
<tr>
<td>4</td>
<td>Designates a width of 4 columns to the tab character.</td>
</tr>
</tbody>
</table>

A.1.50  **TEST compile option**  
This option specifies whether to enable the NetCOBOL Studio debugging function and the COBOL Error Report at the execution time (TEST) or not (NOTEST). If TEST is specified, a debugging information file for use by the NetCOBOL Studio debugging function and the COBOL Error Report is created. The file is usually stored in the same folder as that of the source program. You can use this option to change the storage folder.
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using the debugger</td>
<td>Specifies whether to use the debugging function of NetCOBOL Studio. The default is NOTEST. If debugging is the target, NOTEST is cleared and EST is selected.</td>
</tr>
<tr>
<td>TEST</td>
<td>Uses the debugging function of NetCOBOL Studio.</td>
</tr>
<tr>
<td>NOTEST</td>
<td>Does not use the debugging function of NetCOBOL Studio.</td>
</tr>
<tr>
<td>Folder for debugging</td>
<td>Specifies the debugging information file storage folder.</td>
</tr>
</tbody>
</table>

**Note**

- If this option is specified with OPTIMIZE, the debugging information file can be used by the COBOL Error Report, and cannot be used by the debugging function of NetCOBOL Studio. Do not specify OPTIMIZE when you use the debugging function of NetCOBOL Studio.
- When debugging, store the debugging information file in the same folder as the target file.

### A.1.51 THREAD compile option

This option specifies whether the object format is multithread (THREAD(MULTI)) or single thread (THREAD(SINGLE)).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type of thread mode</td>
<td>Specifies an attribute of an object file as multi-thread or single thread. The default is SINGLE.</td>
</tr>
<tr>
<td>MULTI</td>
<td>Specifies an attribute of an object file as multi-thread.</td>
</tr>
<tr>
<td>SINGLE</td>
<td>Specifies an attribute of an object file as single thread</td>
</tr>
</tbody>
</table>

### A.1.52 TRACE compile option

This option specifies whether to use the TRACE function (TRACE) or not (NOTRACE).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tracing procedure names</td>
<td>Specifies whether to use the TRACE function. The default is NOTRACE.</td>
</tr>
<tr>
<td>TRACE</td>
<td>Uses the TRACE function.</td>
</tr>
<tr>
<td>NOTRACE</td>
<td>Does not use the TRACE function.</td>
</tr>
<tr>
<td>Number of variables showing trace information</td>
<td>Specifies an integer ranging from 1 to 999999 as the number of trace information items to be output. The default is 200.</td>
</tr>
</tbody>
</table>

**Note**

- If TRACE is specified, processing to display trace information is embedded in an object program, decreasing execution performance. After debugging, recompile the program with NOTRACE specified.
- TRACE cannot be specified together with the COUNT compile option. If both of these options are specified together, the option specified last is valid.
A.1.53 TRUNC compile option

This option specifies whether to truncate upper digits in numeric characters when converting into binary (TRUNC), or to give priority to execution speed regarding truncation (NOTRUNC).

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Truncation of high-order digits when converting into binary items</td>
<td>Specifies whether to truncate the upper digits of numeric characters when converting to binary. The default is NOTRUNC.</td>
</tr>
<tr>
<td>TRUNC</td>
<td>Truncates the number of upper digits according to the PICTURE clause of the receiving-side item, and saves the resultant value in the receiving-side item. If this item is specified with the OPTIMIZE compile option, optimization truncates the number of upper digits of data items that are from zoned decimal items or packed decimal items. The number of upper digits is truncated as described above only if the number of digits in the integer part of the sending-side item is greater than that of the receiving-side item.</td>
</tr>
<tr>
<td>NOTRUNC</td>
<td>Gives priority to the object program execution speed. If the execution speed would be higher without truncation of the upper digits, the digits will not be truncated.</td>
</tr>
</tbody>
</table>

Point

In the PICTURE clause:

- Moving S999V9 (three-digit integer part) to S99V99 (two-digit integer part): The digits are truncated.
- Moving S9V999 (one-digit integer part) to S99V99 (two-digit integer part): The digits are not truncated.

Note

- If NOTRUNC is specified and the number of digits in the integer part of the sending-side item is greater than that of the receiving-side item, the results are not defined.
- To specify NOTRUNC, the applicable program must be designed such that no value exceeding the digit number in the PICTURE clause is stored in the receiving-side item, even if the truncation of digits is not applied.
- The criteria for whether to truncate the digits in cases where NOTRUNC is specified are different for different compilers. The compatibility with another system is not guaranteed for a program that depends on the specification of NOTRUNC to suppress truncation.

A.1.54 XREF compile option

This option specifies whether to output a cross reference list (XREF) or not (NOXREF). A cross reference list displays information such as user-defined words and special registers in ascending order of the collating sequence. If XREF is specified, the cross reference list is output to the folder specified by the PRINT compile option.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output of the cross-reference list</td>
<td>Specifies whether to output a cross reference list. The default is NOXREF.</td>
</tr>
<tr>
<td>XREF</td>
<td>Outputs a cross reference list.</td>
</tr>
<tr>
<td>NOXREF</td>
<td>Does not output a cross reference list.</td>
</tr>
</tbody>
</table>
Note

- If the PRINT compile option is not specified, no cross reference list is output regardless of the specification of this option.
- If the maximum severity code is S level or higher as a result of compilation with the XREF compile option specified, output of a cross reference list is suppressed.

A.1.55 ZWB compile option

In a comparison between a signed zoned decimal item and an alphanumeric character field, this option specifies whether to ignore the sign part of the zoned decimal item (ZWB) or not (NOZWB). Here, an alphanumeric character means an alphanumeric data item, alphabetic item, alphanumeric edited data item, numeric edited data item, nonnumeric literal, or figurative constant other than ZERO.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comparison of signed external decimal item and alphanumeric item</td>
<td>Specifies a method for comparing a signed zoned decimal item and an alphanumeric character field. The default is ZWB.</td>
</tr>
<tr>
<td>ZWB</td>
<td>Compares the items ignoring the signed part.</td>
</tr>
<tr>
<td>NOZWB</td>
<td>Compares the items including the signed part.</td>
</tr>
</tbody>
</table>

Example

```
77 ED PIC $9(3) VALUE +123.  
77 AN PIC X(3) VALUE "123". 
```

Under these conditions, the logical value of the conditional expression ED = AN is as follows:

- If ZWB is specified ... True
- If NOZWB is specified ... False
B.1 Build Problems

B.1.1 After a resource is updated with an external editor, build is not executed when Build Project or Build All is selected.

**Issue:** Resource changes have not been reflected in the workspace concerned.

**Solution:** Take any of the following actions:

- Select "Window" > "Preferences" > "General" > "Workspace" from the menu bar, and then select "Refresh automatically". If this option is selected, resources in the workspace are automatically synchronized with the corresponding resources in the file system.

- When an external editor has been used to update a resource, before executing a build, select the updated resource or the folder containing it in the Dependency or Structure view, and then select "File" > "Refresh" from the menu bar.

B.1.2 A message "repository file (*.rep) was not found" is displayed in a dependency analysis.

**Issue:** The Console view displays the following error message in a dependency analysis:

full-path-name-for-a-cobol-source-file: line-number: repository-file-name: does not exist.

**Solution:** Check for the following:

- A repository file of COBOL source files in the project. Since a project contains no repository file immediately after the project is created or cleaned, this error message is displayed. Repository files are created when a build for the project is executed, so no special response is required for this message.

- A repository file outside the project. Confirm that coding in the COBOL source files is correct and that all the necessary repository files have been provided.

B.1.3 A static library (lib) cannot be made

**Issue:** Static library (lib) cannot be made with NetCOBOL Studio though executable file (exe) or dynamic link library (dll) can be made.

**Solution:** Use the LIB command to make static library (lib). Refer to the technical intelligence of the Microsoft company for detail of the LIB command.

B.2 Debugger problems

B.2.1 Menu items in the Run menu cannot be used during debugging.

**Issue:** The following menu items in the Run menu are grayed out and their functions are disabled during debugging of a COBOL application:

- Run to Line
- Use Step Filters
- Watch
- Inspect
- Display
- Execute
- Step Into Selection
- Toggle Line Breakpoint
- Toggle Method Breakpoint
- Toggle Watchpoint

**Solution**: These menu items are used for debugging a Java application, and cannot be used for a COBOL application.

- To add or delete a breakpoint, right-click on the vertical ruler of the COBOL editor, and select "Add Breakpoint" or "Remove Breakpoint" from the context menu.
- To execute a program up to the specified line, select "Run to Line" from the context menu of the COBOL editor.

### B.2.2 Values of data items outside the scope are displayed during debugging.

**Issue**: Values of data items outside the scope are also displayed, but they are not correct values.

**Solution**: Do not use the values displayed for data items outside the scope.

### B.2.3 An error dialog box containing the message "Target executable not found. Could not proceed" appears.

**Issue**: If a COBOL application is executed or debugged in a workspace created by copying or moving a workspace folder containing the COBOL project, an error dialog box containing the message "Target executable not found. Could not proceed." appears.

**Solution**: Although the workspace folder containing the COBOL project was copied or moved, the path name used before the copy or move remains defined in Executable file on the "Main" tab of Debug or Run for the COBOL application. This discrepancy causes this message. In this case, click the "Browse" button of Project name on the "Main" tab of Debug or Run, and select the project name again in the Project Selection dialog box. The path name is changed to the correct one.

### B.2.4 Program execution cannot be restarted after it stops at a breakpoint.

In the Debug view, if a selection is made outside the tree element displaying the path of the program being debugged, the program remains stopped even if "Resume" or "Step Into" is selected to restart program execution.

**Solution**: In the Debug view, make a selection from the tree element displaying the path of the program, and then select "Resume" or "Step Into" to restart program execution.

### B.3 Execution Problems

#### B.3.1 A runtime error occurs when an executable file is double-clicked.

**Issue**: When you double-click an executable file (.exe), a runtime initialization failure occurs.

**Solution**: See Chapter 8 Execution Function", and verify that the correct folder is specified in the Working folder field.

### B.4 Remote Development Problems

#### B.4.1 The stty command causes an error in link with a server.

**Issue**: The stty command causes an error and fails when linking to a Solaris or Linux server that uses the ftpd/rexec service.

**Solution**: Comment out the stty command coded in the .bashrc file (if bash is used) or .cshrc file (if csh is used).

Before modification:

```
stty erase ^H
```

After modification:

```
#stty erase ^H
```
### B.4.2 NetCOBOL Studio freezes when linking with a server.

**Issue:** The server does not respond when linking to a Solaris or Linux server that uses the ftpd/rexec service and NetCOBOL Studio freezes.

**Solution:** This problem occurs when the .bashrc file (if bash is used) or .cshrc file (if csh is used) has been coded with a script that requests user input and involves waiting for a response. Delete the script that causes waiting for a response, such as one that requests user input, from the file.

### B.4.3 The error message "Error occurred while sending command. Remote computer reset connection" is displayed.

**Issue:** The "Error occurred while sending command. Remote computer reset connection." error occurs when linking to a Solaris or Linux server that uses the ftpd/rexec service, and connection to the server is not possible.

**Solution:** The domain name system (DNS) controls domain names and IP addresses. With some DNS settings, the rexec daemon fails in a reverse search for the host name of a personal computer connected to the server. Edit the /etc/hosts file on the server to add the following information about the client personal computer:

<table>
<thead>
<tr>
<th>IP address</th>
<th>host name</th>
</tr>
</thead>
</table>

### B.4.4 The line feed code is not converted when a text file is transferred.

**Issue:** If vsftpd is used for file transfer (FTP) in Linux server remote development, when a text file is transferred the line feed codes remain as Windows line feed codes (0x0d0a) rather than changing to Unix line feed codes (0x0a).

**Solution:** To enable conversion of the line feed code, delete # at the beginning of the following lines, which are commented out, in the /etc/vsftpd/vsftpd.conf file:

<table>
<thead>
<tr>
<th>Before modification</th>
</tr>
</thead>
<tbody>
<tr>
<td>#ascii_upload_enable=YES</td>
</tr>
<tr>
<td>#ascii_download_enable=YES</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>After modification</th>
</tr>
</thead>
<tbody>
<tr>
<td>ascii_upload_enable=YES</td>
</tr>
<tr>
<td>ascii_download_enable=YES</td>
</tr>
</tbody>
</table>

### B.4.5 The error message "Parameter of server command is invalid" is displayed when using remote development functions.

**Issue:** The line feed code is not converted according to vsftpd settings.

**Solution:** To enable conversion of the line feed code, delete # at the beginning of the following lines, which are commented out, in the /etc/vsftpd/vsftpd.conf file:

<table>
<thead>
<tr>
<th>Before modification</th>
</tr>
</thead>
<tbody>
<tr>
<td>#ascii_upload_enable=YES</td>
</tr>
<tr>
<td>#ascii_download_enable=YES</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>After modification</th>
</tr>
</thead>
<tbody>
<tr>
<td>ascii_upload_enable=YES</td>
</tr>
<tr>
<td>ascii_download_enable=YES</td>
</tr>
</tbody>
</table>

### B.4.6 Local project build runs when starting remote debug.

**Issue:** The "Build (if required) before launching" checkbox is checked.

**Solution:** Following the steps below to uncheck the checkbox.
1. Select "Window" > "Preferences" from the menu bar. The Preferences dialog box is displayed.
2. Select "Run/Debug" > "Launching" from the left pane. The "Launching" page is displayed.
3. Uncheck the "Build (if required) before launching" checkbox in the General Options group box.

### B.4.7 Nothing appears in the Problems view even though the remote build failed.

For remote builds, the Problems view displays only compile errors. To check other errors, select "COBOL Remote" from the toolbar icon ("Open Console") in the Console view.

### B.5 NetCOBOL Studio General Problems

#### B.5.1 An error dialog box stating "for details refer to log" appears.

**Issue**: An error occurs directing you to refer to the log for more information.

**Solution**: The log can be referenced by selecting "Help" > "About NetCOBOL Studio(x64)" from the menu bar, selecting "Configuration Details" in the dialog box that appears, and then selecting "View Error Log" in the Configuration Details dialog box.

To display the Error Log view and reference the log:

1. Select "Window" > "Show View" > "Other" from the menu bar.
2. Select "General" > "Error Log" in the tree in the "Show View" dialog box that appears.
3. Click the "OK" button to display the Error Log view.

Information such as when each workspace was created, when NetCOBOL Studio was started, and what errors have occurred in NetCOBOL Studio are recorded in the log. Some log information will indicate normal NetCOBOL Studio operation. Problems are recorded at the time they occur in NetCOBOL Studio. If no NetCOBOL Studio operation problems are indicated in the error log, the error dialog box display may be caused by an erroneous operation, such as trying to do a build for remote development with incorrect server information. If a NetCOBOL Studio operation problem does appear in the error log, collect the log information listed below and contact a Fujitsu certified service engineer.

The log files are created in the following folder:

```plaintext
<work-space-folder>\metadata\`
```

The log files are named as follows:

```
.bak_0.log
.bak_1.log
:
:
.bak_9.log
```

Existing log files contain information sorted in descending time stamp order, with the most recent item at the top of the list.

#### B.5.2 Entire message containing "..." cannot be displayed.

**Issue**: If a message to be displayed in a dialog box is longer than the message display field, the middle of the message may be represented by "...".

**Solution**: The entire message can be displayed using one of the following methods:

- Move the mouse cursor onto the displayed message whose middle part is omitted. A tooltip appears displaying the entire message.
- If the dialog box can be resized, expand the width of the dialog box so that the entire message can be displayed.

#### B.5.3 Files, folders, and projects cannot be deleted.

**Issue**: If a file is generated with a path that exceeds the maximum value for file system path lengths, deletion fails for that file and for the folder and project that include that file.
**Solution:** Use the method below to delete the file and folder

```java
java -classpath (NetCOBOL install folder) \eclipse\f5drprfc.jar RemoveFolderContents folder name
```

This command requests confirmation on each file and folder in the specified folder, before deleting them. The specified folder itself is not deleted.

**B.5.4 The Export of COBOL Project Fail**

**Issue:** After a resource is updated with an external editor, changes are not reflected in the workspace.

**Solution:** Take any of the following actions:

- Select "Window" > "Preferences" > "General" > "Workspace" from the menu bar, and then select "Refresh automatically". When this option is selected, resources in the workspace are automatically synchronized with the corresponding resources in the file system.

- When an external editor is used to update a resource, before executing the export, select the updated resource, or the folder containing it in the Dependency or Structure view, and then select "File" > "Refresh" from the menu bar.
Appendix C  Handling of Workspace and Project

This section explains the handling of workspace and project.

C.1  Default workspace

The default workspace is in the following folder. It is created when NetCOBOL Studio is first started.

```
My documents folder (*1) \NetCOBOL Studio V11.0.0(x64)\workspace3.4
```

*1: The "My documents" folder is used to save each user's data. The location of the "My documents" folder varies based on the Windows OS.

C.2  Setting and switch method of workspace

Workspace

A workspace is the place where development resources and the user's working state are maintained. Development resources are managed in the workspace as a project. Multiple projects can be created in a workspace. The working state is information such as workbench setting and the break point set in the source file, and is maintained in the workspace.

The workspace can fall into several categories, such as workspace for development, workspace for investigation, and workspace for test.

Note

- A workspace can be shared among multiple users or machines, but the same workspace cannot be used among multiple Eclipse bases at the same time.
- A project can be placed out of workspace folder, but do not refer to the same project in multiple workspaces. If a project is used by multiple workspaces, the alteration of project information cannot function normally.

C.2.1  Setting workspace

The Workspace is set using the "setting operating environment" dialog box according to the following procedures.

1. Select Apps > Fujitsu NetCOBOL V11(x64) > NetCOBOL Studio(x64) from the Start menu.

NetCOBOL Studio Start screen displays.
2. Click the "Setup..." button. The "Setup Configuration" dialog box is displayed.

![Setup Configuration dialog box]

3. Click the "Add" button. The "Select Folder" dialog box is displayed.

4. Select the folder used as the workspace. A "New folder" is made in the selected folder when the "Make New Folder" button is clicked. It can be used by changing the name.

![Select Folder dialog box]

Select a folder, and click the "OK" button. In this example, "C:\NetCOBOL Studio\workspace" is set as the new workspace.
5. Click the "Yes" button since the following message box is displayed.

6. Select the Workspace, and click the "OK" button.

7. Click the "Run" button on the "Run" dialog box.

NetCOBOL Studio is started. The Workspace becomes "C:\NetCOBOL Studio\workspace".

C.2.2 Switch of workspace

The Workspace can be switched to another workspace when NetCOBOL Studio is active.

1. Select "File" > "Switch Workspace" > "Other" from the NetCOBOL Studio menu bar.

   The "Workspace Launcher" dialog box is displayed. The present workspace is displayed in "workspace".

2. Enter the switched new workspace name for "Workspace" using the full path.

   The folder can be selected by using the "Browse" button.
Moreover, when the "Workspace" drop-down button is selected, the history of the workspaces used so far is displayed. The Workspace can be selected from the list displayed.

3. Click the "OK" button.

NetCOBOL Studio is re-started. The Workspace becomes the specified workspace.

C.3 Importing Project

In the following cases, the projects are imported and used.

- When you want to use a project made with NetCOBOL Studio based on Eclipse 3.4, with NetCOBOL Studio based on Eclipse 3.2.

Use the following method to import an existing project in batch mode.

1. Set the workspace of the copy destination, and start NetCOBOL Studio.
2. Select "File" > "Import" from the NetCOBOL Studio menu bar. The "Import" wizard is started.
Appendix D Various Specification Formats used in Debugging

This section explains various specification formats used in the Watch view.

D.1 Identifier Name

When adding data items for monitoring to the Watch view, use the identifier name as data name.

One of the following is the identifier name.
- Identifier
- Condition-name
- Index Name
- Special Register
- Symbolic-constant
- Named Literal
- Function

It is necessary to enclose the identifier name in parenthesis when it contains spaces. See the example below.

```
LIST (DATA01 OF DATA02)
```

Identifier

The identifier can be specified with the same scope of COBOL language specifications in debugging.

In addition, the data described in the factory definition and the object definition can be handled from external, by using the same specification as the original identifier.

Specification Format of Identifier

It is the same as the language specification of COBOL with the exception of the following restrictions for subscript and reference modifier.

- Subscript is specified by the following formats.

```
| Subscript | {Integer | Identifier[{+ | -}Integer | Index Name[{+ | -}Integer | Symbolic-constant[{+ | -}Integer | Named Literal[{+ | -}Integer]}
```

- Reference modification is specified by the following formats.

```
<table>
<thead>
<tr>
<th>Reference Modifier</th>
<th>(High order end character position: [Length])</th>
</tr>
</thead>
</table>
| High order end character position/ Length | {Integer | Identifier[{+ | -}Integer | Symbolic-constant[{+ | -}Integer] | Named Literal[{+ | -}Integer]
```

- Predefined object identifier can be specified except SUPER.
- Identifier is specified by the following formats. Underlined part is the part which is extended originally.
- Identifier is specified by the internal name under the class condition.
- Object reference qualifier is specified under the condition that handling data which is described in factory definition or object definition from external. The class-name of object reference qualifier specifies the internal name.
- Under the condition that identifying super-class data, predefined object identifier SUPER specifies the super-class name. Super-class name specifies the internal name or the external name.

**Condition-name**

Condition-name can be specified with the same scope of COBOL language specifications in debugging.

In addition, the condition-name described in the factory definition and the object definition can be handled from external, by using the same specification as the original condition-name.

**Specification Format of condition-name**

It is the same as the language specification of COBOL with the exception of the following restrictions for subscript.

- Subscript is specified by the following formats.

```plaintext
<table>
<thead>
<tr>
<th>Subscript</th>
</tr>
</thead>
<tbody>
<tr>
<td>{Integer</td>
</tr>
<tr>
<td>Index Name[+</td>
</tr>
<tr>
<td>Symbolic-constant[+</td>
</tr>
<tr>
<td>Named Literal[+</td>
</tr>
</tbody>
</table>
```

- Condition-name is specified by the following formats. The underlined part is the part that is extended originally.

```plaintext
<table>
<thead>
<tr>
<th>Condition-name</th>
</tr>
</thead>
<tbody>
<tr>
<td>[{pointer qualifier</td>
</tr>
<tr>
<td>{IN</td>
</tr>
</tbody>
</table>
```
### Pointer Qualifier

| [ { IN | OF} file name] |
|------------------------|
| ([{subscript}...]...) |

### Object Reference Qualifier

<table>
<thead>
<tr>
<th>Object reference qualifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>[{data name [{IN</td>
</tr>
<tr>
<td>data name [{IN</td>
</tr>
<tr>
<td>(data name [{IN</td>
</tr>
<tr>
<td>ADDR function</td>
</tr>
<tr>
<td>-&gt; [{data name [ { IN</td>
</tr>
<tr>
<td>(data name [{IN</td>
</tr>
</tbody>
</table>

### Predefined Object Identifier SUPER

<table>
<thead>
<tr>
<th>AS class-name</th>
</tr>
</thead>
</table>

- Object reference qualifier is specified under the condition that handling condition-name which is described in factory definition or object definition from external. The class-name of the object reference qualifier specifies the internal name.

- Under the condition that identifying super-class data, predefined object identifier SUPER specifies the super-class name. Super-class name specifies the internal name or the external name.

---

### Index-name

Index-name can be specified with the same scope of COBOL language specifications in debugging.

In addition, the index-name described in the factory definition and the object definition can be handled from external, by using the same specification as the original index-name.

#### Specification Format of Index-name

It is the same as the language specification of COBOL. The underlined part is the part that is extended originally.

<table>
<thead>
<tr>
<th>Index-name</th>
<th>[object reference qualifier] index-name</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>[{IN</td>
</tr>
<tr>
<td></td>
<td>[{IN</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Object Reference Qualifier</th>
<th>[class-name [predefined object identifier SUPER ] :: ]</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>[object reference item [{IN</td>
</tr>
<tr>
<td></td>
<td>({{subscript}...})</td>
</tr>
<tr>
<td></td>
<td>[predefined object identifier SUPER ] :: ] ...</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Predefined Object Identifier SUPER</th>
<th>AS class-name</th>
</tr>
</thead>
</table>

- Object reference qualifier is specified under the condition that handling index-name which is described in factory definition or object definition from external. The class-name of the object reference qualifier specifies the internal name.

- Under the condition that identifying super-class data, predefined object identifier SUPER specifies the super-class name. Super-class name specifies the internal name or the external name.
Special Register

Special register can be specified with the same scope of COBOL language specifications in debugging.

Symbolic-constant

Symbolic-constant can be specified with the same scope of COBOL language specifications in debugging.

Named Literal

Named literal can be specified with the same scope of COBOL language specifications in debugging.

Function

The following functions can be specified in debugging.

<table>
<thead>
<tr>
<th>Function</th>
<th>ADDR Function</th>
<th>LENG Function</th>
<th>LENGTH Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADDR Function</td>
<td>FUNCTION ADDR( argument )</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LENG Function</td>
<td>FUNCTION LENG( argument )</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LENGTH Function</td>
<td>FUNCTION LENGTH( argument )</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- The argument of the ADDR function must be an identifier beyond Internal Boolean data item and object reference item.
- The argument for the LENG function and LENGTH function must be either data item, nonnumeric literal, hexadecimal nonnumeric literal or national nonnumeric literal.

D.2 Program name

The specification formats for program name are as follows.

- external program name
  - Specify program definition (external program).
- [external program name].internal program name
  - Specify program definition (internal program). It is considered that an external program name of implied program name is specified when the external program name is omitted. The internal program name referred here is the program that contains the external and internal program.
- [class-name]:method-name
  - Specify method definition (factory) or method definition (object). When a user-defined property method is specified, refer to Specification Formats of Property Method. It is considered that class-name of implied program name is specified when the class-name is omitted.
To use a program name that contains a period (.), colon (:), or other special character, specify the external name and internal name with a nonnumeric literal.

Specification Formats of Property Method

When debugging a user-defined property method, specify the method-name using the following formats.

- GET method _ GET _ property name
- SET method _ SET _ property name
Appendix E  Transition from Project Manager

This section explains how to transfer COBOL application development environment from NetCOBOL project manager for Windows (x86) to NetCOBOL Studio, and how to use the project organization converting command that is the transference support tool.

E.1 Difference Between Project Manager and NetCOBOL Studio

Project manager and NetCOBOL Studio are both development environment tools for developing COBOL applications. Project manager has provided as COBOL development environment tool in NetCOBOL for Windows(x86) from the older version of NetCOBOL for Windows. Now, more companies are using COBOL alongside of JAVA, and the NetCOBOL Studio IDE allows people to choose a more flexible development environment in terms of easily linking in multiple types of objects. And since the NetCOBOL studio is developed in open-source Eclipse, it is a very flexible and extensible development environment.

Note

NetCOBOL Studio is the only allowable development IDE for NetCOBOL for Windows(x64). You cannot use the NetCOBOL Project Manager for development in that environment.

Projects developed in different IDEs use different storage methods; thus, projects are stored in NetCOBOL Project Manager and NetCOBOL Studio with different internal formats. Particularly in NetCOBOL Studio, it is imperative to store projects in a directory structure that exactly matches that shown in the IDE workspace. The same is not true with NetCOBOL Project Manager. When you convert from NetCOBOL Project Manager to NetCOBOL Studio, you will need to handle the differences in how the individual components of the project are actually stored.

Project Manager

The Project Manager is a tool to manage the resources and the compiler options as a project.

The project manager can register two or more targets (dynamic link library (.DLL) or executable file (.EXE)) in one project file. And the place of the managed resource files can be flexibility decided.
NetCOBOL Studio

Based on Eclipse, an open-source integrated development environment, the COBOL development environment includes assist functions for COBOL program development. In NetCOBOL Studio, folders called Projects are used for creating target files, and managing necessary information such as resources and compile options. It is necessary to configure COBOL source files and target files in the project folder. In addition, it is necessary to create or import a project in the user's workspace in NetCOBOL Studio.
E.2 Project Transition Procedure

The procedure for changing a project in project manager to a project in NetCOBOL Studio is as follows.
(1) Understand the original project configuration
Organize the resources managed by the project manager project.

(2) Understand the destination project configuration
Become familiar with the resources that are managed in the NetCOBOL Studio project and how they are arranged.

(3) Back up the original project
It is recommended that you back up the conversion source project before using the project configuration conversion command.

(4) Create a shared resources project
Create a COBOL resource project on NetCOBOL Studio, and then copy the shared file that is used by multiple projects, which contains the library and descriptor, into the COBOL resource project.
One method for creating a COBOL resource project is to use the wizard provided by NetCOBOL Studio. Another method is to use the project configuration conversion command.

(5) Conversion of Project configuration

(6) Confirmation of destination project

Use the Project configuration conversion command
a. Using NetCOBOL Studio
   2. Select "File" > "New" > "COBOL Resource Project" from menu bar to start the wizard for creating a COBOL resource project.
   3. Run the wizard, and follow the instructions to create the OBOL resource project. For details, refer to "4.2.3 COBOL resource generation wizard".
   4. Copy the existing shared COBOL resource into the created COBOL resource project. For details, refer to "4.5.1 Adding the existing COBOL resource.

b. Using the Project configuration conversion command
   1. Use the "E.3.2 COBOL Resource Project Writer Module e" of the project configuration conversion command. This function executes the procedure from step 2 to step 4. For details, refer to "E.3.2 COBOL Resource Project Writer Module e".
   2. Use the import function of NetCOBOL Studio to import a COBOL resource project that has been created into any workspace.

(5) Convert the Project Organization
Create NetCOBOL Studio COBOL project in each target (exe and dll). Copy the COBOL resources into the COBOL project folder. The compiler option with the path specification changes according to the COBOL project configuration of NetCOBOL Studio.

a. Using NetCOBOL Studio
   1. Start NetCOBOL Studio
   2. Select "File" > "New" > "COBOL Project" from the menu bar to start the wizard for creating a COBOL project.
   3. Follow the wizard instructions to create a COBOL project that corresponds to the target file. For details, refer to "4.2.2 COBOL Project generation Wizard".
   4. Add the existing COBOL resource into the COBOL project. For details, refer to "4.4.1 Adding Existing COBOL Resources".
   5. Select "File" > "New" > "COBOL Solution Project" from menu bar to start the wizard for creating a COBOL solution project.
   6. Follow the wizard instructions to create a COBOL solution project that corresponds to the project manager project file. For details, refer to "4.2.1 COBOL solution generation wizard".
   7. Add the COBOL project into the COBOL solution project.
   8. Set the build options in the COBOL solution project property dialog box.
   9. Deselect the "Enable project specific setting" checkbox in the build page of every COBOL project. When building a COBOL project, build options of the COBOL solution project become effective. For details, refer to "4.3.3 Setting common options for the projects".
   10. When using a precompiler, add the precompiler build tool in the property dialog box of the COBOL solution project. For details, refer to "6.2.3 Creating a COBOL program by using the precompiler".

b. The Method of using Project Configuration Conversion Command
   a. Use the "Project Organization-converting Function" of the project configuration conversion command. This function does processing from step 2 to 10 when above-mentioned Using NetCOBOL Studio. For details, refer to "E.3.3 Usage of Project Configuration Conversion Command (PM2NS Command) ".
   Confirm the project configuration conversion command output message. If necessary, change the conversion destination project setting after starting NetCOBOL Studio.
   b. Using the Import function of NetCOBOL Studio, import the COBOL solution project and the COBOL project that has been created in any workspace.

(6) Confirm the destination project
Confirm the project organization of NetCOBOL Studio and make sure that it can be built correctly.
When the conversion destination project is converted with the project configuration conversion command, confirm the message that is output at the time of converting and correct the conversion destination project setting as necessary.
E.3 Transition of Project According to Project Configuration Conversion Command

Provide the project configuration conversion command as a transfer support tool in order to convert the project in project manager to the project in NetCOBOL Studio. In the following two functions are parts of the project configuration conversion command.

- Function that converts the project in project manager to the project in NetCOBOL Studio (project organization-converting function).
- Function that summarizes shared files such as library and create COBOL resource project (COBOL resource project created function).

E.3.1 Project Configuration Conversion Function

A NetCOBOL Studio project creates a target. As the project manager, when setting common build options for multiple targets, set the same build options for all COBOL projects, or use a COBOL solution project. For more about COBOL solution projects, refer to "4.1.1 COBOL Solution project".

The project configuration conversion command provides a function that converts the project manager project to a COBOL solution project, and converts every target to a COBOL project.

It is necessary for the following COBOL resource files to exist in the COBOL project folder in the NetCOBOL Studio COBOL project. Therefore, the project configuration conversion command copies those files into the project folder or the subfolder of the project folder.

Table E.1 COBOL resource

<table>
<thead>
<tr>
<th>File Types</th>
<th>Extent</th>
<th>Conversion Handling</th>
</tr>
</thead>
<tbody>
<tr>
<td>COBOL source file (input of compiler)</td>
<td>.CBL, .COB, .COBOL</td>
<td>When the COBOL conversion source file exists, create the project folder or the subfolder of the project folder into which to copy it. Whether or not to create a subfolder is decided by the -M option of the project configuration conversion command. For details, refer to &quot;E.3.3 Usage of Project Configuration Conversion Command (PM2NS Command)&quot;.</td>
</tr>
</tbody>
</table>
| Library file (input of compiler) | .CBL  | When it is not handled as a shared file according to the -M option of the project configuration conversion command, copy it using the following rules.  
- When it exists in the same folder as the conversion source project file, copy it into the COBOL project folder.  
- When it exists in the same folder as the conversion source COBOL source file, copy it into the same folder as the COBOL source file.  
For details of the -M option, refer to "E.3.3 Usage of Project Configuration Conversion Command (PM2NS Command)". |
<p>| Descriptor file (input of compiler) | .FFD, .PMD, .SMD, .PXD | Convert it using the same rule as the library file. |
| Repository file (input of compiler) | .REP  | Convert it using the same rule as the library file. |
| Other files                  | Any    | When it is not handled as a shared file according to the -M option of the project configuration conversion command, copy it into the COBOL project folder if it exists in the same folder as the conversion source project file. |
| Object file (input of linker) | .OBJ   | Copy it using the same rule as the other files. |
| Library file (input of linker) | .LIB   | Copy it using the same rule as the other files. |
| Include file (input of precompiler) | Any   | Copy it using the same rule as the other files. |</p>
<table>
<thead>
<tr>
<th>File Types</th>
<th>Extent</th>
<th>Conversion Handling</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object file (output of compiler)</td>
<td>.OBJ</td>
<td>When the .OBJ file with the same base-name as the COBOL source file exists in the same folder as the COBOL conversion source file, copy it into the same folder as the COBOL source file.</td>
</tr>
<tr>
<td>Debugging information file (output of compiler)</td>
<td>.SVD</td>
<td>When the .SVD file with the same base-name as the COBOL source file exists in the same folder as the COBOL conversion source file, copy it into the same folder as the COBOL source file.</td>
</tr>
<tr>
<td>SAI file (output of compiler)</td>
<td>.SAI</td>
<td>When the SAI compile options are specified, and the .SAI file with the same base-name as the COBOL source file exists in the same folder as the COBOL conversion source file, copy it into the same folder as the COBOL source file.</td>
</tr>
<tr>
<td>Target repository file (output of compiler)</td>
<td>.REP</td>
<td>When conversion source target repository file exists, copy it into the same folder as the COBOL source file.</td>
</tr>
<tr>
<td>Target file (output of linker)</td>
<td>.DLL</td>
<td>When the conversion source target file exists, copy it into the same folder.</td>
</tr>
<tr>
<td></td>
<td>.EXE</td>
<td>When the conversion source target file exists, copy it into the same folder.</td>
</tr>
<tr>
<td>MAP file (output of linker)</td>
<td>.MAP</td>
<td>When the /MAP options are specified, and /MAP file with the same base-name as the target file exists in the same folder as the conversion source target file, copy it into the COBOL project folder.</td>
</tr>
<tr>
<td>Resource script file (output of project manager)</td>
<td>.RC</td>
<td>When About COBOL97 is set, copy the .RC file with the same base-name as the target file into the COBOL project folder.</td>
</tr>
<tr>
<td>Resource file (output of project manager)</td>
<td>.RES</td>
<td>When the .RES file with the same base-name as the target file exists, copy it into the same folder as the project file of the conversion source.</td>
</tr>
</tbody>
</table>

In addition, when files with the same name exist in the conversion destination folder and the -F option is not specified, the project configuration conversion command outputs an error and stops conversion.

### E.3.2 COBOL Resource Project Writer Module

Use a project relative path specification to refer to shared files such as library in the NetCOBOL Studio COBOL resource project. When using compile options such as LIB and referring to shared files such as library by relative path in project manager, by adding shared files in the NetCOBOL Studio COBOL resource project, compile options can be specified by relative path even in the NetCOBOL Studio project.

The project configuration conversion command summarizes shared files such as library, and provides the function for creating the COBOL resource project. For details, refer to "E.3.3 Usage of Project Configuration Conversion Command (PM2NS Command)".

### E.3.3 Usage of Project Configuration Conversion Command (PM2NS Command)

Use the project configuration conversion command at the NetCOBOL command prompt.

**Project Configuration Conversion Function**

```
PM2NS [options list] [project manager project file]
```

**COBOL Resource Project creation Function**

```
PM2NS [options list] -RCOBOL-resource-project-name -1shared-files-original-folder
```
<table>
<thead>
<tr>
<th>Options</th>
<th>Specify whether or not</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-RCOBOL-resource-project-name</td>
<td>Yes</td>
<td>When creating a COBOL resource project, specify the COBOL resource project name.</td>
</tr>
<tr>
<td>-I shared-files-original-folder</td>
<td>Yes</td>
<td>-R option must be specified. When creating a COBOL resource project, specify the original shared file path.</td>
</tr>
<tr>
<td>-Ooutput-folder</td>
<td>Yes</td>
<td>Specify the project output folder. When options are omitted, the output folder is the current folder. In the output folder, create a project folder used for NetCOBOL Studio, and then create the file or copy the file from the original folder.</td>
</tr>
<tr>
<td>-F</td>
<td>Yes</td>
<td>When an error occurs at the time of converting, output a warning message and continue to convert.</td>
</tr>
<tr>
<td>-Eextent</td>
<td>Yes</td>
<td>When creating a COBOL resource project, specify the extent of shared files that are copied. When options are omitted, copy all files. When multiple extents are specified, separate them with semicolons (;).</td>
</tr>
<tr>
<td>-MINI file</td>
<td>Yes</td>
<td>Specify INI files that are described as follows.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Path that is specified in compile options and mapping of COBOL resource project</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Mapping of subfolder at the time of copying the COBOL source file</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Formats of INI files are as follows.</td>
</tr>
</tbody>
</table>
|                                 |                        | ```
|                                 |                        | [COBOLResourceProject] |
|                                 |                        | original-path=COBOL resource project name |
|                                 |                        | ... |
|                                 |                        | [COBOLSourceFile] |
|                                 |                        | original-path=relative path of destination project |
|                                 |                        | ... |
|                                 |                        | For example, when the conversion source project file is "C:\PM\PRI", the library file is "C:\PM\AICBL", the LIB compile option is "..\AICBL", by specifying the following INI files, convert LIB compile option of COBOL project of conversion destination to '..\A_CBL". |
| -S{Y|N}                         | Yes                    | Specify whether or not COBOL solution project is created at the time of converting. |
|                                 |                        | When omit options or specify Y, COBOL solution project is created. |
### E.3.4 Project Conversion Using the Project Configuration Conversion Command

Use the project configuration conversion command to convert the management resource on the file system as shown in the following figure.

In the example above, execute the following command to convert into the project used for NetCOBOL Studio management.

1. Create the COBOL resource project (CBL).
   
   ```
   PM2NS -OC:\NS -RCBL -IC:\PM\CBL
   ```

2. Create the COBOL resource project (OTHER).
   
   ```
   PM2NS -OC:\NS -Etxt -ROTHER -IC:\PM\SRC -OC:\NS
   ```

3. Convert the project.
   
   ```
   PM2NS -OC:\NS C:\PM\TEST.prj
   ```

   - TEST.CBI is compile option file. The content of compile option file is reflected in build option of COBOL solution project.

---

<table>
<thead>
<tr>
<th>Options</th>
<th>Specify whether or not</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>When N is specified, the COBOL solution project is not created. Option information that is set in the conversion source project is set in every option of the conversion destination COBOL project.</td>
</tr>
<tr>
<td>-?</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Yes: it can be specified
E.4 Notes

E.4.1 Project that Cannot Be Transferred

In project manager, the project that uses the following functions cannot be transferred to the NetCOBOL Studio project. When an attempt is made to convert using the project configuration conversion command, an error message is output and the conversion stops.

- Multiple pre-compiler (use multiple pre-compiler setting for one target)
- Multistage pre-compiler (use output of pre-compiler as input for another pre-compiler)
- JEF (applications that use JEF options)
- COM server
- CORBA
- OSIV distributed development

Use project manager for NetCOBOL for Windows (x86) as the project for the functions described above, please use project manager of NetCOBOL for Windows (x86).

E.4.2 Project Which Include Functions that are not supported in NetCOBOL Studio

When the conversion source project includes a function that is not supported in NetCOBOL Studio, the project configuration conversion command handles the non-supported function one of two ways.

- Outputs an error message and stops project conversion
  However, when the -F option is specified, after disabling the object function, it outputs a warning message and continues project conversion.
- Outputs a warning message and continues project conversion

Detailed information by function follows.

Function that outputs error message and stops project conversion

When converting a project that includes the following functions, the project configuration conversion command outputs an error message and stops conversion.

However, when specifying the -F option, after disabling the object function, it outputs a warning message and continues conversion.

- An error is generated when the following compile options are specified
  - FLAGSW(GSW), FLAGSW(GSS)
  - LIBEXT
  - FORMEXT
  - SRF(FREE)
  - library file creation (create library file as the input of module definition file)

Function that outputs warning message and continues project conversion

When converting a project that includes the following functions, the project configuration conversion command outputs a warning message and continues conversion.

- When %OUTFOLDER% is contained in the pre-compiler parameter
- When the extension of the input file for the pre-compiler is one of the following
  - cobol
  - cob
When converting a project using the project configuration conversion command, change the extension to "pco" and continue.

- When the extension of the output file for the pre-compiler is none of the following
  - cob
  - cobol
When converting a project using the project configuration conversion command, change the extension to "cob" and continue.

- When the base-name of the output file for the pre-compiler is different from the input file.
  When converting a project using the project configuration conversion command, change the base-name of the output file to the base-name of the input file and continue.

- When there are two or more kinds of extensions of the input file for the pre-compiler
  When converting a project using the project configuration conversion command, change the extension to "pco" and continue.

- When there are two or more kinds of extensions of the output file for the pre-compiler
  When converting a project using the project configuration conversion command, change the extension to "cob" and continue.

- When the following OS-dependent compile options are specified in the build management file on the Unix distributed development application
  - LALIGN
  - FILELIB
  - CODECHECK
  - KANA
When converting a project using the project configuration conversion command, the command doesn't distinguish server OS. Convert and continue using them in the raw format.

- When server link information can be obtained by a Unix distributed development application

  Server link information cannot be set as the project information. When converting a project using the project configuration conversion command, output server link information in ini file with the following format and continue.

  
  [ServerName]
  ServerAddress=***
  UserName=***
  ServerOS=***
  HostCode=***
  HostClientCodeChange=***
  PASVSendMessage=***

- When server link information cannot be obtained by a Unix distributed development application
  When converting a project using the project configuration conversion command, output only a warning message and continue.

- When multiple build management files exist by a Unix distributed development application
  When converting a project using the project configuration conversion command, output a warning message about the build management file that has not converted and continue.

- When the following link options used for Solaris are specified in the build management file of a Unix distributed development application
  - pm
  - pc
  - pi
  - Ns
When converting a project using the project configuration conversion command, the command does not distinguish server OS. Convert and continue using them in the raw format.

- When send function information is set by a Unix distributed development application
  When converting a project using the project configuration conversion command, output only a warning message and continue.

- When a reference library name is set by a Unix distributed development application
  When converting a project using the project configuration conversion command, output only a warning message and continue.
### Index

<table>
<thead>
<tr>
<th>A</th>
<th>[A]</th>
</tr>
</thead>
<tbody>
<tr>
<td>A area</td>
<td>72,75</td>
</tr>
<tr>
<td>AIMLIB</td>
<td>84</td>
</tr>
<tr>
<td>ALPHAL</td>
<td>85,150</td>
</tr>
<tr>
<td>APOST</td>
<td>164</td>
</tr>
<tr>
<td>Application format</td>
<td>62</td>
</tr>
<tr>
<td>ASCOMP5</td>
<td>150</td>
</tr>
<tr>
<td>attach debug</td>
<td>138</td>
</tr>
<tr>
<td>attached debugging</td>
<td>146</td>
</tr>
<tr>
<td>Automatic build</td>
<td>94</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>B</th>
<th>[B]</th>
</tr>
</thead>
<tbody>
<tr>
<td>B area</td>
<td>72,75</td>
</tr>
<tr>
<td>BINARY</td>
<td>151</td>
</tr>
<tr>
<td>bookmark</td>
<td>80</td>
</tr>
<tr>
<td>breakpoint</td>
<td>102</td>
</tr>
<tr>
<td>Breakpoints view</td>
<td>100</td>
</tr>
<tr>
<td>build</td>
<td>50</td>
</tr>
<tr>
<td>build mode</td>
<td>92,137</td>
</tr>
<tr>
<td>Build Tools</td>
<td>81,88</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>C</th>
<th>[C]</th>
</tr>
</thead>
<tbody>
<tr>
<td>CHECK</td>
<td>84,152</td>
</tr>
<tr>
<td>COBOL85.CBR</td>
<td>92,107</td>
</tr>
<tr>
<td>COBOL Entry Object</td>
<td>91,134</td>
</tr>
<tr>
<td>COBOL Remote</td>
<td>137</td>
</tr>
<tr>
<td>CODECHK</td>
<td>132</td>
</tr>
<tr>
<td>comment in a line</td>
<td>69</td>
</tr>
<tr>
<td>comment line</td>
<td>69,75,76</td>
</tr>
<tr>
<td>compile</td>
<td>27,81</td>
</tr>
<tr>
<td>compile options</td>
<td>83,132</td>
</tr>
<tr>
<td>CONF</td>
<td>154</td>
</tr>
<tr>
<td>Console view</td>
<td>50,81</td>
</tr>
<tr>
<td>Contents Assist</td>
<td>76</td>
</tr>
<tr>
<td>COPY</td>
<td>154</td>
</tr>
<tr>
<td>COUNT</td>
<td>155,171</td>
</tr>
<tr>
<td>C Run-time Library Name</td>
<td>91,134</td>
</tr>
<tr>
<td>CURRENCY</td>
<td>155</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>D</th>
<th>[D]</th>
</tr>
</thead>
<tbody>
<tr>
<td>debugger</td>
<td>96</td>
</tr>
<tr>
<td>Debugging information file</td>
<td>82</td>
</tr>
<tr>
<td>Debug view</td>
<td>100</td>
</tr>
<tr>
<td>Dependency view</td>
<td>27,81</td>
</tr>
<tr>
<td>Dependent Files folder</td>
<td>28,67,136,137</td>
</tr>
<tr>
<td>descriptor files</td>
<td>136</td>
</tr>
<tr>
<td>DLOAD</td>
<td>155</td>
</tr>
<tr>
<td>DUPCHAR</td>
<td>155</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>E</th>
<th>[E]</th>
</tr>
</thead>
<tbody>
<tr>
<td>entry information</td>
<td>107</td>
</tr>
<tr>
<td>environment variable information</td>
<td>107</td>
</tr>
<tr>
<td>EQUALS</td>
<td>156</td>
</tr>
<tr>
<td>Figurative constant</td>
<td>69</td>
</tr>
<tr>
<td>file constant</td>
<td>121</td>
</tr>
<tr>
<td>FILELIB</td>
<td>84</td>
</tr>
<tr>
<td>fixed format</td>
<td>72,75,76,77,169</td>
</tr>
<tr>
<td>FLAG</td>
<td>157</td>
</tr>
<tr>
<td>FLAGSW</td>
<td>157</td>
</tr>
<tr>
<td>FORMEXT</td>
<td>84</td>
</tr>
<tr>
<td>FORMLIB</td>
<td>158</td>
</tr>
<tr>
<td>ftpd</td>
<td>117</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>G</th>
<th>[G]</th>
</tr>
</thead>
<tbody>
<tr>
<td>GEN</td>
<td>84</td>
</tr>
<tr>
<td>horizontal ruler</td>
<td>72</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>H</th>
<th>[H]</th>
</tr>
</thead>
<tbody>
<tr>
<td>indicator column</td>
<td>75</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>I</th>
<th>[I]</th>
</tr>
</thead>
<tbody>
<tr>
<td>INSDBINF</td>
<td>87</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>K</th>
<th>[K]</th>
</tr>
</thead>
<tbody>
<tr>
<td>KANA</td>
<td>132</td>
</tr>
<tr>
<td>LALIGN</td>
<td>132</td>
</tr>
<tr>
<td>LANG_LVL</td>
<td>158</td>
</tr>
<tr>
<td>LIB</td>
<td>85,159</td>
</tr>
<tr>
<td>LIBEXT</td>
<td>84</td>
</tr>
<tr>
<td>library</td>
<td>28,64,85,121,136,159</td>
</tr>
<tr>
<td>Library file</td>
<td>82</td>
</tr>
<tr>
<td>Library name</td>
<td>121,130,134</td>
</tr>
<tr>
<td>LINECOUNT</td>
<td>159</td>
</tr>
<tr>
<td>line number</td>
<td>70,79</td>
</tr>
<tr>
<td>LINESIZE</td>
<td>70</td>
</tr>
<tr>
<td>link</td>
<td>27,90</td>
</tr>
<tr>
<td>Linking Files folder</td>
<td>28,39,67,136</td>
</tr>
<tr>
<td>link options</td>
<td>90,134</td>
</tr>
<tr>
<td>LIST</td>
<td>159</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>M</th>
<th>[M]</th>
</tr>
</thead>
<tbody>
<tr>
<td>main program</td>
<td>83</td>
</tr>
<tr>
<td>makefile</td>
<td>128</td>
</tr>
<tr>
<td>Manual build</td>
<td>93</td>
</tr>
<tr>
<td>MAP</td>
<td>160</td>
</tr>
<tr>
<td>MESSAGE</td>
<td>160</td>
</tr>
<tr>
<td>MODE</td>
<td>160</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>N</th>
<th>[N]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Navigator view</td>
<td>42</td>
</tr>
<tr>
<td>NCW</td>
<td>161</td>
</tr>
<tr>
<td>normal debug</td>
<td>138</td>
</tr>
<tr>
<td>normal debugging</td>
<td>138</td>
</tr>
</tbody>
</table>